Merge lp:~davewalker/ubuntu/natty/ocfs2-tools/bug_363877 into lp:ubuntu/natty/ocfs2-tools

Proposed by Dave Walker on 2011-01-19
Status: Merged
Merged at revision: 28
Proposed branch: lp:~davewalker/ubuntu/natty/ocfs2-tools/bug_363877
Merge into: lp:ubuntu/natty/ocfs2-tools
Diff against target: 47 lines (+27/-0)
3 files modified
debian/changelog (+8/-0)
debian/patches/popen2-ignore-depreciation-warn.patch (+18/-0)
debian/patches/series (+1/-0)
To merge this branch: bzr merge lp:~davewalker/ubuntu/natty/ocfs2-tools/bug_363877
Reviewer Review Type Date Requested Status
Chuck Short (community) 2011-01-19 Approve on 2011-01-19
Review via email: mp+46807@code.launchpad.net
To post a comment you must log in.
Chuck Short (zulcss) wrote :

Looks ok.

Chuck Short (zulcss) :
review: Approve

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'debian/changelog'
2--- debian/changelog 2011-01-14 12:46:49 +0000
3+++ debian/changelog 2011-01-19 19:27:54 +0000
4@@ -1,3 +1,11 @@
5+ocfs2-tools (1.6.3-1ubuntu2) natty; urgency=low
6+
7+ * debian/patches/popen2-ignore-depreciation-warn.patch: Ignore the depreciation
8+ warning that importing popen2 raises, which caused the application to exit.
9+ (LP: #655548)
10+
11+ -- Dave Walker (Daviey) <DaveWalker@ubuntu.com> Wed, 19 Jan 2011 19:23:53 +0000
12+
13 ocfs2-tools (1.6.3-1ubuntu1) natty; urgency=low
14
15 * Merge from debian unstable (LP: #703008). Remaining changes:
16
17=== added file 'debian/patches/popen2-ignore-depreciation-warn.patch'
18--- debian/patches/popen2-ignore-depreciation-warn.patch 1970-01-01 00:00:00 +0000
19+++ debian/patches/popen2-ignore-depreciation-warn.patch 2011-01-19 19:27:54 +0000
20@@ -0,0 +1,18 @@
21+Description: Ignore the depreciation warning that popen2 will raise when it is imported.
22+ Pending conversion to subprocess module.
23+Author: Dave Walker (Daviey) <DaveWalker@ubuntu.com>
24+Bug: https://launchpad.net/bugs/655548
25+--- a/ocfs2console/ocfs2console
26++++ b/ocfs2console/ocfs2console
27+@@ -13,6 +13,11 @@
28+ #
29+ import warnings
30+ warnings.filterwarnings("error")
31++
32++# Ignore the depreciation warning that popen2 will raise when it is imported.
33++# FIXME: Pending conversion to subprocess module.
34++warnings.simplefilter("ignore", DeprecationWarning)
35++
36+ try:
37+ import gtk
38+ except Exception, e:
39
40=== modified file 'debian/patches/series'
41--- debian/patches/series 2011-01-14 12:46:49 +0000
42+++ debian/patches/series 2011-01-19 19:27:54 +0000
43@@ -5,3 +5,4 @@
44 shorten-manpage-lines.patch
45 ld-no-add-needed.diff
46 ld-as-needed.diff
47+popen2-ignore-depreciation-warn.patch

Subscribers

People subscribed via source and target branches

to all changes: