lp:~darkmuggle-deactivatedaccount/ubuntu/precise/ssl-cert/fdqn.lp1004682

Created by Ben Howard on 2012-05-25 and last modified on 2012-05-28
Get this branch:
bzr branch lp:~darkmuggle-deactivatedaccount/ubuntu/precise/ssl-cert/fdqn.lp1004682
Only Ben Howard can upload to this branch. If you are Ben Howard please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Ben Howard
Status:
Development

Recent revisions

15. By Ben Howard on 2012-05-28

Allow installation of snake-oil cert on systems with hosts names longer
than 64-characters by using the short hostname. (LP: #1004682)

14. By Stefan Fritsch on 2010-12-12

Add Danish translation, thanks to Joe Hansen. Closes: #606736

13. By Stefan Fritsch on 2010-10-02

Make default key length 2048 bits. Closes: #598732

12. By Stefan Fritsch on 2010-08-08

* Update Brazilian translation. Thanks to Flamarion Jorge. Closes: #592157
* Run debconf-updatepo.
* Switch to source format 3.0.
* Bump Standards-Version (no changes).
* Remove Adam Conrad from Uploaders. Thanks for your work in the past.

11. By Colin Watson on 2009-07-07

releasing version 1.0.23ubuntu2

10. By Colin Watson on 2009-07-07

Fixed comment typo in make-ssl-cert (LP: #352157).

9. By Steve Langasek on 2009-01-16

* Drop the dependency on openssl-blacklist; by this point (roughly 12
  months from the original security vulnerability to the jaunty
  release) all users should have upgraded to a version that will clear
  their vulnerable keys out, and we need the space back on the CDs
  now.
* Change the debconf template to an error, telling the user what
  commands to run to check for the problem and advising them that they
  should have installed the security update before now.

8. By Stefan Fritsch on 2008-09-24

Update Dutch translation, thanks to Paul Gevers. Closes: #499978

7. By Mathias Gug on 2008-06-05

* Merge from debian unstable, remaining changes:
  - replace known vulnerable weak keys and certificates caused by
    Debian openssl bug (CVE-2008-0166).
    - debian/control: Depends on openssl (0.9.8g-4ubuntu3.1),
      openssl-blacklist.
    - debian/templates: add critical debconf note.
    - debian/postinst: regenerate snakeoil key and certificate on upgrade if
      vulnerable.
  - debian/control:
    - Update Maintainer field and VCS-* fields.

6. By Mathias Gug on 2008-05-14

* SECURITY UPDATE: replace known vulnerable weak keys and certificates
  caused by Debian openssl bug.
* debian/control: Depends on openssl (0.9.8g-4ubuntu3.1),
  openssl-blacklist.
* debian/templates: add critical debconf note.
* debian/postinst: regenerate snakeoil key and certificate on upgrade if
  vulnerable.
* References
  CVE-2008-0166
  http://www.ubuntu.com/usn/usn-612-4

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:ubuntu/quantal/ssl-cert
This branch contains Public information 
Everyone can see this information.

Subscribers

No subscribers.