lp:~corey.bryant/charm-helpers/fixup-git-default-repos

Created by Corey Bryant on 2016-06-15 and last modified on 2016-07-08
Get this branch:
bzr branch lp:~corey.bryant/charm-helpers/fixup-git-default-repos
Only Corey Bryant can upload to this branch. If you are Corey Bryant please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Corey Bryant
Project:
Charm Helpers
Status:
Development

Recent revisions

607. By Corey Bryant on 2016-07-08

Default check_candidates to False for os_release()

606. By Corey Bryant on 2016-07-08

Fix typo

605. By Corey Bryant on 2016-07-08

Drop kilo DFS default because upper constraints doesn't work in kilo for openstack-dashboard and glance.

604. By Corey Bryant on 2016-07-08

Add flag to disable upper constraints

By default, deploy from source now uses upper constraints to install
known good dependency versions. Upper contraints will always be used
when using openstack-origin-git default values. However when manually
specifying git repos to openstack-origin-git, users can now set
use_contraints to false, allowing various openstack dependency versions
to be tested.

603. By Corey Bryant on 2016-07-08

Merge lp:charm-helpers

602. By Corey Bryant on 2016-07-07

Merge lp:charm-helpers

601. By Corey Bryant on 2016-07-07

Get OpenStack release based on package candidate

When deploying neutron-openvswitch from source, the calls to
os_release('neutron-common') don't work. This is because the
charm doesn't apt-install OpenStack packages when deployed from
source, so get_os_codename_package() can't determine the version
based on the installed package. Additionally, neutron-openvswitch
doesn't have an openstack-origin config option because it is a
subordinate charm, causing os_release() to be unable to determine
the OpenStack release based on openstack-origin.

This patch enables os_release() and get_os_codename_package() to
determine the OpenStack release based on the the highest available
installation candidate if the package is not installed.

600. By Corey Bryant on 2016-07-07

Add home_dir parameter to adduser()

599. By Marco Ceppi <marco@T430> on 2016-07-06

flake8 fixes

598. By Marco Ceppi <marco@T430> on 2016-07-06

version bump

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:charm-helpers
This branch contains Public information 
Everyone can see this information.

Subscribers