lp:~compiz-team/compiz/compiz.bump_VERSION_to_0.9.10.0

Created by Sam Spilsbury and last modified
Get this branch:
bzr branch lp:~compiz-team/compiz/compiz.bump_VERSION_to_0.9.10.0
Members of Compiz Maintainers can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Compiz Maintainers
Project:
Compiz
Status:
Merged

Recent revisions

3670. By Sam Spilsbury

s/raring/UNRELEASED/

3669. By Sam Spilsbury

Bump version to 0.9.10.0

3668. By Sam Spilsbury

Bump VERSION to 0.9.10

3667. By MC Return

*Screenshot, xml:

Better plugin summary.
Added option to disable the drawing of the screenshot
selection indicator.
Added options to change color and opacity of the outline
and the inside of the rectangle indicator, default colors
have not been changed.
Other minor improvements.

*Screenshot, code:

Introduced the new variable bool selectionSizeChanged,
which is true if the size of the selection has changed.

We just want to draw the screenshot selection box, if
we are grabbed, the size has changed and the CCSM
option to draw it is enabled.
Do not render anything if indicator is disabled.

Indicator colors are now configurable.
Increased indicator box outline line width to 2.0.

Only damage the full screen once, if the grab gets
terminated, during grab just damage the region painted,
which is the screenshot selection box (LP: #1172234).

*SCreenshot, cleanup:

Minor cleanup in the rendering code.
Removed redundant #ifndef USE_GLES compiler option,
GLES can cope with enabling and disabling GL_BLEND.
Use prefix- instead of postfix increments.
Declaration and assignment of local variables in one line.
Reduced the scope of the variables x1, y1, x2 and y2.
Replaced magic number 65535.0f with const float MaxUShortFloat =
std::numeric_limits <unsigned short>::max ();.
Indentation fixes.
C++ style for comments, added comments.

(LP: #1169353, LP: #1172234). Fixes: https://bugs.launchpad.net/bugs/1169353, https://bugs.launchpad.net/bugs/1172234.

Approved by PS Jenkins bot, Sam Spilsbury.

3666. By MC Return

*Workspacenames:

New Feature:
Implemented option to adjust vertical offset for
top and bottom of screen workspacename placement.
Set the default offset to 50 pixel.

Cleanup:
Added brackets to for loop.
Use prefix increments.
Indentation fixes.
Added and removed newlines for better readability.
Added comment.
Removed TEXT_BORDER constant.
Improved tooltips.

(LP: #1172063). Fixes: https://bugs.launchpad.net/bugs/1172063.

Approved by PS Jenkins bot, Sam Spilsbury.

3665. By MC Return

*Showmouse code cleanup:

Assignment and declaration of local variables in one line.
Removed redundant brackets.
Fixed indentation.
Removed and added newlines for better readability.

*Showmouse code changes:

Removed these redundant gl calls:
glEnable (GL_TEXTURE_2D);
glDisable (GL_TEXTURE_2D);

(partially fixes LP: #1051290 and LP: #1051295).

Approved by PS Jenkins bot, Sam Spilsbury.

3664. By MC Return

*Cube Gears:

Added glDepthMask (GL_TRUE); and glDepthFunc (GL_LESS); to void
GearsScreen::cubePaintInside (...) to fix the culling on multimonitor
systems (green gear was always rendered in front).

Also fixed indentation and removed some redundant newlines.

(LP: #1168919). Fixes: https://bugs.launchpad.net/bugs/1168919.

Approved by PS Jenkins bot, Sam Spilsbury.

3663. By MC Return

*Grid code:

Simplified bool GridScreen::restoreWindow (...):
If Grid has not touched the window we return false and let core do the
dirty work.
(Thanks go to Sam Spilsbury for suggesting this solution.)

*Grid xml:

Improved the CCSM Grid put_restore_key tooltip.

(LP: #1116538). Fixes: https://bugs.launchpad.net/bugs/1116538.

Approved by PS Jenkins bot, Sam Spilsbury.

3662. By MC Return

Composite code cleanup:

Merged a few if-if condition checks.
Declaration and assignment of local variables in one line.
Removed redundant brackets.
Added and removed newlines to improve readability.
Fixed indentation.

Approved by PS Jenkins bot, Sam Spilsbury.

3661. By MC Return

Shift Switcher code cleanup:

Merged a few if-if condition checks.
Declaration and assignment of local variables in one line.
Removed redundant brackets.
Added and removed newlines to improve readability.
Fixed indentation.

Approved by PS Jenkins bot, Sam Spilsbury.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:compiz/0.9.10
This branch contains Public information 
Everyone can see this information.