lp:~clint-fewbar/+junk/cyrus-sasl2-builddeb

Created by Clint Byrum on 2012-02-13 and last modified on 2012-02-13
Get this branch:
bzr branch lp:~clint-fewbar/+junk/cyrus-sasl2-builddeb
Only Clint Byrum can upload to this branch. If you are Clint Byrum please log in for upload directions.

Related bugs

Related blueprints

Branch information

Owner:
Clint Byrum
Status:
Development

Recent revisions

48. By Clint Byrum on 2011-11-23

Rebuild for libmysqlclient transition.

47. By Steve Langasek on 2011-08-15

releasing version 2.1.24~rc1.dfsg1+cvs2011-05-23-4ubuntu2

46. By Steve Langasek on 2011-08-15

run update-maintainer

45. By Steve Langasek on 2011-08-15

Build for multiarch. LP: #826601.

43. By Ondřej Surý on 2011-06-08

Fix yet another upstream segfault breakage in GSSAPI from CVS
(Closes: #629589)

42. By Ondřej Surý on 2011-05-27

* Upload to unstable
* One more AC_CACHE_VAL without _cv_ fix
* Update Vcs-* links
* Add gs2 and scram modules to libsasl2-modules-gssapi-mit
  (Closes: #628067)
* Revert "Change gbp.conf for experimental branch"
* Add lintian-override for libsasl2-modules-gssapi-mit: possible-gpl-
  code-linked-with-openssl

41. By Ondřej Surý on 2011-05-25

[ Roberto C. Sanchez ]
* libsasl2-2.README.Debian: document that SASL logs debug messages by
  default, and how change/stop it (Closes: #590598)
* Bump Standards-Version to 3.9.2 (no changes)
* Remove Build-Depends on libopie-dev, which was removed
  (Closes: #622221)

[ Ondřej Surý ]
* Patch to support newer Berkeley DB (Closes: #621437)
* Remove /etc/sasldb2 in prerm remove if empty (Closes: #618885)
* Improve Berkeley DB upgrade code to note the used version in
  berkeley_db.active file and compare it with current version
* Convert debian/rules to debhelper7
* Update Vcs-* and Homepage fields
* Fix autoreconf by adding some recommended options to configure.in
  and Makefile.am
* Imported Upstream version 2.1.24~rc1.dfsg1
* Update patches to new release
* Update repack.sh
* Build against sqlite3 since upstream has a support for it
  (Closes: #444799)
* Fix FTBFS in LDAP plugin
* Don't use .la files to open plugins, just scan .so
* Set configdir to /etc/sasl2:/etc/sasl:/usr/lib/sasl2
  (Closes: #465569)
* Stop shipping .la and .a files for all modules (Closes: #516833)
* sasl2-bin can depend on generic db-util package now
* Add myself to uploaders
* Removed hardcoded -R option when searching for sqlite libraries
* Fix Sqlite3 FTBFS due missing link libraries in plugins/

40. By Colin Watson on 2011-05-25

Rebuild for OpenSSL 1.0.0.

39. By Roberto C. Sanchez <email address hidden> on 2011-03-16

* Eliminate getsubopt conflict when building with glibc 2.2, thanks to
  Colin Watson for the patch (Closes: #588528)
* Convert package from using dpatch to using quilt
* debian/sasl2-bin.saslauthd.init: Properly handle $(OPTIONS) missing from
  defaults file (Closes: #515534)
* Bump Standards-Version to 3.9.1 (no changes)
* cyrus-sasl2-dbg: Demote dependency on cyrus-sasl2-{mit,heimdal}-dbg to
  a recommendation (Closes: #607558)
* Enable hardening features (Closes: #542725)
* Fix FTBFS, add $(SASL_DB_LIB) as dependency to libsasldb, and use it.
  Thanks to Matthias Klose for the patch (Closes: #609237)
* Drop gratuitous dependency on krb5support (Closes: #528238)
* Ship docs on testing with sasl-sample-{client,server} (Closes: #516542)
* Allow getting saslauthd status with '/etc/init.d/saslauthd status'.
  Thanks to Raoul Bhatia for the patch (Closes: #589181)
* Fix documentation on saslauthd runtime directory perms (Closes: #528554)
* Add Danish translation, thanks to Joe Dalton. (Closes: #585553)
* Change to machine readable copyright file (Closes: 470948)
* Improve documentation on location of socket directory based on whether
  Postfix runs inside or outside a chroot, thanks to Walter Rohrer for the
  suggestion. (Closes: #528553)
* Start shipping gen-auth (Closes: #459624)
* Switch to dpkg-source 3.0 (quilt) format.
* Drop Conflicts/Replaces for pre-Lenny and pre-Sarge versions of packages

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
This branch contains Public information 
Everyone can see this information.

Subscribers