lp:~certify-web-dev/twisted/certify-staging

Created by Marc Tardif on 2010-05-20 and last modified on 2012-03-02
Get this branch:
bzr branch lp:~certify-web-dev/twisted/certify-staging
Members of certify-web Developers can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
certify-web Developers
Project:
Twisted
Status:
Mature

Recent revisions

35. By Marc Tardif on 2010-05-20

Added twisted-web.

34. By Matthias Klose on 2010-04-14

Remove all plugin cache files before rebuilding the cahce files
for the installed python versions. LP: #558443.

33. By Matthias Klose on 2010-03-30

Add a trigger `twisted-plugins-cache' to rebuild the plugins cache.

32. By Registry Administrators on 2010-03-09

* Include changes from 9.0.0-2 which got skipped
* python-twisted depends on version >= 10.0 of other packages

31. By Matthias Klose on 2010-01-02

* python-twisted: Depend on the python-twisted-* 9.0 packages.
* python-twisted: Depend on python-zope.interface only. Closes: #557781.

30. By Matthias Klose on 2009-08-25

* Depend on the standalone python-zope.interface{,-dbg} packages.
  Closes: #543132, #542932.
* Remove plugins directory on purge. Closes: #527897.
* Fix some lintian warnings.

29. By Matthias Klose on 2009-04-18

* python-twisted-core: Regenerate the plugin cache as the last action
  in the postinst. Closes: #521663. LP: #361865.
* Avoid md5/sha1 deprecation warnings. LP: #344782.

28. By Matthias Klose on 2009-02-21

* Tigthen dependencies to 8.2.
* Build-depend on python-central (>= 0.6.11).

27. By Matthias Klose on 2008-10-10

* Move the cache update from python-twisted into python-twisted-core.
  Closes: #500942.

  Plugins should update the cache on package install (postinst) and
  removal (postrm remove) by updating the cache. See the postinst
  script of python-twisted-core how to update the cache.

* Fix PortableGtkReactor (now able to run trial test suite with the gtk2
  reactor). Closes: #499311.
* Don't install twisted/test/generator_failure_tests.py, syntax errors
  with python2.4. Closes: #492830.
* Fix manhole to work with python-gtk2 (>= 2.10). Closes: #469105.
* mktap(1) description of options fixed in an earlier version.
  Closes: #278194.
* mktap news fixed in an earlier version. Closes: #278196.
* Fix build failure on GNU/kFreeBSD (Petr Salinger). Closes: #490770.

26. By Matthias Klose on 2008-10-09

* Move the cache update from python-twisted into python-twisted-core.
* Do not include twisted/plugins/dropin.cache, but generate it on
  configure, remove it on package removal. Closes: #500942.

  Plugins should update the cache on package install (postinst) and
  removal (postrm remove) by updating the cache. See the postinst
  script of python-twisted-core how to update the cache.

* Fix PortableGtkReactor (now able to run trial test suite with the gtk2
  reactor). Closes: #499311.
* Don't install twisted/test/generator_failure_tests.py, syntax errors
  with python2.4. Closes: #492830.
* Fix manhole to work with python-gtk2 (>= 2.10). Closes: #469105.
* mktap(1) description of options fixed in an earlier version.
  Closes: #278194.
* mktap news fixed in an earlier version. Closes: #278196.
* Fix build failure on GNU/kFreeBSD (Petr Salinger). Closes: #490770.

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:twisted
This branch contains Public information 
Everyone can see this information.

Subscribers