Code review comment for lp:~canonical-platform-qa/ubuntu-community-testing/improved-reporting

Brendan Donegan (brendan-donegan) wrote :

Technically speaking the part of a provider name before the : is just an FQDN, so it doesn't really make much sense on its own. Therefore I'd have the top level of reporting be the full name of the provider, breaking down into individual testplans/whitelists. For example for clock app:
-> clock-app-alarm
-> clock-app-setting
-> clock-app-stopwatch
-> clock-app-worldcity

Also the testsuite overview seems to be mixing job plainbox execution unit (pxu) file names with test plan or whitelist file names. I'd have to look at the raw data to see what the reason for this is though.

review: Needs Fixing

« Back to merge proposal