lp:~aptdaemon-developers/sessioninstaller/multiarch

Created by Sebastian Heinlein on 2012-03-28 and last modified on 2012-03-28
Get this branch:
bzr branch lp:~aptdaemon-developers/sessioninstaller/multiarch
Members of Aptdaemon Developers can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Aptdaemon Developers
Project:
Session Installer
Status:
Merged

Recent revisions

128. By Sebastian Heinlein on 2012-03-28

Fix detecting black listed restricted packages of an alternative architecure

The restricted detection is moved to a single function. The architecture snippet
gets stripped from the package name and also the restricted repository is
considered restrcited.

127. By Sebastian Heinlein on 2012-03-28

Fix reporting all packages as restricted in the confirmation dialog if only
one of them is restricted at all

126. By Sebastian Heinlein on 2012-03-28

Show nicer package names for packages of alternative architectures

The architecture gets stripped from the package name and re-appended in
brackets, e.g. gstreamer0.10-ffmpeg:i386 -> gstreamer0.10-ffmpeg (i386).
Furthermore reuse the application name from the app-install-data database.

125. By Sebastian Heinlein on 2012-03-28

Fix scoring of codecs: recommend the best providers for all supported architectures

124. By Sebastian Heinlein on 2012-03-28

Don't show codec packages for not used architectures

Unfortunately the architecture isn't part of the request. So we
have to detect for which architectuers gstreamer has been installed
on the system, to avoid showing codecs for not used but enabeled
architecures, see LP #899001

123. By Martin Pitt on 2011-11-14

sessioninstaller/gstinstaller.py: Drop unnecessary gst import

122. By Martin Pitt on 2011-11-14

Port to PyGI and GTK3

121. By Sebastian Heinlein on 2011-10-28

Merge typo fix in the man page, thanks Luca!

120. By Sebastian Heinlein on 2011-05-31

Fix a typo. Thanks to Aviv Sapire.

119. By Michael Vogt on 2011-03-29

sessioninstaller/core.py: do not set stock_id to "0" this causes a TypeError (LP: #713984)

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:sessioninstaller
This branch contains Public information 
Everyone can see this information.