lp:~aptdaemon-developers/aptdaemon/high-level-privilege

Created by Sebastian Heinlein on 2010-08-22 and last modified on 2010-08-22
Get this branch:
bzr branch lp:~aptdaemon-developers/aptdaemon/high-level-privilege
Members of Aptdaemon Developers can upload to this branch. Log in for directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Aptdaemon Developers
Project:
Aptdaemon
Status:
Development

Recent revisions

457. By Sebastian Heinlein on 2010-08-22

Check if the user can obtain the high level privilege install-or-remove in
CommitPackages before falling back to the single low level privileges.

456. By Sebastian Heinlein on 2010-08-22

Add a new high level privilege install-or-remove

455. By Sebastian Heinlein on 2010-08-22

Make the AuthorizationFailed error an inheritance of NotAuthorizedError

454. By Sebastian Heinlein on 2010-08-22

Raise an AuthorizationFailed exception in a non-interactive check if the
user could obtain the privilege in interactive-mode (is_challenged)

453. By Sebastian Heinlein on 2010-08-21

Workaround a bug in optparser which doesn't handle unicode/str correctly, see http://bugs.python.org/issue4391

Fixes LP:#613147

452. By Sebastian Heinlein on 2010-08-21

Unset LC_ALL to get translations from APT, fixes LP:#620978

451. By Sebastian Heinlein on 2010-08-21

Cherry pick: fix translation of console client

450. By Sebastian Heinlein on 2010-08-20

Cherry pick language fixes

449. By Michael Vogt on 2010-08-05

aptdaemon/client.py: make sure we have a _signal_matcher before we delete it

448. By Michael Vogt on 2010-08-05

aptdaemon/worker.py: only check _cache if its not None (it will be None for transactions like add-vendor-key-from-keyserver

Branch metadata

Branch format:
Branch format 6
Repository format:
Bazaar pack repository format 1 (needs bzr 0.92)
This branch contains Public information 
Everyone can see this information.