Merge lp:~andreserl/maas/packaging.trusty.lp1300507 into lp:~maas-maintainers/maas/packaging.trusty

Proposed by Andres Rodriguez on 2014-08-19
Status: Merged
Approved by: Andres Rodriguez on 2014-08-19
Approved revision: 291
Merged at revision: 291
Proposed branch: lp:~andreserl/maas/packaging.trusty.lp1300507
Merge into: lp:~maas-maintainers/maas/packaging.trusty
Diff against target: 45 lines (+11/-6)
2 files modified
debian/changelog (+5/-0)
debian/maas-region-controller.postinst (+6/-6)
To merge this branch: bzr merge lp:~andreserl/maas/packaging.trusty.lp1300507
Reviewer Review Type Date Requested Status
Andres Rodriguez (community) Approve on 2014-08-19
Review via email: mp+231419@code.launchpad.net

Commit message

debian/maas-region-controller.postinst: Do not change celery's rabbitmq
password on upgrade to not lock remote Cluster Controllers if upgrading
from 1.5+. (LP: #1300507)

To post a comment you must log in.
Andres Rodriguez (andreserl) wrote :

Backporting and making sure this only happens on upgrade, not on a clean install.

review: Approve

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
1=== modified file 'debian/changelog'
2--- debian/changelog 2014-08-19 12:40:09 +0000
3+++ debian/changelog 2014-08-19 16:47:23 +0000
4@@ -24,6 +24,11 @@
5 * debian/extras/99-maas-sudoers: Add permissions for tgt-admin and
6 uec2roottar
7
8+ [ Andres Rodriguez ]
9+ * debian/maas-region-controller.postinst: Do not change celery's rabbitmq
10+ password on upgrade to not lock remote Cluster Controllers if upgrading
11+ from 1.5+. (LP: #1300507)
12+
13 -- Julian Edwards <julian.edwards@canonical.com> Tue, 19 Aug 2014 22:34:30 +1000
14
15 maas (1.5.3+bzr2287-0ubuntu1) trusty; urgency=medium
16
17=== modified file 'debian/maas-region-controller.postinst'
18--- debian/maas-region-controller.postinst 2014-08-19 02:59:49 +0000
19+++ debian/maas-region-controller.postinst 2014-08-19 16:47:23 +0000
20@@ -219,10 +219,8 @@
21 ########## Configure worker rabbitmq config ###########
22 #########################################################
23
24- if dpkg --compare-versions "$2" lt 1.5+bzr2252-0ubuntu1; then
25- # Handle celery/rabbitmq publishing
26- configure_maas_workers_rabbitmq_user "$ipaddr"
27- fi
28+ # Handle celery/rabbitmq publishing
29+ configure_maas_workers_rabbitmq_user "$ipaddr"
30
31 #########################################################
32 ################ Configure Database ###################
33@@ -274,8 +272,10 @@
34 # make sure rabbitmq is running
35 restart_rabbitmq
36 configure_maas_txlongpoll_rabbitmq_user
37- # Handle celery/rabbitmq publishing
38- configure_maas_workers_rabbitmq_user "$ipaddr"
39+ if dpkg --compare-versions "$2" lt 1.5+bzr2252-0ubuntu1; then
40+ # Handle celery/rabbitmq publishing
41+ configure_maas_workers_rabbitmq_user "$ipaddr"
42+ fi
43 # handle database upgrade
44 if [ -f /etc/dbconfig-common/maas-region-controller.conf ]; then
45 # source dbconfig-common db config for maas-region-controller

Subscribers

People subscribed via source and target branches