~alfonsosanchezbeato/snappy-hwe-snaps/+git/wifi-ap:master

Last commit made on 2019-06-03
Get this branch:
git clone -b master https://git.launchpad.net/~alfonsosanchezbeato/snappy-hwe-snaps/+git/wifi-ap
Only Alfonso Sanchez-Beato can upload to this branch. If you are Alfonso Sanchez-Beato please log in for upload directions.

Branch information

Recent commits

c2eb8a0... by Alfonso Sanchez-Beato on 2019-06-03

No-change rebuild to address USN-3999-1

CVEs in the USN (https://usn.ubuntu.com/3999-1/):
* CVE-2018-10844
* CVE-2018-10845
* CVE-2018-10846
* CVE-2019-3829
* CVE-2019-3836

19aac51... by System Enablement CI Bot <email address hidden> on 2019-05-29

Open development for 25-dev

d68652e... by System Enablement CI Bot <email address hidden> on 2019-05-29

Bump version to 24

7e5570a... by System Enablement CI Bot <email address hidden> on 2019-05-29

Update ChangeLog for 24

82b7643... by System Enablement CI Bot <email address hidden> on 2019-05-28

Open development for 24-dev

067cd97... by System Enablement CI Bot <email address hidden> on 2019-05-28

Bump version to 23

9b2d994... by System Enablement CI Bot <email address hidden> on 2019-05-28

Update ChangeLog for 23

6f3612a... by System Enablement CI Bot <email address hidden> on 2019-05-28

Merge remote tracking branch fix-usns

Merge-Proposal: https://code.launchpad.net/~alfonsosanchezbeato/snappy-hwe-snaps/+git/wifi-ap/+merge/367408

Author: Alfonso Sanchez-Beato <email address hidden>

Update to hostapd 2.8 to fix vulnerabilities

The fixed vulnerabilities are USN-3944-1 (fixed in 2.8), USN-3956-1 (Bind
vulnerability, fixed by rebuilding), USN-3009-1 (dnsmasq vulnerability,
fixed by rebuilding), and USN-3969-1 (fixed in 2.8).

1b621c3... by Alfonso Sanchez-Beato on 2019-05-14

test: do not try to revert core18

We can have core and core18 in the system under test due to installation
of snaps that depend on core18, and we cannot remove it. So avoid
reverting any of them.

232b2bf... by Alfonso Sanchez-Beato on 2019-05-14

Update to hostapd 2.8 to fix vulnerabilities

The fixed vulnerabilities are USN-3944-1 (fixed in 2.8), USN-3956-1 (Bind
vulnerability, fixed by rebuilding), USN-3009-1 (dnsmasq vulnerability,
fixed by rebuilding), and USN-3969-1 (fixed in 2.8).