lp:~albertomilone/jockey/pkg-version-ubuntu

Created by Alberto Milone on 2010-04-11 and last modified on 2010-04-11
Get this branch:
bzr branch lp:~albertomilone/jockey/pkg-version-ubuntu
Only Alberto Milone can upload to this branch. If you are Alberto Milone please log in for upload directions.

Branch merges

Related bugs

Related blueprints

Branch information

Owner:
Alberto Milone
Project:
Jockey
Status:
Mature

Recent revisions

415. By Alberto Milone on 2010-04-11

* jockey/oslib.py:
  - Implement the package_version() method so that we
    can get the version of a package from apt.
* data/handlers/nvidia.py:
  - Implement the pkg_version() method so that we can
    show the version of the driver instead of being
    limited to the information carried by the version
    attribute. For example, in the case of the
    nvidia-current package, self.version is an
    unlocalised and therefore rather confusing string
    i.e. current when it should really be something
    like 195 (LP: #543176).

414. By Alberto Milone on 2010-04-11

Merge from trunk

413. By Alberto Milone on 2010-04-10

* data/handlers/nvidia.py:
  - Do not check that the module is loaded in enabled(), as this is
    what we should do in used(). Just make sure that the module and
    its alias are not blacklisted. This prevents Jockey from claiming
    that the installation of nvidia driver failed when when it
    didn't (LP: #552653).

412. By Alberto Milone on 2010-03-30

Release 0.5.8-0ubuntu6

411. By Alberto Milone on 2010-03-30

Merge from lp:jockey

410. By Alberto Milone on 2010-03-30

* data/handlers/fglrx.py:
  - Re-enable the fglrx handler and make it use the alternatives system
    (LP: #496225).
* data/handlers/nvidia.py:
  - See if the module alias is loaded and then check what module it
    corresponds to in order to see if it's really enabled (LP: #547066).
    This involved overriding the enabled() and the used() methods.

409. By Martin Pitt on 2010-03-26

releasing version 0.5.8-0ubuntu5

408. By Martin Pitt on 2010-03-26

debian/control: Revert the python-distutils-extra build dependency bump,
not necessary any more with the fix above.

407. By Martin Pitt on 2010-03-26

Merge fixed KDE .ui file from trunk, thanks Jonathan Thomas! This fixes
the crash on jockey-kde startup.

406. By Martin Pitt on 2010-03-26

releasing version 0.5.8-0ubuntu4

Branch metadata

Branch format:
Branch format 7
Repository format:
Bazaar repository format 2a (needs bzr 1.16 or later)
Stacked on:
lp:jockey
This branch contains Public information 
Everyone can see this information.

Subscribers