Code review comment for lp:~alan-griffiths/mir/add-mir_surface_spec_attach

Revision history for this message
Alan Griffiths (alan-griffiths) wrote :

> I considered 'MirPlacement' but decided not to suggest it because
> 'MirPlacement' is too general. Once we have a "MirPlacement" that's just for
> surfaces then if something else needs a placement enum the naming will look
> inconsistent: MirPlacement, MirSomethingElsePlacement
> Please mention it's for placing surfaces in the least, and ideally edges too.
> So something like 'MirSurfacePlacementEdge'.

I should have been more explicit in my intent: I aim to provide a route to add further enum values unrelated to "edge attachment". (For an example, see the referenced GDK discussion which has other options such as "gravity".) For that reason I don't want to make the name specific to "Edge".

I don't believe we need to specify placement strategies for anything other than surfaces. (Buffer streams are positioned directly.)

To be fully explicit in our naming we could say MirSurfacePlacementStrategy, but that seems a bit long. I feel MirPlacement is enough.

> I know the team often belittles the importance of naming, but this is a
> permanent decision about the clarity of our communication to developers.

We agree about the importance of good names. Here are some options:


Votes (or other options) please!

review: Needs Information

« Back to merge proposal