Code review comment for lp:~alan-griffiths/mir/add-mir_surface_spec_attach

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

(1) Function naming getting better. My confusion stems from the function name syntax:
The reader assumes that 'place' is what you're doing with a 'spec'. Actually 'place' is what we're doing with the surface. So that's a source of confusion we're never really going to avoid with the current prefix.

(2) Enum name needs fixing. It sounds like an action rather than an attribute:
  enum MirPlaceSurface
That should be something like 'MirSurfacePlacement'.

review: Needs Fixing

« Back to merge proposal