Code review comment for lp:~ack/landscape-client/swift-usage

Revision history for this message
Free Ekanayaka (free.ekanayaka) wrote :

Quick comment:

+SWIFT = Message("swift", {
+ "usages": List(Tuple(Int(), Unicode(), Int(), Int(), Int()))})
+

I'd rename this to SWIFT_USAGE/"swift-usage" for consistency with the Ceph one. Also, although I see it's used in other spots, I believe the plural "usages" is not quite correct in this context. A better term would be probably "data-points", but I see it's not the current pattern.

Please add a comment explaining the format of the message too, e.g.:

# Report Swift node usage in the last time interval.
SWIFT = Message("swift", {
    # List of data points of the form (timestamp, device, size, avail, used)
    "usages": List(Tuple(Int(), Unicode(), Int(), Int(), Int()))})

« Back to merge proposal