Code review comment for lp:~ace17/bzr-git/dulwich

Sergei Golubchik (sergii) wrote :

This patch isn't quite correct. The old code in dulwich was

 def get_graph_walker(self, heads):
     return ObjectStoreGraphWalker(heads, lambda sha: self[sha].parents)

But this patch does

- graph_walker = store.get_graph_walker(list)
+ graph_walker = ObjectStoreGraphWalker(heads, list)

The correct replacement is

 graph_walker = ObjectStoreGraphWalker(
         [store._lookup_revision_sha1(head) for head in heads],
         lambda sha: store[sha].parents)

« Back to merge proposal