Branches for Saucy

Name Status Last Modified Last Commit
lp:ubuntu/saucy/maas bug 2 Mature 2013-10-14 13:10:21 UTC 2013-10-14
41. * debian/patches: - 99_fix_wsgi_app...

Author: Andres Rodriguez
Revision Date: 2013-10-14 13:10:21 UTC

* debian/patches:
  - 99_fix_wsgi_app_group_lp1237463.patch: Import wsgi into the %{GLOBAL}
    application group, to avoid bson encoding issues. (LP: #1237463)
  - 99_ephemeral_backward_compat_lp1238376.patch: Maintain import_ephemerals
    config compatibility to allow maas-import-ephemerals to inherit the
    config used for maas-import-pxe-files, otherwise it will always download
    all releases even when set to a particular one. (LP: #1238376)
  - 99_split_config_arch_rel_lp1238681.patch: arches/releases are a list
    of characters that need to be split. (LP: #1238681)
  - 99_handle_ephemeral_archs_correctly.patch: Allow maas-import-ephemerals
    to use arches correctly coming from the legacy config (LP: #1240215)

lp:ubuntu/saucy-security/maas bug 2 Mature 2014-02-13 19:33:06 UTC 2014-02-13
42. * SECURITY UPDATE: incorrect Content-...

Author: Seth Arnold
Revision Date: 2014-02-11 12:16:40 UTC

* SECURITY UPDATE: incorrect Content-type header allowed cross-site
  scripting vulnerability if an unknown API was used. (LP: #1251336)
  - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
    browsers to not render error messages as HTML.
  - CVE-2013-1070
* SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
  password. (LP: #1254034)
  - debian/maas-region-controller-min.postinst: chown and chmod
    /etc/maas/txlongpoll.yaml with correct permissions
  - CVE-2013-1069

lp:ubuntu/saucy-updates/maas 2 Mature 2014-02-11 12:16:40 UTC 2014-02-11
42. * SECURITY UPDATE: incorrect Content-...

Author: Seth Arnold
Revision Date: 2014-02-11 12:16:40 UTC

* SECURITY UPDATE: incorrect Content-type header allowed cross-site
  scripting vulnerability if an unknown API was used. (LP: #1251336)
  - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
    browsers to not render error messages as HTML.
  - CVE-2013-1070
* SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
  password. (LP: #1254034)
  - debian/maas-region-controller-min.postinst: chown and chmod
    /etc/maas/txlongpoll.yaml with correct permissions
  - CVE-2013-1069

lp:~smoser/ubuntu/saucy/maas/lp1287772 bug 1 Development 2014-03-04 18:19:33 UTC 2014-03-04
43. enable support for deploying trusty (...

Author: Scott Moser
Revision Date: 2014-03-04 18:09:53 UTC

enable support for deploying trusty (LP: #1287772).
User must modify config to import trusty, but after that is done
they will be able to deploy.

lp:ubuntu/saucy-proposed/maas bug 1 Development 2013-10-24 21:34:12 UTC 2013-10-24
42. * debian/patches: - 99_fix_dhcp_tem...

Author: Andres Rodriguez
Revision Date: 2013-10-24 13:35:00 UTC

* debian/patches:
  - 99_fix_dhcp_template_lp1240972.patch: Do not prevent the MAAS DHCP
    template from adding ignore-client-uids on precise, which causes
    issues with DNS for MAAS in the Cloud Archive. (LP: #1240972)
  - 99_arm_generic_kernel_lp1166994.patch: Re-enable armhf generic as it
    is supported starting from raring. (LP: #1166994)

15 of 5 results