Branches for Hardy

Name Status Last Modified Last Commit
lp:ubuntu/hardy/pam 2 Mature 2009-12-19 05:57:02 UTC 2009-12-19
27. debian/local/common-{auth,password}, ...

Author: Steve Langasek
Revision Date: 2008-04-08 18:21:40 UTC

debian/local/common-{auth,password}, debian/libpam-runtime.postinst:
Add pam_smbpass as an optional module in the stack, to keep NTLM
passwords (for filesharing) in sync with the main system passwords on a
best-effort basis. LP: #208419.

lp:ubuntu/hardy-security/pam bug 2 Mature 2011-10-24 19:24:23 UTC 2011-10-24
30. * SECURITY UPDATE: possible code exec...

Author: Marc Deslauriers
Revision Date: 2011-10-18 10:31:55 UTC

* SECURITY UPDATE: possible code execution via incorrect environment file
  parsing (LP: #874469)
  - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
    whitespace when parsing environment file in
    Linux-PAM/modules/pam_env/pam_env.c.
  - CVE-2011-3148
* SECURITY UPDATE: denial of service via overflowed environment variable
  expansion (LP: #874565)
  - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
    with PAM_BUF_ERR in Linux-PAM/modules/pam_env/pam_env.c.
  - CVE-2011-3149

lp:ubuntu/hardy-proposed/pam bug 1 Development 2009-06-27 05:18:11 UTC 2009-06-27
28. * debian/patches-applied/ubuntu-no-er...

Author: Steve Langasek
Revision Date: 2008-04-22 18:53:37 UTC

* debian/patches-applied/ubuntu-no-error-if-missingok: add a new, magic
  module option 'missingok' which will suppress logging of errors by
  libpam if the module is not found.
* debian/local/common-{auth,password}, debian/libpam-runtime.postinst:
  Use the new 'missingok' option by default for pam_smbpass, to
  correct the problem of very loud logging introduced in the previous
  upload when libpam-smbpass is not installed. LP: #216990.

lp:ubuntu/hardy-updates/pam 1 Development 2011-10-18 10:31:55 UTC 2011-10-18
30. * SECURITY UPDATE: possible code exec...

Author: Marc Deslauriers
Revision Date: 2011-10-18 10:31:55 UTC

* SECURITY UPDATE: possible code execution via incorrect environment file
  parsing (LP: #874469)
  - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
    whitespace when parsing environment file in
    Linux-PAM/modules/pam_env/pam_env.c.
  - CVE-2011-3148
* SECURITY UPDATE: denial of service via overflowed environment variable
  expansion (LP: #874565)
  - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
    with PAM_BUF_ERR in Linux-PAM/modules/pam_env/pam_env.c.
  - CVE-2011-3149

14 of 4 results