View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/vim
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
ubuntu/jaunty 2009-03-19 16:05:06 UTC 2009-03-19
Import patches-unapplied version 2:7.2.079-1ubuntu5 to ubuntu/jaunty

Author: Colin Watson
Author Date: 2009-03-19 15:16:10 UTC

Import patches-unapplied version 2:7.2.079-1ubuntu5 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 453b2c04e6f98c58718b6b764fde67c69cd398a3

New changelog entries:
  * Guard "syntax on" default so that it's only used if the syntax feature
    is available, since /etc/vim/vimrc is sometimes used by vim-tiny too
    (LP: #342174).

ubuntu/intrepid-security 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1.314-3ubuntu3.1 to ubuntu/intrepid-prop...

Author: Marc Deslauriers
Author Date: 2009-01-06 19:56:09 UTC

Import patches-unapplied version 1:7.1.314-3ubuntu3.1 to ubuntu/intrepid-proposed

Imported using git-ubuntu import.

Changelog parent: 294758bce2601e29a7b479c50898abdbf64e2a93

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - Cherry-picked fixes from Debian's Lenny vim svn.
    - http://git.debian.org/?p=pkg-vim/vim.git;a=shortlog;h=refs/heads/maint/lenny
    - runtime/autoload/netrw.vim: Backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - Upstream patch 7.2.010
    - src/normal.c: NUL-terminate the identifier string
    - src/normal.c: Only use the word under the cursor, instead of the entire
      line after the cursor, when constructing the shell command to run.
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=cb279e0979a103089695c21564ccc5bf8de5f558
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=706c71e15525a8939ede60c827f4131007f0c81e
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=805d0695937ec8c634a3d07393df2e7e565370b4
    - CVE-2008-4101

ubuntu/dapper-updates 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:6.4-006+2ubuntu6.2 to ubuntu/dapper-proposed

Author: Marc Deslauriers
Author Date: 2009-01-06 14:57:33 UTC

Import patches-unapplied version 1:6.4-006+2ubuntu6.2 to ubuntu/dapper-proposed

Imported using git-ubuntu import.

Changelog parent: 8fc41a645151eb90f04fe98cf55b6ba3e6846dc2

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Based on Red Hat's patch
      backport for vim 6.3 and cherry-picked fixes from Debian's Lenny vim svn.
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff: Based on Red Hat's patch
      backport for vim 6.3
    - CVE-2008-4101

ubuntu/dapper-security 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:6.4-006+2ubuntu6.2 to ubuntu/dapper-proposed

Author: Marc Deslauriers
Author Date: 2009-01-06 14:57:33 UTC

Import patches-unapplied version 1:6.4-006+2ubuntu6.2 to ubuntu/dapper-proposed

Imported using git-ubuntu import.

Changelog parent: 8fc41a645151eb90f04fe98cf55b6ba3e6846dc2

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Based on Red Hat's patch
      backport for vim 6.3 and cherry-picked fixes from Debian's Lenny vim svn.
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff: Based on Red Hat's patch
      backport for vim 6.3
    - CVE-2008-4101

ubuntu/dapper-proposed 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:6.4-006+2ubuntu6.2 to ubuntu/dapper-proposed

Author: Marc Deslauriers
Author Date: 2009-01-06 14:57:33 UTC

Import patches-unapplied version 1:6.4-006+2ubuntu6.2 to ubuntu/dapper-proposed

Imported using git-ubuntu import.

Changelog parent: 8fc41a645151eb90f04fe98cf55b6ba3e6846dc2

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Based on Red Hat's patch
      backport for vim 6.3 and cherry-picked fixes from Debian's Lenny vim svn.
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff: Based on Red Hat's patch
      backport for vim 6.3
    - CVE-2008-4101

ubuntu/dapper-devel 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:6.4-006+2ubuntu6.2 to ubuntu/dapper-proposed

Author: Marc Deslauriers
Author Date: 2009-01-06 14:57:33 UTC

Import patches-unapplied version 1:6.4-006+2ubuntu6.2 to ubuntu/dapper-proposed

Imported using git-ubuntu import.

Changelog parent: 8fc41a645151eb90f04fe98cf55b6ba3e6846dc2

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Based on Red Hat's patch
      backport for vim 6.3 and cherry-picked fixes from Debian's Lenny vim svn.
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff: Based on Red Hat's patch
      backport for vim 6.3
    - CVE-2008-4101

ubuntu/gutsy-devel 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1-056+2ubuntu2.1 to ubuntu/gutsy-proposed

Author: Marc Deslauriers
Author Date: 2009-01-07 13:47:31 UTC

Import patches-unapplied version 1:7.1-056+2ubuntu2.1 to ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: 55ccf04459fe940d9d29758c7c16071e4e5331e6

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Cherry-picked fixes from
      Debian's Lenny vim svn and backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff:
      - Upstream patch 7.2.010
      - src/normal.c: NUL-terminate the identifier string
      - src/normal.c: Only use the word under the cursor, instead of the entire
        line after the cursor, when constructing the shell command to run.
    - CVE-2008-4101

ubuntu/gutsy-proposed 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1-056+2ubuntu2.1 to ubuntu/gutsy-proposed

Author: Marc Deslauriers
Author Date: 2009-01-07 13:47:31 UTC

Import patches-unapplied version 1:7.1-056+2ubuntu2.1 to ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: 55ccf04459fe940d9d29758c7c16071e4e5331e6

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Cherry-picked fixes from
      Debian's Lenny vim svn and backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff:
      - Upstream patch 7.2.010
      - src/normal.c: NUL-terminate the identifier string
      - src/normal.c: Only use the word under the cursor, instead of the entire
        line after the cursor, when constructing the shell command to run.
    - CVE-2008-4101

ubuntu/gutsy-security 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1-056+2ubuntu2.1 to ubuntu/gutsy-proposed

Author: Marc Deslauriers
Author Date: 2009-01-07 13:47:31 UTC

Import patches-unapplied version 1:7.1-056+2ubuntu2.1 to ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: 55ccf04459fe940d9d29758c7c16071e4e5331e6

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Cherry-picked fixes from
      Debian's Lenny vim svn and backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff:
      - Upstream patch 7.2.010
      - src/normal.c: NUL-terminate the identifier string
      - src/normal.c: Only use the word under the cursor, instead of the entire
        line after the cursor, when constructing the shell command to run.
    - CVE-2008-4101

ubuntu/gutsy-updates 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1-056+2ubuntu2.1 to ubuntu/gutsy-proposed

Author: Marc Deslauriers
Author Date: 2009-01-07 13:47:31 UTC

Import patches-unapplied version 1:7.1-056+2ubuntu2.1 to ubuntu/gutsy-proposed

Imported using git-ubuntu import.

Changelog parent: 55ccf04459fe940d9d29758c7c16071e4e5331e6

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Cherry-picked fixes from
      Debian's Lenny vim svn and backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff:
      - Upstream patch 7.2.010
      - src/normal.c: NUL-terminate the identifier string
      - src/normal.c: Only use the word under the cursor, instead of the entire
        line after the cursor, when constructing the shell command to run.
    - CVE-2008-4101

ubuntu/hardy-devel 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1-138+1ubuntu3.1 to ubuntu/hardy-proposed

Author: Marc Deslauriers
Author Date: 2009-01-07 13:27:51 UTC

Import patches-unapplied version 1:7.1-138+1ubuntu3.1 to ubuntu/hardy-proposed

Imported using git-ubuntu import.

Changelog parent: e34ca75ad81128bf9120e6b0e90bc074b9a17d59

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Cherry-picked fixes from
      Debian's Lenny vim svn and backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff:
      - Upstream patch 7.2.010
      - src/normal.c: NUL-terminate the identifier string
      - src/normal.c: Only use the word under the cursor, instead of the entire
        line after the cursor, when constructing the shell command to run.
    - CVE-2008-4101

ubuntu/hardy-proposed 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1-138+1ubuntu3.1 to ubuntu/hardy-proposed

Author: Marc Deslauriers
Author Date: 2009-01-07 13:27:51 UTC

Import patches-unapplied version 1:7.1-138+1ubuntu3.1 to ubuntu/hardy-proposed

Imported using git-ubuntu import.

Changelog parent: e34ca75ad81128bf9120e6b0e90bc074b9a17d59

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Cherry-picked fixes from
      Debian's Lenny vim svn and backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff:
      - Upstream patch 7.2.010
      - src/normal.c: NUL-terminate the identifier string
      - src/normal.c: Only use the word under the cursor, instead of the entire
        line after the cursor, when constructing the shell command to run.
    - CVE-2008-4101

ubuntu/hardy-security 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1-138+1ubuntu3.1 to ubuntu/hardy-proposed

Author: Marc Deslauriers
Author Date: 2009-01-07 13:27:51 UTC

Import patches-unapplied version 1:7.1-138+1ubuntu3.1 to ubuntu/hardy-proposed

Imported using git-ubuntu import.

Changelog parent: e34ca75ad81128bf9120e6b0e90bc074b9a17d59

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Cherry-picked fixes from
      Debian's Lenny vim svn and backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff:
      - Upstream patch 7.2.010
      - src/normal.c: NUL-terminate the identifier string
      - src/normal.c: Only use the word under the cursor, instead of the entire
        line after the cursor, when constructing the shell command to run.
    - CVE-2008-4101

ubuntu/hardy-updates 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1-138+1ubuntu3.1 to ubuntu/hardy-proposed

Author: Marc Deslauriers
Author Date: 2009-01-07 13:27:51 UTC

Import patches-unapplied version 1:7.1-138+1ubuntu3.1 to ubuntu/hardy-proposed

Imported using git-ubuntu import.

Changelog parent: e34ca75ad81128bf9120e6b0e90bc074b9a17d59

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - patches/910_SECURITY_CVE-2008-2712.diff: Cherry-picked fixes from
      Debian's Lenny vim svn and backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - patches/911_SECURITY_CVE-2008-4104.diff:
      - Upstream patch 7.2.010
      - src/normal.c: NUL-terminate the identifier string
      - src/normal.c: Only use the word under the cursor, instead of the entire
        line after the cursor, when constructing the shell command to run.
    - CVE-2008-4101

ubuntu/intrepid-devel 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1.314-3ubuntu3.1 to ubuntu/intrepid-prop...

Author: Marc Deslauriers
Author Date: 2009-01-06 19:56:09 UTC

Import patches-unapplied version 1:7.1.314-3ubuntu3.1 to ubuntu/intrepid-proposed

Imported using git-ubuntu import.

Changelog parent: 294758bce2601e29a7b479c50898abdbf64e2a93

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - Cherry-picked fixes from Debian's Lenny vim svn.
    - http://git.debian.org/?p=pkg-vim/vim.git;a=shortlog;h=refs/heads/maint/lenny
    - runtime/autoload/netrw.vim: Backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - Upstream patch 7.2.010
    - src/normal.c: NUL-terminate the identifier string
    - src/normal.c: Only use the word under the cursor, instead of the entire
      line after the cursor, when constructing the shell command to run.
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=cb279e0979a103089695c21564ccc5bf8de5f558
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=706c71e15525a8939ede60c827f4131007f0c81e
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=805d0695937ec8c634a3d07393df2e7e565370b4
    - CVE-2008-4101

ubuntu/intrepid-proposed 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1.314-3ubuntu3.1 to ubuntu/intrepid-prop...

Author: Marc Deslauriers
Author Date: 2009-01-06 19:56:09 UTC

Import patches-unapplied version 1:7.1.314-3ubuntu3.1 to ubuntu/intrepid-proposed

Imported using git-ubuntu import.

Changelog parent: 294758bce2601e29a7b479c50898abdbf64e2a93

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - Cherry-picked fixes from Debian's Lenny vim svn.
    - http://git.debian.org/?p=pkg-vim/vim.git;a=shortlog;h=refs/heads/maint/lenny
    - runtime/autoload/netrw.vim: Backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - Upstream patch 7.2.010
    - src/normal.c: NUL-terminate the identifier string
    - src/normal.c: Only use the word under the cursor, instead of the entire
      line after the cursor, when constructing the shell command to run.
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=cb279e0979a103089695c21564ccc5bf8de5f558
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=706c71e15525a8939ede60c827f4131007f0c81e
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=805d0695937ec8c634a3d07393df2e7e565370b4
    - CVE-2008-4101

ubuntu/intrepid-updates 2009-01-09 17:04:27 UTC 2009-01-09
Import patches-unapplied version 1:7.1.314-3ubuntu3.1 to ubuntu/intrepid-prop...

Author: Marc Deslauriers
Author Date: 2009-01-06 19:56:09 UTC

Import patches-unapplied version 1:7.1.314-3ubuntu3.1 to ubuntu/intrepid-proposed

Imported using git-ubuntu import.

Changelog parent: 294758bce2601e29a7b479c50898abdbf64e2a93

New changelog entries:
  * SECURITY UPDATE: arbitrary command execution via vim scripts
    - Cherry-picked fixes from Debian's Lenny vim svn.
    - http://git.debian.org/?p=pkg-vim/vim.git;a=shortlog;h=refs/heads/maint/lenny
    - runtime/autoload/netrw.vim: Backported NetrwDelete() from netrw v132 so
      we pass the netrw.v4 vulnerability test from www.rdancer.org
    - CVE-2008-2712
  * SECURITY UPDATE: user-assisted arbitrary command execution from "K" in
    Visual mode
    - Upstream patch 7.2.010
    - src/normal.c: NUL-terminate the identifier string
    - src/normal.c: Only use the word under the cursor, instead of the entire
      line after the cursor, when constructing the shell command to run.
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=cb279e0979a103089695c21564ccc5bf8de5f558
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=706c71e15525a8939ede60c827f4131007f0c81e
    - http://git.debian.org/?p=pkg-vim/vim.git;a=commit;h=805d0695937ec8c634a3d07393df2e7e565370b4
    - CVE-2008-4101

debian/lenny 2008-10-29 16:13:49 UTC 2008-10-29
Import patches-unapplied version 1:7.1.314-3+lenny2 to debian/lenny

Author: James McCoy
Author Date: 2008-10-17 14:58:00 UTC

Import patches-unapplied version 1:7.1.314-3+lenny2 to debian/lenny

Imported using git-ubuntu import.

applied/debian/lenny 2008-10-29 16:13:49 UTC 2008-10-29
Import patches-applied version 1:7.1.314-3+lenny2 to applied/debian/lenny

Author: James McCoy
Author Date: 2008-10-17 14:58:00 UTC

Import patches-applied version 1:7.1.314-3+lenny2 to applied/debian/lenny

Imported using git-ubuntu import.

Unapplied parent: e8e00ecd0623331009620eb1f7f8b7daee935dcc

ubuntu/intrepid 2008-07-21 14:04:20 UTC 2008-07-21
Import patches-unapplied version 1:7.1.314-3ubuntu3 to ubuntu/intrepid

Author: Colin Watson
Author Date: 2008-07-21 13:22:09 UTC

Import patches-unapplied version 1:7.1.314-3ubuntu3 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 0e4cbe77f7fce9605ec331c4df229919776255eb

New changelog entries:
  * runtime/syntax/grub.vim:
    - Add Ubuntu-specific 'quiet' keyword.
  * Remove some unnecessary divergence from Debian, thanks to James Vega
    (LP: #248713):
    - Remove explicit settings of textwidth=0 and nobackup, since those are
      already the defaults.
    - Remove explicit setting of viminfo to a subset of the default, thereby
      adding s10 and h.
    - Remove NoDisplay=true from gvim.desktop; vim-gui-common isn't
      installed by default and there's no reason to withhold the menu entry
      from those who have installed it (LP: #3222).

ubuntu/dapper-backports 2008-02-12 18:05:23 UTC 2008-02-12
Import patches-unapplied version 1:7.0-035+1ubuntu5.2~dapper1 to ubuntu/dappe...

Author: Reinhard Tartler
Author Date: 2008-02-05 19:57:44 UTC

Import patches-unapplied version 1:7.0-035+1ubuntu5.2~dapper1 to ubuntu/dapper-backports

Imported using git-ubuntu import.

Changelog parent: 60cce1243d05042c4ed2f7bc77422035a9d1b3e2

New changelog entries:
  * import the patch from vim upload 1:7.0-035+1ubuntu5.2 to edgy-security
    LP: #150858

ubuntu/hardy 2008-01-31 11:03:54 UTC 2008-01-31
Import patches-unapplied version 1:7.1-138+1ubuntu3 to ubuntu/hardy

Author: Colin Watson
Author Date: 2008-01-31 10:59:03 UTC

Import patches-unapplied version 1:7.1-138+1ubuntu3 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 8934f6dbe584a0a5c008c8fdd93b3471dcdac38b

New changelog entries:
  * patches/debchangelog_launchpad.diff:
    - Add omni completion support for Launchpad bugs via
      python-launchpad-bugs.

ubuntu/gutsy 2007-10-05 01:03:54 UTC 2007-10-05
Import patches-unapplied version 1:7.1-056+2ubuntu2 to ubuntu/gutsy

Author: LaMont Jones
Author Date: 2007-10-04 18:26:15 UTC

Import patches-unapplied version 1:7.1-056+2ubuntu2 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: d73dc9566141c61d17a9dfe32c70b5875ba00ffd

New changelog entries:
  * Trigger rebuild for hppa

ubuntu/edgy-security 2007-08-28 20:04:15 UTC 2007-08-28
Import patches-unapplied version 1:7.0-035+1ubuntu5.2 to ubuntu/edgy-security

Author: Neil McGovern
Author Date: 2007-08-27 20:42:31 UTC

Import patches-unapplied version 1:7.0-035+1ubuntu5.2 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: 0f57da45f1f197c9682ed8d4f62cd46b926f332b

New changelog entries:
  * SECURITY UPDATE: Format string vulnerability allows user-assisted
    remote attackers to execute arbitrary code.
  * Added 'patches/801_CVE-2007-2953': Use puts() instead of
    fprintf(). Patch from upstream, backported.
  * References
    CVE-2007-2953

ubuntu/feisty-security 2007-08-28 20:04:15 UTC 2007-08-28
Import patches-unapplied version 1:7.0-164+1ubuntu7.2 to ubuntu/feisty-security

Author: Neil McGovern
Author Date: 2007-08-27 16:00:47 UTC

Import patches-unapplied version 1:7.0-164+1ubuntu7.2 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: 85979d0f152f084d374eb61208f15a1fb61ec314

New changelog entries:
  * SECURITY UPDATE: Format string vulnerability allows user-assisted remote
    attackers to execute arbitrary code.
  * Added 'patches/801_CVE-2007-2953': Use puts() instead of
    fprintf(). Patch from upstream, backported.
  * References
    CVE-2007-2953

ubuntu/edgy-updates 2007-08-28 20:04:15 UTC 2007-08-28
Import patches-unapplied version 1:7.0-035+1ubuntu5.2 to ubuntu/edgy-security

Author: Neil McGovern
Author Date: 2007-08-27 20:42:31 UTC

Import patches-unapplied version 1:7.0-035+1ubuntu5.2 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: 0f57da45f1f197c9682ed8d4f62cd46b926f332b

New changelog entries:
  * SECURITY UPDATE: Format string vulnerability allows user-assisted
    remote attackers to execute arbitrary code.
  * Added 'patches/801_CVE-2007-2953': Use puts() instead of
    fprintf(). Patch from upstream, backported.
  * References
    CVE-2007-2953

ubuntu/edgy-devel 2007-08-28 20:04:15 UTC 2007-08-28
Import patches-unapplied version 1:7.0-035+1ubuntu5.2 to ubuntu/edgy-security

Author: Neil McGovern
Author Date: 2007-08-27 20:42:31 UTC

Import patches-unapplied version 1:7.0-035+1ubuntu5.2 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: 0f57da45f1f197c9682ed8d4f62cd46b926f332b

New changelog entries:
  * SECURITY UPDATE: Format string vulnerability allows user-assisted
    remote attackers to execute arbitrary code.
  * Added 'patches/801_CVE-2007-2953': Use puts() instead of
    fprintf(). Patch from upstream, backported.
  * References
    CVE-2007-2953

ubuntu/feisty-updates 2007-08-28 20:04:15 UTC 2007-08-28
Import patches-unapplied version 1:7.0-164+1ubuntu7.2 to ubuntu/feisty-security

Author: Neil McGovern
Author Date: 2007-08-27 16:00:47 UTC

Import patches-unapplied version 1:7.0-164+1ubuntu7.2 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: 85979d0f152f084d374eb61208f15a1fb61ec314

New changelog entries:
  * SECURITY UPDATE: Format string vulnerability allows user-assisted remote
    attackers to execute arbitrary code.
  * Added 'patches/801_CVE-2007-2953': Use puts() instead of
    fprintf(). Patch from upstream, backported.
  * References
    CVE-2007-2953

ubuntu/feisty-devel 2007-08-28 20:04:15 UTC 2007-08-28
Import patches-unapplied version 1:7.0-164+1ubuntu7.2 to ubuntu/feisty-security

Author: Neil McGovern
Author Date: 2007-08-27 16:00:47 UTC

Import patches-unapplied version 1:7.0-164+1ubuntu7.2 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: 85979d0f152f084d374eb61208f15a1fb61ec314

New changelog entries:
  * SECURITY UPDATE: Format string vulnerability allows user-assisted remote
    attackers to execute arbitrary code.
  * Added 'patches/801_CVE-2007-2953': Use puts() instead of
    fprintf(). Patch from upstream, backported.
  * References
    CVE-2007-2953

ubuntu/feisty 2007-03-11 03:03:21 UTC 2007-03-11
Import patches-unapplied version 1:7.0-164+1ubuntu7 to ubuntu/feisty

Author: Soren Hansen
Author Date: 2007-03-10 21:07:48 UTC

Import patches-unapplied version 1:7.0-164+1ubuntu7 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 6fc3b65558a23af89232bc0478b2b6429fc298bc

New changelog entries:
  * Add XSBC-Original-Maintainer to debcontrol syntax highlighting.

ubuntu/edgy-backports 2007-03-08 21:03:19 UTC 2007-03-08
Import patches-unapplied version 1:7.0-164+1ubuntu6~edgy1 to ubuntu/edgy-back...

Author: John Dong
Author Date: 2007-03-08 20:02:56 UTC

Import patches-unapplied version 1:7.0-164+1ubuntu6~edgy1 to ubuntu/edgy-backports

Imported using git-ubuntu import.

Changelog parent: 6fc3b65558a23af89232bc0478b2b6429fc298bc

New changelog entries:
  * Automated backport upload; no source changes.

ubuntu/edgy 2006-10-20 09:03:12 UTC 2006-10-20
Import patches-unapplied version 1:7.0-035+1ubuntu5 to ubuntu/edgy

Author: Colin Watson
Author Date: 2006-10-18 17:43:57 UTC

Import patches-unapplied version 1:7.0-035+1ubuntu5 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: cc35096f1c09f1a0ccce5f232296f393f895f8bd

New changelog entries:
  * Backport from Debian (James Vega, closes: Malone #66733):
    - Build vim-tiny with multibyte support. (closes: #361378)

applied/ubuntu/devel 2006-05-23 11:06:38 UTC 2006-05-23
Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Author: Martin Pitt
Author Date: 2006-05-23 09:39:49 UTC

Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: f1798eca11bfd68869472e1adff8424c7cad2c95
Unapplied parent: e19960cf7b9a58ea1ff92ddc8ae11a50d9767c35

New changelog entries:
  * debian/rules: Create a POT file on build.

applied/ubuntu/edgy-devel 2006-05-23 11:06:38 UTC 2006-05-23
Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Author: Martin Pitt
Author Date: 2006-05-23 09:39:49 UTC

Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: f1798eca11bfd68869472e1adff8424c7cad2c95
Unapplied parent: e19960cf7b9a58ea1ff92ddc8ae11a50d9767c35

New changelog entries:
  * debian/rules: Create a POT file on build.

ubuntu/dapper 2006-05-23 11:06:38 UTC 2006-05-23
Import patches-unapplied version 1:6.4-006+2ubuntu6 to ubuntu/dapper

Author: Martin Pitt
Author Date: 2006-05-23 09:39:49 UTC

Import patches-unapplied version 1:6.4-006+2ubuntu6 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: ec7f16d6ad2e02c8309b11cf1440089bdddd82f8

New changelog entries:
  * debian/rules: Create a POT file on build.

applied/ubuntu/dapper 2006-05-23 11:06:38 UTC 2006-05-23
Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Author: Martin Pitt
Author Date: 2006-05-23 09:39:49 UTC

Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: f1798eca11bfd68869472e1adff8424c7cad2c95
Unapplied parent: e19960cf7b9a58ea1ff92ddc8ae11a50d9767c35

New changelog entries:
  * debian/rules: Create a POT file on build.

applied/ubuntu/dapper-devel 2006-05-23 11:06:38 UTC 2006-05-23
Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Author: Martin Pitt
Author Date: 2006-05-23 09:39:49 UTC

Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: f1798eca11bfd68869472e1adff8424c7cad2c95
Unapplied parent: e19960cf7b9a58ea1ff92ddc8ae11a50d9767c35

New changelog entries:
  * debian/rules: Create a POT file on build.

applied/ubuntu/edgy 2006-05-23 11:06:38 UTC 2006-05-23
Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Author: Martin Pitt
Author Date: 2006-05-23 09:39:49 UTC

Import patches-applied version 1:6.4-006+2ubuntu6 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: f1798eca11bfd68869472e1adff8424c7cad2c95
Unapplied parent: e19960cf7b9a58ea1ff92ddc8ae11a50d9767c35

New changelog entries:
  * debian/rules: Create a POT file on build.

ubuntu/breezy 2005-12-21 06:05:10 UTC 2005-12-21
Import patches-unapplied version 1:6.3-078+1ubuntu3 to ubuntu/breezy

Author: Adam Conrad
Author Date: 2005-08-22 15:57:09 UTC

Import patches-unapplied version 1:6.3-078+1ubuntu3 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: af2bb02d924ca8039726762992c4d31958b612e5

New changelog entries:
  * Rebuild for the cairo1 -> cairo2 transition.
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/990_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html
  * debian/patches/124_errorformat.vim.diff: Remove obsolete hunk that doesn't
    apply any more.
  * Resynchronise with Debian.
  * debian/control:
    - Build-Depends on libxt-dev (Ubuntu: #11113).
  * Drop vim-lesstif package.
  * Add 'breezy' to the list of accepted distribution keywords.
  * Norbert Tretkowski <nobse@debian.org>:
    + Removed all kvim related packages, the code is no longer maintained.
      Sorry. (closes: #234455, #237385, #283765, #293110, #194449, #205586,
      #266431, #272621, #294848, #245006, #194964)
    + Removed patch 401_gcc4.diff, it modified kvim code which is no longer
      available.
    + Added NEWS file, so people upgrading to this version getting informed
      about the kvim removal.
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Fixed up a patch for xml.vim.
  * Norbert Tretkowski <nobse@debian.org>:
    + Add a replaces: vim (<= 1:6.3-068+1) to every (k)vim-* package, required
      for menu-icon-missing fix from 1:6.3-068+2. (closes: #301866)
    + Urgency medium because above modification fixes regular upgrade with
      apt-get.
    + Fixed broken rgvim manpage. (closes: #301881)
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Enhance the es.po. (closes: #206782)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Modified patch 113_xml.vim.diff that fixes #196001 has introduced
      another syntax error. (closes: #301736)
    + Fixed menu-icon-missing on vim-* packages.
  * New upstream patch (068), see README.gz for details.
    + 6.3.068: When editing a compressed file xxx.gz which is a symbolic link
      to the actual file a ":write" no longer renames the link (patch by James
      Vega). (closes: #281630)
  * Norbert Tretkowski <nobse@debian.org>:
    + Added James Vega <jamessan@jamessan.com> to uploaders.
    + Fixed wrong executable registration in /usr/lib/mime/packages/kvim,
      thanks to Robin Verduijn for the patch. (closes: #295471)
    + Fixed synchronisation of syntax highlighting in fortran 90 programs.
      (closes: #301452)
    + Removed vim-doc's dependency on vim, so it's possible to install vim-doc
      without also installing vim.
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Fix php indent plugin, thanks to the ITLab at MUSC. (closes: #282135)
    + Fix prolog syntax file. (closes: #269692)
    + Fix xml syntax ('\' has no special meaning for xml). (closes: #196001)
    + Fix texinfo syntax file warning. (closes: #286763)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Fix lintian warning packages-installs-file-to-usr-x11r6:
      - Moving xpm files to /usr/share/pixmaps.
      - Edited the menu files.
    + Removed prerm-does-not-call-installdocs from lintian/vim.
    + Added patch 111_fstab.vim.diff to fix highlighting in fstab.
      (closes: #300108)
    + Removed Suggests: vim from vim-doc in debian/control.
    + Fixed binary-without-manpage for several packages.
    + Fixed pkg-not-in-package-test in kvim-tcl, kvim-ruby, kvim-python and
      kvim-perl.
    + Fixed the errors postinst-does-not-call-updatemenus and
      postrm-does-not-call-updatemenus.
  * James Vega <jamessan@jamessan.com>:
    + Fixed wrong highlighting of comments in syntax/sh.vim when comments
      occur between switches of case. (closes: #269325)
  * Stefano Zacchiroli <zack@debian.org>:
    + Added patch 302_message.c.diff to fix CTRL-C quit loops in range commands.
      (closes: #295639)
    + Added patch 118_ocaml.vim.diff to ship latest version of ocaml runtime
      support files: {syntax,ftplugin,ident}/ocaml.vim.
    + Modifications on debian/rules:
      - Uses debian/compat in place of debian/rules' DH_COMPAT.
      - Ignores diff error in "make_patch" target since diff usually returns 1.
      - Added support for command line VARIANT variable to override VARIANTS.
  * Pepijn de Langen <pepijn@ce.et.tudelft.nl>:
    + Added patch 119_php.vim.diff to php syntax highlighting backticks.
      (closes: #144754)
  * Norbert Tretkowski <nobse@debian.org>:
    + Disabled dh_installchangelogs and dh_installdocs for vim-doc.
    + Raised urgency to medium because of upstream patch 6.3.066.
  * New upstream patches (065 to 067), see README.gz for details.
    + 6.3.065: Entering Euro char via digraph doesn't always work.
      (closes: #298162)
  * Norbert Tretkowski <nobse@debian.org>:
    + Added Pierre Habouzit, Torsten Landschoff, Matthijs Mohlmann, Stefano
      Zacchiroli, Alexis Sukrieh and Pepijn de Langen to uploaders.
      (closes: #299446)
    + Added a new patch from Christian Hammers which adds additional keywords
      to /etc/fstab syntax hilighting. (closes: #299704)
    + Modified --with-compiledby value to use $DEBFULLNAME and $DEBEMAIL.
    + Updated tpp syntax file, thanks to Gerfried Fuchs.
    + Changed priority of vim-common package from extra to optional.
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Documented the /etc/vim/{g,}vimrc.local files in README.Debian.
    + Fixed some debcontrol.vim issues:
      - Don't search emails in fields that have not one. (closes: #114508)
      - Fix debcontrolName according to Policy. (closes: #148144)
    + Fixed tutor.vim to use usual locale envvars semantics. (closes: #289113)
    + Added a 16px icon for menu entries too
      (taken from http://www.vim.org/images/vim16x16.xpm). (closes: #39250)
    + Fixed changelog.Debian.gz detection. (closes: #263740)
    + Manpages various fixes:
      - Escape some dashes in vim(1). (closes: #279606)
      - Various fixes for xxd(1). (closes: #281124)
    + Fixed french translation. (closes: #277502)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Add syntax highlighting for xmodmap. (closes: #296759)
    + Fixed lintian warning unquoted-string-in-menu-item in kvim.menu.
    + Fixed lintian warning spelling-error-in-readme-debian (adviced should
      be advised).
    + Changed current maintainer in copyright file.
    + Fixed lintian warning package-relation-with-self in kvim.
    + Fixed lintian warning binary-has-unneeded-section in vim (added
      dh_strip).
    + Added depends on vim in vim-doc.
  * Alexis Sukrieh <sukria@sukria.net>:
    + Added a note about UTF-8 related issues in README.Debian.
    + Added debian/patches/108_automake.vim.diff (thanks to Alexander Kogan)
      which enables highlighting of _CPPFLAGS in automake files.
      (closes: #196212)
    + Added debian/patches/109_xdefaults.vim.diff (thanks to Peter De Wachter)
      which fixes bad highlighting when putting a FONT directive in xdefaults.
      (closes: #264284)
  * Stefano Zacchiroli <zack@debian.org>:
    + Added #DEBHELPER# tag to debian/vim-{doc,common}.preinst.
    + Minor cleanup of debian/rules so vim-{doc,common} uses dh_install
      instead of dh_movefiles ("binary" target could now be invoked twice
      after a single "install" invocation), let dh_compress compress README.
  * Norbert Tretkowski <nobse@debian.org>:
    + New upstream patches (062 to 064), see README.gz for details.
    + Set maintainer address to project mailinglist on alioth and added myself to
      uploaders.
    + Added a new patch which sets automake syntax recognition for files named
      GNUmakefile.am. (closes: #277596)
    + Added a new patch which adds testing-proposed-updates to debchangelog
      syntax hilighting.
  * New upstream patches (059 to 061), see README.gz for details.
  * Kudos to Javier Fernandez-Sanguino Pena, he discovered the usage of
    insecure $$ constructs in vimspell.sh and tcltags.sh which have been
    fixed with the last upload.
  * Removed vimspell.sh and tcltags.sh, these scripts are no longer supported
    upstream.
  * Removed patch which was added in 1:6.3-058+1, it's no longer required.
  * New upstream patches (055 to 058), see README.gz for details.
  * Added a new patch (stolen from Ubuntu) which modifies vimspell.sh and
    tcltags.sh so they use mktemp instead of insecure $$ construction to
    create temporary files. (CAN-2005-0069) (closes: #289560)
  * New upstream patches (047 to 054), see README.gz for details.
  * Source /etc/vim/gvimrc.local if available. (closes: #272001)
  * Added a new patch which fixes ftbfs on amd64 with gcc-4.0, thanks to
    Andreas Jochens. (closes: #288731)

ubuntu/breezy-devel 2005-12-21 06:05:10 UTC 2005-12-21
Import patches-unapplied version 1:6.3-078+1ubuntu3 to ubuntu/breezy

Author: Adam Conrad
Author Date: 2005-08-22 15:57:09 UTC

Import patches-unapplied version 1:6.3-078+1ubuntu3 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: af2bb02d924ca8039726762992c4d31958b612e5

New changelog entries:
  * Rebuild for the cairo1 -> cairo2 transition.
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/990_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html
  * debian/patches/124_errorformat.vim.diff: Remove obsolete hunk that doesn't
    apply any more.
  * Resynchronise with Debian.
  * debian/control:
    - Build-Depends on libxt-dev (Ubuntu: #11113).
  * Drop vim-lesstif package.
  * Add 'breezy' to the list of accepted distribution keywords.
  * Norbert Tretkowski <nobse@debian.org>:
    + Removed all kvim related packages, the code is no longer maintained.
      Sorry. (closes: #234455, #237385, #283765, #293110, #194449, #205586,
      #266431, #272621, #294848, #245006, #194964)
    + Removed patch 401_gcc4.diff, it modified kvim code which is no longer
      available.
    + Added NEWS file, so people upgrading to this version getting informed
      about the kvim removal.
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Fixed up a patch for xml.vim.
  * Norbert Tretkowski <nobse@debian.org>:
    + Add a replaces: vim (<= 1:6.3-068+1) to every (k)vim-* package, required
      for menu-icon-missing fix from 1:6.3-068+2. (closes: #301866)
    + Urgency medium because above modification fixes regular upgrade with
      apt-get.
    + Fixed broken rgvim manpage. (closes: #301881)
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Enhance the es.po. (closes: #206782)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Modified patch 113_xml.vim.diff that fixes #196001 has introduced
      another syntax error. (closes: #301736)
    + Fixed menu-icon-missing on vim-* packages.
  * New upstream patch (068), see README.gz for details.
    + 6.3.068: When editing a compressed file xxx.gz which is a symbolic link
      to the actual file a ":write" no longer renames the link (patch by James
      Vega). (closes: #281630)
  * Norbert Tretkowski <nobse@debian.org>:
    + Added James Vega <jamessan@jamessan.com> to uploaders.
    + Fixed wrong executable registration in /usr/lib/mime/packages/kvim,
      thanks to Robin Verduijn for the patch. (closes: #295471)
    + Fixed synchronisation of syntax highlighting in fortran 90 programs.
      (closes: #301452)
    + Removed vim-doc's dependency on vim, so it's possible to install vim-doc
      without also installing vim.
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Fix php indent plugin, thanks to the ITLab at MUSC. (closes: #282135)
    + Fix prolog syntax file. (closes: #269692)
    + Fix xml syntax ('\' has no special meaning for xml). (closes: #196001)
    + Fix texinfo syntax file warning. (closes: #286763)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Fix lintian warning packages-installs-file-to-usr-x11r6:
      - Moving xpm files to /usr/share/pixmaps.
      - Edited the menu files.
    + Removed prerm-does-not-call-installdocs from lintian/vim.
    + Added patch 111_fstab.vim.diff to fix highlighting in fstab.
      (closes: #300108)
    + Removed Suggests: vim from vim-doc in debian/control.
    + Fixed binary-without-manpage for several packages.
    + Fixed pkg-not-in-package-test in kvim-tcl, kvim-ruby, kvim-python and
      kvim-perl.
    + Fixed the errors postinst-does-not-call-updatemenus and
      postrm-does-not-call-updatemenus.
  * James Vega <jamessan@jamessan.com>:
    + Fixed wrong highlighting of comments in syntax/sh.vim when comments
      occur between switches of case. (closes: #269325)
  * Stefano Zacchiroli <zack@debian.org>:
    + Added patch 302_message.c.diff to fix CTRL-C quit loops in range commands.
      (closes: #295639)
    + Added patch 118_ocaml.vim.diff to ship latest version of ocaml runtime
      support files: {syntax,ftplugin,ident}/ocaml.vim.
    + Modifications on debian/rules:
      - Uses debian/compat in place of debian/rules' DH_COMPAT.
      - Ignores diff error in "make_patch" target since diff usually returns 1.
      - Added support for command line VARIANT variable to override VARIANTS.
  * Pepijn de Langen <pepijn@ce.et.tudelft.nl>:
    + Added patch 119_php.vim.diff to php syntax highlighting backticks.
      (closes: #144754)
  * Norbert Tretkowski <nobse@debian.org>:
    + Disabled dh_installchangelogs and dh_installdocs for vim-doc.
    + Raised urgency to medium because of upstream patch 6.3.066.
  * New upstream patches (065 to 067), see README.gz for details.
    + 6.3.065: Entering Euro char via digraph doesn't always work.
      (closes: #298162)
  * Norbert Tretkowski <nobse@debian.org>:
    + Added Pierre Habouzit, Torsten Landschoff, Matthijs Mohlmann, Stefano
      Zacchiroli, Alexis Sukrieh and Pepijn de Langen to uploaders.
      (closes: #299446)
    + Added a new patch from Christian Hammers which adds additional keywords
      to /etc/fstab syntax hilighting. (closes: #299704)
    + Modified --with-compiledby value to use $DEBFULLNAME and $DEBEMAIL.
    + Updated tpp syntax file, thanks to Gerfried Fuchs.
    + Changed priority of vim-common package from extra to optional.
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Documented the /etc/vim/{g,}vimrc.local files in README.Debian.
    + Fixed some debcontrol.vim issues:
      - Don't search emails in fields that have not one. (closes: #114508)
      - Fix debcontrolName according to Policy. (closes: #148144)
    + Fixed tutor.vim to use usual locale envvars semantics. (closes: #289113)
    + Added a 16px icon for menu entries too
      (taken from http://www.vim.org/images/vim16x16.xpm). (closes: #39250)
    + Fixed changelog.Debian.gz detection. (closes: #263740)
    + Manpages various fixes:
      - Escape some dashes in vim(1). (closes: #279606)
      - Various fixes for xxd(1). (closes: #281124)
    + Fixed french translation. (closes: #277502)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Add syntax highlighting for xmodmap. (closes: #296759)
    + Fixed lintian warning unquoted-string-in-menu-item in kvim.menu.
    + Fixed lintian warning spelling-error-in-readme-debian (adviced should
      be advised).
    + Changed current maintainer in copyright file.
    + Fixed lintian warning package-relation-with-self in kvim.
    + Fixed lintian warning binary-has-unneeded-section in vim (added
      dh_strip).
    + Added depends on vim in vim-doc.
  * Alexis Sukrieh <sukria@sukria.net>:
    + Added a note about UTF-8 related issues in README.Debian.
    + Added debian/patches/108_automake.vim.diff (thanks to Alexander Kogan)
      which enables highlighting of _CPPFLAGS in automake files.
      (closes: #196212)
    + Added debian/patches/109_xdefaults.vim.diff (thanks to Peter De Wachter)
      which fixes bad highlighting when putting a FONT directive in xdefaults.
      (closes: #264284)
  * Stefano Zacchiroli <zack@debian.org>:
    + Added #DEBHELPER# tag to debian/vim-{doc,common}.preinst.
    + Minor cleanup of debian/rules so vim-{doc,common} uses dh_install
      instead of dh_movefiles ("binary" target could now be invoked twice
      after a single "install" invocation), let dh_compress compress README.
  * Norbert Tretkowski <nobse@debian.org>:
    + New upstream patches (062 to 064), see README.gz for details.
    + Set maintainer address to project mailinglist on alioth and added myself to
      uploaders.
    + Added a new patch which sets automake syntax recognition for files named
      GNUmakefile.am. (closes: #277596)
    + Added a new patch which adds testing-proposed-updates to debchangelog
      syntax hilighting.
  * New upstream patches (059 to 061), see README.gz for details.
  * Kudos to Javier Fernandez-Sanguino Pena, he discovered the usage of
    insecure $$ constructs in vimspell.sh and tcltags.sh which have been
    fixed with the last upload.
  * Removed vimspell.sh and tcltags.sh, these scripts are no longer supported
    upstream.
  * Removed patch which was added in 1:6.3-058+1, it's no longer required.
  * New upstream patches (055 to 058), see README.gz for details.
  * Added a new patch (stolen from Ubuntu) which modifies vimspell.sh and
    tcltags.sh so they use mktemp instead of insecure $$ construction to
    create temporary files. (CAN-2005-0069) (closes: #289560)
  * New upstream patches (047 to 054), see README.gz for details.
  * Source /etc/vim/gvimrc.local if available. (closes: #272001)
  * Added a new patch which fixes ftbfs on amd64 with gcc-4.0, thanks to
    Andreas Jochens. (closes: #288731)

applied/ubuntu/breezy-devel 2005-12-21 06:05:10 UTC 2005-12-21
Import patches-applied version 1:6.3-078+1ubuntu3 to applied/ubuntu/breezy

Author: Adam Conrad
Author Date: 2005-08-22 15:57:09 UTC

Import patches-applied version 1:6.3-078+1ubuntu3 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 97de01b8ebc1669699fe974fa98b648e9e46fb1d
Unapplied parent: 14f7c8d4e35508c5636f36e024d864b6d3682912

New changelog entries:
  * Rebuild for the cairo1 -> cairo2 transition.
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/990_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html
  * debian/patches/124_errorformat.vim.diff: Remove obsolete hunk that doesn't
    apply any more.
  * Resynchronise with Debian.
  * debian/control:
    - Build-Depends on libxt-dev (Ubuntu: #11113).
  * Drop vim-lesstif package.
  * Add 'breezy' to the list of accepted distribution keywords.
  * Norbert Tretkowski <nobse@debian.org>:
    + Removed all kvim related packages, the code is no longer maintained.
      Sorry. (closes: #234455, #237385, #283765, #293110, #194449, #205586,
      #266431, #272621, #294848, #245006, #194964)
    + Removed patch 401_gcc4.diff, it modified kvim code which is no longer
      available.
    + Added NEWS file, so people upgrading to this version getting informed
      about the kvim removal.
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Fixed up a patch for xml.vim.
  * Norbert Tretkowski <nobse@debian.org>:
    + Add a replaces: vim (<= 1:6.3-068+1) to every (k)vim-* package, required
      for menu-icon-missing fix from 1:6.3-068+2. (closes: #301866)
    + Urgency medium because above modification fixes regular upgrade with
      apt-get.
    + Fixed broken rgvim manpage. (closes: #301881)
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Enhance the es.po. (closes: #206782)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Modified patch 113_xml.vim.diff that fixes #196001 has introduced
      another syntax error. (closes: #301736)
    + Fixed menu-icon-missing on vim-* packages.
  * New upstream patch (068), see README.gz for details.
    + 6.3.068: When editing a compressed file xxx.gz which is a symbolic link
      to the actual file a ":write" no longer renames the link (patch by James
      Vega). (closes: #281630)
  * Norbert Tretkowski <nobse@debian.org>:
    + Added James Vega <jamessan@jamessan.com> to uploaders.
    + Fixed wrong executable registration in /usr/lib/mime/packages/kvim,
      thanks to Robin Verduijn for the patch. (closes: #295471)
    + Fixed synchronisation of syntax highlighting in fortran 90 programs.
      (closes: #301452)
    + Removed vim-doc's dependency on vim, so it's possible to install vim-doc
      without also installing vim.
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Fix php indent plugin, thanks to the ITLab at MUSC. (closes: #282135)
    + Fix prolog syntax file. (closes: #269692)
    + Fix xml syntax ('\' has no special meaning for xml). (closes: #196001)
    + Fix texinfo syntax file warning. (closes: #286763)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Fix lintian warning packages-installs-file-to-usr-x11r6:
      - Moving xpm files to /usr/share/pixmaps.
      - Edited the menu files.
    + Removed prerm-does-not-call-installdocs from lintian/vim.
    + Added patch 111_fstab.vim.diff to fix highlighting in fstab.
      (closes: #300108)
    + Removed Suggests: vim from vim-doc in debian/control.
    + Fixed binary-without-manpage for several packages.
    + Fixed pkg-not-in-package-test in kvim-tcl, kvim-ruby, kvim-python and
      kvim-perl.
    + Fixed the errors postinst-does-not-call-updatemenus and
      postrm-does-not-call-updatemenus.
  * James Vega <jamessan@jamessan.com>:
    + Fixed wrong highlighting of comments in syntax/sh.vim when comments
      occur between switches of case. (closes: #269325)
  * Stefano Zacchiroli <zack@debian.org>:
    + Added patch 302_message.c.diff to fix CTRL-C quit loops in range commands.
      (closes: #295639)
    + Added patch 118_ocaml.vim.diff to ship latest version of ocaml runtime
      support files: {syntax,ftplugin,ident}/ocaml.vim.
    + Modifications on debian/rules:
      - Uses debian/compat in place of debian/rules' DH_COMPAT.
      - Ignores diff error in "make_patch" target since diff usually returns 1.
      - Added support for command line VARIANT variable to override VARIANTS.
  * Pepijn de Langen <pepijn@ce.et.tudelft.nl>:
    + Added patch 119_php.vim.diff to php syntax highlighting backticks.
      (closes: #144754)
  * Norbert Tretkowski <nobse@debian.org>:
    + Disabled dh_installchangelogs and dh_installdocs for vim-doc.
    + Raised urgency to medium because of upstream patch 6.3.066.
  * New upstream patches (065 to 067), see README.gz for details.
    + 6.3.065: Entering Euro char via digraph doesn't always work.
      (closes: #298162)
  * Norbert Tretkowski <nobse@debian.org>:
    + Added Pierre Habouzit, Torsten Landschoff, Matthijs Mohlmann, Stefano
      Zacchiroli, Alexis Sukrieh and Pepijn de Langen to uploaders.
      (closes: #299446)
    + Added a new patch from Christian Hammers which adds additional keywords
      to /etc/fstab syntax hilighting. (closes: #299704)
    + Modified --with-compiledby value to use $DEBFULLNAME and $DEBEMAIL.
    + Updated tpp syntax file, thanks to Gerfried Fuchs.
    + Changed priority of vim-common package from extra to optional.
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Documented the /etc/vim/{g,}vimrc.local files in README.Debian.
    + Fixed some debcontrol.vim issues:
      - Don't search emails in fields that have not one. (closes: #114508)
      - Fix debcontrolName according to Policy. (closes: #148144)
    + Fixed tutor.vim to use usual locale envvars semantics. (closes: #289113)
    + Added a 16px icon for menu entries too
      (taken from http://www.vim.org/images/vim16x16.xpm). (closes: #39250)
    + Fixed changelog.Debian.gz detection. (closes: #263740)
    + Manpages various fixes:
      - Escape some dashes in vim(1). (closes: #279606)
      - Various fixes for xxd(1). (closes: #281124)
    + Fixed french translation. (closes: #277502)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Add syntax highlighting for xmodmap. (closes: #296759)
    + Fixed lintian warning unquoted-string-in-menu-item in kvim.menu.
    + Fixed lintian warning spelling-error-in-readme-debian (adviced should
      be advised).
    + Changed current maintainer in copyright file.
    + Fixed lintian warning package-relation-with-self in kvim.
    + Fixed lintian warning binary-has-unneeded-section in vim (added
      dh_strip).
    + Added depends on vim in vim-doc.
  * Alexis Sukrieh <sukria@sukria.net>:
    + Added a note about UTF-8 related issues in README.Debian.
    + Added debian/patches/108_automake.vim.diff (thanks to Alexander Kogan)
      which enables highlighting of _CPPFLAGS in automake files.
      (closes: #196212)
    + Added debian/patches/109_xdefaults.vim.diff (thanks to Peter De Wachter)
      which fixes bad highlighting when putting a FONT directive in xdefaults.
      (closes: #264284)
  * Stefano Zacchiroli <zack@debian.org>:
    + Added #DEBHELPER# tag to debian/vim-{doc,common}.preinst.
    + Minor cleanup of debian/rules so vim-{doc,common} uses dh_install
      instead of dh_movefiles ("binary" target could now be invoked twice
      after a single "install" invocation), let dh_compress compress README.
  * Norbert Tretkowski <nobse@debian.org>:
    + New upstream patches (062 to 064), see README.gz for details.
    + Set maintainer address to project mailinglist on alioth and added myself to
      uploaders.
    + Added a new patch which sets automake syntax recognition for files named
      GNUmakefile.am. (closes: #277596)
    + Added a new patch which adds testing-proposed-updates to debchangelog
      syntax hilighting.
  * New upstream patches (059 to 061), see README.gz for details.
  * Kudos to Javier Fernandez-Sanguino Pena, he discovered the usage of
    insecure $$ constructs in vimspell.sh and tcltags.sh which have been
    fixed with the last upload.
  * Removed vimspell.sh and tcltags.sh, these scripts are no longer supported
    upstream.
  * Removed patch which was added in 1:6.3-058+1, it's no longer required.
  * New upstream patches (055 to 058), see README.gz for details.
  * Added a new patch (stolen from Ubuntu) which modifies vimspell.sh and
    tcltags.sh so they use mktemp instead of insecure $$ construction to
    create temporary files. (CAN-2005-0069) (closes: #289560)
  * New upstream patches (047 to 054), see README.gz for details.
  * Source /etc/vim/gvimrc.local if available. (closes: #272001)
  * Added a new patch which fixes ftbfs on amd64 with gcc-4.0, thanks to
    Andreas Jochens. (closes: #288731)

applied/ubuntu/breezy 2005-12-21 06:05:10 UTC 2005-12-21
Import patches-applied version 1:6.3-078+1ubuntu3 to applied/ubuntu/breezy

Author: Adam Conrad
Author Date: 2005-08-22 15:57:09 UTC

Import patches-applied version 1:6.3-078+1ubuntu3 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 97de01b8ebc1669699fe974fa98b648e9e46fb1d
Unapplied parent: 14f7c8d4e35508c5636f36e024d864b6d3682912

New changelog entries:
  * Rebuild for the cairo1 -> cairo2 transition.
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/990_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html
  * debian/patches/124_errorformat.vim.diff: Remove obsolete hunk that doesn't
    apply any more.
  * Resynchronise with Debian.
  * debian/control:
    - Build-Depends on libxt-dev (Ubuntu: #11113).
  * Drop vim-lesstif package.
  * Add 'breezy' to the list of accepted distribution keywords.
  * Norbert Tretkowski <nobse@debian.org>:
    + Removed all kvim related packages, the code is no longer maintained.
      Sorry. (closes: #234455, #237385, #283765, #293110, #194449, #205586,
      #266431, #272621, #294848, #245006, #194964)
    + Removed patch 401_gcc4.diff, it modified kvim code which is no longer
      available.
    + Added NEWS file, so people upgrading to this version getting informed
      about the kvim removal.
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Fixed up a patch for xml.vim.
  * Norbert Tretkowski <nobse@debian.org>:
    + Add a replaces: vim (<= 1:6.3-068+1) to every (k)vim-* package, required
      for menu-icon-missing fix from 1:6.3-068+2. (closes: #301866)
    + Urgency medium because above modification fixes regular upgrade with
      apt-get.
    + Fixed broken rgvim manpage. (closes: #301881)
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Enhance the es.po. (closes: #206782)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Modified patch 113_xml.vim.diff that fixes #196001 has introduced
      another syntax error. (closes: #301736)
    + Fixed menu-icon-missing on vim-* packages.
  * New upstream patch (068), see README.gz for details.
    + 6.3.068: When editing a compressed file xxx.gz which is a symbolic link
      to the actual file a ":write" no longer renames the link (patch by James
      Vega). (closes: #281630)
  * Norbert Tretkowski <nobse@debian.org>:
    + Added James Vega <jamessan@jamessan.com> to uploaders.
    + Fixed wrong executable registration in /usr/lib/mime/packages/kvim,
      thanks to Robin Verduijn for the patch. (closes: #295471)
    + Fixed synchronisation of syntax highlighting in fortran 90 programs.
      (closes: #301452)
    + Removed vim-doc's dependency on vim, so it's possible to install vim-doc
      without also installing vim.
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Fix php indent plugin, thanks to the ITLab at MUSC. (closes: #282135)
    + Fix prolog syntax file. (closes: #269692)
    + Fix xml syntax ('\' has no special meaning for xml). (closes: #196001)
    + Fix texinfo syntax file warning. (closes: #286763)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Fix lintian warning packages-installs-file-to-usr-x11r6:
      - Moving xpm files to /usr/share/pixmaps.
      - Edited the menu files.
    + Removed prerm-does-not-call-installdocs from lintian/vim.
    + Added patch 111_fstab.vim.diff to fix highlighting in fstab.
      (closes: #300108)
    + Removed Suggests: vim from vim-doc in debian/control.
    + Fixed binary-without-manpage for several packages.
    + Fixed pkg-not-in-package-test in kvim-tcl, kvim-ruby, kvim-python and
      kvim-perl.
    + Fixed the errors postinst-does-not-call-updatemenus and
      postrm-does-not-call-updatemenus.
  * James Vega <jamessan@jamessan.com>:
    + Fixed wrong highlighting of comments in syntax/sh.vim when comments
      occur between switches of case. (closes: #269325)
  * Stefano Zacchiroli <zack@debian.org>:
    + Added patch 302_message.c.diff to fix CTRL-C quit loops in range commands.
      (closes: #295639)
    + Added patch 118_ocaml.vim.diff to ship latest version of ocaml runtime
      support files: {syntax,ftplugin,ident}/ocaml.vim.
    + Modifications on debian/rules:
      - Uses debian/compat in place of debian/rules' DH_COMPAT.
      - Ignores diff error in "make_patch" target since diff usually returns 1.
      - Added support for command line VARIANT variable to override VARIANTS.
  * Pepijn de Langen <pepijn@ce.et.tudelft.nl>:
    + Added patch 119_php.vim.diff to php syntax highlighting backticks.
      (closes: #144754)
  * Norbert Tretkowski <nobse@debian.org>:
    + Disabled dh_installchangelogs and dh_installdocs for vim-doc.
    + Raised urgency to medium because of upstream patch 6.3.066.
  * New upstream patches (065 to 067), see README.gz for details.
    + 6.3.065: Entering Euro char via digraph doesn't always work.
      (closes: #298162)
  * Norbert Tretkowski <nobse@debian.org>:
    + Added Pierre Habouzit, Torsten Landschoff, Matthijs Mohlmann, Stefano
      Zacchiroli, Alexis Sukrieh and Pepijn de Langen to uploaders.
      (closes: #299446)
    + Added a new patch from Christian Hammers which adds additional keywords
      to /etc/fstab syntax hilighting. (closes: #299704)
    + Modified --with-compiledby value to use $DEBFULLNAME and $DEBEMAIL.
    + Updated tpp syntax file, thanks to Gerfried Fuchs.
    + Changed priority of vim-common package from extra to optional.
  * Pierre Habouzit <pierre.habouzit@m4x.org>:
    + Documented the /etc/vim/{g,}vimrc.local files in README.Debian.
    + Fixed some debcontrol.vim issues:
      - Don't search emails in fields that have not one. (closes: #114508)
      - Fix debcontrolName according to Policy. (closes: #148144)
    + Fixed tutor.vim to use usual locale envvars semantics. (closes: #289113)
    + Added a 16px icon for menu entries too
      (taken from http://www.vim.org/images/vim16x16.xpm). (closes: #39250)
    + Fixed changelog.Debian.gz detection. (closes: #263740)
    + Manpages various fixes:
      - Escape some dashes in vim(1). (closes: #279606)
      - Various fixes for xxd(1). (closes: #281124)
    + Fixed french translation. (closes: #277502)
  * Matthijs Mohlmann <matthijs@cacholong.nl>:
    + Add syntax highlighting for xmodmap. (closes: #296759)
    + Fixed lintian warning unquoted-string-in-menu-item in kvim.menu.
    + Fixed lintian warning spelling-error-in-readme-debian (adviced should
      be advised).
    + Changed current maintainer in copyright file.
    + Fixed lintian warning package-relation-with-self in kvim.
    + Fixed lintian warning binary-has-unneeded-section in vim (added
      dh_strip).
    + Added depends on vim in vim-doc.
  * Alexis Sukrieh <sukria@sukria.net>:
    + Added a note about UTF-8 related issues in README.Debian.
    + Added debian/patches/108_automake.vim.diff (thanks to Alexander Kogan)
      which enables highlighting of _CPPFLAGS in automake files.
      (closes: #196212)
    + Added debian/patches/109_xdefaults.vim.diff (thanks to Peter De Wachter)
      which fixes bad highlighting when putting a FONT directive in xdefaults.
      (closes: #264284)
  * Stefano Zacchiroli <zack@debian.org>:
    + Added #DEBHELPER# tag to debian/vim-{doc,common}.preinst.
    + Minor cleanup of debian/rules so vim-{doc,common} uses dh_install
      instead of dh_movefiles ("binary" target could now be invoked twice
      after a single "install" invocation), let dh_compress compress README.
  * Norbert Tretkowski <nobse@debian.org>:
    + New upstream patches (062 to 064), see README.gz for details.
    + Set maintainer address to project mailinglist on alioth and added myself to
      uploaders.
    + Added a new patch which sets automake syntax recognition for files named
      GNUmakefile.am. (closes: #277596)
    + Added a new patch which adds testing-proposed-updates to debchangelog
      syntax hilighting.
  * New upstream patches (059 to 061), see README.gz for details.
  * Kudos to Javier Fernandez-Sanguino Pena, he discovered the usage of
    insecure $$ constructs in vimspell.sh and tcltags.sh which have been
    fixed with the last upload.
  * Removed vimspell.sh and tcltags.sh, these scripts are no longer supported
    upstream.
  * Removed patch which was added in 1:6.3-058+1, it's no longer required.
  * New upstream patches (055 to 058), see README.gz for details.
  * Added a new patch (stolen from Ubuntu) which modifies vimspell.sh and
    tcltags.sh so they use mktemp instead of insecure $$ construction to
    create temporary files. (CAN-2005-0069) (closes: #289560)
  * New upstream patches (047 to 054), see README.gz for details.
  * Source /etc/vim/gvimrc.local if available. (closes: #272001)
  * Added a new patch which fixes ftbfs on amd64 with gcc-4.0, thanks to
    Andreas Jochens. (closes: #288731)

applied/ubuntu/hoary-devel 2005-12-21 03:58:37 UTC 2005-12-21
Import patches-applied version 1:6.3-046+1ubuntu7.1 to applied/ubuntu/hoary-s...

Author: Martin Pitt
Author Date: 2005-07-26 11:39:18 UTC

Import patches-applied version 1:6.3-046+1ubuntu7.1 to applied/ubuntu/hoary-security

Imported using git-ubuntu import.

Changelog parent: 97de01b8ebc1669699fe974fa98b648e9e46fb1d
Unapplied parent: 18cb9ef0b6c9a0f49ff099505c753fe3237f451d

New changelog entries:
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/990_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html

ubuntu/hoary-devel 2005-12-21 03:58:37 UTC 2005-12-21
Import patches-unapplied version 1:6.3-046+1ubuntu7.1 to ubuntu/hoary-security

Author: Martin Pitt
Author Date: 2005-07-26 11:39:18 UTC

Import patches-unapplied version 1:6.3-046+1ubuntu7.1 to ubuntu/hoary-security

Imported using git-ubuntu import.

Changelog parent: af2bb02d924ca8039726762992c4d31958b612e5

New changelog entries:
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/990_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html

ubuntu/hoary-security 2005-12-21 03:58:37 UTC 2005-12-21
Import patches-unapplied version 1:6.3-046+1ubuntu7.1 to ubuntu/hoary-security

Author: Martin Pitt
Author Date: 2005-07-26 11:39:18 UTC

Import patches-unapplied version 1:6.3-046+1ubuntu7.1 to ubuntu/hoary-security

Imported using git-ubuntu import.

Changelog parent: af2bb02d924ca8039726762992c4d31958b612e5

New changelog entries:
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/990_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html

applied/ubuntu/hoary-security 2005-12-21 03:58:37 UTC 2005-12-21
Import patches-applied version 1:6.3-046+1ubuntu7.1 to applied/ubuntu/hoary-s...

Author: Martin Pitt
Author Date: 2005-07-26 11:39:18 UTC

Import patches-applied version 1:6.3-046+1ubuntu7.1 to applied/ubuntu/hoary-security

Imported using git-ubuntu import.

Changelog parent: 97de01b8ebc1669699fe974fa98b648e9e46fb1d
Unapplied parent: 18cb9ef0b6c9a0f49ff099505c753fe3237f451d

New changelog entries:
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/990_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html

ubuntu/hoary 2005-12-20 21:55:30 UTC 2005-12-20
Import patches-unapplied version 1:6.3-046+1ubuntu7 to ubuntu/hoary

Author: Jonathan Riddell
Author Date: 2005-04-03 12:09:32 UTC

Import patches-unapplied version 1:6.3-046+1ubuntu7 to ubuntu/hoary

Imported using git-ubuntu import.

Changelog parent: ee418f37425ff5d205b2a1534e7960aa9aee66e4

New changelog entries:
  * Ensure kubuntu_01_xdg_menus.diff is not applied before uploading.
  * Add kubuntu_01_xdg_menus.diff to make kvim menu entry XDG compliant.
  * Revert KDE removal, thus making the kvim package actually have useful
    content rather than just a broken diversion of vim. kvim-ruby is still
    skipped.
  * Drop editor alternative priority to 35, since Ubuntu installs vim by
    default (closes: Ubuntu #4710).
  * Don't autoindent by default (Ubuntu: #5602)
  * SECURITY UPDATE: fix insecure temporary files
  * Added patch 104_secure_tempfiles.diff: use mktemp instead of insecure $$
    construction to create temporary files in vimspell.sh and tcltags.sh
  * References:
    CAN-2005-0069
    http://bugs.debian.org/289560
  * Resynchronise with Debian.
  * debian/vim-variant.desktop: Disable menu item again.
  * Norbert Tretkowski <nobse@debian.org>:
    + new upstream patches (032 to 046), see README.gz for details
    + added a desktop entry under /usr/share/applications/ for all variants
      (closes: #285065)
    + added farsi fonts to vim-common package (closes: #258773)
  * Rebuild with python2.4.
  * 900_debcontrol.vim.diff: Add restricted, universe, and multiverse to
    debcontrolSection.
  * debian/rules (make_patch): Ignore error code from diff, since it'll
    normally be non-zero.
  * 900_debcontrol.vim.diff: Add amd64 to debcontrolArchitecture.
  * 901_debchangelog.vim.diff: Add warty and hoary to debchangelogTarget.
  * Fix changelog ordering.
  * Resynchronise with Debian.
  * Norbert Tretkowski <nobse@debian.org>:
    + really add Brandens patch which adds XXX and FIXME comment hilighting
      to sh.vim (closes: #280471)
    + updated debcontrol.vim syntax file, which adds debcontrolArchitecture
      for s390, thanks to Gerfried Fuchs (closes: #281127)
  * Norbert Tretkowski <nobse@debian.org>:
    + fixed broken vim-doc.preinst (closes: #280824, #280825)
  * Norbert Tretkowski <nobse@debian.org>:
    + new upstream patches (026 to 031), see README.gz for details
    + add symlink replacing from vim-common also to vim-doc (closes: #279058)
    + added a new patch which adds XXX and FIXME comment hilighting to sh.vim,
      thanks to Branden Robinson (closes: #280471)
    + added a new patch which allows multiple spaces as arguments for xxd,
      thanks to Glyn Kennington (closes: #279709)
    + updated tpp and debcontrol syntax files, thanks to Gerfried Fuchs

applied/ubuntu/hoary 2005-12-20 21:55:30 UTC 2005-12-20
Import patches-applied version 1:6.3-046+1ubuntu7 to applied/ubuntu/hoary

Author: Jonathan Riddell
Author Date: 2005-04-03 12:09:32 UTC

Import patches-applied version 1:6.3-046+1ubuntu7 to applied/ubuntu/hoary

Imported using git-ubuntu import.

Changelog parent: 1e78a240a45df087681f49bb7880ef1a1e0cc118
Unapplied parent: af2bb02d924ca8039726762992c4d31958b612e5

New changelog entries:
  * Ensure kubuntu_01_xdg_menus.diff is not applied before uploading.
  * Add kubuntu_01_xdg_menus.diff to make kvim menu entry XDG compliant.
  * Revert KDE removal, thus making the kvim package actually have useful
    content rather than just a broken diversion of vim. kvim-ruby is still
    skipped.
  * Drop editor alternative priority to 35, since Ubuntu installs vim by
    default (closes: Ubuntu #4710).
  * Don't autoindent by default (Ubuntu: #5602)
  * SECURITY UPDATE: fix insecure temporary files
  * Added patch 104_secure_tempfiles.diff: use mktemp instead of insecure $$
    construction to create temporary files in vimspell.sh and tcltags.sh
  * References:
    CAN-2005-0069
    http://bugs.debian.org/289560
  * Resynchronise with Debian.
  * debian/vim-variant.desktop: Disable menu item again.
  * Norbert Tretkowski <nobse@debian.org>:
    + new upstream patches (032 to 046), see README.gz for details
    + added a desktop entry under /usr/share/applications/ for all variants
      (closes: #285065)
    + added farsi fonts to vim-common package (closes: #258773)
  * Rebuild with python2.4.
  * 900_debcontrol.vim.diff: Add restricted, universe, and multiverse to
    debcontrolSection.
  * debian/rules (make_patch): Ignore error code from diff, since it'll
    normally be non-zero.
  * 900_debcontrol.vim.diff: Add amd64 to debcontrolArchitecture.
  * 901_debchangelog.vim.diff: Add warty and hoary to debchangelogTarget.
  * Fix changelog ordering.
  * Resynchronise with Debian.
  * Norbert Tretkowski <nobse@debian.org>:
    + really add Brandens patch which adds XXX and FIXME comment hilighting
      to sh.vim (closes: #280471)
    + updated debcontrol.vim syntax file, which adds debcontrolArchitecture
      for s390, thanks to Gerfried Fuchs (closes: #281127)
  * Norbert Tretkowski <nobse@debian.org>:
    + fixed broken vim-doc.preinst (closes: #280824, #280825)
  * Norbert Tretkowski <nobse@debian.org>:
    + new upstream patches (026 to 031), see README.gz for details
    + add symlink replacing from vim-common also to vim-doc (closes: #279058)
    + added a new patch which adds XXX and FIXME comment hilighting to sh.vim,
      thanks to Branden Robinson (closes: #280471)
    + added a new patch which allows multiple spaces as arguments for xxd,
      thanks to Glyn Kennington (closes: #279709)
    + updated tpp and debcontrol syntax files, thanks to Gerfried Fuchs

ubuntu/warty-security 2005-12-20 20:16:35 UTC 2005-12-20
Import patches-unapplied version 1:6.3-025+1ubuntu2.3 to ubuntu/warty-security

Author: Martin Pitt
Author Date: 2005-07-26 11:51:13 UTC

Import patches-unapplied version 1:6.3-025+1ubuntu2.3 to ubuntu/warty-security

Imported using git-ubuntu import.

Changelog parent: ee418f37425ff5d205b2a1534e7960aa9aee66e4

New changelog entries:
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/06_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html
  * SECURITY UPDATE: fix insecure temporary files
  * Added patch 05_secure_tempfiles.diff: use mktemp instead of insecure $$
    construction to create temporary files in vimspell.sh and tcltags
  * References:
    CAN-2005-0069
    http://bugs.debian.org/289560
  * [SECURITY] Unusual characters in an option value may cause unexpected
               behavior, especially for a modeline (Ciaran McCreesh):
    - Add patch: 04_CAN-2004-1138.diff.
    (CAN-2004-1138)

applied/ubuntu/warty-devel 2005-12-20 20:16:35 UTC 2005-12-20
Import patches-applied version 1:6.3-025+1ubuntu2.3 to applied/ubuntu/warty-s...

Author: Martin Pitt
Author Date: 2005-07-26 11:51:13 UTC

Import patches-applied version 1:6.3-025+1ubuntu2.3 to applied/ubuntu/warty-security

Imported using git-ubuntu import.

Changelog parent: 1e78a240a45df087681f49bb7880ef1a1e0cc118
Unapplied parent: b08e031858c1064ec085f8a7fe9a8ab7c267a28a

New changelog entries:
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/06_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html
  * SECURITY UPDATE: fix insecure temporary files
  * Added patch 05_secure_tempfiles.diff: use mktemp instead of insecure $$
    construction to create temporary files in vimspell.sh and tcltags
  * References:
    CAN-2005-0069
    http://bugs.debian.org/289560
  * [SECURITY] Unusual characters in an option value may cause unexpected
               behavior, especially for a modeline (Ciaran McCreesh):
    - Add patch: 04_CAN-2004-1138.diff.
    (CAN-2004-1138)

ubuntu/warty-devel 2005-12-20 20:16:35 UTC 2005-12-20
Import patches-unapplied version 1:6.3-025+1ubuntu2.3 to ubuntu/warty-security

Author: Martin Pitt
Author Date: 2005-07-26 11:51:13 UTC

Import patches-unapplied version 1:6.3-025+1ubuntu2.3 to ubuntu/warty-security

Imported using git-ubuntu import.

Changelog parent: ee418f37425ff5d205b2a1534e7960aa9aee66e4

New changelog entries:
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/06_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html
  * SECURITY UPDATE: fix insecure temporary files
  * Added patch 05_secure_tempfiles.diff: use mktemp instead of insecure $$
    construction to create temporary files in vimspell.sh and tcltags
  * References:
    CAN-2005-0069
    http://bugs.debian.org/289560
  * [SECURITY] Unusual characters in an option value may cause unexpected
               behavior, especially for a modeline (Ciaran McCreesh):
    - Add patch: 04_CAN-2004-1138.diff.
    (CAN-2004-1138)

applied/ubuntu/warty-security 2005-12-20 20:16:35 UTC 2005-12-20
Import patches-applied version 1:6.3-025+1ubuntu2.3 to applied/ubuntu/warty-s...

Author: Martin Pitt
Author Date: 2005-07-26 11:51:13 UTC

Import patches-applied version 1:6.3-025+1ubuntu2.3 to applied/ubuntu/warty-security

Imported using git-ubuntu import.

Changelog parent: 1e78a240a45df087681f49bb7880ef1a1e0cc118
Unapplied parent: b08e031858c1064ec085f8a7fe9a8ab7c267a28a

New changelog entries:
  * SECURITY UPDATE: Fix code execution.
  * Add debian/patches/06_modeline_codeexec.diff:
    - Do not execute code in glob() and expand() statements when we read them
      from a modeline.
    - Combined upstream patches 6.3.081 and 6.3.082.
    - References:
      http://www.guninski.com/where_do_you_want_billg_to_go_today_5.html
  * SECURITY UPDATE: fix insecure temporary files
  * Added patch 05_secure_tempfiles.diff: use mktemp instead of insecure $$
    construction to create temporary files in vimspell.sh and tcltags
  * References:
    CAN-2005-0069
    http://bugs.debian.org/289560
  * [SECURITY] Unusual characters in an option value may cause unexpected
               behavior, especially for a modeline (Ciaran McCreesh):
    - Add patch: 04_CAN-2004-1138.diff.
    (CAN-2004-1138)

ubuntu/warty 2005-12-20 16:01:31 UTC 2005-12-20
Import patches-unapplied version 1:6.3-025+1ubuntu2 to ubuntu/warty

Author: Jeff Waugh
Author Date: 2004-10-08 00:04:36 UTC

Import patches-unapplied version 1:6.3-025+1ubuntu2 to ubuntu/warty

Imported using git-ubuntu import.

applied/ubuntu/warty 2005-12-20 16:01:31 UTC 2005-12-20
Import patches-applied version 1:6.3-025+1ubuntu2 to applied/ubuntu/warty

Author: Jeff Waugh
Author Date: 2004-10-08 00:04:36 UTC

Import patches-applied version 1:6.3-025+1ubuntu2 to applied/ubuntu/warty

Imported using git-ubuntu import.

Unapplied parent: ee418f37425ff5d205b2a1534e7960aa9aee66e4

101154 of 154 results

Other repositories

Name Last Modified
lp:ubuntu/+source/vim 2019-11-09
lp:~jbenden/ubuntu/+source/vim 2017-08-31
12 of 2 results
You can't create new repositories for vim in Ubuntu.