View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/ubuntu-core-launcher
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2018-04-17 11:35:45 UTC 2018-04-17
DSC file for 1.0.30ubuntu1

Author: Ubuntu Git Importer
Author Date: 2018-04-17 11:35:45 UTC

DSC file for 1.0.30ubuntu1

importer/debian/dsc 2018-04-17 11:27:21 UTC 2018-04-17
DSC file for 1.0.29+2

Author: Ubuntu Git Importer
Author Date: 2018-04-17 11:27:21 UTC

DSC file for 1.0.29+2

ubuntu/yakkety-proposed 2016-06-22 22:04:11 UTC 2016-06-22
Import patches-unapplied version 1.0.30ubuntu1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-06-22 21:35:33 UTC

Import patches-unapplied version 1.0.30ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 1380722f78f96283963a600fd2e46bc482c6b936

New changelog entries:
  * Fix the Breaks/Replaces, to stop this wreaking havoc on autopkgtest
    testbed upgrades.

ubuntu/yakkety-devel 2016-06-22 22:04:11 UTC 2016-06-22
Import patches-unapplied version 1.0.30ubuntu1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-06-22 21:35:33 UTC

Import patches-unapplied version 1.0.30ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 1380722f78f96283963a600fd2e46bc482c6b936

New changelog entries:
  * Fix the Breaks/Replaces, to stop this wreaking havoc on autopkgtest
    testbed upgrades.

ubuntu/devel 2016-06-22 22:04:11 UTC 2016-06-22
Import patches-unapplied version 1.0.30ubuntu1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-06-22 21:35:33 UTC

Import patches-unapplied version 1.0.30ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 1380722f78f96283963a600fd2e46bc482c6b936

New changelog entries:
  * Fix the Breaks/Replaces, to stop this wreaking havoc on autopkgtest
    testbed upgrades.

ubuntu/yakkety 2016-06-16 06:44:35 UTC 2016-06-16
Import patches-unapplied version 1.0.29+1ubuntu1 to ubuntu/yakkety-proposed

Author: Jamie Strandboge
Author Date: 2016-06-16 06:02:53 UTC

Import patches-unapplied version 1.0.29+1ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 55dcdac4fb27eef5863ad0a4b99c3474738944f2

New changelog entries:
  * debian/usr.bin.ubuntu-core-launcher: add a couple more workaround rules
    for ecryptfs (LP: #1592696)

applied/debian/sid 2016-06-14 10:20:52 UTC 2016-06-14
Import patches-applied version 1.0.29+2 to applied/debian/sid

Author: Steve Langasek
Author Date: 2016-06-13 22:11:07 UTC

Import patches-applied version 1.0.29+2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: fc4293a75e22476cecf4297e2d444cb7d52daa25
Unapplied parent: 3f20a92804d5fcd6e4ac896431b18777037055a3

New changelog entries:
  [ Zygmunt Krynicki ]
  * Rename the package and everything else from ubuntu-core-launcher to
    snap-run
  * Allow for graceful migrations from ubuntu-core-launcher to snap-run by
    providing both commands as binary packages, with proper dependencies and
    post-installation scripts that manage apparmor profile changes.
  * Discard the useless duplicate argument. Now snap-run is invoked with
    'snap-name $SECURITY_TAG $COMMAND...'. Previously, security tag was
    duplicated. In the future this will change once again, so that security
    tag is derived from an argument containing $SNAP_NAME and $APP_NAME.
  * Clean up tests so that shellcheck reports no more errors or warnings
  * Ensure that shellcheck reports no errors on each build
  * Add #DEBHELPER# to maintainer scripts (thanks to lintian)
  * Switch to autotools, build-depend on pkg-config, autotools-dev, autoconf
    and automake (thanks to ogra for the missing bits).
  * Use "dh $@ --with autoreconf" to prepare the build system.
  * Rename executable to snap-confine, to fit the new execution model.
  [ Steve Langasek ]
  * Update Standards-Version.
  * Add lintian override for suid binary.
  [ Zygmunt Krynicki ]
  * Change unreleased version back to 1.0.x after discussion with Michael Vogt.
  * Don't mark ubuntu-core-launcher as transitional (it isn't yet).
  * Move rm_conffile to ubuntu-core-launcher.maintscript, remove the now-empty
    postrm and preinst scripts.
  * Enable hardening options for snap-confine
  * Build-depend on udev, use udevlibdir instead of hardcoding /lib/udev
  [ Steve Langasek ]
  * Don't call --enable-rootfs-is-core-snap on Debian.
  * Build with --disable-confinement for Debian, since Debian apparmor
    support doesn't meet snap requirements.
  * Revert package rename temporarily, to avoid a NEW roundtrip in Debian.
  * Don't ignore errors from maintainer script.

applied/debian/stretch 2016-06-14 10:20:52 UTC 2016-06-14
Import patches-applied version 1.0.29+2 to applied/debian/sid

Author: Steve Langasek
Author Date: 2016-06-13 22:11:07 UTC

Import patches-applied version 1.0.29+2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: fc4293a75e22476cecf4297e2d444cb7d52daa25
Unapplied parent: 3f20a92804d5fcd6e4ac896431b18777037055a3

New changelog entries:
  [ Zygmunt Krynicki ]
  * Rename the package and everything else from ubuntu-core-launcher to
    snap-run
  * Allow for graceful migrations from ubuntu-core-launcher to snap-run by
    providing both commands as binary packages, with proper dependencies and
    post-installation scripts that manage apparmor profile changes.
  * Discard the useless duplicate argument. Now snap-run is invoked with
    'snap-name $SECURITY_TAG $COMMAND...'. Previously, security tag was
    duplicated. In the future this will change once again, so that security
    tag is derived from an argument containing $SNAP_NAME and $APP_NAME.
  * Clean up tests so that shellcheck reports no more errors or warnings
  * Ensure that shellcheck reports no errors on each build
  * Add #DEBHELPER# to maintainer scripts (thanks to lintian)
  * Switch to autotools, build-depend on pkg-config, autotools-dev, autoconf
    and automake (thanks to ogra for the missing bits).
  * Use "dh $@ --with autoreconf" to prepare the build system.
  * Rename executable to snap-confine, to fit the new execution model.
  [ Steve Langasek ]
  * Update Standards-Version.
  * Add lintian override for suid binary.
  [ Zygmunt Krynicki ]
  * Change unreleased version back to 1.0.x after discussion with Michael Vogt.
  * Don't mark ubuntu-core-launcher as transitional (it isn't yet).
  * Move rm_conffile to ubuntu-core-launcher.maintscript, remove the now-empty
    postrm and preinst scripts.
  * Enable hardening options for snap-confine
  * Build-depend on udev, use udevlibdir instead of hardcoding /lib/udev
  [ Steve Langasek ]
  * Don't call --enable-rootfs-is-core-snap on Debian.
  * Build with --disable-confinement for Debian, since Debian apparmor
    support doesn't meet snap requirements.
  * Revert package rename temporarily, to avoid a NEW roundtrip in Debian.
  * Don't ignore errors from maintainer script.

debian/sid 2016-06-14 10:20:52 UTC 2016-06-14
Import patches-unapplied version 1.0.29+2 to debian/sid

Author: Steve Langasek
Author Date: 2016-06-13 22:11:07 UTC

Import patches-unapplied version 1.0.29+2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 55dcdac4fb27eef5863ad0a4b99c3474738944f2

New changelog entries:
  [ Zygmunt Krynicki ]
  * Rename the package and everything else from ubuntu-core-launcher to
    snap-run
  * Allow for graceful migrations from ubuntu-core-launcher to snap-run by
    providing both commands as binary packages, with proper dependencies and
    post-installation scripts that manage apparmor profile changes.
  * Discard the useless duplicate argument. Now snap-run is invoked with
    'snap-name $SECURITY_TAG $COMMAND...'. Previously, security tag was
    duplicated. In the future this will change once again, so that security
    tag is derived from an argument containing $SNAP_NAME and $APP_NAME.
  * Clean up tests so that shellcheck reports no more errors or warnings
  * Ensure that shellcheck reports no errors on each build
  * Add #DEBHELPER# to maintainer scripts (thanks to lintian)
  * Switch to autotools, build-depend on pkg-config, autotools-dev, autoconf
    and automake (thanks to ogra for the missing bits).
  * Use "dh $@ --with autoreconf" to prepare the build system.
  * Rename executable to snap-confine, to fit the new execution model.
  [ Steve Langasek ]
  * Update Standards-Version.
  * Add lintian override for suid binary.
  [ Zygmunt Krynicki ]
  * Change unreleased version back to 1.0.x after discussion with Michael Vogt.
  * Don't mark ubuntu-core-launcher as transitional (it isn't yet).
  * Move rm_conffile to ubuntu-core-launcher.maintscript, remove the now-empty
    postrm and preinst scripts.
  * Enable hardening options for snap-confine
  * Build-depend on udev, use udevlibdir instead of hardcoding /lib/udev
  [ Steve Langasek ]
  * Don't call --enable-rootfs-is-core-snap on Debian.
  * Build with --disable-confinement for Debian, since Debian apparmor
    support doesn't meet snap requirements.
  * Revert package rename temporarily, to avoid a NEW roundtrip in Debian.
  * Don't ignore errors from maintainer script.

debian/stretch 2016-06-14 10:20:52 UTC 2016-06-14
Import patches-unapplied version 1.0.29+2 to debian/sid

Author: Steve Langasek
Author Date: 2016-06-13 22:11:07 UTC

Import patches-unapplied version 1.0.29+2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 55dcdac4fb27eef5863ad0a4b99c3474738944f2

New changelog entries:
  [ Zygmunt Krynicki ]
  * Rename the package and everything else from ubuntu-core-launcher to
    snap-run
  * Allow for graceful migrations from ubuntu-core-launcher to snap-run by
    providing both commands as binary packages, with proper dependencies and
    post-installation scripts that manage apparmor profile changes.
  * Discard the useless duplicate argument. Now snap-run is invoked with
    'snap-name $SECURITY_TAG $COMMAND...'. Previously, security tag was
    duplicated. In the future this will change once again, so that security
    tag is derived from an argument containing $SNAP_NAME and $APP_NAME.
  * Clean up tests so that shellcheck reports no more errors or warnings
  * Ensure that shellcheck reports no errors on each build
  * Add #DEBHELPER# to maintainer scripts (thanks to lintian)
  * Switch to autotools, build-depend on pkg-config, autotools-dev, autoconf
    and automake (thanks to ogra for the missing bits).
  * Use "dh $@ --with autoreconf" to prepare the build system.
  * Rename executable to snap-confine, to fit the new execution model.
  [ Steve Langasek ]
  * Update Standards-Version.
  * Add lintian override for suid binary.
  [ Zygmunt Krynicki ]
  * Change unreleased version back to 1.0.x after discussion with Michael Vogt.
  * Don't mark ubuntu-core-launcher as transitional (it isn't yet).
  * Move rm_conffile to ubuntu-core-launcher.maintscript, remove the now-empty
    postrm and preinst scripts.
  * Enable hardening options for snap-confine
  * Build-depend on udev, use udevlibdir instead of hardcoding /lib/udev
  [ Steve Langasek ]
  * Don't call --enable-rootfs-is-core-snap on Debian.
  * Build with --disable-confinement for Debian, since Debian apparmor
    support doesn't meet snap requirements.
  * Revert package rename temporarily, to avoid a NEW roundtrip in Debian.
  * Don't ignore errors from maintainer script.

ubuntu/xenial-updates 2016-04-29 16:55:03 UTC 2016-04-29
Import patches-unapplied version 1.0.27.1 to ubuntu/xenial-security

Author: Jamie Strandboge
Author Date: 2016-04-29 15:06:19 UTC

Import patches-unapplied version 1.0.27.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 0ee3faac4a3af4764707cea9490a88484ed535ab

New changelog entries:
  * SECURITY UPDATE: delayed attack snap data theft and privilege escalation
    when using Snappy on traditional Ubuntu (classic) systems (LP: #1576699)
    - src/main.c: remove glob code and hardcode /snap/ubuntu-core/current
      instead. The glob code both used an improper glob and performed an
      incorrect check due to a typo which allowed a snap named ubuntu-core-...
      to be bind mounted into application runtimes instead of the ubuntu-core
      OS snap. Ubuntu Core removed .<origin> and .sideload from the SNAP path
      so the glob can simply be dropped.
    - CVE-2016-1580
  * debian/usr.bin.ubuntu-core-launcher:
    - only allow mounting /snap/ubuntu-core/*/... to safeguard against this in
      the future
    - add lib32 and libx32 to match setup_snappy_os_mounts()

ubuntu/xenial-devel 2016-04-29 16:55:03 UTC 2016-04-29
Import patches-unapplied version 1.0.27.1 to ubuntu/xenial-security

Author: Jamie Strandboge
Author Date: 2016-04-29 15:06:19 UTC

Import patches-unapplied version 1.0.27.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 0ee3faac4a3af4764707cea9490a88484ed535ab

New changelog entries:
  * SECURITY UPDATE: delayed attack snap data theft and privilege escalation
    when using Snappy on traditional Ubuntu (classic) systems (LP: #1576699)
    - src/main.c: remove glob code and hardcode /snap/ubuntu-core/current
      instead. The glob code both used an improper glob and performed an
      incorrect check due to a typo which allowed a snap named ubuntu-core-...
      to be bind mounted into application runtimes instead of the ubuntu-core
      OS snap. Ubuntu Core removed .<origin> and .sideload from the SNAP path
      so the glob can simply be dropped.
    - CVE-2016-1580
  * debian/usr.bin.ubuntu-core-launcher:
    - only allow mounting /snap/ubuntu-core/*/... to safeguard against this in
      the future
    - add lib32 and libx32 to match setup_snappy_os_mounts()

ubuntu/xenial-security 2016-04-29 16:55:03 UTC 2016-04-29
Import patches-unapplied version 1.0.27.1 to ubuntu/xenial-security

Author: Jamie Strandboge
Author Date: 2016-04-29 15:06:19 UTC

Import patches-unapplied version 1.0.27.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 0ee3faac4a3af4764707cea9490a88484ed535ab

New changelog entries:
  * SECURITY UPDATE: delayed attack snap data theft and privilege escalation
    when using Snappy on traditional Ubuntu (classic) systems (LP: #1576699)
    - src/main.c: remove glob code and hardcode /snap/ubuntu-core/current
      instead. The glob code both used an improper glob and performed an
      incorrect check due to a typo which allowed a snap named ubuntu-core-...
      to be bind mounted into application runtimes instead of the ubuntu-core
      OS snap. Ubuntu Core removed .<origin> and .sideload from the SNAP path
      so the glob can simply be dropped.
    - CVE-2016-1580
  * debian/usr.bin.ubuntu-core-launcher:
    - only allow mounting /snap/ubuntu-core/*/... to safeguard against this in
      the future
    - add lib32 and libx32 to match setup_snappy_os_mounts()

ubuntu/xenial-proposed 2016-04-15 21:49:01 UTC 2016-04-15
Import patches-unapplied version 1.0.27 to ubuntu/xenial-proposed

Author: Jamie Strandboge
Author Date: 2016-04-15 20:22:05 UTC

Import patches-unapplied version 1.0.27 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 647abf1b616232528b9400ed23fe80274612a11f

New changelog entries:
  * src/main.c:
    - don't prepend snap. or snap_ since snapd is doing that for us now
      (LP: #1571048)
    - make whitelist_re strictly follow the 16.04 specification and adjust
      testsuite accordingly
  * debian/usr.bin.ubuntu-core-launcher: add locale and gconv reads for tr
  * src/main.c: allow caps in appname (LP: #1570914)

ubuntu/xenial 2016-04-15 21:49:01 UTC 2016-04-15
Import patches-unapplied version 1.0.27 to ubuntu/xenial-proposed

Author: Jamie Strandboge
Author Date: 2016-04-15 20:22:05 UTC

Import patches-unapplied version 1.0.27 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 647abf1b616232528b9400ed23fe80274612a11f

New changelog entries:
  * src/main.c:
    - don't prepend snap. or snap_ since snapd is doing that for us now
      (LP: #1571048)
    - make whitelist_re strictly follow the 16.04 specification and adjust
      testsuite accordingly
  * debian/usr.bin.ubuntu-core-launcher: add locale and gconv reads for tr
  * src/main.c: allow caps in appname (LP: #1570914)

ubuntu/wily 2015-08-19 13:38:37 UTC 2015-08-19
Import patches-unapplied version 1.0.9 to ubuntu/wily-proposed

Author: Jamie Strandboge
Author Date: 2015-08-19 13:16:53 UTC

Import patches-unapplied version 1.0.9 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 8e6dd6e5d7bbf118acfa6cea673ead5ea8fc43e7

New changelog entries:
  * debian/usr.bin.ubuntu-core-launcher: add rw for /dev/null, /dev/full and
    /dev/zero

ubuntu/wily-devel 2015-08-19 13:38:37 UTC 2015-08-19
Import patches-unapplied version 1.0.9 to ubuntu/wily-proposed

Author: Jamie Strandboge
Author Date: 2015-08-19 13:16:53 UTC

Import patches-unapplied version 1.0.9 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 8e6dd6e5d7bbf118acfa6cea673ead5ea8fc43e7

New changelog entries:
  * debian/usr.bin.ubuntu-core-launcher: add rw for /dev/null, /dev/full and
    /dev/zero

ubuntu/wily-proposed 2015-08-19 13:38:37 UTC 2015-08-19
Import patches-unapplied version 1.0.9 to ubuntu/wily-proposed

Author: Jamie Strandboge
Author Date: 2015-08-19 13:16:53 UTC

Import patches-unapplied version 1.0.9 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 8e6dd6e5d7bbf118acfa6cea673ead5ea8fc43e7

New changelog entries:
  * debian/usr.bin.ubuntu-core-launcher: add rw for /dev/null, /dev/full and
    /dev/zero

ubuntu/vivid-devel 2015-04-23 14:18:50 UTC 2015-04-23
Import patches-unapplied version 1.0.1 to ubuntu/vivid-proposed

Author: Michael Vogt
Author Date: 2015-04-23 14:08:26 UTC

Import patches-unapplied version 1.0.1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 4a07707c93b2cbf0cf4d0f0c4debb41b10120294

New changelog entries:
  * fix typo in udev rule
  * add COPYING/copyright headers
  * fix incorrect Vcs-Bzr link

ubuntu/vivid 2015-04-23 14:18:50 UTC 2015-04-23
Import patches-unapplied version 1.0.1 to ubuntu/vivid-proposed

Author: Michael Vogt
Author Date: 2015-04-23 14:08:26 UTC

Import patches-unapplied version 1.0.1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 4a07707c93b2cbf0cf4d0f0c4debb41b10120294

New changelog entries:
  * fix typo in udev rule
  * add COPYING/copyright headers
  * fix incorrect Vcs-Bzr link

ubuntu/vivid-proposed 2015-04-23 14:18:50 UTC 2015-04-23
Import patches-unapplied version 1.0.1 to ubuntu/vivid-proposed

Author: Michael Vogt
Author Date: 2015-04-23 14:08:26 UTC

Import patches-unapplied version 1.0.1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 4a07707c93b2cbf0cf4d0f0c4debb41b10120294

New changelog entries:
  * fix typo in udev rule
  * add COPYING/copyright headers
  * fix incorrect Vcs-Bzr link

applied/ubuntu/devel 2015-04-23 10:03:32 UTC 2015-04-23
Import patches-applied version 1.0 to applied/ubuntu/vivid-proposed

Author: Michael Vogt
Author Date: 2015-04-23 09:05:01 UTC

Import patches-applied version 1.0 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Unapplied parent: 4a07707c93b2cbf0cf4d0f0c4debb41b10120294

applied/ubuntu/vivid-devel 2015-04-23 10:03:32 UTC 2015-04-23
Import patches-applied version 1.0 to applied/ubuntu/vivid-proposed

Author: Michael Vogt
Author Date: 2015-04-23 09:05:01 UTC

Import patches-applied version 1.0 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Unapplied parent: 4a07707c93b2cbf0cf4d0f0c4debb41b10120294

applied/ubuntu/vivid 2015-04-23 10:03:32 UTC 2015-04-23
Import patches-applied version 1.0 to applied/ubuntu/vivid-proposed

Author: Michael Vogt
Author Date: 2015-04-23 09:05:01 UTC

Import patches-applied version 1.0 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Unapplied parent: 4a07707c93b2cbf0cf4d0f0c4debb41b10120294

applied/ubuntu/vivid-proposed 2015-04-23 10:03:32 UTC 2015-04-23
Import patches-applied version 1.0 to applied/ubuntu/vivid-proposed

Author: Michael Vogt
Author Date: 2015-04-23 09:05:01 UTC

Import patches-applied version 1.0 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Unapplied parent: 4a07707c93b2cbf0cf4d0f0c4debb41b10120294

125 of 25 results

Other repositories

Name Last Modified
lp:ubuntu/+source/ubuntu-core-launcher 2018-04-17
11 of 1 result
You can't create new repositories for ubuntu-core-launcher in Ubuntu.