View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/tcpdump
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2018-04-07 19:05:58 UTC 2018-04-07
DSC file for 4.9.2-3

Author: Ubuntu Git Importer
Author Date: 2018-04-07 19:05:58 UTC

DSC file for 4.9.2-3

importer/debian/dsc 2018-04-01 04:43:32 UTC 2018-04-01
DSC file for 4.9.2-3

Author: Ubuntu Git Importer
Author Date: 2018-04-01 04:43:32 UTC

DSC file for 4.9.2-3

ubuntu/cosmic 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/debian/buster 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

ubuntu/disco-devel 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

debian/sid 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/ubuntu/disco 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/ubuntu/bionic 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/debian/sid 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/ubuntu/cosmic-devel 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

debian/buster 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/ubuntu/cosmic 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

ubuntu/cosmic-devel 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/ubuntu/devel 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

ubuntu/devel 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

ubuntu/bionic 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

ubuntu/bionic-proposed 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

ubuntu/disco 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/ubuntu/disco-devel 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/ubuntu/bionic-proposed 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

applied/ubuntu/bionic-devel 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-applied version 4.9.2-3 to applied/debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-applied version 4.9.2-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 849be17be14624fccdab89b5ed6c5d2ca27ede84
Unapplied parent: 7d2d1ef8642c25f195eafdb0a31e31676ec41b98

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

ubuntu/bionic-devel 2018-04-01 04:39:40 UTC 2018-04-01
Import patches-unapplied version 4.9.2-3 to debian/sid

Author: Romain Francoise
Author Date: 2018-03-31 20:22:36 UTC

Import patches-unapplied version 4.9.2-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ee5c9d0841f2f74f847d99631e961063eff94d7

New changelog entries:
  [ Jamie Strandboge ]
  * debian/usr.sbin.tcpdump: drop 'capability sys_module' since we already
    have 'net_admin' and network module loading (which happens with -D) is
    allowed with 'net_admin' (LP: #1759029) (closes: #894161)
  [ Romain Francoise ]
  * Switch to debhelper compatibility level 11.
  * Bump Standards-Version to 4.1.3.

importer/ubuntu/pristine-tar 2018-03-09 13:48:15 UTC 2018-03-09
pristine-tar data for tcpdump_4.9.2.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-09 13:48:15 UTC

pristine-tar data for tcpdump_4.9.2.orig.tar.gz

importer/debian/pristine-tar 2018-03-09 13:26:23 UTC 2018-03-09
pristine-tar data for tcpdump_4.9.2.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-09 13:26:23 UTC

pristine-tar data for tcpdump_4.9.2.orig.tar.gz

applied/debian/jessie 2017-12-09 17:57:27 UTC 2017-12-09
Import patches-applied version 4.9.2-1~deb8u1 to applied/debian/jessie

Author: Romain Francoise
Author Date: 2017-09-09 19:39:47 UTC

Import patches-applied version 4.9.2-1~deb8u1 to applied/debian/jessie

Imported using git-ubuntu import.

Changelog parent: 11e808b40c7860ad10168c54a2263bedbb7fda0e
Unapplied parent: e8fefdc6db3a96feb61eb735a2ff93969ccfc14e

New changelog entries:
  * New upstream release, fixing 90 new CVEs. See the upstream changelog
    for the full list (closes: #867718, #873804, #873805, #873806).

debian/jessie 2017-12-09 17:57:27 UTC 2017-12-09
Import patches-unapplied version 4.9.2-1~deb8u1 to debian/jessie

Author: Romain Francoise
Author Date: 2017-09-09 19:39:47 UTC

Import patches-unapplied version 4.9.2-1~deb8u1 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: 046c67e08764db3647a0521f3bbdab1e02dede7f

New changelog entries:
  * New upstream release, fixing 90 new CVEs. See the upstream changelog
    for the full list (closes: #867718, #873804, #873805, #873806).

applied/debian/stretch 2017-10-07 11:11:40 UTC 2017-10-07
Import patches-applied version 4.9.2-1~deb9u1 to applied/debian/stretch

Author: Romain Francoise
Author Date: 2017-09-09 18:33:48 UTC

Import patches-applied version 4.9.2-1~deb9u1 to applied/debian/stretch

Imported using git-ubuntu import.

Changelog parent: 63c10ac106eeeff9935f3281f4d5c30fef10b895
Unapplied parent: afa2682218c66e05fcb1704c5377faa85ef88ea8

New changelog entries:
  * New upstream release, fixing 90 new CVEs. See the upstream changelog
    for the full list (closes: #867718, #873804, #873805, #873806).

debian/stretch 2017-10-07 11:11:40 UTC 2017-10-07
Import patches-unapplied version 4.9.2-1~deb9u1 to debian/stretch

Author: Romain Francoise
Author Date: 2017-09-09 18:33:48 UTC

Import patches-unapplied version 4.9.2-1~deb9u1 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: b5220d3795d2bb8285d9ab7810b6c63b10c8f7f2

New changelog entries:
  * New upstream release, fixing 90 new CVEs. See the upstream changelog
    for the full list (closes: #867718, #873804, #873805, #873806).

ubuntu/trusty-devel 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.14.04.1 to ubuntu/trusty-secu...

Author: Steve Beattie
Author Date: 2017-09-13 10:26:05 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.14.04.1 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there in xenial.
      + drop multi-arch: foreign
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/xenial-devel 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.16.04.1 to applied/ubuntu/xenia...

Author: Steve Beattie
Author Date: 2017-09-13 09:29:51 UTC

Import patches-applied version 4.9.2-0ubuntu0.16.04.1 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: 1aef93011e4d6173655b4ee8897ec69be90c54c0

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there.
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/xenial-updates 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.16.04.1 to ubuntu/xenial-secu...

Author: Steve Beattie
Author Date: 2017-09-13 09:29:51 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.16.04.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there.
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/zesty-security 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.17.04.2 to ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-09-13 08:11:24 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.17.04.2 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control: keep dependency on libssl1.0-dev, don't add
      breaks/replaces on apparmor-profiles-extras, as tcpdump profile
      is already dropped from there.
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/xenial-security 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.16.04.1 to applied/ubuntu/xenia...

Author: Steve Beattie
Author Date: 2017-09-13 09:29:51 UTC

Import patches-applied version 4.9.2-0ubuntu0.16.04.1 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: 1aef93011e4d6173655b4ee8897ec69be90c54c0

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there.
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/xenial-security 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.16.04.1 to ubuntu/xenial-secu...

Author: Steve Beattie
Author Date: 2017-09-13 09:29:51 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.16.04.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there.
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/zesty-updates 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.17.04.2 to ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-09-13 08:11:24 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.17.04.2 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control: keep dependency on libssl1.0-dev, don't add
      breaks/replaces on apparmor-profiles-extras, as tcpdump profile
      is already dropped from there.
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/xenial-updates 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.16.04.1 to applied/ubuntu/xenia...

Author: Steve Beattie
Author Date: 2017-09-13 09:29:51 UTC

Import patches-applied version 4.9.2-0ubuntu0.16.04.1 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: 1aef93011e4d6173655b4ee8897ec69be90c54c0

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there.
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/trusty-updates 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.14.04.1 to applied/ubuntu/trust...

Author: Steve Beattie
Author Date: 2017-09-13 10:26:05 UTC

Import patches-applied version 4.9.2-0ubuntu0.14.04.1 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: c362451552ba33f92101ae93c1f0106a28e0d06e

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there in xenial.
      + drop multi-arch: foreign
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/trusty-security 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.14.04.1 to ubuntu/trusty-secu...

Author: Steve Beattie
Author Date: 2017-09-13 10:26:05 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.14.04.1 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there in xenial.
      + drop multi-arch: foreign
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/zesty-devel 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.17.04.2 to applied/ubuntu/zesty...

Author: Steve Beattie
Author Date: 2017-09-13 08:11:24 UTC

Import patches-applied version 4.9.2-0ubuntu0.17.04.2 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: a57aaa8268e623d9b03a4b4b22c6f46ed0a04efd

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control: keep dependency on libssl1.0-dev, don't add
      breaks/replaces on apparmor-profiles-extras, as tcpdump profile
      is already dropped from there.
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/xenial-devel 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.16.04.1 to ubuntu/xenial-secu...

Author: Steve Beattie
Author Date: 2017-09-13 09:29:51 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.16.04.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there.
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/trusty-security 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.14.04.1 to applied/ubuntu/trust...

Author: Steve Beattie
Author Date: 2017-09-13 10:26:05 UTC

Import patches-applied version 4.9.2-0ubuntu0.14.04.1 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: c362451552ba33f92101ae93c1f0106a28e0d06e

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there in xenial.
      + drop multi-arch: foreign
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/trusty-devel 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.14.04.1 to applied/ubuntu/trust...

Author: Steve Beattie
Author Date: 2017-09-13 10:26:05 UTC

Import patches-applied version 4.9.2-0ubuntu0.14.04.1 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: c362451552ba33f92101ae93c1f0106a28e0d06e

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there in xenial.
      + drop multi-arch: foreign
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/zesty-devel 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.17.04.2 to ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-09-13 08:11:24 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.17.04.2 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control: keep dependency on libssl1.0-dev, don't add
      breaks/replaces on apparmor-profiles-extras, as tcpdump profile
      is already dropped from there.
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/trusty-updates 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-unapplied version 4.9.2-0ubuntu0.14.04.1 to ubuntu/trusty-secu...

Author: Steve Beattie
Author Date: 2017-09-13 10:26:05 UTC

Import patches-unapplied version 4.9.2-0ubuntu0.14.04.1 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 4a171711140646f460f36be9b92155efb78f4909

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control:
      + keep older libpcap0.8-dev dependency
      + don't add breaks/replaces on apparmor-profiles-extras, as
        tcpdump profile is already dropped from there in xenial.
      + drop multi-arch: foreign
    - debian/patches/disable_tests.diff: disable additional tests
      failing with older pcap versions
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/zesty-security 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.17.04.2 to applied/ubuntu/zesty...

Author: Steve Beattie
Author Date: 2017-09-13 08:11:24 UTC

Import patches-applied version 4.9.2-0ubuntu0.17.04.2 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: a57aaa8268e623d9b03a4b4b22c6f46ed0a04efd

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control: keep dependency on libssl1.0-dev, don't add
      breaks/replaces on apparmor-profiles-extras, as tcpdump profile
      is already dropped from there.
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

applied/ubuntu/zesty-updates 2017-09-13 22:18:24 UTC 2017-09-13
Import patches-applied version 4.9.2-0ubuntu0.17.04.2 to applied/ubuntu/zesty...

Author: Steve Beattie
Author Date: 2017-09-13 08:11:24 UTC

Import patches-applied version 4.9.2-0ubuntu0.17.04.2 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 9b53f75bb1260ccc35a00282951a41fbcd78738c
Unapplied parent: a57aaa8268e623d9b03a4b4b22c6f46ed0a04efd

New changelog entries:
  * SECURITY UPDATE: multiple security issues in tcpdump
    - CVE-2017-13011: buffer overflow in util-print.c:
      bittok2str_internal().
    - CVE-2017-12989: RESP parser infinite loop in print-resp.c:
      resp_get_length().
    - CVE-2017-12990: ISAKMP parser infinite loops in print-isakmp.c,
      several functions.
    - CVE-2017-12995 DNS parser infinite loop in print-domain.c:
      ns_print().
    - CVE-2017-12997: LLDP parser infinite loop in print-lldp.c:
      lldp_private_8021_print().
    - CVE-2017-12893: buffer over-read in smbutil.c:name_len().
    - CVE-2017-12894: buffer over-read in addrtoname.c:
      lookup_bytestring().
    - CVE-2017-12895: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-12896: buffer over-read in print-isakmp.c:
      isakmp_rfc3948_print().
    - CVE-2017-12897: buffer over-read in print-isoclns.c:
      isoclns_print().
    - CVE-2017-12898: buffer over-read in print-nfs.c:interp_reply().
    - CVE-2017-12899: buffer over-read in print-decnet.c:
      decnet_print().
    - CVE-2017-12900: buffer over-read in util-print.c:tok2strbuf().
    - CVE-2017-12901: buffer over-read in print-eigrp.c:eigrp_print().
    - CVE-2017-12902: buffer over-read in print-zephyr.c, several
      functions.
    - CVE-2017-12985: buffer over-read in print-ip6.c:ip6_print().
    - CVE-2017-12986: buffer over-read in print-rt6.c:rt6_print().
    - CVE-2017-12987: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-12988: buffer over-read in print-telnet.c:
      telnet_parse().
    - CVE-2017-12991: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12992: buffer over-read in print-ripng.c:ripng_print().
    - CVE-2017-12993: buffer over-read in print-juniper.c, several
      functions.
    - CVE-2017-12994: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-12996: buffer over-read in print-pim.c:pimv2_print().
    - CVE-2017-12998: buffer over-read in print-isoclns.c:
      isis_print_extd_ip_reach().
    - CVE-2017-12999: buffer over-read in print-isoclns.c:isis_print().
    - CVE-2017-13000: buffer over-read in print-802_15_4.c:
      ieee802_15_4_if_print().
    - CVE-2017-13001: buffer over-read in print-nfs.c:nfs_printfh().
    - CVE-2017-13002: buffer over-read in print-aodv.c:
      aodv_extension().
    - CVE-2017-13003: buffer over-read in print-lmp.c:lmp_print().
    - CVE-2017-13004: buffer over-read in print-juniper.c:
      juniper_parse_header().
    - CVE-2017-13005: buffer over-read in print-nfs.c:xid_map_enter().
    - CVE-2017-13006: buffer over-read in print-l2tp.c, several
      functions.
    - CVE-2017-13007: buffer over-read in print-pktap.c:
      pktap_if_print().
    - CVE-2017-13008: buffer over-read in print-802_11.c:
      parse_elements().
    - CVE-2017-13009: buffer over-read in print-mobility.c:
      mobility_print().
    - CVE-2017-13010: buffer over-read in print-beep.c:l_strnstart().
    - CVE-2017-13012: buffer over-read in print-icmp.c:icmp_print().
    - CVE-2017-13013: buffer over-read in print-arp.c, several
      functions.
    - CVE-2017-13014: buffer over-read in print-wb.c:wb_prep(), several
      functions.
    - CVE-2017-13015: buffer over-read in print-eap.c:eap_print().
    - CVE-2017-13016: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13017: buffer over-read in print-dhcp6.c:
      dhcp6opt_print().
    - CVE-2017-13018: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13019: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13020: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13021: buffer over-read in print-icmp6.c:icmp6_print().
    - CVE-2017-13022: buffer over-read in print-ip.c:ip_printroute().
    - CVE-2017-13023, CVE-2017-13024, CVE-2017-13025: multiple buffer
      over-reads in print-mobility.c:mobility_opt_print().
    - CVE-2017-13026: buffer over-read in print-isoclns.c, several functions.
    - CVE-2017-13027: buffer over-read in print-lldp.c:
      lldp_mgmt_addr_tlv_print().
    - CVE-2017-13028: buffer over-read in print-bootp.c:bootp_print().
    - CVE-2017-13029: buffer over-read in print-ppp.c:
      print_ccp_config_options().
    - CVE-2017-13030: buffer over-read in print-pim.c, several functions.
    - CVE-2017-13031: buffer over-read in print-frag6.c:frag6_print().
    - CVE-2017-13032: buffer over-read in print-radius.c:print_attr_string().
    - CVE-2017-13033: buffer over-read in print-vtp.c:vtp_print().
    - CVE-2017-13034: buffer over-read in print-pgm.c:pgm_print().
    - CVE-2017-13035: buffer over-read in print-isoclns.c:isis_print_id().
    - CVE-2017-13036: buffer over-read in print-ospf6.c:ospf6_decode_v3().
    - CVE-2017-13037: buffer over-read in print-ip.c:ip_printts().
    - CVE-2017-13038: buffer over-read in print-ppp.c:handle_mlppp().
    - CVE-2017-13039: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13040: buffer over-read in print-mptcp.c, several
      functions.
    - CVE-2017-13041: buffer over-read in print-icmp6.c:
      icmp6_nodeinfo_print().
    - CVE-2017-13042: buffer over-read in print-hncp.c:dhcpv6_print().
    - CVE-2017-13043: buffer over-read in print-bgp.c:
      decode_multicast_vpn().
    - CVE-2017-13044: buffer over-read in print-hncp.c:dhcpv4_print().
    - CVE-2017-13045: buffer over-read in print-vqp.c:vqp_print().
    - CVE-2017-13046: buffer over-read in print-bgp.c:bgp_attr_print().
    - CVE-2017-13047: buffer over-read in print-isoclns.c:esis_print().
    - CVE-2017-13048: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13049: buffer over-read in print-rx.c:ubik_print().
    - CVE-2017-13050: buffer over-read in print-rpki-rtr.c:
      rpki_rtr_pdu_print().
    - CVE-2017-13051: buffer over-read in print-rsvp.c:
      rsvp_obj_print().
    - CVE-2017-13052: buffer over-read in print-cfm.c:cfm_print().
    - CVE-2017-13053: buffer over-read in print-bgp.c:
      decode_rt_routing_info().
    - CVE-2017-13054: buffer over-read in print-lldp.c:
      lldp_private_8023_print().
    - CVE-2017-13055: buffer over-read in print-isoclns.c:
      isis_print_is_reach_subtlv().
    - CVE-2017-13687: buffer over-read in print-chdlc.c:chdlc_print().
    - CVE-2017-13688: buffer over-read in print-olsr.c:olsr_print().
    - CVE-2017-13689: buffer over-read in print-isakmp.c:
      ikev1_id_print().
    - CVE-2017-13690: buffer over-read in print-isakmp.c, several
      functions.
    - CVE-2017-13725: buffer over-read in print-rt6.c:rt6_print().
  * Merge from Debian unstable. Remaining changes:
    - debian/control: keep dependency on libssl1.0-dev, don't add
      breaks/replaces on apparmor-profiles-extras, as tcpdump profile
      is already dropped from there.
    - debian/patches/90_man_apparmor.diff: mention apparmor profile
    - debian/tcpdump.dirs: for apparmor force-complain dir

ubuntu/artful 2017-09-09 04:35:50 UTC 2017-09-09
Import patches-unapplied version 4.9.2-1 to debian/sid

Author: Romain Francoise
Author Date: 2017-09-08 19:30:47 UTC

Import patches-unapplied version 4.9.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8a821b45000b44bf2c2f4c4cd70b80d1ee354529

New changelog entries:
  * New upstream release:
    + Fixes 86 new CVEs, see the upstream changelog for the full list.
    + Now supports OpenSSL 1.1, so move back to libssl-dev (closes: #859740).
  * Urgency high due to security fixes.

ubuntu/artful-devel 2017-09-09 04:35:50 UTC 2017-09-09
Import patches-unapplied version 4.9.2-1 to debian/sid

Author: Romain Francoise
Author Date: 2017-09-08 19:30:47 UTC

Import patches-unapplied version 4.9.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8a821b45000b44bf2c2f4c4cd70b80d1ee354529

New changelog entries:
  * New upstream release:
    + Fixes 86 new CVEs, see the upstream changelog for the full list.
    + Now supports OpenSSL 1.1, so move back to libssl-dev (closes: #859740).
  * Urgency high due to security fixes.

ubuntu/artful-proposed 2017-09-09 04:35:50 UTC 2017-09-09
Import patches-unapplied version 4.9.2-1 to debian/sid

Author: Romain Francoise
Author Date: 2017-09-08 19:30:47 UTC

Import patches-unapplied version 4.9.2-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8a821b45000b44bf2c2f4c4cd70b80d1ee354529

New changelog entries:
  * New upstream release:
    + Fixes 86 new CVEs, see the upstream changelog for the full list.
    + Now supports OpenSSL 1.1, so move back to libssl-dev (closes: #859740).
  * Urgency high due to security fixes.

applied/ubuntu/artful-devel 2017-09-09 04:35:50 UTC 2017-09-09
Import patches-applied version 4.9.2-1 to applied/debian/sid

Author: Romain Francoise
Author Date: 2017-09-08 19:30:47 UTC

Import patches-applied version 4.9.2-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: eca861c344b08bf41ff980f705e00e7418741bff
Unapplied parent: f15194871284fdd78a70af77d4331310c3537d12

New changelog entries:
  * New upstream release:
    + Fixes 86 new CVEs, see the upstream changelog for the full list.
    + Now supports OpenSSL 1.1, so move back to libssl-dev (closes: #859740).
  * Urgency high due to security fixes.

applied/ubuntu/artful-proposed 2017-09-09 04:35:50 UTC 2017-09-09
Import patches-applied version 4.9.2-1 to applied/debian/sid

Author: Romain Francoise
Author Date: 2017-09-08 19:30:47 UTC

Import patches-applied version 4.9.2-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: eca861c344b08bf41ff980f705e00e7418741bff
Unapplied parent: f15194871284fdd78a70af77d4331310c3537d12

New changelog entries:
  * New upstream release:
    + Fixes 86 new CVEs, see the upstream changelog for the full list.
    + Now supports OpenSSL 1.1, so move back to libssl-dev (closes: #859740).
  * Urgency high due to security fixes.

applied/ubuntu/artful 2017-09-09 04:35:50 UTC 2017-09-09
Import patches-applied version 4.9.2-1 to applied/debian/sid

Author: Romain Francoise
Author Date: 2017-09-08 19:30:47 UTC

Import patches-applied version 4.9.2-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: eca861c344b08bf41ff980f705e00e7418741bff
Unapplied parent: f15194871284fdd78a70af77d4331310c3537d12

New changelog entries:
  * New upstream release:
    + Fixes 86 new CVEs, see the upstream changelog for the full list.
    + Now supports OpenSSL 1.1, so move back to libssl-dev (closes: #859740).
  * Urgency high due to security fixes.

ubuntu/zesty-proposed 2017-02-24 07:28:27 UTC 2017-02-24
Import patches-unapplied version 4.9.0-2ubuntu2 to ubuntu/zesty-proposed

Author: Gianfranco Costamagna
Author Date: 2017-02-24 07:22:12 UTC

Import patches-unapplied version 4.9.0-2ubuntu2 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 5d97819a79367e4303c4b2533b86de25886f80b2

New changelog entries:
  [ Intrigeri ]
  * Support apparmor profiles for merged /usr systems
    (LP: #1647188)

applied/ubuntu/zesty-proposed 2017-02-24 07:28:27 UTC 2017-02-24
Import patches-applied version 4.9.0-2ubuntu2 to applied/ubuntu/zesty-proposed

Author: Gianfranco Costamagna
Author Date: 2017-02-24 07:22:12 UTC

Import patches-applied version 4.9.0-2ubuntu2 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 559ba6acffe503451b6963e3cf0d8fba7f72d4c5
Unapplied parent: 33b4f51e46525baa8513850b7ba52d9de888daad

New changelog entries:
  [ Intrigeri ]
  * Support apparmor profiles for merged /usr systems
    (LP: #1647188)

applied/ubuntu/zesty 2017-02-24 07:28:27 UTC 2017-02-24
Import patches-applied version 4.9.0-2ubuntu2 to applied/ubuntu/zesty-proposed

Author: Gianfranco Costamagna
Author Date: 2017-02-24 07:22:12 UTC

Import patches-applied version 4.9.0-2ubuntu2 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 559ba6acffe503451b6963e3cf0d8fba7f72d4c5
Unapplied parent: 33b4f51e46525baa8513850b7ba52d9de888daad

New changelog entries:
  [ Intrigeri ]
  * Support apparmor profiles for merged /usr systems
    (LP: #1647188)

ubuntu/zesty 2017-02-24 07:28:27 UTC 2017-02-24
Import patches-unapplied version 4.9.0-2ubuntu2 to ubuntu/zesty-proposed

Author: Gianfranco Costamagna
Author Date: 2017-02-24 07:22:12 UTC

Import patches-unapplied version 4.9.0-2ubuntu2 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 5d97819a79367e4303c4b2533b86de25886f80b2

New changelog entries:
  [ Intrigeri ]
  * Support apparmor profiles for merged /usr systems
    (LP: #1647188)

applied/ubuntu/precise-updates 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-applied version 4.9.0-1ubuntu1~ubuntu12.04.1 to applied/ubuntu...

Author: Marc Deslauriers
Author Date: 2017-02-21 13:26:01 UTC

Import patches-applied version 4.9.0-1ubuntu1~ubuntu12.04.1 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: e582343d0651a880e0a9f977be4b051cb8602629
Unapplied parent: b90d0fd9f11f05c1dbd86d9ac95c4d25aa560191

New changelog entries:
  [ Gianfranco Costamagna ]
  * Backport to precise to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to precise version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

applied/ubuntu/precise-security 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-applied version 4.9.0-1ubuntu1~ubuntu12.04.1 to applied/ubuntu...

Author: Marc Deslauriers
Author Date: 2017-02-21 13:26:01 UTC

Import patches-applied version 4.9.0-1ubuntu1~ubuntu12.04.1 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: e582343d0651a880e0a9f977be4b051cb8602629
Unapplied parent: b90d0fd9f11f05c1dbd86d9ac95c4d25aa560191

New changelog entries:
  [ Gianfranco Costamagna ]
  * Backport to precise to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to precise version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

applied/ubuntu/precise-devel 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-applied version 4.9.0-1ubuntu1~ubuntu12.04.1 to applied/ubuntu...

Author: Marc Deslauriers
Author Date: 2017-02-21 13:26:01 UTC

Import patches-applied version 4.9.0-1ubuntu1~ubuntu12.04.1 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: e582343d0651a880e0a9f977be4b051cb8602629
Unapplied parent: b90d0fd9f11f05c1dbd86d9ac95c4d25aa560191

New changelog entries:
  [ Gianfranco Costamagna ]
  * Backport to precise to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to precise version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

ubuntu/precise-updates 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu12.04.1 to ubuntu/preci...

Author: Marc Deslauriers
Author Date: 2017-02-21 13:26:01 UTC

Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu12.04.1 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: dc3f42a6cc582015f4511647c3118c7ada5afa6e

New changelog entries:
  [ Gianfranco Costamagna ]
  * Backport to precise to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to precise version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

ubuntu/yakkety-security 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu16.10.1 to ubuntu/yakke...

Author: Gianfranco Costamagna
Author Date: 2017-02-05 19:39:58 UTC

Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu16.10.1 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: dc3f42a6cc582015f4511647c3118c7ada5afa6e

New changelog entries:
  * Backport to yakkety to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to yakkety version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

applied/ubuntu/yakkety-updates 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-applied version 4.9.0-1ubuntu1~ubuntu16.10.1 to applied/ubuntu...

Author: Gianfranco Costamagna
Author Date: 2017-02-05 19:39:58 UTC

Import patches-applied version 4.9.0-1ubuntu1~ubuntu16.10.1 to applied/ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: e582343d0651a880e0a9f977be4b051cb8602629
Unapplied parent: e4d55fe57d17bd8a10f5721e2a1c258336300b9b

New changelog entries:
  * Backport to yakkety to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to yakkety version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

applied/ubuntu/yakkety-security 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-applied version 4.9.0-1ubuntu1~ubuntu16.10.1 to applied/ubuntu...

Author: Gianfranco Costamagna
Author Date: 2017-02-05 19:39:58 UTC

Import patches-applied version 4.9.0-1ubuntu1~ubuntu16.10.1 to applied/ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: e582343d0651a880e0a9f977be4b051cb8602629
Unapplied parent: e4d55fe57d17bd8a10f5721e2a1c258336300b9b

New changelog entries:
  * Backport to yakkety to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to yakkety version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

ubuntu/precise-devel 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu12.04.1 to ubuntu/preci...

Author: Marc Deslauriers
Author Date: 2017-02-21 13:26:01 UTC

Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu12.04.1 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: dc3f42a6cc582015f4511647c3118c7ada5afa6e

New changelog entries:
  [ Gianfranco Costamagna ]
  * Backport to precise to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to precise version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

applied/ubuntu/yakkety-devel 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-applied version 4.9.0-1ubuntu1~ubuntu16.10.1 to applied/ubuntu...

Author: Gianfranco Costamagna
Author Date: 2017-02-05 19:39:58 UTC

Import patches-applied version 4.9.0-1ubuntu1~ubuntu16.10.1 to applied/ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: e582343d0651a880e0a9f977be4b051cb8602629
Unapplied parent: e4d55fe57d17bd8a10f5721e2a1c258336300b9b

New changelog entries:
  * Backport to yakkety to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to yakkety version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

ubuntu/yakkety-devel 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu16.10.1 to ubuntu/yakke...

Author: Gianfranco Costamagna
Author Date: 2017-02-05 19:39:58 UTC

Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu16.10.1 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: dc3f42a6cc582015f4511647c3118c7ada5afa6e

New changelog entries:
  * Backport to yakkety to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to yakkety version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

ubuntu/yakkety-updates 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu16.10.1 to ubuntu/yakke...

Author: Gianfranco Costamagna
Author Date: 2017-02-05 19:39:58 UTC

Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu16.10.1 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: dc3f42a6cc582015f4511647c3118c7ada5afa6e

New changelog entries:
  * Backport to yakkety to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to yakkety version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

ubuntu/precise-security 2017-02-21 17:58:22 UTC 2017-02-21
Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu12.04.1 to ubuntu/preci...

Author: Marc Deslauriers
Author Date: 2017-02-21 13:26:01 UTC

Import patches-unapplied version 4.9.0-1ubuntu1~ubuntu12.04.1 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: dc3f42a6cc582015f4511647c3118c7ada5afa6e

New changelog entries:
  [ Gianfranco Costamagna ]
  * Backport to precise to fix CVEs (LP: #1662177).
  * Reset libpcap dependency to precise version
  * Enable crypto support, dropped in zesty because of openssl.
  * Disable some tests failing with older pcap versions

applied/ubuntu/yakkety-proposed 2016-10-13 06:29:55 UTC 2016-10-13
Import patches-applied version 4.7.4-1ubuntu1.16.10.1 to applied/ubuntu/yakke...

Author: Tyler Hicks
Author Date: 2016-10-13 04:58:52 UTC

Import patches-applied version 4.7.4-1ubuntu1.16.10.1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 69ab9a159338d983c676366d3e2ff36389bf7539
Unapplied parent: c3aefc6e4b58e26552d6b8e31a0a202912752345

New changelog entries:
  * debian/usr.sbin.tcpdump: Allow the tcpdump binary to be mapped as required
    by version 4.8 and newer kernels. tcpdump was immediately segfaulting when
    used inside of LXD containers before this AppArmor profile change.
    (LP: #1632399)

ubuntu/yakkety-proposed 2016-10-13 06:29:55 UTC 2016-10-13
Import patches-unapplied version 4.7.4-1ubuntu1.16.10.1 to ubuntu/yakkety-pro...

Author: Tyler Hicks
Author Date: 2016-10-13 04:58:52 UTC

Import patches-unapplied version 4.7.4-1ubuntu1.16.10.1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 4594417a2fbe2056832c01eecde9ca35c4bf4f71

New changelog entries:
  * debian/usr.sbin.tcpdump: Allow the tcpdump binary to be mapped as required
    by version 4.8 and newer kernels. tcpdump was immediately segfaulting when
    used inside of LXD containers before this AppArmor profile change.
    (LP: #1632399)

debian/wheezy 2015-09-05 17:14:18 UTC 2015-09-05
Import patches-unapplied version 4.3.0-1+deb7u2 to debian/wheezy

Author: Romain Francoise
Author Date: 2015-03-16 19:51:18 UTC

Import patches-unapplied version 4.3.0-1+deb7u2 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: c3404027d8d53adad9c305a5535769d1b83819d4

New changelog entries:
  * Cherry-pick changes from upstream Git to fix the following security
    issues:
    + CVE-2015-0261: missing bounds checks in IPv6 Mobility printer.
    + CVE-2015-2153: missing bounds checks in RPKI/RTR printer.
    + CVE-2015-2154: missing bounds checks in ISOCLNS printer.
    + CVE-2015-2155: missing bounds checks in ForCES printer.

applied/debian/wheezy 2015-09-05 17:14:18 UTC 2015-09-05
Import patches-applied version 4.3.0-1+deb7u2 to applied/debian/wheezy

Author: Romain Francoise
Author Date: 2015-03-16 19:51:18 UTC

Import patches-applied version 4.3.0-1+deb7u2 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: d19eb22d6d72e17359731978ef22646628cd8b03
Unapplied parent: 2293387c97b555ef653a2a5054cb88952c62464d

New changelog entries:
  * Cherry-pick changes from upstream Git to fix the following security
    issues:
    + CVE-2015-0261: missing bounds checks in IPv6 Mobility printer.
    + CVE-2015-2153: missing bounds checks in RPKI/RTR printer.
    + CVE-2015-2154: missing bounds checks in ISOCLNS printer.
    + CVE-2015-2155: missing bounds checks in ForCES printer.

ubuntu/wily 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 863c6595ad3679f8b8ffafebffb665fbd71f23da

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

applied/ubuntu/yakkety 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 0cba3656ded16106ac5dda738c0713c5c7c29ca7
Unapplied parent: 38b9dfa7cdf32b008cea7b773a1386669f71ab10

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

applied/ubuntu/xenial 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 0cba3656ded16106ac5dda738c0713c5c7c29ca7
Unapplied parent: 38b9dfa7cdf32b008cea7b773a1386669f71ab10

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

applied/ubuntu/wily-proposed 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 0cba3656ded16106ac5dda738c0713c5c7c29ca7
Unapplied parent: 38b9dfa7cdf32b008cea7b773a1386669f71ab10

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

applied/ubuntu/wily-devel 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 0cba3656ded16106ac5dda738c0713c5c7c29ca7
Unapplied parent: 38b9dfa7cdf32b008cea7b773a1386669f71ab10

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

applied/ubuntu/wily 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-applied version 4.7.4-1ubuntu1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 0cba3656ded16106ac5dda738c0713c5c7c29ca7
Unapplied parent: 38b9dfa7cdf32b008cea7b773a1386669f71ab10

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

ubuntu/wily-devel 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 863c6595ad3679f8b8ffafebffb665fbd71f23da

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

ubuntu/wily-proposed 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 863c6595ad3679f8b8ffafebffb665fbd71f23da

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

ubuntu/yakkety 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 863c6595ad3679f8b8ffafebffb665fbd71f23da

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

ubuntu/xenial 2015-06-02 07:44:27 UTC 2015-06-02
Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Author: Gianfranco Costamagna
Author Date: 2015-05-29 18:13:33 UTC

Import patches-unapplied version 4.7.4-1ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 863c6595ad3679f8b8ffafebffb665fbd71f23da

New changelog entries:
  * Merge from Debian unstable. (LP: #1460170) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
    - Drop 60_cve-2015-2153-fix-regression.diff: upstream

applied/ubuntu/utopic-updates 2015-04-27 15:03:37 UTC 2015-04-27
Import patches-applied version 4.6.2-1ubuntu1.2 to applied/ubuntu/utopic-secu...

Author: Marc Deslauriers
Author Date: 2015-04-24 16:51:00 UTC

Import patches-applied version 4.6.2-1ubuntu1.2 to applied/ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: d02b069ae0df4b8a43e8bb8629e7e44375ec12eb
Unapplied parent: cbd35df22ca5b89074c93ac58190fbdd6ad096e9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    multiple issues (LP: #1444363)
    - debian/patches/60_cve-2015-0261.diff: check lengths in
      print-mobility.c.
    - debian/patches/60_cve-2015-2153.diff: check length in
      print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2153-fix-regression.diff: more length
      checks in print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2154.diff: check lengths in
      print-isoclns.c.
    - debian/patches/60_cve-2015-2155.diff: make sure ops->print is valid
      in print-forces.c.
    - CVE-2015-0261
    - CVE-2015-2153
    - CVE-2015-2154
    - CVE-2015-2155

applied/ubuntu/utopic-security 2015-04-27 15:03:37 UTC 2015-04-27
Import patches-applied version 4.6.2-1ubuntu1.2 to applied/ubuntu/utopic-secu...

Author: Marc Deslauriers
Author Date: 2015-04-24 16:51:00 UTC

Import patches-applied version 4.6.2-1ubuntu1.2 to applied/ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: d02b069ae0df4b8a43e8bb8629e7e44375ec12eb
Unapplied parent: cbd35df22ca5b89074c93ac58190fbdd6ad096e9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    multiple issues (LP: #1444363)
    - debian/patches/60_cve-2015-0261.diff: check lengths in
      print-mobility.c.
    - debian/patches/60_cve-2015-2153.diff: check length in
      print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2153-fix-regression.diff: more length
      checks in print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2154.diff: check lengths in
      print-isoclns.c.
    - debian/patches/60_cve-2015-2155.diff: make sure ops->print is valid
      in print-forces.c.
    - CVE-2015-0261
    - CVE-2015-2153
    - CVE-2015-2154
    - CVE-2015-2155

applied/ubuntu/utopic-devel 2015-04-27 15:03:37 UTC 2015-04-27
Import patches-applied version 4.6.2-1ubuntu1.2 to applied/ubuntu/utopic-secu...

Author: Marc Deslauriers
Author Date: 2015-04-24 16:51:00 UTC

Import patches-applied version 4.6.2-1ubuntu1.2 to applied/ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: d02b069ae0df4b8a43e8bb8629e7e44375ec12eb
Unapplied parent: cbd35df22ca5b89074c93ac58190fbdd6ad096e9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    multiple issues (LP: #1444363)
    - debian/patches/60_cve-2015-0261.diff: check lengths in
      print-mobility.c.
    - debian/patches/60_cve-2015-2153.diff: check length in
      print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2153-fix-regression.diff: more length
      checks in print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2154.diff: check lengths in
      print-isoclns.c.
    - debian/patches/60_cve-2015-2155.diff: make sure ops->print is valid
      in print-forces.c.
    - CVE-2015-0261
    - CVE-2015-2153
    - CVE-2015-2154
    - CVE-2015-2155

ubuntu/utopic-updates 2015-04-27 15:03:37 UTC 2015-04-27
Import patches-unapplied version 4.6.2-1ubuntu1.2 to ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-04-24 16:51:00 UTC

Import patches-unapplied version 4.6.2-1ubuntu1.2 to ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: 5ad00c2c4d9f2ac51aada1cb702712cdacfe8e64

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    multiple issues (LP: #1444363)
    - debian/patches/60_cve-2015-0261.diff: check lengths in
      print-mobility.c.
    - debian/patches/60_cve-2015-2153.diff: check length in
      print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2153-fix-regression.diff: more length
      checks in print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2154.diff: check lengths in
      print-isoclns.c.
    - debian/patches/60_cve-2015-2155.diff: make sure ops->print is valid
      in print-forces.c.
    - CVE-2015-0261
    - CVE-2015-2153
    - CVE-2015-2154
    - CVE-2015-2155

ubuntu/utopic-security 2015-04-27 15:03:37 UTC 2015-04-27
Import patches-unapplied version 4.6.2-1ubuntu1.2 to ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-04-24 16:51:00 UTC

Import patches-unapplied version 4.6.2-1ubuntu1.2 to ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: 5ad00c2c4d9f2ac51aada1cb702712cdacfe8e64

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    multiple issues (LP: #1444363)
    - debian/patches/60_cve-2015-0261.diff: check lengths in
      print-mobility.c.
    - debian/patches/60_cve-2015-2153.diff: check length in
      print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2153-fix-regression.diff: more length
      checks in print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2154.diff: check lengths in
      print-isoclns.c.
    - debian/patches/60_cve-2015-2155.diff: make sure ops->print is valid
      in print-forces.c.
    - CVE-2015-0261
    - CVE-2015-2153
    - CVE-2015-2154
    - CVE-2015-2155

ubuntu/utopic-devel 2015-04-27 15:03:37 UTC 2015-04-27
Import patches-unapplied version 4.6.2-1ubuntu1.2 to ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-04-24 16:51:00 UTC

Import patches-unapplied version 4.6.2-1ubuntu1.2 to ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: 5ad00c2c4d9f2ac51aada1cb702712cdacfe8e64

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    multiple issues (LP: #1444363)
    - debian/patches/60_cve-2015-0261.diff: check lengths in
      print-mobility.c.
    - debian/patches/60_cve-2015-2153.diff: check length in
      print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2153-fix-regression.diff: more length
      checks in print-rpki-rtr.c.
    - debian/patches/60_cve-2015-2154.diff: check lengths in
      print-isoclns.c.
    - debian/patches/60_cve-2015-2155.diff: make sure ops->print is valid
      in print-forces.c.
    - CVE-2015-0261
    - CVE-2015-2153
    - CVE-2015-2154
    - CVE-2015-2155

ubuntu/vivid-proposed 2015-03-26 22:28:52 UTC 2015-03-26
Import patches-unapplied version 4.6.2-4ubuntu1 to ubuntu/vivid-proposed

Author: Artur Rona
Author Date: 2015-03-22 23:42:29 UTC

Import patches-unapplied version 4.6.2-4ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: a8f4be9f411305397cf4aac0f119a9a5bf208c8e

New changelog entries:
  * Merge from Debian unstable. (LP: #1433815) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
  * debian/patches/60_cve-2015-2153-fix-regression.diff:
    - Fix regression due to 60_cve-2015-2153.diff

ubuntu/vivid 2015-03-26 22:28:52 UTC 2015-03-26
Import patches-unapplied version 4.6.2-4ubuntu1 to ubuntu/vivid-proposed

Author: Artur Rona
Author Date: 2015-03-22 23:42:29 UTC

Import patches-unapplied version 4.6.2-4ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: a8f4be9f411305397cf4aac0f119a9a5bf208c8e

New changelog entries:
  * Merge from Debian unstable. (LP: #1433815) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
  * debian/patches/60_cve-2015-2153-fix-regression.diff:
    - Fix regression due to 60_cve-2015-2153.diff

ubuntu/vivid-devel 2015-03-26 22:28:52 UTC 2015-03-26
Import patches-unapplied version 4.6.2-4ubuntu1 to ubuntu/vivid-proposed

Author: Artur Rona
Author Date: 2015-03-22 23:42:29 UTC

Import patches-unapplied version 4.6.2-4ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: a8f4be9f411305397cf4aac0f119a9a5bf208c8e

New changelog entries:
  * Merge from Debian unstable. (LP: #1433815) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
  * debian/patches/60_cve-2015-2153-fix-regression.diff:
    - Fix regression due to 60_cve-2015-2153.diff

applied/ubuntu/vivid-proposed 2015-03-26 22:28:52 UTC 2015-03-26
Import patches-applied version 4.6.2-4ubuntu1 to applied/ubuntu/vivid-proposed

Author: Artur Rona
Author Date: 2015-03-22 23:42:29 UTC

Import patches-applied version 4.6.2-4ubuntu1 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 815a997444d57337e61062046ecdcfc25725a2d2
Unapplied parent: 260b622dfe42ac6912bc279563d6dda7c25dea37

New changelog entries:
  * Merge from Debian unstable. (LP: #1433815) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
  * debian/patches/60_cve-2015-2153-fix-regression.diff:
    - Fix regression due to 60_cve-2015-2153.diff

applied/ubuntu/vivid-devel 2015-03-26 22:28:52 UTC 2015-03-26
Import patches-applied version 4.6.2-4ubuntu1 to applied/ubuntu/vivid-proposed

Author: Artur Rona
Author Date: 2015-03-22 23:42:29 UTC

Import patches-applied version 4.6.2-4ubuntu1 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 815a997444d57337e61062046ecdcfc25725a2d2
Unapplied parent: 260b622dfe42ac6912bc279563d6dda7c25dea37

New changelog entries:
  * Merge from Debian unstable. (LP: #1433815) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
  * debian/patches/60_cve-2015-2153-fix-regression.diff:
    - Fix regression due to 60_cve-2015-2153.diff

applied/ubuntu/vivid 2015-03-26 22:28:52 UTC 2015-03-26
Import patches-applied version 4.6.2-4ubuntu1 to applied/ubuntu/vivid-proposed

Author: Artur Rona
Author Date: 2015-03-22 23:42:29 UTC

Import patches-applied version 4.6.2-4ubuntu1 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 815a997444d57337e61062046ecdcfc25725a2d2
Unapplied parent: 260b622dfe42ac6912bc279563d6dda7c25dea37

New changelog entries:
  * Merge from Debian unstable. (LP: #1433815) Remaining changes:
    - debian/{control, README.Debian, tcpdump.dirs, usr.sbin.tcpdump,
      install, rules, patches/patches/90_man_apparmor.diff}:
      + Add AppArmor profile.
    - debian/usr.sbin.tcpdump:
      + Allow capability net_admin to support '-j'.
  * debian/patches/60_cve-2015-2153-fix-regression.diff:
    - Fix regression due to 60_cve-2015-2153.diff

applied/ubuntu/lucid-updates 2014-12-04 13:58:42 UTC 2014-12-04
Import patches-applied version 4.0.0-6ubuntu3.1 to applied/ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-12-03 22:17:23 UTC

Import patches-applied version 4.0.0-6ubuntu3.1 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: bfbd1bf5ac7e51fa2dc79daa3ac8d703ae46c431
Unapplied parent: 5e4c2b46ecdb57c38ffbac44188bc07b442df0f6

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution in
    olsr_print
    - debian/patches/CVE-2014-8767.patch: improve bounds checking and
      error handling in print-olsr.c.
    - CVE-2014-8767
  * SECURITY UPDATE: denial of service and possible code execution in
    print-aodv.c
    - debian/patches/CVE-2014-8769.patch: improve bounds checking and
      length checking in print-aodv.c, aodv.h.
    - CVE-2014-8769
  * SECURITY UPDATE: denial of service and possible code execution in
    print-ppp.c
    - debian/patches/CVE-2014-9140.patch: improve bounds checking in
      print-ppp.c.
    - CVE-2014-9140

applied/ubuntu/lucid-security 2014-12-04 13:58:42 UTC 2014-12-04
Import patches-applied version 4.0.0-6ubuntu3.1 to applied/ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-12-03 22:17:23 UTC

Import patches-applied version 4.0.0-6ubuntu3.1 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: bfbd1bf5ac7e51fa2dc79daa3ac8d703ae46c431
Unapplied parent: 5e4c2b46ecdb57c38ffbac44188bc07b442df0f6

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution in
    olsr_print
    - debian/patches/CVE-2014-8767.patch: improve bounds checking and
      error handling in print-olsr.c.
    - CVE-2014-8767
  * SECURITY UPDATE: denial of service and possible code execution in
    print-aodv.c
    - debian/patches/CVE-2014-8769.patch: improve bounds checking and
      length checking in print-aodv.c, aodv.h.
    - CVE-2014-8769
  * SECURITY UPDATE: denial of service and possible code execution in
    print-ppp.c
    - debian/patches/CVE-2014-9140.patch: improve bounds checking in
      print-ppp.c.
    - CVE-2014-9140

applied/ubuntu/lucid-devel 2014-12-04 13:58:42 UTC 2014-12-04
Import patches-applied version 4.0.0-6ubuntu3.1 to applied/ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-12-03 22:17:23 UTC

Import patches-applied version 4.0.0-6ubuntu3.1 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: bfbd1bf5ac7e51fa2dc79daa3ac8d703ae46c431
Unapplied parent: 5e4c2b46ecdb57c38ffbac44188bc07b442df0f6

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution in
    olsr_print
    - debian/patches/CVE-2014-8767.patch: improve bounds checking and
      error handling in print-olsr.c.
    - CVE-2014-8767
  * SECURITY UPDATE: denial of service and possible code execution in
    print-aodv.c
    - debian/patches/CVE-2014-8769.patch: improve bounds checking and
      length checking in print-aodv.c, aodv.h.
    - CVE-2014-8769
  * SECURITY UPDATE: denial of service and possible code execution in
    print-ppp.c
    - debian/patches/CVE-2014-9140.patch: improve bounds checking in
      print-ppp.c.
    - CVE-2014-9140

ubuntu/lucid-devel 2014-12-04 13:58:42 UTC 2014-12-04
Import patches-unapplied version 4.0.0-6ubuntu3.1 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-12-03 22:17:23 UTC

Import patches-unapplied version 4.0.0-6ubuntu3.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 17bba50d39b79cceb31c5cf49206610a5f117366

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution in
    olsr_print
    - debian/patches/CVE-2014-8767.patch: improve bounds checking and
      error handling in print-olsr.c.
    - CVE-2014-8767
  * SECURITY UPDATE: denial of service and possible code execution in
    print-aodv.c
    - debian/patches/CVE-2014-8769.patch: improve bounds checking and
      length checking in print-aodv.c, aodv.h.
    - CVE-2014-8769
  * SECURITY UPDATE: denial of service and possible code execution in
    print-ppp.c
    - debian/patches/CVE-2014-9140.patch: improve bounds checking in
      print-ppp.c.
    - CVE-2014-9140

ubuntu/lucid-updates 2014-12-04 13:58:42 UTC 2014-12-04
Import patches-unapplied version 4.0.0-6ubuntu3.1 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-12-03 22:17:23 UTC

Import patches-unapplied version 4.0.0-6ubuntu3.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 17bba50d39b79cceb31c5cf49206610a5f117366

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution in
    olsr_print
    - debian/patches/CVE-2014-8767.patch: improve bounds checking and
      error handling in print-olsr.c.
    - CVE-2014-8767
  * SECURITY UPDATE: denial of service and possible code execution in
    print-aodv.c
    - debian/patches/CVE-2014-8769.patch: improve bounds checking and
      length checking in print-aodv.c, aodv.h.
    - CVE-2014-8769
  * SECURITY UPDATE: denial of service and possible code execution in
    print-ppp.c
    - debian/patches/CVE-2014-9140.patch: improve bounds checking in
      print-ppp.c.
    - CVE-2014-9140

ubuntu/lucid-security 2014-12-04 13:58:42 UTC 2014-12-04
Import patches-unapplied version 4.0.0-6ubuntu3.1 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2014-12-03 22:17:23 UTC

Import patches-unapplied version 4.0.0-6ubuntu3.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 17bba50d39b79cceb31c5cf49206610a5f117366

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution in
    olsr_print
    - debian/patches/CVE-2014-8767.patch: improve bounds checking and
      error handling in print-olsr.c.
    - CVE-2014-8767
  * SECURITY UPDATE: denial of service and possible code execution in
    print-aodv.c
    - debian/patches/CVE-2014-8769.patch: improve bounds checking and
      length checking in print-aodv.c, aodv.h.
    - CVE-2014-8769
  * SECURITY UPDATE: denial of service and possible code execution in
    print-ppp.c
    - debian/patches/CVE-2014-9140.patch: improve bounds checking in
      print-ppp.c.
    - CVE-2014-9140

1100 of 208 results

Other repositories

Name Last Modified
lp:ubuntu/+source/tcpdump 2018-10-30
11 of 1 result
You can't create new repositories for tcpdump in Ubuntu.