View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/subversion
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2019-10-18 22:58:10 UTC 2019-10-18
DSC file for 1.10.6-1build1

Author: Ubuntu Git Importer
Author Date: 2019-10-18 22:58:10 UTC

DSC file for 1.10.6-1build1

ubuntu/focal-devel 2019-10-18 21:08:25 UTC 2019-10-18
Import patches-unapplied version 1.10.6-1build1 to ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2019-10-18 19:38:16 UTC

Import patches-unapplied version 1.10.6-1build1 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: ef5a83167bd4adfed5b7043e9d00069954538080

New changelog entries:
  * No-change rebuild for the perl update.

ubuntu/focal-proposed 2019-10-18 21:08:25 UTC 2019-10-18
Import patches-unapplied version 1.10.6-1build1 to ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2019-10-18 19:38:16 UTC

Import patches-unapplied version 1.10.6-1build1 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: ef5a83167bd4adfed5b7043e9d00069954538080

New changelog entries:
  * No-change rebuild for the perl update.

applied/ubuntu/devel 2019-10-18 21:08:25 UTC 2019-10-18
Import patches-applied version 1.10.6-1build1 to applied/ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2019-10-18 19:38:16 UTC

Import patches-applied version 1.10.6-1build1 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: d82d6041a7e1a4a39c249a4018e2f54007b5a216
Unapplied parent: 6c384d9a853254482219c6e2a0a6db4e18be6d73

New changelog entries:
  * No-change rebuild for the perl update.

applied/ubuntu/focal-proposed 2019-10-18 21:08:25 UTC 2019-10-18
Import patches-applied version 1.10.6-1build1 to applied/ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2019-10-18 19:38:16 UTC

Import patches-applied version 1.10.6-1build1 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: d82d6041a7e1a4a39c249a4018e2f54007b5a216
Unapplied parent: 6c384d9a853254482219c6e2a0a6db4e18be6d73

New changelog entries:
  * No-change rebuild for the perl update.

applied/ubuntu/focal-devel 2019-10-18 21:08:25 UTC 2019-10-18
Import patches-applied version 1.10.6-1build1 to applied/ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2019-10-18 19:38:16 UTC

Import patches-applied version 1.10.6-1build1 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: d82d6041a7e1a4a39c249a4018e2f54007b5a216
Unapplied parent: 6c384d9a853254482219c6e2a0a6db4e18be6d73

New changelog entries:
  * No-change rebuild for the perl update.

ubuntu/devel 2019-10-18 21:08:25 UTC 2019-10-18
Import patches-unapplied version 1.10.6-1build1 to ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2019-10-18 19:38:16 UTC

Import patches-unapplied version 1.10.6-1build1 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: ef5a83167bd4adfed5b7043e9d00069954538080

New changelog entries:
  * No-change rebuild for the perl update.

importer/debian/dsc 2019-09-07 18:10:30 UTC 2019-09-07
DSC file for 1.9.5-1+deb9u4

Author: Ubuntu Git Importer
Author Date: 2019-09-07 18:10:30 UTC

DSC file for 1.9.5-1+deb9u4

debian/stretch 2019-09-07 18:06:50 UTC 2019-09-07
Import patches-unapplied version 1.9.5-1+deb9u4 to debian/stretch

Author: James McCoy
Author Date: 2019-07-30 02:45:42 UTC

Import patches-unapplied version 1.9.5-1+deb9u4 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: ebd44a544b3e871774d19adbf61f77ad510b5f70

New changelog entries:
  * Backport security fixes from upstream:
    + CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
      'get-deleted-rev'.
    + CVE-2018-0203: Remote unauthenticated denial-of-service in Subversion
      svnserve.

applied/debian/stretch 2019-09-07 18:06:50 UTC 2019-09-07
Import patches-applied version 1.9.5-1+deb9u4 to applied/debian/stretch

Author: James McCoy
Author Date: 2019-07-30 02:45:42 UTC

Import patches-applied version 1.9.5-1+deb9u4 to applied/debian/stretch

Imported using git-ubuntu import.

Changelog parent: b8e575ca5440f760607d9775fa8d945e1260ceae
Unapplied parent: bc49e616b8ee85e4063f841cdf1419d89d4e71f2

New changelog entries:
  * Backport security fixes from upstream:
    + CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
      'get-deleted-rev'.
    + CVE-2018-0203: Remote unauthenticated denial-of-service in Subversion
      svnserve.

debian/buster 2019-09-07 17:26:25 UTC 2019-09-07
Import patches-unapplied version 1.10.4-1+deb10u1 to debian/buster

Author: James McCoy
Author Date: 2019-07-28 02:44:06 UTC

Import patches-unapplied version 1.10.4-1+deb10u1 to debian/buster

Imported using git-ubuntu import.

Changelog parent: 9dbe640069d82e5f9231ed687c279f35a1253039

New changelog entries:
  * Backport security fixes from upstream:
    + CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
      'get-deleted-rev'.
    + CVE-2018-0203: Remote unauthenticated denial-of-service in Subversion
      svnserve.

applied/debian/buster 2019-09-07 17:26:25 UTC 2019-09-07
Import patches-applied version 1.10.4-1+deb10u1 to applied/debian/buster

Author: James McCoy
Author Date: 2019-07-28 02:44:06 UTC

Import patches-applied version 1.10.4-1+deb10u1 to applied/debian/buster

Imported using git-ubuntu import.

Changelog parent: 73ab6b988ccf79e8384b3174a35ac9b996d30a2c
Unapplied parent: 56fa480fb99728567409b75217c10200b709d9e4

New changelog entries:
  * Backport security fixes from upstream:
    + CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
      'get-deleted-rev'.
    + CVE-2018-0203: Remote unauthenticated denial-of-service in Subversion
      svnserve.

applied/ubuntu/focal 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-applied version 1.10.6-1 to applied/debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-applied version 1.10.6-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 73ab6b988ccf79e8384b3174a35ac9b996d30a2c
Unapplied parent: 349496492e3780c876b1bde8060ea4abbe5a8b80

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

applied/ubuntu/eoan-devel 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-applied version 1.10.6-1 to applied/debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-applied version 1.10.6-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 73ab6b988ccf79e8384b3174a35ac9b996d30a2c
Unapplied parent: 349496492e3780c876b1bde8060ea4abbe5a8b80

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

applied/ubuntu/eoan 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-applied version 1.10.6-1 to applied/debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-applied version 1.10.6-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 73ab6b988ccf79e8384b3174a35ac9b996d30a2c
Unapplied parent: 349496492e3780c876b1bde8060ea4abbe5a8b80

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

ubuntu/eoan-devel 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-unapplied version 1.10.6-1 to debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-unapplied version 1.10.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9dbe640069d82e5f9231ed687c279f35a1253039

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

ubuntu/eoan-proposed 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-unapplied version 1.10.6-1 to debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-unapplied version 1.10.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9dbe640069d82e5f9231ed687c279f35a1253039

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

applied/debian/sid 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-applied version 1.10.6-1 to applied/debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-applied version 1.10.6-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 73ab6b988ccf79e8384b3174a35ac9b996d30a2c
Unapplied parent: 349496492e3780c876b1bde8060ea4abbe5a8b80

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

ubuntu/focal 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-unapplied version 1.10.6-1 to debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-unapplied version 1.10.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9dbe640069d82e5f9231ed687c279f35a1253039

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

ubuntu/eoan 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-unapplied version 1.10.6-1 to debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-unapplied version 1.10.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9dbe640069d82e5f9231ed687c279f35a1253039

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

debian/sid 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-unapplied version 1.10.6-1 to debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-unapplied version 1.10.6-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9dbe640069d82e5f9231ed687c279f35a1253039

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

applied/ubuntu/eoan-proposed 2019-08-01 04:39:00 UTC 2019-08-01
Import patches-applied version 1.10.6-1 to applied/debian/sid

Author: James McCoy
Author Date: 2019-07-31 11:01:38 UTC

Import patches-applied version 1.10.6-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 73ab6b988ccf79e8384b3174a35ac9b996d30a2c
Unapplied parent: 349496492e3780c876b1bde8060ea4abbe5a8b80

New changelog entries:
  * Update to new upstream version 1.10.6.
    + Security fix
      - CVE-2018-11782: Remotely triggerable DoS vulnerability in svnserve
        'get-deleted-rev'
      - CVE-2019-0203: Remote unauthenticated denial-of-service in Subversion
        svnserve
  * Support a pkg.subversion.nokde build profile.
    Thanks to Jason Duerstock for the patch (Closes: #929326)

applied/ubuntu/xenial-security 2019-07-31 16:48:28 UTC 2019-07-31
Import patches-applied version 1.9.3-2ubuntu1.3 to applied/ubuntu/xenial-secu...

Author: Marc Deslauriers
Author Date: 2019-07-26 13:55:16 UTC

Import patches-applied version 1.9.3-2ubuntu1.3 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 8e3290ebdd03add48e8454b92dc02b4b90fe11ae
Unapplied parent: 0ffe58728d831af23dba6cd15850bbc422f4e96b

New changelog entries:
  * SECURITY UPDATE: Remotely triggerable DoS vulnerability in svnserve
    'get-deleted-rev'
    - debian/patches/CVE-2018-11782.patch: properly handle certain replies
      in subversion/libsvn_ra_svn/client.c, subversion/svnserve/serve.c,
      subversion/tests/libsvn_ra/ra-test.c.
    - CVE-2018-11782
  * SECURITY UPDATE: Remote unauthenticated denial-of-service in svnserve
    - debian/patches/CVE-2019-0203.patch: properly handle errors in
      subversion/svnserve/serve.c.
    - CVE-2019-0203
  * WARNING: this update does _not_ include the changes from
    (1.9.3-2ubuntu1.2) in xenial-proposed.

ubuntu/xenial-updates 2019-07-31 16:48:28 UTC 2019-07-31
Import patches-unapplied version 1.9.3-2ubuntu1.3 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2019-07-26 13:55:16 UTC

Import patches-unapplied version 1.9.3-2ubuntu1.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: d9ddd01bd67f8afc54169d19b8f463ab9d56bf44

New changelog entries:
  * SECURITY UPDATE: Remotely triggerable DoS vulnerability in svnserve
    'get-deleted-rev'
    - debian/patches/CVE-2018-11782.patch: properly handle certain replies
      in subversion/libsvn_ra_svn/client.c, subversion/svnserve/serve.c,
      subversion/tests/libsvn_ra/ra-test.c.
    - CVE-2018-11782
  * SECURITY UPDATE: Remote unauthenticated denial-of-service in svnserve
    - debian/patches/CVE-2019-0203.patch: properly handle errors in
      subversion/svnserve/serve.c.
    - CVE-2019-0203
  * WARNING: this update does _not_ include the changes from
    (1.9.3-2ubuntu1.2) in xenial-proposed.

applied/ubuntu/xenial-devel 2019-07-31 16:48:28 UTC 2019-07-31
Import patches-applied version 1.9.3-2ubuntu1.3 to applied/ubuntu/xenial-secu...

Author: Marc Deslauriers
Author Date: 2019-07-26 13:55:16 UTC

Import patches-applied version 1.9.3-2ubuntu1.3 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 8e3290ebdd03add48e8454b92dc02b4b90fe11ae
Unapplied parent: 0ffe58728d831af23dba6cd15850bbc422f4e96b

New changelog entries:
  * SECURITY UPDATE: Remotely triggerable DoS vulnerability in svnserve
    'get-deleted-rev'
    - debian/patches/CVE-2018-11782.patch: properly handle certain replies
      in subversion/libsvn_ra_svn/client.c, subversion/svnserve/serve.c,
      subversion/tests/libsvn_ra/ra-test.c.
    - CVE-2018-11782
  * SECURITY UPDATE: Remote unauthenticated denial-of-service in svnserve
    - debian/patches/CVE-2019-0203.patch: properly handle errors in
      subversion/svnserve/serve.c.
    - CVE-2019-0203
  * WARNING: this update does _not_ include the changes from
    (1.9.3-2ubuntu1.2) in xenial-proposed.

ubuntu/xenial-devel 2019-07-31 16:48:28 UTC 2019-07-31
Import patches-unapplied version 1.9.3-2ubuntu1.3 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2019-07-26 13:55:16 UTC

Import patches-unapplied version 1.9.3-2ubuntu1.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: d9ddd01bd67f8afc54169d19b8f463ab9d56bf44

New changelog entries:
  * SECURITY UPDATE: Remotely triggerable DoS vulnerability in svnserve
    'get-deleted-rev'
    - debian/patches/CVE-2018-11782.patch: properly handle certain replies
      in subversion/libsvn_ra_svn/client.c, subversion/svnserve/serve.c,
      subversion/tests/libsvn_ra/ra-test.c.
    - CVE-2018-11782
  * SECURITY UPDATE: Remote unauthenticated denial-of-service in svnserve
    - debian/patches/CVE-2019-0203.patch: properly handle errors in
      subversion/svnserve/serve.c.
    - CVE-2019-0203
  * WARNING: this update does _not_ include the changes from
    (1.9.3-2ubuntu1.2) in xenial-proposed.

applied/ubuntu/xenial-updates 2019-07-31 16:48:28 UTC 2019-07-31
Import patches-applied version 1.9.3-2ubuntu1.3 to applied/ubuntu/xenial-secu...

Author: Marc Deslauriers
Author Date: 2019-07-26 13:55:16 UTC

Import patches-applied version 1.9.3-2ubuntu1.3 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 8e3290ebdd03add48e8454b92dc02b4b90fe11ae
Unapplied parent: 0ffe58728d831af23dba6cd15850bbc422f4e96b

New changelog entries:
  * SECURITY UPDATE: Remotely triggerable DoS vulnerability in svnserve
    'get-deleted-rev'
    - debian/patches/CVE-2018-11782.patch: properly handle certain replies
      in subversion/libsvn_ra_svn/client.c, subversion/svnserve/serve.c,
      subversion/tests/libsvn_ra/ra-test.c.
    - CVE-2018-11782
  * SECURITY UPDATE: Remote unauthenticated denial-of-service in svnserve
    - debian/patches/CVE-2019-0203.patch: properly handle errors in
      subversion/svnserve/serve.c.
    - CVE-2019-0203
  * WARNING: this update does _not_ include the changes from
    (1.9.3-2ubuntu1.2) in xenial-proposed.

ubuntu/xenial-security 2019-07-31 16:48:28 UTC 2019-07-31
Import patches-unapplied version 1.9.3-2ubuntu1.3 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2019-07-26 13:55:16 UTC

Import patches-unapplied version 1.9.3-2ubuntu1.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: d9ddd01bd67f8afc54169d19b8f463ab9d56bf44

New changelog entries:
  * SECURITY UPDATE: Remotely triggerable DoS vulnerability in svnserve
    'get-deleted-rev'
    - debian/patches/CVE-2018-11782.patch: properly handle certain replies
      in subversion/libsvn_ra_svn/client.c, subversion/svnserve/serve.c,
      subversion/tests/libsvn_ra/ra-test.c.
    - CVE-2018-11782
  * SECURITY UPDATE: Remote unauthenticated denial-of-service in svnserve
    - debian/patches/CVE-2019-0203.patch: properly handle errors in
      subversion/svnserve/serve.c.
    - CVE-2019-0203
  * WARNING: this update does _not_ include the changes from
    (1.9.3-2ubuntu1.2) in xenial-proposed.

ubuntu/xenial-proposed 2019-05-01 13:03:14 UTC 2019-05-01
Import patches-unapplied version 1.9.3-2ubuntu1.2 to ubuntu/xenial-proposed

Author: James McCoy
Author Date: 2018-03-15 02:29:16 UTC

Import patches-unapplied version 1.9.3-2ubuntu1.2 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: d9ddd01bd67f8afc54169d19b8f463ab9d56bf44

New changelog entries:
  * Backport patches/perl-swig-crash from upstream to fix crashes with Perl
    bindings, commonly seen when using git-svn (LP: #1451028)

applied/ubuntu/xenial-proposed 2019-05-01 13:03:14 UTC 2019-05-01
Import patches-applied version 1.9.3-2ubuntu1.2 to applied/ubuntu/xenial-prop...

Author: James McCoy
Author Date: 2018-03-15 02:29:16 UTC

Import patches-applied version 1.9.3-2ubuntu1.2 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 8e3290ebdd03add48e8454b92dc02b4b90fe11ae
Unapplied parent: b4ae62d61ffaa1d9e5ea92f0b42a812edd9c1d63

New changelog entries:
  * Backport patches/perl-swig-crash from upstream to fix crashes with Perl
    bindings, commonly seen when using git-svn (LP: #1451028)

applied/ubuntu/cosmic-security 2019-01-24 14:28:15 UTC 2019-01-24
Import patches-applied version 1.10.0-2ubuntu2.1 to applied/ubuntu/cosmic-sec...

Author: Leonidas S. Barbosa
Author Date: 2019-01-23 15:12:36 UTC

Import patches-applied version 1.10.0-2ubuntu2.1 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 15c06a1221beac397934835e425f15aab27dd692
Unapplied parent: 25a6959a0fcb8eea21341e2860e60b7f78b4851f

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2018-11803.patch: fix in
      subversion/mod_dav_svn/reports/list.c.
    - CVE-2018-11803

ubuntu/cosmic-security 2019-01-24 14:28:15 UTC 2019-01-24
Import patches-unapplied version 1.10.0-2ubuntu2.1 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2019-01-23 15:12:36 UTC

Import patches-unapplied version 1.10.0-2ubuntu2.1 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 4d0a379eb6e5aa4bd3832a35f8db7d9a91aebb4c

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2018-11803.patch: fix in
      subversion/mod_dav_svn/reports/list.c.
    - CVE-2018-11803

applied/ubuntu/cosmic-devel 2019-01-24 14:28:15 UTC 2019-01-24
Import patches-applied version 1.10.0-2ubuntu2.1 to applied/ubuntu/cosmic-sec...

Author: Leonidas S. Barbosa
Author Date: 2019-01-23 15:12:36 UTC

Import patches-applied version 1.10.0-2ubuntu2.1 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 15c06a1221beac397934835e425f15aab27dd692
Unapplied parent: 25a6959a0fcb8eea21341e2860e60b7f78b4851f

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2018-11803.patch: fix in
      subversion/mod_dav_svn/reports/list.c.
    - CVE-2018-11803

ubuntu/cosmic-devel 2019-01-24 14:28:15 UTC 2019-01-24
Import patches-unapplied version 1.10.0-2ubuntu2.1 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2019-01-23 15:12:36 UTC

Import patches-unapplied version 1.10.0-2ubuntu2.1 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 4d0a379eb6e5aa4bd3832a35f8db7d9a91aebb4c

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2018-11803.patch: fix in
      subversion/mod_dav_svn/reports/list.c.
    - CVE-2018-11803

applied/ubuntu/cosmic-updates 2019-01-24 14:28:15 UTC 2019-01-24
Import patches-applied version 1.10.0-2ubuntu2.1 to applied/ubuntu/cosmic-sec...

Author: Leonidas S. Barbosa
Author Date: 2019-01-23 15:12:36 UTC

Import patches-applied version 1.10.0-2ubuntu2.1 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 15c06a1221beac397934835e425f15aab27dd692
Unapplied parent: 25a6959a0fcb8eea21341e2860e60b7f78b4851f

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2018-11803.patch: fix in
      subversion/mod_dav_svn/reports/list.c.
    - CVE-2018-11803

ubuntu/cosmic-updates 2019-01-24 14:28:15 UTC 2019-01-24
Import patches-unapplied version 1.10.0-2ubuntu2.1 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2019-01-23 15:12:36 UTC

Import patches-unapplied version 1.10.0-2ubuntu2.1 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 4d0a379eb6e5aa4bd3832a35f8db7d9a91aebb4c

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2018-11803.patch: fix in
      subversion/mod_dav_svn/reports/list.c.
    - CVE-2018-11803

applied/ubuntu/disco-proposed 2018-11-03 05:43:23 UTC 2018-11-03
Import patches-applied version 1.10.0-2ubuntu3 to applied/ubuntu/disco-proposed

Author: Adam Conrad
Author Date: 2018-11-03 00:15:03 UTC

Import patches-applied version 1.10.0-2ubuntu3 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 15c06a1221beac397934835e425f15aab27dd692
Unapplied parent: 230f155dcd1e017367a635d2028292b9d319c48c

New changelog entries:
  * No-change rebuild for the perl 5.28 transition.

applied/ubuntu/disco-devel 2018-11-03 05:43:23 UTC 2018-11-03
Import patches-applied version 1.10.0-2ubuntu3 to applied/ubuntu/disco-proposed

Author: Adam Conrad
Author Date: 2018-11-03 00:15:03 UTC

Import patches-applied version 1.10.0-2ubuntu3 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 15c06a1221beac397934835e425f15aab27dd692
Unapplied parent: 230f155dcd1e017367a635d2028292b9d319c48c

New changelog entries:
  * No-change rebuild for the perl 5.28 transition.

applied/ubuntu/disco 2018-11-03 05:43:23 UTC 2018-11-03
Import patches-applied version 1.10.0-2ubuntu3 to applied/ubuntu/disco-proposed

Author: Adam Conrad
Author Date: 2018-11-03 00:15:03 UTC

Import patches-applied version 1.10.0-2ubuntu3 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 15c06a1221beac397934835e425f15aab27dd692
Unapplied parent: 230f155dcd1e017367a635d2028292b9d319c48c

New changelog entries:
  * No-change rebuild for the perl 5.28 transition.

ubuntu/disco-devel 2018-11-03 05:43:23 UTC 2018-11-03
Import patches-unapplied version 1.10.0-2ubuntu3 to ubuntu/disco-proposed

Author: Adam Conrad
Author Date: 2018-11-03 00:15:03 UTC

Import patches-unapplied version 1.10.0-2ubuntu3 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 4d0a379eb6e5aa4bd3832a35f8db7d9a91aebb4c

New changelog entries:
  * No-change rebuild for the perl 5.28 transition.

ubuntu/disco-proposed 2018-11-03 05:43:23 UTC 2018-11-03
Import patches-unapplied version 1.10.0-2ubuntu3 to ubuntu/disco-proposed

Author: Adam Conrad
Author Date: 2018-11-03 00:15:03 UTC

Import patches-unapplied version 1.10.0-2ubuntu3 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 4d0a379eb6e5aa4bd3832a35f8db7d9a91aebb4c

New changelog entries:
  * No-change rebuild for the perl 5.28 transition.

ubuntu/disco 2018-11-03 05:43:23 UTC 2018-11-03
Import patches-unapplied version 1.10.0-2ubuntu3 to ubuntu/disco-proposed

Author: Adam Conrad
Author Date: 2018-11-03 00:15:03 UTC

Import patches-unapplied version 1.10.0-2ubuntu3 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 4d0a379eb6e5aa4bd3832a35f8db7d9a91aebb4c

New changelog entries:
  * No-change rebuild for the perl 5.28 transition.

applied/debian/experimental 2018-10-10 16:31:35 UTC 2018-10-10
Import patches-applied version 1.11.0~rc2-1 to applied/debian/experimental

Author: James McCoy
Author Date: 2018-10-10 02:21:31 UTC

Import patches-applied version 1.11.0~rc2-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 8249d8ffa3d8c3a5ee587ea3d47f4d207062812a
Unapplied parent: 7101f21b7483cf9d861a7a0f680bde4232d3d586

New changelog entries:
  * Update to new upstream version 1.11.0~rc2.
    + Drop java patch now that upstream can build against Java 10
  * control:
    + Bump minimum Java version to 1.8
    + Bump Build-Conflicts on libsvn-dev
  * Add 1.11 release notes and update others
  * libsvn1: Add new symbols, remove obsolete experimental shelving APIs
  * lintian:
    + Update libapache2-mod-svn override due to tag being renamed
    + Add libsvn1 override for package-name-doesnt-match-sonames
  * libsvn-{java,dev}: Use absolute target path for symlink_to_dir calls
    (Closes: #910233)
  * rules: Allow quiet builds when DEB_BUILD_OPTIONS=terse
  * Declare compliance with Policy 4.2.1
  * libsvn-java: Remove obsolete libsvn-jni Conflicts/Replaces

debian/experimental 2018-10-10 16:31:35 UTC 2018-10-10
Import patches-unapplied version 1.11.0~rc2-1 to debian/experimental

Author: James McCoy
Author Date: 2018-10-10 02:21:31 UTC

Import patches-unapplied version 1.11.0~rc2-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: aef62c6faa18cd368f9c06445a40bc4c8cd72a1b

New changelog entries:
  * Update to new upstream version 1.11.0~rc2.
    + Drop java patch now that upstream can build against Java 10
  * control:
    + Bump minimum Java version to 1.8
    + Bump Build-Conflicts on libsvn-dev
  * Add 1.11 release notes and update others
  * libsvn1: Add new symbols, remove obsolete experimental shelving APIs
  * lintian:
    + Update libapache2-mod-svn override due to tag being renamed
    + Add libsvn1 override for package-name-doesnt-match-sonames
  * libsvn-{java,dev}: Use absolute target path for symlink_to_dir calls
    (Closes: #910233)
  * rules: Allow quiet builds when DEB_BUILD_OPTIONS=terse
  * Declare compliance with Policy 4.2.1
  * libsvn-java: Remove obsolete libsvn-jni Conflicts/Replaces

ubuntu/cosmic-proposed 2018-07-29 08:33:15 UTC 2018-07-29
Import patches-unapplied version 1.10.0-2ubuntu2 to ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-07-29 02:58:30 UTC

Import patches-unapplied version 1.10.0-2ubuntu2 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 35422cd946223e7116fe774b5a2ca132f3b7d7f4

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

applied/ubuntu/cosmic-proposed 2018-07-29 08:33:15 UTC 2018-07-29
Import patches-applied version 1.10.0-2ubuntu2 to applied/ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-07-29 02:58:30 UTC

Import patches-applied version 1.10.0-2ubuntu2 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 5c462badc72df34b13cb07b6b3ff71b2ad31a80f
Unapplied parent: df7d717cb0a4e2074fc6804e22901beff0b2d9cb

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

ubuntu/cosmic 2018-07-29 08:33:15 UTC 2018-07-29
Import patches-unapplied version 1.10.0-2ubuntu2 to ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-07-29 02:58:30 UTC

Import patches-unapplied version 1.10.0-2ubuntu2 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 35422cd946223e7116fe774b5a2ca132f3b7d7f4

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

applied/ubuntu/cosmic 2018-07-29 08:33:15 UTC 2018-07-29
Import patches-applied version 1.10.0-2ubuntu2 to applied/ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-07-29 02:58:30 UTC

Import patches-applied version 1.10.0-2ubuntu2 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 5c462badc72df34b13cb07b6b3ff71b2ad31a80f
Unapplied parent: df7d717cb0a4e2074fc6804e22901beff0b2d9cb

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

applied/debian/jessie 2018-06-23 17:29:09 UTC 2018-06-23
Import patches-applied version 1.8.10-6+deb8u6 to applied/debian/jessie

Author: James McCoy
Author Date: 2018-02-27 03:00:47 UTC

Import patches-applied version 1.8.10-6+deb8u6 to applied/debian/jessie

Imported using git-ubuntu import.

Changelog parent: 0c570be7e5085af12402e93274ef8a766403b1b4
Unapplied parent: cbc2ecd74654c058dbc350afffe4cb3b609792f7

New changelog entries:
  * Backport patches/perl-swig-crash from upstream to fix crashes with Perl
    bindings, commonly seen when using git-svn (Closes: #780246, #534763).

debian/jessie 2018-06-23 17:29:09 UTC 2018-06-23
Import patches-unapplied version 1.8.10-6+deb8u6 to debian/jessie

Author: James McCoy
Author Date: 2018-02-27 03:00:47 UTC

Import patches-unapplied version 1.8.10-6+deb8u6 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: 7834be57e323c0cae14e08cb5ca4cc2ea5a93988

New changelog entries:
  * Backport patches/perl-swig-crash from upstream to fix crashes with Perl
    bindings, commonly seen when using git-svn (Closes: #780246, #534763).

importer/ubuntu/pristine-tar 2018-03-28 10:42:54 UTC 2018-03-28
pristine-tar data for subversion_1.9.7.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-28 10:42:54 UTC

pristine-tar data for subversion_1.9.7.orig.tar.gz

applied/ubuntu/bionic-proposed 2018-03-28 09:48:55 UTC 2018-03-28
Import patches-applied version 1.9.7-4ubuntu1 to applied/ubuntu/bionic-proposed

Author: Matthias Klose
Author Date: 2018-03-28 08:49:13 UTC

Import patches-applied version 1.9.7-4ubuntu1 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 674bef0efb2d4e21ecd3e489443180ff5545beff
Unapplied parent: 6438194d2dc17f312f32f53c2b00163af6584521

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

applied/ubuntu/bionic-devel 2018-03-28 09:48:55 UTC 2018-03-28
Import patches-applied version 1.9.7-4ubuntu1 to applied/ubuntu/bionic-proposed

Author: Matthias Klose
Author Date: 2018-03-28 08:49:13 UTC

Import patches-applied version 1.9.7-4ubuntu1 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 674bef0efb2d4e21ecd3e489443180ff5545beff
Unapplied parent: 6438194d2dc17f312f32f53c2b00163af6584521

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

applied/ubuntu/bionic 2018-03-28 09:48:55 UTC 2018-03-28
Import patches-applied version 1.9.7-4ubuntu1 to applied/ubuntu/bionic-proposed

Author: Matthias Klose
Author Date: 2018-03-28 08:49:13 UTC

Import patches-applied version 1.9.7-4ubuntu1 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 674bef0efb2d4e21ecd3e489443180ff5545beff
Unapplied parent: 6438194d2dc17f312f32f53c2b00163af6584521

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

importer/debian/pristine-tar 2018-03-28 09:03:31 UTC 2018-03-28
pristine-tar data for subversion_1.10.0~rc1.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-28 09:03:31 UTC

pristine-tar data for subversion_1.10.0~rc1.orig.tar.gz

ubuntu/bionic-proposed 2018-03-28 08:49:13 UTC 2018-03-28
Import patches-unapplied version 1.9.7-4ubuntu1 to ubuntu/bionic-proposed

Author: Matthias Klose
Author Date: 2018-03-28 08:49:13 UTC

Import patches-unapplied version 1.9.7-4ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: ff307ec6fc7df98f10f2ffec50c1432b37244e69

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

ubuntu/bionic 2018-03-28 08:49:13 UTC 2018-03-28
Import patches-unapplied version 1.9.7-4ubuntu1 to ubuntu/bionic-proposed

Author: Matthias Klose
Author Date: 2018-03-28 08:49:13 UTC

Import patches-unapplied version 1.9.7-4ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: ff307ec6fc7df98f10f2ffec50c1432b37244e69

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

ubuntu/bionic-devel 2018-03-28 08:49:13 UTC 2018-03-28
Import patches-unapplied version 1.9.7-4ubuntu1 to ubuntu/bionic-proposed

Author: Matthias Klose
Author Date: 2018-03-28 08:49:13 UTC

Import patches-unapplied version 1.9.7-4ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: ff307ec6fc7df98f10f2ffec50c1432b37244e69

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level

applied/ubuntu/artful-proposed 2017-08-25 16:28:38 UTC 2017-08-25
Import patches-applied version 1.9.7-2ubuntu1 to applied/ubuntu/artful-proposed

Author: Merge-o-Matic
Author Date: 2017-08-17 10:20:03 UTC

Import patches-applied version 1.9.7-2ubuntu1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 2c4911717df11c407307094a47088a0e342c5342
Unapplied parent: a0aca3979440da3bc998476ae898b11a2af88608

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
  * Updated changes:
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level
  * Dropped Ubuntu changes:
    - debian/patches/CVE-2017-9800-1.9.6.patch: fixed upstream
    - debian/control: drop X-Python-Versions: as it is no longer
      needed with 2.7 the only remaining supported python 2 version
      and on obsolete flag
    - debian/rules: drop change that ignores swig test failures

applied/ubuntu/artful-devel 2017-08-25 16:28:38 UTC 2017-08-25
Import patches-applied version 1.9.7-2ubuntu1 to applied/ubuntu/artful-proposed

Author: Merge-o-Matic
Author Date: 2017-08-17 10:20:03 UTC

Import patches-applied version 1.9.7-2ubuntu1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 2c4911717df11c407307094a47088a0e342c5342
Unapplied parent: a0aca3979440da3bc998476ae898b11a2af88608

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
  * Updated changes:
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level
  * Dropped Ubuntu changes:
    - debian/patches/CVE-2017-9800-1.9.6.patch: fixed upstream
    - debian/control: drop X-Python-Versions: as it is no longer
      needed with 2.7 the only remaining supported python 2 version
      and on obsolete flag
    - debian/rules: drop change that ignores swig test failures

ubuntu/artful 2017-08-25 16:28:38 UTC 2017-08-25
Import patches-unapplied version 1.9.7-2ubuntu1 to ubuntu/artful-proposed

Author: Merge-o-Matic
Author Date: 2017-08-17 10:20:03 UTC

Import patches-unapplied version 1.9.7-2ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 727893a63879efeaa6a3ea69bda2fa1cc3e6727a

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
  * Updated changes:
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level
  * Dropped Ubuntu changes:
    - debian/patches/CVE-2017-9800-1.9.6.patch: fixed upstream
    - debian/control: drop X-Python-Versions: as it is no longer
      needed with 2.7 the only remaining supported python 2 version
      and on obsolete flag
    - debian/rules: drop change that ignores swig test failures

ubuntu/artful-devel 2017-08-25 16:28:38 UTC 2017-08-25
Import patches-unapplied version 1.9.7-2ubuntu1 to ubuntu/artful-proposed

Author: Merge-o-Matic
Author Date: 2017-08-17 10:20:03 UTC

Import patches-unapplied version 1.9.7-2ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 727893a63879efeaa6a3ea69bda2fa1cc3e6727a

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
  * Updated changes:
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level
  * Dropped Ubuntu changes:
    - debian/patches/CVE-2017-9800-1.9.6.patch: fixed upstream
    - debian/control: drop X-Python-Versions: as it is no longer
      needed with 2.7 the only remaining supported python 2 version
      and on obsolete flag
    - debian/rules: drop change that ignores swig test failures

ubuntu/artful-proposed 2017-08-25 16:28:38 UTC 2017-08-25
Import patches-unapplied version 1.9.7-2ubuntu1 to ubuntu/artful-proposed

Author: Merge-o-Matic
Author Date: 2017-08-17 10:20:03 UTC

Import patches-unapplied version 1.9.7-2ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 727893a63879efeaa6a3ea69bda2fa1cc3e6727a

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
  * Updated changes:
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level
  * Dropped Ubuntu changes:
    - debian/patches/CVE-2017-9800-1.9.6.patch: fixed upstream
    - debian/control: drop X-Python-Versions: as it is no longer
      needed with 2.7 the only remaining supported python 2 version
      and on obsolete flag
    - debian/rules: drop change that ignores swig test failures

applied/ubuntu/artful 2017-08-25 16:28:38 UTC 2017-08-25
Import patches-applied version 1.9.7-2ubuntu1 to applied/ubuntu/artful-proposed

Author: Merge-o-Matic
Author Date: 2017-08-17 10:20:03 UTC

Import patches-applied version 1.9.7-2ubuntu1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 2c4911717df11c407307094a47088a0e342c5342
Unapplied parent: a0aca3979440da3bc998476ae898b11a2af88608

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - debian/patches/verbose-tests: Make tests verbose.
  * Updated changes:
    - debian/rules: add verbosity level to --with-ruby-test-verbose
      configure argument as the ruby swig test errors out without a
      specific level
  * Dropped Ubuntu changes:
    - debian/patches/CVE-2017-9800-1.9.6.patch: fixed upstream
    - debian/control: drop X-Python-Versions: as it is no longer
      needed with 2.7 the only remaining supported python 2 version
      and on obsolete flag
    - debian/rules: drop change that ignores swig test failures

applied/ubuntu/zesty-security 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-applied version 1.9.5-1ubuntu1.1 to applied/ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-08-10 05:28:44 UTC

Import patches-applied version 1.9.5-1ubuntu1.1 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: ae35dece05a798397aee476a468281bf05ab0442
Unapplied parent: 5a98e742f3e77518ef6794f577134e938b642a21

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.9.6.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800

applied/ubuntu/zesty-devel 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-applied version 1.9.5-1ubuntu1.1 to applied/ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-08-10 05:28:44 UTC

Import patches-applied version 1.9.5-1ubuntu1.1 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: ae35dece05a798397aee476a468281bf05ab0442
Unapplied parent: 5a98e742f3e77518ef6794f577134e938b642a21

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.9.6.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800

applied/ubuntu/zesty-updates 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-applied version 1.9.5-1ubuntu1.1 to applied/ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-08-10 05:28:44 UTC

Import patches-applied version 1.9.5-1ubuntu1.1 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: ae35dece05a798397aee476a468281bf05ab0442
Unapplied parent: 5a98e742f3e77518ef6794f577134e938b642a21

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.9.6.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800

applied/ubuntu/trusty-security 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-applied version 1.8.8-1ubuntu3.3 to applied/ubuntu/trusty-secu...

Author: Steve Beattie
Author Date: 2017-08-10 07:00:57 UTC

Import patches-applied version 1.8.8-1ubuntu3.3 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 86be3f5def0ba6608935d76c5d16632c5abeeca3
Unapplied parent: 48d7131949f57b11ffa86e8bb6f20960a9ea13f0

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.8.18.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800
  * SECURITY UPDATE: svnserve/sasl may authenticate users using the
    wrong realm.
    - debian/patches/CVE-2016-2167.patch: Reject invalid usernames when
      SASL is being used.
    - CVE-2016-2167
  * SECURITY UPDATE: remotely triggerable crash in the mod_authz_svn
    module.
    - debian/patches/CVE-2016-2167.patch: Reject requests with invalid
      Destination headers.
    - CVE-2016-2168
  * SECURITY UPDATE: denial-of-service caused by exponential XML
    entity expansion ("billion laughs attack").
    - debian/patches/CVE-2016-8734-1,8.patch: properly error out the
      parser on invalid data.
    - CVE-2016-8734
  * SECURITY UPDATE: mod_dav_svn: integer overflow when parsing
    skel-encoded request bodies.
    - debian/patches/CVE-2015-5343.patch: Defer memory allocation
      when reading skel-encoded requests.
    - CVE-2015-5343

applied/ubuntu/trusty-devel 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-applied version 1.8.8-1ubuntu3.3 to applied/ubuntu/trusty-secu...

Author: Steve Beattie
Author Date: 2017-08-10 07:00:57 UTC

Import patches-applied version 1.8.8-1ubuntu3.3 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 86be3f5def0ba6608935d76c5d16632c5abeeca3
Unapplied parent: 48d7131949f57b11ffa86e8bb6f20960a9ea13f0

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.8.18.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800
  * SECURITY UPDATE: svnserve/sasl may authenticate users using the
    wrong realm.
    - debian/patches/CVE-2016-2167.patch: Reject invalid usernames when
      SASL is being used.
    - CVE-2016-2167
  * SECURITY UPDATE: remotely triggerable crash in the mod_authz_svn
    module.
    - debian/patches/CVE-2016-2167.patch: Reject requests with invalid
      Destination headers.
    - CVE-2016-2168
  * SECURITY UPDATE: denial-of-service caused by exponential XML
    entity expansion ("billion laughs attack").
    - debian/patches/CVE-2016-8734-1,8.patch: properly error out the
      parser on invalid data.
    - CVE-2016-8734
  * SECURITY UPDATE: mod_dav_svn: integer overflow when parsing
    skel-encoded request bodies.
    - debian/patches/CVE-2015-5343.patch: Defer memory allocation
      when reading skel-encoded requests.
    - CVE-2015-5343

applied/ubuntu/trusty-updates 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-applied version 1.8.8-1ubuntu3.3 to applied/ubuntu/trusty-secu...

Author: Steve Beattie
Author Date: 2017-08-10 07:00:57 UTC

Import patches-applied version 1.8.8-1ubuntu3.3 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 86be3f5def0ba6608935d76c5d16632c5abeeca3
Unapplied parent: 48d7131949f57b11ffa86e8bb6f20960a9ea13f0

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.8.18.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800
  * SECURITY UPDATE: svnserve/sasl may authenticate users using the
    wrong realm.
    - debian/patches/CVE-2016-2167.patch: Reject invalid usernames when
      SASL is being used.
    - CVE-2016-2167
  * SECURITY UPDATE: remotely triggerable crash in the mod_authz_svn
    module.
    - debian/patches/CVE-2016-2167.patch: Reject requests with invalid
      Destination headers.
    - CVE-2016-2168
  * SECURITY UPDATE: denial-of-service caused by exponential XML
    entity expansion ("billion laughs attack").
    - debian/patches/CVE-2016-8734-1,8.patch: properly error out the
      parser on invalid data.
    - CVE-2016-8734
  * SECURITY UPDATE: mod_dav_svn: integer overflow when parsing
    skel-encoded request bodies.
    - debian/patches/CVE-2015-5343.patch: Defer memory allocation
      when reading skel-encoded requests.
    - CVE-2015-5343

ubuntu/trusty-security 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-unapplied version 1.8.8-1ubuntu3.3 to ubuntu/trusty-security

Author: Steve Beattie
Author Date: 2017-08-10 07:00:57 UTC

Import patches-unapplied version 1.8.8-1ubuntu3.3 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 3f76ecc1d15dc7ef89459479a5c03141c4c5179b

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.8.18.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800
  * SECURITY UPDATE: svnserve/sasl may authenticate users using the
    wrong realm.
    - debian/patches/CVE-2016-2167.patch: Reject invalid usernames when
      SASL is being used.
    - CVE-2016-2167
  * SECURITY UPDATE: remotely triggerable crash in the mod_authz_svn
    module.
    - debian/patches/CVE-2016-2167.patch: Reject requests with invalid
      Destination headers.
    - CVE-2016-2168
  * SECURITY UPDATE: denial-of-service caused by exponential XML
    entity expansion ("billion laughs attack").
    - debian/patches/CVE-2016-8734-1,8.patch: properly error out the
      parser on invalid data.
    - CVE-2016-8734
  * SECURITY UPDATE: mod_dav_svn: integer overflow when parsing
    skel-encoded request bodies.
    - debian/patches/CVE-2015-5343.patch: Defer memory allocation
      when reading skel-encoded requests.
    - CVE-2015-5343

ubuntu/trusty-devel 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-unapplied version 1.8.8-1ubuntu3.3 to ubuntu/trusty-security

Author: Steve Beattie
Author Date: 2017-08-10 07:00:57 UTC

Import patches-unapplied version 1.8.8-1ubuntu3.3 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 3f76ecc1d15dc7ef89459479a5c03141c4c5179b

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.8.18.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800
  * SECURITY UPDATE: svnserve/sasl may authenticate users using the
    wrong realm.
    - debian/patches/CVE-2016-2167.patch: Reject invalid usernames when
      SASL is being used.
    - CVE-2016-2167
  * SECURITY UPDATE: remotely triggerable crash in the mod_authz_svn
    module.
    - debian/patches/CVE-2016-2167.patch: Reject requests with invalid
      Destination headers.
    - CVE-2016-2168
  * SECURITY UPDATE: denial-of-service caused by exponential XML
    entity expansion ("billion laughs attack").
    - debian/patches/CVE-2016-8734-1,8.patch: properly error out the
      parser on invalid data.
    - CVE-2016-8734
  * SECURITY UPDATE: mod_dav_svn: integer overflow when parsing
    skel-encoded request bodies.
    - debian/patches/CVE-2015-5343.patch: Defer memory allocation
      when reading skel-encoded requests.
    - CVE-2015-5343

ubuntu/trusty-updates 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-unapplied version 1.8.8-1ubuntu3.3 to ubuntu/trusty-security

Author: Steve Beattie
Author Date: 2017-08-10 07:00:57 UTC

Import patches-unapplied version 1.8.8-1ubuntu3.3 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 3f76ecc1d15dc7ef89459479a5c03141c4c5179b

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.8.18.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800
  * SECURITY UPDATE: svnserve/sasl may authenticate users using the
    wrong realm.
    - debian/patches/CVE-2016-2167.patch: Reject invalid usernames when
      SASL is being used.
    - CVE-2016-2167
  * SECURITY UPDATE: remotely triggerable crash in the mod_authz_svn
    module.
    - debian/patches/CVE-2016-2167.patch: Reject requests with invalid
      Destination headers.
    - CVE-2016-2168
  * SECURITY UPDATE: denial-of-service caused by exponential XML
    entity expansion ("billion laughs attack").
    - debian/patches/CVE-2016-8734-1,8.patch: properly error out the
      parser on invalid data.
    - CVE-2016-8734
  * SECURITY UPDATE: mod_dav_svn: integer overflow when parsing
    skel-encoded request bodies.
    - debian/patches/CVE-2015-5343.patch: Defer memory allocation
      when reading skel-encoded requests.
    - CVE-2015-5343

ubuntu/zesty-devel 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-unapplied version 1.9.5-1ubuntu1.1 to ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-08-10 05:28:44 UTC

Import patches-unapplied version 1.9.5-1ubuntu1.1 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: b4a3517f487283769b9cc521cf8fb112a795929e

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.9.6.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800

ubuntu/zesty-updates 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-unapplied version 1.9.5-1ubuntu1.1 to ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-08-10 05:28:44 UTC

Import patches-unapplied version 1.9.5-1ubuntu1.1 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: b4a3517f487283769b9cc521cf8fb112a795929e

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.9.6.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800

ubuntu/zesty-security 2017-08-11 06:19:36 UTC 2017-08-11
Import patches-unapplied version 1.9.5-1ubuntu1.1 to ubuntu/zesty-security

Author: Steve Beattie
Author Date: 2017-08-10 05:28:44 UTC

Import patches-unapplied version 1.9.5-1ubuntu1.1 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: b4a3517f487283769b9cc521cf8fb112a795929e

New changelog entries:
  * SECURITY UPDATE: Arbitrary code execution on clients through
    malicious svn+ssh URLs
    - debian/patches/CVE-2017-9800-1.9.6.patch: ensure that host
      arguments to ssh cannot be treated as ssh options.
    - CVE-2017-9800

applied/ubuntu/zesty-proposed 2017-02-15 18:28:59 UTC 2017-02-15
Import patches-applied version 1.9.5-1ubuntu1 to applied/ubuntu/zesty-proposed

Author: FanJun Kong - ( BH1SCW )
Author Date: 2017-02-13 14:27:30 UTC

Import patches-applied version 1.9.5-1ubuntu1 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 1d4828a7391fb8a2a7b48d46a3f406f04e00de4a
Unapplied parent: b4a3517f487283769b9cc521cf8fb112a795929e

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

applied/ubuntu/zesty 2017-02-15 18:28:59 UTC 2017-02-15
Import patches-applied version 1.9.5-1ubuntu1 to applied/ubuntu/zesty-proposed

Author: FanJun Kong - ( BH1SCW )
Author Date: 2017-02-13 14:27:30 UTC

Import patches-applied version 1.9.5-1ubuntu1 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 1d4828a7391fb8a2a7b48d46a3f406f04e00de4a
Unapplied parent: b4a3517f487283769b9cc521cf8fb112a795929e

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

ubuntu/zesty-proposed 2017-02-15 18:28:59 UTC 2017-02-15
Import patches-unapplied version 1.9.5-1ubuntu1 to ubuntu/zesty-proposed

Author: FanJun Kong - ( BH1SCW )
Author Date: 2017-02-13 14:27:30 UTC

Import patches-unapplied version 1.9.5-1ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 4e8aacc6a9f844427d0b7427ce1e148b63351c5f

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

ubuntu/zesty 2017-02-15 18:28:59 UTC 2017-02-15
Import patches-unapplied version 1.9.5-1ubuntu1 to ubuntu/zesty-proposed

Author: FanJun Kong - ( BH1SCW )
Author Date: 2017-02-13 14:27:30 UTC

Import patches-unapplied version 1.9.5-1ubuntu1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 4e8aacc6a9f844427d0b7427ce1e148b63351c5f

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

applied/ubuntu/yakkety 2016-05-25 15:04:23 UTC 2016-05-25
Import patches-applied version 1.9.4-1ubuntu1 to applied/ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-05-25 14:08:13 UTC

Import patches-applied version 1.9.4-1ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 4fc2f4f1e6704b8fc739e7afb86ae2a523d88454
Unapplied parent: 959c8aaab9ed192321fec5dc9d4974b7aa56ce49

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

applied/ubuntu/yakkety-devel 2016-05-25 15:04:23 UTC 2016-05-25
Import patches-applied version 1.9.4-1ubuntu1 to applied/ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-05-25 14:08:13 UTC

Import patches-applied version 1.9.4-1ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 4fc2f4f1e6704b8fc739e7afb86ae2a523d88454
Unapplied parent: 959c8aaab9ed192321fec5dc9d4974b7aa56ce49

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

applied/ubuntu/yakkety-proposed 2016-05-25 15:04:23 UTC 2016-05-25
Import patches-applied version 1.9.4-1ubuntu1 to applied/ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-05-25 14:08:13 UTC

Import patches-applied version 1.9.4-1ubuntu1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 4fc2f4f1e6704b8fc739e7afb86ae2a523d88454
Unapplied parent: 959c8aaab9ed192321fec5dc9d4974b7aa56ce49

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

ubuntu/yakkety-devel 2016-05-25 15:04:23 UTC 2016-05-25
Import patches-unapplied version 1.9.4-1ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-05-25 14:08:13 UTC

Import patches-unapplied version 1.9.4-1ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 44a25ff5112b7666a4ced7c0b7adbd9f377c8460

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

ubuntu/yakkety-proposed 2016-05-25 15:04:23 UTC 2016-05-25
Import patches-unapplied version 1.9.4-1ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-05-25 14:08:13 UTC

Import patches-unapplied version 1.9.4-1ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 44a25ff5112b7666a4ced7c0b7adbd9f377c8460

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

ubuntu/yakkety 2016-05-25 15:04:23 UTC 2016-05-25
Import patches-unapplied version 1.9.4-1ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-05-25 14:08:13 UTC

Import patches-unapplied version 1.9.4-1ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 44a25ff5112b7666a4ced7c0b7adbd9f377c8460

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

ubuntu/xenial 2016-03-14 07:43:47 UTC 2016-03-14
Import patches-unapplied version 1.9.3-2ubuntu1 to ubuntu/xenial-proposed

Author: Matthias Klose
Author Date: 2016-03-14 07:29:53 UTC

Import patches-unapplied version 1.9.3-2ubuntu1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 57a2b2b8c494659c790a2ed60ae7234855212d69

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

applied/ubuntu/xenial 2016-03-14 07:43:47 UTC 2016-03-14
Import patches-applied version 1.9.3-2ubuntu1 to applied/ubuntu/xenial-proposed

Author: Matthias Klose
Author Date: 2016-03-14 07:29:53 UTC

Import patches-applied version 1.9.3-2ubuntu1 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: dda38bdec1c05d932fd0877a6fe716d66c761105
Unapplied parent: b08934ac8ca23020d724c1db95d493702dfd7041

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build a python-subversion-dbg package.
    - Build-depend on python-all-dbg.
    - Only build on requested python versions (X-Python-Versions:).
    - debian/patches/verbose-tests: Make tests verbose.

ubuntu/wily-proposed 2015-09-08 15:13:59 UTC 2015-09-08
Import patches-unapplied version 1.8.13-1ubuntu3 to ubuntu/wily-proposed

Author: Matthias Klose
Author Date: 2015-09-08 14:49:49 UTC

Import patches-unapplied version 1.8.13-1ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 14acf5228143a90abb0577f1637c2289f4c6c4d6

New changelog entries:
  * No-change rebuild to add ruby2.2 support.

ubuntu/wily 2015-09-08 15:13:59 UTC 2015-09-08
Import patches-unapplied version 1.8.13-1ubuntu3 to ubuntu/wily-proposed

Author: Matthias Klose
Author Date: 2015-09-08 14:49:49 UTC

Import patches-unapplied version 1.8.13-1ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 14acf5228143a90abb0577f1637c2289f4c6c4d6

New changelog entries:
  * No-change rebuild to add ruby2.2 support.

ubuntu/wily-devel 2015-09-08 15:13:59 UTC 2015-09-08
Import patches-unapplied version 1.8.13-1ubuntu3 to ubuntu/wily-proposed

Author: Matthias Klose
Author Date: 2015-09-08 14:49:49 UTC

Import patches-unapplied version 1.8.13-1ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 14acf5228143a90abb0577f1637c2289f4c6c4d6

New changelog entries:
  * No-change rebuild to add ruby2.2 support.

applied/ubuntu/wily-devel 2015-09-08 15:13:59 UTC 2015-09-08
Import patches-applied version 1.8.13-1ubuntu3 to applied/ubuntu/wily-proposed

Author: Matthias Klose
Author Date: 2015-09-08 14:49:49 UTC

Import patches-applied version 1.8.13-1ubuntu3 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: e3151969fd5f461bbad4223ba8281edd5eba3b05
Unapplied parent: 7122017a982ab799636eae162813898cb46786b3

New changelog entries:
  * No-change rebuild to add ruby2.2 support.

applied/ubuntu/wily 2015-09-08 15:13:59 UTC 2015-09-08
Import patches-applied version 1.8.13-1ubuntu3 to applied/ubuntu/wily-proposed

Author: Matthias Klose
Author Date: 2015-09-08 14:49:49 UTC

Import patches-applied version 1.8.13-1ubuntu3 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: e3151969fd5f461bbad4223ba8281edd5eba3b05
Unapplied parent: 7122017a982ab799636eae162813898cb46786b3

New changelog entries:
  * No-change rebuild to add ruby2.2 support.

applied/ubuntu/wily-proposed 2015-09-08 15:13:59 UTC 2015-09-08
Import patches-applied version 1.8.13-1ubuntu3 to applied/ubuntu/wily-proposed

Author: Matthias Klose
Author Date: 2015-09-08 14:49:49 UTC

Import patches-applied version 1.8.13-1ubuntu3 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: e3151969fd5f461bbad4223ba8281edd5eba3b05
Unapplied parent: 7122017a982ab799636eae162813898cb46786b3

New changelog entries:
  * No-change rebuild to add ruby2.2 support.

debian/wheezy 2015-09-05 17:13:55 UTC 2015-09-05
Import patches-unapplied version 1.6.17dfsg-4+deb7u10 to debian/wheezy

Author: James McCoy
Author Date: 2015-08-10 03:39:21 UTC

Import patches-unapplied version 1.6.17dfsg-4+deb7u10 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 186fa5d9569ceeb7d3c1370c8c8e819ce9ff7235

New changelog entries:
  * patches/CVE-2015-3817: svn_repos_trace_node_locations() reveals paths
    hidden by authz
  * patches/CVE-2015-0248: Assertion DoS vulnerability for certain mod_dav_svn
    and svnserve requests with dynamically evaluated revision numbers
  * patches/CVE-2015-0251: mod_dav_svn allows spoofing svn:author property
    values for new revisions

applied/debian/wheezy 2015-09-05 17:13:55 UTC 2015-09-05
Import patches-applied version 1.6.17dfsg-4+deb7u10 to applied/debian/wheezy

Author: James McCoy
Author Date: 2015-08-10 03:39:21 UTC

Import patches-applied version 1.6.17dfsg-4+deb7u10 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 98f19be40ce964d4bbf9959684f9b36c52555ed6
Unapplied parent: b29b2885e1c027093391353a5f8df424467f6aae

New changelog entries:
  * patches/CVE-2015-3817: svn_repos_trace_node_locations() reveals paths
    hidden by authz
  * patches/CVE-2015-0248: Assertion DoS vulnerability for certain mod_dav_svn
    and svnserve requests with dynamically evaluated revision numbers
  * patches/CVE-2015-0251: mod_dav_svn allows spoofing svn:author property
    values for new revisions

applied/ubuntu/vivid-security 2015-08-20 17:38:48 UTC 2015-08-20
Import patches-applied version 1.8.10-5ubuntu1.1 to applied/ubuntu/vivid-secu...

Author: Marc Deslauriers
Author Date: 2015-08-19 16:38:31 UTC

Import patches-applied version 1.8.10-5ubuntu1.1 to applied/ubuntu/vivid-security

Imported using git-ubuntu import.

Changelog parent: 626a55a13240362898aa548f910b0c95c6d89707
Unapplied parent: 6fb6a8b5c4f2d0376b366baa8ffc2de5a2546562

New changelog entries:
  * SECURITY UPDATE: denial of service via large number of REPORT requests
    - debian/patches/CVE-2015-0202.patch: refactor locking in
      subversion/libsvn_fs_fs/tree.c.
    - CVE-2015-0202
  * SECURITY UPDATE: denial of service via crafted parameter combinations
    - debian/patches/CVE-2015-0248.patch: properly handle missing revision
      numbers in subversion/mod_dav_svn/reports/get-location-segments.c,
      subversion/svnserve/serve.c.
    - CVE-2015-0248
  * SECURITY UPDATE: svn:author property spoofing issue
    - debian/patches/CVE-2015-0251.patch: restrict svn:author modifications
      in subversion/mod_dav_svn/deadprops.c.
    - CVE-2015-0251
  * SECURITY UPDATE: incorrect anonymous access restriction
    - debian/patches/CVE-2015-3184.patch: use force_authn() in Makefile.in,
      build/ac-macros/apache.m4, build/run_tests.py,
      subversion/mod_authz_svn/mod_authz_svn.c,
      subversion/tests/cmdline/README,
      subversion/tests/cmdline/davautocheck.sh,
      subversion/tests/cmdline/mod_authz_svn_tests.py,
      subversion/tests/cmdline/svntest/main.py, win-tests.py.
    - CVE-2015-3184
  * SECURITY UPDATE: sensitive path information disclosure
    - debian/patches/CVE-2015-3187.patch: fix order in
      subversion/libsvn_repos/rev_hunt.c, added tests to
      subversion/tests/cmdline/authz_tests.py,
      subversion/tests/libsvn_repos/repos-test.c.
    - CVE-2015-3187
  * debian/control: Depend on specific version of apache2-dev and
    apache2-bin to make sure fix for CVE-2015-3185 is included.

ubuntu/vivid-devel 2015-08-20 17:38:48 UTC 2015-08-20
Import patches-unapplied version 1.8.10-5ubuntu1.1 to ubuntu/vivid-security

Author: Marc Deslauriers
Author Date: 2015-08-19 16:38:31 UTC

Import patches-unapplied version 1.8.10-5ubuntu1.1 to ubuntu/vivid-security

Imported using git-ubuntu import.

Changelog parent: b51f49d4357d97a8dde6159770efb4d89f00fc99

New changelog entries:
  * SECURITY UPDATE: denial of service via large number of REPORT requests
    - debian/patches/CVE-2015-0202.patch: refactor locking in
      subversion/libsvn_fs_fs/tree.c.
    - CVE-2015-0202
  * SECURITY UPDATE: denial of service via crafted parameter combinations
    - debian/patches/CVE-2015-0248.patch: properly handle missing revision
      numbers in subversion/mod_dav_svn/reports/get-location-segments.c,
      subversion/svnserve/serve.c.
    - CVE-2015-0248
  * SECURITY UPDATE: svn:author property spoofing issue
    - debian/patches/CVE-2015-0251.patch: restrict svn:author modifications
      in subversion/mod_dav_svn/deadprops.c.
    - CVE-2015-0251
  * SECURITY UPDATE: incorrect anonymous access restriction
    - debian/patches/CVE-2015-3184.patch: use force_authn() in Makefile.in,
      build/ac-macros/apache.m4, build/run_tests.py,
      subversion/mod_authz_svn/mod_authz_svn.c,
      subversion/tests/cmdline/README,
      subversion/tests/cmdline/davautocheck.sh,
      subversion/tests/cmdline/mod_authz_svn_tests.py,
      subversion/tests/cmdline/svntest/main.py, win-tests.py.
    - CVE-2015-3184
  * SECURITY UPDATE: sensitive path information disclosure
    - debian/patches/CVE-2015-3187.patch: fix order in
      subversion/libsvn_repos/rev_hunt.c, added tests to
      subversion/tests/cmdline/authz_tests.py,
      subversion/tests/libsvn_repos/repos-test.c.
    - CVE-2015-3187
  * debian/control: Depend on specific version of apache2-dev and
    apache2-bin to make sure fix for CVE-2015-3185 is included.

ubuntu/precise-updates 2015-08-20 17:38:48 UTC 2015-08-20
Import patches-unapplied version 1.6.17dfsg-3ubuntu3.5 to ubuntu/precise-secu...

Author: Marc Deslauriers
Author Date: 2015-08-20 12:53:48 UTC

Import patches-unapplied version 1.6.17dfsg-3ubuntu3.5 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 4fc4051a02ab7fb45c47ac3f5c9c7bc30603e701

New changelog entries:
  * SECURITY UPDATE: denial of service via non-existing REPORT request
    - debian/patches/CVE-2014-3580.patch: make sure repo paths are
      specified in subversion/mod_dav_svn/reports/deleted-rev.c,
      subversion/mod_dav_svn/reports/file-revs.c,
      subversion/mod_dav_svn/reports/get-location-segments.c,
      subversion/mod_dav_svn/reports/get-locations.c,
      subversion/mod_dav_svn/reports/log.c,
      subversion/mod_dav_svn/reports/mergeinfo.c.
    - CVE-2014-3580
  * SECURITY UPDATE: denial of service via crafted parameter combinations
    - debian/patches/CVE-2015-0248.patch: properly handle missing revision
      numbers in subversion/mod_dav_svn/reports/get-location-segments.c,
      subversion/svnserve/serve.c.
    - CVE-2015-0248
  * SECURITY UPDATE: svn:author property spoofing issue
    - debian/patches/CVE-2015-0251.patch: restrict svn:author modifications
      in subversion/mod_dav_svn/deadprops.c.
    - CVE-2015-0251
  * SECURITY UPDATE: sensitive path information disclosure
    - debian/patches/CVE-2015-3187.patch: fix order in
      subversion/libsvn_repos/rev_hunt.c, added tests to
      subversion/tests/cmdline/authz_tests.py,
      subversion/tests/libsvn_repos/repos-test.c.
    - CVE-2015-3187

ubuntu/precise-security 2015-08-20 17:38:48 UTC 2015-08-20
Import patches-unapplied version 1.6.17dfsg-3ubuntu3.5 to ubuntu/precise-secu...

Author: Marc Deslauriers
Author Date: 2015-08-20 12:53:48 UTC

Import patches-unapplied version 1.6.17dfsg-3ubuntu3.5 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 4fc4051a02ab7fb45c47ac3f5c9c7bc30603e701

New changelog entries:
  * SECURITY UPDATE: denial of service via non-existing REPORT request
    - debian/patches/CVE-2014-3580.patch: make sure repo paths are
      specified in subversion/mod_dav_svn/reports/deleted-rev.c,
      subversion/mod_dav_svn/reports/file-revs.c,
      subversion/mod_dav_svn/reports/get-location-segments.c,
      subversion/mod_dav_svn/reports/get-locations.c,
      subversion/mod_dav_svn/reports/log.c,
      subversion/mod_dav_svn/reports/mergeinfo.c.
    - CVE-2014-3580
  * SECURITY UPDATE: denial of service via crafted parameter combinations
    - debian/patches/CVE-2015-0248.patch: properly handle missing revision
      numbers in subversion/mod_dav_svn/reports/get-location-segments.c,
      subversion/svnserve/serve.c.
    - CVE-2015-0248
  * SECURITY UPDATE: svn:author property spoofing issue
    - debian/patches/CVE-2015-0251.patch: restrict svn:author modifications
      in subversion/mod_dav_svn/deadprops.c.
    - CVE-2015-0251
  * SECURITY UPDATE: sensitive path information disclosure
    - debian/patches/CVE-2015-3187.patch: fix order in
      subversion/libsvn_repos/rev_hunt.c, added tests to
      subversion/tests/cmdline/authz_tests.py,
      subversion/tests/libsvn_repos/repos-test.c.
    - CVE-2015-3187

1100 of 256 results

Other repositories

Name Last Modified
lp:ubuntu/+source/subversion 2019-10-18
11 of 1 result
You can't create new repositories for subversion in Ubuntu.