View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/shim-signed
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2020-04-09 21:11:40 UTC 2020-04-09
DSC file for 1.40.3

Author: Ubuntu Git Importer
Author Date: 2020-04-09 21:11:40 UTC

DSC file for 1.40.3

applied/ubuntu/focal-devel 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: fa3f9573aabb2cf1361bb11d3d1b353e4c2f16b3
Unapplied parent: 8ac15af6c295ac6f34a75f320a87d6f25c49c05c

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

applied/ubuntu/focal 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: fa3f9573aabb2cf1361bb11d3d1b353e4c2f16b3
Unapplied parent: 8ac15af6c295ac6f34a75f320a87d6f25c49c05c

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

ubuntu/devel 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: b29d166ea13782ae190bb2f0a15a8b00c0a703d3

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

ubuntu/focal 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: b29d166ea13782ae190bb2f0a15a8b00c0a703d3

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

ubuntu/focal-devel 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: b29d166ea13782ae190bb2f0a15a8b00c0a703d3

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

ubuntu/focal-proposed 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: b29d166ea13782ae190bb2f0a15a8b00c0a703d3

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

applied/ubuntu/focal-proposed 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: fa3f9573aabb2cf1361bb11d3d1b353e4c2f16b3
Unapplied parent: 8ac15af6c295ac6f34a75f320a87d6f25c49c05c

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

applied/ubuntu/devel 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: fa3f9573aabb2cf1361bb11d3d1b353e4c2f16b3
Unapplied parent: 8ac15af6c295ac6f34a75f320a87d6f25c49c05c

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

applied/ubuntu/groovy-devel 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: fa3f9573aabb2cf1361bb11d3d1b353e4c2f16b3
Unapplied parent: 8ac15af6c295ac6f34a75f320a87d6f25c49c05c

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

applied/ubuntu/groovy 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-applied version 1.40.3 to applied/ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: fa3f9573aabb2cf1361bb11d3d1b353e4c2f16b3
Unapplied parent: 8ac15af6c295ac6f34a75f320a87d6f25c49c05c

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

ubuntu/groovy-devel 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: b29d166ea13782ae190bb2f0a15a8b00c0a703d3

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

ubuntu/groovy 2020-04-09 19:03:25 UTC 2020-04-09
Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Author: Julian Andres Klode
Author Date: 2020-04-09 20:48:31 UTC

Import patches-unapplied version 1.40.3 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: b29d166ea13782ae190bb2f0a15a8b00c0a703d3

New changelog entries:
  * Depend on the correct version of grub-signed (LP: #1871895)

importer/debian/dsc 2020-03-30 17:34:13 UTC 2020-03-30
DSC file for 1.33

Author: Ubuntu Git Importer
Author Date: 2020-03-30 17:34:13 UTC

DSC file for 1.33

ubuntu/bionic-devel 2020-02-10 18:25:59 UTC 2020-02-10
Import patches-unapplied version 1.37~18.04.5 to ubuntu/bionic-proposed

Author: Steve Langasek
Author Date: 2020-02-10 09:50:46 UTC

Import patches-unapplied version 1.37~18.04.5 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: a94f6d6950c74e3bed560fc2c5b850fe3a38b968

New changelog entries:
  * Fix versioned dependency on mokutil so that it matches the version in
    bionic-updates. LP: #1862632.

applied/ubuntu/bionic-devel 2020-02-10 18:25:59 UTC 2020-02-10
Import patches-applied version 1.37~18.04.5 to applied/ubuntu/bionic-proposed

Author: Steve Langasek
Author Date: 2020-02-10 09:50:46 UTC

Import patches-applied version 1.37~18.04.5 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: a2cb82fa3501c0a53f206609790c831ac655eeb1
Unapplied parent: 51421599171946227aa15cdc58a50fe90a727e67

New changelog entries:
  * Fix versioned dependency on mokutil so that it matches the version in
    bionic-updates. LP: #1862632.

applied/ubuntu/bionic-proposed 2020-02-10 18:25:59 UTC 2020-02-10
Import patches-applied version 1.37~18.04.5 to applied/ubuntu/bionic-proposed

Author: Steve Langasek
Author Date: 2020-02-10 09:50:46 UTC

Import patches-applied version 1.37~18.04.5 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: a2cb82fa3501c0a53f206609790c831ac655eeb1
Unapplied parent: 51421599171946227aa15cdc58a50fe90a727e67

New changelog entries:
  * Fix versioned dependency on mokutil so that it matches the version in
    bionic-updates. LP: #1862632.

ubuntu/bionic-proposed 2020-02-10 18:25:59 UTC 2020-02-10
Import patches-unapplied version 1.37~18.04.5 to ubuntu/bionic-proposed

Author: Steve Langasek
Author Date: 2020-02-10 09:50:46 UTC

Import patches-unapplied version 1.37~18.04.5 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: a94f6d6950c74e3bed560fc2c5b850fe3a38b968

New changelog entries:
  * Fix versioned dependency on mokutil so that it matches the version in
    bionic-updates. LP: #1862632.

applied/ubuntu/eoan-proposed 2020-02-07 17:15:05 UTC 2020-02-07
Import patches-applied version 1.39.1 to applied/ubuntu/eoan-proposed

Author: Steve Langasek
Author Date: 2019-12-14 20:58:35 UTC

Import patches-applied version 1.39.1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 75ca3d8373337f54fa3da817421a9d929ef69888
Unapplied parent: 8adee2580e11e2d536e544c84c03f2ef1b836401

New changelog entries:
  * Pass --timeout -1 to mokutil so that users don't end up with broken
    systems by missing MokManager on reboot after install. LP: #1856422.
  * Add a versioned dependency on the mokutil that introduces --timeout.

ubuntu/eoan-proposed 2020-02-07 17:15:05 UTC 2020-02-07
Import patches-unapplied version 1.39.1 to ubuntu/eoan-proposed

Author: Steve Langasek
Author Date: 2019-12-14 20:58:35 UTC

Import patches-unapplied version 1.39.1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: daeace488da40ed5b8bfdfbe689a0cf5623e43a3

New changelog entries:
  * Pass --timeout -1 to mokutil so that users don't end up with broken
    systems by missing MokManager on reboot after install. LP: #1856422.
  * Add a versioned dependency on the mokutil that introduces --timeout.

applied/ubuntu/eoan-devel 2020-02-07 17:15:05 UTC 2020-02-07
Import patches-applied version 1.39.1 to applied/ubuntu/eoan-proposed

Author: Steve Langasek
Author Date: 2019-12-14 20:58:35 UTC

Import patches-applied version 1.39.1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 75ca3d8373337f54fa3da817421a9d929ef69888
Unapplied parent: 8adee2580e11e2d536e544c84c03f2ef1b836401

New changelog entries:
  * Pass --timeout -1 to mokutil so that users don't end up with broken
    systems by missing MokManager on reboot after install. LP: #1856422.
  * Add a versioned dependency on the mokutil that introduces --timeout.

ubuntu/eoan-devel 2020-02-07 17:15:05 UTC 2020-02-07
Import patches-unapplied version 1.39.1 to ubuntu/eoan-proposed

Author: Steve Langasek
Author Date: 2019-12-14 20:58:35 UTC

Import patches-unapplied version 1.39.1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: daeace488da40ed5b8bfdfbe689a0cf5623e43a3

New changelog entries:
  * Pass --timeout -1 to mokutil so that users don't end up with broken
    systems by missing MokManager on reboot after install. LP: #1856422.
  * Add a versioned dependency on the mokutil that introduces --timeout.

applied/debian/buster 2019-06-09 22:38:50 UTC 2019-06-09
Import patches-applied version 1.33 to applied/debian/sid

Author: Steve McIntyre
Author Date: 2019-06-09 17:32:54 UTC

Import patches-applied version 1.33 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: aa17c4e09c8b9b6de1631e6e6609caacb8793a2d
Unapplied parent: 423c0a3c642e560946b9c878156eb02e9ac0010d

New changelog entries:
  * Build against new signed binaries corresponding to
    15+1533136590.3beb971-7
  * Update Build-Depends and Depends to match. Closes: #928107
  * Drop the hard-coded version in Built-Using; pick up the version of
    shim we're using properly.
  * Display the sha256sums of the binaries as we check them

applied/debian/sid 2019-06-09 22:38:50 UTC 2019-06-09
Import patches-applied version 1.33 to applied/debian/sid

Author: Steve McIntyre
Author Date: 2019-06-09 17:32:54 UTC

Import patches-applied version 1.33 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: aa17c4e09c8b9b6de1631e6e6609caacb8793a2d
Unapplied parent: 423c0a3c642e560946b9c878156eb02e9ac0010d

New changelog entries:
  * Build against new signed binaries corresponding to
    15+1533136590.3beb971-7
  * Update Build-Depends and Depends to match. Closes: #928107
  * Drop the hard-coded version in Built-Using; pick up the version of
    shim we're using properly.
  * Display the sha256sums of the binaries as we check them

debian/buster 2019-06-09 22:38:50 UTC 2019-06-09
Import patches-unapplied version 1.33 to debian/sid

Author: Steve McIntyre
Author Date: 2019-06-09 17:32:54 UTC

Import patches-unapplied version 1.33 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 08dce9169dffcc13350431a46be179f39e40f0c9

New changelog entries:
  * Build against new signed binaries corresponding to
    15+1533136590.3beb971-7
  * Update Build-Depends and Depends to match. Closes: #928107
  * Drop the hard-coded version in Built-Using; pick up the version of
    shim we're using properly.
  * Display the sha256sums of the binaries as we check them

debian/sid 2019-06-09 22:38:50 UTC 2019-06-09
Import patches-unapplied version 1.33 to debian/sid

Author: Steve McIntyre
Author Date: 2019-06-09 17:32:54 UTC

Import patches-unapplied version 1.33 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 08dce9169dffcc13350431a46be179f39e40f0c9

New changelog entries:
  * Build against new signed binaries corresponding to
    15+1533136590.3beb971-7
  * Update Build-Depends and Depends to match. Closes: #928107
  * Drop the hard-coded version in Built-Using; pick up the version of
    shim we're using properly.
  * Display the sha256sums of the binaries as we check them

applied/ubuntu/artful 2019-05-28 16:40:21 UTC 2019-05-28
Import patches-applied version 1.32 to applied/debian/sid

Author: Steve McIntyre
Author Date: 2019-05-28 14:23:54 UTC

Import patches-applied version 1.32 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7576345678ffcb343e088eacf9404b92853156ae
Unapplied parent: 08dce9169dffcc13350431a46be179f39e40f0c9

New changelog entries:
  * Add Breaks/Replaces to shim-signed-common for
    update-secureboot-policy etc. Closes: #929673

applied/ubuntu/trusty-updates 2019-04-08 17:40:13 UTC 2019-04-08
Import patches-applied version 1.33.1~14.04.5 to applied/ubuntu/trusty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:20:03 UTC

Import patches-applied version 1.33.1~14.04.5 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 420badc5033c67c05aed12e828ea144e1029a508
Unapplied parent: 548755c64bfd9b3b7d37c3f967d6932c5016c829

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

ubuntu/trusty-devel 2019-04-08 17:40:13 UTC 2019-04-08
Import patches-unapplied version 1.33.1~14.04.5 to ubuntu/trusty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:20:03 UTC

Import patches-unapplied version 1.33.1~14.04.5 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 4697efc51ac47f3cae7bb1ca1422af40bb275c4e

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

applied/ubuntu/trusty-devel 2019-04-08 17:40:13 UTC 2019-04-08
Import patches-applied version 1.33.1~14.04.5 to applied/ubuntu/trusty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:20:03 UTC

Import patches-applied version 1.33.1~14.04.5 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 420badc5033c67c05aed12e828ea144e1029a508
Unapplied parent: 548755c64bfd9b3b7d37c3f967d6932c5016c829

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

applied/ubuntu/trusty-proposed 2019-04-08 17:40:13 UTC 2019-04-08
Import patches-applied version 1.33.1~14.04.5 to applied/ubuntu/trusty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:20:03 UTC

Import patches-applied version 1.33.1~14.04.5 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 420badc5033c67c05aed12e828ea144e1029a508
Unapplied parent: 548755c64bfd9b3b7d37c3f967d6932c5016c829

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

ubuntu/trusty-proposed 2019-04-08 17:40:13 UTC 2019-04-08
Import patches-unapplied version 1.33.1~14.04.5 to ubuntu/trusty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:20:03 UTC

Import patches-unapplied version 1.33.1~14.04.5 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 4697efc51ac47f3cae7bb1ca1422af40bb275c4e

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

ubuntu/trusty-updates 2019-04-08 17:40:13 UTC 2019-04-08
Import patches-unapplied version 1.33.1~14.04.5 to ubuntu/trusty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:20:03 UTC

Import patches-unapplied version 1.33.1~14.04.5 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 4697efc51ac47f3cae7bb1ca1422af40bb275c4e

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

applied/ubuntu/xenial-proposed 2019-04-08 17:38:57 UTC 2019-04-08
Import patches-applied version 1.33.1~16.04.5 to applied/ubuntu/xenial-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:15:21 UTC

Import patches-applied version 1.33.1~16.04.5 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: b7934d919077cd3daed840c1a91eef61ddfe1547
Unapplied parent: 1ec1a646389076f2de1e6380311c1a13ae238db2

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

ubuntu/xenial-proposed 2019-04-08 17:38:57 UTC 2019-04-08
Import patches-unapplied version 1.33.1~16.04.5 to ubuntu/xenial-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:15:21 UTC

Import patches-unapplied version 1.33.1~16.04.5 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 5d27882bfaea3e9904c85414b31c9af1fe84d586

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

ubuntu/xenial-devel 2019-04-08 17:38:57 UTC 2019-04-08
Import patches-unapplied version 1.33.1~16.04.5 to ubuntu/xenial-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:15:21 UTC

Import patches-unapplied version 1.33.1~16.04.5 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 5d27882bfaea3e9904c85414b31c9af1fe84d586

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

ubuntu/xenial-updates 2019-04-08 17:38:57 UTC 2019-04-08
Import patches-unapplied version 1.33.1~16.04.5 to ubuntu/xenial-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:15:21 UTC

Import patches-unapplied version 1.33.1~16.04.5 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 5d27882bfaea3e9904c85414b31c9af1fe84d586

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

applied/ubuntu/xenial-updates 2019-04-08 17:38:57 UTC 2019-04-08
Import patches-applied version 1.33.1~16.04.5 to applied/ubuntu/xenial-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:15:21 UTC

Import patches-applied version 1.33.1~16.04.5 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: b7934d919077cd3daed840c1a91eef61ddfe1547
Unapplied parent: 1ec1a646389076f2de1e6380311c1a13ae238db2

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

applied/ubuntu/xenial-devel 2019-04-08 17:38:57 UTC 2019-04-08
Import patches-applied version 1.33.1~16.04.5 to applied/ubuntu/xenial-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2019-04-01 12:15:21 UTC

Import patches-applied version 1.33.1~16.04.5 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: b7934d919077cd3daed840c1a91eef61ddfe1547
Unapplied parent: 1ec1a646389076f2de1e6380311c1a13ae238db2

New changelog entries:
  * debian/control: make the sbsigntool dependency versioned to ensure updates
    include getting the new sbsigntool so DKMS modules can be correctly signed.
    (LP: #1818929)

applied/ubuntu/eoan 2018-11-14 18:18:09 UTC 2018-11-14
Import patches-applied version 1.39 to applied/ubuntu/disco-proposed

Author: dann frazier
Author Date: 2018-11-14 11:13:42 UTC

Import patches-applied version 1.39 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 8547cf9cf95901f95c4473ebd88d344d13f876df
Unapplied parent: daeace488da40ed5b8bfdfbe689a0cf5623e43a3

New changelog entries:
  * debian/source_shim-signed.py: Correct EFI architecture name for arm64.
  * Parameterize code to remove hardcoded x86-isms.
  * Add arm64 support.

applied/ubuntu/disco 2018-11-14 18:18:09 UTC 2018-11-14
Import patches-applied version 1.39 to applied/ubuntu/disco-proposed

Author: dann frazier
Author Date: 2018-11-14 11:13:42 UTC

Import patches-applied version 1.39 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 8547cf9cf95901f95c4473ebd88d344d13f876df
Unapplied parent: daeace488da40ed5b8bfdfbe689a0cf5623e43a3

New changelog entries:
  * debian/source_shim-signed.py: Correct EFI architecture name for arm64.
  * Parameterize code to remove hardcoded x86-isms.
  * Add arm64 support.

applied/ubuntu/disco-devel 2018-11-14 18:18:09 UTC 2018-11-14
Import patches-applied version 1.39 to applied/ubuntu/disco-proposed

Author: dann frazier
Author Date: 2018-11-14 11:13:42 UTC

Import patches-applied version 1.39 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 8547cf9cf95901f95c4473ebd88d344d13f876df
Unapplied parent: daeace488da40ed5b8bfdfbe689a0cf5623e43a3

New changelog entries:
  * debian/source_shim-signed.py: Correct EFI architecture name for arm64.
  * Parameterize code to remove hardcoded x86-isms.
  * Add arm64 support.

applied/ubuntu/disco-proposed 2018-11-14 18:18:09 UTC 2018-11-14
Import patches-applied version 1.39 to applied/ubuntu/disco-proposed

Author: dann frazier
Author Date: 2018-11-14 11:13:42 UTC

Import patches-applied version 1.39 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 8547cf9cf95901f95c4473ebd88d344d13f876df
Unapplied parent: daeace488da40ed5b8bfdfbe689a0cf5623e43a3

New changelog entries:
  * debian/source_shim-signed.py: Correct EFI architecture name for arm64.
  * Parameterize code to remove hardcoded x86-isms.
  * Add arm64 support.

ubuntu/disco 2018-11-14 18:18:09 UTC 2018-11-14
Import patches-unapplied version 1.39 to ubuntu/disco-proposed

Author: dann frazier
Author Date: 2018-11-14 11:13:42 UTC

Import patches-unapplied version 1.39 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: c8b4418c475d2ff9f43aada60aa901aee4a2a569

New changelog entries:
  * debian/source_shim-signed.py: Correct EFI architecture name for arm64.
  * Parameterize code to remove hardcoded x86-isms.
  * Add arm64 support.

ubuntu/disco-devel 2018-11-14 18:18:09 UTC 2018-11-14
Import patches-unapplied version 1.39 to ubuntu/disco-proposed

Author: dann frazier
Author Date: 2018-11-14 11:13:42 UTC

Import patches-unapplied version 1.39 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: c8b4418c475d2ff9f43aada60aa901aee4a2a569

New changelog entries:
  * debian/source_shim-signed.py: Correct EFI architecture name for arm64.
  * Parameterize code to remove hardcoded x86-isms.
  * Add arm64 support.

ubuntu/disco-proposed 2018-11-14 18:18:09 UTC 2018-11-14
Import patches-unapplied version 1.39 to ubuntu/disco-proposed

Author: dann frazier
Author Date: 2018-11-14 11:13:42 UTC

Import patches-unapplied version 1.39 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: c8b4418c475d2ff9f43aada60aa901aee4a2a569

New changelog entries:
  * debian/source_shim-signed.py: Correct EFI architecture name for arm64.
  * Parameterize code to remove hardcoded x86-isms.
  * Add arm64 support.

ubuntu/eoan 2018-11-14 18:18:09 UTC 2018-11-14
Import patches-unapplied version 1.39 to ubuntu/disco-proposed

Author: dann frazier
Author Date: 2018-11-14 11:13:42 UTC

Import patches-unapplied version 1.39 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: c8b4418c475d2ff9f43aada60aa901aee4a2a569

New changelog entries:
  * debian/source_shim-signed.py: Correct EFI architecture name for arm64.
  * Parameterize code to remove hardcoded x86-isms.
  * Add arm64 support.

applied/ubuntu/bionic-updates 2018-10-29 21:38:38 UTC 2018-10-29
Import patches-applied version 1.37~18.04.3 to applied/ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-10-25 20:55:38 UTC

Import patches-applied version 1.37~18.04.3 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 10e866545714461f473a979be5c5df7a1f361ecf
Unapplied parent: 589f08d6959a00aac537bf3f2dcd5bf47f0ca5c2

New changelog entries:
  * Don't fail non-interactive upgrade of nvidia module and module removals
    (LP: #1726803)

ubuntu/bionic-updates 2018-10-29 21:38:38 UTC 2018-10-29
Import patches-unapplied version 1.37~18.04.3 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-10-25 20:55:38 UTC

Import patches-unapplied version 1.37~18.04.3 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: b07e14e27a7fd52b9c16c1c779e3f7276570b92b

New changelog entries:
  * Don't fail non-interactive upgrade of nvidia module and module removals
    (LP: #1726803)

applied/ubuntu/cosmic-devel 2018-10-12 17:40:09 UTC 2018-10-12
Import patches-applied version 1.38 to applied/ubuntu/cosmic-proposed

Author: Balint Reczey
Author Date: 2018-10-11 18:12:37 UTC

Import patches-applied version 1.38 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: fea9ad0ecf78ca51c1b7f17865ccef098c54a4ef
Unapplied parent: c8b4418c475d2ff9f43aada60aa901aee4a2a569

New changelog entries:
  * Don't fail non-interactive upgrade of nvidia module and module removals
    (LP: #1726803)

applied/ubuntu/cosmic-proposed 2018-10-12 17:40:09 UTC 2018-10-12
Import patches-applied version 1.38 to applied/ubuntu/cosmic-proposed

Author: Balint Reczey
Author Date: 2018-10-11 18:12:37 UTC

Import patches-applied version 1.38 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: fea9ad0ecf78ca51c1b7f17865ccef098c54a4ef
Unapplied parent: c8b4418c475d2ff9f43aada60aa901aee4a2a569

New changelog entries:
  * Don't fail non-interactive upgrade of nvidia module and module removals
    (LP: #1726803)

ubuntu/cosmic-devel 2018-10-12 17:40:09 UTC 2018-10-12
Import patches-unapplied version 1.38 to ubuntu/cosmic-proposed

Author: Balint Reczey
Author Date: 2018-10-11 18:12:37 UTC

Import patches-unapplied version 1.38 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 786f7b493a2ae5bb84a9d750727717fed7b87c1b

New changelog entries:
  * Don't fail non-interactive upgrade of nvidia module and module removals
    (LP: #1726803)

applied/ubuntu/cosmic 2018-10-12 17:40:09 UTC 2018-10-12
Import patches-applied version 1.38 to applied/ubuntu/cosmic-proposed

Author: Balint Reczey
Author Date: 2018-10-11 18:12:37 UTC

Import patches-applied version 1.38 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: fea9ad0ecf78ca51c1b7f17865ccef098c54a4ef
Unapplied parent: c8b4418c475d2ff9f43aada60aa901aee4a2a569

New changelog entries:
  * Don't fail non-interactive upgrade of nvidia module and module removals
    (LP: #1726803)

ubuntu/cosmic-proposed 2018-10-12 17:40:09 UTC 2018-10-12
Import patches-unapplied version 1.38 to ubuntu/cosmic-proposed

Author: Balint Reczey
Author Date: 2018-10-11 18:12:37 UTC

Import patches-unapplied version 1.38 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 786f7b493a2ae5bb84a9d750727717fed7b87c1b

New changelog entries:
  * Don't fail non-interactive upgrade of nvidia module and module removals
    (LP: #1726803)

ubuntu/cosmic 2018-10-12 17:40:09 UTC 2018-10-12
Import patches-unapplied version 1.38 to ubuntu/cosmic-proposed

Author: Balint Reczey
Author Date: 2018-10-11 18:12:37 UTC

Import patches-unapplied version 1.38 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 786f7b493a2ae5bb84a9d750727717fed7b87c1b

New changelog entries:
  * Don't fail non-interactive upgrade of nvidia module and module removals
    (LP: #1726803)

ubuntu/bionic 2018-04-24 17:27:56 UTC 2018-04-24
Import patches-unapplied version 1.34.9 to ubuntu/bionic-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2018-04-24 13:24:24 UTC

Import patches-unapplied version 1.34.9 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: a532de06da90535ce5f61ea97e910e7ad0fcfb4f

New changelog entries:
  * debian/shim-signed.postinst: check for MOK existence rather than ignoring
    failures in the trigger. (LP: #1766627)

applied/ubuntu/bionic 2018-04-24 17:27:56 UTC 2018-04-24
Import patches-applied version 1.34.9 to applied/ubuntu/bionic-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2018-04-24 13:24:24 UTC

Import patches-applied version 1.34.9 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 2b4842c9a5725aca096e9275c71f7e101f73addc
Unapplied parent: 4823d3bac571e6f34f3957bf69f73ceba82be135

New changelog entries:
  * debian/shim-signed.postinst: check for MOK existence rather than ignoring
    failures in the trigger. (LP: #1766627)

ubuntu/artful-devel 2018-01-22 17:01:40 UTC 2018-01-22
Import patches-unapplied version 1.33.1~17.10.1 to ubuntu/artful-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2018-01-11 15:49:09 UTC

Import patches-unapplied version 1.33.1~17.10.1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: d57780caa93d2e19a0ebf756a42f7c06ca01fc8d

New changelog entries:
  * Backport shim-signed 1.33.1 to 17.10. (LP: #1708245)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.

applied/ubuntu/artful-devel 2018-01-22 17:01:40 UTC 2018-01-22
Import patches-applied version 1.33.1~17.10.1 to applied/ubuntu/artful-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2018-01-11 15:49:09 UTC

Import patches-applied version 1.33.1~17.10.1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: b58fe700ba9a97f26af9a16ccbd600912b86ab65
Unapplied parent: 15499d74ba919887c32af5782bf34c9515b8441d

New changelog entries:
  * Backport shim-signed 1.33.1 to 17.10. (LP: #1708245)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.

applied/ubuntu/artful-proposed 2018-01-22 17:01:40 UTC 2018-01-22
Import patches-applied version 1.33.1~17.10.1 to applied/ubuntu/artful-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2018-01-11 15:49:09 UTC

Import patches-applied version 1.33.1~17.10.1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: b58fe700ba9a97f26af9a16ccbd600912b86ab65
Unapplied parent: 15499d74ba919887c32af5782bf34c9515b8441d

New changelog entries:
  * Backport shim-signed 1.33.1 to 17.10. (LP: #1708245)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.

ubuntu/artful-proposed 2018-01-22 17:01:40 UTC 2018-01-22
Import patches-unapplied version 1.33.1~17.10.1 to ubuntu/artful-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2018-01-11 15:49:09 UTC

Import patches-unapplied version 1.33.1~17.10.1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: d57780caa93d2e19a0ebf756a42f7c06ca01fc8d

New changelog entries:
  * Backport shim-signed 1.33.1 to 17.10. (LP: #1708245)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.

ubuntu/artful-updates 2018-01-22 17:01:40 UTC 2018-01-22
Import patches-unapplied version 1.33.1~17.10.1 to ubuntu/artful-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2018-01-11 15:49:09 UTC

Import patches-unapplied version 1.33.1~17.10.1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: d57780caa93d2e19a0ebf756a42f7c06ca01fc8d

New changelog entries:
  * Backport shim-signed 1.33.1 to 17.10. (LP: #1708245)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.

applied/ubuntu/artful-updates 2018-01-22 17:01:40 UTC 2018-01-22
Import patches-applied version 1.33.1~17.10.1 to applied/ubuntu/artful-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2018-01-11 15:49:09 UTC

Import patches-applied version 1.33.1~17.10.1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: b58fe700ba9a97f26af9a16ccbd600912b86ab65
Unapplied parent: 15499d74ba919887c32af5782bf34c9515b8441d

New changelog entries:
  * Backport shim-signed 1.33.1 to 17.10. (LP: #1708245)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.

ubuntu/yakkety-devel 2017-07-13 21:02:36 UTC 2017-07-13
Import patches-unapplied version 1.32~16.10.1 to ubuntu/yakkety-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:27:42 UTC

Import patches-unapplied version 1.32~16.10.1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 08dce9169dffcc13350431a46be179f39e40f0c9
Changelog parent: 6b3ce0b2bc4247959c89f976edf673590f4aeda7

applied/ubuntu/yakkety-devel 2017-07-13 21:02:36 UTC 2017-07-13
Import patches-applied version 1.32~16.10.1 to applied/ubuntu/yakkety-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:27:42 UTC

Import patches-applied version 1.32~16.10.1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: aa17c4e09c8b9b6de1631e6e6609caacb8793a2d
Unapplied parent: 257dc723895a0155498ba1581c020183591a3623

New changelog entries:
  * Backport shim-signed 1.32 to 16.10. (LP: #1700170)
  * Handle cleanup of /var/lib/shim-signed on package purge.
  * Fix regression in postinst when /var/lib/dkms does not exist.
    (LP#1700195)
  * Sort the list of dkms modules when recording.
  * update-secureboot-policy: track the installed DKMS modules so we can skip
    failing unattended upgrades if they hasn't changed (ie. if no new DKMS
    modules have been installed, just honour the user's previous decision to
    not disable shim validation). (LP: #1695578)
  * update-secureboot-policy: allow re-enabling shim validation when no DKMS
    packages are installed. (LP: #1673904)
  * debian/source_shim-signed.py: add the textual representation of SecureBoot
    and MokSBStateRT EFI variables rather than just adding the files directly;
    also, make sure we include the relevant EFI bits from kernel log.
    (LP: #1680279)
  * Makefile: Generate BOOT$arch.CSV, for use with fallback.
  * debian/rules: make sure we can do per-arch EFI files.
  * Adjust apport hook to include key files that tell us about the system's
    current SB state. LP: #1680279.
  [ Steve Langasek ]
  * Update to the signed 0.9+1474479173.6c180c6-1ubuntu1 binary from
    Microsoft.
  * update-secureboot-policy:
    - detect when we have no debconf prompting and error out instead of ending
      up in an infinite loop. LP: #1673817.
    - refactor to make the code easier to follow.
    - remove a confusing boolean that would always re-prompt on a request to
      --enable, but not on a request to --disable.
  [ Mathieu Trudel-Lapierre ]
  * update-secureboot-policy:
    - some more fixes to properly handle non-interactive mode. (LP: #1673817)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.
  * Update to the signed 0.9+1474479173.6c180c6-0ubuntu1 binary from Microsoft.
  * Update paths now that the shim binary has been renamed to include the
    target architecture.
  * debian/shim-signed.postinst: clean up old MokManager.efi from EFI/ubuntu;
    since it's being replaced by mm$arch.efi.
  * No-change rebuild for shim 0.9+1465500757.14a5905.is.0.8-0ubuntu3.
  * Revert to signed shim from 0.8-0ubuntu2. (LP: #1624096)
    - shim.efi.signed originally built from shim 0.8-0ubuntu2 in wily.
  * Update to the signed 0.9+1465500757.14a5905-0ubuntu1 binary from Microsoft.
    (LP: #1581299)
  * update-secureboot-policy:
    - Add a --help option, document other options. (LP: #1604936)
    - Rework prompting to display our Secure Boot warning and explanation
      text more prominently, rather than forcing graphical users to hit
      "Help" to see the full explanation for why we ask about disabling
      Secure Boot. (LP: #1595611)
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.
  * update-secureboot-policy: rework setting capabilities to stop having
    the backup capability while showing an error message; which won't affect
    the Dialog debconf frontend but otherwise made the GTK frontend confusing.
  * update-secureboot-policy: all debconf prompts should be at priority
    critical: there is no good default to pick, we must prompt the user.
  * debian/templates: make the password inputs be standard inputs; this is an
    unfortunate workaround to aptdaemon not having access to the debconf
    password database on desktop; since the frontend runs as an unprivileged
    user. See bug LP#1599981 (LP: #1599051)
  * debian/shim-signed.postinst: call for the trigger on update of shim-signed.
  * update-secureboot-policy: validate the state of MokSBStateRT against what
    the kernel believes it to be via /proc/sys/kernel/moksbstate_disabled,
    in case we have the kernel which knows about shim's validation policy but
    an old shim that doesn't export MokSBStateRT.
  * update-secureboot-policy:
    - Make it easier for users to really re-enable Secure Boot via an --enable
      option.
    - Don't prompt for action if there are no DKMS packages installed, as per
      checking if there are any subdirectories in /var/lib/dkms.
  * update-secureboot-policy: have a trigger-ready script available to deal
    with the necessity to change Secure Boot policy on a system.
  * debian/shim-signed.templates: ship the necessary templates for secureboot.
  * debian/shim-signed.postinst: Run our trigger script to update Secure Boot
    policy when necessary at the end of installs, without calling dpkg-trigger
    again.
  * debian/control: add Depends on mokutil, to ship a way for users to
    control shim features, such as enrolling new keys.
  * Add in an apport package hook for shim-signed and shim. (LP: #1490030)
  * Add a versioned dependency on grub2-common, so that partial upgrades from
    Ubuntu 12.04 don't break due to a lack of --target option to grub-install.
    LP: #1474203.
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.
  * Update to the signed 0.7-0ubuntu4 binary from Microsoft.
  * Also add a build-dependency on grub2-common, to ensure that our
    grub-install is the correct one - since grub-efi-amd64-bin is
    coinstallable with grub1. LP: #1259558.
  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
  * Add a dependency on shim, so that we can pull in MokManager for use.
  * Update to the signed 0.4-0ubuntu4 binary from Microsoft.
  * Build-depend on sbsigntool (>= 0.6-0ubuntu4) and check the integrity of
    our signed binary at build time.
  * Update to the signed 0.4-0ubuntu3 binary from Microsoft.
  * Recommend secureboot-db (LP: #1087843).
  * Rev shim-signed for updated shim.
  * Initial release, based on grub2-signed package.

applied/ubuntu/yakkety-proposed 2017-07-13 21:02:36 UTC 2017-07-13
Import patches-applied version 1.32~16.10.1 to applied/ubuntu/yakkety-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:27:42 UTC

Import patches-applied version 1.32~16.10.1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: aa17c4e09c8b9b6de1631e6e6609caacb8793a2d
Unapplied parent: 257dc723895a0155498ba1581c020183591a3623

New changelog entries:
  * Backport shim-signed 1.32 to 16.10. (LP: #1700170)
  * Handle cleanup of /var/lib/shim-signed on package purge.
  * Fix regression in postinst when /var/lib/dkms does not exist.
    (LP#1700195)
  * Sort the list of dkms modules when recording.
  * update-secureboot-policy: track the installed DKMS modules so we can skip
    failing unattended upgrades if they hasn't changed (ie. if no new DKMS
    modules have been installed, just honour the user's previous decision to
    not disable shim validation). (LP: #1695578)
  * update-secureboot-policy: allow re-enabling shim validation when no DKMS
    packages are installed. (LP: #1673904)
  * debian/source_shim-signed.py: add the textual representation of SecureBoot
    and MokSBStateRT EFI variables rather than just adding the files directly;
    also, make sure we include the relevant EFI bits from kernel log.
    (LP: #1680279)
  * Makefile: Generate BOOT$arch.CSV, for use with fallback.
  * debian/rules: make sure we can do per-arch EFI files.
  * Adjust apport hook to include key files that tell us about the system's
    current SB state. LP: #1680279.
  [ Steve Langasek ]
  * Update to the signed 0.9+1474479173.6c180c6-1ubuntu1 binary from
    Microsoft.
  * update-secureboot-policy:
    - detect when we have no debconf prompting and error out instead of ending
      up in an infinite loop. LP: #1673817.
    - refactor to make the code easier to follow.
    - remove a confusing boolean that would always re-prompt on a request to
      --enable, but not on a request to --disable.
  [ Mathieu Trudel-Lapierre ]
  * update-secureboot-policy:
    - some more fixes to properly handle non-interactive mode. (LP: #1673817)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.
  * Update to the signed 0.9+1474479173.6c180c6-0ubuntu1 binary from Microsoft.
  * Update paths now that the shim binary has been renamed to include the
    target architecture.
  * debian/shim-signed.postinst: clean up old MokManager.efi from EFI/ubuntu;
    since it's being replaced by mm$arch.efi.
  * No-change rebuild for shim 0.9+1465500757.14a5905.is.0.8-0ubuntu3.
  * Revert to signed shim from 0.8-0ubuntu2. (LP: #1624096)
    - shim.efi.signed originally built from shim 0.8-0ubuntu2 in wily.
  * Update to the signed 0.9+1465500757.14a5905-0ubuntu1 binary from Microsoft.
    (LP: #1581299)
  * update-secureboot-policy:
    - Add a --help option, document other options. (LP: #1604936)
    - Rework prompting to display our Secure Boot warning and explanation
      text more prominently, rather than forcing graphical users to hit
      "Help" to see the full explanation for why we ask about disabling
      Secure Boot. (LP: #1595611)
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.
  * update-secureboot-policy: rework setting capabilities to stop having
    the backup capability while showing an error message; which won't affect
    the Dialog debconf frontend but otherwise made the GTK frontend confusing.
  * update-secureboot-policy: all debconf prompts should be at priority
    critical: there is no good default to pick, we must prompt the user.
  * debian/templates: make the password inputs be standard inputs; this is an
    unfortunate workaround to aptdaemon not having access to the debconf
    password database on desktop; since the frontend runs as an unprivileged
    user. See bug LP#1599981 (LP: #1599051)
  * debian/shim-signed.postinst: call for the trigger on update of shim-signed.
  * update-secureboot-policy: validate the state of MokSBStateRT against what
    the kernel believes it to be via /proc/sys/kernel/moksbstate_disabled,
    in case we have the kernel which knows about shim's validation policy but
    an old shim that doesn't export MokSBStateRT.
  * update-secureboot-policy:
    - Make it easier for users to really re-enable Secure Boot via an --enable
      option.
    - Don't prompt for action if there are no DKMS packages installed, as per
      checking if there are any subdirectories in /var/lib/dkms.
  * update-secureboot-policy: have a trigger-ready script available to deal
    with the necessity to change Secure Boot policy on a system.
  * debian/shim-signed.templates: ship the necessary templates for secureboot.
  * debian/shim-signed.postinst: Run our trigger script to update Secure Boot
    policy when necessary at the end of installs, without calling dpkg-trigger
    again.
  * debian/control: add Depends on mokutil, to ship a way for users to
    control shim features, such as enrolling new keys.
  * Add in an apport package hook for shim-signed and shim. (LP: #1490030)
  * Add a versioned dependency on grub2-common, so that partial upgrades from
    Ubuntu 12.04 don't break due to a lack of --target option to grub-install.
    LP: #1474203.
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.
  * Update to the signed 0.7-0ubuntu4 binary from Microsoft.
  * Also add a build-dependency on grub2-common, to ensure that our
    grub-install is the correct one - since grub-efi-amd64-bin is
    coinstallable with grub1. LP: #1259558.
  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
  * Add a dependency on shim, so that we can pull in MokManager for use.
  * Update to the signed 0.4-0ubuntu4 binary from Microsoft.
  * Build-depend on sbsigntool (>= 0.6-0ubuntu4) and check the integrity of
    our signed binary at build time.
  * Update to the signed 0.4-0ubuntu3 binary from Microsoft.
  * Recommend secureboot-db (LP: #1087843).
  * Rev shim-signed for updated shim.
  * Initial release, based on grub2-signed package.

ubuntu/yakkety-proposed 2017-07-13 21:02:36 UTC 2017-07-13
Import patches-unapplied version 1.32~16.10.1 to ubuntu/yakkety-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:27:42 UTC

Import patches-unapplied version 1.32~16.10.1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 08dce9169dffcc13350431a46be179f39e40f0c9
Changelog parent: 6b3ce0b2bc4247959c89f976edf673590f4aeda7

ubuntu/zesty-devel 2017-07-13 20:53:45 UTC 2017-07-13
Import patches-unapplied version 1.32~17.04.1 to ubuntu/zesty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:10:08 UTC

Import patches-unapplied version 1.32~17.04.1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 08dce9169dffcc13350431a46be179f39e40f0c9
Changelog parent: 6b3ce0b2bc4247959c89f976edf673590f4aeda7

applied/ubuntu/zesty-devel 2017-07-13 20:53:45 UTC 2017-07-13
Import patches-applied version 1.32~17.04.1 to applied/ubuntu/zesty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:10:08 UTC

Import patches-applied version 1.32~17.04.1 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: aa17c4e09c8b9b6de1631e6e6609caacb8793a2d
Unapplied parent: 76f959fb94ed2148b07e203d81b305c8778da24f

New changelog entries:
  * Backport shim-signed 1.32 to 17.04. (LP: #1700170)
  * Handle cleanup of /var/lib/shim-signed on package purge.
  * Fix regression in postinst when /var/lib/dkms does not exist.
    (LP#1700195)
  * Sort the list of dkms modules when recording.
  * update-secureboot-policy: track the installed DKMS modules so we can skip
    failing unattended upgrades if they hasn't changed (ie. if no new DKMS
    modules have been installed, just honour the user's previous decision to
    not disable shim validation). (LP: #1695578)
  * update-secureboot-policy: allow re-enabling shim validation when no DKMS
    packages are installed. (LP: #1673904)
  * debian/source_shim-signed.py: add the textual representation of SecureBoot
    and MokSBStateRT EFI variables rather than just adding the files directly;
    also, make sure we include the relevant EFI bits from kernel log.
    (LP: #1680279)
  * Makefile: Generate BOOT$arch.CSV, for use with fallback.
  * debian/rules: make sure we can do per-arch EFI files.
  * Adjust apport hook to include key files that tell us about the system's
    current SB state.
  [ Steve Langasek ]
  * Update to the signed 0.9+1474479173.6c180c6-1ubuntu1 binary from
    Microsoft.
  * update-secureboot-policy:
    - detect when we have no debconf prompting and error out instead of ending
      up in an infinite loop. LP: #1673817.
    - refactor to make the code easier to follow.
    - remove a confusing boolean that would always re-prompt on a request to
      --enable, but not on a request to --disable.
  [ Mathieu Trudel-Lapierre ]
  * update-secureboot-policy:
    - some more fixes to properly handle non-interactive mode. (LP: #1673817)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.
  * Update to the signed 0.9+1474479173.6c180c6-0ubuntu1 binary from Microsoft.
  * Update paths now that the shim binary has been renamed to include the
    target architecture.
  * debian/shim-signed.postinst: clean up old MokManager.efi from EFI/ubuntu;
    since it's being replaced by mm$arch.efi.
  * No-change rebuild for shim 0.9+1465500757.14a5905.is.0.8-0ubuntu3.
  * Revert to signed shim from 0.8-0ubuntu2. (LP: #1624096)
    - shim.efi.signed originally built from shim 0.8-0ubuntu2 in wily.
  * Update to the signed 0.9+1465500757.14a5905-0ubuntu1 binary from Microsoft.
    (LP: #1581299)
  * update-secureboot-policy:
    - Add a --help option, document other options. (LP: #1604936)
    - Rework prompting to display our Secure Boot warning and explanation
      text more prominently, rather than forcing graphical users to hit
      "Help" to see the full explanation for why we ask about disabling
      Secure Boot. (LP: #1595611)
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.
  * update-secureboot-policy: rework setting capabilities to stop having
    the backup capability while showing an error message; which won't affect
    the Dialog debconf frontend but otherwise made the GTK frontend confusing.
  * update-secureboot-policy: all debconf prompts should be at priority
    critical: there is no good default to pick, we must prompt the user.
  * debian/templates: make the password inputs be standard inputs; this is an
    unfortunate workaround to aptdaemon not having access to the debconf
    password database on desktop; since the frontend runs as an unprivileged
    user. See bug LP#1599981 (LP: #1599051)
  * debian/shim-signed.postinst: call for the trigger on update of shim-signed.
  * update-secureboot-policy: validate the state of MokSBStateRT against what
    the kernel believes it to be via /proc/sys/kernel/moksbstate_disabled,
    in case we have the kernel which knows about shim's validation policy but
    an old shim that doesn't export MokSBStateRT.
  * update-secureboot-policy:
    - Make it easier for users to really re-enable Secure Boot via an --enable
      option.
    - Don't prompt for action if there are no DKMS packages installed, as per
      checking if there are any subdirectories in /var/lib/dkms.
  * update-secureboot-policy: have a trigger-ready script available to deal
    with the necessity to change Secure Boot policy on a system.
  * debian/shim-signed.templates: ship the necessary templates for secureboot.
  * debian/shim-signed.postinst: Run our trigger script to update Secure Boot
    policy when necessary at the end of installs, without calling dpkg-trigger
    again.
  * debian/control: add Depends on mokutil, to ship a way for users to
    control shim features, such as enrolling new keys.
  * Add in an apport package hook for shim-signed and shim. (LP: #1490030)
  * Add a versioned dependency on grub2-common, so that partial upgrades from
    Ubuntu 12.04 don't break due to a lack of --target option to grub-install.
    LP: #1474203.
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.
  * Update to the signed 0.7-0ubuntu4 binary from Microsoft.
  * Also add a build-dependency on grub2-common, to ensure that our
    grub-install is the correct one - since grub-efi-amd64-bin is
    coinstallable with grub1. LP: #1259558.
  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
  * Add a dependency on shim, so that we can pull in MokManager for use.
  * Update to the signed 0.4-0ubuntu4 binary from Microsoft.
  * Build-depend on sbsigntool (>= 0.6-0ubuntu4) and check the integrity of
    our signed binary at build time.
  * Update to the signed 0.4-0ubuntu3 binary from Microsoft.
  * Recommend secureboot-db (LP: #1087843).
  * Rev shim-signed for updated shim.
  * Initial release, based on grub2-signed package.

applied/ubuntu/zesty-proposed 2017-07-13 20:53:45 UTC 2017-07-13
Import patches-applied version 1.32~17.04.1 to applied/ubuntu/zesty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:10:08 UTC

Import patches-applied version 1.32~17.04.1 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: aa17c4e09c8b9b6de1631e6e6609caacb8793a2d
Unapplied parent: 76f959fb94ed2148b07e203d81b305c8778da24f

New changelog entries:
  * Backport shim-signed 1.32 to 17.04. (LP: #1700170)
  * Handle cleanup of /var/lib/shim-signed on package purge.
  * Fix regression in postinst when /var/lib/dkms does not exist.
    (LP#1700195)
  * Sort the list of dkms modules when recording.
  * update-secureboot-policy: track the installed DKMS modules so we can skip
    failing unattended upgrades if they hasn't changed (ie. if no new DKMS
    modules have been installed, just honour the user's previous decision to
    not disable shim validation). (LP: #1695578)
  * update-secureboot-policy: allow re-enabling shim validation when no DKMS
    packages are installed. (LP: #1673904)
  * debian/source_shim-signed.py: add the textual representation of SecureBoot
    and MokSBStateRT EFI variables rather than just adding the files directly;
    also, make sure we include the relevant EFI bits from kernel log.
    (LP: #1680279)
  * Makefile: Generate BOOT$arch.CSV, for use with fallback.
  * debian/rules: make sure we can do per-arch EFI files.
  * Adjust apport hook to include key files that tell us about the system's
    current SB state.
  [ Steve Langasek ]
  * Update to the signed 0.9+1474479173.6c180c6-1ubuntu1 binary from
    Microsoft.
  * update-secureboot-policy:
    - detect when we have no debconf prompting and error out instead of ending
      up in an infinite loop. LP: #1673817.
    - refactor to make the code easier to follow.
    - remove a confusing boolean that would always re-prompt on a request to
      --enable, but not on a request to --disable.
  [ Mathieu Trudel-Lapierre ]
  * update-secureboot-policy:
    - some more fixes to properly handle non-interactive mode. (LP: #1673817)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.
  * Update to the signed 0.9+1474479173.6c180c6-0ubuntu1 binary from Microsoft.
  * Update paths now that the shim binary has been renamed to include the
    target architecture.
  * debian/shim-signed.postinst: clean up old MokManager.efi from EFI/ubuntu;
    since it's being replaced by mm$arch.efi.
  * No-change rebuild for shim 0.9+1465500757.14a5905.is.0.8-0ubuntu3.
  * Revert to signed shim from 0.8-0ubuntu2. (LP: #1624096)
    - shim.efi.signed originally built from shim 0.8-0ubuntu2 in wily.
  * Update to the signed 0.9+1465500757.14a5905-0ubuntu1 binary from Microsoft.
    (LP: #1581299)
  * update-secureboot-policy:
    - Add a --help option, document other options. (LP: #1604936)
    - Rework prompting to display our Secure Boot warning and explanation
      text more prominently, rather than forcing graphical users to hit
      "Help" to see the full explanation for why we ask about disabling
      Secure Boot. (LP: #1595611)
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.
  * update-secureboot-policy: rework setting capabilities to stop having
    the backup capability while showing an error message; which won't affect
    the Dialog debconf frontend but otherwise made the GTK frontend confusing.
  * update-secureboot-policy: all debconf prompts should be at priority
    critical: there is no good default to pick, we must prompt the user.
  * debian/templates: make the password inputs be standard inputs; this is an
    unfortunate workaround to aptdaemon not having access to the debconf
    password database on desktop; since the frontend runs as an unprivileged
    user. See bug LP#1599981 (LP: #1599051)
  * debian/shim-signed.postinst: call for the trigger on update of shim-signed.
  * update-secureboot-policy: validate the state of MokSBStateRT against what
    the kernel believes it to be via /proc/sys/kernel/moksbstate_disabled,
    in case we have the kernel which knows about shim's validation policy but
    an old shim that doesn't export MokSBStateRT.
  * update-secureboot-policy:
    - Make it easier for users to really re-enable Secure Boot via an --enable
      option.
    - Don't prompt for action if there are no DKMS packages installed, as per
      checking if there are any subdirectories in /var/lib/dkms.
  * update-secureboot-policy: have a trigger-ready script available to deal
    with the necessity to change Secure Boot policy on a system.
  * debian/shim-signed.templates: ship the necessary templates for secureboot.
  * debian/shim-signed.postinst: Run our trigger script to update Secure Boot
    policy when necessary at the end of installs, without calling dpkg-trigger
    again.
  * debian/control: add Depends on mokutil, to ship a way for users to
    control shim features, such as enrolling new keys.
  * Add in an apport package hook for shim-signed and shim. (LP: #1490030)
  * Add a versioned dependency on grub2-common, so that partial upgrades from
    Ubuntu 12.04 don't break due to a lack of --target option to grub-install.
    LP: #1474203.
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.
  * Update to the signed 0.7-0ubuntu4 binary from Microsoft.
  * Also add a build-dependency on grub2-common, to ensure that our
    grub-install is the correct one - since grub-efi-amd64-bin is
    coinstallable with grub1. LP: #1259558.
  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
  * Add a dependency on shim, so that we can pull in MokManager for use.
  * Update to the signed 0.4-0ubuntu4 binary from Microsoft.
  * Build-depend on sbsigntool (>= 0.6-0ubuntu4) and check the integrity of
    our signed binary at build time.
  * Update to the signed 0.4-0ubuntu3 binary from Microsoft.
  * Recommend secureboot-db (LP: #1087843).
  * Rev shim-signed for updated shim.
  * Initial release, based on grub2-signed package.

applied/ubuntu/zesty-updates 2017-07-13 20:53:45 UTC 2017-07-13
Import patches-applied version 1.32~17.04.1 to applied/ubuntu/zesty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:10:08 UTC

Import patches-applied version 1.32~17.04.1 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: aa17c4e09c8b9b6de1631e6e6609caacb8793a2d
Unapplied parent: 76f959fb94ed2148b07e203d81b305c8778da24f

New changelog entries:
  * Backport shim-signed 1.32 to 17.04. (LP: #1700170)
  * Handle cleanup of /var/lib/shim-signed on package purge.
  * Fix regression in postinst when /var/lib/dkms does not exist.
    (LP#1700195)
  * Sort the list of dkms modules when recording.
  * update-secureboot-policy: track the installed DKMS modules so we can skip
    failing unattended upgrades if they hasn't changed (ie. if no new DKMS
    modules have been installed, just honour the user's previous decision to
    not disable shim validation). (LP: #1695578)
  * update-secureboot-policy: allow re-enabling shim validation when no DKMS
    packages are installed. (LP: #1673904)
  * debian/source_shim-signed.py: add the textual representation of SecureBoot
    and MokSBStateRT EFI variables rather than just adding the files directly;
    also, make sure we include the relevant EFI bits from kernel log.
    (LP: #1680279)
  * Makefile: Generate BOOT$arch.CSV, for use with fallback.
  * debian/rules: make sure we can do per-arch EFI files.
  * Adjust apport hook to include key files that tell us about the system's
    current SB state.
  [ Steve Langasek ]
  * Update to the signed 0.9+1474479173.6c180c6-1ubuntu1 binary from
    Microsoft.
  * update-secureboot-policy:
    - detect when we have no debconf prompting and error out instead of ending
      up in an infinite loop. LP: #1673817.
    - refactor to make the code easier to follow.
    - remove a confusing boolean that would always re-prompt on a request to
      --enable, but not on a request to --disable.
  [ Mathieu Trudel-Lapierre ]
  * update-secureboot-policy:
    - some more fixes to properly handle non-interactive mode. (LP: #1673817)
  * debian/control: bump the Depends on grub2-common since that's needed to
    install with the new updated EFI binaries filenames.
  * Update to the signed 0.9+1474479173.6c180c6-0ubuntu1 binary from Microsoft.
  * Update paths now that the shim binary has been renamed to include the
    target architecture.
  * debian/shim-signed.postinst: clean up old MokManager.efi from EFI/ubuntu;
    since it's being replaced by mm$arch.efi.
  * No-change rebuild for shim 0.9+1465500757.14a5905.is.0.8-0ubuntu3.
  * Revert to signed shim from 0.8-0ubuntu2. (LP: #1624096)
    - shim.efi.signed originally built from shim 0.8-0ubuntu2 in wily.
  * Update to the signed 0.9+1465500757.14a5905-0ubuntu1 binary from Microsoft.
    (LP: #1581299)
  * update-secureboot-policy:
    - Add a --help option, document other options. (LP: #1604936)
    - Rework prompting to display our Secure Boot warning and explanation
      text more prominently, rather than forcing graphical users to hit
      "Help" to see the full explanation for why we ask about disabling
      Secure Boot. (LP: #1595611)
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.
  * update-secureboot-policy: rework setting capabilities to stop having
    the backup capability while showing an error message; which won't affect
    the Dialog debconf frontend but otherwise made the GTK frontend confusing.
  * update-secureboot-policy: all debconf prompts should be at priority
    critical: there is no good default to pick, we must prompt the user.
  * debian/templates: make the password inputs be standard inputs; this is an
    unfortunate workaround to aptdaemon not having access to the debconf
    password database on desktop; since the frontend runs as an unprivileged
    user. See bug LP#1599981 (LP: #1599051)
  * debian/shim-signed.postinst: call for the trigger on update of shim-signed.
  * update-secureboot-policy: validate the state of MokSBStateRT against what
    the kernel believes it to be via /proc/sys/kernel/moksbstate_disabled,
    in case we have the kernel which knows about shim's validation policy but
    an old shim that doesn't export MokSBStateRT.
  * update-secureboot-policy:
    - Make it easier for users to really re-enable Secure Boot via an --enable
      option.
    - Don't prompt for action if there are no DKMS packages installed, as per
      checking if there are any subdirectories in /var/lib/dkms.
  * update-secureboot-policy: have a trigger-ready script available to deal
    with the necessity to change Secure Boot policy on a system.
  * debian/shim-signed.templates: ship the necessary templates for secureboot.
  * debian/shim-signed.postinst: Run our trigger script to update Secure Boot
    policy when necessary at the end of installs, without calling dpkg-trigger
    again.
  * debian/control: add Depends on mokutil, to ship a way for users to
    control shim features, such as enrolling new keys.
  * Add in an apport package hook for shim-signed and shim. (LP: #1490030)
  * Add a versioned dependency on grub2-common, so that partial upgrades from
    Ubuntu 12.04 don't break due to a lack of --target option to grub-install.
    LP: #1474203.
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.
  * Update to the signed 0.7-0ubuntu4 binary from Microsoft.
  * Also add a build-dependency on grub2-common, to ensure that our
    grub-install is the correct one - since grub-efi-amd64-bin is
    coinstallable with grub1. LP: #1259558.
  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
  * Add a dependency on shim, so that we can pull in MokManager for use.
  * Update to the signed 0.4-0ubuntu4 binary from Microsoft.
  * Build-depend on sbsigntool (>= 0.6-0ubuntu4) and check the integrity of
    our signed binary at build time.
  * Update to the signed 0.4-0ubuntu3 binary from Microsoft.
  * Recommend secureboot-db (LP: #1087843).
  * Rev shim-signed for updated shim.
  * Initial release, based on grub2-signed package.

ubuntu/zesty-updates 2017-07-13 20:53:45 UTC 2017-07-13
Import patches-unapplied version 1.32~17.04.1 to ubuntu/zesty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:10:08 UTC

Import patches-unapplied version 1.32~17.04.1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 08dce9169dffcc13350431a46be179f39e40f0c9
Changelog parent: 6b3ce0b2bc4247959c89f976edf673590f4aeda7

ubuntu/zesty-proposed 2017-07-13 20:53:45 UTC 2017-07-13
Import patches-unapplied version 1.32~17.04.1 to ubuntu/zesty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-07-10 17:10:08 UTC

Import patches-unapplied version 1.32~17.04.1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 08dce9169dffcc13350431a46be179f39e40f0c9
Changelog parent: 6b3ce0b2bc4247959c89f976edf673590f4aeda7

ubuntu/artful 2017-06-24 05:33:19 UTC 2017-06-24
Import patches-unapplied version 1.32 to ubuntu/artful-proposed

Author: Steve Langasek
Author Date: 2017-06-23 22:30:42 UTC

Import patches-unapplied version 1.32 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: a3e2093bf3e8cdec0014ed1bd33fe6863588d221
Changelog parent: a9e693d0b4970ab60dff002ccf63b9854d9d9b99

applied/ubuntu/zesty 2017-04-15 10:22:48 UTC 2017-04-15
Import patches-applied version 1.28 to applied/debian/sid

Author: Steve Langasek
Author Date: 2017-04-14 21:44:06 UTC

Import patches-applied version 1.28 to applied/debian/sid

Imported using git-ubuntu import.

Unapplied parent: 3d3979c864f65ba390ee9f5613a7fd129b0205f1

ubuntu/zesty 2017-04-06 04:44:44 UTC 2017-04-06
Import patches-unapplied version 1.28 to ubuntu/zesty-proposed

Author: Steve Langasek
Author Date: 2017-04-05 15:14:49 UTC

Import patches-unapplied version 1.28 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 275f797d9f4359d98bcd309b915084c1753d59cb

New changelog entries:
  * Adjust apport hook to include key files that tell us about the system's
    current SB state.

ubuntu/yakkety-updates 2017-03-24 06:56:22 UTC 2017-03-24
Import patches-unapplied version 1.27~16.10.1 to ubuntu/yakkety-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-03-23 16:58:44 UTC

Import patches-unapplied version 1.27~16.10.1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 275f797d9f4359d98bcd309b915084c1753d59cb

New changelog entries:
  * Backport shim 0.9+1474479173.6c180c6-1ubuntu1 to 16.10. (LP: #1637290)

applied/ubuntu/yakkety-updates 2017-03-24 06:56:22 UTC 2017-03-24
Import patches-applied version 1.27~16.10.1 to applied/ubuntu/yakkety-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2017-03-23 16:58:44 UTC

Import patches-applied version 1.27~16.10.1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 761a3bf3310858db93a13a1ab53e9c42d58edc37
Unapplied parent: 6b72551878f3683366bef66d09394624b33ba12d

New changelog entries:
  * Backport shim 0.9+1474479173.6c180c6-1ubuntu1 to 16.10. (LP: #1637290)

applied/ubuntu/yakkety 2016-10-07 01:41:32 UTC 2016-10-07
Import patches-applied version 1.21.3 to applied/ubuntu/yakkety-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2016-10-06 19:20:36 UTC

Import patches-applied version 1.21.3 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 15ef6115156b6ceba090997bc031e5ff96e70017
Unapplied parent: a2d4293a325162c362e88fe4b2296c55e53d68df

New changelog entries:
  * No-change rebuild for shim 0.9+1465500757.14a5905.is.0.8-0ubuntu3.

ubuntu/yakkety 2016-10-07 01:41:32 UTC 2016-10-07
Import patches-unapplied version 1.21.3 to ubuntu/yakkety-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2016-10-06 19:20:36 UTC

Import patches-unapplied version 1.21.3 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 381b6b8f6db9f510e067366cbe764e0ae5783c41

New changelog entries:
  * No-change rebuild for shim 0.9+1465500757.14a5905.is.0.8-0ubuntu3.

ubuntu/precise-proposed 2016-07-21 13:47:29 UTC 2016-07-21
Import patches-unapplied version 1.18~12.04.1 to ubuntu/precise-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:22:42 UTC

Import patches-unapplied version 1.18~12.04.1 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 6b8cd019e26c709f35ba3fdc74a0426eb6abe045

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

applied/ubuntu/precise-updates 2016-07-21 13:47:29 UTC 2016-07-21
Import patches-applied version 1.18~12.04.1 to applied/ubuntu/precise-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:22:42 UTC

Import patches-applied version 1.18~12.04.1 to applied/ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 27ccd04e3b019ea97cd5fe7a48897bc6937095ba
Unapplied parent: b0b2614da6a7bb64d72d24288706a691bcae8624

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

applied/ubuntu/precise-proposed 2016-07-21 13:47:29 UTC 2016-07-21
Import patches-applied version 1.18~12.04.1 to applied/ubuntu/precise-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:22:42 UTC

Import patches-applied version 1.18~12.04.1 to applied/ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 27ccd04e3b019ea97cd5fe7a48897bc6937095ba
Unapplied parent: b0b2614da6a7bb64d72d24288706a691bcae8624

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

applied/ubuntu/precise-devel 2016-07-21 13:47:29 UTC 2016-07-21
Import patches-applied version 1.18~12.04.1 to applied/ubuntu/precise-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:22:42 UTC

Import patches-applied version 1.18~12.04.1 to applied/ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 27ccd04e3b019ea97cd5fe7a48897bc6937095ba
Unapplied parent: b0b2614da6a7bb64d72d24288706a691bcae8624

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

ubuntu/precise-devel 2016-07-21 13:47:29 UTC 2016-07-21
Import patches-unapplied version 1.18~12.04.1 to ubuntu/precise-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:22:42 UTC

Import patches-unapplied version 1.18~12.04.1 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 6b8cd019e26c709f35ba3fdc74a0426eb6abe045

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

ubuntu/precise-updates 2016-07-21 13:47:29 UTC 2016-07-21
Import patches-unapplied version 1.18~12.04.1 to ubuntu/precise-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:22:42 UTC

Import patches-unapplied version 1.18~12.04.1 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 6b8cd019e26c709f35ba3fdc74a0426eb6abe045

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

applied/ubuntu/wily-updates 2016-07-21 13:45:26 UTC 2016-07-21
Import patches-applied version 1.18~15.10.1 to applied/ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:20:26 UTC

Import patches-applied version 1.18~15.10.1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 403b1c686d7954c38b14a2c23c2769e9484d71ab
Unapplied parent: 741750b6f40b301f76ae520e58cd0d8e756ba805

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

ubuntu/wily-devel 2016-07-21 13:45:26 UTC 2016-07-21
Import patches-unapplied version 1.18~15.10.1 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:20:26 UTC

Import patches-unapplied version 1.18~15.10.1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 1d0613308e9c3fdfa98f4626e778054083f4f67e

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

applied/ubuntu/wily-devel 2016-07-21 13:45:26 UTC 2016-07-21
Import patches-applied version 1.18~15.10.1 to applied/ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:20:26 UTC

Import patches-applied version 1.18~15.10.1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 403b1c686d7954c38b14a2c23c2769e9484d71ab
Unapplied parent: 741750b6f40b301f76ae520e58cd0d8e756ba805

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

ubuntu/wily-updates 2016-07-21 13:45:26 UTC 2016-07-21
Import patches-unapplied version 1.18~15.10.1 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:20:26 UTC

Import patches-unapplied version 1.18~15.10.1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 1d0613308e9c3fdfa98f4626e778054083f4f67e

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

ubuntu/wily-proposed 2016-07-21 13:45:26 UTC 2016-07-21
Import patches-unapplied version 1.18~15.10.1 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:20:26 UTC

Import patches-unapplied version 1.18~15.10.1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 1d0613308e9c3fdfa98f4626e778054083f4f67e

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

applied/ubuntu/wily-proposed 2016-07-21 13:45:26 UTC 2016-07-21
Import patches-applied version 1.18~15.10.1 to applied/ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2016-07-20 16:20:26 UTC

Import patches-applied version 1.18~15.10.1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 403b1c686d7954c38b14a2c23c2769e9484d71ab
Unapplied parent: 741750b6f40b301f76ae520e58cd0d8e756ba805

New changelog entries:
  * update-secureboot-policy: If /proc/sys/kernel/moksbstate_disabled is
    present, prefer this unconditionally over MokSBStateRT. LP: #1604873.

applied/ubuntu/xenial 2015-12-16 15:31:09 UTC 2015-12-16
Import patches-applied version 1.12 to applied/ubuntu/xenial-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2015-12-16 10:19:23 UTC

Import patches-applied version 1.12 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: bc88e763e2b00697d521058136df7a29ae0c73a2
Unapplied parent: b5fa4d2ad07a90486c450101d55b38336be81892

New changelog entries:
  * debian/control: add Depends on mokutil, to ship a way for users to
    control shim features, such as enrolling new keys.

ubuntu/xenial 2015-12-16 15:31:09 UTC 2015-12-16
Import patches-unapplied version 1.12 to ubuntu/xenial-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2015-12-16 10:19:23 UTC

Import patches-unapplied version 1.12 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: dbed5c6c5a1ccc603438cffd666a800f67695c26

New changelog entries:
  * debian/control: add Depends on mokutil, to ship a way for users to
    control shim features, such as enrolling new keys.

ubuntu/wily 2015-09-11 22:05:10 UTC 2015-09-11
Import patches-unapplied version 1.11 to ubuntu/wily-proposed

Author: Brian Murray
Author Date: 2015-09-11 15:04:31 UTC

Import patches-unapplied version 1.11 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: c35536930aac4a343a5084ddb52787de371d5832

New changelog entries:
  * Add in an apport package hook for shim-signed and shim. (LP: #1490030)

applied/ubuntu/wily 2015-09-11 22:05:10 UTC 2015-09-11
Import patches-applied version 1.11 to applied/ubuntu/wily-proposed

Author: Brian Murray
Author Date: 2015-09-11 15:04:31 UTC

Import patches-applied version 1.11 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 6c3c41429f24ba150ae7ce21132f182d021cc2f6
Unapplied parent: dbed5c6c5a1ccc603438cffd666a800f67695c26

New changelog entries:
  * Add in an apport package hook for shim-signed and shim. (LP: #1490030)

applied/ubuntu/utopic-proposed 2015-06-07 20:15:13 UTC 2015-06-07
Import patches-applied version 1.9 to applied/ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-06-07 19:27:35 UTC

Import patches-applied version 1.9 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: c55012318ade5ae156113622ca632e7b4727a849
Unapplied parent: 55abb2ea204889e125f4a5650bc1eb6ca2128429

New changelog entries:
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.

applied/ubuntu/vivid-devel 2015-06-07 20:15:13 UTC 2015-06-07
Import patches-applied version 1.9 to applied/ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-06-07 19:27:35 UTC

Import patches-applied version 1.9 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: c55012318ade5ae156113622ca632e7b4727a849
Unapplied parent: 55abb2ea204889e125f4a5650bc1eb6ca2128429

New changelog entries:
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.

applied/ubuntu/vivid-proposed 2015-06-07 20:15:13 UTC 2015-06-07
Import patches-applied version 1.9 to applied/ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-06-07 19:27:35 UTC

Import patches-applied version 1.9 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: c55012318ade5ae156113622ca632e7b4727a849
Unapplied parent: 55abb2ea204889e125f4a5650bc1eb6ca2128429

New changelog entries:
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.

applied/ubuntu/vivid-updates 2015-06-07 20:15:13 UTC 2015-06-07
Import patches-applied version 1.9 to applied/ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-06-07 19:27:35 UTC

Import patches-applied version 1.9 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: c55012318ade5ae156113622ca632e7b4727a849
Unapplied parent: 55abb2ea204889e125f4a5650bc1eb6ca2128429

New changelog entries:
  * Update to the signed 0.8-0ubuntu2 binary from Microsoft.

1100 of 136 results

Other repositories

Name Last Modified
lp:ubuntu/+source/shim-signed 2020-05-26
11 of 1 result
You can't create new repositories for shim-signed in Ubuntu.