View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/shadow
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/debian/dsc 2018-07-27 16:52:06 UTC 2018-07-27
DSC file for 1:4.5-1.1

Author: Ubuntu Git Importer
Author Date: 2018-07-27 16:52:06 UTC

DSC file for 1:4.5-1.1

debian/buster 2018-07-27 16:40:45 UTC 2018-07-27
Import patches-unapplied version 1:4.5-1.1 to debian/sid

Author: Andreas Henriksson
Author Date: 2018-07-27 08:07:37 UTC

Import patches-unapplied version 1:4.5-1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Non-maintainer upload (greetings from DebCamp/DebConf Taiwan).
  * Stop shipping su and break old util-linux version. (See #833256)
    - Breaks on old version to force lockstep upgrade, which should
      really be a depends-new-version (and can be switched around
      together with util-linux once the transition is finished).
      Using Breaks/Depends the 'wrong' way around is to make apt
      unpack things in the 'right' order (avoiding any gaps where
      /bin/su is not available during the upgrade phase).

debian/sid 2018-07-27 16:40:45 UTC 2018-07-27
Import patches-unapplied version 1:4.5-1.1 to debian/sid

Author: Andreas Henriksson
Author Date: 2018-07-27 08:07:37 UTC

Import patches-unapplied version 1:4.5-1.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Non-maintainer upload (greetings from DebCamp/DebConf Taiwan).
  * Stop shipping su and break old util-linux version. (See #833256)
    - Breaks on old version to force lockstep upgrade, which should
      really be a depends-new-version (and can be switched around
      together with util-linux once the transition is finished).
      Using Breaks/Depends the 'wrong' way around is to make apt
      unpack things in the 'right' order (avoiding any gaps where
      /bin/su is not available during the upgrade phase).

importer/ubuntu/pristine-tar 2018-03-06 18:31:42 UTC 2018-03-06
pristine-tar data for shadow_4.5.orig.tar.xz

Author: Ubuntu Git Importer
Author Date: 2018-03-06 18:31:42 UTC

pristine-tar data for shadow_4.5.orig.tar.xz

importer/ubuntu/dsc 2018-03-06 18:31:01 UTC 2018-03-06
DSC file for 1:4.5-1ubuntu1

Author: Ubuntu Git Importer
Author Date: 2018-03-06 18:31:01 UTC

DSC file for 1:4.5-1ubuntu1

importer/debian/pristine-tar 2018-03-06 17:56:04 UTC 2018-03-06
pristine-tar data for shadow_4.5.orig.tar.xz

Author: Ubuntu Git Importer
Author Date: 2018-03-06 17:56:04 UTC

pristine-tar data for shadow_4.5.orig.tar.xz

ubuntu/cosmic 2018-01-29 02:03:12 UTC 2018-01-29
Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-01-25 15:09:22 UTC

Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/1012_extrausers_chfn.patch: add support for
      --extrausers to the chfn tool
    - debian/passwd.maintscripts: Clean up upstart configuration
  * Dropped changes, included in Debian:
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
  * Dropped changes, included upstream:
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
    - debian/patches/1021_no_subuids_for_system_users.patch
    - debian/patches/CVE-2017-2616.patch: Check process's exit status before
      sending signal
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    - CVE-2017-2616
    - debian/patches/CVE-2016-6252.patch: parse directly into unsigned long
    - CVE-2016-6252
  * Dropped obsoleted changes:
    - debian/rules: setting DEB_*_INSTALLINIT_ARGS became obsolete after
      switching to passwd.tmpfile from passwd.service

ubuntu/disco-devel 2018-01-29 02:03:12 UTC 2018-01-29
Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-01-25 15:09:22 UTC

Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/1012_extrausers_chfn.patch: add support for
      --extrausers to the chfn tool
    - debian/passwd.maintscripts: Clean up upstart configuration
  * Dropped changes, included in Debian:
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
  * Dropped changes, included upstream:
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
    - debian/patches/1021_no_subuids_for_system_users.patch
    - debian/patches/CVE-2017-2616.patch: Check process's exit status before
      sending signal
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    - CVE-2017-2616
    - debian/patches/CVE-2016-6252.patch: parse directly into unsigned long
    - CVE-2016-6252
  * Dropped obsoleted changes:
    - debian/rules: setting DEB_*_INSTALLINIT_ARGS became obsolete after
      switching to passwd.tmpfile from passwd.service

ubuntu/disco 2018-01-29 02:03:12 UTC 2018-01-29
Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-01-25 15:09:22 UTC

Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/1012_extrausers_chfn.patch: add support for
      --extrausers to the chfn tool
    - debian/passwd.maintscripts: Clean up upstart configuration
  * Dropped changes, included in Debian:
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
  * Dropped changes, included upstream:
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
    - debian/patches/1021_no_subuids_for_system_users.patch
    - debian/patches/CVE-2017-2616.patch: Check process's exit status before
      sending signal
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    - CVE-2017-2616
    - debian/patches/CVE-2016-6252.patch: parse directly into unsigned long
    - CVE-2016-6252
  * Dropped obsoleted changes:
    - debian/rules: setting DEB_*_INSTALLINIT_ARGS became obsolete after
      switching to passwd.tmpfile from passwd.service

ubuntu/devel 2018-01-29 02:03:12 UTC 2018-01-29
Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-01-25 15:09:22 UTC

Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/1012_extrausers_chfn.patch: add support for
      --extrausers to the chfn tool
    - debian/passwd.maintscripts: Clean up upstart configuration
  * Dropped changes, included in Debian:
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
  * Dropped changes, included upstream:
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
    - debian/patches/1021_no_subuids_for_system_users.patch
    - debian/patches/CVE-2017-2616.patch: Check process's exit status before
      sending signal
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    - CVE-2017-2616
    - debian/patches/CVE-2016-6252.patch: parse directly into unsigned long
    - CVE-2016-6252
  * Dropped obsoleted changes:
    - debian/rules: setting DEB_*_INSTALLINIT_ARGS became obsolete after
      switching to passwd.tmpfile from passwd.service

ubuntu/cosmic-devel 2018-01-29 02:03:12 UTC 2018-01-29
Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-01-25 15:09:22 UTC

Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/1012_extrausers_chfn.patch: add support for
      --extrausers to the chfn tool
    - debian/passwd.maintscripts: Clean up upstart configuration
  * Dropped changes, included in Debian:
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
  * Dropped changes, included upstream:
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
    - debian/patches/1021_no_subuids_for_system_users.patch
    - debian/patches/CVE-2017-2616.patch: Check process's exit status before
      sending signal
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    - CVE-2017-2616
    - debian/patches/CVE-2016-6252.patch: parse directly into unsigned long
    - CVE-2016-6252
  * Dropped obsoleted changes:
    - debian/rules: setting DEB_*_INSTALLINIT_ARGS became obsolete after
      switching to passwd.tmpfile from passwd.service

ubuntu/bionic 2018-01-29 02:03:12 UTC 2018-01-29
Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-01-25 15:09:22 UTC

Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/1012_extrausers_chfn.patch: add support for
      --extrausers to the chfn tool
    - debian/passwd.maintscripts: Clean up upstart configuration
  * Dropped changes, included in Debian:
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
  * Dropped changes, included upstream:
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
    - debian/patches/1021_no_subuids_for_system_users.patch
    - debian/patches/CVE-2017-2616.patch: Check process's exit status before
      sending signal
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    - CVE-2017-2616
    - debian/patches/CVE-2016-6252.patch: parse directly into unsigned long
    - CVE-2016-6252
  * Dropped obsoleted changes:
    - debian/rules: setting DEB_*_INSTALLINIT_ARGS became obsolete after
      switching to passwd.tmpfile from passwd.service

ubuntu/bionic-devel 2018-01-29 02:03:12 UTC 2018-01-29
Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-01-25 15:09:22 UTC

Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/1012_extrausers_chfn.patch: add support for
      --extrausers to the chfn tool
    - debian/passwd.maintscripts: Clean up upstart configuration
  * Dropped changes, included in Debian:
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
  * Dropped changes, included upstream:
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
    - debian/patches/1021_no_subuids_for_system_users.patch
    - debian/patches/CVE-2017-2616.patch: Check process's exit status before
      sending signal
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    - CVE-2017-2616
    - debian/patches/CVE-2016-6252.patch: parse directly into unsigned long
    - CVE-2016-6252
  * Dropped obsoleted changes:
    - debian/rules: setting DEB_*_INSTALLINIT_ARGS became obsolete after
      switching to passwd.tmpfile from passwd.service

ubuntu/bionic-proposed 2018-01-29 02:03:12 UTC 2018-01-29
Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Author: Balint Reczey
Author Date: 2018-01-25 15:09:22 UTC

Import patches-unapplied version 1:4.5-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: f3bfbd3bbc20ca57dbba77b430347bae3123b908

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/1012_extrausers_chfn.patch: add support for
      --extrausers to the chfn tool
    - debian/passwd.maintscripts: Clean up upstart configuration
  * Dropped changes, included in Debian:
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
  * Dropped changes, included upstream:
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
    - debian/patches/1021_no_subuids_for_system_users.patch
    - debian/patches/CVE-2017-2616.patch: Check process's exit status before
      sending signal
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    - CVE-2017-2616
    - debian/patches/CVE-2016-6252.patch: parse directly into unsigned long
    - CVE-2016-6252
  * Dropped obsoleted changes:
    - debian/rules: setting DEB_*_INSTALLINIT_ARGS became obsolete after
      switching to passwd.tmpfile from passwd.service

ubuntu/artful 2017-08-21 10:43:25 UTC 2017-08-21
Import patches-unapplied version 1:4.2-3.2ubuntu4 to ubuntu/artful-proposed

Author: Dimitri John Ledkov
Author Date: 2017-08-20 23:56:14 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu4 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 57158851102e32c27f5c567dc182b77b061f5868

New changelog entries:
  * Drop upstart system jobs.

ubuntu/artful-devel 2017-08-21 10:43:25 UTC 2017-08-21
Import patches-unapplied version 1:4.2-3.2ubuntu4 to ubuntu/artful-proposed

Author: Dimitri John Ledkov
Author Date: 2017-08-20 23:56:14 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu4 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 57158851102e32c27f5c567dc182b77b061f5868

New changelog entries:
  * Drop upstart system jobs.

ubuntu/artful-proposed 2017-08-21 10:43:25 UTC 2017-08-21
Import patches-unapplied version 1:4.2-3.2ubuntu4 to ubuntu/artful-proposed

Author: Dimitri John Ledkov
Author Date: 2017-08-20 23:56:14 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu4 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 57158851102e32c27f5c567dc182b77b061f5868

New changelog entries:
  * Drop upstart system jobs.

debian/jessie 2017-07-22 17:29:06 UTC 2017-07-22
Import patches-unapplied version 1:4.2-3+deb8u4 to debian/jessie

Author: Salvatore Bonaccorso
Author Date: 2017-05-17 10:58:54 UTC

Import patches-unapplied version 1:4.2-3+deb8u4 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: f8fc665427e57c13d85e62cc2ae02d62014d88af

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Reset pid_child only if waitpid was successful.
    This is a regression fix for CVE-2017-2616. If su receives a signal like
    SIGTERM, it is not propagated to the child. (Closes: #862806)

debian/stretch 2017-05-22 16:19:19 UTC 2017-05-22
Import patches-unapplied version 1:4.4-4.1 to debian/sid

Author: Salvatore Bonaccorso
Author Date: 2017-05-17 11:59:59 UTC

Import patches-unapplied version 1:4.4-4.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3a9ebc1fef4f7105cc5384bc7c083d21ac5b8b35

New changelog entries:
  * Non-maintainer upload.
  * Reset pid_child only if waitpid was successful.
    This is a regression fix for CVE-2017-2616. If su receives a signal like
    SIGTERM, it is not propagated to the child. (Closes: #862806)

ubuntu/xenial-security 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.1ubuntu5.3 to ubuntu/xenial-security

Author: Seth Arnold
Author Date: 2017-05-16 02:26:55 UTC

Import patches-unapplied version 1:4.2-3.1ubuntu5.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: d7c2b0106613414619b420f689c429a56f2bb804

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/xenial-updates 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.1ubuntu5.3 to ubuntu/xenial-security

Author: Seth Arnold
Author Date: 2017-05-16 02:26:55 UTC

Import patches-unapplied version 1:4.2-3.1ubuntu5.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: d7c2b0106613414619b420f689c429a56f2bb804

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/yakkety-security 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.2ubuntu1.16.10.2 to ubuntu/yakkety-s...

Author: Seth Arnold
Author Date: 2017-05-16 02:27:49 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1.16.10.2 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 22a396dc72204277f1b19b28702151fc5b289fb7

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/trusty-devel 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.1.5.1-1ubuntu9.5 to ubuntu/trusty-security

Author: Seth Arnold
Author Date: 2017-05-16 02:22:49 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu9.5 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 6581c70922d59c8d692a3f32a2620dfe10d837ac

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/yakkety-updates 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.2ubuntu1.16.10.2 to ubuntu/yakkety-s...

Author: Seth Arnold
Author Date: 2017-05-16 02:27:49 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1.16.10.2 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 22a396dc72204277f1b19b28702151fc5b289fb7

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/yakkety-devel 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.2ubuntu1.16.10.2 to ubuntu/yakkety-s...

Author: Seth Arnold
Author Date: 2017-05-16 02:27:49 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1.16.10.2 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 22a396dc72204277f1b19b28702151fc5b289fb7

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/zesty-updates 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.2ubuntu1.17.04.2 to ubuntu/zesty-sec...

Author: Seth Arnold
Author Date: 2017-05-16 02:28:44 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1.17.04.2 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 6c2ec5c7d7d6554c1707aed54dea3f814d5f4fe6

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/trusty-updates 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.1.5.1-1ubuntu9.5 to ubuntu/trusty-security

Author: Seth Arnold
Author Date: 2017-05-16 02:22:49 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu9.5 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 6581c70922d59c8d692a3f32a2620dfe10d837ac

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/zesty-security 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.2ubuntu1.17.04.2 to ubuntu/zesty-sec...

Author: Seth Arnold
Author Date: 2017-05-16 02:28:44 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1.17.04.2 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 6c2ec5c7d7d6554c1707aed54dea3f814d5f4fe6

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/xenial-devel 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.1ubuntu5.3 to ubuntu/xenial-security

Author: Seth Arnold
Author Date: 2017-05-16 02:26:55 UTC

Import patches-unapplied version 1:4.2-3.1ubuntu5.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: d7c2b0106613414619b420f689c429a56f2bb804

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/zesty-devel 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.2-3.2ubuntu1.17.04.2 to ubuntu/zesty-sec...

Author: Seth Arnold
Author Date: 2017-05-16 02:28:44 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1.17.04.2 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 6c2ec5c7d7d6554c1707aed54dea3f814d5f4fe6

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/trusty-security 2017-05-17 01:03:30 UTC 2017-05-17
Import patches-unapplied version 1:4.1.5.1-1ubuntu9.5 to ubuntu/trusty-security

Author: Seth Arnold
Author Date: 2017-05-16 02:22:49 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu9.5 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 6581c70922d59c8d692a3f32a2620dfe10d837ac

New changelog entries:
  * REGRESSION UPDATE: The patch for CVE-2017-2616 introduced a regression.
    If su received a signal like SIGTERM it wasn't propagated to the child.
    - debian/patches/CVE-2017-2616-regression.patch: Do not reset the
      pid_child to 0 if the child process is still running.
    Thanks to Tobias Stoeckmann for the fix and Radu Duta for the report.

ubuntu/yakkety-proposed 2016-09-20 08:01:46 UTC 2016-09-20
Import patches-unapplied version 1:4.2-3.2ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-09-20 07:43:54 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 92700e24a50a45a6baf1b7d24be402a152b06962

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/passwd.upstart: Add an upstart job to clear locks on
      [shadow-]passwd/group.
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
  * Dropped changes, included in Debian:
    - Allow LXC devices (lxc/console, lxc/tty[1234]), used from precise on.
    - Add uidmap package based on upstream patches that introduce
      newuidmap/newgidmap as well as /etc/subuid and /etc/subgid. Additional
      updates on those to widen the default allocation to 65536 uids and gids
      and only assign ranges to non-system users.
    - debian/patches/1020_fix_user_busy_errors: Call sub_uid_close in all
      error cases.
  * Dropped changes, included upstream:
    - debian/patches/495_stdout-encrypted-password: chpasswd can report
      password hashes on stdout.
    - debian/patches/496_su_kill_process_group: Kill the child process group,
      rather than just the immediate child.
  * Fix pam_motd calls so that the second pam_motd is the noupdate one rather
    than the first, ensuring /run/motd.dynamic is always populated and shown
    on the first login after boot. LP: #1368864.
  * Don't call 'pam_exec uname', a change adopted in Debian without
    coordination with the Debian PAM maintainer
  * Use dh_installinit now for installing the upstart job, as we no longer
    generate a dependency on upstart-job.
  * Include /etc/sub[ug]id in the list of files to clear locks for on boot.
    LP: #1304505
  * Add a systemd unit to go with the upstart job, so that lock clearing works
    on newer Ubuntu releases.
  * add support for "chfn --extrausers" (LP: #1495580)
  * debian/patches/1010_extrausers.patch:
    - Fix usermod to handle a readonly /etc gracefully (LP: #1562872)
  * debian/patches/1010_extrausers.patch:
    - Fix usermod to look in extrausers location for basic changes to a
      user's passwd info. Fixes changing user's real name in Touch via
      AccountsService. (Does not address updating groups yet, since that's
      less useful now, as we can't update any system groups.)
  * d/p/1021_no_subuids_for_system_users.patch: fix the not creating subuids
    for system users. (LP: #1545884)
  * Replace debian/passwd.service with debian/passwd.tmpfile, systemd tmpfile
    handling has support for removing files for us on boot. Thanks to
    Martin Pitt <pitti@ubuntu.com> for the hint.

ubuntu/yakkety 2016-09-20 08:01:46 UTC 2016-09-20
Import patches-unapplied version 1:4.2-3.2ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-09-20 07:43:54 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 92700e24a50a45a6baf1b7d24be402a152b06962

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/passwd.upstart: Add an upstart job to clear locks on
      [shadow-]passwd/group.
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
  * Dropped changes, included in Debian:
    - Allow LXC devices (lxc/console, lxc/tty[1234]), used from precise on.
    - Add uidmap package based on upstream patches that introduce
      newuidmap/newgidmap as well as /etc/subuid and /etc/subgid. Additional
      updates on those to widen the default allocation to 65536 uids and gids
      and only assign ranges to non-system users.
    - debian/patches/1020_fix_user_busy_errors: Call sub_uid_close in all
      error cases.
  * Dropped changes, included upstream:
    - debian/patches/495_stdout-encrypted-password: chpasswd can report
      password hashes on stdout.
    - debian/patches/496_su_kill_process_group: Kill the child process group,
      rather than just the immediate child.
  * Fix pam_motd calls so that the second pam_motd is the noupdate one rather
    than the first, ensuring /run/motd.dynamic is always populated and shown
    on the first login after boot. LP: #1368864.
  * Don't call 'pam_exec uname', a change adopted in Debian without
    coordination with the Debian PAM maintainer
  * Use dh_installinit now for installing the upstart job, as we no longer
    generate a dependency on upstart-job.
  * Include /etc/sub[ug]id in the list of files to clear locks for on boot.
    LP: #1304505
  * Add a systemd unit to go with the upstart job, so that lock clearing works
    on newer Ubuntu releases.
  * add support for "chfn --extrausers" (LP: #1495580)
  * debian/patches/1010_extrausers.patch:
    - Fix usermod to handle a readonly /etc gracefully (LP: #1562872)
  * debian/patches/1010_extrausers.patch:
    - Fix usermod to look in extrausers location for basic changes to a
      user's passwd info. Fixes changing user's real name in Touch via
      AccountsService. (Does not address updating groups yet, since that's
      less useful now, as we can't update any system groups.)
  * d/p/1021_no_subuids_for_system_users.patch: fix the not creating subuids
    for system users. (LP: #1545884)
  * Replace debian/passwd.service with debian/passwd.tmpfile, systemd tmpfile
    handling has support for removing files for us on boot. Thanks to
    Martin Pitt <pitti@ubuntu.com> for the hint.

ubuntu/zesty 2016-09-20 08:01:46 UTC 2016-09-20
Import patches-unapplied version 1:4.2-3.2ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-09-20 07:43:54 UTC

Import patches-unapplied version 1:4.2-3.2ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 92700e24a50a45a6baf1b7d24be402a152b06962

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/passwd.upstart: Add an upstart job to clear locks on
      [shadow-]passwd/group.
    - debian/login.defs:
      + Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
        handling does not only apply to "former (pre-PAM) uses".
      + Update documentation of UMASK: Explain that USERGROUPS_ENAB
        will modify this default for UPGs.
    - debian/{source_shadow.py,rules}: Add apport hook
    - Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
      /etc/update-motd.d/* scripts twice.
    - debian/patches/1010_extrausers.patch: Add support to passwd for
      libnss-extrausers
    - debian/patches/1011_extrausers_toggle.patch: extrausers support for
      useradd and groupadd
    - debian/patches/userns/subuids-nonlocal-users: Don't limit
      subuid/subgid support to local users.
  * Dropped changes, included in Debian:
    - Allow LXC devices (lxc/console, lxc/tty[1234]), used from precise on.
    - Add uidmap package based on upstream patches that introduce
      newuidmap/newgidmap as well as /etc/subuid and /etc/subgid. Additional
      updates on those to widen the default allocation to 65536 uids and gids
      and only assign ranges to non-system users.
    - debian/patches/1020_fix_user_busy_errors: Call sub_uid_close in all
      error cases.
  * Dropped changes, included upstream:
    - debian/patches/495_stdout-encrypted-password: chpasswd can report
      password hashes on stdout.
    - debian/patches/496_su_kill_process_group: Kill the child process group,
      rather than just the immediate child.
  * Fix pam_motd calls so that the second pam_motd is the noupdate one rather
    than the first, ensuring /run/motd.dynamic is always populated and shown
    on the first login after boot. LP: #1368864.
  * Don't call 'pam_exec uname', a change adopted in Debian without
    coordination with the Debian PAM maintainer
  * Use dh_installinit now for installing the upstart job, as we no longer
    generate a dependency on upstart-job.
  * Include /etc/sub[ug]id in the list of files to clear locks for on boot.
    LP: #1304505
  * Add a systemd unit to go with the upstart job, so that lock clearing works
    on newer Ubuntu releases.
  * add support for "chfn --extrausers" (LP: #1495580)
  * debian/patches/1010_extrausers.patch:
    - Fix usermod to handle a readonly /etc gracefully (LP: #1562872)
  * debian/patches/1010_extrausers.patch:
    - Fix usermod to look in extrausers location for basic changes to a
      user's passwd info. Fixes changing user's real name in Touch via
      AccountsService. (Does not address updating groups yet, since that's
      less useful now, as we can't update any system groups.)
  * d/p/1021_no_subuids_for_system_users.patch: fix the not creating subuids
    for system users. (LP: #1545884)
  * Replace debian/passwd.service with debian/passwd.tmpfile, systemd tmpfile
    handling has support for removing files for us on boot. Thanks to
    Martin Pitt <pitti@ubuntu.com> for the hint.

ubuntu/xenial 2016-03-29 10:08:53 UTC 2016-03-29
Import patches-unapplied version 1:4.2-3.1ubuntu5 to ubuntu/xenial-proposed

Author: Michael Terry
Author Date: 2016-03-28 13:44:23 UTC

Import patches-unapplied version 1:4.2-3.1ubuntu5 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 7122c1326e96e7bdce97dcee4bdc60e20110601d

New changelog entries:
  * debian/patches/1010_extrausers.patch:
    - Fix usermod to handle a readonly /etc gracefully (LP: #1562872)

ubuntu/xenial-proposed 2016-03-29 10:08:53 UTC 2016-03-29
Import patches-unapplied version 1:4.2-3.1ubuntu5 to ubuntu/xenial-proposed

Author: Michael Terry
Author Date: 2016-03-28 13:44:23 UTC

Import patches-unapplied version 1:4.2-3.1ubuntu5 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 7122c1326e96e7bdce97dcee4bdc60e20110601d

New changelog entries:
  * debian/patches/1010_extrausers.patch:
    - Fix usermod to handle a readonly /etc gracefully (LP: #1562872)

ubuntu/trusty-proposed 2016-01-27 00:54:03 UTC 2016-01-27
Import patches-unapplied version 1:4.1.5.1-1ubuntu9.2 to ubuntu/trusty-proposed

Author: Mathieu Trudel-Lapierre
Author Date: 2016-01-22 16:21:57 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu9.2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 93da5ba2984be88b1682cf3b5804bd409134ac6c

New changelog entries:
  * debian/control, debian/rules: re-enable libaudit support. (LP: #1478087)

ubuntu/vivid-devel 2015-07-22 13:53:39 UTC 2015-07-22
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu4.1 to ubuntu/vivid-proposed

Author: Steve Langasek
Author Date: 2015-07-21 05:58:18 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu4.1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 3b3de33ced756869a22979a21aed994e37f812dc

New changelog entries:
  * debian/patches/userns/subuids-nonlocal-users: Don't limit
    subuid/subgid support to local users. Closes LP: #1475749.

ubuntu/vivid-proposed 2015-07-22 13:53:39 UTC 2015-07-22
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu4.1 to ubuntu/vivid-proposed

Author: Steve Langasek
Author Date: 2015-07-21 05:58:18 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu4.1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 3b3de33ced756869a22979a21aed994e37f812dc

New changelog entries:
  * debian/patches/userns/subuids-nonlocal-users: Don't limit
    subuid/subgid support to local users. Closes LP: #1475749.

ubuntu/vivid-updates 2015-07-22 13:53:39 UTC 2015-07-22
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu4.1 to ubuntu/vivid-proposed

Author: Steve Langasek
Author Date: 2015-07-21 05:58:18 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu4.1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 3b3de33ced756869a22979a21aed994e37f812dc

New changelog entries:
  * debian/patches/userns/subuids-nonlocal-users: Don't limit
    subuid/subgid support to local users. Closes LP: #1475749.

ubuntu/wily-devel 2015-07-21 05:48:37 UTC 2015-07-21
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu7 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-07-21 01:44:12 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu7 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: ce767d8f0034383d565e7cb67f3d9cd4b38ef75d

New changelog entries:
  * debian/patches/userns/subuids-nonlocal-users: Don't limit
    subuid/subgid support to local users. Closes LP: #1475749.

ubuntu/wily-proposed 2015-07-21 05:48:37 UTC 2015-07-21
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu7 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-07-21 01:44:12 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu7 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: ce767d8f0034383d565e7cb67f3d9cd4b38ef75d

New changelog entries:
  * debian/patches/userns/subuids-nonlocal-users: Don't limit
    subuid/subgid support to local users. Closes LP: #1475749.

ubuntu/wily 2015-07-21 05:48:37 UTC 2015-07-21
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu7 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-07-21 01:44:12 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu7 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: ce767d8f0034383d565e7cb67f3d9cd4b38ef75d

New changelog entries:
  * debian/patches/userns/subuids-nonlocal-users: Don't limit
    subuid/subgid support to local users. Closes LP: #1475749.

ubuntu/utopic-devel 2015-07-15 19:38:43 UTC 2015-07-15
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu2.1 to ubuntu/utopic-prop...

Author: Steve Langasek
Author Date: 2015-07-10 20:17:44 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu2.1 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 43ffe55c9c39734131d0e151da78d1246212d3a9

New changelog entries:
  [ William Grant ]
  * debian/patches/1020_fix_user_busy_errors:
    - libmisc/user_busy.c: Call sub_uid_close in all error cases, otherwise
      code that later opens it as RW fails obscurely. (LP: #1342875)

ubuntu/utopic-proposed 2015-07-15 19:38:43 UTC 2015-07-15
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu2.1 to ubuntu/utopic-prop...

Author: Steve Langasek
Author Date: 2015-07-10 20:17:44 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu2.1 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 43ffe55c9c39734131d0e151da78d1246212d3a9

New changelog entries:
  [ William Grant ]
  * debian/patches/1020_fix_user_busy_errors:
    - libmisc/user_busy.c: Call sub_uid_close in all error cases, otherwise
      code that later opens it as RW fails obscurely. (LP: #1342875)

ubuntu/vivid 2015-04-20 18:18:33 UTC 2015-04-20
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu4 to ubuntu/vivid-proposed

Author: William Grant
Author Date: 2015-04-20 17:41:47 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu4 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 0e0c2ab6bd4ee8d40d8a34819d42f101ca68cd31

New changelog entries:
  * debian/patches/1020_fix_user_busy_errors:
    - libmisc/user_busy.c: Call sub_uid_close in all error cases, otherwise
      code that later opens it as RW fails obscurely. (LP: #1436937)

ubuntu/utopic 2014-07-18 14:23:12 UTC 2014-07-18
Import patches-unapplied version 1:4.1.5.1-1.1ubuntu2 to ubuntu/utopic-proposed

Author: Michael Terry
Author Date: 2014-07-18 14:00:44 UTC

Import patches-unapplied version 1:4.1.5.1-1.1ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 3289b2afbf592e26a3123e4494b5268244ccce47

New changelog entries:
  * debian/patches/1010_extrausers.patch:
    - Add support to passwd for libnss-extrausers by falling back to the
      /var/lib/extrausers/ locations if it exists when updating
      passwd or shadow.

debian/experimental 2014-04-23 22:11:13 UTC 2014-04-23
Import patches-unapplied version 1:4.2-1 to debian/experimental

Author: Christian Perrier
Author Date: 2014-04-22 07:01:42 UTC

Import patches-unapplied version 1:4.2-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 345637cf2498ce043fcb2b432d1ca56b51919a21

New changelog entries:
  [ Nicolas FRANCOIS (Nekral) ]
  * New upstream release. Fixes:
    - Invalid free() in su fixed by using strdup(). Thanks to Serge
      Hallyn for the patch. Closes: #691459
    - Kill the child process group, rather than just the
      immediate child; this is needed now that su no
      longer starts a controlling terminal when not running an
      interactive shell. Thanks to Colin Watson for the patch.
      Closes: #713979
    - German manpages translation update. Closes: #679152
    - Improve login.defs (typographic errors and better format).
      Closes: #685415
    - Russian translation update. Closes: #718356
    - Do not assume random() is limited by RAND_MAX. Closes: #677275
    - Support C libraries with unknown fields in struct passwd.
      Closes: #675824
    - su: child cleanup is performed before terminating PAM sessions. This
      avoids anoying "...terminated" messages when PAM module send signal to
      su during session close. Closes: #670132
    - vipw/vigr is checking arguments provided after options. Closes: #677812
    - Updated Japanese translation. Closes: #720004
    - vipw: Fix error reporting when editor fails. Closes: #688260
  * Moved to git: replace Vcs-Git in place of Vcs-Svn and adapt
    Vcs-Browser.
  * Add pam_loginuid to login PAM settings. Closes: #677441
  * passwd.install: add new subuid.5 and subgid.5 manpages
  * debian/rules, debian/control, debian/uidmap.install: create new uidmap
    package containing the new setuid-root binaries newuidmap and newgidmap
    Set uidmap as priority optional.
  * debian/login.su.pam: Enable pam_limits by default. Closes: #705301
  * debian/rules: Set default editor to sensible-editor for vipw.
    Closes: #688252
  [ Micah Anderson ]
  * added debian/patches/userns to enable use of subuids, plus some bugfix
    patches on top of them, patches from Eric Biederman, pulled from
    Ubuntu. Closes: #739981
  * Allow LXC devices (lxc/console, lxc/tty[1234]) in securetty.linux
  * Update documentation of UMASK: Explain that USERGROUPS_ENAB will modify
    this default for UPGs. (Closes: #583971)
  * login.postinst: install a default /etc/subuid and /etc/subgid
  * fix installation of setuid/setgid/newuidmap/newgid/map man pages
  [ Laurent Bigonville ]
  * Switch to dpkg-source 3.0 (quilt) format
  * Add build-dependency against bison
  * Call dh-autoreconf since we need to regenerate all the autofoo files

  [ Philippe Grégoire ]
  * Fix 1000_configure_userns to avoid dropping a needed #endif
    Closes: #744877
  [ Christian Perrier ]
  * Bump Standards to 3.9.5 (checked)
  * Use 'set -e' in postinst scripts and not in thei shebang line
  * Explicitly point to GPL-2 document in debian/copyright

ubuntu/trusty 2014-02-17 02:38:15 UTC 2014-02-17
Import patches-unapplied version 1:4.1.5.1-1ubuntu9 to ubuntu/trusty-proposed

Author: Stéphane Graber
Author Date: 2014-02-17 00:33:48 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu9 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: e1798d263b1279915260fb904c3196dd740aff4a

New changelog entries:
  * Set our subuid and subgid range to 65536 uids by default.
  * Patch newusers to not add subuids and subgids to system users.
  * Patch useradd to not add subuids and subgids to system users and to
    regular users who don't fit between uid_min and uid_max.
    (This is needed due to adduser not passing --system...)

ubuntu/raring-proposed 2013-07-26 17:13:21 UTC 2013-07-26
Import patches-unapplied version 1:4.1.5.1-1ubuntu4.1 to ubuntu/raring-proposed

Author: Colin Watson
Author Date: 2013-07-26 16:20:17 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu4.1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 05d1996a3b143aa0ea80a3698a61cf5cc51a8a2b

New changelog entries:
  * debian/patches/496_su_kill_process_group: Kill the child process group,
    rather than just the immediate child; this is needed now that su no
    longer starts a controlling terminal when not running an interactive
    shell (closes: #713979, LP: #1205407).

ubuntu/raring-updates 2013-07-26 17:13:21 UTC 2013-07-26
Import patches-unapplied version 1:4.1.5.1-1ubuntu4.1 to ubuntu/raring-proposed

Author: Colin Watson
Author Date: 2013-07-26 16:20:17 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu4.1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 05d1996a3b143aa0ea80a3698a61cf5cc51a8a2b

New changelog entries:
  * debian/patches/496_su_kill_process_group: Kill the child process group,
    rather than just the immediate child; this is needed now that su no
    longer starts a controlling terminal when not running an interactive
    shell (closes: #713979, LP: #1205407).

ubuntu/raring-devel 2013-07-26 17:13:21 UTC 2013-07-26
Import patches-unapplied version 1:4.1.5.1-1ubuntu4.1 to ubuntu/raring-proposed

Author: Colin Watson
Author Date: 2013-07-26 16:20:17 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu4.1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 05d1996a3b143aa0ea80a3698a61cf5cc51a8a2b

New changelog entries:
  * debian/patches/496_su_kill_process_group: Kill the child process group,
    rather than just the immediate child; this is needed now that su no
    longer starts a controlling terminal when not running an interactive
    shell (closes: #713979, LP: #1205407).

ubuntu/saucy-proposed 2013-07-26 16:13:15 UTC 2013-07-26
Import patches-unapplied version 1:4.1.5.1-1ubuntu6 to ubuntu/saucy-proposed

Author: Colin Watson
Author Date: 2013-07-26 15:55:52 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu6 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: dcf7c9b695dbd5c31b824c98684c01f3e4c374f5

New changelog entries:
  * debian/patches/496_su_kill_process_group: Kill the child process group,
    rather than just the immediate child; this is needed now that su no
    longer starts a controlling terminal when not running an interactive
    shell (closes: #713979).

ubuntu/saucy 2013-07-26 16:13:15 UTC 2013-07-26
Import patches-unapplied version 1:4.1.5.1-1ubuntu6 to ubuntu/saucy-proposed

Author: Colin Watson
Author Date: 2013-07-26 15:55:52 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu6 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: dcf7c9b695dbd5c31b824c98684c01f3e4c374f5

New changelog entries:
  * debian/patches/496_su_kill_process_group: Kill the child process group,
    rather than just the immediate child; this is needed now that su no
    longer starts a controlling terminal when not running an interactive
    shell (closes: #713979).

ubuntu/saucy-devel 2013-07-26 16:13:15 UTC 2013-07-26
Import patches-unapplied version 1:4.1.5.1-1ubuntu6 to ubuntu/saucy-proposed

Author: Colin Watson
Author Date: 2013-07-26 15:55:52 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu6 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: dcf7c9b695dbd5c31b824c98684c01f3e4c374f5

New changelog entries:
  * debian/patches/496_su_kill_process_group: Kill the child process group,
    rather than just the immediate child; this is needed now that su no
    longer starts a controlling terminal when not running an interactive
    shell (closes: #713979).

ubuntu/raring 2013-04-18 01:33:26 UTC 2013-04-18
Import patches-unapplied version 1:4.1.5.1-1ubuntu4 to ubuntu/raring-proposed

Author: Colin Watson
Author Date: 2013-04-18 00:01:45 UTC

Import patches-unapplied version 1:4.1.5.1-1ubuntu4 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: edf953f3859c64a5d120d65d39fb5b652f3db498

New changelog entries:
  * Pass noupdate to pam_motd call for /run/motd.dynamic, to avoid running
    /etc/update-motd.d/* scripts twice (LP: #1169558).

ubuntu/precise-devel 2012-09-12 22:33:17 UTC 2012-09-12
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu5.1 to ubuntu/preci...

Author: Dimitri John Ledkov
Author Date: 2012-08-31 12:00:33 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu5.1 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 5f325bba0f1e0e572ec9d9a08775055cce90b0c4

New changelog entries:
  * debian/passwd.upstart: Add an upstrat job to clear locks on
    [shadow-]passwd/group. (LP: #523896).

ubuntu/precise-updates 2012-09-12 22:33:17 UTC 2012-09-12
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu5.1 to ubuntu/preci...

Author: Dimitri John Ledkov
Author Date: 2012-08-31 12:00:33 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu5.1 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 5f325bba0f1e0e572ec9d9a08775055cce90b0c4

New changelog entries:
  * debian/passwd.upstart: Add an upstrat job to clear locks on
    [shadow-]passwd/group. (LP: #523896).

ubuntu/precise-proposed 2012-09-12 22:33:17 UTC 2012-09-12
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu5.1 to ubuntu/preci...

Author: Dimitri John Ledkov
Author Date: 2012-08-31 12:00:33 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu5.1 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 5f325bba0f1e0e572ec9d9a08775055cce90b0c4

New changelog entries:
  * debian/passwd.upstart: Add an upstrat job to clear locks on
    [shadow-]passwd/group. (LP: #523896).

ubuntu/quantal 2012-09-06 18:33:14 UTC 2012-09-06
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu7 to ubuntu/quantal

Author: Dimitri John Ledkov
Author Date: 2012-08-31 12:00:33 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu7 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: f9fb94bfbe218464988dabce11cc6a27071f0c1f

New changelog entries:
  * debian/passwd.upstart: Add an upstrat job to clear locks on
    [shadow-]passwd/group. (LP: #523896).

ubuntu/quantal-devel 2012-09-06 18:33:14 UTC 2012-09-06
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu7 to ubuntu/quantal

Author: Dimitri John Ledkov
Author Date: 2012-08-31 12:00:33 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu7 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: f9fb94bfbe218464988dabce11cc6a27071f0c1f

New changelog entries:
  * debian/passwd.upstart: Add an upstrat job to clear locks on
    [shadow-]passwd/group. (LP: #523896).

debian/wheezy 2012-05-26 09:25:07 UTC 2012-05-26
Import patches-unapplied version 1:4.1.5.1-1 to debian/sid

Author: Nicolas François
Author Date: 2012-05-25 13:42:01 UTC

Import patches-unapplied version 1:4.1.5.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fa9ddfb3ccf1787828aed4a876df84ffaf4efa6c

New changelog entries:
  * The "Gruyère" release.
  [ Nicolas FRANCOIS (Nekral) ]
  * New upstream release:
    - login: log into utmp(x) but not into wtmp (this is done by pam_lastlog).
      Log to utmp(x) was broken by the fix for #605329. Closes: 659957
    - userdel: Fix segfault when userdel removes the user's group.
      Closes: #660406
    - manpages: .so links point to paths relative to the top-level manual
      hierarchy. Closes: #661025
    - useradd(8): Return code 13 no more documented. Closes: #661802
  * debian/patches/series, debian/patches/428_grpck_add_prune_option: Removed.
    The -p option was not documented and was meant to fix consequences of a
    bug now fixed more than 10 years ago.
  * debian/shadowconfig.sh: Display issues, but dot not prompt interactively
    to fix passwd/group/shadow/gshadow issues. Closes: #638263
  * debian/control: Bump Standards-Version to 3.9.3 (no changes needed).
  * debian/rules: Simplify setting of hardening flags. cdbs 0.4.103 needed to
    get hardened version of shadow-utils. Restore previous requirement on
    dpkg-dev to 1.13.5.
  [ Christian Perrier ]
  * Complete Polish translation of logoutd(8). Closes: #668880
  * German translation of manpages completed. Closes: #673234
  [ Roger Leigh ]
  * Separation of static and dynamic motd components in login PAM module
    Closes: #669698

ubuntu/precise 2012-04-09 02:33:28 UTC 2012-04-09
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu5 to ubuntu/precise

Author: Colin Watson
Author Date: 2012-04-08 23:28:03 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu5 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 895072667958f2c8f1cf342028ee5e7e66cedfd0

New changelog entries:
  * Build-depend on gettext:any for cross-building support.

ubuntu/oneiric-devel 2011-06-24 10:05:17 UTC 2011-06-24
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu2 to ubuntu/oneiric

Author: Martin Pitt
Author Date: 2011-06-24 09:07:34 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu2 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: a3e4193db3d21a03b6b2655321f55a583914f995

New changelog entries:
  * debian/login.defs:
    - Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
      handling does not only apply to "former (pre-PAM) uses".
    - Update documentation of UMASK: Explain that USERGROUPS_ENAB will modify
      this default for UPGs. (Closes: #583971)

ubuntu/oneiric 2011-06-24 10:05:17 UTC 2011-06-24
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu2 to ubuntu/oneiric

Author: Martin Pitt
Author Date: 2011-06-24 09:07:34 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu2 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: a3e4193db3d21a03b6b2655321f55a583914f995

New changelog entries:
  * debian/login.defs:
    - Update documentation of USERGROUPS_ENAB: with pam_umask, the UPG
      handling does not only apply to "former (pre-PAM) uses".
    - Update documentation of UMASK: Explain that USERGROUPS_ENAB will modify
      this default for UPGs. (Closes: #583971)

ubuntu/natty-devel 2011-02-21 01:04:46 UTC 2011-02-21
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu1 to ubuntu/natty

Author: Steve Langasek
Author Date: 2011-02-20 23:59:15 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 6b3244600a1aeb119efd46326eb77b434f371725

New changelog entries:
  * The "string cheese" release.
  * Merge from Debian unstable. Remaining changes:
    - Ubuntu specific:
      + debian/login.defs: use SHA512 by default for password crypt routine.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/rules: fix FTBFS from newer libtools
    - debian/patches/495_stdout-encrypted-password: chpasswd can report
      password hashes on stdout (Debian bug 505640).
  * Dropped changes, merged in Debian:
    - debian/patches/300_CVE-2011-0721: reject newlines in GECOS updates.
    - CVE-2011-0721
  * Mark passwd Multi-Arch: foreign, so packages that aren't of the same
    arch can depend on it.

ubuntu/natty 2011-02-21 01:04:46 UTC 2011-02-21
Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu1 to ubuntu/natty

Author: Steve Langasek
Author Date: 2011-02-20 23:59:15 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-3ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 6b3244600a1aeb119efd46326eb77b434f371725

New changelog entries:
  * The "string cheese" release.
  * Merge from Debian unstable. Remaining changes:
    - Ubuntu specific:
      + debian/login.defs: use SHA512 by default for password crypt routine.
    - debian/{source_shadow.py,rules}: Add apport hook
    - debian/rules: fix FTBFS from newer libtools
    - debian/patches/495_stdout-encrypted-password: chpasswd can report
      password hashes on stdout (Debian bug 505640).
  * Dropped changes, merged in Debian:
    - debian/patches/300_CVE-2011-0721: reject newlines in GECOS updates.
    - CVE-2011-0721
  * Mark passwd Multi-Arch: foreign, so packages that aren't of the same
    arch can depend on it.

ubuntu/maverick-security 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.2-1ubuntu3.2 to ubuntu/maverick-secu...

Author: Kees Cook
Author Date: 2011-02-14 21:37:48 UTC

Import patches-unapplied version 1:4.1.4.2-1ubuntu3.2 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 552a89b84d0a30b1a6ce2a05684b880c5fd22540

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

ubuntu/karmic-devel 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.1-1ubuntu2.2 to ubuntu/karmic-security

Author: Kees Cook
Author Date: 2011-02-14 21:43:17 UTC

Import patches-unapplied version 1:4.1.4.1-1ubuntu2.2 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 00c5d077e447e8aa2e6c5dd1f3069a51e004c3bf

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

ubuntu/karmic-security 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.1-1ubuntu2.2 to ubuntu/karmic-security

Author: Kees Cook
Author Date: 2011-02-14 21:43:17 UTC

Import patches-unapplied version 1:4.1.4.1-1ubuntu2.2 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 00c5d077e447e8aa2e6c5dd1f3069a51e004c3bf

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

ubuntu/karmic-updates 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.1-1ubuntu2.2 to ubuntu/karmic-security

Author: Kees Cook
Author Date: 2011-02-14 21:43:17 UTC

Import patches-unapplied version 1:4.1.4.1-1ubuntu2.2 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 00c5d077e447e8aa2e6c5dd1f3069a51e004c3bf

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

ubuntu/lucid-devel 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.2-1ubuntu2.2 to ubuntu/lucid-security

Author: Kees Cook
Author Date: 2011-02-14 21:42:29 UTC

Import patches-unapplied version 1:4.1.4.2-1ubuntu2.2 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 8c125758456ea77ee413b1ba11a64bed2d506d78

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

ubuntu/lucid-security 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.2-1ubuntu2.2 to ubuntu/lucid-security

Author: Kees Cook
Author Date: 2011-02-14 21:42:29 UTC

Import patches-unapplied version 1:4.1.4.2-1ubuntu2.2 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 8c125758456ea77ee413b1ba11a64bed2d506d78

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

ubuntu/lucid-updates 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.2-1ubuntu2.2 to ubuntu/lucid-security

Author: Kees Cook
Author Date: 2011-02-14 21:42:29 UTC

Import patches-unapplied version 1:4.1.4.2-1ubuntu2.2 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 8c125758456ea77ee413b1ba11a64bed2d506d78

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

ubuntu/maverick-devel 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.2-1ubuntu3.2 to ubuntu/maverick-secu...

Author: Kees Cook
Author Date: 2011-02-14 21:37:48 UTC

Import patches-unapplied version 1:4.1.4.2-1ubuntu3.2 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 552a89b84d0a30b1a6ce2a05684b880c5fd22540

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

ubuntu/maverick-updates 2011-02-15 21:05:58 UTC 2011-02-15
Import patches-unapplied version 1:4.1.4.2-1ubuntu3.2 to ubuntu/maverick-secu...

Author: Kees Cook
Author Date: 2011-02-14 21:37:48 UTC

Import patches-unapplied version 1:4.1.4.2-1ubuntu3.2 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 552a89b84d0a30b1a6ce2a05684b880c5fd22540

New changelog entries:
  * SECURITY UPDATE: could inject NIS groups memberships into /etc/passwd.
    - debian/patches/900_locale_env_sanity: actually set locale environment
      variables correctly.
    - debian/patches/901_reject_newline: reject newlines in GECOS updates.
    - CVE-2011-0721

debian/squeeze 2011-02-13 21:02:28 UTC 2011-02-13
Import patches-unapplied version 1:4.1.4.2+svn3283-2+squeeze1 to debian/squeeze

Author: Nicolas François
Author Date: 2011-02-13 21:02:28 UTC

Import patches-unapplied version 1:4.1.4.2+svn3283-2+squeeze1 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 42947519b8e17ade37e8a70dfdb029ff3096766c

New changelog entries:
  * The "Tomanoix" release.
  * debian/patches/300_CVE-2011-0721: Fix insufficient input sanitation
    leading to possible user or group creation in NIS environments.

ubuntu/maverick 2010-09-03 10:06:44 UTC 2010-09-03
Import patches-unapplied version 1:4.1.4.2-1ubuntu3 to ubuntu/maverick

Author: Oliver Grawert
Author Date: 2010-08-31 12:45:17 UTC

Import patches-unapplied version 1:4.1.4.2-1ubuntu3 to ubuntu/maverick

Imported using git-ubuntu import.

Changelog parent: 8c125758456ea77ee413b1ba11a64bed2d506d78

New changelog entries:
  * add ttyO0-3 to debian/securetty.linux, if OMAP kernels are built with
    TI's DMA-offloaded driver instead of the default 8250 one the serial tty's
    are called like that (LP: #512845).

debian/lenny 2010-01-30 15:14:02 UTC 2010-01-30
Import patches-unapplied version 1:4.1.1-6+lenny1 to debian/lenny

Author: Nicolas François
Author Date: 2009-11-13 21:13:39 UTC

Import patches-unapplied version 1:4.1.1-6+lenny1 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: 5a078a4c8b19cdd5205d21fe4550a41d47de4d36

New changelog entries:
  * The "Soumaintrain" release.
  * debian/patches/306_long_group_lines: Fix handling of long lines in the
    user or group files. Closes: #552006

ubuntu/lucid 2010-01-26 17:04:40 UTC 2010-01-26
Import patches-unapplied version 1:4.1.4.2-1ubuntu2 to ubuntu/lucid

Author: Marc Deslauriers
Author Date: 2010-01-26 13:54:59 UTC

Import patches-unapplied version 1:4.1.4.2-1ubuntu2 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 7a20e73adef33cb9f18e954d1cf90deb295f31b3

New changelog entries:
  * debian/{source_shadow.py,rules}: Add apport hook
  * debian/rules: fix FTBFS from newer libtools

ubuntu/karmic 2009-07-31 14:04:04 UTC 2009-07-31
Import patches-unapplied version 1:4.1.4.1-1ubuntu2 to ubuntu/karmic

Author: Loïc Minier
Author Date: 2009-07-31 13:34:56 UTC

Import patches-unapplied version 1:4.1.4.1-1ubuntu2 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: fcde071593539cbd9a3fbec324598831c95176cb

New changelog entries:
  * debian/securetty.linux: also list ttyS2 and ttyS3; beagleboard uses ttyS2
    as serial port.

ubuntu/jaunty 2009-04-04 06:04:19 UTC 2009-04-04
Import patches-unapplied version 1:4.1.1-6ubuntu6 to ubuntu/jaunty

Author: Kees Cook
Author Date: 2009-04-04 05:12:07 UTC

Import patches-unapplied version 1:4.1.1-6ubuntu6 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 6a4f2b17ce3d0df6ba549905f00b837438ee73d7

New changelog entries:
  * debian/login.preinst: fix typo in grep (LP: #354887).

ubuntu/jaunty-devel 2009-04-04 06:04:19 UTC 2009-04-04
Import patches-unapplied version 1:4.1.1-6ubuntu6 to ubuntu/jaunty

Author: Kees Cook
Author Date: 2009-04-04 05:12:07 UTC

Import patches-unapplied version 1:4.1.1-6ubuntu6 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 6a4f2b17ce3d0df6ba549905f00b837438ee73d7

New changelog entries:
  * debian/login.preinst: fix typo in grep (LP: #354887).

ubuntu/hardy-security 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.18.2-1ubuntu2.2 to ubuntu/hardy-security

Author: Kees Cook
Author Date: 2008-12-08 08:46:04 UTC

Import patches-unapplied version 1:4.0.18.2-1ubuntu2.2 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: a408f560c0ce1079cd460f3152247f53cf99f8a5

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/hardy-devel 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.18.2-1ubuntu2.2 to ubuntu/hardy-security

Author: Kees Cook
Author Date: 2008-12-08 08:46:04 UTC

Import patches-unapplied version 1:4.0.18.2-1ubuntu2.2 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: a408f560c0ce1079cd460f3152247f53cf99f8a5

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/intrepid-devel 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.1.1-1ubuntu1.2 to ubuntu/intrepid-security

Author: Kees Cook
Author Date: 2008-12-08 08:26:39 UTC

Import patches-unapplied version 1:4.1.1-1ubuntu1.2 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 97ef535581fc94a763c1c8bccfa04d9cc10e131e

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/dapper-security 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.13-7ubuntu3.4 to ubuntu/dapper-security

Author: Kees Cook
Author Date: 2008-12-08 08:36:57 UTC

Import patches-unapplied version 1:4.0.13-7ubuntu3.4 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: 7499f25fe37dd03285935c90a876ed6ed2229af1

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/dapper-devel 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.13-7ubuntu3.4 to ubuntu/dapper-security

Author: Kees Cook
Author Date: 2008-12-08 08:36:57 UTC

Import patches-unapplied version 1:4.0.13-7ubuntu3.4 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: 7499f25fe37dd03285935c90a876ed6ed2229af1

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/intrepid-updates 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.1.1-1ubuntu1.2 to ubuntu/intrepid-security

Author: Kees Cook
Author Date: 2008-12-08 08:26:39 UTC

Import patches-unapplied version 1:4.1.1-1ubuntu1.2 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 97ef535581fc94a763c1c8bccfa04d9cc10e131e

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/intrepid-security 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.1.1-1ubuntu1.2 to ubuntu/intrepid-security

Author: Kees Cook
Author Date: 2008-12-08 08:26:39 UTC

Import patches-unapplied version 1:4.1.1-1ubuntu1.2 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 97ef535581fc94a763c1c8bccfa04d9cc10e131e

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/dapper-updates 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.13-7ubuntu3.4 to ubuntu/dapper-security

Author: Kees Cook
Author Date: 2008-12-08 08:36:57 UTC

Import patches-unapplied version 1:4.0.13-7ubuntu3.4 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: 7499f25fe37dd03285935c90a876ed6ed2229af1

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/hardy-updates 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.18.2-1ubuntu2.2 to ubuntu/hardy-security

Author: Kees Cook
Author Date: 2008-12-08 08:46:04 UTC

Import patches-unapplied version 1:4.0.18.2-1ubuntu2.2 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: a408f560c0ce1079cd460f3152247f53cf99f8a5

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/gutsy-updates 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.18.1-9ubuntu0.2 to ubuntu/gutsy-security

Author: Kees Cook
Author Date: 2008-12-08 08:35:28 UTC

Import patches-unapplied version 1:4.0.18.1-9ubuntu0.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 4d050fbd25a913e654a9369d0693d0d714948b72

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/gutsy-security 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.18.1-9ubuntu0.2 to ubuntu/gutsy-security

Author: Kees Cook
Author Date: 2008-12-08 08:35:28 UTC

Import patches-unapplied version 1:4.0.18.1-9ubuntu0.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 4d050fbd25a913e654a9369d0693d0d714948b72

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

ubuntu/gutsy-devel 2008-12-18 01:04:16 UTC 2008-12-18
Import patches-unapplied version 1:4.0.18.1-9ubuntu0.2 to ubuntu/gutsy-security

Author: Kees Cook
Author Date: 2008-12-08 08:35:28 UTC

Import patches-unapplied version 1:4.0.18.1-9ubuntu0.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: 4d050fbd25a913e654a9369d0693d0d714948b72

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via utmp group.
    - debian/patches/303_login_symlink_attack: upstream fix thanks
      to Paul Szabo and Nicolas François.

applied/debian/squeeze 2008-11-23 02:14:53 UTC 2008-11-23
Import patches-applied version 1:4.1.1-6 to applied/debian/sid

Author: Nicolas François
Author Date: 2008-11-14 20:52:42 UTC

Import patches-applied version 1:4.1.1-6 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7f97af784c64df7fa087c3563345f08fa6c73027
Unapplied parent: 5a078a4c8b19cdd5205d21fe4550a41d47de4d36

New changelog entries:
  * The "Rollot" release.
  * debian/patches/303_login_symlink_attack: Fix a race condition that could
    lead to gaining ownership or changing mode of arbitrary files.
    Closes: #505271
  * debian/patches/304_su.1_synopsis: Fix the su synopsis. username is
    referenced in the manpage, not LOGIN. Closes: #501830
  * debian/patches/305_login.1_japanese: Fix the path of the utmp and wtmp
    files. Closes: #501353

applied/debian/sid 2008-11-23 02:14:53 UTC 2008-11-23
Import patches-applied version 1:4.1.1-6 to applied/debian/sid

Author: Nicolas François
Author Date: 2008-11-14 20:52:42 UTC

Import patches-applied version 1:4.1.1-6 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7f97af784c64df7fa087c3563345f08fa6c73027
Unapplied parent: 5a078a4c8b19cdd5205d21fe4550a41d47de4d36

New changelog entries:
  * The "Rollot" release.
  * debian/patches/303_login_symlink_attack: Fix a race condition that could
    lead to gaining ownership or changing mode of arbitrary files.
    Closes: #505271
  * debian/patches/304_su.1_synopsis: Fix the su synopsis. username is
    referenced in the manpage, not LOGIN. Closes: #501830
  * debian/patches/305_login.1_japanese: Fix the path of the utmp and wtmp
    files. Closes: #501353

applied/debian/lenny 2008-11-23 02:14:53 UTC 2008-11-23
Import patches-applied version 1:4.1.1-6 to applied/debian/sid

Author: Nicolas François
Author Date: 2008-11-14 20:52:42 UTC

Import patches-applied version 1:4.1.1-6 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7f97af784c64df7fa087c3563345f08fa6c73027
Unapplied parent: 5a078a4c8b19cdd5205d21fe4550a41d47de4d36

New changelog entries:
  * The "Rollot" release.
  * debian/patches/303_login_symlink_attack: Fix a race condition that could
    lead to gaining ownership or changing mode of arbitrary files.
    Closes: #505271
  * debian/patches/304_su.1_synopsis: Fix the su synopsis. username is
    referenced in the manpage, not LOGIN. Closes: #501830
  * debian/patches/305_login.1_japanese: Fix the path of the utmp and wtmp
    files. Closes: #501353

ubuntu/intrepid 2008-06-09 19:06:37 UTC 2008-06-09
Import patches-unapplied version 1:4.1.1-1ubuntu1 to ubuntu/intrepid

Author: Kees Cook
Author Date: 2008-06-09 17:08:38 UTC

Import patches-unapplied version 1:4.1.1-1ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 86f88144c3ca0a4d9b16ef09d07b216ba042780e

New changelog entries:
  * Merge from debian unstable, remaining changes:
    - debian/login.pam: Enable SELinux support in login.pam.
  * New upstream release. This closes the following bugs:
    - Fix errors when gpasswd is called without a gshadow file.
      Closes: #467236, #467488
    - Fix newgrp segfault when the primary group is not listed in /etc/groups.
      Closes: #461670
    - Fix infinite loop in usermod when two groups have the same name.
      Closes: #470745
    - Make SE Linux tests more strict, when the real UID is 0 SE Linux checks
      will be performed. Closes: #472575
    - Option --password added to groupadd / groupmod (like useradd / usermod).
      Closes: #445484
    - Remove patches applied upstream:
      + debian/patches/451_login_PATH
      + debian/patches/462_warn_to_edit_shadow
      + debian/patches/467_useradd_-r_LSB
      + debian/patches/466_fflush-prompt
      + debian/patches/480_getopt_args_reorder
      + debian/patches/496_login_init_session
      + debian/patches/408_passwd_check_arguments
      + debian/patches/412_lastlog_-u_numerical_range
      + debian/patches/407_adduser_disable_PUG_with-n
    - Updated patches:
      + debian/patches/504_undef_USE_PAM.nolibpam
        $(LIBCRYPT) $(LIBSKEY) $(LIBMD) are no more included in libshadow.la.
        Avoid link to unneeded libraries (spotted by dpkg-shlibdeps).
      + debian/patches/501_commonio_group_shadow
      + debian/patches/429_login_FAILLOG_ENAB
      + debian/patches/542_useradd-O_option
      + debian/patches/401_cppw_src.dpatch
      + debian/patches/428_grpck_add_prune_option
    - Updated translations:
      + Basque. Closes: #473555
      + German. Closes: #473646
      + Italian. Closes: #472951
      + Korean. Closes: #471935
      + Portuguese. Closes: #472244
      + Russian. Closes: #472506
      + Slovak. Closes: #471802
      + Turkish. Closes: #473279
  * debian/watch: Add a watch file for shadow.
  * debian/rules, debian/recode_manpages.sh: Do not recode the manpages.
    Keep them in UTF-8.
  * debian/rules, debian/control: login (>= 970502-1) was already provided
    by login in Hamm. libpam-modules (>= 0.72-5) was already provided by
    libpam-modules in Potato. libpam-runtime (>= 0.76-14) was already provided
    by libpam-runtime in Sarge (now oldstable). Simplify the dependencies.
  * debian/control: Move the dependency on libpam-modules from Depends to
    Pre-Depends. The login package is Essential, and without libpam-modules,
    login or su are not functional. Thanks to Steve Langasek for pointing this
    out.
  * debian/control: There's no need for a dependency on login (now that it is
    unversionned; see above) in the passwd package.
  * debian/control: The passwd's Replaces on manpages-de can be versionned
    again. The su(1) manpage was removed from manpages-de.
  * debian/securetty.linux: Added ttyUSB0, ttyUSB1, ttyUSB2, and MPC5200
    serial ports (ttyPSC0, ttyPSC1, ttyPSC2, ttyPSC3, ttyPSC4, ttyPSC5).
    Closes: #461374
  * debian/control: Change XS-X-Vcs-Svn to Vcs-Svn. Update the link to the
    new repository layout. Add a Vcs-Browser field.
  * debian/control: Added Homepage field.
  * debian/passwd.postrm: Removed (was empty).
  * The "Bleu des Causses" release
  * Unversion the conflict with manpages-de for login, as it also provides
    a German manpage for su(1). Closes: #460508
  [ Nicolas FRANCOIS (Nekral) ]
  * The "Bleu d'Auvergne" release
  * New upstream release. This closes the following bugs:
    - usermod: Make usermod options independent of the argument order.
      Closes: #451518
    - login: Improve logging of login when the user's passwd entry could not
      be retrieved. Closes: #451521
    - Updated Russian translations. Thanks to Yuri Kozlov <kozlov.y@gmail.com>.
      Closes: #452291, #452296
    - Section of newgrp fixed in the gshadow manpage. Closes: #454485
    - Remove patches applied upstream:
      + 468_duplicate_passwd_struct_before_usage
      + 495_salt_stack_smash
      + 397_non_numerical_identifier
      + 405_su_no_pam_end_before_exec
      + 493_pwck_no_SHADOWPWD
      + 497_newgrp_primary_group
      + 409_man_generate_from_PO
      + 410_newgrp_man_mention_sg
      + 411_chpasswd_document_no_pam
      + 494_passwd_lock
      + 417_passwd_warndays
    - Updated patches:
      + debian/patches/504_undef_USE_PAM.dpatch
        MD5_CRYPT_ENAB is back in login.defs to define the default crypt
        algorithm. It is tagged as deprecated and ENCRYPT_METHOD is
        recommended instead. New algorithms are also available.
        Closes: #447747
  * Debian packaging fixes:
    - debian/rules: compile with -W -Wall
    - debian/rules: large files are now supported by configure. Remove
      -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 from
      CFLAGS.
    - 479_chowntty_debug was debian specific. Renamed to 579_chowntty_debug
    - Remove (not applied patch) 419_time_structures.dpatch. All its chunks
      are already applied upstream (with some differences), except one chunk
      which comes from 008_login_log_failure_in_FTMP. Fix
      008_login_log_failure_in_FTMP. This should fix some bugs causing invalid
      faillog entries on 64 bit architectures with 32 bit compatibility.
    - debian/securetty.linux: Add ttyS1. Better comments for the ttyS and xen
      consoles. Add a note for the devfs consoles. They are no more needed for
      most users. Closes: #454584
  [ Christian Perrier ]
  * debian/control
    - Updated to Standards: 3.7.3.0 (checked, no change needed)

ubuntu/hardy 2008-04-03 01:03:58 UTC 2008-04-03
Import patches-unapplied version 1:4.0.18.2-1ubuntu2 to ubuntu/hardy

Author: Matt T. Proud
Author Date: 2008-02-09 02:30:51 UTC

Import patches-unapplied version 1:4.0.18.2-1ubuntu2 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 44772ba7fa22495b54342d1c840be6351bfa3b8f

New changelog entries:
  * Add 498_make_useradd_faster_with_ldap: make useradd faster when
    nsswitch uses LDAP or some other remote names database (LP: #120015),
    thanks to Vince Busam.

1100 of 134 results

Other repositories

Name Last Modified
lp:ubuntu/+source/shadow 2018-10-31
11 of 1 result
You can't create new repositories for shadow in Ubuntu.