Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/ruby2.5
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2019-06-03 12:38:42 UTC 2019-06-03
DSC file for 2.5.5-3ubuntu1

Author: Ubuntu Git Importer
Author Date: 2019-06-03 12:38:42 UTC

DSC file for 2.5.5-3ubuntu1

applied/ubuntu/devel 2019-06-03 12:33:16 UTC 2019-06-03
Import patches-applied version 2.5.5-3ubuntu1 to applied/ubuntu/eoan-proposed

Author: Gianfranco Costamagna
Author Date: 2019-06-03 12:29:11 UTC

Import patches-applied version 2.5.5-3ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 83f816ff924d5a6bd3154ffe93c45f9e852bf43d
Unapplied parent: b0aef90591c068535f1ac416d1f2cf1027545001

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch

applied/ubuntu/eoan-proposed 2019-06-03 12:33:16 UTC 2019-06-03
Import patches-applied version 2.5.5-3ubuntu1 to applied/ubuntu/eoan-proposed

Author: Gianfranco Costamagna
Author Date: 2019-06-03 12:29:11 UTC

Import patches-applied version 2.5.5-3ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 83f816ff924d5a6bd3154ffe93c45f9e852bf43d
Unapplied parent: b0aef90591c068535f1ac416d1f2cf1027545001

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch

applied/ubuntu/eoan-devel 2019-06-03 12:33:16 UTC 2019-06-03
Import patches-applied version 2.5.5-3ubuntu1 to applied/ubuntu/eoan-proposed

Author: Gianfranco Costamagna
Author Date: 2019-06-03 12:29:11 UTC

Import patches-applied version 2.5.5-3ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 83f816ff924d5a6bd3154ffe93c45f9e852bf43d
Unapplied parent: b0aef90591c068535f1ac416d1f2cf1027545001

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch

ubuntu/devel 2019-06-03 12:33:16 UTC 2019-06-03
Import patches-unapplied version 2.5.5-3ubuntu1 to ubuntu/eoan-proposed

Author: Gianfranco Costamagna
Author Date: 2019-06-03 12:29:11 UTC

Import patches-unapplied version 2.5.5-3ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e0abd7081d2ba3d525061a8cd031222a17899cbf

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch

ubuntu/eoan 2019-06-03 12:33:16 UTC 2019-06-03
Import patches-unapplied version 2.5.5-3ubuntu1 to ubuntu/eoan-proposed

Author: Gianfranco Costamagna
Author Date: 2019-06-03 12:29:11 UTC

Import patches-unapplied version 2.5.5-3ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e0abd7081d2ba3d525061a8cd031222a17899cbf

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch

applied/ubuntu/eoan 2019-06-03 12:33:16 UTC 2019-06-03
Import patches-applied version 2.5.5-3ubuntu1 to applied/ubuntu/eoan-proposed

Author: Gianfranco Costamagna
Author Date: 2019-06-03 12:29:11 UTC

Import patches-applied version 2.5.5-3ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: 83f816ff924d5a6bd3154ffe93c45f9e852bf43d
Unapplied parent: b0aef90591c068535f1ac416d1f2cf1027545001

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch

ubuntu/eoan-devel 2019-06-03 12:33:16 UTC 2019-06-03
Import patches-unapplied version 2.5.5-3ubuntu1 to ubuntu/eoan-proposed

Author: Gianfranco Costamagna
Author Date: 2019-06-03 12:29:11 UTC

Import patches-unapplied version 2.5.5-3ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e0abd7081d2ba3d525061a8cd031222a17899cbf

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch

ubuntu/eoan-proposed 2019-06-03 12:33:16 UTC 2019-06-03
Import patches-unapplied version 2.5.5-3ubuntu1 to ubuntu/eoan-proposed

Author: Gianfranco Costamagna
Author Date: 2019-06-03 12:29:11 UTC

Import patches-unapplied version 2.5.5-3ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e0abd7081d2ba3d525061a8cd031222a17899cbf

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch

importer/debian/dsc 2019-06-02 16:50:50 UTC 2019-06-02
DSC file for 2.5.5-3

Author: Ubuntu Git Importer
Author Date: 2019-06-02 16:50:50 UTC

DSC file for 2.5.5-3

debian/sid 2019-06-02 16:39:34 UTC 2019-06-02
Import patches-unapplied version 2.5.5-3 to debian/sid

Author: Antonio Terceiro
Author Date: 2019-06-02 13:16:57 UTC

Import patches-unapplied version 2.5.5-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1eb52fba145ea99ebc556b7e343bdb705664c958

New changelog entries:
  * ia64: Don't clear register_stack_start (Closes: #928068)

applied/debian/sid 2019-06-02 16:39:34 UTC 2019-06-02
Import patches-applied version 2.5.5-3 to applied/debian/sid

Author: Antonio Terceiro
Author Date: 2019-06-02 13:16:57 UTC

Import patches-applied version 2.5.5-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: b8554a49de0cf5d6259ddcdd146ae58983007f43
Unapplied parent: ae9cfed93c17536665daff996ca1e32fd0c5e988

New changelog entries:
  * ia64: Don't clear register_stack_start (Closes: #928068)

applied/debian/buster 2019-06-02 16:39:34 UTC 2019-06-02
Import patches-applied version 2.5.5-3 to applied/debian/sid

Author: Antonio Terceiro
Author Date: 2019-06-02 13:16:57 UTC

Import patches-applied version 2.5.5-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: b8554a49de0cf5d6259ddcdd146ae58983007f43
Unapplied parent: ae9cfed93c17536665daff996ca1e32fd0c5e988

New changelog entries:
  * ia64: Don't clear register_stack_start (Closes: #928068)

debian/buster 2019-06-02 16:39:34 UTC 2019-06-02
Import patches-unapplied version 2.5.5-3 to debian/sid

Author: Antonio Terceiro
Author Date: 2019-06-02 13:16:57 UTC

Import patches-unapplied version 2.5.5-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1eb52fba145ea99ebc556b7e343bdb705664c958

New changelog entries:
  * ia64: Don't clear register_stack_start (Closes: #928068)

ubuntu/bionic-proposed 2019-05-25 05:48:13 UTC 2019-05-25
Import patches-unapplied version 2.5.1-1ubuntu1.4 to ubuntu/bionic-proposed

Author: Dimitri John Ledkov
Author Date: 2019-04-23 22:50:41 UTC

Import patches-unapplied version 2.5.1-1ubuntu1.4 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: dd286f3688914d8fb7d125f9a3c0f2ab9924a092

New changelog entries:
  * Cherrypick ruby-openssl upstream commits to fix compat with OpenSSL
    1.1.1 LP: #1797386

ubuntu/bionic-updates 2019-05-25 05:48:13 UTC 2019-05-25
Import patches-unapplied version 2.5.1-1ubuntu1.4 to ubuntu/bionic-proposed

Author: Dimitri John Ledkov
Author Date: 2019-04-23 22:50:41 UTC

Import patches-unapplied version 2.5.1-1ubuntu1.4 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: dd286f3688914d8fb7d125f9a3c0f2ab9924a092

New changelog entries:
  * Cherrypick ruby-openssl upstream commits to fix compat with OpenSSL
    1.1.1 LP: #1797386

applied/ubuntu/bionic-updates 2019-05-25 05:48:13 UTC 2019-05-25
Import patches-applied version 2.5.1-1ubuntu1.4 to applied/ubuntu/bionic-prop...

Author: Dimitri John Ledkov
Author Date: 2019-04-23 22:50:41 UTC

Import patches-applied version 2.5.1-1ubuntu1.4 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 5494f0cd245fd31b93361b27c802a540962d85bd
Unapplied parent: 6207962287e85c282c86af80103fd48e28000f63

New changelog entries:
  * Cherrypick ruby-openssl upstream commits to fix compat with OpenSSL
    1.1.1 LP: #1797386

ubuntu/bionic-devel 2019-05-25 05:48:13 UTC 2019-05-25
Import patches-unapplied version 2.5.1-1ubuntu1.4 to ubuntu/bionic-proposed

Author: Dimitri John Ledkov
Author Date: 2019-04-23 22:50:41 UTC

Import patches-unapplied version 2.5.1-1ubuntu1.4 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: dd286f3688914d8fb7d125f9a3c0f2ab9924a092

New changelog entries:
  * Cherrypick ruby-openssl upstream commits to fix compat with OpenSSL
    1.1.1 LP: #1797386

applied/ubuntu/bionic-proposed 2019-05-25 05:48:13 UTC 2019-05-25
Import patches-applied version 2.5.1-1ubuntu1.4 to applied/ubuntu/bionic-prop...

Author: Dimitri John Ledkov
Author Date: 2019-04-23 22:50:41 UTC

Import patches-applied version 2.5.1-1ubuntu1.4 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 5494f0cd245fd31b93361b27c802a540962d85bd
Unapplied parent: 6207962287e85c282c86af80103fd48e28000f63

New changelog entries:
  * Cherrypick ruby-openssl upstream commits to fix compat with OpenSSL
    1.1.1 LP: #1797386

applied/ubuntu/bionic-devel 2019-05-25 05:48:13 UTC 2019-05-25
Import patches-applied version 2.5.1-1ubuntu1.4 to applied/ubuntu/bionic-prop...

Author: Dimitri John Ledkov
Author Date: 2019-04-23 22:50:41 UTC

Import patches-applied version 2.5.1-1ubuntu1.4 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 5494f0cd245fd31b93361b27c802a540962d85bd
Unapplied parent: 6207962287e85c282c86af80103fd48e28000f63

New changelog entries:
  * Cherrypick ruby-openssl upstream commits to fix compat with OpenSSL
    1.1.1 LP: #1797386

ubuntu/cosmic-devel 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-unapplied version 2.5.1-5ubuntu4.3 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2019-04-02 16:31:23 UTC

Import patches-unapplied version 2.5.1-5ubuntu4.3 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: a5fb6aaf5eec6348ba9af6047096d54fe3132548

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325

applied/ubuntu/bionic-security 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-applied version 2.5.1-1ubuntu1.2 to applied/ubuntu/bionic-secu...

Author: Leonidas S. Barbosa
Author Date: 2019-04-01 14:13:08 UTC

Import patches-applied version 2.5.1-1ubuntu1.2 to applied/ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: f1c7dc396519ec22d5292790678c9f472b38ccf5
Unapplied parent: 9114c7ed3a0397fd59f99348bc2405af965a7400

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325
  * Fixing expired SSL certs
    - debian/patches/fixing_expired_SSL_certs.patch: fix in
      test/net/fixtures/cacert.pem, test/net/fixtures/server.crt,
      test/net/fixtures/server.key.

applied/ubuntu/cosmic-devel 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-applied version 2.5.1-5ubuntu4.3 to applied/ubuntu/cosmic-secu...

Author: Leonidas S. Barbosa
Author Date: 2019-04-02 16:31:23 UTC

Import patches-applied version 2.5.1-5ubuntu4.3 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 4b892bd3d5c80e19b92922a4e0ce3a15569f51f4
Unapplied parent: 9d7523f6866e17e2dda30e3d5433f3a9dbf4c117

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325

applied/ubuntu/cosmic-security 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-applied version 2.5.1-5ubuntu4.3 to applied/ubuntu/cosmic-secu...

Author: Leonidas S. Barbosa
Author Date: 2019-04-02 16:31:23 UTC

Import patches-applied version 2.5.1-5ubuntu4.3 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 4b892bd3d5c80e19b92922a4e0ce3a15569f51f4
Unapplied parent: 9d7523f6866e17e2dda30e3d5433f3a9dbf4c117

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325

applied/ubuntu/cosmic-updates 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-applied version 2.5.1-5ubuntu4.3 to applied/ubuntu/cosmic-secu...

Author: Leonidas S. Barbosa
Author Date: 2019-04-02 16:31:23 UTC

Import patches-applied version 2.5.1-5ubuntu4.3 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 4b892bd3d5c80e19b92922a4e0ce3a15569f51f4
Unapplied parent: 9d7523f6866e17e2dda30e3d5433f3a9dbf4c117

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325

ubuntu/bionic-security 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-unapplied version 2.5.1-1ubuntu1.2 to ubuntu/bionic-security

Author: Leonidas S. Barbosa
Author Date: 2019-04-01 14:13:08 UTC

Import patches-unapplied version 2.5.1-1ubuntu1.2 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: ac8c9214ac6c8a939f508887443b62f926d11929

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325
  * Fixing expired SSL certs
    - debian/patches/fixing_expired_SSL_certs.patch: fix in
      test/net/fixtures/cacert.pem, test/net/fixtures/server.crt,
      test/net/fixtures/server.key.

ubuntu/cosmic-security 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-unapplied version 2.5.1-5ubuntu4.3 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2019-04-02 16:31:23 UTC

Import patches-unapplied version 2.5.1-5ubuntu4.3 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: a5fb6aaf5eec6348ba9af6047096d54fe3132548

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325

ubuntu/cosmic-updates 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-unapplied version 2.5.1-5ubuntu4.3 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2019-04-02 16:31:23 UTC

Import patches-unapplied version 2.5.1-5ubuntu4.3 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: a5fb6aaf5eec6348ba9af6047096d54fe3132548

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325

ubuntu/disco 2019-03-29 07:13:19 UTC 2019-03-29
Import patches-unapplied version 2.5.5-1ubuntu1 to ubuntu/disco-proposed

Author: Gianfranco Costamagna
Author Date: 2019-03-28 09:47:03 UTC

Import patches-unapplied version 2.5.5-1ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 625fb76b54513bc8ed771ea155f8f5005441afca

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch
  * Dropped changes: d/p/1dfc377ae3b174b043d3f0ed36de57b0296b34d0.patch
    - upstream

applied/ubuntu/disco 2019-03-29 07:13:19 UTC 2019-03-29
Import patches-applied version 2.5.5-1ubuntu1 to applied/ubuntu/disco-proposed

Author: Gianfranco Costamagna
Author Date: 2019-03-28 09:47:03 UTC

Import patches-applied version 2.5.5-1ubuntu1 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: f7b8fa3374c3bc913369f2a5bb08a65d7261c357
Unapplied parent: 705490ed606b7f99b9e66fda31b6184545dd5269

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch
  * Dropped changes: d/p/1dfc377ae3b174b043d3f0ed36de57b0296b34d0.patch
    - upstream

ubuntu/disco-proposed 2019-03-29 07:13:19 UTC 2019-03-29
Import patches-unapplied version 2.5.5-1ubuntu1 to ubuntu/disco-proposed

Author: Gianfranco Costamagna
Author Date: 2019-03-28 09:47:03 UTC

Import patches-unapplied version 2.5.5-1ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 625fb76b54513bc8ed771ea155f8f5005441afca

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch
  * Dropped changes: d/p/1dfc377ae3b174b043d3f0ed36de57b0296b34d0.patch
    - upstream

applied/ubuntu/disco-devel 2019-03-29 07:13:19 UTC 2019-03-29
Import patches-applied version 2.5.5-1ubuntu1 to applied/ubuntu/disco-proposed

Author: Gianfranco Costamagna
Author Date: 2019-03-28 09:47:03 UTC

Import patches-applied version 2.5.5-1ubuntu1 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: f7b8fa3374c3bc913369f2a5bb08a65d7261c357
Unapplied parent: 705490ed606b7f99b9e66fda31b6184545dd5269

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch
  * Dropped changes: d/p/1dfc377ae3b174b043d3f0ed36de57b0296b34d0.patch
    - upstream

applied/ubuntu/disco-proposed 2019-03-29 07:13:19 UTC 2019-03-29
Import patches-applied version 2.5.5-1ubuntu1 to applied/ubuntu/disco-proposed

Author: Gianfranco Costamagna
Author Date: 2019-03-28 09:47:03 UTC

Import patches-applied version 2.5.5-1ubuntu1 to applied/ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: f7b8fa3374c3bc913369f2a5bb08a65d7261c357
Unapplied parent: 705490ed606b7f99b9e66fda31b6184545dd5269

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch
  * Dropped changes: d/p/1dfc377ae3b174b043d3f0ed36de57b0296b34d0.patch
    - upstream

ubuntu/disco-devel 2019-03-29 07:13:19 UTC 2019-03-29
Import patches-unapplied version 2.5.5-1ubuntu1 to ubuntu/disco-proposed

Author: Gianfranco Costamagna
Author Date: 2019-03-28 09:47:03 UTC

Import patches-unapplied version 2.5.5-1ubuntu1 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: 625fb76b54513bc8ed771ea155f8f5005441afca

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - d/p/rubygems-2388.patch: Allow either Fetcher or OpenSSL exceptions
      when using invalid cert in rubygems testcase.
      - update the patch with the merged upstream PR: 2507
    - various backports for better openssl support (formerly undocumented in
      changelog)
      + d/p/0001-openssl-buffering.rb-no-RS-when-output.patch
      + d/p/0006-Workaround-for-old-LibreSSL.patch
  * Dropped changes: d/p/1dfc377ae3b174b043d3f0ed36de57b0296b34d0.patch
    - upstream

applied/ubuntu/cosmic-proposed 2019-03-01 20:38:17 UTC 2019-03-01
Import patches-applied version 2.5.1-5ubuntu4.2 to applied/ubuntu/cosmic-prop...

Author: Dimitri John Ledkov
Author Date: 2019-02-20 21:27:17 UTC

Import patches-applied version 2.5.1-5ubuntu4.2 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: c15bc4b07e02b0155eeecac0447ade33d5db6031
Unapplied parent: 924ecb677340b938dfdc88d8c13f6b97415bc523

New changelog entries:
  * d/p/update-cert-{1,2}.patch: update certificates to fix FTBFS. Patches
    prepared by Andreas Hasenack. (LP: #1812669)

ubuntu/cosmic-proposed 2019-03-01 20:38:17 UTC 2019-03-01
Import patches-unapplied version 2.5.1-5ubuntu4.2 to ubuntu/cosmic-proposed

Author: Dimitri John Ledkov
Author Date: 2019-02-20 21:27:17 UTC

Import patches-unapplied version 2.5.1-5ubuntu4.2 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: eb36d11dba53f4f579afdc03c31f7027e46d3d29

New changelog entries:
  * d/p/update-cert-{1,2}.patch: update certificates to fix FTBFS. Patches
    prepared by Andreas Hasenack. (LP: #1812669)

applied/ubuntu/cosmic 2018-09-25 12:48:15 UTC 2018-09-25
Import patches-applied version 2.5.1-5ubuntu4 to applied/ubuntu/cosmic-proposed

Author: Dimitri John Ledkov
Author Date: 2018-09-25 10:36:36 UTC

Import patches-applied version 2.5.1-5ubuntu4 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: d7425412e855760f7d189f705a9c4d31afd2f562
Unapplied parent: 876ecb5a2ff2ab59be08f12e4e239f1c2efcd86c

New changelog entries:
  * No change rebuild against openssl 1.1.1 with TLS1.3 support.

ubuntu/cosmic 2018-09-25 12:48:15 UTC 2018-09-25
Import patches-unapplied version 2.5.1-5ubuntu4 to ubuntu/cosmic-proposed

Author: Dimitri John Ledkov
Author Date: 2018-09-25 10:36:36 UTC

Import patches-unapplied version 2.5.1-5ubuntu4 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 7ea0c209e1ef68cb579686c5f83dd454838ae1b4

New changelog entries:
  * No change rebuild against openssl 1.1.1 with TLS1.3 support.

importer/ubuntu/pristine-tar 2018-04-05 18:47:54 UTC 2018-04-05
pristine-tar data for ruby2.5_2.5.1.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-04-05 18:47:54 UTC

pristine-tar data for ruby2.5_2.5.1.orig.tar.gz

importer/debian/pristine-tar 2018-04-05 18:29:43 UTC 2018-04-05
pristine-tar data for ruby2.5_2.5.1.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-04-05 18:29:43 UTC

pristine-tar data for ruby2.5_2.5.1.orig.tar.gz

applied/ubuntu/bionic 2018-04-02 20:58:23 UTC 2018-04-02
Import patches-applied version 2.5.1-1ubuntu1 to applied/ubuntu/bionic-proposed

Author: Matthias Klose
Author Date: 2018-04-02 20:15:10 UTC

Import patches-applied version 2.5.1-1ubuntu1 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 77d6c4985938ef89a75d21ca8c847dc05cfe683d
Unapplied parent: eeeefa9987c3125067133a38cded1d770bfebd23

New changelog entries:
  * Merge with Debian; remaining changes:
    - Mark some tests as failing on Launchpad.
    - Update symbols file.

ubuntu/bionic 2018-04-02 20:58:23 UTC 2018-04-02
Import patches-unapplied version 2.5.1-1ubuntu1 to ubuntu/bionic-proposed

Author: Matthias Klose
Author Date: 2018-04-02 20:15:10 UTC

Import patches-unapplied version 2.5.1-1ubuntu1 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 6d6fe5fe26ae1d7b6dcf35932240dd6f59d8c203

New changelog entries:
  * Merge with Debian; remaining changes:
    - Mark some tests as failing on Launchpad.
    - Update symbols file.

142 of 42 results

Other repositories

Name Last Modified
lp:ubuntu/+source/ruby2.5 2019-06-10
lp:~ahasenack/ubuntu/+source/ruby2.5 2019-01-21
lp:~paelzer/ubuntu/+source/ruby2.5 2018-12-04
13 of 3 results
You can't create new repositories for ruby2.5 in Ubuntu.