View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/ruby1.9.1
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2019-04-26 08:53:15 UTC 2019-04-26
DSC file for 1.9.3.484-2ubuntu1.14

Author: Ubuntu Git Importer
Author Date: 2019-04-26 08:53:15 UTC

DSC file for 1.9.3.484-2ubuntu1.14

ubuntu/trusty-updates 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-unapplied version 1.9.3.484-2ubuntu1.14 to ubuntu/trusty-security

Author: Leonidas S. Barbosa
Author Date: 2019-03-29 17:46:36 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu1.14 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: e30f2ab0c1690f39b18659cc00469aee5fdc9ae3

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325
  * Fixing expired certification that causes tests to fail
    - debian/patches/fixing_expired_SSL_certificates.patch: updating certs in
      test/net/imap/cacert.pen, test/net/imap/server.crt,
      test/net/imap/server.key.

ubuntu/trusty-security 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-unapplied version 1.9.3.484-2ubuntu1.14 to ubuntu/trusty-security

Author: Leonidas S. Barbosa
Author Date: 2019-03-29 17:46:36 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu1.14 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: e30f2ab0c1690f39b18659cc00469aee5fdc9ae3

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325
  * Fixing expired certification that causes tests to fail
    - debian/patches/fixing_expired_SSL_certificates.patch: updating certs in
      test/net/imap/cacert.pen, test/net/imap/server.crt,
      test/net/imap/server.key.

applied/ubuntu/trusty-devel 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-applied version 1.9.3.484-2ubuntu1.14 to applied/ubuntu/trusty...

Author: Leonidas S. Barbosa
Author Date: 2019-03-29 17:46:36 UTC

Import patches-applied version 1.9.3.484-2ubuntu1.14 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 75524443cff3cff84a4f4ab6b0ff677bdd3c93b4
Unapplied parent: e6e115314956c1f7abf7e7253a6bf1e02e6cd650

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325
  * Fixing expired certification that causes tests to fail
    - debian/patches/fixing_expired_SSL_certificates.patch: updating certs in
      test/net/imap/cacert.pen, test/net/imap/server.crt,
      test/net/imap/server.key.

applied/ubuntu/trusty-updates 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-applied version 1.9.3.484-2ubuntu1.14 to applied/ubuntu/trusty...

Author: Leonidas S. Barbosa
Author Date: 2019-03-29 17:46:36 UTC

Import patches-applied version 1.9.3.484-2ubuntu1.14 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 75524443cff3cff84a4f4ab6b0ff677bdd3c93b4
Unapplied parent: e6e115314956c1f7abf7e7253a6bf1e02e6cd650

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325
  * Fixing expired certification that causes tests to fail
    - debian/patches/fixing_expired_SSL_certificates.patch: updating certs in
      test/net/imap/cacert.pen, test/net/imap/server.crt,
      test/net/imap/server.key.

ubuntu/trusty-devel 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-unapplied version 1.9.3.484-2ubuntu1.14 to ubuntu/trusty-security

Author: Leonidas S. Barbosa
Author Date: 2019-03-29 17:46:36 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu1.14 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: e30f2ab0c1690f39b18659cc00469aee5fdc9ae3

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325
  * Fixing expired certification that causes tests to fail
    - debian/patches/fixing_expired_SSL_certificates.patch: updating certs in
      test/net/imap/cacert.pen, test/net/imap/server.crt,
      test/net/imap/server.key.

applied/ubuntu/trusty-security 2019-04-11 13:28:13 UTC 2019-04-11
Import patches-applied version 1.9.3.484-2ubuntu1.14 to applied/ubuntu/trusty...

Author: Leonidas S. Barbosa
Author Date: 2019-03-29 17:46:36 UTC

Import patches-applied version 1.9.3.484-2ubuntu1.14 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 75524443cff3cff84a4f4ab6b0ff677bdd3c93b4
Unapplied parent: e6e115314956c1f7abf7e7253a6bf1e02e6cd650

New changelog entries:
  * SECURITY UPDATE: Delete directory using symlink when decompressing tar,
    Escape sequence injection vulnerability in gem owner, Escape sequence
    injection vulnerability in API response handling, Arbitrary code exec,
    Escape sequence injection vulnerability in errors
    - debian/patches/CVE-2019-8320-25.patch: fix in
      lib/rubygems/command_manager.rb,
      lib/rubygems/commands/owner_command.rb,
      lib/rubygems/gemcutter_utilities.rb,
      lib/rubygems/installer.rb,
      lib/rubygems/package.rb,
      test/rubygems/test_gem_installer.rb,
      test/rubygems/test_gem_package.rb,
      test/rubygems/test_gem_text.rb.
    - CVE-2019-8320
    - CVE-2019-8321
    - CVE-2019-8322
    - CVE-2019-8323
    - CVE-2019-8324
    - CVE-2019-8325
  * Fixing expired certification that causes tests to fail
    - debian/patches/fixing_expired_SSL_certificates.patch: updating certs in
      test/net/imap/cacert.pen, test/net/imap/server.crt,
      test/net/imap/server.key.

importer/ubuntu/pristine-tar 2018-03-08 00:30:23 UTC 2018-03-08
pristine-tar data for ruby1.9.1_1.9.3.484.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-08 00:30:23 UTC

pristine-tar data for ruby1.9.1_1.9.3.484.orig.tar.gz

importer/debian/dsc 2018-03-07 23:53:02 UTC 2018-03-07
DSC file for 1.9.3.194-8.1+deb7u5

Author: Ubuntu Git Importer
Author Date: 2018-03-07 23:53:02 UTC

DSC file for 1.9.3.194-8.1+deb7u5

importer/debian/pristine-tar 2018-03-07 23:52:04 UTC 2018-03-07
pristine-tar data for ruby1.9.1_1.9.3.484.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-07 23:52:04 UTC

pristine-tar data for ruby1.9.1_1.9.3.484.orig.tar.gz

debian/wheezy 2016-06-05 05:41:21 UTC 2016-06-05
Import patches-unapplied version 1.9.3.194-8.1+deb7u5 to debian/wheezy

Author: Antonio Terceiro
Author Date: 2015-04-27 21:30:57 UTC

Import patches-unapplied version 1.9.3.194-8.1+deb7u5 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: b8b735805754a327bc5767129adab67ba5dbc7b9

New changelog entries:
  * Fix OpenSSL Hostname Verification [CVE-2015-1855]
  * Fix off-by-one error in the encodes function as per CVE-2014-4975
  * Fix unrestricted entity expansion in the REXML parser as per
    CVE-2014-8080 and CVE-2014-8090
  * Set urgency=high accordingly

applied/debian/wheezy 2016-06-05 05:41:21 UTC 2016-06-05
Import patches-applied version 1.9.3.194-8.1+deb7u5 to applied/debian/wheezy

Author: Antonio Terceiro
Author Date: 2015-04-27 21:30:57 UTC

Import patches-applied version 1.9.3.194-8.1+deb7u5 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: b1cb640a36387dde6e979031fce45f8e16966b1d
Unapplied parent: 73c8f264cf290bafc62be9ae9bff056bbb522cb4

New changelog entries:
  * Fix OpenSSL Hostname Verification [CVE-2015-1855]
  * Fix off-by-one error in the encodes function as per CVE-2014-4975
  * Fix unrestricted entity expansion in the REXML parser as per
    CVE-2014-8080 and CVE-2014-8090
  * Set urgency=high accordingly

applied/ubuntu/precise-security 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-applied version 1.9.3.0-1ubuntu2.10 to applied/ubuntu/precise-...

Author: Marc Deslauriers
Author Date: 2014-11-19 20:31:09 UTC

Import patches-applied version 1.9.3.0-1ubuntu2.10 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 5c94908df9aa84699eca3ce4452f53fe7a5a5038
Unapplied parent: f09e4d0703e4a9d2d6d95ac24cc40056b4bbfa31

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

ubuntu/precise-updates 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-unapplied version 1.9.3.0-1ubuntu2.10 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2014-11-19 20:31:09 UTC

Import patches-unapplied version 1.9.3.0-1ubuntu2.10 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 6c8f80fb6950099c01e61a623ab0bea26736a1fc

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

ubuntu/precise-devel 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-unapplied version 1.9.3.0-1ubuntu2.10 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2014-11-19 20:31:09 UTC

Import patches-unapplied version 1.9.3.0-1ubuntu2.10 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 6c8f80fb6950099c01e61a623ab0bea26736a1fc

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

ubuntu/precise-security 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-unapplied version 1.9.3.0-1ubuntu2.10 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2014-11-19 20:31:09 UTC

Import patches-unapplied version 1.9.3.0-1ubuntu2.10 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 6c8f80fb6950099c01e61a623ab0bea26736a1fc

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

applied/ubuntu/precise-devel 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-applied version 1.9.3.0-1ubuntu2.10 to applied/ubuntu/precise-...

Author: Marc Deslauriers
Author Date: 2014-11-19 20:31:09 UTC

Import patches-applied version 1.9.3.0-1ubuntu2.10 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 5c94908df9aa84699eca3ce4452f53fe7a5a5038
Unapplied parent: f09e4d0703e4a9d2d6d95ac24cc40056b4bbfa31

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

applied/ubuntu/precise-updates 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-applied version 1.9.3.0-1ubuntu2.10 to applied/ubuntu/precise-...

Author: Marc Deslauriers
Author Date: 2014-11-19 20:31:09 UTC

Import patches-applied version 1.9.3.0-1ubuntu2.10 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 5c94908df9aa84699eca3ce4452f53fe7a5a5038
Unapplied parent: f09e4d0703e4a9d2d6d95ac24cc40056b4bbfa31

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

debian/squeeze 2014-07-19 17:07:26 UTC 2014-07-19
Import patches-unapplied version 1.9.2.0-2+deb6u2 to debian/squeeze

Author: Antonio Terceiro
Author Date: 2013-12-01 22:47:31 UTC

Import patches-unapplied version 1.9.2.0-2+deb6u2 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: cf839214feb19e4e76a750921d3ffbaa2387b7aa

New changelog entries:
  [ Raphaël Hertzog ]
  * debian/patches/CVE-2013-4164.patch: add upstream patch to fix heap
    overflow in floating point parsing. Closes: #730178
  * Team upload
  * CVE-2013-1821
    debian/patches/CVE-2013-1821.patch: fix Entity expansion DoS vulnerability
    in REXML (Closes: #702525)
  * CVE-2013-4073
    debian/patches/CVE-2013-4073.patch: fix hostname checking bypassing
    vulnerabability in SSL client. Patch prepared by Salvatore Bonaccorso,
    thanks (Closes: #714543)

applied/debian/squeeze 2014-07-19 17:07:26 UTC 2014-07-19
Import patches-applied version 1.9.2.0-2+deb6u2 to applied/debian/squeeze

Author: Antonio Terceiro
Author Date: 2013-12-01 22:47:31 UTC

Import patches-applied version 1.9.2.0-2+deb6u2 to applied/debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 8fbd94ff06abf194a44eacd710c7279eb555e43a
Unapplied parent: bcd53c39b72a9c0847b90242f6aebb29eeeb55d6

New changelog entries:
  [ Raphaël Hertzog ]
  * debian/patches/CVE-2013-4164.patch: add upstream patch to fix heap
    overflow in floating point parsing. Closes: #730178
  * Team upload
  * CVE-2013-1821
    debian/patches/CVE-2013-1821.patch: fix Entity expansion DoS vulnerability
    in REXML (Closes: #702525)
  * CVE-2013-4073
    debian/patches/CVE-2013-4073.patch: fix hostname checking bypassing
    vulnerabability in SSL client. Patch prepared by Salvatore Bonaccorso,
    thanks (Closes: #714543)

applied/ubuntu/vivid 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-pr...

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 406bf9897ebb4415758e6f6783b22e241a4148ef
Unapplied parent: de68f2c63799676155a58561913d8610074f950f

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

applied/ubuntu/wily 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-pr...

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 406bf9897ebb4415758e6f6783b22e241a4148ef
Unapplied parent: de68f2c63799676155a58561913d8610074f950f

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

applied/ubuntu/wily-devel 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-pr...

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 406bf9897ebb4415758e6f6783b22e241a4148ef
Unapplied parent: de68f2c63799676155a58561913d8610074f950f

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/utopic-proposed 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ab5ecd301a0e1200134ed54516ce5a15f40ea865

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/utopic-devel 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ab5ecd301a0e1200134ed54516ce5a15f40ea865

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/utopic 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ab5ecd301a0e1200134ed54516ce5a15f40ea865

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/devel 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ab5ecd301a0e1200134ed54516ce5a15f40ea865

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/wily 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ab5ecd301a0e1200134ed54516ce5a15f40ea865

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/vivid-devel 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ab5ecd301a0e1200134ed54516ce5a15f40ea865

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/vivid 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ab5ecd301a0e1200134ed54516ce5a15f40ea865

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

applied/ubuntu/utopic 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-pr...

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 406bf9897ebb4415758e6f6783b22e241a4148ef
Unapplied parent: de68f2c63799676155a58561913d8610074f950f

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

applied/ubuntu/utopic-devel 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-pr...

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 406bf9897ebb4415758e6f6783b22e241a4148ef
Unapplied parent: de68f2c63799676155a58561913d8610074f950f

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

applied/ubuntu/utopic-proposed 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-pr...

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 406bf9897ebb4415758e6f6783b22e241a4148ef
Unapplied parent: de68f2c63799676155a58561913d8610074f950f

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

applied/ubuntu/vivid-devel 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-pr...

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 406bf9897ebb4415758e6f6783b22e241a4148ef
Unapplied parent: de68f2c63799676155a58561913d8610074f950f

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

applied/ubuntu/devel 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-pr...

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-applied version 1.9.3.484-2ubuntu2 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 406bf9897ebb4415758e6f6783b22e241a4148ef
Unapplied parent: de68f2c63799676155a58561913d8610074f950f

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/wily-devel 2014-04-29 17:18:32 UTC 2014-04-29
Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Author: Matthias Klose
Author Date: 2014-04-29 16:45:45 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: ab5ecd301a0e1200134ed54516ce5a15f40ea865

New changelog entries:
  * Stop building the libtcltk-ruby1.9.1 package.

ubuntu/trusty-proposed 2014-02-15 03:18:24 UTC 2014-02-15
Import patches-unapplied version 1.9.3.484-2ubuntu1 to ubuntu/trusty-proposed

Author: Adam Conrad
Author Date: 2014-02-15 02:48:22 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 2739a9b3e30105902795f75dafbf6345ef489b81

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.
    - debian/patches/20131218-stack-size.patch: Increase thread stack
      size on 64-bit platforms to prevent testsuite failure on ppc64el.
    - Build-depend on Tcl/Tk 8.5, ruby is not yet ready for Tcl/Tk 8.6.

applied/ubuntu/trusty-proposed 2014-02-15 03:18:24 UTC 2014-02-15
Import patches-applied version 1.9.3.484-2ubuntu1 to applied/ubuntu/trusty-pr...

Author: Adam Conrad
Author Date: 2014-02-15 02:48:22 UTC

Import patches-applied version 1.9.3.484-2ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 071e974429050498805c1380d5044102426f0e63
Unapplied parent: 27e64a4004a7c32702358fdb6f8a3e396a5d735e

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.
    - debian/patches/20131218-stack-size.patch: Increase thread stack
      size on 64-bit platforms to prevent testsuite failure on ppc64el.
    - Build-depend on Tcl/Tk 8.5, ruby is not yet ready for Tcl/Tk 8.6.

ubuntu/trusty 2014-02-15 03:18:24 UTC 2014-02-15
Import patches-unapplied version 1.9.3.484-2ubuntu1 to ubuntu/trusty-proposed

Author: Adam Conrad
Author Date: 2014-02-15 02:48:22 UTC

Import patches-unapplied version 1.9.3.484-2ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 2739a9b3e30105902795f75dafbf6345ef489b81

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.
    - debian/patches/20131218-stack-size.patch: Increase thread stack
      size on 64-bit platforms to prevent testsuite failure on ppc64el.
    - Build-depend on Tcl/Tk 8.5, ruby is not yet ready for Tcl/Tk 8.6.

applied/ubuntu/trusty 2014-02-15 03:18:24 UTC 2014-02-15
Import patches-applied version 1.9.3.484-2ubuntu1 to applied/ubuntu/trusty-pr...

Author: Adam Conrad
Author Date: 2014-02-15 02:48:22 UTC

Import patches-applied version 1.9.3.484-2ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 071e974429050498805c1380d5044102426f0e63
Unapplied parent: 27e64a4004a7c32702358fdb6f8a3e396a5d735e

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.
    - debian/patches/20131218-stack-size.patch: Increase thread stack
      size on 64-bit platforms to prevent testsuite failure on ppc64el.
    - Build-depend on Tcl/Tk 8.5, ruby is not yet ready for Tcl/Tk 8.6.

debian/sid 2014-02-03 22:18:43 UTC 2014-02-03
Import patches-unapplied version 1.9.3.484-2 to debian/sid

Author: Antonio Terceiro
Author Date: 2014-02-01 23:40:01 UTC

Import patches-unapplied version 1.9.3.484-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 67c978a9df3bd46d84714dc636a4e3cd2f99f64c

New changelog entries:
  * new strategy for Ruby version transitions:
    - ruby1.9.1 depends on ruby
    - libruby1.9.1 depends on ruby1.9.1
  * Drop alternatives entries.

applied/debian/jessie 2014-02-03 22:18:43 UTC 2014-02-03
Import patches-applied version 1.9.3.484-2 to applied/debian/sid

Author: Antonio Terceiro
Author Date: 2014-02-01 23:40:01 UTC

Import patches-applied version 1.9.3.484-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 766fd24a6e8f3b0e49a2fa5b74891ffd32c49569
Unapplied parent: b13bf8b26d9bb7ac9911909987e6a1fd270ffa34

New changelog entries:
  * new strategy for Ruby version transitions:
    - ruby1.9.1 depends on ruby
    - libruby1.9.1 depends on ruby1.9.1
  * Drop alternatives entries.

debian/jessie 2014-02-03 22:18:43 UTC 2014-02-03
Import patches-unapplied version 1.9.3.484-2 to debian/sid

Author: Antonio Terceiro
Author Date: 2014-02-01 23:40:01 UTC

Import patches-unapplied version 1.9.3.484-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 67c978a9df3bd46d84714dc636a4e3cd2f99f64c

New changelog entries:
  * new strategy for Ruby version transitions:
    - ruby1.9.1 depends on ruby
    - libruby1.9.1 depends on ruby1.9.1
  * Drop alternatives entries.

applied/debian/sid 2014-02-03 22:18:43 UTC 2014-02-03
Import patches-applied version 1.9.3.484-2 to applied/debian/sid

Author: Antonio Terceiro
Author Date: 2014-02-01 23:40:01 UTC

Import patches-applied version 1.9.3.484-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 766fd24a6e8f3b0e49a2fa5b74891ffd32c49569
Unapplied parent: b13bf8b26d9bb7ac9911909987e6a1fd270ffa34

New changelog entries:
  * new strategy for Ruby version transitions:
    - ruby1.9.1 depends on ruby
    - libruby1.9.1 depends on ruby1.9.1
  * Drop alternatives entries.

ubuntu/saucy-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-8.1ubuntu2.1 to ubuntu/saucy-security

Author: Marc Deslauriers
Author Date: 2013-11-26 16:33:50 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu2.1 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 7651fc99d9e84819cdf6c2f1e208c2974adeb39d

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/quantal-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-1ubuntu1.6 to applied/ubuntu/quantal...

Author: Marc Deslauriers
Author Date: 2013-11-26 17:53:19 UTC

Import patches-applied version 1.9.3.194-1ubuntu1.6 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 441caf6fc6890edf285ba525ca023110441ce826
Unapplied parent: 439bd5d036a6c7d742365e8be13e8471504982a5

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/quantal-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-1ubuntu1.6 to applied/ubuntu/quantal...

Author: Marc Deslauriers
Author Date: 2013-11-26 17:53:19 UTC

Import patches-applied version 1.9.3.194-1ubuntu1.6 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 441caf6fc6890edf285ba525ca023110441ce826
Unapplied parent: 439bd5d036a6c7d742365e8be13e8471504982a5

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/quantal-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-1ubuntu1.6 to applied/ubuntu/quantal...

Author: Marc Deslauriers
Author Date: 2013-11-26 17:53:19 UTC

Import patches-applied version 1.9.3.194-1ubuntu1.6 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 441caf6fc6890edf285ba525ca023110441ce826
Unapplied parent: 439bd5d036a6c7d742365e8be13e8471504982a5

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/raring-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-8.1ubuntu1.2 to applied/ubuntu/rarin...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:36:50 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu1.2 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: f2c7f51b00875546d6919c6ff684767ee64cb608
Unapplied parent: 0f264ee01d167ffa09e05d6c36d21db8ada2eedb

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/raring-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-8.1ubuntu1.2 to applied/ubuntu/rarin...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:36:50 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu1.2 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: f2c7f51b00875546d6919c6ff684767ee64cb608
Unapplied parent: 0f264ee01d167ffa09e05d6c36d21db8ada2eedb

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/raring-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-8.1ubuntu1.2 to applied/ubuntu/rarin...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:36:50 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu1.2 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: f2c7f51b00875546d6919c6ff684767ee64cb608
Unapplied parent: 0f264ee01d167ffa09e05d6c36d21db8ada2eedb

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/saucy-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-8.1ubuntu2.1 to applied/ubuntu/saucy...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:33:50 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu2.1 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: cfb793324cffe401c287e8dfac0cff7c1d69c6e8
Unapplied parent: 51175823030348e51db18496d8c2296e777fde91

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/saucy-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-8.1ubuntu2.1 to applied/ubuntu/saucy...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:33:50 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu2.1 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: cfb793324cffe401c287e8dfac0cff7c1d69c6e8
Unapplied parent: 51175823030348e51db18496d8c2296e777fde91

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

applied/ubuntu/saucy-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.9.3.194-8.1ubuntu2.1 to applied/ubuntu/saucy...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:33:50 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu2.1 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: cfb793324cffe401c287e8dfac0cff7c1d69c6e8
Unapplied parent: 51175823030348e51db18496d8c2296e777fde91

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/quantal-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-1ubuntu1.6 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-11-26 17:53:19 UTC

Import patches-unapplied version 1.9.3.194-1ubuntu1.6 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 6c3b3a77ab3b1a497f6a690656a1b645f671ce8f

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/quantal-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-1ubuntu1.6 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-11-26 17:53:19 UTC

Import patches-unapplied version 1.9.3.194-1ubuntu1.6 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 6c3b3a77ab3b1a497f6a690656a1b645f671ce8f

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/quantal-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-1ubuntu1.6 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-11-26 17:53:19 UTC

Import patches-unapplied version 1.9.3.194-1ubuntu1.6 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 6c3b3a77ab3b1a497f6a690656a1b645f671ce8f

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/raring-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-8.1ubuntu1.2 to ubuntu/raring-secu...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:36:50 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu1.2 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: b485a6d99408e03eb3e5dafd95895edbabe3dc98

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/raring-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-8.1ubuntu1.2 to ubuntu/raring-secu...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:36:50 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu1.2 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: b485a6d99408e03eb3e5dafd95895edbabe3dc98

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/raring-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-8.1ubuntu1.2 to ubuntu/raring-secu...

Author: Marc Deslauriers
Author Date: 2013-11-26 16:36:50 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu1.2 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: b485a6d99408e03eb3e5dafd95895edbabe3dc98

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/saucy-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-8.1ubuntu2.1 to ubuntu/saucy-security

Author: Marc Deslauriers
Author Date: 2013-11-26 16:33:50 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu2.1 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 7651fc99d9e84819cdf6c2f1e208c2974adeb39d

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/saucy-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.9.3.194-8.1ubuntu2.1 to ubuntu/saucy-security

Author: Marc Deslauriers
Author Date: 2013-11-26 16:33:50 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu2.1 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 7651fc99d9e84819cdf6c2f1e208c2974adeb39d

New changelog entries:
  * SECURITY UPDATE: safe level restriction bypass via DL and Fiddle
    - debian/patches/CVE-2013-2065.patch: perform taint checking in
      ext/dl/lib/dl/func.rb, ext/fiddle/function.c.
    - CVE-2013-2065
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c, added
      test to test/ruby/test_float.rb.
    - CVE-2013-4164

ubuntu/saucy 2013-07-08 17:53:13 UTC 2013-07-08
Import patches-unapplied version 1.9.3.194-8.1ubuntu2 to ubuntu/saucy-proposed

Author: Marc Deslauriers
Author Date: 2013-07-08 17:00:47 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: bbcff081ae1c098142bb9e22a95f580e534eac16

New changelog entries:
  * SECURITY UPDATE: incorrect ssl hostname verification
    - debian/patches/CVE-2013-4073.patch: fix hostname check and regression
      in ext/openssl/lib/openssl/ssl-internal.rb, added test to
      test/openssl/test_ssl.rb.
    - CVE-2013-4073

applied/ubuntu/saucy 2013-07-08 17:53:13 UTC 2013-07-08
Import patches-applied version 1.9.3.194-8.1ubuntu2 to applied/ubuntu/saucy-p...

Author: Marc Deslauriers
Author Date: 2013-07-08 17:00:47 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 96d587689d0941d4dbbe1a55cf243cd6b956dbab
Unapplied parent: 92fe63fc2e20f3dfb03244fbcad07ba4ac6fd4a5

New changelog entries:
  * SECURITY UPDATE: incorrect ssl hostname verification
    - debian/patches/CVE-2013-4073.patch: fix hostname check and regression
      in ext/openssl/lib/openssl/ssl-internal.rb, added test to
      test/openssl/test_ssl.rb.
    - CVE-2013-4073

applied/ubuntu/saucy-proposed 2013-07-08 17:53:13 UTC 2013-07-08
Import patches-applied version 1.9.3.194-8.1ubuntu2 to applied/ubuntu/saucy-p...

Author: Marc Deslauriers
Author Date: 2013-07-08 17:00:47 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 96d587689d0941d4dbbe1a55cf243cd6b956dbab
Unapplied parent: 92fe63fc2e20f3dfb03244fbcad07ba4ac6fd4a5

New changelog entries:
  * SECURITY UPDATE: incorrect ssl hostname verification
    - debian/patches/CVE-2013-4073.patch: fix hostname check and regression
      in ext/openssl/lib/openssl/ssl-internal.rb, added test to
      test/openssl/test_ssl.rb.
    - CVE-2013-4073

ubuntu/saucy-proposed 2013-07-08 17:53:13 UTC 2013-07-08
Import patches-unapplied version 1.9.3.194-8.1ubuntu2 to ubuntu/saucy-proposed

Author: Marc Deslauriers
Author Date: 2013-07-08 17:00:47 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: bbcff081ae1c098142bb9e22a95f580e534eac16

New changelog entries:
  * SECURITY UPDATE: incorrect ssl hostname verification
    - debian/patches/CVE-2013-4073.patch: fix hostname check and regression
      in ext/openssl/lib/openssl/ssl-internal.rb, added test to
      test/openssl/test_ssl.rb.
    - CVE-2013-4073

ubuntu/raring 2013-03-25 19:06:10 UTC 2013-03-25
Import patches-unapplied version 1.9.3.194-8.1ubuntu1 to ubuntu/raring-proposed

Author: Marc Deslauriers
Author Date: 2013-03-25 14:33:34 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: ae9b549f3bee13d2119112dffa5eb8044ced0708

New changelog entries:
  * Merge from Debian testing. Remaining changes:
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.
    - debian/patches/CVE-2012-4522.patch: Adjust patch to fix build test
      error. Use the version of the fix from upstream's 1.9.3 tree to fix
      the NoMethodError for assert_file_not, which doesn't exist in 1.9.3.
      Adjust the Origin patch tag accordingly.

applied/ubuntu/raring-proposed 2013-03-25 19:06:10 UTC 2013-03-25
Import patches-applied version 1.9.3.194-8.1ubuntu1 to applied/ubuntu/raring-...

Author: Marc Deslauriers
Author Date: 2013-03-25 14:33:34 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu1 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 67eb8f5d095bcf6cb28ee3722c08ae2e1564261a
Unapplied parent: ede7d064475f470f07bf7e93a6b228f71a815997

New changelog entries:
  * Merge from Debian testing. Remaining changes:
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.
    - debian/patches/CVE-2012-4522.patch: Adjust patch to fix build test
      error. Use the version of the fix from upstream's 1.9.3 tree to fix
      the NoMethodError for assert_file_not, which doesn't exist in 1.9.3.
      Adjust the Origin patch tag accordingly.

applied/ubuntu/raring 2013-03-25 19:06:10 UTC 2013-03-25
Import patches-applied version 1.9.3.194-8.1ubuntu1 to applied/ubuntu/raring-...

Author: Marc Deslauriers
Author Date: 2013-03-25 14:33:34 UTC

Import patches-applied version 1.9.3.194-8.1ubuntu1 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 67eb8f5d095bcf6cb28ee3722c08ae2e1564261a
Unapplied parent: ede7d064475f470f07bf7e93a6b228f71a815997

New changelog entries:
  * Merge from Debian testing. Remaining changes:
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.
    - debian/patches/CVE-2012-4522.patch: Adjust patch to fix build test
      error. Use the version of the fix from upstream's 1.9.3 tree to fix
      the NoMethodError for assert_file_not, which doesn't exist in 1.9.3.
      Adjust the Origin patch tag accordingly.

ubuntu/raring-proposed 2013-03-25 19:06:10 UTC 2013-03-25
Import patches-unapplied version 1.9.3.194-8.1ubuntu1 to ubuntu/raring-proposed

Author: Marc Deslauriers
Author Date: 2013-03-25 14:33:34 UTC

Import patches-unapplied version 1.9.3.194-8.1ubuntu1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: ae9b549f3bee13d2119112dffa5eb8044ced0708

New changelog entries:
  * Merge from Debian testing. Remaining changes:
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.
    - debian/patches/CVE-2012-4522.patch: Adjust patch to fix build test
      error. Use the version of the fix from upstream's 1.9.3 tree to fix
      the NoMethodError for assert_file_not, which doesn't exist in 1.9.3.
      Adjust the Origin patch tag accordingly.

applied/ubuntu/quantal 2012-09-28 18:33:47 UTC 2012-09-28
Import patches-applied version 1.9.3.194-1ubuntu1 to applied/ubuntu/quantal

Author: Tyler Hicks
Author Date: 2012-09-28 03:37:54 UTC

Import patches-applied version 1.9.3.194-1ubuntu1 to applied/ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 1607c216d030d131a3124da65225ef5d66e0e89f
Unapplied parent: fb40e4d77c86d7e061c4eb6b76909ec3babca61d

New changelog entries:
  * SECURITY UPDATE: Safe level bypass
    - debian/patches/20120927-cve_2011_1005.patch: Remove incorrect string
      taint in exception handling methods. Based on upstream patch.
    - CVE-2011-1005
  * Make the RubyGems fetcher use distro-provided ca-certificates
    (LP: #1057926)
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.

ubuntu/quantal 2012-09-28 18:33:47 UTC 2012-09-28
Import patches-unapplied version 1.9.3.194-1ubuntu1 to ubuntu/quantal

Author: Tyler Hicks
Author Date: 2012-09-28 03:37:54 UTC

Import patches-unapplied version 1.9.3.194-1ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 37a420cd6e0e7e0b90da9f9742fe808fcb51940f

New changelog entries:
  * SECURITY UPDATE: Safe level bypass
    - debian/patches/20120927-cve_2011_1005.patch: Remove incorrect string
      taint in exception handling methods. Based on upstream patch.
    - CVE-2011-1005
  * Make the RubyGems fetcher use distro-provided ca-certificates
    (LP: #1057926)
    - debian/control: Add ca-certificates to libruby1.9.1 depends so that
      rubygems can perform certificate verification
    - debian/rules: Don't install SSL certificates from upstream sources
    - debian/patches/20120927-rubygems_disable_upstream_certs.patch: Use
      /etc/ssl/certs/ca-certificates.crt for the trusted CA certificates.

applied/ubuntu/precise-proposed 2012-07-06 07:33:37 UTC 2012-07-06
Import patches-applied version 1.9.3.0-1ubuntu2 to applied/ubuntu/precise-pro...

Author: Adam Conrad
Author Date: 2012-07-06 06:42:46 UTC

Import patches-applied version 1.9.3.0-1ubuntu2 to applied/ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: b41c7ffdd914a0d1f9ab4ea475f77f6103abbd91
Unapplied parent: 5d83e706007bd80521a2822635659cadf906ccad

New changelog entries:
  * Revert the previous upload, re-enabling the testsuite on ARM,
    which should now work as we're rebuilding against a version
    of eglibc with a working getcontext/setcontext (LP: #1021604)

ubuntu/precise-proposed 2012-07-06 07:33:37 UTC 2012-07-06
Import patches-unapplied version 1.9.3.0-1ubuntu2 to ubuntu/precise-proposed

Author: Adam Conrad
Author Date: 2012-07-06 06:42:46 UTC

Import patches-unapplied version 1.9.3.0-1ubuntu2 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: a33d6701f6c2e5467f2165b712262306f89fc171

New changelog entries:
  * Revert the previous upload, re-enabling the testsuite on ARM,
    which should now work as we're rebuilding against a version
    of eglibc with a working getcontext/setcontext (LP: #1021604)

applied/ubuntu/precise 2011-12-03 03:07:35 UTC 2011-12-03
Import patches-applied version 1.9.3.0-1ubuntu1 to applied/ubuntu/precise

Author: Matthias Klose
Author Date: 2011-12-03 02:07:55 UTC

Import patches-applied version 1.9.3.0-1ubuntu1 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: a44359714b6d4ccf04685714f93781a8773ea1c2
Unapplied parent: 8d9c4c5e0675b73da8800023f4dea4e2c07e9d8d

New changelog entries:
  * Don't run the tests on armhf for a first build.

ubuntu/precise 2011-12-03 03:07:35 UTC 2011-12-03
Import patches-unapplied version 1.9.3.0-1ubuntu1 to ubuntu/precise

Author: Matthias Klose
Author Date: 2011-12-03 02:07:55 UTC

Import patches-unapplied version 1.9.3.0-1ubuntu1 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 8bd5a5949c7fc399c2bdabb764b939bf9ddc9016

New changelog entries:
  * Don't run the tests on armhf for a first build.

applied/debian/experimental 2011-10-09 21:31:42 UTC 2011-10-09
Import patches-applied version 1.9.3~rc1-3 to applied/debian/experimental

Author: Lucas Nussbaum
Author Date: 2011-10-09 09:09:13 UTC

Import patches-applied version 1.9.3~rc1-3 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: f045ddbad0f55464c66cdafe0161472dbede9ed5
Unapplied parent: 2a021c30224d53e4509db61069d51e47300fe8c1

New changelog entries:
  * Update symbols file to fix FTBFS on i386, mips, mipsel, powerpc, s390.
    Closes: #644705.

debian/experimental 2011-10-09 21:31:42 UTC 2011-10-09
Import patches-unapplied version 1.9.3~rc1-3 to debian/experimental

Author: Lucas Nussbaum
Author Date: 2011-10-09 09:09:13 UTC

Import patches-unapplied version 1.9.3~rc1-3 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: d8229df2f3041aa93061887b9c518b8d3451be82

New changelog entries:
  * Update symbols file to fix FTBFS on i386, mips, mipsel, powerpc, s390.
    Closes: #644705.

applied/ubuntu/oneiric-devel 2011-07-26 13:23:12 UTC 2011-07-26
Import patches-applied version 1.9.2.290-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2011-07-26 13:23:12 UTC

Import patches-applied version 1.9.2.290-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c3650db299bff6a9b85f3276b412ce16ede170d9
Unapplied parent: 524da69532547b82819793663df738725e127e50

New changelog entries:
  * Add -fno-tree-sra on armel. Same workaround as for ruby1.8 (see #634260)

ubuntu/oneiric 2011-07-26 13:23:12 UTC 2011-07-26
Import patches-unapplied version 1.9.2.290-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2011-07-26 13:23:12 UTC

Import patches-unapplied version 1.9.2.290-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5b4df01aa7f05b52dec22be4fb89f70a6e89b023

New changelog entries:
  * Add -fno-tree-sra on armel. Same workaround as for ruby1.8 (see #634260)

applied/ubuntu/oneiric 2011-07-26 13:23:12 UTC 2011-07-26
Import patches-applied version 1.9.2.290-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2011-07-26 13:23:12 UTC

Import patches-applied version 1.9.2.290-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c3650db299bff6a9b85f3276b412ce16ede170d9
Unapplied parent: 524da69532547b82819793663df738725e127e50

New changelog entries:
  * Add -fno-tree-sra on armel. Same workaround as for ruby1.8 (see #634260)

ubuntu/oneiric-devel 2011-07-26 13:23:12 UTC 2011-07-26
Import patches-unapplied version 1.9.2.290-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2011-07-26 13:23:12 UTC

Import patches-unapplied version 1.9.2.290-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5b4df01aa7f05b52dec22be4fb89f70a6e89b023

New changelog entries:
  * Add -fno-tree-sra on armel. Same workaround as for ruby1.8 (see #634260)

ubuntu/natty-devel 2010-11-01 21:20:46 UTC 2010-11-01
Import patches-unapplied version 1.9.2.0-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2010-11-01 08:03:33 UTC

Import patches-unapplied version 1.9.2.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9adb273fbf02e3d7ee1c5f7c0ad3c804fe5bf134

New changelog entries:
  * Clarify versioning in package description to reduce 1.9.1 <-> 1.9.2
    confusion. Closes: #601526.
  * Remove README.Debian. It only contained outdated information.
  * Build with -mieee on SH4. Closes: #591785.
  * Update debian/NEWS to mention LOAD_PATH change. Closes: #593098.
  * ruby1.9.1: add Suggests on ruby1.9.1-dev as it is need to build
    many gems, and that's a FAQ.
  * ruby1.9.1-dev: mention building gems in package description.

applied/ubuntu/natty 2010-11-01 21:20:46 UTC 2010-11-01
Import patches-applied version 1.9.2.0-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2010-11-01 08:03:33 UTC

Import patches-applied version 1.9.2.0-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c25e350a310173847c6f83d91a0818395ee955a
Unapplied parent: 77c722058f45f904ae3882e7e1fbfdc2a348be26

New changelog entries:
  * Clarify versioning in package description to reduce 1.9.1 <-> 1.9.2
    confusion. Closes: #601526.
  * Remove README.Debian. It only contained outdated information.
  * Build with -mieee on SH4. Closes: #591785.
  * Update debian/NEWS to mention LOAD_PATH change. Closes: #593098.
  * ruby1.9.1: add Suggests on ruby1.9.1-dev as it is need to build
    many gems, and that's a FAQ.
  * ruby1.9.1-dev: mention building gems in package description.

applied/ubuntu/natty-devel 2010-11-01 21:20:46 UTC 2010-11-01
Import patches-applied version 1.9.2.0-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2010-11-01 08:03:33 UTC

Import patches-applied version 1.9.2.0-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c25e350a310173847c6f83d91a0818395ee955a
Unapplied parent: 77c722058f45f904ae3882e7e1fbfdc2a348be26

New changelog entries:
  * Clarify versioning in package description to reduce 1.9.1 <-> 1.9.2
    confusion. Closes: #601526.
  * Remove README.Debian. It only contained outdated information.
  * Build with -mieee on SH4. Closes: #591785.
  * Update debian/NEWS to mention LOAD_PATH change. Closes: #593098.
  * ruby1.9.1: add Suggests on ruby1.9.1-dev as it is need to build
    many gems, and that's a FAQ.
  * ruby1.9.1-dev: mention building gems in package description.

ubuntu/natty 2010-11-01 21:20:46 UTC 2010-11-01
Import patches-unapplied version 1.9.2.0-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2010-11-01 08:03:33 UTC

Import patches-unapplied version 1.9.2.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9adb273fbf02e3d7ee1c5f7c0ad3c804fe5bf134

New changelog entries:
  * Clarify versioning in package description to reduce 1.9.1 <-> 1.9.2
    confusion. Closes: #601526.
  * Remove README.Debian. It only contained outdated information.
  * Build with -mieee on SH4. Closes: #591785.
  * Update debian/NEWS to mention LOAD_PATH change. Closes: #593098.
  * ruby1.9.1: add Suggests on ruby1.9.1-dev as it is need to build
    many gems, and that's a FAQ.
  * ruby1.9.1-dev: mention building gems in package description.

ubuntu/maverick-devel 2010-09-14 09:36:42 UTC 2010-09-14
Import patches-unapplied version 1.9.2.0-1 to debian/sid

Author: Lucas Nussbaum
Author Date: 2010-09-11 06:38:44 UTC

Import patches-unapplied version 1.9.2.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 64a53d606cd6983d7165206c442e271a4d4bc6ff

New changelog entries:
  [ Lucas Nussbaum ]
  * New upstream release. The 1.9.2 branch was in deep freeze at the time of
    the last snapshot, and all the changes between that snapshot and the
    present final tarball are bugfixes, as shown by
    svn log -r28788:HEAD http://svn.ruby-lang.org/repos/ruby/branches/ruby_1_9_2
    Also, it sounds much easier to support a released version on the long
    term, rather than an SVN snapshot.
    Also fixes CVE-2010-0541. Closes: #593298.
    Could also improve kFreeBSD support as some changes are FreeBSD-related.
  * Add build-dependency on libyaml-dev to build psych, which is a new, faster
    YAML library provided in Ruby 1.9.2.
  [ Daigo Moriwaki ]
  * debian/watch: support new URL for Ruby 1.9.2.
  * debian/rules: DEB_BUILD_OPTIONS="nordoc" provides no-doc build for
    build testing.
  * Merged rubygems1.9.1: this package used to be provided by the libgems-ruby
    source package, but the version of rubygems provided by libgems-ruby is
    incompatible with Ruby 1.9.2. Also, Rubygems is shipped as part of Ruby.
    Closes: #588125
  [ Lucas Nussbaum ]
  * Provide a way to override Debian's disabling of gem update --system by
    setting an environment variable. This is the same change as the one done
    for libgems-ruby.

applied/ubuntu/maverick-devel 2010-09-14 09:36:42 UTC 2010-09-14
Import patches-applied version 1.9.2.0-1 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2010-09-11 06:38:44 UTC

Import patches-applied version 1.9.2.0-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7bfaaa3474d0efe0a39afc5620314e3525d3bd76
Unapplied parent: d06429f898dbd0c42d0d017b958b5baa5fd81d24

New changelog entries:
  [ Lucas Nussbaum ]
  * New upstream release. The 1.9.2 branch was in deep freeze at the time of
    the last snapshot, and all the changes between that snapshot and the
    present final tarball are bugfixes, as shown by
    svn log -r28788:HEAD http://svn.ruby-lang.org/repos/ruby/branches/ruby_1_9_2
    Also, it sounds much easier to support a released version on the long
    term, rather than an SVN snapshot.
    Also fixes CVE-2010-0541. Closes: #593298.
    Could also improve kFreeBSD support as some changes are FreeBSD-related.
  * Add build-dependency on libyaml-dev to build psych, which is a new, faster
    YAML library provided in Ruby 1.9.2.
  [ Daigo Moriwaki ]
  * debian/watch: support new URL for Ruby 1.9.2.
  * debian/rules: DEB_BUILD_OPTIONS="nordoc" provides no-doc build for
    build testing.
  * Merged rubygems1.9.1: this package used to be provided by the libgems-ruby
    source package, but the version of rubygems provided by libgems-ruby is
    incompatible with Ruby 1.9.2. Also, Rubygems is shipped as part of Ruby.
    Closes: #588125
  [ Lucas Nussbaum ]
  * Provide a way to override Debian's disabling of gem update --system by
    setting an environment variable. This is the same change as the one done
    for libgems-ruby.

applied/ubuntu/maverick 2010-09-14 09:36:42 UTC 2010-09-14
Import patches-applied version 1.9.2.0-1 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2010-09-11 06:38:44 UTC

Import patches-applied version 1.9.2.0-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7bfaaa3474d0efe0a39afc5620314e3525d3bd76
Unapplied parent: d06429f898dbd0c42d0d017b958b5baa5fd81d24

New changelog entries:
  [ Lucas Nussbaum ]
  * New upstream release. The 1.9.2 branch was in deep freeze at the time of
    the last snapshot, and all the changes between that snapshot and the
    present final tarball are bugfixes, as shown by
    svn log -r28788:HEAD http://svn.ruby-lang.org/repos/ruby/branches/ruby_1_9_2
    Also, it sounds much easier to support a released version on the long
    term, rather than an SVN snapshot.
    Also fixes CVE-2010-0541. Closes: #593298.
    Could also improve kFreeBSD support as some changes are FreeBSD-related.
  * Add build-dependency on libyaml-dev to build psych, which is a new, faster
    YAML library provided in Ruby 1.9.2.
  [ Daigo Moriwaki ]
  * debian/watch: support new URL for Ruby 1.9.2.
  * debian/rules: DEB_BUILD_OPTIONS="nordoc" provides no-doc build for
    build testing.
  * Merged rubygems1.9.1: this package used to be provided by the libgems-ruby
    source package, but the version of rubygems provided by libgems-ruby is
    incompatible with Ruby 1.9.2. Also, Rubygems is shipped as part of Ruby.
    Closes: #588125
  [ Lucas Nussbaum ]
  * Provide a way to override Debian's disabling of gem update --system by
    setting an environment variable. This is the same change as the one done
    for libgems-ruby.

ubuntu/maverick 2010-09-14 09:36:42 UTC 2010-09-14
Import patches-unapplied version 1.9.2.0-1 to debian/sid

Author: Lucas Nussbaum
Author Date: 2010-09-11 06:38:44 UTC

Import patches-unapplied version 1.9.2.0-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 64a53d606cd6983d7165206c442e271a4d4bc6ff

New changelog entries:
  [ Lucas Nussbaum ]
  * New upstream release. The 1.9.2 branch was in deep freeze at the time of
    the last snapshot, and all the changes between that snapshot and the
    present final tarball are bugfixes, as shown by
    svn log -r28788:HEAD http://svn.ruby-lang.org/repos/ruby/branches/ruby_1_9_2
    Also, it sounds much easier to support a released version on the long
    term, rather than an SVN snapshot.
    Also fixes CVE-2010-0541. Closes: #593298.
    Could also improve kFreeBSD support as some changes are FreeBSD-related.
  * Add build-dependency on libyaml-dev to build psych, which is a new, faster
    YAML library provided in Ruby 1.9.2.
  [ Daigo Moriwaki ]
  * debian/watch: support new URL for Ruby 1.9.2.
  * debian/rules: DEB_BUILD_OPTIONS="nordoc" provides no-doc build for
    build testing.
  * Merged rubygems1.9.1: this package used to be provided by the libgems-ruby
    source package, but the version of rubygems provided by libgems-ruby is
    incompatible with Ruby 1.9.2. Also, Rubygems is shipped as part of Ruby.
    Closes: #588125
  [ Lucas Nussbaum ]
  * Provide a way to override Debian's disabling of gem update --system by
    setting an environment variable. This is the same change as the one done
    for libgems-ruby.

applied/ubuntu/lucid-devel 2010-01-12 21:20:56 UTC 2010-01-12
Import patches-applied version 1.9.1.378-1 to applied/debian/sid

Author: daigo
Author Date: 2010-01-11 00:46:28 UTC

Import patches-applied version 1.9.1.378-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7558691bfa7ba8a78396eb5d864d7644e04bc4e7
Unapplied parent: de80d865af29b1445ee6dbb95c86f735a5d403ed

New changelog entries:
  * New upstream release
  * The upstream has fixed a vulnerability in WEBrick, a part of Ruby's
    standard library. WEBrick lets attackers to inject malicious escape
    sequences to its logs, making it possible for dangerous control characters
    to be executed on a victim's terminal emulator. (Closes: #564646)

ubuntu/lucid 2010-01-12 21:20:56 UTC 2010-01-12
Import patches-unapplied version 1.9.1.378-1 to debian/sid

Author: daigo
Author Date: 2010-01-11 00:46:28 UTC

Import patches-unapplied version 1.9.1.378-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d48713032370e8e85ad6abe65d6dc0107c31f8ed

New changelog entries:
  * New upstream release
  * The upstream has fixed a vulnerability in WEBrick, a part of Ruby's
    standard library. WEBrick lets attackers to inject malicious escape
    sequences to its logs, making it possible for dangerous control characters
    to be executed on a victim's terminal emulator. (Closes: #564646)

ubuntu/lucid-devel 2010-01-12 21:20:56 UTC 2010-01-12
Import patches-unapplied version 1.9.1.378-1 to debian/sid

Author: daigo
Author Date: 2010-01-11 00:46:28 UTC

Import patches-unapplied version 1.9.1.378-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d48713032370e8e85ad6abe65d6dc0107c31f8ed

New changelog entries:
  * New upstream release
  * The upstream has fixed a vulnerability in WEBrick, a part of Ruby's
    standard library. WEBrick lets attackers to inject malicious escape
    sequences to its logs, making it possible for dangerous control characters
    to be executed on a victim's terminal emulator. (Closes: #564646)

applied/ubuntu/lucid 2010-01-12 21:20:56 UTC 2010-01-12
Import patches-applied version 1.9.1.378-1 to applied/debian/sid

Author: daigo
Author Date: 2010-01-11 00:46:28 UTC

Import patches-applied version 1.9.1.378-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7558691bfa7ba8a78396eb5d864d7644e04bc4e7
Unapplied parent: de80d865af29b1445ee6dbb95c86f735a5d403ed

New changelog entries:
  * New upstream release
  * The upstream has fixed a vulnerability in WEBrick, a part of Ruby's
    standard library. WEBrick lets attackers to inject malicious escape
    sequences to its logs, making it possible for dangerous control characters
    to be executed on a victim's terminal emulator. (Closes: #564646)

applied/ubuntu/karmic 2009-09-26 01:17:17 UTC 2009-09-26
Import patches-applied version 1.9.1.243-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2009-09-09 19:55:24 UTC

Import patches-applied version 1.9.1.243-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 1305b1c7f679f4260a2230fa1e34e4d4593cf170
Unapplied parent: 411810f69889c7a11f946846892da4487c4cf863

New changelog entries:
  [ Lucas Nussbaum ]
  * Removed Fumitoshi UKAI <ukai@debian.or.jp> from Uploaders. Thanks a
    lot for the past help!
  * Removed obsolete Build-Conflicts: on gcc-3.3 (<< 1:3.3.2-0pre1)
  * Add ${misc:Depends} to Depends of all binary packages.
    Avoids debhelper-but-no-misc-depends lintian warning.
  * Add build-dependency on debhelper >= 5, since that's the compatibility
    level with request in debian/compat.
    Avoids package-lacks-versioned-build-depends-on-debhelper lintian
    warning.
  * Fix menu file for irb1.9.1. Avoids two menu-related lintian warnings.
  * Optimized debian/rmshebang.sh a bit.
  * Removed outdated option from DEB_CONFIGURE_USER_FLAGS:
    --with-default-kcode=none
  * Remove 901_extra_search_path: no longer needed.
  * Use --program-suffix=1.9.1 and hack configure.in so that all the
    paths except the ri path match what was done before.
  * Added debian/README.source. Avoids lintian warning.
  * Added a ruby1.9.1-full meta-package that depends on all the ruby 1.9.1
    binary packages. Closes: #503580.
  * Ignore failures of test suite on FreeBSD.
  * Bumped Standards-Version to 3.8.3. No changes needed.
  * Remove executable mode on all example scripts. (fix lintian warning)
  * Run all tests, not just the ones in ruby/.
  [ akira yamada ]
  * Added debian/patches/090908_regexp_unicode_class.dpatch:
    - \d, \s and \w are now non Unicode class. [ruby-dev:39026]
    - warn duplicated characters in character class. [ruby-core:24593]
    (backported from r24387 and r24544.)

ubuntu/karmic 2009-09-26 01:17:17 UTC 2009-09-26
Import patches-unapplied version 1.9.1.243-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2009-09-09 19:55:24 UTC

Import patches-unapplied version 1.9.1.243-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b67e59ef83f6fa78c2e7870e7853929eef2669ce

New changelog entries:
  [ Lucas Nussbaum ]
  * Removed Fumitoshi UKAI <ukai@debian.or.jp> from Uploaders. Thanks a
    lot for the past help!
  * Removed obsolete Build-Conflicts: on gcc-3.3 (<< 1:3.3.2-0pre1)
  * Add ${misc:Depends} to Depends of all binary packages.
    Avoids debhelper-but-no-misc-depends lintian warning.
  * Add build-dependency on debhelper >= 5, since that's the compatibility
    level with request in debian/compat.
    Avoids package-lacks-versioned-build-depends-on-debhelper lintian
    warning.
  * Fix menu file for irb1.9.1. Avoids two menu-related lintian warnings.
  * Optimized debian/rmshebang.sh a bit.
  * Removed outdated option from DEB_CONFIGURE_USER_FLAGS:
    --with-default-kcode=none
  * Remove 901_extra_search_path: no longer needed.
  * Use --program-suffix=1.9.1 and hack configure.in so that all the
    paths except the ri path match what was done before.
  * Added debian/README.source. Avoids lintian warning.
  * Added a ruby1.9.1-full meta-package that depends on all the ruby 1.9.1
    binary packages. Closes: #503580.
  * Ignore failures of test suite on FreeBSD.
  * Bumped Standards-Version to 3.8.3. No changes needed.
  * Remove executable mode on all example scripts. (fix lintian warning)
  * Run all tests, not just the ones in ruby/.
  [ akira yamada ]
  * Added debian/patches/090908_regexp_unicode_class.dpatch:
    - \d, \s and \w are now non Unicode class. [ruby-dev:39026]
    - warn duplicated characters in character class. [ruby-core:24593]
    (backported from r24387 and r24544.)

ubuntu/karmic-devel 2009-09-26 01:17:17 UTC 2009-09-26
Import patches-unapplied version 1.9.1.243-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2009-09-09 19:55:24 UTC

Import patches-unapplied version 1.9.1.243-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b67e59ef83f6fa78c2e7870e7853929eef2669ce

New changelog entries:
  [ Lucas Nussbaum ]
  * Removed Fumitoshi UKAI <ukai@debian.or.jp> from Uploaders. Thanks a
    lot for the past help!
  * Removed obsolete Build-Conflicts: on gcc-3.3 (<< 1:3.3.2-0pre1)
  * Add ${misc:Depends} to Depends of all binary packages.
    Avoids debhelper-but-no-misc-depends lintian warning.
  * Add build-dependency on debhelper >= 5, since that's the compatibility
    level with request in debian/compat.
    Avoids package-lacks-versioned-build-depends-on-debhelper lintian
    warning.
  * Fix menu file for irb1.9.1. Avoids two menu-related lintian warnings.
  * Optimized debian/rmshebang.sh a bit.
  * Removed outdated option from DEB_CONFIGURE_USER_FLAGS:
    --with-default-kcode=none
  * Remove 901_extra_search_path: no longer needed.
  * Use --program-suffix=1.9.1 and hack configure.in so that all the
    paths except the ri path match what was done before.
  * Added debian/README.source. Avoids lintian warning.
  * Added a ruby1.9.1-full meta-package that depends on all the ruby 1.9.1
    binary packages. Closes: #503580.
  * Ignore failures of test suite on FreeBSD.
  * Bumped Standards-Version to 3.8.3. No changes needed.
  * Remove executable mode on all example scripts. (fix lintian warning)
  * Run all tests, not just the ones in ruby/.
  [ akira yamada ]
  * Added debian/patches/090908_regexp_unicode_class.dpatch:
    - \d, \s and \w are now non Unicode class. [ruby-dev:39026]
    - warn duplicated characters in character class. [ruby-core:24593]
    (backported from r24387 and r24544.)

applied/ubuntu/karmic-devel 2009-09-26 01:17:17 UTC 2009-09-26
Import patches-applied version 1.9.1.243-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2009-09-09 19:55:24 UTC

Import patches-applied version 1.9.1.243-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 1305b1c7f679f4260a2230fa1e34e4d4593cf170
Unapplied parent: 411810f69889c7a11f946846892da4487c4cf863

New changelog entries:
  [ Lucas Nussbaum ]
  * Removed Fumitoshi UKAI <ukai@debian.or.jp> from Uploaders. Thanks a
    lot for the past help!
  * Removed obsolete Build-Conflicts: on gcc-3.3 (<< 1:3.3.2-0pre1)
  * Add ${misc:Depends} to Depends of all binary packages.
    Avoids debhelper-but-no-misc-depends lintian warning.
  * Add build-dependency on debhelper >= 5, since that's the compatibility
    level with request in debian/compat.
    Avoids package-lacks-versioned-build-depends-on-debhelper lintian
    warning.
  * Fix menu file for irb1.9.1. Avoids two menu-related lintian warnings.
  * Optimized debian/rmshebang.sh a bit.
  * Removed outdated option from DEB_CONFIGURE_USER_FLAGS:
    --with-default-kcode=none
  * Remove 901_extra_search_path: no longer needed.
  * Use --program-suffix=1.9.1 and hack configure.in so that all the
    paths except the ri path match what was done before.
  * Added debian/README.source. Avoids lintian warning.
  * Added a ruby1.9.1-full meta-package that depends on all the ruby 1.9.1
    binary packages. Closes: #503580.
  * Ignore failures of test suite on FreeBSD.
  * Bumped Standards-Version to 3.8.3. No changes needed.
  * Remove executable mode on all example scripts. (fix lintian warning)
  * Run all tests, not just the ones in ruby/.
  [ akira yamada ]
  * Added debian/patches/090908_regexp_unicode_class.dpatch:
    - \d, \s and \w are now non Unicode class. [ruby-dev:39026]
    - warn duplicated characters in character class. [ruby-core:24593]
    (backported from r24387 and r24544.)

198 of 98 results

Other repositories

Name Last Modified
lp:ubuntu/+source/ruby1.9.1 2019-04-26
11 of 1 result
You can't create new repositories for ruby1.9.1 in Ubuntu.