View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/ruby1.8
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2018-03-06 08:55:10 UTC 2018-03-06
DSC file for 1.8.7.352-2ubuntu1.6

Author: Ubuntu Git Importer
Author Date: 2018-03-06 08:55:10 UTC

DSC file for 1.8.7.352-2ubuntu1.6

importer/ubuntu/pristine-tar 2018-03-06 08:46:01 UTC 2018-03-06
pristine-tar data for ruby1.8_1.8.7.358.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-06 08:46:01 UTC

pristine-tar data for ruby1.8_1.8.7.358.orig.tar.gz

importer/debian/dsc 2018-03-06 08:03:31 UTC 2018-03-06
DSC file for 1.8.7.358-7.1+deb7u3

Author: Ubuntu Git Importer
Author Date: 2018-03-06 08:03:31 UTC

DSC file for 1.8.7.358-7.1+deb7u3

importer/debian/pristine-tar 2018-03-06 07:59:38 UTC 2018-03-06
pristine-tar data for ruby1.8_1.8.7.358.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-06 07:59:38 UTC

pristine-tar data for ruby1.8_1.8.7.358.orig.tar.gz

applied/debian/wheezy 2015-09-05 17:12:48 UTC 2015-09-05
Import patches-applied version 1.8.7.358-7.1+deb7u3 to applied/debian/wheezy

Author: Alessandro Ghedini
Author Date: 2015-04-27 08:20:23 UTC

Import patches-applied version 1.8.7.358-7.1+deb7u3 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 81765e9c738d3bd976b9d78d970eb96b21b07577
Unapplied parent: f17b61a8e9022bad062f26139a97a637423f9826

New changelog entries:
  * Fix OpenSSL Hostname Verification [CVE-2015-1855]
  * Fix unrestricted entity expansion in the REXML parser as per
    CVE-2014-8080 and CVE-2014-8090
  * Set urgency=high accordingly

debian/wheezy 2015-09-05 17:12:48 UTC 2015-09-05
Import patches-unapplied version 1.8.7.358-7.1+deb7u3 to debian/wheezy

Author: Alessandro Ghedini
Author Date: 2015-04-27 08:20:23 UTC

Import patches-unapplied version 1.8.7.358-7.1+deb7u3 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 0ac4cbee2ee4bcabfa91341e98a0da190f4b8b9e

New changelog entries:
  * Fix OpenSSL Hostname Verification [CVE-2015-1855]
  * Fix unrestricted entity expansion in the REXML parser as per
    CVE-2014-8080 and CVE-2014-8090
  * Set urgency=high accordingly

applied/ubuntu/precise-updates 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-applied version 1.8.7.352-2ubuntu1.6 to applied/ubuntu/precise...

Author: Marc Deslauriers
Author Date: 2014-11-19 20:39:16 UTC

Import patches-applied version 1.8.7.352-2ubuntu1.6 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 7027e64d9e78aa3678ea94320abb1a3341488914
Unapplied parent: 22d86c0095a91ba59560a0f35ba6f3e43e8d0c6a

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

applied/ubuntu/precise-security 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-applied version 1.8.7.352-2ubuntu1.6 to applied/ubuntu/precise...

Author: Marc Deslauriers
Author Date: 2014-11-19 20:39:16 UTC

Import patches-applied version 1.8.7.352-2ubuntu1.6 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 7027e64d9e78aa3678ea94320abb1a3341488914
Unapplied parent: 22d86c0095a91ba59560a0f35ba6f3e43e8d0c6a

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

applied/ubuntu/precise-devel 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-applied version 1.8.7.352-2ubuntu1.6 to applied/ubuntu/precise...

Author: Marc Deslauriers
Author Date: 2014-11-19 20:39:16 UTC

Import patches-applied version 1.8.7.352-2ubuntu1.6 to applied/ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 7027e64d9e78aa3678ea94320abb1a3341488914
Unapplied parent: 22d86c0095a91ba59560a0f35ba6f3e43e8d0c6a

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

ubuntu/precise-devel 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-unapplied version 1.8.7.352-2ubuntu1.6 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2014-11-19 20:39:16 UTC

Import patches-unapplied version 1.8.7.352-2ubuntu1.6 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 700a85fc52e16d1acc0cf585088ef441f75135d4

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

ubuntu/precise-security 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-unapplied version 1.8.7.352-2ubuntu1.6 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2014-11-19 20:39:16 UTC

Import patches-unapplied version 1.8.7.352-2ubuntu1.6 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 700a85fc52e16d1acc0cf585088ef441f75135d4

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

ubuntu/precise-updates 2014-11-20 16:28:34 UTC 2014-11-20
Import patches-unapplied version 1.8.7.352-2ubuntu1.6 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2014-11-19 20:39:16 UTC

Import patches-unapplied version 1.8.7.352-2ubuntu1.6 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 700a85fc52e16d1acc0cf585088ef441f75135d4

New changelog entries:
  * SECURITY UPDATE: denial of service via XML expansion
    - debian/patches/CVE-2014-8090.patch: add REXML::Document#document
      to lib/rexml/document.rb, add warning to lib/rexml/entity.rb, added
      tests to test/rexml/test_document.rb.
    - CVE-2014-8090

debian/squeeze 2014-07-19 17:07:02 UTC 2014-07-19
Import patches-unapplied version 1.8.7.302-2squeeze2 to debian/squeeze

Author: Antonio Terceiro
Author Date: 2013-12-01 22:24:20 UTC

Import patches-unapplied version 1.8.7.302-2squeeze2 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: baf67a8bf2eb9d8a722dcba70428bee03d75335e

New changelog entries:
  [ Raphaël Hertzog ]
  * Add multiple patches to fix security issues:
    - CVE-2013-4164: Fix heap overflow in floating point parsing
      (Closes: #730189)
    - CVE-2013-1821: Fix entity expansion DoS vulnerability in REXML
      (Closes: #702526)
    - CVE-2013-4073: Fix incorrect ssl hostname verification (Closes: #714541)

applied/debian/squeeze 2014-07-19 17:07:02 UTC 2014-07-19
Import patches-applied version 1.8.7.302-2squeeze2 to applied/debian/squeeze

Author: Antonio Terceiro
Author Date: 2013-12-01 22:24:20 UTC

Import patches-applied version 1.8.7.302-2squeeze2 to applied/debian/squeeze

Imported using git-ubuntu import.

Changelog parent: d8281f1d19468960a1c7992c848492a84012d20a
Unapplied parent: 3869633152f1b3d6002106fdb5a6479dbbd15a4c

New changelog entries:
  [ Raphaël Hertzog ]
  * Add multiple patches to fix security issues:
    - CVE-2013-4164: Fix heap overflow in floating point parsing
      (Closes: #730189)
    - CVE-2013-1821: Fix entity expansion DoS vulnerability in REXML
      (Closes: #702526)
    - CVE-2013-4073: Fix incorrect ssl hostname verification (Closes: #714541)

debian/sid 2014-05-17 04:27:33 UTC 2014-05-17
Import patches-unapplied version 1.8.7.358-13 to debian/sid

Author: Antonio Terceiro
Author Date: 2014-05-16 23:08:36 UTC

Import patches-unapplied version 1.8.7.358-13 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2ede634bae4e935aec5fd737e5fdb434228f0e3a

New changelog entries:
  * Build against the default gcc with -fno-tree-dce
    -fno-optimize-sibling-calls (Closes: #674541)

applied/debian/sid 2014-05-17 04:27:33 UTC 2014-05-17
Import patches-applied version 1.8.7.358-13 to applied/debian/sid

Author: Antonio Terceiro
Author Date: 2014-05-16 23:08:36 UTC

Import patches-applied version 1.8.7.358-13 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 903a397e8569a50be81895c60f635ec06dfd7d96
Unapplied parent: ec31baad3e5b18e48ccc706838fd4ffeec63f0fc

New changelog entries:
  * Build against the default gcc with -fno-tree-dce
    -fno-optimize-sibling-calls (Closes: #674541)

applied/ubuntu/trusty-proposed 2014-03-07 07:03:26 UTC 2014-03-07
Import patches-applied version 1.8.7.358-10ubuntu1 to applied/ubuntu/trusty-p...

Author: Matthias Klose
Author Date: 2014-03-07 06:31:53 UTC

Import patches-applied version 1.8.7.358-10ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 5e3cdffa949e2ed01bdc8e66337550b631d8e320
Unapplied parent: 7a686934f4ba2142ccc6da78d323546b0e4e3ea0

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build-depend on tcl8.5-dev and tk8.5-dev, ruby is not yet ready
      for Tcl/Tk 8.6.
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
    - Handle multiarch Tcl/Tk.
    - Build with -fno-tree-dce. This fixes the ruby-ffi build.

ubuntu/devel 2014-03-07 07:03:26 UTC 2014-03-07
Import patches-unapplied version 1.8.7.358-10ubuntu1 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-07 06:31:53 UTC

Import patches-unapplied version 1.8.7.358-10ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 9ad157d5a490ec47781b34e7ac9dcb1abca70daa

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build-depend on tcl8.5-dev and tk8.5-dev, ruby is not yet ready
      for Tcl/Tk 8.6.
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
    - Handle multiarch Tcl/Tk.
    - Build with -fno-tree-dce. This fixes the ruby-ffi build.

ubuntu/trusty-proposed 2014-03-07 07:03:26 UTC 2014-03-07
Import patches-unapplied version 1.8.7.358-10ubuntu1 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-07 06:31:53 UTC

Import patches-unapplied version 1.8.7.358-10ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 9ad157d5a490ec47781b34e7ac9dcb1abca70daa

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build-depend on tcl8.5-dev and tk8.5-dev, ruby is not yet ready
      for Tcl/Tk 8.6.
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
    - Handle multiarch Tcl/Tk.
    - Build with -fno-tree-dce. This fixes the ruby-ffi build.

ubuntu/trusty-devel 2014-03-07 07:03:26 UTC 2014-03-07
Import patches-unapplied version 1.8.7.358-10ubuntu1 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-07 06:31:53 UTC

Import patches-unapplied version 1.8.7.358-10ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 9ad157d5a490ec47781b34e7ac9dcb1abca70daa

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build-depend on tcl8.5-dev and tk8.5-dev, ruby is not yet ready
      for Tcl/Tk 8.6.
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
    - Handle multiarch Tcl/Tk.
    - Build with -fno-tree-dce. This fixes the ruby-ffi build.

ubuntu/trusty 2014-03-07 07:03:26 UTC 2014-03-07
Import patches-unapplied version 1.8.7.358-10ubuntu1 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-07 06:31:53 UTC

Import patches-unapplied version 1.8.7.358-10ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 9ad157d5a490ec47781b34e7ac9dcb1abca70daa

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build-depend on tcl8.5-dev and tk8.5-dev, ruby is not yet ready
      for Tcl/Tk 8.6.
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
    - Handle multiarch Tcl/Tk.
    - Build with -fno-tree-dce. This fixes the ruby-ffi build.

applied/ubuntu/devel 2014-03-07 07:03:26 UTC 2014-03-07
Import patches-applied version 1.8.7.358-10ubuntu1 to applied/ubuntu/trusty-p...

Author: Matthias Klose
Author Date: 2014-03-07 06:31:53 UTC

Import patches-applied version 1.8.7.358-10ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 5e3cdffa949e2ed01bdc8e66337550b631d8e320
Unapplied parent: 7a686934f4ba2142ccc6da78d323546b0e4e3ea0

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build-depend on tcl8.5-dev and tk8.5-dev, ruby is not yet ready
      for Tcl/Tk 8.6.
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
    - Handle multiarch Tcl/Tk.
    - Build with -fno-tree-dce. This fixes the ruby-ffi build.

applied/ubuntu/trusty 2014-03-07 07:03:26 UTC 2014-03-07
Import patches-applied version 1.8.7.358-10ubuntu1 to applied/ubuntu/trusty-p...

Author: Matthias Klose
Author Date: 2014-03-07 06:31:53 UTC

Import patches-applied version 1.8.7.358-10ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 5e3cdffa949e2ed01bdc8e66337550b631d8e320
Unapplied parent: 7a686934f4ba2142ccc6da78d323546b0e4e3ea0

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build-depend on tcl8.5-dev and tk8.5-dev, ruby is not yet ready
      for Tcl/Tk 8.6.
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
    - Handle multiarch Tcl/Tk.
    - Build with -fno-tree-dce. This fixes the ruby-ffi build.

applied/ubuntu/trusty-devel 2014-03-07 07:03:26 UTC 2014-03-07
Import patches-applied version 1.8.7.358-10ubuntu1 to applied/ubuntu/trusty-p...

Author: Matthias Klose
Author Date: 2014-03-07 06:31:53 UTC

Import patches-applied version 1.8.7.358-10ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 5e3cdffa949e2ed01bdc8e66337550b631d8e320
Unapplied parent: 7a686934f4ba2142ccc6da78d323546b0e4e3ea0

New changelog entries:
  * Merge with Debian; remaining changes:
    - Build-depend on tcl8.5-dev and tk8.5-dev, ruby is not yet ready
      for Tcl/Tk 8.6.
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
    - Handle multiarch Tcl/Tk.
    - Build with -fno-tree-dce. This fixes the ruby-ffi build.

applied/debian/jessie 2014-01-07 10:19:01 UTC 2014-01-07
Import patches-applied version 1.8.7.358-10 to applied/debian/sid

Author: Antonio Terceiro
Author Date: 2014-01-06 19:35:05 UTC

Import patches-applied version 1.8.7.358-10 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 1a7254a77df3741bffb7022ff3610fadad0dd21d
Unapplied parent: 0d7c549cffe87991f2016c8a453dc815d444a1d3

New changelog entries:
  * Drop `Provides: ruby-interpreter` as ruby1.8 is deprecated, and will be
    removed soon. It should not be used anymore as a valid Ruby interpreter
    for packaged Ruby software. Closes: #734319
  * add debian/patches/newer-openssl.patch to ... build against the new
    openssl.

debian/jessie 2014-01-07 10:19:01 UTC 2014-01-07
Import patches-unapplied version 1.8.7.358-10 to debian/sid

Author: Antonio Terceiro
Author Date: 2014-01-06 19:35:05 UTC

Import patches-unapplied version 1.8.7.358-10 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 5d4ce9c9a95c22642ba44f16e890cd7a672803e9

New changelog entries:
  * Drop `Provides: ruby-interpreter` as ruby1.8 is deprecated, and will be
    removed soon. It should not be used anymore as a valid Ruby interpreter
    for packaged Ruby software. Closes: #734319
  * add debian/patches/newer-openssl.patch to ... build against the new
    openssl.

applied/ubuntu/raring-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-7ubuntu1.2 to applied/ubuntu/raring-...

Author: Marc Deslauriers
Author Date: 2013-11-26 14:07:23 UTC

Import patches-applied version 1.8.7.358-7ubuntu1.2 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 082fac469c8bff7aa2e92c447c94ecf7dcd6e858
Unapplied parent: 5322d172fe045a33dd7c1155f92d8ee2c729763a

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

applied/ubuntu/quantal-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-4ubuntu0.4 to applied/ubuntu/quantal...

Author: Marc Deslauriers
Author Date: 2013-11-26 14:08:25 UTC

Import patches-applied version 1.8.7.358-4ubuntu0.4 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 2a8af7983ffb0f726221333d8cbf19dd1f76462b
Unapplied parent: 31b4a9263ff643ced03c13ad400c2236be0c96e8

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

applied/ubuntu/quantal-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-4ubuntu0.4 to applied/ubuntu/quantal...

Author: Marc Deslauriers
Author Date: 2013-11-26 14:08:25 UTC

Import patches-applied version 1.8.7.358-4ubuntu0.4 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 2a8af7983ffb0f726221333d8cbf19dd1f76462b
Unapplied parent: 31b4a9263ff643ced03c13ad400c2236be0c96e8

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

applied/ubuntu/quantal-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-4ubuntu0.4 to applied/ubuntu/quantal...

Author: Marc Deslauriers
Author Date: 2013-11-26 14:08:25 UTC

Import patches-applied version 1.8.7.358-4ubuntu0.4 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 2a8af7983ffb0f726221333d8cbf19dd1f76462b
Unapplied parent: 31b4a9263ff643ced03c13ad400c2236be0c96e8

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/raring-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-7ubuntu1.2 to ubuntu/raring-security

Author: Marc Deslauriers
Author Date: 2013-11-26 14:07:23 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu1.2 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 8a8ca3d0b601bac25c269f71b189415a289f7a02

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/raring-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-7ubuntu1.2 to ubuntu/raring-security

Author: Marc Deslauriers
Author Date: 2013-11-26 14:07:23 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu1.2 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 8a8ca3d0b601bac25c269f71b189415a289f7a02

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

applied/ubuntu/raring-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-7ubuntu1.2 to applied/ubuntu/raring-...

Author: Marc Deslauriers
Author Date: 2013-11-26 14:07:23 UTC

Import patches-applied version 1.8.7.358-7ubuntu1.2 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 082fac469c8bff7aa2e92c447c94ecf7dcd6e858
Unapplied parent: 5322d172fe045a33dd7c1155f92d8ee2c729763a

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/saucy-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-7ubuntu2.1 to ubuntu/saucy-security

Author: Marc Deslauriers
Author Date: 2013-11-26 13:47:29 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu2.1 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 3c49123467eb14c1d89b341ce4647de71ad1b4ff

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/quantal-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-4ubuntu0.4 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-11-26 14:08:25 UTC

Import patches-unapplied version 1.8.7.358-4ubuntu0.4 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 1b74b5759407e839671fe5173983a0e70f7aab9e

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

applied/ubuntu/saucy-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-7ubuntu2.1 to applied/ubuntu/saucy-s...

Author: Marc Deslauriers
Author Date: 2013-11-26 13:47:29 UTC

Import patches-applied version 1.8.7.358-7ubuntu2.1 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 9802168ef1a511355ba49b6c78c416fda82222c3
Unapplied parent: 1012d7f19e772463cb590b975d8c70cf55b40797

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

applied/ubuntu/raring-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-7ubuntu1.2 to applied/ubuntu/raring-...

Author: Marc Deslauriers
Author Date: 2013-11-26 14:07:23 UTC

Import patches-applied version 1.8.7.358-7ubuntu1.2 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 082fac469c8bff7aa2e92c447c94ecf7dcd6e858
Unapplied parent: 5322d172fe045a33dd7c1155f92d8ee2c729763a

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/saucy-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-7ubuntu2.1 to ubuntu/saucy-security

Author: Marc Deslauriers
Author Date: 2013-11-26 13:47:29 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu2.1 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 3c49123467eb14c1d89b341ce4647de71ad1b4ff

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/raring-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-7ubuntu1.2 to ubuntu/raring-security

Author: Marc Deslauriers
Author Date: 2013-11-26 14:07:23 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu1.2 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 8a8ca3d0b601bac25c269f71b189415a289f7a02

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/saucy-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-7ubuntu2.1 to ubuntu/saucy-security

Author: Marc Deslauriers
Author Date: 2013-11-26 13:47:29 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu2.1 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 3c49123467eb14c1d89b341ce4647de71ad1b4ff

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

applied/ubuntu/saucy-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-7ubuntu2.1 to applied/ubuntu/saucy-s...

Author: Marc Deslauriers
Author Date: 2013-11-26 13:47:29 UTC

Import patches-applied version 1.8.7.358-7ubuntu2.1 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 9802168ef1a511355ba49b6c78c416fda82222c3
Unapplied parent: 1012d7f19e772463cb590b975d8c70cf55b40797

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

applied/ubuntu/saucy-security 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-applied version 1.8.7.358-7ubuntu2.1 to applied/ubuntu/saucy-s...

Author: Marc Deslauriers
Author Date: 2013-11-26 13:47:29 UTC

Import patches-applied version 1.8.7.358-7ubuntu2.1 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 9802168ef1a511355ba49b6c78c416fda82222c3
Unapplied parent: 1012d7f19e772463cb590b975d8c70cf55b40797

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/quantal-updates 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-4ubuntu0.4 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-11-26 14:08:25 UTC

Import patches-unapplied version 1.8.7.358-4ubuntu0.4 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 1b74b5759407e839671fe5173983a0e70f7aab9e

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/quantal-devel 2013-11-27 16:33:25 UTC 2013-11-27
Import patches-unapplied version 1.8.7.358-4ubuntu0.4 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-11-26 14:08:25 UTC

Import patches-unapplied version 1.8.7.358-4ubuntu0.4 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 1b74b5759407e839671fe5173983a0e70f7aab9e

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    heap overflow in floating point parsing.
    - debian/patches/CVE-2013-4164.patch: check lengths in util.c.
    - CVE-2013-4164

ubuntu/saucy 2013-07-08 15:18:20 UTC 2013-07-08
Import patches-unapplied version 1.8.7.358-7ubuntu2 to ubuntu/saucy-proposed

Author: Marc Deslauriers
Author Date: 2013-07-08 14:11:00 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 89ba375e08151d04b6b19555897bb4a8ebf13396

New changelog entries:
  * SECURITY UPDATE: incorrect ssl hostname verification
    - debian/patches/CVE-2013-4073.patch: fix hostname check and regression
      in ext/openssl/lib/openssl/ssl-internal.rb, added test to
      test/openssl/test_ssl.rb.
    - CVE-2013-4073

applied/ubuntu/saucy 2013-07-08 15:18:20 UTC 2013-07-08
Import patches-applied version 1.8.7.358-7ubuntu2 to applied/ubuntu/saucy-pro...

Author: Marc Deslauriers
Author Date: 2013-07-08 14:11:00 UTC

Import patches-applied version 1.8.7.358-7ubuntu2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: e3ad3a38156efdb12ce1fe40a950e5655dc25c90
Unapplied parent: 2bacf920029ec276126d009d35ee57b5e79561a4

New changelog entries:
  * SECURITY UPDATE: incorrect ssl hostname verification
    - debian/patches/CVE-2013-4073.patch: fix hostname check and regression
      in ext/openssl/lib/openssl/ssl-internal.rb, added test to
      test/openssl/test_ssl.rb.
    - CVE-2013-4073

ubuntu/saucy-proposed 2013-07-08 15:18:20 UTC 2013-07-08
Import patches-unapplied version 1.8.7.358-7ubuntu2 to ubuntu/saucy-proposed

Author: Marc Deslauriers
Author Date: 2013-07-08 14:11:00 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 89ba375e08151d04b6b19555897bb4a8ebf13396

New changelog entries:
  * SECURITY UPDATE: incorrect ssl hostname verification
    - debian/patches/CVE-2013-4073.patch: fix hostname check and regression
      in ext/openssl/lib/openssl/ssl-internal.rb, added test to
      test/openssl/test_ssl.rb.
    - CVE-2013-4073

applied/ubuntu/saucy-proposed 2013-07-08 15:18:20 UTC 2013-07-08
Import patches-applied version 1.8.7.358-7ubuntu2 to applied/ubuntu/saucy-pro...

Author: Marc Deslauriers
Author Date: 2013-07-08 14:11:00 UTC

Import patches-applied version 1.8.7.358-7ubuntu2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: e3ad3a38156efdb12ce1fe40a950e5655dc25c90
Unapplied parent: 2bacf920029ec276126d009d35ee57b5e79561a4

New changelog entries:
  * SECURITY UPDATE: incorrect ssl hostname verification
    - debian/patches/CVE-2013-4073.patch: fix hostname check and regression
      in ext/openssl/lib/openssl/ssl-internal.rb, added test to
      test/openssl/test_ssl.rb.
    - CVE-2013-4073

ubuntu/lucid-devel 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-unapplied version 1.8.7.249-2ubuntu0.3 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2013-03-22 19:00:28 UTC

Import patches-unapplied version 1.8.7.249-2ubuntu0.3 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 93dac9555e7f8c4d68faeb0d0cd5d17749c966b5

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.dpatch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

ubuntu/oneiric-updates 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-unapplied version 1.8.7.352-2ubuntu0.3 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2013-03-22 18:57:47 UTC

Import patches-unapplied version 1.8.7.352-2ubuntu0.3 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 124ec28993edea52cf99998f74000e9103858211

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.patch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

ubuntu/oneiric-security 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-unapplied version 1.8.7.352-2ubuntu0.3 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2013-03-22 18:57:47 UTC

Import patches-unapplied version 1.8.7.352-2ubuntu0.3 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 124ec28993edea52cf99998f74000e9103858211

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.patch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

ubuntu/oneiric-devel 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-unapplied version 1.8.7.352-2ubuntu0.3 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2013-03-22 18:57:47 UTC

Import patches-unapplied version 1.8.7.352-2ubuntu0.3 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 124ec28993edea52cf99998f74000e9103858211

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.patch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

ubuntu/lucid-updates 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-unapplied version 1.8.7.249-2ubuntu0.3 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2013-03-22 19:00:28 UTC

Import patches-unapplied version 1.8.7.249-2ubuntu0.3 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 93dac9555e7f8c4d68faeb0d0cd5d17749c966b5

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.dpatch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

ubuntu/lucid-security 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-unapplied version 1.8.7.249-2ubuntu0.3 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2013-03-22 19:00:28 UTC

Import patches-unapplied version 1.8.7.249-2ubuntu0.3 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 93dac9555e7f8c4d68faeb0d0cd5d17749c966b5

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.dpatch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

applied/ubuntu/lucid-devel 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-applied version 1.8.7.249-2ubuntu0.3 to applied/ubuntu/lucid-s...

Author: Marc Deslauriers
Author Date: 2013-03-22 19:00:28 UTC

Import patches-applied version 1.8.7.249-2ubuntu0.3 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 756511a4efe5c6a162cee99bd840266d4c17bf9e
Unapplied parent: 84268fd7a51efb69a7408343acb456fe1da63843

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.dpatch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

applied/ubuntu/lucid-security 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-applied version 1.8.7.249-2ubuntu0.3 to applied/ubuntu/lucid-s...

Author: Marc Deslauriers
Author Date: 2013-03-22 19:00:28 UTC

Import patches-applied version 1.8.7.249-2ubuntu0.3 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 756511a4efe5c6a162cee99bd840266d4c17bf9e
Unapplied parent: 84268fd7a51efb69a7408343acb456fe1da63843

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.dpatch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

applied/ubuntu/lucid-updates 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-applied version 1.8.7.249-2ubuntu0.3 to applied/ubuntu/lucid-s...

Author: Marc Deslauriers
Author Date: 2013-03-22 19:00:28 UTC

Import patches-applied version 1.8.7.249-2ubuntu0.3 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 756511a4efe5c6a162cee99bd840266d4c17bf9e
Unapplied parent: 84268fd7a51efb69a7408343acb456fe1da63843

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.dpatch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

applied/ubuntu/oneiric-devel 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-applied version 1.8.7.352-2ubuntu0.3 to applied/ubuntu/oneiric...

Author: Marc Deslauriers
Author Date: 2013-03-22 18:57:47 UTC

Import patches-applied version 1.8.7.352-2ubuntu0.3 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 7c60485e71849250a6eaa0c91934b9a1307bcc67
Unapplied parent: fd17c6cf37547148dc5259fbb76f71557ebc4c19

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.patch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

applied/ubuntu/oneiric-security 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-applied version 1.8.7.352-2ubuntu0.3 to applied/ubuntu/oneiric...

Author: Marc Deslauriers
Author Date: 2013-03-22 18:57:47 UTC

Import patches-applied version 1.8.7.352-2ubuntu0.3 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 7c60485e71849250a6eaa0c91934b9a1307bcc67
Unapplied parent: fd17c6cf37547148dc5259fbb76f71557ebc4c19

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.patch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

applied/ubuntu/oneiric-updates 2013-03-25 17:33:17 UTC 2013-03-25
Import patches-applied version 1.8.7.352-2ubuntu0.3 to applied/ubuntu/oneiric...

Author: Marc Deslauriers
Author Date: 2013-03-22 18:57:47 UTC

Import patches-applied version 1.8.7.352-2ubuntu0.3 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 7c60485e71849250a6eaa0c91934b9a1307bcc67
Unapplied parent: fd17c6cf37547148dc5259fbb76f71557ebc4c19

New changelog entries:
  * SECURITY UPDATE: REXML entity expansion DoS
    - debian/patches/CVE-2013-1821.patch: set an expansion limit in
      lib/rexml/document.rb, lib/rexml/text.rb, added test to
      test/rexml/test_document.rb.
    - Patch taken from Debian's 1.8.7.358-7
    - CVE-2013-1821

ubuntu/raring-proposed 2013-03-19 14:03:15 UTC 2013-03-19
Import patches-unapplied version 1.8.7.358-7ubuntu1 to ubuntu/raring-proposed

Author: Colin Watson
Author Date: 2013-03-19 13:40:19 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 4245f4f8715da00f68430a02b1dea5560f439821

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
  * Handle multiarch Tcl/Tk.
  * Build with -fno-tree-dce. This fixes the ruby-ffi build.

applied/ubuntu/raring-proposed 2013-03-19 14:03:15 UTC 2013-03-19
Import patches-applied version 1.8.7.358-7ubuntu1 to applied/ubuntu/raring-pr...

Author: Colin Watson
Author Date: 2013-03-19 13:40:19 UTC

Import patches-applied version 1.8.7.358-7ubuntu1 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: fb916ae5e1e8d0e6d431d849b4ab04c94e95d04c
Unapplied parent: 50179cd6d03af1be276613c00bc8b890acc5e15e

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
  * Handle multiarch Tcl/Tk.
  * Build with -fno-tree-dce. This fixes the ruby-ffi build.

applied/ubuntu/raring 2013-03-19 14:03:15 UTC 2013-03-19
Import patches-applied version 1.8.7.358-7ubuntu1 to applied/ubuntu/raring-pr...

Author: Colin Watson
Author Date: 2013-03-19 13:40:19 UTC

Import patches-applied version 1.8.7.358-7ubuntu1 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: fb916ae5e1e8d0e6d431d849b4ab04c94e95d04c
Unapplied parent: 50179cd6d03af1be276613c00bc8b890acc5e15e

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
  * Handle multiarch Tcl/Tk.
  * Build with -fno-tree-dce. This fixes the ruby-ffi build.

ubuntu/raring 2013-03-19 14:03:15 UTC 2013-03-19
Import patches-unapplied version 1.8.7.358-7ubuntu1 to ubuntu/raring-proposed

Author: Colin Watson
Author Date: 2013-03-19 13:40:19 UTC

Import patches-unapplied version 1.8.7.358-7ubuntu1 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 4245f4f8715da00f68430a02b1dea5560f439821

New changelog entries:
  * Resynchronise with Debian. Remaining changes:
    - Fix safe level bypass (CVE-2012-4466).
    - Build using the default GCC again, and -fno-optimize-sibling-calls.
  * Handle multiarch Tcl/Tk.
  * Build with -fno-tree-dce. This fixes the ruby-ffi build.

applied/ubuntu/natty-devel 2012-10-10 22:03:11 UTC 2012-10-10
Import patches-applied version 1.8.7.302-2ubuntu0.2 to applied/ubuntu/natty-s...

Author: Tyler Hicks
Author Date: 2012-10-10 07:42:55 UTC

Import patches-applied version 1.8.7.302-2ubuntu0.2 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: cf22c4765aa6a21a10ec673dd9afd7f0ee067712
Unapplied parent: 900afdddd669d98560fc418f074f24685087639e

New changelog entries:
  * SECURITY UPDATE: Safe level bypasses
    - debian/patches/CVE-2012-4466_CVE-2012-4481.patch: Remove incorrect
      string taints in exception handling methods. Based on upstream patch.
    - CVE-2012-4466
    - CVE-2012-4481

applied/ubuntu/natty-security 2012-10-10 22:03:11 UTC 2012-10-10
Import patches-applied version 1.8.7.302-2ubuntu0.2 to applied/ubuntu/natty-s...

Author: Tyler Hicks
Author Date: 2012-10-10 07:42:55 UTC

Import patches-applied version 1.8.7.302-2ubuntu0.2 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: cf22c4765aa6a21a10ec673dd9afd7f0ee067712
Unapplied parent: 900afdddd669d98560fc418f074f24685087639e

New changelog entries:
  * SECURITY UPDATE: Safe level bypasses
    - debian/patches/CVE-2012-4466_CVE-2012-4481.patch: Remove incorrect
      string taints in exception handling methods. Based on upstream patch.
    - CVE-2012-4466
    - CVE-2012-4481

ubuntu/natty-updates 2012-10-10 22:03:11 UTC 2012-10-10
Import patches-unapplied version 1.8.7.302-2ubuntu0.2 to ubuntu/natty-security

Author: Tyler Hicks
Author Date: 2012-10-10 07:42:55 UTC

Import patches-unapplied version 1.8.7.302-2ubuntu0.2 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: f5a682830b7a090903dc1b0d537c52f92c7254be

New changelog entries:
  * SECURITY UPDATE: Safe level bypasses
    - debian/patches/CVE-2012-4466_CVE-2012-4481.patch: Remove incorrect
      string taints in exception handling methods. Based on upstream patch.
    - CVE-2012-4466
    - CVE-2012-4481

ubuntu/natty-security 2012-10-10 22:03:11 UTC 2012-10-10
Import patches-unapplied version 1.8.7.302-2ubuntu0.2 to ubuntu/natty-security

Author: Tyler Hicks
Author Date: 2012-10-10 07:42:55 UTC

Import patches-unapplied version 1.8.7.302-2ubuntu0.2 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: f5a682830b7a090903dc1b0d537c52f92c7254be

New changelog entries:
  * SECURITY UPDATE: Safe level bypasses
    - debian/patches/CVE-2012-4466_CVE-2012-4481.patch: Remove incorrect
      string taints in exception handling methods. Based on upstream patch.
    - CVE-2012-4466
    - CVE-2012-4481

ubuntu/natty-devel 2012-10-10 22:03:11 UTC 2012-10-10
Import patches-unapplied version 1.8.7.302-2ubuntu0.2 to ubuntu/natty-security

Author: Tyler Hicks
Author Date: 2012-10-10 07:42:55 UTC

Import patches-unapplied version 1.8.7.302-2ubuntu0.2 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: f5a682830b7a090903dc1b0d537c52f92c7254be

New changelog entries:
  * SECURITY UPDATE: Safe level bypasses
    - debian/patches/CVE-2012-4466_CVE-2012-4481.patch: Remove incorrect
      string taints in exception handling methods. Based on upstream patch.
    - CVE-2012-4466
    - CVE-2012-4481

applied/ubuntu/natty-updates 2012-10-10 22:03:11 UTC 2012-10-10
Import patches-applied version 1.8.7.302-2ubuntu0.2 to applied/ubuntu/natty-s...

Author: Tyler Hicks
Author Date: 2012-10-10 07:42:55 UTC

Import patches-applied version 1.8.7.302-2ubuntu0.2 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: cf22c4765aa6a21a10ec673dd9afd7f0ee067712
Unapplied parent: 900afdddd669d98560fc418f074f24685087639e

New changelog entries:
  * SECURITY UPDATE: Safe level bypasses
    - debian/patches/CVE-2012-4466_CVE-2012-4481.patch: Remove incorrect
      string taints in exception handling methods. Based on upstream patch.
    - CVE-2012-4466
    - CVE-2012-4481

applied/ubuntu/quantal 2012-06-02 16:26:22 UTC 2012-06-02
Import patches-applied version 1.8.7.358-4 to applied/debian/sid

Author: Antonio Terceiro
Author Date: 2012-06-02 01:44:42 UTC

Import patches-applied version 1.8.7.358-4 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 26fd2d73b714b916f6f92b763cf5155d398ded85
Unapplied parent: 175b45eda504a53c8c33dac5bc65ab560b24ad76

New changelog entries:
  * debian/rules: avoid running DRB tests, since they crash and leave runaway
    processes that make buildds hang forever. With this, I expect that we
    don't need to set timeouts for the test suite at all (Closes: #674942).
  * Added patch by Steven Chamberlain to make ruby1.8-dev depend on gcc-4.6,
    since Ruby will hard code that as the compiler for building C extensions.
    Any C extension will FTBFS if gcc-4.6 is not installed (Closes: #675347).

ubuntu/quantal 2012-06-02 16:26:22 UTC 2012-06-02
Import patches-unapplied version 1.8.7.358-4 to debian/sid

Author: Antonio Terceiro
Author Date: 2012-06-02 01:44:42 UTC

Import patches-unapplied version 1.8.7.358-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 46d9d56f1aa7334c415396dba6de4fd469640633

New changelog entries:
  * debian/rules: avoid running DRB tests, since they crash and leave runaway
    processes that make buildds hang forever. With this, I expect that we
    don't need to set timeouts for the test suite at all (Closes: #674942).
  * Added patch by Steven Chamberlain to make ruby1.8-dev depend on gcc-4.6,
    since Ruby will hard code that as the compiler for building C extensions.
    Any C extension will FTBFS if gcc-4.6 is not installed (Closes: #675347).

applied/ubuntu/precise 2012-03-03 15:03:41 UTC 2012-03-03
Import patches-applied version 1.8.7.352-2ubuntu1 to applied/ubuntu/precise

Author: Tyler Hicks
Author Date: 2012-02-29 18:11:48 UTC

Import patches-applied version 1.8.7.352-2ubuntu1 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 7fed36b222018174daa75fc5f910c7e2ffdf2c41
Unapplied parent: 8bd80043a549b099e0a4f63d0b79296b38d6d5cd

New changelog entries:
  * SECURITY UPDATE: Denial of service via crafted hash table keys
    (LP: #943451)
    - debian/patches/CVE-2011-4815.patch: Add randomness to the key hashing
      algorithm to prevent predictable results when inserting objects into a
      hash table. Based on upstream patch.
    - CVE-2011-4815

ubuntu/precise 2012-03-03 15:03:41 UTC 2012-03-03
Import patches-unapplied version 1.8.7.352-2ubuntu1 to ubuntu/precise

Author: Tyler Hicks
Author Date: 2012-02-29 18:11:48 UTC

Import patches-unapplied version 1.8.7.352-2ubuntu1 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: c3c4addfd4a025e238cccd8203d84b3f98e660d3

New changelog entries:
  * SECURITY UPDATE: Denial of service via crafted hash table keys
    (LP: #943451)
    - debian/patches/CVE-2011-4815.patch: Add randomness to the key hashing
      algorithm to prevent predictable results when inserting objects into a
      hash table. Based on upstream patch.
    - CVE-2011-4815

ubuntu/maverick-security 2012-02-28 02:34:54 UTC 2012-02-28
Import patches-unapplied version 1.8.7.299-2ubuntu0.1 to ubuntu/maverick-secu...

Author: Tyler Hicks
Author Date: 2012-02-21 22:28:51 UTC

Import patches-unapplied version 1.8.7.299-2ubuntu0.1 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: baedf58e07122da21bca9de214b55e550c4b2be9

New changelog entries:
  * SECURITY UPDATE: Cross-site scripting via HTTP error responses
    - debian/patches/CVE-2010-0541.patch: Use the ISO-8859-1 character
      set for HTTP error responses. Based on upstream patch.
    - CVE-2010-0541
  * SECURITY UPDATE: Arbitrary code execution and denial of service
    - debian/patches/CVE-2011-0188.patch: Remove cast to prevent memory
      corruption during allocation. Based on upstream patch.
    - CVE-2011-0188
  * SECURITY UPDATE: Arbitrary file deletion due to symlink race
    - debian/patches/CVE-2011-1004.patch: Unlink the symlink rather
      than recursively removing everything underneath the symlink
      destination. Based on upstream patch.
    - CVE-2011-1004
  * SECURITY UPDATE: Safe level bypass
    - debian/patches/CVE-2011-1005.patch: Remove incorrect string taint
      in exception handling methods. Based on upstream patch.
    - CVE-2011-1005
  * SECURITY UPDATE: Predictable random number generation
    - debian/patches/CVE-2011-2686.patch: Reseed the random number
      generator each time a child process is created. Based on upstream
      patch.
    - CVE-2011-2686
  * SECURITY UPDATE: Predicatable random number generation
    - debian/patches/CVE-2011-2705.patch: Reseed the random number
      generator with the pid number and the current time to prevent
      predictable random numbers in the case of pid number rollover. Based on
      upstream patch.
    - CVE-2011-2705
  * SECURITY UPDATE: Denial of service via crafted hash table keys
    - debian/patches/CVE-2011-4815.patch: Add randomness to the key hashing
      algorithm to prevent predictable results when inserting objects into a
      hash table. Based on upstream patch.
    - CVE-2011-4815

applied/ubuntu/maverick-updates 2012-02-28 02:34:54 UTC 2012-02-28
Import patches-applied version 1.8.7.299-2ubuntu0.1 to applied/ubuntu/maveric...

Author: Tyler Hicks
Author Date: 2012-02-21 22:28:51 UTC

Import patches-applied version 1.8.7.299-2ubuntu0.1 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 68a4308c1254b8be6a4d5a93a4782a1c51a2a6ab
Unapplied parent: f1179cd7f1ad92b6f4926ac5329dd3c3437dd777

New changelog entries:
  * SECURITY UPDATE: Cross-site scripting via HTTP error responses
    - debian/patches/CVE-2010-0541.patch: Use the ISO-8859-1 character
      set for HTTP error responses. Based on upstream patch.
    - CVE-2010-0541
  * SECURITY UPDATE: Arbitrary code execution and denial of service
    - debian/patches/CVE-2011-0188.patch: Remove cast to prevent memory
      corruption during allocation. Based on upstream patch.
    - CVE-2011-0188
  * SECURITY UPDATE: Arbitrary file deletion due to symlink race
    - debian/patches/CVE-2011-1004.patch: Unlink the symlink rather
      than recursively removing everything underneath the symlink
      destination. Based on upstream patch.
    - CVE-2011-1004
  * SECURITY UPDATE: Safe level bypass
    - debian/patches/CVE-2011-1005.patch: Remove incorrect string taint
      in exception handling methods. Based on upstream patch.
    - CVE-2011-1005
  * SECURITY UPDATE: Predictable random number generation
    - debian/patches/CVE-2011-2686.patch: Reseed the random number
      generator each time a child process is created. Based on upstream
      patch.
    - CVE-2011-2686
  * SECURITY UPDATE: Predicatable random number generation
    - debian/patches/CVE-2011-2705.patch: Reseed the random number
      generator with the pid number and the current time to prevent
      predictable random numbers in the case of pid number rollover. Based on
      upstream patch.
    - CVE-2011-2705
  * SECURITY UPDATE: Denial of service via crafted hash table keys
    - debian/patches/CVE-2011-4815.patch: Add randomness to the key hashing
      algorithm to prevent predictable results when inserting objects into a
      hash table. Based on upstream patch.
    - CVE-2011-4815

applied/ubuntu/maverick-security 2012-02-28 02:34:54 UTC 2012-02-28
Import patches-applied version 1.8.7.299-2ubuntu0.1 to applied/ubuntu/maveric...

Author: Tyler Hicks
Author Date: 2012-02-21 22:28:51 UTC

Import patches-applied version 1.8.7.299-2ubuntu0.1 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 68a4308c1254b8be6a4d5a93a4782a1c51a2a6ab
Unapplied parent: f1179cd7f1ad92b6f4926ac5329dd3c3437dd777

New changelog entries:
  * SECURITY UPDATE: Cross-site scripting via HTTP error responses
    - debian/patches/CVE-2010-0541.patch: Use the ISO-8859-1 character
      set for HTTP error responses. Based on upstream patch.
    - CVE-2010-0541
  * SECURITY UPDATE: Arbitrary code execution and denial of service
    - debian/patches/CVE-2011-0188.patch: Remove cast to prevent memory
      corruption during allocation. Based on upstream patch.
    - CVE-2011-0188
  * SECURITY UPDATE: Arbitrary file deletion due to symlink race
    - debian/patches/CVE-2011-1004.patch: Unlink the symlink rather
      than recursively removing everything underneath the symlink
      destination. Based on upstream patch.
    - CVE-2011-1004
  * SECURITY UPDATE: Safe level bypass
    - debian/patches/CVE-2011-1005.patch: Remove incorrect string taint
      in exception handling methods. Based on upstream patch.
    - CVE-2011-1005
  * SECURITY UPDATE: Predictable random number generation
    - debian/patches/CVE-2011-2686.patch: Reseed the random number
      generator each time a child process is created. Based on upstream
      patch.
    - CVE-2011-2686
  * SECURITY UPDATE: Predicatable random number generation
    - debian/patches/CVE-2011-2705.patch: Reseed the random number
      generator with the pid number and the current time to prevent
      predictable random numbers in the case of pid number rollover. Based on
      upstream patch.
    - CVE-2011-2705
  * SECURITY UPDATE: Denial of service via crafted hash table keys
    - debian/patches/CVE-2011-4815.patch: Add randomness to the key hashing
      algorithm to prevent predictable results when inserting objects into a
      hash table. Based on upstream patch.
    - CVE-2011-4815

applied/ubuntu/maverick-devel 2012-02-28 02:34:54 UTC 2012-02-28
Import patches-applied version 1.8.7.299-2ubuntu0.1 to applied/ubuntu/maveric...

Author: Tyler Hicks
Author Date: 2012-02-21 22:28:51 UTC

Import patches-applied version 1.8.7.299-2ubuntu0.1 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 68a4308c1254b8be6a4d5a93a4782a1c51a2a6ab
Unapplied parent: f1179cd7f1ad92b6f4926ac5329dd3c3437dd777

New changelog entries:
  * SECURITY UPDATE: Cross-site scripting via HTTP error responses
    - debian/patches/CVE-2010-0541.patch: Use the ISO-8859-1 character
      set for HTTP error responses. Based on upstream patch.
    - CVE-2010-0541
  * SECURITY UPDATE: Arbitrary code execution and denial of service
    - debian/patches/CVE-2011-0188.patch: Remove cast to prevent memory
      corruption during allocation. Based on upstream patch.
    - CVE-2011-0188
  * SECURITY UPDATE: Arbitrary file deletion due to symlink race
    - debian/patches/CVE-2011-1004.patch: Unlink the symlink rather
      than recursively removing everything underneath the symlink
      destination. Based on upstream patch.
    - CVE-2011-1004
  * SECURITY UPDATE: Safe level bypass
    - debian/patches/CVE-2011-1005.patch: Remove incorrect string taint
      in exception handling methods. Based on upstream patch.
    - CVE-2011-1005
  * SECURITY UPDATE: Predictable random number generation
    - debian/patches/CVE-2011-2686.patch: Reseed the random number
      generator each time a child process is created. Based on upstream
      patch.
    - CVE-2011-2686
  * SECURITY UPDATE: Predicatable random number generation
    - debian/patches/CVE-2011-2705.patch: Reseed the random number
      generator with the pid number and the current time to prevent
      predictable random numbers in the case of pid number rollover. Based on
      upstream patch.
    - CVE-2011-2705
  * SECURITY UPDATE: Denial of service via crafted hash table keys
    - debian/patches/CVE-2011-4815.patch: Add randomness to the key hashing
      algorithm to prevent predictable results when inserting objects into a
      hash table. Based on upstream patch.
    - CVE-2011-4815

ubuntu/maverick-updates 2012-02-28 02:34:54 UTC 2012-02-28
Import patches-unapplied version 1.8.7.299-2ubuntu0.1 to ubuntu/maverick-secu...

Author: Tyler Hicks
Author Date: 2012-02-21 22:28:51 UTC

Import patches-unapplied version 1.8.7.299-2ubuntu0.1 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: baedf58e07122da21bca9de214b55e550c4b2be9

New changelog entries:
  * SECURITY UPDATE: Cross-site scripting via HTTP error responses
    - debian/patches/CVE-2010-0541.patch: Use the ISO-8859-1 character
      set for HTTP error responses. Based on upstream patch.
    - CVE-2010-0541
  * SECURITY UPDATE: Arbitrary code execution and denial of service
    - debian/patches/CVE-2011-0188.patch: Remove cast to prevent memory
      corruption during allocation. Based on upstream patch.
    - CVE-2011-0188
  * SECURITY UPDATE: Arbitrary file deletion due to symlink race
    - debian/patches/CVE-2011-1004.patch: Unlink the symlink rather
      than recursively removing everything underneath the symlink
      destination. Based on upstream patch.
    - CVE-2011-1004
  * SECURITY UPDATE: Safe level bypass
    - debian/patches/CVE-2011-1005.patch: Remove incorrect string taint
      in exception handling methods. Based on upstream patch.
    - CVE-2011-1005
  * SECURITY UPDATE: Predictable random number generation
    - debian/patches/CVE-2011-2686.patch: Reseed the random number
      generator each time a child process is created. Based on upstream
      patch.
    - CVE-2011-2686
  * SECURITY UPDATE: Predicatable random number generation
    - debian/patches/CVE-2011-2705.patch: Reseed the random number
      generator with the pid number and the current time to prevent
      predictable random numbers in the case of pid number rollover. Based on
      upstream patch.
    - CVE-2011-2705
  * SECURITY UPDATE: Denial of service via crafted hash table keys
    - debian/patches/CVE-2011-4815.patch: Add randomness to the key hashing
      algorithm to prevent predictable results when inserting objects into a
      hash table. Based on upstream patch.
    - CVE-2011-4815

ubuntu/maverick-devel 2012-02-28 02:34:54 UTC 2012-02-28
Import patches-unapplied version 1.8.7.299-2ubuntu0.1 to ubuntu/maverick-secu...

Author: Tyler Hicks
Author Date: 2012-02-21 22:28:51 UTC

Import patches-unapplied version 1.8.7.299-2ubuntu0.1 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: baedf58e07122da21bca9de214b55e550c4b2be9

New changelog entries:
  * SECURITY UPDATE: Cross-site scripting via HTTP error responses
    - debian/patches/CVE-2010-0541.patch: Use the ISO-8859-1 character
      set for HTTP error responses. Based on upstream patch.
    - CVE-2010-0541
  * SECURITY UPDATE: Arbitrary code execution and denial of service
    - debian/patches/CVE-2011-0188.patch: Remove cast to prevent memory
      corruption during allocation. Based on upstream patch.
    - CVE-2011-0188
  * SECURITY UPDATE: Arbitrary file deletion due to symlink race
    - debian/patches/CVE-2011-1004.patch: Unlink the symlink rather
      than recursively removing everything underneath the symlink
      destination. Based on upstream patch.
    - CVE-2011-1004
  * SECURITY UPDATE: Safe level bypass
    - debian/patches/CVE-2011-1005.patch: Remove incorrect string taint
      in exception handling methods. Based on upstream patch.
    - CVE-2011-1005
  * SECURITY UPDATE: Predictable random number generation
    - debian/patches/CVE-2011-2686.patch: Reseed the random number
      generator each time a child process is created. Based on upstream
      patch.
    - CVE-2011-2686
  * SECURITY UPDATE: Predicatable random number generation
    - debian/patches/CVE-2011-2705.patch: Reseed the random number
      generator with the pid number and the current time to prevent
      predictable random numbers in the case of pid number rollover. Based on
      upstream patch.
    - CVE-2011-2705
  * SECURITY UPDATE: Denial of service via crafted hash table keys
    - debian/patches/CVE-2011-4815.patch: Add randomness to the key hashing
      algorithm to prevent predictable results when inserting objects into a
      hash table. Based on upstream patch.
    - CVE-2011-4815

applied/ubuntu/oneiric 2011-07-24 10:30:48 UTC 2011-07-24
Import patches-applied version 1.8.7.352-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2011-07-24 10:30:48 UTC

Import patches-applied version 1.8.7.352-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 41ad6dc23f82b22570c95632e88548edee879e8f
Unapplied parent: af0d638d6d565001cf17f590a4502d2a75e409d8

New changelog entries:
  * Add -fno-tree-sra on armel. Workaround that Closes: #634260

ubuntu/oneiric 2011-07-24 10:30:48 UTC 2011-07-24
Import patches-unapplied version 1.8.7.352-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2011-07-24 10:30:48 UTC

Import patches-unapplied version 1.8.7.352-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 80c99111882fb7e26a916c09e643292cd9f08dfa

New changelog entries:
  * Add -fno-tree-sra on armel. Workaround that Closes: #634260

debian/experimental 2011-06-15 09:47:48 UTC 2011-06-15
Import patches-unapplied version 1.8.7.334+svn31904-1 to debian/experimental

Author: Lucas Nussbaum
Author Date: 2011-06-15 09:47:48 UTC

Import patches-unapplied version 1.8.7.334+svn31904-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: b7aeb8fa8a6c5187a7d0d3efe1b3be2c9bb8da12

New changelog entries:
  * new upstream snapshot from SVN revision 31904.
  * Update Lucas' email address.
  * Bump Standards-Version to 3.9.2. No changes needed.

applied/debian/experimental 2011-06-15 09:47:48 UTC 2011-06-15
Import patches-applied version 1.8.7.334+svn31904-1 to applied/debian/experim...

Author: Lucas Nussbaum
Author Date: 2011-06-15 09:47:48 UTC

Import patches-applied version 1.8.7.334+svn31904-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: e7328ccfeccce0b428b3de01cf91038e6a707735
Unapplied parent: 12adfce6fc0553ca52fb98d1ea3abd569e60f363

New changelog entries:
  * new upstream snapshot from SVN revision 31904.
  * Update Lucas' email address.
  * Bump Standards-Version to 3.9.2. No changes needed.

ubuntu/natty 2010-09-01 21:23:25 UTC 2010-09-01
Import patches-unapplied version 1.8.7.302-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2010-09-01 10:08:48 UTC

Import patches-unapplied version 1.8.7.302-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 02620f0016a8c3e2561f476bd89138b7c379b73f

New changelog entries:
  * Add debian/patches/100901_threading_fixes.patch. Fixes threading
    problems on Debian GNU/kFreeBSD exhibited by puppet.
    Thanks to Petr Salinger and Aurélien Jarno. Closes: #595034

applied/ubuntu/natty 2010-09-01 21:23:25 UTC 2010-09-01
Import patches-applied version 1.8.7.302-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2010-09-01 10:08:48 UTC

Import patches-applied version 1.8.7.302-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: def155e7c60e3b2126c097e28dc235edc585e5b6
Unapplied parent: 040470e18ea8701c860f09af06a66f9717454398

New changelog entries:
  * Add debian/patches/100901_threading_fixes.patch. Fixes threading
    problems on Debian GNU/kFreeBSD exhibited by puppet.
    Thanks to Petr Salinger and Aurélien Jarno. Closes: #595034

ubuntu/maverick 2010-07-31 08:23:52 UTC 2010-07-31
Import patches-unapplied version 1.8.7.299-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2010-07-30 21:45:14 UTC

Import patches-unapplied version 1.8.7.299-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4e787104146726cb583645c44f930a2e45d03b87

New changelog entries:
  * Convert from dpatch to quilt using dpatch2quilt.sh
  * Add patch 100730_disable_getsetcontext_on_nptl: disable getsetcontext on
    NPTL. LP: #307462, Closes: #579229
  * Added 100730_verbose-tests.patch: run tests in verbose mode.
  * Run make test-all, but do not consider failures fatal for now.
  * Upgrade to Standards-Version: 3.9.1. No changes needed.
  * Deal with Ubuntu changing the GCC target to i686-linux-gnu: search
    for libs in i486-linux too. LP: #611322.

applied/ubuntu/maverick 2010-07-31 08:23:52 UTC 2010-07-31
Import patches-applied version 1.8.7.299-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2010-07-30 21:45:14 UTC

Import patches-applied version 1.8.7.299-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: d317f2420243f1fa732dadcdb22b3b626b0fa72f
Unapplied parent: baedf58e07122da21bca9de214b55e550c4b2be9

New changelog entries:
  * Convert from dpatch to quilt using dpatch2quilt.sh
  * Add patch 100730_disable_getsetcontext_on_nptl: disable getsetcontext on
    NPTL. LP: #307462, Closes: #579229
  * Added 100730_verbose-tests.patch: run tests in verbose mode.
  * Run make test-all, but do not consider failures fatal for now.
  * Upgrade to Standards-Version: 3.9.1. No changes needed.
  * Deal with Ubuntu changing the GCC target to i686-linux-gnu: search
    for libs in i486-linux too. LP: #611322.

ubuntu/lucid 2010-03-12 15:18:56 UTC 2010-03-12
Import patches-unapplied version 1.8.7.249-2 to debian/sid

Author: Lucas Nussbaum
Author Date: 2010-03-12 06:13:47 UTC

Import patches-unapplied version 1.8.7.249-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8f9e034d4a67cd66ff8a7e01edc45f0a75251707

New changelog entries:
  * Add 100312_timeout-fix.dpatch: Backport upstream change to fix
    problem with threads and timeouts. Closes: #539987

applied/ubuntu/lucid 2010-03-12 15:18:56 UTC 2010-03-12
Import patches-applied version 1.8.7.249-2 to applied/debian/sid

Author: Lucas Nussbaum
Author Date: 2010-03-12 06:13:47 UTC

Import patches-applied version 1.8.7.249-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 60f28bf46b62df68a3eaaebd5584705c0597cf73
Unapplied parent: b20db92664e9fc64ce3ad3661eb156e8fc94517b

New changelog entries:
  * Add 100312_timeout-fix.dpatch: Backport upstream change to fix
    problem with threads and timeouts. Closes: #539987

applied/ubuntu/karmic-proposed 2009-12-07 11:04:45 UTC 2009-12-07
Import patches-applied version 1.8.7.174-1ubuntu1 to applied/ubuntu/karmic-pr...

Author: Bryan McLellan
Author Date: 2009-12-01 11:33:13 UTC

Import patches-applied version 1.8.7.174-1ubuntu1 to applied/ubuntu/karmic-proposed

Imported using git-ubuntu import.

Changelog parent: ec48434956656a1561bd28b84f7ce06b03538a48
Unapplied parent: f6d1212a22e3cbbbb55965c02426a1924dd71419

New changelog entries:
  * Added debian/patches/091125_gc_check.dpatch: Avoid segv on gc run whe
    heap fills up with deferred objects. (LP: #488115)
  * Added debian/patches/090812_class_clone_segv.dpatch: avoid segv when an
    object cloned. (LP: #484756)

applied/ubuntu/karmic-updates 2009-12-07 11:04:45 UTC 2009-12-07
Import patches-applied version 1.8.7.174-1ubuntu1 to applied/ubuntu/karmic-pr...

Author: Bryan McLellan
Author Date: 2009-12-01 11:33:13 UTC

Import patches-applied version 1.8.7.174-1ubuntu1 to applied/ubuntu/karmic-proposed

Imported using git-ubuntu import.

Changelog parent: ec48434956656a1561bd28b84f7ce06b03538a48
Unapplied parent: f6d1212a22e3cbbbb55965c02426a1924dd71419

New changelog entries:
  * Added debian/patches/091125_gc_check.dpatch: Avoid segv on gc run whe
    heap fills up with deferred objects. (LP: #488115)
  * Added debian/patches/090812_class_clone_segv.dpatch: avoid segv when an
    object cloned. (LP: #484756)

ubuntu/karmic-updates 2009-12-07 11:04:45 UTC 2009-12-07
Import patches-unapplied version 1.8.7.174-1ubuntu1 to ubuntu/karmic-proposed

Author: Bryan McLellan
Author Date: 2009-12-01 11:33:13 UTC

Import patches-unapplied version 1.8.7.174-1ubuntu1 to ubuntu/karmic-proposed

Imported using git-ubuntu import.

Changelog parent: b5f90e61db727f6f59138ddb91dda32fd36822b7

New changelog entries:
  * Added debian/patches/091125_gc_check.dpatch: Avoid segv on gc run whe
    heap fills up with deferred objects. (LP: #488115)
  * Added debian/patches/090812_class_clone_segv.dpatch: avoid segv when an
    object cloned. (LP: #484756)

applied/ubuntu/karmic-devel 2009-12-07 11:04:45 UTC 2009-12-07
Import patches-applied version 1.8.7.174-1ubuntu1 to applied/ubuntu/karmic-pr...

Author: Bryan McLellan
Author Date: 2009-12-01 11:33:13 UTC

Import patches-applied version 1.8.7.174-1ubuntu1 to applied/ubuntu/karmic-proposed

Imported using git-ubuntu import.

Changelog parent: ec48434956656a1561bd28b84f7ce06b03538a48
Unapplied parent: f6d1212a22e3cbbbb55965c02426a1924dd71419

New changelog entries:
  * Added debian/patches/091125_gc_check.dpatch: Avoid segv on gc run whe
    heap fills up with deferred objects. (LP: #488115)
  * Added debian/patches/090812_class_clone_segv.dpatch: avoid segv when an
    object cloned. (LP: #484756)

ubuntu/karmic-devel 2009-12-07 11:04:45 UTC 2009-12-07
Import patches-unapplied version 1.8.7.174-1ubuntu1 to ubuntu/karmic-proposed

Author: Bryan McLellan
Author Date: 2009-12-01 11:33:13 UTC

Import patches-unapplied version 1.8.7.174-1ubuntu1 to ubuntu/karmic-proposed

Imported using git-ubuntu import.

Changelog parent: b5f90e61db727f6f59138ddb91dda32fd36822b7

New changelog entries:
  * Added debian/patches/091125_gc_check.dpatch: Avoid segv on gc run whe
    heap fills up with deferred objects. (LP: #488115)
  * Added debian/patches/090812_class_clone_segv.dpatch: avoid segv when an
    object cloned. (LP: #484756)

ubuntu/karmic-proposed 2009-12-07 11:04:45 UTC 2009-12-07
Import patches-unapplied version 1.8.7.174-1ubuntu1 to ubuntu/karmic-proposed

Author: Bryan McLellan
Author Date: 2009-12-01 11:33:13 UTC

Import patches-unapplied version 1.8.7.174-1ubuntu1 to ubuntu/karmic-proposed

Imported using git-ubuntu import.

Changelog parent: b5f90e61db727f6f59138ddb91dda32fd36822b7

New changelog entries:
  * Added debian/patches/091125_gc_check.dpatch: Avoid segv on gc run whe
    heap fills up with deferred objects. (LP: #488115)
  * Added debian/patches/090812_class_clone_segv.dpatch: avoid segv when an
    object cloned. (LP: #484756)

debian/lenny 2009-09-05 13:09:39 UTC 2009-09-05
Import patches-unapplied version 1.8.7.72-3lenny1 to debian/lenny

Author: akira yamada
Author Date: 2009-07-10 08:17:38 UTC

Import patches-unapplied version 1.8.7.72-3lenny1 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: 0247883b74914937a78a74480ffdec7bef4bbab9

New changelog entries:
  * added patch: 932_CVE-2009-1904 (closes: #532689)
    It fixes BigDecimal DoS vulnerability (CVE-2009-1904). (backported from
    1.8.7-p172 and 1.8.7-p174)
  * Add upstream patch to properly check return values of the
    OCSP_basic_verify function (CVE-2009-0642; Closes: #513528)

applied/debian/lenny 2009-09-05 13:09:39 UTC 2009-09-05
Import patches-applied version 1.8.7.72-3lenny1 to applied/debian/lenny

Author: akira yamada
Author Date: 2009-07-10 08:17:38 UTC

Import patches-applied version 1.8.7.72-3lenny1 to applied/debian/lenny

Imported using git-ubuntu import.

Changelog parent: 18cfd146b55bc4492549590a7ad055eedc2c709f
Unapplied parent: 03d2a978d4e24bc65f80e35e79d161be74d8f1c0

New changelog entries:
  * added patch: 932_CVE-2009-1904 (closes: #532689)
    It fixes BigDecimal DoS vulnerability (CVE-2009-1904). (backported from
    1.8.7-p172 and 1.8.7-p174)
  * Add upstream patch to properly check return values of the
    OCSP_basic_verify function (CVE-2009-0642; Closes: #513528)

applied/ubuntu/hardy-security 2009-07-20 14:04:57 UTC 2009-07-20
Import patches-applied version 1.8.6.111-2ubuntu1.3 to applied/ubuntu/hardy-s...

Author: Marc Deslauriers
Author Date: 2009-07-15 17:06:03 UTC

Import patches-applied version 1.8.6.111-2ubuntu1.3 to applied/ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 9541b3e4f36605c2941e2aefd4c6144e2934a2a9
Unapplied parent: c82d12d8f40ceddb5ddfa4585cb549fd4526122c

New changelog entries:
  * SECURITY UPDATE: certificate spoofing via invalid return value check
    in OCSP_basic_verify
    - debian/patches/904_security_CVE-2009-0642.dpatch: also check for -1
      return code in ext/openssl/ossl_ocsp.c.
    - CVE-2009-0642
  * SECURITY UPDATE: denial of service in BigDecimal library via string
    argument that represents a large number (LP: #385436)
    - debian/patches/905_security_CVE-2009-1904.dpatch: handle large
      numbers properly in ext/bigdecimal/bigdecimal.c.
    - CVE-2009-1904

applied/ubuntu/intrepid-updates 2009-07-20 14:04:57 UTC 2009-07-20
Import patches-applied version 1.8.7.72-1ubuntu0.2 to applied/ubuntu/intrepid...

Author: Marc Deslauriers
Author Date: 2009-07-15 15:49:36 UTC

Import patches-applied version 1.8.7.72-1ubuntu0.2 to applied/ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 35c26a216de608a9432651e450f3f05cc20852cd
Unapplied parent: cee20d29121065e90fa7b6fc1632dde65dca1b10

New changelog entries:
  * SECURITY UPDATE: certificate spoofing via invalid return value check
    in OCSP_basic_verify
    - debian/patches/906_security_CVE-2009-0642.dpatch: also check for -1
      return code in ext/openssl/ossl_ocsp.c.
    - CVE-2009-0642
  * SECURITY UPDATE: denial of service in BigDecimal library via string
    argument that represents a large number (LP: #385436)
    - debian/patches/907_security_CVE-2009-1904.dpatch: handle large
      numbers properly in ext/bigdecimal/bigdecimal.c.
    - CVE-2009-1904

1100 of 178 results

Other repositories

Name Last Modified
lp:ubuntu/+source/ruby1.8 2018-03-06
11 of 1 result
You can't create new repositories for ruby1.8 in Ubuntu.