View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/python-coverage
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2020-02-20 12:32:00 UTC 2020-02-20
DSC file for 4.5.2+dfsg.1-4ubuntu1

Author: Ubuntu Git Importer
Author Date: 2020-02-20 12:32:00 UTC

DSC file for 4.5.2+dfsg.1-4ubuntu1

ubuntu/devel 2020-02-20 12:18:09 UTC 2020-02-20
Import patches-unapplied version 4.5.2+dfsg.1-4ubuntu1 to ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2020-02-20 13:16:23 UTC

Import patches-unapplied version 4.5.2+dfsg.1-4ubuntu1 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: 205029b7a67f91ac30f9359e15c0b0f3ab65682c

New changelog entries:
  * Drop build dependencies on python and python3.

ubuntu/focal-proposed 2020-02-20 12:18:09 UTC 2020-02-20
Import patches-unapplied version 4.5.2+dfsg.1-4ubuntu1 to ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2020-02-20 13:16:23 UTC

Import patches-unapplied version 4.5.2+dfsg.1-4ubuntu1 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: 205029b7a67f91ac30f9359e15c0b0f3ab65682c

New changelog entries:
  * Drop build dependencies on python and python3.

ubuntu/focal 2020-02-20 12:18:09 UTC 2020-02-20
Import patches-unapplied version 4.5.2+dfsg.1-4ubuntu1 to ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2020-02-20 13:16:23 UTC

Import patches-unapplied version 4.5.2+dfsg.1-4ubuntu1 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: 205029b7a67f91ac30f9359e15c0b0f3ab65682c

New changelog entries:
  * Drop build dependencies on python and python3.

ubuntu/focal-devel 2020-02-20 12:18:09 UTC 2020-02-20
Import patches-unapplied version 4.5.2+dfsg.1-4ubuntu1 to ubuntu/focal-proposed

Author: Matthias Klose
Author Date: 2020-02-20 13:16:23 UTC

Import patches-unapplied version 4.5.2+dfsg.1-4ubuntu1 to ubuntu/focal-proposed

Imported using git-ubuntu import.

Changelog parent: 205029b7a67f91ac30f9359e15c0b0f3ab65682c

New changelog entries:
  * Drop build dependencies on python and python3.

importer/debian/dsc 2019-11-11 04:39:04 UTC 2019-11-11
DSC file for 4.5.2+dfsg.1-4

Author: Ubuntu Git Importer
Author Date: 2019-11-11 04:39:04 UTC

DSC file for 4.5.2+dfsg.1-4

debian/sid 2019-11-11 04:37:56 UTC 2019-11-11
Import patches-unapplied version 4.5.2+dfsg.1-4 to debian/sid

Author: Ben Finney
Author Date: 2019-11-10 23:20:28 UTC

Import patches-unapplied version 4.5.2+dfsg.1-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 094b95e51d1f5606de1c354925782595c9f04308

New changelog entries:
  * Urgency “high” to restore dependency for other Python 2 packages.
    See bug#937665 discussion.
  * Build Python 2 and PyPy 2 binary packages.
    These still have reverse dependencies, during the Python 2 removal.
  * Exercise Python 2 and PyPy 2 packages in autopkgtest.

applied/debian/sid 2019-11-11 04:37:56 UTC 2019-11-11
Import patches-applied version 4.5.2+dfsg.1-4 to applied/debian/sid

Author: Ben Finney
Author Date: 2019-11-10 23:20:28 UTC

Import patches-applied version 4.5.2+dfsg.1-4 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 92e2bf040fde3c56f785a77ad2f25967985a345f
Unapplied parent: 5ec99a7ea3808b5200e3abac7c9c8e181f85c00e

New changelog entries:
  * Urgency “high” to restore dependency for other Python 2 packages.
    See bug#937665 discussion.
  * Build Python 2 and PyPy 2 binary packages.
    These still have reverse dependencies, during the Python 2 removal.
  * Exercise Python 2 and PyPy 2 packages in autopkgtest.

ubuntu/disco-devel 2019-01-25 04:38:50 UTC 2019-01-25
Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2019-01-25 00:58:58 UTC

Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9139188d621341609cea546616e4b9ac2d995f28

New changelog entries:
  * The “وليد أبوالخير‎‎ (Waleed Sami Abulkhair)” release.
  * New upstream version.
    Highlights since previous release:
    * Upstream development hosting moved.
    * Namespace packages are supported on Python 3.7, where they used to
      cause TypeErrors about path being None.
    * Extend supported Python versions to include Python 3.8.
  * Update publication years for Debian packaging in copyright notices.
  * Update package source documentation for standard packaging tools.
  * debian/repack, debian/source_package_build.bash:
    * Remove unused custom ‘repack’ program.
  * Declare AutoPkgTest dependency on all relevant CPython packages.
    Closes: bug#915133. Thanks to Paul Gevers for the report.
  * Update Lintian override for new Python-version-specific filenames.
  * Declare “Standards-Version: 4.3.0”. No additional changes required.
  * Record upstream metadata in DEP-12 document.

applied/debian/buster 2019-01-25 04:38:50 UTC 2019-01-25
Import patches-applied version 4.5.2+dfsg.1-1 to applied/debian/sid

Author: Ben Finney
Author Date: 2019-01-25 00:58:58 UTC

Import patches-applied version 4.5.2+dfsg.1-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: bd2bbc7178a741792d748ec2bc8a9a9d2c291c0a
Unapplied parent: a998d483f1dcbe73ba57d0401bd2cdecafa3fdb5

New changelog entries:
  * The “وليد أبوالخير‎‎ (Waleed Sami Abulkhair)” release.
  * New upstream version.
    Highlights since previous release:
    * Upstream development hosting moved.
    * Namespace packages are supported on Python 3.7, where they used to
      cause TypeErrors about path being None.
    * Extend supported Python versions to include Python 3.8.
  * Update publication years for Debian packaging in copyright notices.
  * Update package source documentation for standard packaging tools.
  * debian/repack, debian/source_package_build.bash:
    * Remove unused custom ‘repack’ program.
  * Declare AutoPkgTest dependency on all relevant CPython packages.
    Closes: bug#915133. Thanks to Paul Gevers for the report.
  * Update Lintian override for new Python-version-specific filenames.
  * Declare “Standards-Version: 4.3.0”. No additional changes required.
  * Record upstream metadata in DEP-12 document.

debian/buster 2019-01-25 04:38:50 UTC 2019-01-25
Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2019-01-25 00:58:58 UTC

Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9139188d621341609cea546616e4b9ac2d995f28

New changelog entries:
  * The “وليد أبوالخير‎‎ (Waleed Sami Abulkhair)” release.
  * New upstream version.
    Highlights since previous release:
    * Upstream development hosting moved.
    * Namespace packages are supported on Python 3.7, where they used to
      cause TypeErrors about path being None.
    * Extend supported Python versions to include Python 3.8.
  * Update publication years for Debian packaging in copyright notices.
  * Update package source documentation for standard packaging tools.
  * debian/repack, debian/source_package_build.bash:
    * Remove unused custom ‘repack’ program.
  * Declare AutoPkgTest dependency on all relevant CPython packages.
    Closes: bug#915133. Thanks to Paul Gevers for the report.
  * Update Lintian override for new Python-version-specific filenames.
  * Declare “Standards-Version: 4.3.0”. No additional changes required.
  * Record upstream metadata in DEP-12 document.

ubuntu/eoan-devel 2019-01-25 04:38:50 UTC 2019-01-25
Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2019-01-25 00:58:58 UTC

Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9139188d621341609cea546616e4b9ac2d995f28

New changelog entries:
  * The “وليد أبوالخير‎‎ (Waleed Sami Abulkhair)” release.
  * New upstream version.
    Highlights since previous release:
    * Upstream development hosting moved.
    * Namespace packages are supported on Python 3.7, where they used to
      cause TypeErrors about path being None.
    * Extend supported Python versions to include Python 3.8.
  * Update publication years for Debian packaging in copyright notices.
  * Update package source documentation for standard packaging tools.
  * debian/repack, debian/source_package_build.bash:
    * Remove unused custom ‘repack’ program.
  * Declare AutoPkgTest dependency on all relevant CPython packages.
    Closes: bug#915133. Thanks to Paul Gevers for the report.
  * Update Lintian override for new Python-version-specific filenames.
  * Declare “Standards-Version: 4.3.0”. No additional changes required.
  * Record upstream metadata in DEP-12 document.

ubuntu/eoan 2019-01-25 04:38:50 UTC 2019-01-25
Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2019-01-25 00:58:58 UTC

Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9139188d621341609cea546616e4b9ac2d995f28

New changelog entries:
  * The “وليد أبوالخير‎‎ (Waleed Sami Abulkhair)” release.
  * New upstream version.
    Highlights since previous release:
    * Upstream development hosting moved.
    * Namespace packages are supported on Python 3.7, where they used to
      cause TypeErrors about path being None.
    * Extend supported Python versions to include Python 3.8.
  * Update publication years for Debian packaging in copyright notices.
  * Update package source documentation for standard packaging tools.
  * debian/repack, debian/source_package_build.bash:
    * Remove unused custom ‘repack’ program.
  * Declare AutoPkgTest dependency on all relevant CPython packages.
    Closes: bug#915133. Thanks to Paul Gevers for the report.
  * Update Lintian override for new Python-version-specific filenames.
  * Declare “Standards-Version: 4.3.0”. No additional changes required.
  * Record upstream metadata in DEP-12 document.

ubuntu/disco 2019-01-25 04:38:50 UTC 2019-01-25
Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2019-01-25 00:58:58 UTC

Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9139188d621341609cea546616e4b9ac2d995f28

New changelog entries:
  * The “وليد أبوالخير‎‎ (Waleed Sami Abulkhair)” release.
  * New upstream version.
    Highlights since previous release:
    * Upstream development hosting moved.
    * Namespace packages are supported on Python 3.7, where they used to
      cause TypeErrors about path being None.
    * Extend supported Python versions to include Python 3.8.
  * Update publication years for Debian packaging in copyright notices.
  * Update package source documentation for standard packaging tools.
  * debian/repack, debian/source_package_build.bash:
    * Remove unused custom ‘repack’ program.
  * Declare AutoPkgTest dependency on all relevant CPython packages.
    Closes: bug#915133. Thanks to Paul Gevers for the report.
  * Update Lintian override for new Python-version-specific filenames.
  * Declare “Standards-Version: 4.3.0”. No additional changes required.
  * Record upstream metadata in DEP-12 document.

ubuntu/disco-proposed 2019-01-25 04:38:50 UTC 2019-01-25
Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2019-01-25 00:58:58 UTC

Import patches-unapplied version 4.5.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9139188d621341609cea546616e4b9ac2d995f28

New changelog entries:
  * The “وليد أبوالخير‎‎ (Waleed Sami Abulkhair)” release.
  * New upstream version.
    Highlights since previous release:
    * Upstream development hosting moved.
    * Namespace packages are supported on Python 3.7, where they used to
      cause TypeErrors about path being None.
    * Extend supported Python versions to include Python 3.8.
  * Update publication years for Debian packaging in copyright notices.
  * Update package source documentation for standard packaging tools.
  * debian/repack, debian/source_package_build.bash:
    * Remove unused custom ‘repack’ program.
  * Declare AutoPkgTest dependency on all relevant CPython packages.
    Closes: bug#915133. Thanks to Paul Gevers for the report.
  * Update Lintian override for new Python-version-specific filenames.
  * Declare “Standards-Version: 4.3.0”. No additional changes required.
  * Record upstream metadata in DEP-12 document.

ubuntu/cosmic-devel 2018-07-15 10:34:51 UTC 2018-07-15
Import patches-unapplied version 4.5.1+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2018-07-15 02:25:30 UTC

Import patches-unapplied version 4.5.1+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 281d8984f346dadc249968b0cfea74991ae27a4f

New changelog entries:
  * The “Ahmedur Rashid Chowdhury” release.
  * New upstream version.
    Highlights since previous release: none documented.
  * Consolidate the ‘override_dh_auto_build’ packaging target.
  * Use a null command for ‘clean’ during ‘Git-BuildPackage’.
  * Correct build dependencies for both arch-dependent and -independent.
    Closes: bug#901114. Thanks to Santiago Vila for the report.
  * Declare “Standards-Version: 4.1.5”.
  * Specify current URL for upstream source repository.
  * Improve consistency of copyright grant in Debian packaging.
  * Remove ‘get-orig-source’ and ‘get-packaged-orig-source’ targets.
    These are no longer mentioned in Debian Policy 4.1.4 and later.
  * Use standard Debian packaging tools to repack upstream source.
  * Convert UScan configuration to format version 4.
  * Remove specification of minimum Python versions.
    These are now satisfied by all currently supported Debian releases.

ubuntu/cosmic 2018-07-15 10:34:51 UTC 2018-07-15
Import patches-unapplied version 4.5.1+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2018-07-15 02:25:30 UTC

Import patches-unapplied version 4.5.1+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 281d8984f346dadc249968b0cfea74991ae27a4f

New changelog entries:
  * The “Ahmedur Rashid Chowdhury” release.
  * New upstream version.
    Highlights since previous release: none documented.
  * Consolidate the ‘override_dh_auto_build’ packaging target.
  * Use a null command for ‘clean’ during ‘Git-BuildPackage’.
  * Correct build dependencies for both arch-dependent and -independent.
    Closes: bug#901114. Thanks to Santiago Vila for the report.
  * Declare “Standards-Version: 4.1.5”.
  * Specify current URL for upstream source repository.
  * Improve consistency of copyright grant in Debian packaging.
  * Remove ‘get-orig-source’ and ‘get-packaged-orig-source’ targets.
    These are no longer mentioned in Debian Policy 4.1.4 and later.
  * Use standard Debian packaging tools to repack upstream source.
  * Convert UScan configuration to format version 4.
  * Remove specification of minimum Python versions.
    These are now satisfied by all currently supported Debian releases.

ubuntu/cosmic-proposed 2018-07-15 10:34:51 UTC 2018-07-15
Import patches-unapplied version 4.5.1+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2018-07-15 02:25:30 UTC

Import patches-unapplied version 4.5.1+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 281d8984f346dadc249968b0cfea74991ae27a4f

New changelog entries:
  * The “Ahmedur Rashid Chowdhury” release.
  * New upstream version.
    Highlights since previous release: none documented.
  * Consolidate the ‘override_dh_auto_build’ packaging target.
  * Use a null command for ‘clean’ during ‘Git-BuildPackage’.
  * Correct build dependencies for both arch-dependent and -independent.
    Closes: bug#901114. Thanks to Santiago Vila for the report.
  * Declare “Standards-Version: 4.1.5”.
  * Specify current URL for upstream source repository.
  * Improve consistency of copyright grant in Debian packaging.
  * Remove ‘get-orig-source’ and ‘get-packaged-orig-source’ targets.
    These are no longer mentioned in Debian Policy 4.1.4 and later.
  * Use standard Debian packaging tools to repack upstream source.
  * Convert UScan configuration to format version 4.
  * Remove specification of minimum Python versions.
    These are now satisfied by all currently supported Debian releases.

importer/ubuntu/pristine-tar 2018-04-05 13:04:13 UTC 2018-04-05
pristine-tar data for python-coverage_4.5+dfsg.1.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-04-05 13:04:13 UTC

pristine-tar data for python-coverage_4.5+dfsg.1.orig.tar.gz

importer/debian/pristine-tar 2018-04-05 12:51:13 UTC 2018-04-05
pristine-tar data for python-coverage_4.5+dfsg.1.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-04-05 12:51:13 UTC

pristine-tar data for python-coverage_4.5+dfsg.1.orig.tar.gz

ubuntu/bionic-devel 2018-02-21 10:36:29 UTC 2018-02-21
Import patches-unapplied version 4.5+dfsg.1-3 to debian/sid

Author: Ben Finney
Author Date: 2018-02-21 06:33:50 UTC

Import patches-unapplied version 4.5+dfsg.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dab373fea8d3d741908b278af498f03c10617619

New changelog entries:
  * The “Simona Monti” release.
  * Document copyright information for bundled files in source:
    * jquery.hotkeys.js
    * jquery.isonscreen.js
    Closes: bug#890578. Thanks to Chris Lamb for the report.

ubuntu/bionic 2018-02-21 10:36:29 UTC 2018-02-21
Import patches-unapplied version 4.5+dfsg.1-3 to debian/sid

Author: Ben Finney
Author Date: 2018-02-21 06:33:50 UTC

Import patches-unapplied version 4.5+dfsg.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dab373fea8d3d741908b278af498f03c10617619

New changelog entries:
  * The “Simona Monti” release.
  * Document copyright information for bundled files in source:
    * jquery.hotkeys.js
    * jquery.isonscreen.js
    Closes: bug#890578. Thanks to Chris Lamb for the report.

ubuntu/bionic-proposed 2018-02-21 10:36:29 UTC 2018-02-21
Import patches-unapplied version 4.5+dfsg.1-3 to debian/sid

Author: Ben Finney
Author Date: 2018-02-21 06:33:50 UTC

Import patches-unapplied version 4.5+dfsg.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dab373fea8d3d741908b278af498f03c10617619

New changelog entries:
  * The “Simona Monti” release.
  * Document copyright information for bundled files in source:
    * jquery.hotkeys.js
    * jquery.isonscreen.js
    Closes: bug#890578. Thanks to Chris Lamb for the report.

ubuntu/artful-devel 2017-08-05 09:49:06 UTC 2017-08-05
Import patches-unapplied version 4.3.4+dfsg.1-1build1 to ubuntu/artful-proposed

Author: Michael Hudson-Doyle
Author Date: 2017-08-05 09:28:58 UTC

Import patches-unapplied version 4.3.4+dfsg.1-1build1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: badbfb2442d2ddf50c2ee41bea8deafa38c97a22

New changelog entries:
  * No change rebuild to drop Python 3.5 support.

ubuntu/artful 2017-08-05 09:49:06 UTC 2017-08-05
Import patches-unapplied version 4.3.4+dfsg.1-1build1 to ubuntu/artful-proposed

Author: Michael Hudson-Doyle
Author Date: 2017-08-05 09:28:58 UTC

Import patches-unapplied version 4.3.4+dfsg.1-1build1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: badbfb2442d2ddf50c2ee41bea8deafa38c97a22

New changelog entries:
  * No change rebuild to drop Python 3.5 support.

ubuntu/artful-proposed 2017-08-05 09:49:06 UTC 2017-08-05
Import patches-unapplied version 4.3.4+dfsg.1-1build1 to ubuntu/artful-proposed

Author: Michael Hudson-Doyle
Author Date: 2017-08-05 09:28:58 UTC

Import patches-unapplied version 4.3.4+dfsg.1-1build1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: badbfb2442d2ddf50c2ee41bea8deafa38c97a22

New changelog entries:
  * No change rebuild to drop Python 3.5 support.

ubuntu/zesty-devel 2016-09-24 16:24:01 UTC 2016-09-24
Import patches-unapplied version 4.2+dfsg.1-2 to debian/sid

Author: Ben Finney
Author Date: 2016-09-24 05:03:52 UTC

Import patches-unapplied version 4.2+dfsg.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 41da4afb02afe8a8a2f141fe010bb5e8212b983a

New changelog entries:
  * The “Niloy Neel” release.
  * debian/*:
    * Update my email address for Debian work.
  * debian/README.source:
    * Much more detail about how to build the source package from VCS.
  * Specify current VCS for Debian packaging work.
  * Convert UScan configuration to format version 4.
  * Add invocations of command-line programs to autopkgtests.
    Closes: bug#827464. Thanks to Barry Warsaw for the report.
  * Configure Sphinx build system to allow import of code during build.
    This allows the ‘autodoc’ extension to generate API documentation.

applied/debian/stretch 2016-09-24 16:24:01 UTC 2016-09-24
Import patches-applied version 4.2+dfsg.1-2 to applied/debian/sid

Author: Ben Finney
Author Date: 2016-09-24 05:03:52 UTC

Import patches-applied version 4.2+dfsg.1-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: d609a0405e65c8bb67d3f0253d49c4894d960e08
Unapplied parent: 42f8f5ebb5e147b8a2701f747f4b0109efe1d68b

New changelog entries:
  * The “Niloy Neel” release.
  * debian/*:
    * Update my email address for Debian work.
  * debian/README.source:
    * Much more detail about how to build the source package from VCS.
  * Specify current VCS for Debian packaging work.
  * Convert UScan configuration to format version 4.
  * Add invocations of command-line programs to autopkgtests.
    Closes: bug#827464. Thanks to Barry Warsaw for the report.
  * Configure Sphinx build system to allow import of code during build.
    This allows the ‘autodoc’ extension to generate API documentation.

ubuntu/zesty 2016-09-24 16:24:01 UTC 2016-09-24
Import patches-unapplied version 4.2+dfsg.1-2 to debian/sid

Author: Ben Finney
Author Date: 2016-09-24 05:03:52 UTC

Import patches-unapplied version 4.2+dfsg.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 41da4afb02afe8a8a2f141fe010bb5e8212b983a

New changelog entries:
  * The “Niloy Neel” release.
  * debian/*:
    * Update my email address for Debian work.
  * debian/README.source:
    * Much more detail about how to build the source package from VCS.
  * Specify current VCS for Debian packaging work.
  * Convert UScan configuration to format version 4.
  * Add invocations of command-line programs to autopkgtests.
    Closes: bug#827464. Thanks to Barry Warsaw for the report.
  * Configure Sphinx build system to allow import of code during build.
    This allows the ‘autodoc’ extension to generate API documentation.

ubuntu/zesty-proposed 2016-09-24 16:24:01 UTC 2016-09-24
Import patches-unapplied version 4.2+dfsg.1-2 to debian/sid

Author: Ben Finney
Author Date: 2016-09-24 05:03:52 UTC

Import patches-unapplied version 4.2+dfsg.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 41da4afb02afe8a8a2f141fe010bb5e8212b983a

New changelog entries:
  * The “Niloy Neel” release.
  * debian/*:
    * Update my email address for Debian work.
  * debian/README.source:
    * Much more detail about how to build the source package from VCS.
  * Specify current VCS for Debian packaging work.
  * Convert UScan configuration to format version 4.
  * Add invocations of command-line programs to autopkgtests.
    Closes: bug#827464. Thanks to Barry Warsaw for the report.
  * Configure Sphinx build system to allow import of code during build.
    This allows the ‘autodoc’ extension to generate API documentation.

debian/stretch 2016-09-24 16:24:01 UTC 2016-09-24
Import patches-unapplied version 4.2+dfsg.1-2 to debian/sid

Author: Ben Finney
Author Date: 2016-09-24 05:03:52 UTC

Import patches-unapplied version 4.2+dfsg.1-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 41da4afb02afe8a8a2f141fe010bb5e8212b983a

New changelog entries:
  * The “Niloy Neel” release.
  * debian/*:
    * Update my email address for Debian work.
  * debian/README.source:
    * Much more detail about how to build the source package from VCS.
  * Specify current VCS for Debian packaging work.
  * Convert UScan configuration to format version 4.
  * Add invocations of command-line programs to autopkgtests.
    Closes: bug#827464. Thanks to Barry Warsaw for the report.
  * Configure Sphinx build system to allow import of code during build.
    This allows the ‘autodoc’ extension to generate API documentation.

ubuntu/yakkety-devel 2016-08-11 22:27:20 UTC 2016-08-11
Import patches-unapplied version 4.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2016-08-08 20:05:28 UTC

Import patches-unapplied version 4.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 045cd6958646ad6065af11dc48485af3a62e9ab1

New changelog entries:
  * The “Ananta Bijoy Das” release.
  * New upstream version.
    Highlights since previous release:
    * The ‘coverage combine’ command now ignores an existing ‘.coverage’
      data file.
    * Now it is an error to use ‘--concurrency=multiprocessing’ and other
      run-affecting options on the command line. (Previously, the options
      didn’t apply to the subprocesses, but there was no indication.)
    * Better support for multiprocessing and combining data.
  * debian/*.lintian-overrides:
    * Override false-positive Lintian warnings about Coverage.py being an
      application.
  * debian/control:
    * Declare the package for upstream documentation.
    * Add dependencies on the documentation package.
  * debian/control, debian/rules:
    * Enable build of upstream documentation using Sphinx.
  * debian/python-coverage-doc.{docs, doc-base}:
    * Install the upstream documentation.
  * debian/tests/control:
    * Test that the documentation is correctly installed as HTML.

ubuntu/yakkety-proposed 2016-08-11 22:27:20 UTC 2016-08-11
Import patches-unapplied version 4.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2016-08-08 20:05:28 UTC

Import patches-unapplied version 4.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 045cd6958646ad6065af11dc48485af3a62e9ab1

New changelog entries:
  * The “Ananta Bijoy Das” release.
  * New upstream version.
    Highlights since previous release:
    * The ‘coverage combine’ command now ignores an existing ‘.coverage’
      data file.
    * Now it is an error to use ‘--concurrency=multiprocessing’ and other
      run-affecting options on the command line. (Previously, the options
      didn’t apply to the subprocesses, but there was no indication.)
    * Better support for multiprocessing and combining data.
  * debian/*.lintian-overrides:
    * Override false-positive Lintian warnings about Coverage.py being an
      application.
  * debian/control:
    * Declare the package for upstream documentation.
    * Add dependencies on the documentation package.
  * debian/control, debian/rules:
    * Enable build of upstream documentation using Sphinx.
  * debian/python-coverage-doc.{docs, doc-base}:
    * Install the upstream documentation.
  * debian/tests/control:
    * Test that the documentation is correctly installed as HTML.

ubuntu/yakkety 2016-08-11 22:27:20 UTC 2016-08-11
Import patches-unapplied version 4.2+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2016-08-08 20:05:28 UTC

Import patches-unapplied version 4.2+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 045cd6958646ad6065af11dc48485af3a62e9ab1

New changelog entries:
  * The “Ananta Bijoy Das” release.
  * New upstream version.
    Highlights since previous release:
    * The ‘coverage combine’ command now ignores an existing ‘.coverage’
      data file.
    * Now it is an error to use ‘--concurrency=multiprocessing’ and other
      run-affecting options on the command line. (Previously, the options
      didn’t apply to the subprocesses, but there was no indication.)
    * Better support for multiprocessing and combining data.
  * debian/*.lintian-overrides:
    * Override false-positive Lintian warnings about Coverage.py being an
      application.
  * debian/control:
    * Declare the package for upstream documentation.
    * Add dependencies on the documentation package.
  * debian/control, debian/rules:
    * Enable build of upstream documentation using Sphinx.
  * debian/python-coverage-doc.{docs, doc-base}:
    * Install the upstream documentation.
  * debian/tests/control:
    * Test that the documentation is correctly installed as HTML.

ubuntu/xenial-devel 2016-01-18 23:15:09 UTC 2016-01-18
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu7 to ubuntu/xenial-proposed

Author: Matthias Klose
Author Date: 2016-01-18 20:42:57 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu7 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 9409d15bd27a727d26e354ffbaa76e53f26580da

New changelog entries:
  * No-change rebuild to drop python3.4 support.

ubuntu/xenial-proposed 2016-01-18 23:15:09 UTC 2016-01-18
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu7 to ubuntu/xenial-proposed

Author: Matthias Klose
Author Date: 2016-01-18 20:42:57 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu7 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 9409d15bd27a727d26e354ffbaa76e53f26580da

New changelog entries:
  * No-change rebuild to drop python3.4 support.

ubuntu/xenial 2016-01-18 23:15:09 UTC 2016-01-18
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu7 to ubuntu/xenial-proposed

Author: Matthias Klose
Author Date: 2016-01-18 20:42:57 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu7 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 9409d15bd27a727d26e354ffbaa76e53f26580da

New changelog entries:
  * No-change rebuild to drop python3.4 support.

ubuntu/wily 2015-07-22 21:38:38 UTC 2015-07-22
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu3 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-07-22 21:31:58 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 2503f4da1540f4b9b6eb1c912502b3e0087b6672

New changelog entries:
  * No-change rebuild for python3.5 transition

ubuntu/wily-devel 2015-07-22 21:38:38 UTC 2015-07-22
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu3 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-07-22 21:31:58 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 2503f4da1540f4b9b6eb1c912502b3e0087b6672

New changelog entries:
  * No-change rebuild for python3.5 transition

ubuntu/wily-proposed 2015-07-22 21:38:38 UTC 2015-07-22
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu3 to ubuntu/wily-proposed

Author: Steve Langasek
Author Date: 2015-07-22 21:31:58 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 2503f4da1540f4b9b6eb1c912502b3e0087b6672

New changelog entries:
  * No-change rebuild for python3.5 transition

ubuntu/utopic-devel 2014-03-23 09:13:21 UTC 2014-03-23
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-23 09:04:23 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: ea571788cdcd363698afcb683d71f6c23f0d0792

New changelog entries:
  * No-change rebuild to drop support for Python 3.3.

ubuntu/trusty-devel 2014-03-23 09:13:21 UTC 2014-03-23
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-23 09:04:23 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: ea571788cdcd363698afcb683d71f6c23f0d0792

New changelog entries:
  * No-change rebuild to drop support for Python 3.3.

ubuntu/trusty-proposed 2014-03-23 09:13:21 UTC 2014-03-23
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-23 09:04:23 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: ea571788cdcd363698afcb683d71f6c23f0d0792

New changelog entries:
  * No-change rebuild to drop support for Python 3.3.

ubuntu/utopic 2014-03-23 09:13:21 UTC 2014-03-23
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-23 09:04:23 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: ea571788cdcd363698afcb683d71f6c23f0d0792

New changelog entries:
  * No-change rebuild to drop support for Python 3.3.

ubuntu/trusty 2014-03-23 09:13:21 UTC 2014-03-23
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-23 09:04:23 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: ea571788cdcd363698afcb683d71f6c23f0d0792

New changelog entries:
  * No-change rebuild to drop support for Python 3.3.

ubuntu/vivid-devel 2014-03-23 09:13:21 UTC 2014-03-23
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-23 09:04:23 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: ea571788cdcd363698afcb683d71f6c23f0d0792

New changelog entries:
  * No-change rebuild to drop support for Python 3.3.

ubuntu/vivid 2014-03-23 09:13:21 UTC 2014-03-23
Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Author: Matthias Klose
Author Date: 2014-03-23 09:04:23 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: ea571788cdcd363698afcb683d71f6c23f0d0792

New changelog entries:
  * No-change rebuild to drop support for Python 3.3.

debian/jessie 2014-03-07 04:21:10 UTC 2014-03-07
Import patches-unapplied version 3.7.1+dfsg.1-1 to debian/sid

Author: Ben Finney
Author Date: 2014-03-05 02:14:27 UTC

Import patches-unapplied version 3.7.1+dfsg.1-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e80f31d947114d85bab5de129b17dbbd11f2ce24

New changelog entries:
  * The “Ziauddin Yousafzai” release.
  * Urgency “medium” because we fix a bug of severity “serious”.
  * New upstream version.
    (Closes: bug#735359)
  * debian/patches/:
    + Patches incorporated upstream:
      * 02.use-system-ecmascript-libraries.patch
      Remaining patch files re-sequenced contiguously.
    + Add editor hints to patch files.
  * debian/repack:
    + Correct quoting of parameters (quote parameters used as filesystem
      entry names, don't quote parameters used as numbers).
  * debian/rules:
    + Explicitly replace shebang for programs needing default Python
      interpreter (Closes: bug#736121).
    + Correct generation of Python version strings for object code
      filenames (Closes: bug#740053).
      Thanks to Dmitry Shachnev for the bug report and patch.

applied/debian/jessie 2014-03-07 04:21:10 UTC 2014-03-07
Import patches-applied version 3.7.1+dfsg.1-1 to applied/debian/sid

Author: Ben Finney
Author Date: 2014-03-05 02:14:27 UTC

Import patches-applied version 3.7.1+dfsg.1-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c199a7e906876940dfd87072a208a2cf693b097d
Unapplied parent: 43da1f67d2603836837b1f69a811a36d8986b5a3

New changelog entries:
  * The “Ziauddin Yousafzai” release.
  * Urgency “medium” because we fix a bug of severity “serious”.
  * New upstream version.
    (Closes: bug#735359)
  * debian/patches/:
    + Patches incorporated upstream:
      * 02.use-system-ecmascript-libraries.patch
      Remaining patch files re-sequenced contiguously.
    + Add editor hints to patch files.
  * debian/repack:
    + Correct quoting of parameters (quote parameters used as filesystem
      entry names, don't quote parameters used as numbers).
  * debian/rules:
    + Explicitly replace shebang for programs needing default Python
      interpreter (Closes: bug#736121).
    + Correct generation of Python version strings for object code
      filenames (Closes: bug#740053).
      Thanks to Dmitry Shachnev for the bug report and patch.

ubuntu/saucy-devel 2013-09-26 09:08:22 UTC 2013-09-26
Import patches-unapplied version 3.6-0ubuntu6 to ubuntu/saucy-proposed

Author: Andrew Starr-Bochicchio
Author Date: 2013-09-19 20:47:07 UTC

Import patches-unapplied version 3.6-0ubuntu6 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: a55d4fbf24b342441bae75310a33a1f4d1ed4fa8

New changelog entries:
  * 02.use-system-js-libraries.patch: Update to deal with the
    removal of jquery.isonscreen.js and jquery.hotkeys.js
  * Add libjs-jquery-hotkeys and libjs-jquery-isonscreen to Suggests
    (not Depends as they are not in main).
  * debian/rules: Make the override_dh_auto_build target depend on
    the remove-bundled-libraries target so the bundled JavaScript
    libraries are removed no matter which arch the package is being
    built on (LP: #1215175).

ubuntu/saucy 2013-09-26 09:08:22 UTC 2013-09-26
Import patches-unapplied version 3.6-0ubuntu6 to ubuntu/saucy-proposed

Author: Andrew Starr-Bochicchio
Author Date: 2013-09-19 20:47:07 UTC

Import patches-unapplied version 3.6-0ubuntu6 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: a55d4fbf24b342441bae75310a33a1f4d1ed4fa8

New changelog entries:
  * 02.use-system-js-libraries.patch: Update to deal with the
    removal of jquery.isonscreen.js and jquery.hotkeys.js
  * Add libjs-jquery-hotkeys and libjs-jquery-isonscreen to Suggests
    (not Depends as they are not in main).
  * debian/rules: Make the override_dh_auto_build target depend on
    the remove-bundled-libraries target so the bundled JavaScript
    libraries are removed no matter which arch the package is being
    built on (LP: #1215175).

ubuntu/saucy-proposed 2013-09-26 09:08:22 UTC 2013-09-26
Import patches-unapplied version 3.6-0ubuntu6 to ubuntu/saucy-proposed

Author: Andrew Starr-Bochicchio
Author Date: 2013-09-19 20:47:07 UTC

Import patches-unapplied version 3.6-0ubuntu6 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: a55d4fbf24b342441bae75310a33a1f4d1ed4fa8

New changelog entries:
  * 02.use-system-js-libraries.patch: Update to deal with the
    removal of jquery.isonscreen.js and jquery.hotkeys.js
  * Add libjs-jquery-hotkeys and libjs-jquery-isonscreen to Suggests
    (not Depends as they are not in main).
  * debian/rules: Make the override_dh_auto_build target depend on
    the remove-bundled-libraries target so the bundled JavaScript
    libraries are removed no matter which arch the package is being
    built on (LP: #1215175).

ubuntu/raring-proposed 2013-03-22 10:33:16 UTC 2013-03-22
Import patches-unapplied version 3.6-0ubuntu2 to ubuntu/raring-proposed

Author: Dmitry Shachnev
Author Date: 2013-03-19 15:25:38 UTC

Import patches-unapplied version 3.6-0ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 8d4cb302fb825d1282eefd70a739a39d91dc9780

New changelog entries:
  * Fix a typo in 02.use-system-js-libraries.patch that was causing
    NameErrors (LP: #1109090).

ubuntu/raring 2013-03-22 10:33:16 UTC 2013-03-22
Import patches-unapplied version 3.6-0ubuntu2 to ubuntu/raring-proposed

Author: Dmitry Shachnev
Author Date: 2013-03-19 15:25:38 UTC

Import patches-unapplied version 3.6-0ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 8d4cb302fb825d1282eefd70a739a39d91dc9780

New changelog entries:
  * Fix a typo in 02.use-system-js-libraries.patch that was causing
    NameErrors (LP: #1109090).

ubuntu/raring-devel 2013-03-22 10:33:16 UTC 2013-03-22
Import patches-unapplied version 3.6-0ubuntu2 to ubuntu/raring-proposed

Author: Dmitry Shachnev
Author Date: 2013-03-19 15:25:38 UTC

Import patches-unapplied version 3.6-0ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 8d4cb302fb825d1282eefd70a739a39d91dc9780

New changelog entries:
  * Fix a typo in 02.use-system-js-libraries.patch that was causing
    NameErrors (LP: #1109090).

ubuntu/quantal 2012-05-31 21:12:49 UTC 2012-05-31
Import patches-unapplied version 3.4-3ubuntu1 to ubuntu/quantal

Author: Andres Rodriguez
Author Date: 2012-05-31 21:02:47 UTC

Import patches-unapplied version 3.4-3ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 7f0c2585c460d8f4ac05c6ea55c19af9b0dec184

New changelog entries:
  * Merge from Debian testing (LP: #1007137). Remaining changes:
    - debian/control: Suggests libjs-jquery, libjs-jquery-tablesorter.

ubuntu/quantal-devel 2012-05-31 21:12:49 UTC 2012-05-31
Import patches-unapplied version 3.4-3ubuntu1 to ubuntu/quantal

Author: Andres Rodriguez
Author Date: 2012-05-31 21:02:47 UTC

Import patches-unapplied version 3.4-3ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 7f0c2585c460d8f4ac05c6ea55c19af9b0dec184

New changelog entries:
  * Merge from Debian testing (LP: #1007137). Remaining changes:
    - debian/control: Suggests libjs-jquery, libjs-jquery-tablesorter.

debian/wheezy 2012-05-10 09:24:07 UTC 2012-05-10
Import patches-unapplied version 3.4-3 to debian/sid

Author: Ben Finney
Author Date: 2012-05-10 00:21:16 UTC

Import patches-unapplied version 3.4-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e90c124a85d2e869d6c2ea4c7222460e8783cf9d

New changelog entries:
  * debian/rules:
    Revert mistaken method of consolidating doc directories, which doesn't
    work because it asks ‘dpkg’ to violate Policy (Closes: bug#672224).

applied/debian/wheezy 2012-05-10 09:24:07 UTC 2012-05-10
Import patches-applied version 3.4-3 to applied/debian/sid

Author: Ben Finney
Author Date: 2012-05-10 00:21:16 UTC

Import patches-applied version 3.4-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: cc1a07a9d02900abaa9a19d805e7954c8d69da1a
Unapplied parent: d354cd6505bd022ae6d0a42391e8d9a5e07969ac

New changelog entries:
  * debian/rules:
    Revert mistaken method of consolidating doc directories, which doesn't
    work because it asks ‘dpkg’ to violate Policy (Closes: bug#672224).

ubuntu/precise 2012-04-23 10:33:41 UTC 2012-04-23
Import patches-unapplied version 3.4-1ubuntu1 to ubuntu/precise

Author: Dave Walker
Author Date: 2012-04-23 09:38:29 UTC

Import patches-unapplied version 3.4-1ubuntu1 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: f404563bb20ced9839a92e15ab37f059263f3803

New changelog entries:
  * Bump version number, introducing Ubuntu delta from last upload
    which satisfied requirements for python-coverage MIR of dropping
    libjs-jquery to Suggests. LP: #981101

ubuntu/precise-devel 2012-04-23 10:33:41 UTC 2012-04-23
Import patches-unapplied version 3.4-1ubuntu1 to ubuntu/precise

Author: Dave Walker
Author Date: 2012-04-23 09:38:29 UTC

Import patches-unapplied version 3.4-1ubuntu1 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: f404563bb20ced9839a92e15ab37f059263f3803

New changelog entries:
  * Bump version number, introducing Ubuntu delta from last upload
    which satisfied requirements for python-coverage MIR of dropping
    libjs-jquery to Suggests. LP: #981101

ubuntu/oneiric 2011-07-27 06:23:25 UTC 2011-07-27
Import patches-unapplied version 3.4-1 to debian/sid

Author: Ben Finney
Author Date: 2011-07-27 06:23:25 UTC

Import patches-unapplied version 3.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bfc4bedf37e4f9f7c77342ad40d3082ac1863602

New changelog entries:
  * The “Mravaljamier” release.
  * New upstream version (Closes: bug#600672).
    Primary user-visible changes:
    + Settings are now read from a .coveragerc file.
    + Enable coverage measurement when Python starts.
    + Support for Python 2.7 and 3.2 opcodes.
    + Finer control over what gets recorded or reported.
  * debian/preinst:
    + Remove: Squeeze is released, so we no longer need to maintain the
      special cleanup of ‘python-central’ mess.
  * debian/copyright:
    + Conform to current DEP-5 format.
    + Update with current copyright information.
  * debian/control:
    + Conform to ‘Standards-Version: 3.9.2’. No additional changes required.
  * debian/control, debian/rules:
    + Switch to ‘dh_python2’ packaging helper.
    + Depend on ECMAScript libraries needed for HTML reports.
    + Remove duplicate ECMAScript libraries.
  * debian/patches/01.refactor-handling-static-files.patch,
    debian/patches/02.use-system-js-libraries.patch:
    + Use the Debian system ECMAScript libraries
      (Closes: bug#596212).

ubuntu/oneiric-devel 2011-07-27 06:23:25 UTC 2011-07-27
Import patches-unapplied version 3.4-1 to debian/sid

Author: Ben Finney
Author Date: 2011-07-27 06:23:25 UTC

Import patches-unapplied version 3.4-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bfc4bedf37e4f9f7c77342ad40d3082ac1863602

New changelog entries:
  * The “Mravaljamier” release.
  * New upstream version (Closes: bug#600672).
    Primary user-visible changes:
    + Settings are now read from a .coveragerc file.
    + Enable coverage measurement when Python starts.
    + Support for Python 2.7 and 3.2 opcodes.
    + Finer control over what gets recorded or reported.
  * debian/preinst:
    + Remove: Squeeze is released, so we no longer need to maintain the
      special cleanup of ‘python-central’ mess.
  * debian/copyright:
    + Conform to current DEP-5 format.
    + Update with current copyright information.
  * debian/control:
    + Conform to ‘Standards-Version: 3.9.2’. No additional changes required.
  * debian/control, debian/rules:
    + Switch to ‘dh_python2’ packaging helper.
    + Depend on ECMAScript libraries needed for HTML reports.
    + Remove duplicate ECMAScript libraries.
  * debian/patches/01.refactor-handling-static-files.patch,
    debian/patches/02.use-system-js-libraries.patch:
    + Use the Debian system ECMAScript libraries
      (Closes: bug#596212).

ubuntu/natty-devel 2010-10-20 15:04:50 UTC 2010-10-20
Import patches-unapplied version 3.2-1ubuntu1 to ubuntu/natty

Author: Bhavani Shankar
Author Date: 2010-10-20 14:55:31 UTC

Import patches-unapplied version 3.2-1ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: bfc4bedf37e4f9f7c77342ad40d3082ac1863602

New changelog entries:
  * Bump up pyversions to 2.7 to hopefully fix FTBFS

ubuntu/natty 2010-10-20 15:04:50 UTC 2010-10-20
Import patches-unapplied version 3.2-1ubuntu1 to ubuntu/natty

Author: Bhavani Shankar
Author Date: 2010-10-20 14:55:31 UTC

Import patches-unapplied version 3.2-1ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: bfc4bedf37e4f9f7c77342ad40d3082ac1863602

New changelog entries:
  * Bump up pyversions to 2.7 to hopefully fix FTBFS

ubuntu/maverick 2010-07-15 01:05:07 UTC 2010-07-15
Import patches-unapplied version 3.2-0ubuntu1 to ubuntu/maverick

Author: Robert Ancell
Author Date: 2010-07-15 00:37:20 UTC

Import patches-unapplied version 3.2-0ubuntu1 to ubuntu/maverick

Imported using git-ubuntu import.

Changelog parent: 6ef2cf18cea6101a13b2b75e85c9a028a08bb771

New changelog entries:
  * Package taken from Debian sponsorship queue: (LP: #395599)
    http://mentors.debian.net/cgi-bin/sponsor-pkglist?action=details;package=python-coverage
  [ Ben Finney ]
  * The “Artificial Conscience” release.
  * New upstream version. Primary user-visible changes:
    + Command-line interface re-worked with sub-commands.
    + Inspection now traverses egg packages.
    + Branch coverage recording and reporting.
    + New XML format for generated reports.
  * debian/control:
    + Remove Lars Wirzenius from all roles at his request.
    + Conform to ‘Standards-Version: 3.8.4’. No changes required.
  * debian/python-coverage.install, debian/python-coverage.manpages:
    + Use ‘dh_installman(1)’ to install man pages.
  * debian/control, debian/rules:
    + Add ‘python-coverage-dbg’ package for debugging symbols.
    + Use newer ‘debhelper’ to ensure automated build for all supported
      versions and for debug packages.
  * debian/copyright:
    + Update copyright information for latest upstream source.
  * debian/source/format:
    + Convert packaging to source format “3.0 (quilt)”.
  * debian/python-coverage.dirs:
    + Removed, the ‘/usr/bin/’ directory is created by ‘setup.py’.
  * debian/rules:
    + Remove, during ‘clean’ target, files that clobber upstream source.
    + Specify installation of Python package to ‘/usr/’ hierarchy (not
      default).
  * The “Rods and Cones” release.
  * New upstream version. Primary user-visible changes:
    + Remove tracer recursion limit.
    + Skip coverage of ‘coverage’ library code.
    + Run Python source files in “universal newline mode”.
  * debian/control:
    + Update email address for Lars Wirzenius.
    + Comply with ‘Standards-Version: 3.8.3’. No changes required.
    + Update ‘Homepage’ field.
    + Add ‘VCS-bzr’ and ‘VCS-Browser’ fields.
    + Build for all supported Python versions.
  * debian/README.source:
    + Remove, no longer applicable.
  * debian/pyversions:
    + Specify Python versions supported.
  * The “ladny” release.
  [ Ben Finney ]
  * New upstream version. Primary user-visible changes:
    + Major overhaul: refactored into a Python package, with some
      functionality implemented in C for speed.
    + Defaults to skipping measurement of standard library coverage.
    + HTML output now available, via ‘-b’ option.
    (Closes: bug#535764)
  * debian/watch:
    + Primary upstream source distribution channel is now the Cheese Shop.
    + Deal with crazy-arse version comparison semantics.
  * debian/control, debian/rules, debian/compat:
    + Comply with ‘Standards-Version: 3.8.2’. No changes required.
    + Migrate from CDBS to debhelper 7.
  * debian/control, debian/rules, debian/preinst:
    + Migrate from python-central to python-support.
  * debian/rules:
    + Install upstream changelog.
  * debian/control, debian/rules:
    + Package is arch-dependent now that it uses C extension.
  * debian/control:
    + Set myself as Maintainer, demote Lars Wirzenius to Uploader at his
      request. Thanks, Lars!

ubuntu/maverick-devel 2010-07-15 01:05:07 UTC 2010-07-15
Import patches-unapplied version 3.2-0ubuntu1 to ubuntu/maverick

Author: Robert Ancell
Author Date: 2010-07-15 00:37:20 UTC

Import patches-unapplied version 3.2-0ubuntu1 to ubuntu/maverick

Imported using git-ubuntu import.

Changelog parent: 6ef2cf18cea6101a13b2b75e85c9a028a08bb771

New changelog entries:
  * Package taken from Debian sponsorship queue: (LP: #395599)
    http://mentors.debian.net/cgi-bin/sponsor-pkglist?action=details;package=python-coverage
  [ Ben Finney ]
  * The “Artificial Conscience” release.
  * New upstream version. Primary user-visible changes:
    + Command-line interface re-worked with sub-commands.
    + Inspection now traverses egg packages.
    + Branch coverage recording and reporting.
    + New XML format for generated reports.
  * debian/control:
    + Remove Lars Wirzenius from all roles at his request.
    + Conform to ‘Standards-Version: 3.8.4’. No changes required.
  * debian/python-coverage.install, debian/python-coverage.manpages:
    + Use ‘dh_installman(1)’ to install man pages.
  * debian/control, debian/rules:
    + Add ‘python-coverage-dbg’ package for debugging symbols.
    + Use newer ‘debhelper’ to ensure automated build for all supported
      versions and for debug packages.
  * debian/copyright:
    + Update copyright information for latest upstream source.
  * debian/source/format:
    + Convert packaging to source format “3.0 (quilt)”.
  * debian/python-coverage.dirs:
    + Removed, the ‘/usr/bin/’ directory is created by ‘setup.py’.
  * debian/rules:
    + Remove, during ‘clean’ target, files that clobber upstream source.
    + Specify installation of Python package to ‘/usr/’ hierarchy (not
      default).
  * The “Rods and Cones” release.
  * New upstream version. Primary user-visible changes:
    + Remove tracer recursion limit.
    + Skip coverage of ‘coverage’ library code.
    + Run Python source files in “universal newline mode”.
  * debian/control:
    + Update email address for Lars Wirzenius.
    + Comply with ‘Standards-Version: 3.8.3’. No changes required.
    + Update ‘Homepage’ field.
    + Add ‘VCS-bzr’ and ‘VCS-Browser’ fields.
    + Build for all supported Python versions.
  * debian/README.source:
    + Remove, no longer applicable.
  * debian/pyversions:
    + Specify Python versions supported.
  * The “ladny” release.
  [ Ben Finney ]
  * New upstream version. Primary user-visible changes:
    + Major overhaul: refactored into a Python package, with some
      functionality implemented in C for speed.
    + Defaults to skipping measurement of standard library coverage.
    + HTML output now available, via ‘-b’ option.
    (Closes: bug#535764)
  * debian/watch:
    + Primary upstream source distribution channel is now the Cheese Shop.
    + Deal with crazy-arse version comparison semantics.
  * debian/control, debian/rules, debian/compat:
    + Comply with ‘Standards-Version: 3.8.2’. No changes required.
    + Migrate from CDBS to debhelper 7.
  * debian/control, debian/rules, debian/preinst:
    + Migrate from python-central to python-support.
  * debian/rules:
    + Install upstream changelog.
  * debian/control, debian/rules:
    + Package is arch-dependent now that it uses C extension.
  * debian/control:
    + Set myself as Maintainer, demote Lars Wirzenius to Uploader at his
      request. Thanks, Lars!

debian/squeeze 2009-05-11 01:17:53 UTC 2009-05-11
Import patches-unapplied version 2.85-1 to debian/sid

Author: Ben Finney
Author Date: 2009-03-19 12:25:23 UTC

Import patches-unapplied version 2.85-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 308d9a716de113405e6fc3e0ff896ec86d39498a

New changelog entries:

  [ Lars Wirzenius ]
  * debian/control: Added missing DM-Upload-Allowed field.
  [ Ben Finney ]
  * New upstream version:
    + Use os.realpath as part of the fixing of filenames so that symlinks
      won't confuse things. Thanks, Patrick Mezard.
      Closes: bug#495963.
  * debian/rules:
    + Fix bogus executable permission for non-program files from upstream
      tarball.
  * debian/copyright:
    + Re-work to proposed machine-parseable format.
  * debian/control:
    + Comply with ‘Standards-Version: 3.8.1’.
    + Add ‘Depends: ${misc:Depends}’ for debhelper.

ubuntu/karmic 2009-05-11 01:17:53 UTC 2009-05-11
Import patches-unapplied version 2.85-1 to debian/sid

Author: Ben Finney
Author Date: 2009-03-19 12:25:23 UTC

Import patches-unapplied version 2.85-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 308d9a716de113405e6fc3e0ff896ec86d39498a

New changelog entries:

  [ Lars Wirzenius ]
  * debian/control: Added missing DM-Upload-Allowed field.
  [ Ben Finney ]
  * New upstream version:
    + Use os.realpath as part of the fixing of filenames so that symlinks
      won't confuse things. Thanks, Patrick Mezard.
      Closes: bug#495963.
  * debian/rules:
    + Fix bogus executable permission for non-program files from upstream
      tarball.
  * debian/copyright:
    + Re-work to proposed machine-parseable format.
  * debian/control:
    + Comply with ‘Standards-Version: 3.8.1’.
    + Add ‘Depends: ${misc:Depends}’ for debhelper.

ubuntu/karmic-devel 2009-05-11 01:17:53 UTC 2009-05-11
Import patches-unapplied version 2.85-1 to debian/sid

Author: Ben Finney
Author Date: 2009-03-19 12:25:23 UTC

Import patches-unapplied version 2.85-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 308d9a716de113405e6fc3e0ff896ec86d39498a

New changelog entries:

  [ Lars Wirzenius ]
  * debian/control: Added missing DM-Upload-Allowed field.
  [ Ben Finney ]
  * New upstream version:
    + Use os.realpath as part of the fixing of filenames so that symlinks
      won't confuse things. Thanks, Patrick Mezard.
      Closes: bug#495963.
  * debian/rules:
    + Fix bogus executable permission for non-program files from upstream
      tarball.
  * debian/copyright:
    + Re-work to proposed machine-parseable format.
  * debian/control:
    + Comply with ‘Standards-Version: 3.8.1’.
    + Add ‘Depends: ${misc:Depends}’ for debhelper.

ubuntu/lucid 2009-05-11 01:17:53 UTC 2009-05-11
Import patches-unapplied version 2.85-1 to debian/sid

Author: Ben Finney
Author Date: 2009-03-19 12:25:23 UTC

Import patches-unapplied version 2.85-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 308d9a716de113405e6fc3e0ff896ec86d39498a

New changelog entries:

  [ Lars Wirzenius ]
  * debian/control: Added missing DM-Upload-Allowed field.
  [ Ben Finney ]
  * New upstream version:
    + Use os.realpath as part of the fixing of filenames so that symlinks
      won't confuse things. Thanks, Patrick Mezard.
      Closes: bug#495963.
  * debian/rules:
    + Fix bogus executable permission for non-program files from upstream
      tarball.
  * debian/copyright:
    + Re-work to proposed machine-parseable format.
  * debian/control:
    + Comply with ‘Standards-Version: 3.8.1’.
    + Add ‘Depends: ${misc:Depends}’ for debhelper.

ubuntu/lucid-devel 2009-05-11 01:17:53 UTC 2009-05-11
Import patches-unapplied version 2.85-1 to debian/sid

Author: Ben Finney
Author Date: 2009-03-19 12:25:23 UTC

Import patches-unapplied version 2.85-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 308d9a716de113405e6fc3e0ff896ec86d39498a

New changelog entries:

  [ Lars Wirzenius ]
  * debian/control: Added missing DM-Upload-Allowed field.
  [ Ben Finney ]
  * New upstream version:
    + Use os.realpath as part of the fixing of filenames so that symlinks
      won't confuse things. Thanks, Patrick Mezard.
      Closes: bug#495963.
  * debian/rules:
    + Fix bogus executable permission for non-program files from upstream
      tarball.
  * debian/copyright:
    + Re-work to proposed machine-parseable format.
  * debian/control:
    + Comply with ‘Standards-Version: 3.8.1’.
    + Add ‘Depends: ${misc:Depends}’ for debhelper.

applied/debian/squeeze 2009-05-11 01:17:53 UTC 2009-05-11
Import patches-applied version 2.85-1 to applied/debian/sid

Author: Ben Finney
Author Date: 2009-03-19 12:25:23 UTC

Import patches-applied version 2.85-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 9c3badb89c2f3b86a4a4f8aef76c8388127c5d18
Unapplied parent: 6ef2cf18cea6101a13b2b75e85c9a028a08bb771

New changelog entries:

  [ Lars Wirzenius ]
  * debian/control: Added missing DM-Upload-Allowed field.
  [ Ben Finney ]
  * New upstream version:
    + Use os.realpath as part of the fixing of filenames so that symlinks
      won't confuse things. Thanks, Patrick Mezard.
      Closes: bug#495963.
  * debian/rules:
    + Fix bogus executable permission for non-program files from upstream
      tarball.
  * debian/copyright:
    + Re-work to proposed machine-parseable format.
  * debian/control:
    + Comply with ‘Standards-Version: 3.8.1’.
    + Add ‘Depends: ${misc:Depends}’ for debhelper.

ubuntu/jaunty 2008-10-29 15:17:42 UTC 2008-10-29
Import patches-unapplied version 2.80-2 to debian/lenny

Author: Ben Finney
Author Date: 2008-08-22 00:02:53 UTC

Import patches-unapplied version 2.80-2 to debian/lenny

Imported using git-ubuntu import.

ubuntu/intrepid-devel 2008-10-29 15:17:42 UTC 2008-10-29
Import patches-unapplied version 2.80-2 to debian/lenny

Author: Ben Finney
Author Date: 2008-08-22 00:02:53 UTC

Import patches-unapplied version 2.80-2 to debian/lenny

Imported using git-ubuntu import.

ubuntu/intrepid 2008-10-29 15:17:42 UTC 2008-10-29
Import patches-unapplied version 2.80-2 to debian/lenny

Author: Ben Finney
Author Date: 2008-08-22 00:02:53 UTC

Import patches-unapplied version 2.80-2 to debian/lenny

Imported using git-ubuntu import.

applied/debian/lenny 2008-10-29 15:17:42 UTC 2008-10-29
Import patches-applied version 2.80-2 to applied/debian/lenny

Author: Ben Finney
Author Date: 2008-08-22 00:02:53 UTC

Import patches-applied version 2.80-2 to applied/debian/lenny

Imported using git-ubuntu import.

Unapplied parent: 308d9a716de113405e6fc3e0ff896ec86d39498a

debian/lenny 2008-10-29 15:17:42 UTC 2008-10-29
Import patches-unapplied version 2.80-2 to debian/lenny

Author: Ben Finney
Author Date: 2008-08-22 00:02:53 UTC

Import patches-unapplied version 2.80-2 to debian/lenny

Imported using git-ubuntu import.

ubuntu/jaunty-devel 2008-10-29 15:17:42 UTC 2008-10-29
Import patches-unapplied version 2.80-2 to debian/lenny

Author: Ben Finney
Author Date: 2008-08-22 00:02:53 UTC

Import patches-unapplied version 2.80-2 to debian/lenny

Imported using git-ubuntu import.

applied/ubuntu/intrepid-devel 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Unapplied parent: 7ea3adeccf0fedc6f152f58726f6d86376dceee6

ubuntu/gutsy-devel 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-unapplied version 2.6-0ubuntu1 to ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-unapplied version 2.6-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

applied/ubuntu/hardy-devel 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Unapplied parent: 7ea3adeccf0fedc6f152f58726f6d86376dceee6

applied/ubuntu/hardy 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Unapplied parent: 7ea3adeccf0fedc6f152f58726f6d86376dceee6

applied/ubuntu/gutsy-devel 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Unapplied parent: 7ea3adeccf0fedc6f152f58726f6d86376dceee6

applied/ubuntu/gutsy 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Unapplied parent: 7ea3adeccf0fedc6f152f58726f6d86376dceee6

applied/ubuntu/devel 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Unapplied parent: 7ea3adeccf0fedc6f152f58726f6d86376dceee6

ubuntu/gutsy 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-unapplied version 2.6-0ubuntu1 to ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-unapplied version 2.6-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

ubuntu/hardy-devel 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-unapplied version 2.6-0ubuntu1 to ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-unapplied version 2.6-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

ubuntu/hardy 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-unapplied version 2.6-0ubuntu1 to ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-unapplied version 2.6-0ubuntu1 to ubuntu/gutsy

Imported using git-ubuntu import.

applied/ubuntu/intrepid 2007-07-02 13:03:57 UTC 2007-07-02
Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Author: Elliot Murphy
Author Date: 2007-06-12 14:42:55 UTC

Import patches-applied version 2.6-0ubuntu1 to applied/ubuntu/gutsy

Imported using git-ubuntu import.

Unapplied parent: 7ea3adeccf0fedc6f152f58726f6d86376dceee6

190 of 90 results

Other repositories

Name Last Modified
lp:ubuntu/+source/python-coverage 2020-02-21
11 of 1 result
You can't create new repositories for python-coverage in Ubuntu.