View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/poppler
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/debian/dsc 2018-12-13 21:19:19 UTC 2018-12-13
DSC file for 0.71.0-1

Author: Ubuntu Git Importer
Author Date: 2018-12-13 21:19:19 UTC

DSC file for 0.71.0-1

applied/debian/experimental 2018-12-13 16:28:53 UTC 2018-12-13
Import patches-applied version 0.71.0-1 to applied/debian/experimental

Author: Emilio Pozuelo Monfort
Author Date: 2018-12-11 18:34:06 UTC

Import patches-applied version 0.71.0-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: b5f17c25d5232b5a280c888d26c622b63899a50b
Unapplied parent: 02caecd4d255244ce6f3ebfc41a35126d72435db

New changelog entries:
  * New upstream release.
  * libpoppler80 -> libpoppler82.
  * Update libpoppler-glib8 and libpoppler-qt5-1 symbols.
  * Update copyright holders.

debian/experimental 2018-12-13 16:28:53 UTC 2018-12-13
Import patches-unapplied version 0.71.0-1 to debian/experimental

Author: Emilio Pozuelo Monfort
Author Date: 2018-12-11 18:34:06 UTC

Import patches-unapplied version 0.71.0-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 04f70f9ea4730cfccf61dcc01fa87061b72a28f6

New changelog entries:
  * New upstream release.
  * libpoppler80 -> libpoppler82.
  * Update libpoppler-glib8 and libpoppler-qt5-1 symbols.
  * Update copyright holders.

importer/ubuntu/dsc 2018-12-11 16:30:13 UTC 2018-12-11
DSC file for 0.41.0-0ubuntu1.10

Author: Ubuntu Git Importer
Author Date: 2018-12-11 16:30:13 UTC

DSC file for 0.41.0-0ubuntu1.10

ubuntu/trusty-updates 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.24.5-2ubuntu4.14 to ubuntu/trusty-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-11 13:14:13 UTC

Import patches-unapplied version 0.24.5-2ubuntu4.14 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 7fa0e5329b61eab917024203512cb81b3bc6b26b

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/cosmic-updates 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.68.0-0ubuntu1.3 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 18:46:44 UTC

Import patches-unapplied version 0.68.0-0ubuntu1.3 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 369b7a5e99762f9450835a9fd6da65004aa2ec56

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/cosmic-security 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.68.0-0ubuntu1.3 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 18:46:44 UTC

Import patches-unapplied version 0.68.0-0ubuntu1.3 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 369b7a5e99762f9450835a9fd6da65004aa2ec56

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/cosmic-devel 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.68.0-0ubuntu1.3 to ubuntu/cosmic-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 18:46:44 UTC

Import patches-unapplied version 0.68.0-0ubuntu1.3 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: 369b7a5e99762f9450835a9fd6da65004aa2ec56

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/xenial-updates 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.41.0-0ubuntu1.10 to ubuntu/xenial-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 19:08:10 UTC

Import patches-unapplied version 0.41.0-0ubuntu1.10 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 1dcc1d214a7aa70cd29549db4c104f00f4cc936b

New changelog entries:
  * SECURITY REGRESSION: fixing patch applied previously
    for CVE-2018-19149
    - debian/patch/CVE-2018-19149-fixing-previous.patch
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/bionic-devel 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.62.0-2ubuntu2.5 to ubuntu/bionic-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 17:14:38 UTC

Import patches-unapplied version 0.62.0-2ubuntu2.5 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: 9cfbee795eb77379469df4a7bb58ad8cd79d7637

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/trusty-security 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.24.5-2ubuntu4.14 to ubuntu/trusty-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-11 13:14:13 UTC

Import patches-unapplied version 0.24.5-2ubuntu4.14 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 7fa0e5329b61eab917024203512cb81b3bc6b26b

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/xenial-security 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.41.0-0ubuntu1.10 to ubuntu/xenial-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 19:08:10 UTC

Import patches-unapplied version 0.41.0-0ubuntu1.10 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 1dcc1d214a7aa70cd29549db4c104f00f4cc936b

New changelog entries:
  * SECURITY REGRESSION: fixing patch applied previously
    for CVE-2018-19149
    - debian/patch/CVE-2018-19149-fixing-previous.patch
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/trusty-devel 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.24.5-2ubuntu4.14 to ubuntu/trusty-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-11 13:14:13 UTC

Import patches-unapplied version 0.24.5-2ubuntu4.14 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 7fa0e5329b61eab917024203512cb81b3bc6b26b

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/xenial-devel 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.41.0-0ubuntu1.10 to ubuntu/xenial-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 19:08:10 UTC

Import patches-unapplied version 0.41.0-0ubuntu1.10 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 1dcc1d214a7aa70cd29549db4c104f00f4cc936b

New changelog entries:
  * SECURITY REGRESSION: fixing patch applied previously
    for CVE-2018-19149
    - debian/patch/CVE-2018-19149-fixing-previous.patch
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/bionic-updates 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.62.0-2ubuntu2.5 to ubuntu/bionic-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 17:14:38 UTC

Import patches-unapplied version 0.62.0-2ubuntu2.5 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: 9cfbee795eb77379469df4a7bb58ad8cd79d7637

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/bionic-security 2018-12-11 16:23:16 UTC 2018-12-11
Import patches-unapplied version 0.62.0-2ubuntu2.5 to ubuntu/bionic-security

Author: Leonidas S. Barbosa
Author Date: 2018-12-10 17:14:38 UTC

Import patches-unapplied version 0.62.0-2ubuntu2.5 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: 9cfbee795eb77379469df4a7bb58ad8cd79d7637

New changelog entries:
  * SECURITY REGRESSION: fixing regression in check entry
    - debian/patches/CVE-2018-16646-fix-regression-p1.patch
    - debian/patches/CVE-2018-16646-fix-regression-p2.patch

ubuntu/bionic-proposed 2018-11-27 20:48:23 UTC 2018-11-27
Import patches-unapplied version 0.62.0-2ubuntu2.3 to ubuntu/bionic-proposed

Author: Sebastien Bacher
Author Date: 2018-11-23 10:07:19 UTC

Import patches-unapplied version 0.62.0-2ubuntu2.3 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 2b5002b409961d0012fd2a019f2b44809dd1657f

New changelog entries:
  * debian/patches/git_embed_segfault.patch:
    - "Check whether an embedded file is actually present in the PDF
       and show warning in that case." (lp: #1803059)

ubuntu/cosmic-proposed 2018-11-27 16:53:15 UTC 2018-11-27
Import patches-unapplied version 0.68.0-0ubuntu1.1 to ubuntu/cosmic-proposed

Author: Sebastien Bacher
Author Date: 2018-11-23 15:01:35 UTC

Import patches-unapplied version 0.68.0-0ubuntu1.1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 0608939d6938336e51d0307ad1eede1866adba5d

New changelog entries:
  * debian/patches/git_embed_segfault.patch:
    - "Check whether an embedded file is actually present in the PDF
       and show warning in that case." (lp: #1803059)

ubuntu/disco-devel 2018-11-23 14:48:26 UTC 2018-11-23
Import patches-unapplied version 0.71.0-0ubuntu3 to ubuntu/disco-proposed

Author: Sebastien Bacher
Author Date: 2018-11-23 14:35:31 UTC

Import patches-unapplied version 0.71.0-0ubuntu3 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: a2ae51289b7954a063088188b4bfc3100f28657d

New changelog entries:
  * Re-upload the 0.71 update which was deleted from disco-proposed to
    not get in the way of other transitions (lp: #1796717)
    - include a fix for a crash due to missing embedded file (lp: #1803059)

ubuntu/disco-proposed 2018-11-23 14:48:26 UTC 2018-11-23
Import patches-unapplied version 0.71.0-0ubuntu3 to ubuntu/disco-proposed

Author: Sebastien Bacher
Author Date: 2018-11-23 14:35:31 UTC

Import patches-unapplied version 0.71.0-0ubuntu3 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: a2ae51289b7954a063088188b4bfc3100f28657d

New changelog entries:
  * Re-upload the 0.71 update which was deleted from disco-proposed to
    not get in the way of other transitions (lp: #1796717)
    - include a fix for a crash due to missing embedded file (lp: #1803059)

ubuntu/devel 2018-11-23 14:48:26 UTC 2018-11-23
Import patches-unapplied version 0.71.0-0ubuntu3 to ubuntu/disco-proposed

Author: Sebastien Bacher
Author Date: 2018-11-23 14:35:31 UTC

Import patches-unapplied version 0.71.0-0ubuntu3 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: a2ae51289b7954a063088188b4bfc3100f28657d

New changelog entries:
  * Re-upload the 0.71 update which was deleted from disco-proposed to
    not get in the way of other transitions (lp: #1796717)
    - include a fix for a crash due to missing embedded file (lp: #1803059)

ubuntu/disco 2018-11-23 14:48:26 UTC 2018-11-23
Import patches-unapplied version 0.71.0-0ubuntu3 to ubuntu/disco-proposed

Author: Sebastien Bacher
Author Date: 2018-11-23 14:35:31 UTC

Import patches-unapplied version 0.71.0-0ubuntu3 to ubuntu/disco-proposed

Imported using git-ubuntu import.

Changelog parent: a2ae51289b7954a063088188b4bfc3100f28657d

New changelog entries:
  * Re-upload the 0.71 update which was deleted from disco-proposed to
    not get in the way of other transitions (lp: #1796717)
    - include a fix for a crash due to missing embedded file (lp: #1803059)

debian/buster 2018-10-18 16:40:51 UTC 2018-10-18
Import patches-unapplied version 0.69.0-2 to debian/sid

Author: Emilio Pozuelo Monfort
Author Date: 2018-10-18 07:59:36 UTC

Import patches-unapplied version 0.69.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4481f488e96a654c64eac0c950088a4fa40f27fa

New changelog entries:
  * Upload to unstable.

applied/debian/buster 2018-10-18 16:40:51 UTC 2018-10-18
Import patches-applied version 0.69.0-2 to applied/debian/sid

Author: Emilio Pozuelo Monfort
Author Date: 2018-10-18 07:59:36 UTC

Import patches-applied version 0.69.0-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 3fc8dca8bd17458091725f3869a906e4e2e23570
Unapplied parent: 04f70f9ea4730cfccf61dcc01fa87061b72a28f6

New changelog entries:
  * Upload to unstable.

debian/sid 2018-10-18 16:40:51 UTC 2018-10-18
Import patches-unapplied version 0.69.0-2 to debian/sid

Author: Emilio Pozuelo Monfort
Author Date: 2018-10-18 07:59:36 UTC

Import patches-unapplied version 0.69.0-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4481f488e96a654c64eac0c950088a4fa40f27fa

New changelog entries:
  * Upload to unstable.

applied/debian/sid 2018-10-18 16:40:51 UTC 2018-10-18
Import patches-applied version 0.69.0-2 to applied/debian/sid

Author: Emilio Pozuelo Monfort
Author Date: 2018-10-18 07:59:36 UTC

Import patches-applied version 0.69.0-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 3fc8dca8bd17458091725f3869a906e4e2e23570
Unapplied parent: 04f70f9ea4730cfccf61dcc01fa87061b72a28f6

New changelog entries:
  * Upload to unstable.

ubuntu/cosmic 2018-08-22 09:48:20 UTC 2018-08-22
Import patches-unapplied version 0.68.0-0ubuntu1 to ubuntu/cosmic-proposed

Author: Sebastien Bacher
Author Date: 2018-08-22 09:30:47 UTC

Import patches-unapplied version 0.68.0-0ubuntu1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 7ae97286dc92570430ae5d52e2609953cf166087

New changelog entries:
  * New upstream version
    - TextPage: Add horizontal scaling to font matrix (lp: #1761567)
  * Updated for the soname change libpoppler73 -> 79
  * debian/patches/proper-init.patch:
    - removed, the issue has been fixed upstream in another way since
  * debian/patches/01-new-gtk-doc.patch,
    debian/patches/cairo-good-filter.patch,
    debian/patches/CVE-2017-18267.patch:
    - removed, the fixes are in the new version
  * debian/patches/series:
    - added a comment about the remaining patches

debian/jessie 2018-06-23 17:26:09 UTC 2018-06-23
Import patches-unapplied version 0.26.5-2+deb8u4 to debian/jessie

Author: Salvatore Bonaccorso
Author Date: 2018-04-12 09:19:50 UTC

Import patches-unapplied version 0.26.5-2+deb8u4 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: f192a3c22de5978b34d04788a9408190957c0cfb

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Correct patch for CVE-2017-9776.
    Fixes "[regression] Broken rendering of scan PDF from Xerox WorkCentre
    5945". (Closes: #890826)
  * Fix regression in fix for CVE-2017-14519
  * CVE-2017-1000456
  * CVE-2017-14929
  * Fix CVE-2017-9406: a memory leak vulnerability was found in the function
    gmalloc in gmem.cc, which allows attackers to cause a denial of service
    via a crafted file.
  * Fix CVE-2017-9408: memory leak in the function Object::initArray in
    Object.cc that allows attackers to cause a DoS via a crafted file.
  * Fix CVE-2017-9775: Stack buffer overflow in GfxState.cc in pdftocairo that
    allows remote attackers to cause a denial of service (application crash)
    via a crafted PDF document.
  * Fix CVE-2017-9776: Integer overflow leading to Heap buffer overflow in
    JBIG2Stream.cc in pdftocairo allows remote attackers to cause a denial of
    service (application crash) or possibly have unspecified other impact via a
    crafted PDF document.
  * Fix CVE-2017-9865: The function GfxImageColorMap::getGray in GfxState.cc
    allows remote attackers to cause a denial of service (stack-based buffer
    over-read and application crash) via a crafted PDF document
  * Fix CVE-2017-14517: NULL pointer dereference vulnerability in the
    XRef::parseEntry() function in XRef.cc
  * Fix CVE-2017-14518: Floating point exception in the
    isImageInterpolationRequired() function in Splash.cc
  * Fix CVE-2017-14519: A memory corruption may occur in a call to
    Object::streamGetChar
  * Fix CVE-2017-14520: Floating point exception in Splash::scaleImageYuXd()
  * Fix CVE-2017-14617: Floating point exception in the ImageStream class in
    Stream.cc
  * Fix CVE-2017-14975: NULL pointer dereference vulnerability in the
    FoFiType1C::convertToType0 function in FoFiType1C.cc
  * Fix CVE-2017-14976: Heap-based buffer over-read vulnerability in the
    FoFiType1C::convertToType0 function in FoFiType1C.cc
  * Fix CVE-2017-14977: NULL pointer dereference vulnerability in the
    FoFiTrueType::getCFFBlock function in FoFiTrueType.cc
  * Fix CVE-2017-15565: NULL Pointer Dereference in the
    GfxImageColorMap::getGrayLine() function in GfxState.cc

applied/debian/jessie 2018-06-23 17:26:09 UTC 2018-06-23
Import patches-applied version 0.26.5-2+deb8u4 to applied/debian/jessie

Author: Salvatore Bonaccorso
Author Date: 2018-04-12 09:19:50 UTC

Import patches-applied version 0.26.5-2+deb8u4 to applied/debian/jessie

Imported using git-ubuntu import.

Changelog parent: bc75f89c327589c9f088112b36d478d90c213356
Unapplied parent: 447a9f1c858136dce9cfdfa8fa8029520d428a9b

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Correct patch for CVE-2017-9776.
    Fixes "[regression] Broken rendering of scan PDF from Xerox WorkCentre
    5945". (Closes: #890826)
  * Fix regression in fix for CVE-2017-14519
  * CVE-2017-1000456
  * CVE-2017-14929
  * Fix CVE-2017-9406: a memory leak vulnerability was found in the function
    gmalloc in gmem.cc, which allows attackers to cause a denial of service
    via a crafted file.
  * Fix CVE-2017-9408: memory leak in the function Object::initArray in
    Object.cc that allows attackers to cause a DoS via a crafted file.
  * Fix CVE-2017-9775: Stack buffer overflow in GfxState.cc in pdftocairo that
    allows remote attackers to cause a denial of service (application crash)
    via a crafted PDF document.
  * Fix CVE-2017-9776: Integer overflow leading to Heap buffer overflow in
    JBIG2Stream.cc in pdftocairo allows remote attackers to cause a denial of
    service (application crash) or possibly have unspecified other impact via a
    crafted PDF document.
  * Fix CVE-2017-9865: The function GfxImageColorMap::getGray in GfxState.cc
    allows remote attackers to cause a denial of service (stack-based buffer
    over-read and application crash) via a crafted PDF document
  * Fix CVE-2017-14517: NULL pointer dereference vulnerability in the
    XRef::parseEntry() function in XRef.cc
  * Fix CVE-2017-14518: Floating point exception in the
    isImageInterpolationRequired() function in Splash.cc
  * Fix CVE-2017-14519: A memory corruption may occur in a call to
    Object::streamGetChar
  * Fix CVE-2017-14520: Floating point exception in Splash::scaleImageYuXd()
  * Fix CVE-2017-14617: Floating point exception in the ImageStream class in
    Stream.cc
  * Fix CVE-2017-14975: NULL pointer dereference vulnerability in the
    FoFiType1C::convertToType0 function in FoFiType1C.cc
  * Fix CVE-2017-14976: Heap-based buffer over-read vulnerability in the
    FoFiType1C::convertToType0 function in FoFiType1C.cc
  * Fix CVE-2017-14977: NULL pointer dereference vulnerability in the
    FoFiTrueType::getCFFBlock function in FoFiTrueType.cc
  * Fix CVE-2017-15565: NULL Pointer Dereference in the
    GfxImageColorMap::getGrayLine() function in GfxState.cc

ubuntu/artful-security 2018-05-15 17:14:12 UTC 2018-05-15
Import patches-unapplied version 0.57.0-2ubuntu4.3 to ubuntu/artful-security

Author: Leonidas S. Barbosa
Author Date: 2018-05-14 15:43:51 UTC

Import patches-unapplied version 0.57.0-2ubuntu4.3 to ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 19445339c87c5d1e3380fb21733cfd00d027dc26

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2017-18267.patch: fix issue for malformed
      documents in fofi/FoFiType1C.cc.
    - CVE-2017-18267

ubuntu/artful-devel 2018-05-15 17:14:12 UTC 2018-05-15
Import patches-unapplied version 0.57.0-2ubuntu4.3 to ubuntu/artful-security

Author: Leonidas S. Barbosa
Author Date: 2018-05-14 15:43:51 UTC

Import patches-unapplied version 0.57.0-2ubuntu4.3 to ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 19445339c87c5d1e3380fb21733cfd00d027dc26

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2017-18267.patch: fix issue for malformed
      documents in fofi/FoFiType1C.cc.
    - CVE-2017-18267

ubuntu/artful-updates 2018-05-15 17:14:12 UTC 2018-05-15
Import patches-unapplied version 0.57.0-2ubuntu4.3 to ubuntu/artful-security

Author: Leonidas S. Barbosa
Author Date: 2018-05-14 15:43:51 UTC

Import patches-unapplied version 0.57.0-2ubuntu4.3 to ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 19445339c87c5d1e3380fb21733cfd00d027dc26

New changelog entries:
  * SECURITY UPDATE: Denial of service
    - debian/patches/CVE-2017-18267.patch: fix issue for malformed
      documents in fofi/FoFiType1C.cc.
    - CVE-2017-18267

ubuntu/bionic 2018-04-16 09:44:14 UTC 2018-04-16
Import patches-unapplied version 0.62.0-2ubuntu2 to ubuntu/bionic-proposed

Author: Jeremy Bicha
Author Date: 2018-04-14 02:08:42 UTC

Import patches-unapplied version 0.62.0-2ubuntu2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 3b0d29778e1447cc4bffa2dc8be5cd36250f6927

New changelog entries:
  * Cherry-pick cairo-good-filter.patch from 0.63:
    Use cairo's GOOD filter instead of BEST to significantly improve
    performance. Thanks Rogério Brito for suggesting this patch.
    (Closes: #895487) (LP: #1763874)

importer/ubuntu/pristine-tar 2018-04-03 12:54:09 UTC 2018-04-03
pristine-tar data for poppler_0.62.0.orig.tar.xz

Author: Ubuntu Git Importer
Author Date: 2018-04-03 12:54:09 UTC

pristine-tar data for poppler_0.62.0.orig.tar.xz

importer/debian/pristine-tar 2018-04-03 11:08:17 UTC 2018-04-03
pristine-tar data for poppler_0.62.0.orig.tar.xz

Author: Ubuntu Git Importer
Author Date: 2018-04-03 11:08:17 UTC

pristine-tar data for poppler_0.62.0.orig.tar.xz

applied/debian/stretch 2018-03-10 17:03:25 UTC 2018-03-10
Import patches-applied version 0.48.0-2+deb9u2 to applied/debian/stretch

Author: Moritz Mühlenhoff
Author Date: 2018-01-22 18:42:15 UTC

Import patches-applied version 0.48.0-2+deb9u2 to applied/debian/stretch

Imported using git-ubuntu import.

Changelog parent: 31e2ae9375804263d03fc84b92159255302a99a9
Unapplied parent: 9b1b64aace5563068102cb12f9672357fd5a3fab

New changelog entries:
  * Fix regression in fix for CVE-2017-14519
  * CVE-2017-1000456
  * CVE-2017-14929
  * Fix CVE-2017-9406: a memory leak vulnerability was found in the function
    gmalloc in gmem.cc, which allows attackers to cause a denial of service
    via a crafted file.
  * Fix CVE-2017-9408: memory leak in the function Object::initArray in
    Object.cc that allows attackers to cause a DoS via a crafted file.
  * Fix CVE-2017-9775: Stack buffer overflow in GfxState.cc in pdftocairo that
    allows remote attackers to cause a denial of service (application crash)
    via a crafted PDF document.
  * Fix CVE-2017-9776: Integer overflow leading to Heap buffer overflow in
    JBIG2Stream.cc in pdftocairo allows remote attackers to cause a denial of
    service (application crash) or possibly have unspecified other impact via a
    crafted PDF document.
  * Fix CVE-2017-9865: The function GfxImageColorMap::getGray in GfxState.cc
    allows remote attackers to cause a denial of service (stack-based buffer
    over-read and application crash) via a crafted PDF document
  * Fix CVE-2017-14517: NULL pointer dereference vulnerability in the
    XRef::parseEntry() function in XRef.cc
  * Fix CVE-2017-14518: Floating point exception in the
    isImageInterpolationRequired() function in Splash.cc
  * Fix CVE-2017-14519: A memory corruption may occur in a call to
    Object::streamGetChar
  * Fix CVE-2017-14520: Floating point exception in Splash::scaleImageYuXd()
  * Fix CVE-2017-14617: Floating point exception in the ImageStream class in
    Stream.cc
  * Fix CVE-2017-14975: NULL pointer dereference vulnerability in the
    FoFiType1C::convertToType0 function in FoFiType1C.cc
  * Fix CVE-2017-14976: Heap-based buffer over-read vulnerability in the
    FoFiType1C::convertToType0 function in FoFiType1C.cc
  * Fix CVE-2017-14977: NULL pointer dereference vulnerability in the
    FoFiTrueType::getCFFBlock function in FoFiTrueType.cc
  * Fix CVE-2017-15565: NULL Pointer Dereference in the
    GfxImageColorMap::getGrayLine() function in GfxState.cc

debian/stretch 2018-03-10 17:03:25 UTC 2018-03-10
Import patches-unapplied version 0.48.0-2+deb9u2 to debian/stretch

Author: Moritz Mühlenhoff
Author Date: 2018-01-22 18:42:15 UTC

Import patches-unapplied version 0.48.0-2+deb9u2 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: e31f3c6ab7ca187312b10db4de93ba4d47ccff01

New changelog entries:
  * Fix regression in fix for CVE-2017-14519
  * CVE-2017-1000456
  * CVE-2017-14929
  * Fix CVE-2017-9406: a memory leak vulnerability was found in the function
    gmalloc in gmem.cc, which allows attackers to cause a denial of service
    via a crafted file.
  * Fix CVE-2017-9408: memory leak in the function Object::initArray in
    Object.cc that allows attackers to cause a DoS via a crafted file.
  * Fix CVE-2017-9775: Stack buffer overflow in GfxState.cc in pdftocairo that
    allows remote attackers to cause a denial of service (application crash)
    via a crafted PDF document.
  * Fix CVE-2017-9776: Integer overflow leading to Heap buffer overflow in
    JBIG2Stream.cc in pdftocairo allows remote attackers to cause a denial of
    service (application crash) or possibly have unspecified other impact via a
    crafted PDF document.
  * Fix CVE-2017-9865: The function GfxImageColorMap::getGray in GfxState.cc
    allows remote attackers to cause a denial of service (stack-based buffer
    over-read and application crash) via a crafted PDF document
  * Fix CVE-2017-14517: NULL pointer dereference vulnerability in the
    XRef::parseEntry() function in XRef.cc
  * Fix CVE-2017-14518: Floating point exception in the
    isImageInterpolationRequired() function in Splash.cc
  * Fix CVE-2017-14519: A memory corruption may occur in a call to
    Object::streamGetChar
  * Fix CVE-2017-14520: Floating point exception in Splash::scaleImageYuXd()
  * Fix CVE-2017-14617: Floating point exception in the ImageStream class in
    Stream.cc
  * Fix CVE-2017-14975: NULL pointer dereference vulnerability in the
    FoFiType1C::convertToType0 function in FoFiType1C.cc
  * Fix CVE-2017-14976: Heap-based buffer over-read vulnerability in the
    FoFiType1C::convertToType0 function in FoFiType1C.cc
  * Fix CVE-2017-14977: NULL pointer dereference vulnerability in the
    FoFiTrueType::getCFFBlock function in FoFiTrueType.cc
  * Fix CVE-2017-15565: NULL Pointer Dereference in the
    GfxImageColorMap::getGrayLine() function in GfxState.cc

ubuntu/zesty-devel 2018-01-08 14:18:11 UTC 2018-01-08
Import patches-unapplied version 0.48.0-2ubuntu2.5 to ubuntu/zesty-security

Author: Leonidas S. Barbosa
Author Date: 2018-01-04 17:34:55 UTC

Import patches-unapplied version 0.48.0-2ubuntu2.5 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 6cb1cfdec0b8997ad9ce1268abbe328f68b29c44

New changelog entries:
  * SECURITY UPDATE: fails to validate boundaries in TextPool::addWord
    leading to overflow
    - debian/patches/CVE-2017-1000456.patch: fix crash in fuzzed file in
      poppler/TextOutputDev.cc.
    - CVE-2017-1000456
  * SECURITY UPDATE: has a heap-based buffer over-read vulnerability
    - debian/patches/CVE-2017-14976.patch: fix crash in broken files in
      fofi/FoFiType1C.cc.
    - CVE-2017-14976

ubuntu/zesty-security 2018-01-08 14:18:11 UTC 2018-01-08
Import patches-unapplied version 0.48.0-2ubuntu2.5 to ubuntu/zesty-security

Author: Leonidas S. Barbosa
Author Date: 2018-01-04 17:34:55 UTC

Import patches-unapplied version 0.48.0-2ubuntu2.5 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 6cb1cfdec0b8997ad9ce1268abbe328f68b29c44

New changelog entries:
  * SECURITY UPDATE: fails to validate boundaries in TextPool::addWord
    leading to overflow
    - debian/patches/CVE-2017-1000456.patch: fix crash in fuzzed file in
      poppler/TextOutputDev.cc.
    - CVE-2017-1000456
  * SECURITY UPDATE: has a heap-based buffer over-read vulnerability
    - debian/patches/CVE-2017-14976.patch: fix crash in broken files in
      fofi/FoFiType1C.cc.
    - CVE-2017-14976

ubuntu/zesty-updates 2018-01-08 14:18:11 UTC 2018-01-08
Import patches-unapplied version 0.48.0-2ubuntu2.5 to ubuntu/zesty-security

Author: Leonidas S. Barbosa
Author Date: 2018-01-04 17:34:55 UTC

Import patches-unapplied version 0.48.0-2ubuntu2.5 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 6cb1cfdec0b8997ad9ce1268abbe328f68b29c44

New changelog entries:
  * SECURITY UPDATE: fails to validate boundaries in TextPool::addWord
    leading to overflow
    - debian/patches/CVE-2017-1000456.patch: fix crash in fuzzed file in
      poppler/TextOutputDev.cc.
    - CVE-2017-1000456
  * SECURITY UPDATE: has a heap-based buffer over-read vulnerability
    - debian/patches/CVE-2017-14976.patch: fix crash in broken files in
      fofi/FoFiType1C.cc.
    - CVE-2017-14976

ubuntu/artful-proposed 2017-10-10 18:29:24 UTC 2017-10-10
Import patches-unapplied version 0.57.0-2ubuntu4 to ubuntu/artful-proposed

Author: Leonidas S. Barbosa
Author Date: 2017-10-05 18:20:07 UTC

Import patches-unapplied version 0.57.0-2ubuntu4 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 7c6aae1096b925b8c1222b741097864701cefb65

New changelog entries:
  * SECURITY UPDATE: Floating point exception
    - debian/patches/CVE-2017-14518.patch: Fix divide by 0 on broken
      documents in splash/Splash.cc.
    - CVE-2017-14518
  * SECURITY UPDATE: Floating point exception
    - debian/patches/CVE-2017-14520.patch: don't try to scale if srcHeight or
      srcWidth is less than 1 in splash/Splash.cc.
    - CVE-2017-14520
  * SECURITY UPDATE: Floating point exception in ImageStream
    - debian/patches/CVE-2017-14617.patch: Fix crash in broken files in
      poppler/Stream.cc.
    - CVE-2017-14617
  * SECURITY UPDATE: NULL pointer dereference
    - debian/patches/CVE-2017-14926.patch: Fix crash on broken files
      in poppler/Annot.cc.
    - CVE-2017-14926
  * SECURITY UPDATE: NULL pointer dereferencem
    - debian/patches/CVE-2017-14927.patch: Fix crash in broken files in
      poppler/SplashOutputDev.cc
    - CVE-2017-14927
  * SECURITY UPDATE: NULL pointer dereference
    - debian/patches/CVE-2017-14928.patch: Fix crash broken files
      in poppler/Annot.cc.
    - CVE-2017-14928
  * SECURITY UPDATE: Memory corruption
    - debian/patches/CVE-2017-14929.patch: Fix infinite recursion
      in poppler/Gfx.cc, poppler/GfxState.cc, poppler/GfxState.h.
    - CVE-2017-14929
  * SECURITY UPDATE: NULL pointer dereference
    - debian/patches/CVE-2017-14975.patch: fix crash in convertToType0 in
      fofi/FoFiType1C.cc.
    - CVE-2017-14975
  * SECURITY UPDATE: heap-based buffer over-read
    - debian/patches/CVE-2017-14976.patch: fix crash in convertToType0 in
      fofi/FoFiType1C.cc.
    - CVE-2017-14976
  * SECURITY UPDATE: NULL pointer dereference
    - debian/patches/CVE-2017-14977.patch: fix NULL deference pointer in
      fofi/FoFiTrueType.cc.
    - CVE-2017-14977

ubuntu/artful 2017-10-10 18:29:24 UTC 2017-10-10
Import patches-unapplied version 0.57.0-2ubuntu4 to ubuntu/artful-proposed

Author: Leonidas S. Barbosa
Author Date: 2017-10-05 18:20:07 UTC

Import patches-unapplied version 0.57.0-2ubuntu4 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 7c6aae1096b925b8c1222b741097864701cefb65

New changelog entries:
  * SECURITY UPDATE: Floating point exception
    - debian/patches/CVE-2017-14518.patch: Fix divide by 0 on broken
      documents in splash/Splash.cc.
    - CVE-2017-14518
  * SECURITY UPDATE: Floating point exception
    - debian/patches/CVE-2017-14520.patch: don't try to scale if srcHeight or
      srcWidth is less than 1 in splash/Splash.cc.
    - CVE-2017-14520
  * SECURITY UPDATE: Floating point exception in ImageStream
    - debian/patches/CVE-2017-14617.patch: Fix crash in broken files in
      poppler/Stream.cc.
    - CVE-2017-14617
  * SECURITY UPDATE: NULL pointer dereference
    - debian/patches/CVE-2017-14926.patch: Fix crash on broken files
      in poppler/Annot.cc.
    - CVE-2017-14926
  * SECURITY UPDATE: NULL pointer dereferencem
    - debian/patches/CVE-2017-14927.patch: Fix crash in broken files in
      poppler/SplashOutputDev.cc
    - CVE-2017-14927
  * SECURITY UPDATE: NULL pointer dereference
    - debian/patches/CVE-2017-14928.patch: Fix crash broken files
      in poppler/Annot.cc.
    - CVE-2017-14928
  * SECURITY UPDATE: Memory corruption
    - debian/patches/CVE-2017-14929.patch: Fix infinite recursion
      in poppler/Gfx.cc, poppler/GfxState.cc, poppler/GfxState.h.
    - CVE-2017-14929
  * SECURITY UPDATE: NULL pointer dereference
    - debian/patches/CVE-2017-14975.patch: fix crash in convertToType0 in
      fofi/FoFiType1C.cc.
    - CVE-2017-14975
  * SECURITY UPDATE: heap-based buffer over-read
    - debian/patches/CVE-2017-14976.patch: fix crash in convertToType0 in
      fofi/FoFiType1C.cc.
    - CVE-2017-14976
  * SECURITY UPDATE: NULL pointer dereference
    - debian/patches/CVE-2017-14977.patch: fix NULL deference pointer in
      fofi/FoFiTrueType.cc.
    - CVE-2017-14977

ubuntu/yakkety-devel 2017-07-07 14:38:13 UTC 2017-07-07
Import patches-unapplied version 0.44.0-3ubuntu2.1 to ubuntu/yakkety-security

Author: Marc Deslauriers
Author Date: 2017-07-06 14:59:00 UTC

Import patches-unapplied version 0.44.0-3ubuntu2.1 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 613e77cab04080535ccd0b61d0c1d048133bd258

New changelog entries:
  * SECURITY UPDATE: NULL pointer dereference in pdfunite
    - debian/patches/CVE-2017-7511.patch: add extra checks to
      utils/pdfunite.cc.
    - CVE-2017-7511
  * SECURITY UPDATE: uncontrolled recursion in pdfunite
    - debian/patches/CVE-2017-7515.patch: fix recursion in
      poppler/PDFDoc.cc, poppler/PDFDoc.h.
    - CVE-2017-7515
  * SECURITY UPDATE: NULL pointer dereference in JPXStream::readUByte
    - debian/patches/CVE-2017-9083.patch: check nComps in
      poppler/JPXStream.cc.
    - CVE-2017-9083
  * SECURITY UPDATE: memory leak in gmalloc
    - debian/patches/CVE-2017-9406.patch: fix leak in poppler/XRef.cc.
    - CVE-2017-9406
  * SECURITY UPDATE: memory leak in Object::initArray
    - debian/patches/CVE-2017-9408.patch: fix leak in poppler/XRef.cc.
    - CVE-2017-9408
  * SECURITY UPDATE: stack buffer overflow in GfxState.cc
    - debian/patches/CVE-2017-9775.patch: add extra checks to
      poppler/GfxState.cc.
    - CVE-2017-9775
  * SECURITY UPDATE: integer overflow in JPXStream::readTilePart
    - debian/patches/CVE-2017-2820.patch: check for overflow in
      poppler/JPXStream.cc.
    - CVE-2017-2820

ubuntu/yakkety-security 2017-07-07 14:38:13 UTC 2017-07-07
Import patches-unapplied version 0.44.0-3ubuntu2.1 to ubuntu/yakkety-security

Author: Marc Deslauriers
Author Date: 2017-07-06 14:59:00 UTC

Import patches-unapplied version 0.44.0-3ubuntu2.1 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 613e77cab04080535ccd0b61d0c1d048133bd258

New changelog entries:
  * SECURITY UPDATE: NULL pointer dereference in pdfunite
    - debian/patches/CVE-2017-7511.patch: add extra checks to
      utils/pdfunite.cc.
    - CVE-2017-7511
  * SECURITY UPDATE: uncontrolled recursion in pdfunite
    - debian/patches/CVE-2017-7515.patch: fix recursion in
      poppler/PDFDoc.cc, poppler/PDFDoc.h.
    - CVE-2017-7515
  * SECURITY UPDATE: NULL pointer dereference in JPXStream::readUByte
    - debian/patches/CVE-2017-9083.patch: check nComps in
      poppler/JPXStream.cc.
    - CVE-2017-9083
  * SECURITY UPDATE: memory leak in gmalloc
    - debian/patches/CVE-2017-9406.patch: fix leak in poppler/XRef.cc.
    - CVE-2017-9406
  * SECURITY UPDATE: memory leak in Object::initArray
    - debian/patches/CVE-2017-9408.patch: fix leak in poppler/XRef.cc.
    - CVE-2017-9408
  * SECURITY UPDATE: stack buffer overflow in GfxState.cc
    - debian/patches/CVE-2017-9775.patch: add extra checks to
      poppler/GfxState.cc.
    - CVE-2017-9775
  * SECURITY UPDATE: integer overflow in JPXStream::readTilePart
    - debian/patches/CVE-2017-2820.patch: check for overflow in
      poppler/JPXStream.cc.
    - CVE-2017-2820

ubuntu/yakkety-updates 2017-07-07 14:38:13 UTC 2017-07-07
Import patches-unapplied version 0.44.0-3ubuntu2.1 to ubuntu/yakkety-security

Author: Marc Deslauriers
Author Date: 2017-07-06 14:59:00 UTC

Import patches-unapplied version 0.44.0-3ubuntu2.1 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 613e77cab04080535ccd0b61d0c1d048133bd258

New changelog entries:
  * SECURITY UPDATE: NULL pointer dereference in pdfunite
    - debian/patches/CVE-2017-7511.patch: add extra checks to
      utils/pdfunite.cc.
    - CVE-2017-7511
  * SECURITY UPDATE: uncontrolled recursion in pdfunite
    - debian/patches/CVE-2017-7515.patch: fix recursion in
      poppler/PDFDoc.cc, poppler/PDFDoc.h.
    - CVE-2017-7515
  * SECURITY UPDATE: NULL pointer dereference in JPXStream::readUByte
    - debian/patches/CVE-2017-9083.patch: check nComps in
      poppler/JPXStream.cc.
    - CVE-2017-9083
  * SECURITY UPDATE: memory leak in gmalloc
    - debian/patches/CVE-2017-9406.patch: fix leak in poppler/XRef.cc.
    - CVE-2017-9406
  * SECURITY UPDATE: memory leak in Object::initArray
    - debian/patches/CVE-2017-9408.patch: fix leak in poppler/XRef.cc.
    - CVE-2017-9408
  * SECURITY UPDATE: stack buffer overflow in GfxState.cc
    - debian/patches/CVE-2017-9775.patch: add extra checks to
      poppler/GfxState.cc.
    - CVE-2017-9775
  * SECURITY UPDATE: integer overflow in JPXStream::readTilePart
    - debian/patches/CVE-2017-2820.patch: check for overflow in
      poppler/JPXStream.cc.
    - CVE-2017-2820

ubuntu/zesty-proposed 2017-02-24 11:49:17 UTC 2017-02-24
Import patches-unapplied version 0.48.0-2ubuntu2 to ubuntu/zesty-proposed

Author: Andy Whitcroft
Author Date: 2017-02-24 11:15:23 UTC

Import patches-unapplied version 0.48.0-2ubuntu2 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: aa94c27b3e3628c4e0ad9bdf53efc04421e6072b

New changelog entries:
  * No-change rebuild against libnspr4

ubuntu/zesty 2017-02-24 11:49:17 UTC 2017-02-24
Import patches-unapplied version 0.48.0-2ubuntu2 to ubuntu/zesty-proposed

Author: Andy Whitcroft
Author Date: 2017-02-24 11:15:23 UTC

Import patches-unapplied version 0.48.0-2ubuntu2 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: aa94c27b3e3628c4e0ad9bdf53efc04421e6072b

New changelog entries:
  * No-change rebuild against libnspr4

ubuntu/xenial-proposed 2016-08-11 22:04:14 UTC 2016-08-11
Import patches-unapplied version 0.41.0-0ubuntu1.1 to ubuntu/xenial-proposed

Author: Jean-Louis Dupond
Author Date: 2016-08-07 16:45:07 UTC

Import patches-unapplied version 0.41.0-0ubuntu1.1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 8b915e7fc7f91822566d628157fc1f80edb8da9b

New changelog entries:
  * debian/patches/fix-fillToStrokePathClip-crash-and-rendering.patch
    - Fix crash in _cairo_gstate_set_dash (LP: #1610714)

ubuntu/yakkety 2016-08-01 11:14:00 UTC 2016-08-01
Import patches-unapplied version 0.44.0-3ubuntu2 to ubuntu/yakkety-proposed

Author: Timo Jyrinki
Author Date: 2016-08-01 10:45:28 UTC

Import patches-unapplied version 0.44.0-3ubuntu2 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: ba1fee46a9c790c2c0ceaa51633264998da0d94b

New changelog entries:
  * Fix build with Qt 5.6. (LP: #1608476)

ubuntu/yakkety-proposed 2016-08-01 11:14:00 UTC 2016-08-01
Import patches-unapplied version 0.44.0-3ubuntu2 to ubuntu/yakkety-proposed

Author: Timo Jyrinki
Author Date: 2016-08-01 10:45:28 UTC

Import patches-unapplied version 0.44.0-3ubuntu2 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: ba1fee46a9c790c2c0ceaa51633264998da0d94b

New changelog entries:
  * Fix build with Qt 5.6. (LP: #1608476)

ubuntu/precise-devel 2016-05-02 17:08:49 UTC 2016-05-02
Import patches-unapplied version 0.18.4-1ubuntu3.2 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2016-04-29 20:08:29 UTC

Import patches-unapplied version 0.18.4-1ubuntu3.2 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: e37597d510625b419fd0c3500ae27f43368e3847

New changelog entries:
  * SECURITY UPDATE: denial of service in pdfseparate via long filename
    - debian/patches/CVE-2013-4473.patch: improve path building in
      utils/pdfseparate.cc.
    - CVE-2013-4473
  * SECURITY UPDATE: denial of service in pdfseparate via string specifiers
    in filename
    - debian/patches/CVE-2013-4474.patch: properly filter filename in
      utils/pdfseparate.cc.
    - CVE-2013-4474
  * SECURITY UPDATE: heap overflow on invalid files
    - debian/patches/CVE-2015-8868.patch: check length of C0 array in
      poppler/Function.cc.
    - CVE-2015-8868

ubuntu/precise-security 2016-05-02 17:08:49 UTC 2016-05-02
Import patches-unapplied version 0.18.4-1ubuntu3.2 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2016-04-29 20:08:29 UTC

Import patches-unapplied version 0.18.4-1ubuntu3.2 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: e37597d510625b419fd0c3500ae27f43368e3847

New changelog entries:
  * SECURITY UPDATE: denial of service in pdfseparate via long filename
    - debian/patches/CVE-2013-4473.patch: improve path building in
      utils/pdfseparate.cc.
    - CVE-2013-4473
  * SECURITY UPDATE: denial of service in pdfseparate via string specifiers
    in filename
    - debian/patches/CVE-2013-4474.patch: properly filter filename in
      utils/pdfseparate.cc.
    - CVE-2013-4474
  * SECURITY UPDATE: heap overflow on invalid files
    - debian/patches/CVE-2015-8868.patch: check length of C0 array in
      poppler/Function.cc.
    - CVE-2015-8868

ubuntu/wily-updates 2016-05-02 17:08:49 UTC 2016-05-02
Import patches-unapplied version 0.33.0-0ubuntu3.1 to ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2016-04-29 19:56:35 UTC

Import patches-unapplied version 0.33.0-0ubuntu3.1 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: 3746a8dfc8c5edaecd0f05700b526fdec3038daf

New changelog entries:
  * SECURITY UPDATE: heap overflow on invalid files
    - debian/patches/CVE-2015-8868.patch: check length of C0 array in
      poppler/Function.cc.
    - CVE-2015-8868

ubuntu/wily-security 2016-05-02 17:08:49 UTC 2016-05-02
Import patches-unapplied version 0.33.0-0ubuntu3.1 to ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2016-04-29 19:56:35 UTC

Import patches-unapplied version 0.33.0-0ubuntu3.1 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: 3746a8dfc8c5edaecd0f05700b526fdec3038daf

New changelog entries:
  * SECURITY UPDATE: heap overflow on invalid files
    - debian/patches/CVE-2015-8868.patch: check length of C0 array in
      poppler/Function.cc.
    - CVE-2015-8868

ubuntu/wily-devel 2016-05-02 17:08:49 UTC 2016-05-02
Import patches-unapplied version 0.33.0-0ubuntu3.1 to ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2016-04-29 19:56:35 UTC

Import patches-unapplied version 0.33.0-0ubuntu3.1 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: 3746a8dfc8c5edaecd0f05700b526fdec3038daf

New changelog entries:
  * SECURITY UPDATE: heap overflow on invalid files
    - debian/patches/CVE-2015-8868.patch: check length of C0 array in
      poppler/Function.cc.
    - CVE-2015-8868

ubuntu/precise-updates 2016-05-02 17:08:49 UTC 2016-05-02
Import patches-unapplied version 0.18.4-1ubuntu3.2 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2016-04-29 20:08:29 UTC

Import patches-unapplied version 0.18.4-1ubuntu3.2 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: e37597d510625b419fd0c3500ae27f43368e3847

New changelog entries:
  * SECURITY UPDATE: denial of service in pdfseparate via long filename
    - debian/patches/CVE-2013-4473.patch: improve path building in
      utils/pdfseparate.cc.
    - CVE-2013-4473
  * SECURITY UPDATE: denial of service in pdfseparate via string specifiers
    in filename
    - debian/patches/CVE-2013-4474.patch: properly filter filename in
      utils/pdfseparate.cc.
    - CVE-2013-4474
  * SECURITY UPDATE: heap overflow on invalid files
    - debian/patches/CVE-2015-8868.patch: check length of C0 array in
      poppler/Function.cc.
    - CVE-2015-8868

ubuntu/xenial 2016-02-26 17:08:55 UTC 2016-02-26
Import patches-unapplied version 0.41.0-0ubuntu1 to ubuntu/xenial-proposed

Author: Sebastien Bacher
Author Date: 2016-02-22 17:45:00 UTC

Import patches-unapplied version 0.41.0-0ubuntu1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 5b177d3c207ee07ccbf352bfabab9bf416f8ab5b

New changelog entries:
  * New upstream version (soname update 57->58)
  * debian/patchres/revert_api_change.patch:
    - revert upstream commit that removed an enum, they claim it's
      not an abi change because it's unused, but other packages (bindings)
      rely on it to build still, we can drop the patch later once the
      redpends have been updated

ubuntu/trusty-proposed 2015-10-14 14:19:59 UTC 2015-10-14
Import patches-unapplied version 0.24.5-2ubuntu4.3 to ubuntu/trusty-proposed

Author: Sebastien Bacher
Author Date: 2015-10-13 15:10:18 UTC

Import patches-unapplied version 0.24.5-2ubuntu4.3 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 4744e23b14d4f2dde72d77878742caf7064c3087

New changelog entries:
  * debian/patches/git_matrix_not_invertable.patch:
    - cairo: don't render text when text matrix is not invertable
      (lp: #1412916)

ubuntu/wily-proposed 2015-07-31 15:08:36 UTC 2015-07-31
Import patches-unapplied version 0.33.0-0ubuntu3 to ubuntu/wily-proposed

Author: Iain Lane
Author Date: 2015-07-20 11:53:12 UTC

Import patches-unapplied version 0.33.0-0ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: e83b9204e871307f7cc1acbcd515f0bb8b9d7075

New changelog entries:
  * Set hardening flags to "+all,-pie" to build with all hardening flags
    except -fPIE.
  * Build using GCC 5.
  * Don't set hardening flags. Qt5 doesn't allow building with -fPIE.

ubuntu/wily 2015-07-31 15:08:36 UTC 2015-07-31
Import patches-unapplied version 0.33.0-0ubuntu3 to ubuntu/wily-proposed

Author: Iain Lane
Author Date: 2015-07-20 11:53:12 UTC

Import patches-unapplied version 0.33.0-0ubuntu3 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: e83b9204e871307f7cc1acbcd515f0bb8b9d7075

New changelog entries:
  * Set hardening flags to "+all,-pie" to build with all hardening flags
    except -fPIE.
  * Build using GCC 5.
  * Don't set hardening flags. Qt5 doesn't allow building with -fPIE.

ubuntu/utopic-devel 2015-01-21 13:43:34 UTC 2015-01-21
Import patches-unapplied version 0.26.5-0ubuntu2 to ubuntu/utopic-proposed

Author: Iain Lane
Author Date: 2015-01-19 12:52:43 UTC

Import patches-unapplied version 0.26.5-0ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 71dc27d59752b9cad4ae5ff711a4a670a4d5a278

New changelog entries:
  * 0001-Map-Standard-Expert-encoding-ligatures-to-AGLFN-name.patch:
    Cherry-pick patch from upstream to fix ligature mapping with substitute
    fonts which don't use the current standard glyph names. (LP: #1379375)

ubuntu/utopic-updates 2015-01-21 13:43:34 UTC 2015-01-21
Import patches-unapplied version 0.26.5-0ubuntu2 to ubuntu/utopic-proposed

Author: Iain Lane
Author Date: 2015-01-19 12:52:43 UTC

Import patches-unapplied version 0.26.5-0ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 71dc27d59752b9cad4ae5ff711a4a670a4d5a278

New changelog entries:
  * 0001-Map-Standard-Expert-encoding-ligatures-to-AGLFN-name.patch:
    Cherry-pick patch from upstream to fix ligature mapping with substitute
    fonts which don't use the current standard glyph names. (LP: #1379375)

ubuntu/utopic-proposed 2015-01-21 13:43:34 UTC 2015-01-21
Import patches-unapplied version 0.26.5-0ubuntu2 to ubuntu/utopic-proposed

Author: Iain Lane
Author Date: 2015-01-19 12:52:43 UTC

Import patches-unapplied version 0.26.5-0ubuntu2 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 71dc27d59752b9cad4ae5ff711a4a670a4d5a278

New changelog entries:
  * 0001-Map-Standard-Expert-encoding-ligatures-to-AGLFN-name.patch:
    Cherry-pick patch from upstream to fix ligature mapping with substitute
    fonts which don't use the current standard glyph names. (LP: #1379375)

ubuntu/vivid-devel 2015-01-20 12:43:37 UTC 2015-01-20
Import patches-unapplied version 0.30.0-0ubuntu1 to ubuntu/vivid-proposed

Author: Iain Lane
Author Date: 2015-01-20 12:06:08 UTC

Import patches-unapplied version 0.30.0-0ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: adc8fe4b4421245352ef3a0ccabdf4bbdb2958c5

New changelog entries:
  * New upstream release
  * Rename packages according to the new SONAMEs:
    - libpoppler47 -> libpoppler49
  * Explicitly pass --disable-libopenjpeg now - this support was auto-disabled
    before but now configure fails without this flag.

ubuntu/vivid-proposed 2015-01-20 12:43:37 UTC 2015-01-20
Import patches-unapplied version 0.30.0-0ubuntu1 to ubuntu/vivid-proposed

Author: Iain Lane
Author Date: 2015-01-20 12:06:08 UTC

Import patches-unapplied version 0.30.0-0ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: adc8fe4b4421245352ef3a0ccabdf4bbdb2958c5

New changelog entries:
  * New upstream release
  * Rename packages according to the new SONAMEs:
    - libpoppler47 -> libpoppler49
  * Explicitly pass --disable-libopenjpeg now - this support was auto-disabled
    before but now configure fails without this flag.

ubuntu/vivid 2015-01-20 12:43:37 UTC 2015-01-20
Import patches-unapplied version 0.30.0-0ubuntu1 to ubuntu/vivid-proposed

Author: Iain Lane
Author Date: 2015-01-20 12:06:08 UTC

Import patches-unapplied version 0.30.0-0ubuntu1 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: adc8fe4b4421245352ef3a0ccabdf4bbdb2958c5

New changelog entries:
  * New upstream release
  * Rename packages according to the new SONAMEs:
    - libpoppler47 -> libpoppler49
  * Explicitly pass --disable-libopenjpeg now - this support was auto-disabled
    before but now configure fails without this flag.

ubuntu/utopic 2014-09-30 14:13:22 UTC 2014-09-30
Import patches-unapplied version 0.26.5-0ubuntu1 to ubuntu/utopic-proposed

Author: Sebastien Bacher
Author Date: 2014-09-29 17:01:18 UTC

Import patches-unapplied version 0.26.5-0ubuntu1 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 73d6b56b17633b3d0488041105b75729fe5b35b2

New changelog entries:
  * New upstream bugfix version

ubuntu/trusty 2014-03-13 18:53:32 UTC 2014-03-13
Import patches-unapplied version 0.24.5-2ubuntu4 to ubuntu/trusty-proposed

Author: Timo Jyrinki
Author Date: 2014-03-07 09:46:30 UTC

Import patches-unapplied version 0.24.5-2ubuntu4 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 3696d127d33a9dd5cd35bedb9e1f772ea8401dc6

New changelog entries:
  * Rebuild to solve a powerpc dependency problem.
  * Rebuild against Qt 5.2.1

applied/debian/squeeze 2013-10-19 16:44:59 UTC 2013-10-19
Import patches-applied version 0.12.4-1.2+squeeze3 to applied/debian/squeeze

Author: Michael Gilbert
Author Date: 2013-07-07 18:46:43 UTC

Import patches-applied version 0.12.4-1.2+squeeze3 to applied/debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 80507cdcd281a984d18a1d0988258bf02a92d397
Unapplied parent: 35bf91afb748a4895b0dd4f6562389e255a6c75d

New changelog entries:
  * Upload to oldstable-security.
  * Non-maintainer upload by the Security Team.
  * Fix cve-2013-1788: invalid memory access issues.
  * Fix cve-2013-1790: uninitialized memory issue.

debian/squeeze 2013-10-19 16:44:59 UTC 2013-10-19
Import patches-unapplied version 0.12.4-1.2+squeeze3 to debian/squeeze

Author: Michael Gilbert
Author Date: 2013-07-07 18:46:43 UTC

Import patches-unapplied version 0.12.4-1.2+squeeze3 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 02b43908504e099f62e1905d59152eb4892ce991

New changelog entries:
  * Upload to oldstable-security.
  * Non-maintainer upload by the Security Team.
  * Fix cve-2013-1788: invalid memory access issues.
  * Fix cve-2013-1790: uninitialized memory issue.

ubuntu/saucy 2013-08-27 17:28:21 UTC 2013-08-27
Import patches-unapplied version 0.24.1-0ubuntu1 to ubuntu/saucy-proposed

Author: Sebastien Bacher
Author Date: 2013-08-27 14:35:09 UTC

Import patches-unapplied version 0.24.1-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 60f543a175207c2d938ec3f87fe6781be5d60b67

New changelog entries:
  * New upstream version

ubuntu/saucy-devel 2013-08-27 17:28:21 UTC 2013-08-27
Import patches-unapplied version 0.24.1-0ubuntu1 to ubuntu/saucy-proposed

Author: Sebastien Bacher
Author Date: 2013-08-27 14:35:09 UTC

Import patches-unapplied version 0.24.1-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 60f543a175207c2d938ec3f87fe6781be5d60b67

New changelog entries:
  * New upstream version

ubuntu/saucy-proposed 2013-08-27 17:28:21 UTC 2013-08-27
Import patches-unapplied version 0.24.1-0ubuntu1 to ubuntu/saucy-proposed

Author: Sebastien Bacher
Author Date: 2013-08-27 14:35:09 UTC

Import patches-unapplied version 0.24.1-0ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 60f543a175207c2d938ec3f87fe6781be5d60b67

New changelog entries:
  * New upstream version

ubuntu/hardy-security 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.6.4-1ubuntu3.6 to ubuntu/hardy-security

Author: Marc Deslauriers
Author Date: 2013-03-27 18:17:55 UTC

Import patches-unapplied version 0.6.4-1ubuntu3.6 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 459d429eb39d77dda5fc976b2b157bebfeb02d3c

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/110_security_CVE-2013-1788.patch: add checks in
      poppler/Function.cc, poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/111_security_CVE-2013-1790.patch: properly handle
      refLine in poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/hardy-devel 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.6.4-1ubuntu3.6 to ubuntu/hardy-security

Author: Marc Deslauriers
Author Date: 2013-03-27 18:17:55 UTC

Import patches-unapplied version 0.6.4-1ubuntu3.6 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 459d429eb39d77dda5fc976b2b157bebfeb02d3c

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/110_security_CVE-2013-1788.patch: add checks in
      poppler/Function.cc, poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/111_security_CVE-2013-1790.patch: properly handle
      refLine in poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/hardy-updates 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.6.4-1ubuntu3.6 to ubuntu/hardy-security

Author: Marc Deslauriers
Author Date: 2013-03-27 18:17:55 UTC

Import patches-unapplied version 0.6.4-1ubuntu3.6 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 459d429eb39d77dda5fc976b2b157bebfeb02d3c

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/110_security_CVE-2013-1788.patch: add checks in
      poppler/Function.cc, poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/111_security_CVE-2013-1790.patch: properly handle
      refLine in poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/oneiric-devel 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.16.7-2ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2013-03-27 13:33:46 UTC

Import patches-unapplied version 0.16.7-2ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 67903c3e523ece419acb36386e2b1e49b4009861

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/quantal-updates 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.20.4-0ubuntu1.2 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-03-08 18:43:15 UTC

Import patches-unapplied version 0.20.4-0ubuntu1.2 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: bc282f938e7228ff4a9215951e2a7d98f732f2fc

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: denial of service via malformed documents
    - debian/patches/CVE-2013-1789.patch: validate data in splash/Splash.cc.
    - CVE-2013-1789
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/quantal-security 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.20.4-0ubuntu1.2 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-03-08 18:43:15 UTC

Import patches-unapplied version 0.20.4-0ubuntu1.2 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: bc282f938e7228ff4a9215951e2a7d98f732f2fc

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: denial of service via malformed documents
    - debian/patches/CVE-2013-1789.patch: validate data in splash/Splash.cc.
    - CVE-2013-1789
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/quantal-devel 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.20.4-0ubuntu1.2 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-03-08 18:43:15 UTC

Import patches-unapplied version 0.20.4-0ubuntu1.2 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: bc282f938e7228ff4a9215951e2a7d98f732f2fc

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: denial of service via malformed documents
    - debian/patches/CVE-2013-1789.patch: validate data in splash/Splash.cc.
    - CVE-2013-1789
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/lucid-devel 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.12.4-0ubuntu5.3 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2013-03-27 18:05:52 UTC

Import patches-unapplied version 0.12.4-0ubuntu5.3 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d6d4611a37fc4276ccac6ef67b83eeac889ddc5f

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/lucid-security 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.12.4-0ubuntu5.3 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2013-03-27 18:05:52 UTC

Import patches-unapplied version 0.12.4-0ubuntu5.3 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d6d4611a37fc4276ccac6ef67b83eeac889ddc5f

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/lucid-updates 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.12.4-0ubuntu5.3 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2013-03-27 18:05:52 UTC

Import patches-unapplied version 0.12.4-0ubuntu5.3 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d6d4611a37fc4276ccac6ef67b83eeac889ddc5f

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/oneiric-updates 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.16.7-2ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2013-03-27 13:33:46 UTC

Import patches-unapplied version 0.16.7-2ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 67903c3e523ece419acb36386e2b1e49b4009861

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/oneiric-security 2013-04-02 12:17:51 UTC 2013-04-02
Import patches-unapplied version 0.16.7-2ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2013-03-27 13:33:46 UTC

Import patches-unapplied version 0.16.7-2ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 67903c3e523ece419acb36386e2b1e49b4009861

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/raring-proposed 2013-03-26 20:03:13 UTC 2013-03-26
Import patches-unapplied version 0.20.5-1ubuntu3 to ubuntu/raring-proposed

Author: Marc Deslauriers
Author Date: 2013-03-08 17:59:26 UTC

Import patches-unapplied version 0.20.5-1ubuntu3 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 40b672425e40b6db79e318eb995f1d9e76cf5f29

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: denial of service via malformed documents
    - debian/patches/CVE-2013-1789.patch: validate data in splash/Splash.cc.
    - CVE-2013-1789
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/raring 2013-03-26 20:03:13 UTC 2013-03-26
Import patches-unapplied version 0.20.5-1ubuntu3 to ubuntu/raring-proposed

Author: Marc Deslauriers
Author Date: 2013-03-08 17:59:26 UTC

Import patches-unapplied version 0.20.5-1ubuntu3 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 40b672425e40b6db79e318eb995f1d9e76cf5f29

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: denial of service via malformed documents
    - debian/patches/CVE-2013-1789.patch: validate data in splash/Splash.cc.
    - CVE-2013-1789
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

ubuntu/raring-devel 2013-03-26 20:03:13 UTC 2013-03-26
Import patches-unapplied version 0.20.5-1ubuntu3 to ubuntu/raring-proposed

Author: Marc Deslauriers
Author Date: 2013-03-08 17:59:26 UTC

Import patches-unapplied version 0.20.5-1ubuntu3 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 40b672425e40b6db79e318eb995f1d9e76cf5f29

New changelog entries:
  * SECURITY UPDATE: invalid memory access issues
    - debian/patches/CVE-2013-1788.patch: add checks in poppler/Function.cc,
      poppler/Stream.cc, splash/Splash.cc.
    - CVE-2013-1788
  * SECURITY UPDATE: denial of service via malformed documents
    - debian/patches/CVE-2013-1789.patch: validate data in splash/Splash.cc.
    - CVE-2013-1789
  * SECURITY UPDATE: uninitialized memory read
    - debian/patches/CVE-2013-1790.patch: properly handle refLine in
      poppler/Stream.cc.
    - CVE-2013-1790

applied/debian/wheezy 2013-03-26 04:20:37 UTC 2013-03-26
Import patches-applied version 0.18.4-6 to applied/debian/sid

Author: Pino Toscano
Author Date: 2013-03-25 20:43:07 UTC

Import patches-applied version 0.18.4-6 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c09a57d42e6ae7b3143b5b7dcea3ae6d61c097fe
Unapplied parent: cbc6913a509365e2fbd9ddc03b1c38cce4be0a6b

New changelog entries:
  * Backport upstream commits 0388837f01bc467045164f9ddaff787000a8caaa (patch
    upstream_Fix-another-invalid-memory-access-in-1091.pdf.asan.7.patch),
    8b6dc55e530b2f5ede6b9dfb64aafdd1d5836492 (adapted patch
    upstream_Fix-invalid-memory-access-in-1150.pdf.asan.8.69.patch), and
    e14b6e9c13d35c9bd1e0c50906ace8e707816888 (adapted patch
    upstream_Fix-invalid-memory-access-in-2030.pdf.asan.69.463.patch) to fix
    CVE-2013-1788.
  * Backport upstream commit b1026b5978c385328f2a15a2185c599a563edf91 to fix
    CVE-2013-1790 (patch upstream_Initialize-refLine-totally.patch).
  * With the changes above, this upload closes: #702071.

debian/wheezy 2013-03-26 04:20:37 UTC 2013-03-26
Import patches-unapplied version 0.18.4-6 to debian/sid

Author: Pino Toscano
Author Date: 2013-03-25 20:43:07 UTC

Import patches-unapplied version 0.18.4-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 3b9b4a35b3a3939b154237e555b01d2b4868e3b6

New changelog entries:
  * Backport upstream commits 0388837f01bc467045164f9ddaff787000a8caaa (patch
    upstream_Fix-another-invalid-memory-access-in-1091.pdf.asan.7.patch),
    8b6dc55e530b2f5ede6b9dfb64aafdd1d5836492 (adapted patch
    upstream_Fix-invalid-memory-access-in-1150.pdf.asan.8.69.patch), and
    e14b6e9c13d35c9bd1e0c50906ace8e707816888 (adapted patch
    upstream_Fix-invalid-memory-access-in-2030.pdf.asan.69.463.patch) to fix
    CVE-2013-1788.
  * Backport upstream commit b1026b5978c385328f2a15a2185c599a563edf91 to fix
    CVE-2013-1790 (patch upstream_Initialize-refLine-totally.patch).
  * With the changes above, this upload closes: #702071.

ubuntu/quantal-proposed 2013-01-03 22:03:13 UTC 2013-01-03
Import patches-unapplied version 0.20.4-0ubuntu1.1 to ubuntu/quantal-proposed

Author: Matthieu Baerts
Author Date: 2012-11-10 15:53:36 UTC

Import patches-unapplied version 0.20.4-0ubuntu1.1 to ubuntu/quantal-proposed

Imported using git-ubuntu import.

Changelog parent: b00fb8bfcbb8b21840f099adcafcd7e0761ee964

New changelog entries:
  * debian/patches/git_gouraud_shading_support.patch: (LP: #1072129)
    - Evince crashes after opening certain PDF file because parameterized
      Gouraud shading is not supported.

ubuntu/precise-proposed 2012-12-19 02:33:48 UTC 2012-12-19
Import patches-unapplied version 0.18.4-1ubuntu3 to ubuntu/precise-proposed

Author: Sebastien Bacher
Author Date: 2012-12-04 18:39:07 UTC

Import patches-unapplied version 0.18.4-1ubuntu3 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: bed57a7d49d2ad0db9ff994db3eb682dc883ee35

New changelog entries:
  * debian/patches/git_no_buggy_check.patch:
    "Don't do a check for sanity that then we don't use" (lp: #1020162)

ubuntu/quantal 2012-09-11 23:33:20 UTC 2012-09-11
Import patches-unapplied version 0.20.4-0ubuntu1 to ubuntu/quantal

Author: Robert Ancell
Author Date: 2012-09-11 22:53:15 UTC

Import patches-unapplied version 0.20.4-0ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 3789c82125db7d151f0188d0ab9cd80e38bea594

New changelog entries:
  * New upstream bugfix release
  * debian/control:
  * debian/rules:
  * debian/libpoppler28.install:
    - libpoppler27 -> libpoppler28

ubuntu/precise 2012-03-01 20:33:50 UTC 2012-03-01
Import patches-unapplied version 0.18.4-1ubuntu2 to ubuntu/precise

Author: Martin Pitt
Author Date: 2012-02-27 07:56:28 UTC

Import patches-unapplied version 0.18.4-1ubuntu2 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: e2f1cc521288958795f2360ec15408d368e76875

New changelog entries:
  * debian/control: Add back libfontconfig1-dev dependency to libpoppler-dev
    for the time being, to avoid introducing FTBFS at this point. This will be
    dropped again later on when all reverse dependencies have their build deps
    fixed. Thanks Pino Toscano for pointing this out!

ubuntu/oneiric 2011-08-19 14:03:59 UTC 2011-08-19
Import patches-unapplied version 0.16.7-2ubuntu2 to ubuntu/oneiric

Author: Till Kamppeter
Author Date: 2011-08-19 13:10:18 UTC

Import patches-unapplied version 0.16.7-2ubuntu2 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: 3d3e10cb8d1ad886b2d677ec8f1ae3cd4c4729d1

New changelog entries:
  * debian/patches/15_output-tiling-patterns-issuing-PS-patterns.patch,
    debian/patches/17_dont-use-patterns-when-only-one-instance-is-used.patch:
    Backported upstream patch to use PostScript Patterns for tiling fill when
    output PostScript level >= 2 and to avoid using /PatternType if only one
    instance of the pattern is used. This should fix LP: #817049.

ubuntu/lucid-proposed 2011-05-30 06:09:58 UTC 2011-05-30
Import patches-unapplied version 0.12.4-0ubuntu5.2 to ubuntu/lucid-proposed

Author: Nobuto Murata
Author Date: 2011-04-26 00:58:25 UTC

Import patches-unapplied version 0.12.4-0ubuntu5.2 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 400c1ed5a114a97b3cc1a7ffe808ac57135e29d3

New changelog entries:
  * debian/patches/12_set-font-weight-medium.patch: added
    - set FC_WEIGHT_MEDIUM when the font name contains "Medium", LP: #769827

ubuntu/natty-devel 2011-04-26 21:04:54 UTC 2011-04-26
Import patches-unapplied version 0.16.4-0ubuntu1.1 to ubuntu/natty-proposed

Author: Nobuto Murata
Author Date: 2011-04-25 16:11:24 UTC

Import patches-unapplied version 0.16.4-0ubuntu1.1 to ubuntu/natty-proposed

Imported using git-ubuntu import.

Changelog parent: b85246ba7ba1cc2b16ef87914f084c7118c3e54a

New changelog entries:
  * debian/patches/11_set-font-weight-medium.patch: added
    - set FC_WEIGHT_MEDIUM when the font name contains "Medium", LP: #769827

ubuntu/natty-proposed 2011-04-26 21:04:54 UTC 2011-04-26
Import patches-unapplied version 0.16.4-0ubuntu1.1 to ubuntu/natty-proposed

Author: Nobuto Murata
Author Date: 2011-04-25 16:11:24 UTC

Import patches-unapplied version 0.16.4-0ubuntu1.1 to ubuntu/natty-proposed

Imported using git-ubuntu import.

Changelog parent: b85246ba7ba1cc2b16ef87914f084c7118c3e54a

New changelog entries:
  * debian/patches/11_set-font-weight-medium.patch: added
    - set FC_WEIGHT_MEDIUM when the font name contains "Medium", LP: #769827

ubuntu/natty-updates 2011-04-26 21:04:54 UTC 2011-04-26
Import patches-unapplied version 0.16.4-0ubuntu1.1 to ubuntu/natty-proposed

Author: Nobuto Murata
Author Date: 2011-04-25 16:11:24 UTC

Import patches-unapplied version 0.16.4-0ubuntu1.1 to ubuntu/natty-proposed

Imported using git-ubuntu import.

Changelog parent: b85246ba7ba1cc2b16ef87914f084c7118c3e54a

New changelog entries:
  * debian/patches/11_set-font-weight-medium.patch: added
    - set FC_WEIGHT_MEDIUM when the font name contains "Medium", LP: #769827

ubuntu/natty 2011-04-05 15:05:59 UTC 2011-04-05
Import patches-unapplied version 0.16.4-0ubuntu1 to ubuntu/natty

Author: Sebastien Bacher
Author Date: 2011-04-05 14:23:40 UTC

Import patches-unapplied version 0.16.4-0ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: be867c6b3a89882000fa5c1bec123441b8885f85

New changelog entries:
  * New upstream version

1100 of 155 results

Other repositories

Name Last Modified
lp:ubuntu/+source/poppler 2018-12-13
11 of 1 result
You can't create new repositories for poppler in Ubuntu.