View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/policykit-1
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2019-08-16 14:59:15 UTC 2019-08-16
DSC file for 0.105-26ubuntu1

Author: Ubuntu Git Importer
Author Date: 2019-08-16 14:59:15 UTC

DSC file for 0.105-26ubuntu1

applied/ubuntu/focal-devel 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: b2294873153e4e46583dcc6a2e11c005354dd291
Unapplied parent: 72c6b511cbd20284303f25a88e6d72696fc800ed

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

ubuntu/focal-devel 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e928eff7b44c2cade0a8a3aecd507f177ca0ba35

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

ubuntu/devel 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e928eff7b44c2cade0a8a3aecd507f177ca0ba35

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

ubuntu/eoan 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e928eff7b44c2cade0a8a3aecd507f177ca0ba35

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

ubuntu/eoan-devel 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e928eff7b44c2cade0a8a3aecd507f177ca0ba35

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

ubuntu/eoan-proposed 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e928eff7b44c2cade0a8a3aecd507f177ca0ba35

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

ubuntu/focal 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-unapplied version 0.105-26ubuntu1 to ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: e928eff7b44c2cade0a8a3aecd507f177ca0ba35

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

applied/ubuntu/devel 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: b2294873153e4e46583dcc6a2e11c005354dd291
Unapplied parent: 72c6b511cbd20284303f25a88e6d72696fc800ed

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

applied/ubuntu/focal 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: b2294873153e4e46583dcc6a2e11c005354dd291
Unapplied parent: 72c6b511cbd20284303f25a88e6d72696fc800ed

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

applied/ubuntu/eoan-proposed 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: b2294873153e4e46583dcc6a2e11c005354dd291
Unapplied parent: 72c6b511cbd20284303f25a88e6d72696fc800ed

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

applied/ubuntu/eoan-devel 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: b2294873153e4e46583dcc6a2e11c005354dd291
Unapplied parent: 72c6b511cbd20284303f25a88e6d72696fc800ed

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

applied/ubuntu/eoan 2019-08-16 14:48:22 UTC 2019-08-16
Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Author: Iain Lane
Author Date: 2019-08-16 12:37:39 UTC

Import patches-applied version 0.105-26ubuntu1 to applied/ubuntu/eoan-proposed

Imported using git-ubuntu import.

Changelog parent: b2294873153e4e46583dcc6a2e11c005354dd291
Unapplied parent: 72c6b511cbd20284303f25a88e6d72696fc800ed

New changelog entries:
  * Revert "Depend on new virtual packages default-logind and logind". We
    don't yet have a systemd which provides these virtual packages, rendering
    policykit-1 uninstallable. This change can be reverted once we do.

importer/debian/dsc 2019-08-11 22:41:21 UTC 2019-08-11
DSC file for 0.105-26

Author: Ubuntu Git Importer
Author Date: 2019-08-11 22:41:21 UTC

DSC file for 0.105-26

debian/sid 2019-08-11 22:34:47 UTC 2019-08-11
Import patches-unapplied version 0.105-26 to debian/sid

Author: Simon McVittie
Author Date: 2019-08-11 18:09:35 UTC

Import patches-unapplied version 0.105-26 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 33d74ac2b6b8caa8de0d15986c433027c1a0a768

New changelog entries:
  [ Mark Hindley ]
  * Depend on new virtual packages default-logind and logind
    (Closes: #923240)
  [ Simon McVittie ]
  * Apply most changes from upstream release 0.116
    - d/p/0.116/Elaborate-message-printed-by-polkit-when-disconnecting-fr.patch,
      d/p/0.116/Error-message-raised-on-every-systemctl-start-in-emergenc.patch:
      Reduce messages to stderr from polkit agents, in particular when using
      "systemctl reboot" on a ssh connection or when using "systemctl start"
      in systemd emergency mode
    - d/p/0.116/Fix-a-critical-warning-on-calling-polkit_permission_new_s.patch:
      Fix critical warnings when calling polkit_permission_new_sync() with
      no D-Bus system bus
    - d/p/0.116/Possible-resource-leak-found-by-static-analyzer.patch:
      Fix a potential use-after-free in polkit agents
    - d/p/0.116/pkttyagent-PolkitAgentTextListener-leaves-echo-tty-disabl.patch:
      Re-enable echo if the tty agent is killed by SIGINT or SIGTERM
      or suspended with SIGTSTP
  * Add more bug fixes backported from earlier upstream releases
    - d/p/0.108/PolkitAgent-Avoid-crashing-if-initializing-the-server-obj.patch:
      Fix a segfault when a library user like flatpak attempts to register
      a polkit agent with no system bus available (Closes: #923046)
    - d/p/0.111/Add-a-FIXME-to-polkitprivate.h.patch:
      Make it more obvious that polkitprivate.h was never intended to be API
    - d/p/0.114/polkitpermission-Fix-a-memory-leak-on-authority-changes.patch:
      Fix a memory leak
    - d/p/0.113/PolkitSystemBusName-Retrieve-both-pid-and-uid.patch:
      Avoid a use of the deprecated polkit_unix_process_new()
  * d/*.symbols: Add Build-Depends-Package metadata
  * d/policykit-1.lintian-overrides: Override systemd unit false positives.
    The systemd unit is only for on-demand D-Bus activation, and is not
    intended to be started during boot, so an [Install] section and a
    parallel LSB init script are not necessary.
  * Stop building libpolkit-backend as a shared library.
    Its API was never declared stable before upstream removed it in
    0.106. Nothing in Debian depended on it, except for polkitd itself,
    which now links the same code statically.
    This is a step towards being able to use the current upstream release of
    polkit and patch in the old localauthority backend as an alternative to
    the JavaScript backend, instead of using the old 0.105 codebase and
    patching in essentially every change except the JavaScript backend,
    which is becoming unmanageable.
    - Remove the example null backend, which is pointless now that we've
      removed the ability to extend polkit.
    - Remove obsolete conffile 50-nullbackend.conf on upgrade
    - Remove the directory that previously contained 50-nullbackend.conf
      after upgrading or removing policykit-1
    - Remove obsolete dh_makeshlibs override for the null backend
  * d/policykit-1.bug-control: Add systemd, elogind versions to bug reports.
    reportbug doesn't currently seem to interpret
    "Depends: default-logind | logind" as implying that it should include
    the version number of the package that Provides logind in bug reports.
    Workaround for #934472.
  * Change the policykit-1 package from Architecture: any to
    Architecture: linux-any, and remove the consolekit [!linux-any]
    dependency. consolekit is no longer available in any Debian or
    debian-ports architecture, even those for non-Linux kernels.
    (Closes: #918446)
  * Standards-Version: 4.4.0 (no changes required)
  * Switch to debhelper-compat 12
    - d/control: Add ${misc:Pre-Depends}
  * Switch to dh_missing and abort on uninstalled files
    (patch taken from experimental, thanks to Michael Biebl)

applied/debian/sid 2019-08-11 22:34:47 UTC 2019-08-11
Import patches-applied version 0.105-26 to applied/debian/sid

Author: Simon McVittie
Author Date: 2019-08-11 18:09:35 UTC

Import patches-applied version 0.105-26 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7e092e881be88d96914deec8a32b62999fc37e66
Unapplied parent: ed752d5de5a8a1bd100ffe78ad8ad53685a2d810

New changelog entries:
  [ Mark Hindley ]
  * Depend on new virtual packages default-logind and logind
    (Closes: #923240)
  [ Simon McVittie ]
  * Apply most changes from upstream release 0.116
    - d/p/0.116/Elaborate-message-printed-by-polkit-when-disconnecting-fr.patch,
      d/p/0.116/Error-message-raised-on-every-systemctl-start-in-emergenc.patch:
      Reduce messages to stderr from polkit agents, in particular when using
      "systemctl reboot" on a ssh connection or when using "systemctl start"
      in systemd emergency mode
    - d/p/0.116/Fix-a-critical-warning-on-calling-polkit_permission_new_s.patch:
      Fix critical warnings when calling polkit_permission_new_sync() with
      no D-Bus system bus
    - d/p/0.116/Possible-resource-leak-found-by-static-analyzer.patch:
      Fix a potential use-after-free in polkit agents
    - d/p/0.116/pkttyagent-PolkitAgentTextListener-leaves-echo-tty-disabl.patch:
      Re-enable echo if the tty agent is killed by SIGINT or SIGTERM
      or suspended with SIGTSTP
  * Add more bug fixes backported from earlier upstream releases
    - d/p/0.108/PolkitAgent-Avoid-crashing-if-initializing-the-server-obj.patch:
      Fix a segfault when a library user like flatpak attempts to register
      a polkit agent with no system bus available (Closes: #923046)
    - d/p/0.111/Add-a-FIXME-to-polkitprivate.h.patch:
      Make it more obvious that polkitprivate.h was never intended to be API
    - d/p/0.114/polkitpermission-Fix-a-memory-leak-on-authority-changes.patch:
      Fix a memory leak
    - d/p/0.113/PolkitSystemBusName-Retrieve-both-pid-and-uid.patch:
      Avoid a use of the deprecated polkit_unix_process_new()
  * d/*.symbols: Add Build-Depends-Package metadata
  * d/policykit-1.lintian-overrides: Override systemd unit false positives.
    The systemd unit is only for on-demand D-Bus activation, and is not
    intended to be started during boot, so an [Install] section and a
    parallel LSB init script are not necessary.
  * Stop building libpolkit-backend as a shared library.
    Its API was never declared stable before upstream removed it in
    0.106. Nothing in Debian depended on it, except for polkitd itself,
    which now links the same code statically.
    This is a step towards being able to use the current upstream release of
    polkit and patch in the old localauthority backend as an alternative to
    the JavaScript backend, instead of using the old 0.105 codebase and
    patching in essentially every change except the JavaScript backend,
    which is becoming unmanageable.
    - Remove the example null backend, which is pointless now that we've
      removed the ability to extend polkit.
    - Remove obsolete conffile 50-nullbackend.conf on upgrade
    - Remove the directory that previously contained 50-nullbackend.conf
      after upgrading or removing policykit-1
    - Remove obsolete dh_makeshlibs override for the null backend
  * d/policykit-1.bug-control: Add systemd, elogind versions to bug reports.
    reportbug doesn't currently seem to interpret
    "Depends: default-logind | logind" as implying that it should include
    the version number of the package that Provides logind in bug reports.
    Workaround for #934472.
  * Change the policykit-1 package from Architecture: any to
    Architecture: linux-any, and remove the consolekit [!linux-any]
    dependency. consolekit is no longer available in any Debian or
    debian-ports architecture, even those for non-Linux kernels.
    (Closes: #918446)
  * Standards-Version: 4.4.0 (no changes required)
  * Switch to debhelper-compat 12
    - d/control: Add ${misc:Pre-Depends}
  * Switch to dh_missing and abort on uninstalled files
    (patch taken from experimental, thanks to Michael Biebl)

debian/experimental 2019-08-11 22:26:48 UTC 2019-08-11
Import patches-unapplied version 0.116-2 to debian/experimental

Author: Simon McVittie
Author Date: 2019-08-11 17:56:22 UTC

Import patches-unapplied version 0.116-2 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: e1df1930be2b493b5661e84e591896b757f7ab25

New changelog entries:
  [ Mark Hindley ]
  * Depend on new virtual packages default-logind and logind
    (Closes: #923240)
  [ Simon McVittie ]
  * d/*.symbols: Add Build-Depends-Package metadata
  * d/policykit-1.lintian-overrides: Override systemd unit false positives.
    The systemd unit is only for on-demand D-Bus activation, and is not
    intended to be started during boot, so an [Install] section and a
    parallel LSB init script are not necessary.
  * d/policykit-1.bug-control: Add systemd, elogind versions to bug reports.
    reportbug doesn't currently seem to interpret
    "Depends: default-logind | logind" as implying that it should include
    the version number of the package that Provides logind in bug reports.
    Workaround for #934472.
  * Standards-Version: 4.4.0 (no changes required)
  * Switch to debhelper-compat 12

applied/debian/experimental 2019-08-11 22:26:48 UTC 2019-08-11
Import patches-applied version 0.116-2 to applied/debian/experimental

Author: Simon McVittie
Author Date: 2019-08-11 17:56:22 UTC

Import patches-applied version 0.116-2 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: aa018cd0313be1a887e0e18e2ceab00714106714
Unapplied parent: 715e8807be582bfd6296825847e04bcabfaf97b4

New changelog entries:
  [ Mark Hindley ]
  * Depend on new virtual packages default-logind and logind
    (Closes: #923240)
  [ Simon McVittie ]
  * d/*.symbols: Add Build-Depends-Package metadata
  * d/policykit-1.lintian-overrides: Override systemd unit false positives.
    The systemd unit is only for on-demand D-Bus activation, and is not
    intended to be started during boot, so an [Install] section and a
    parallel LSB init script are not necessary.
  * d/policykit-1.bug-control: Add systemd, elogind versions to bug reports.
    reportbug doesn't currently seem to interpret
    "Depends: default-logind | logind" as implying that it should include
    the version number of the package that Provides logind in bug reports.
    Workaround for #934472.
  * Standards-Version: 4.4.0 (no changes required)
  * Switch to debhelper-compat 12

applied/ubuntu/xenial-security 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-14.1ubuntu0.5 to applied/ubuntu/xenial-s...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:28 UTC

Import patches-applied version 0.105-14.1ubuntu0.5 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 2a18978fcfea1c8dff83f21ae4ac6c99c4de0037
Unapplied parent: db08047ab38a136e5486a723e506184b7d59053d

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/xenial-updates 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-14.1ubuntu0.5 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:28 UTC

Import patches-unapplied version 0.105-14.1ubuntu0.5 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 5f2921c5443095b0bc8b3a9a41717243d6a233be

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/xenial-security 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-14.1ubuntu0.5 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:28 UTC

Import patches-unapplied version 0.105-14.1ubuntu0.5 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 5f2921c5443095b0bc8b3a9a41717243d6a233be

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/bionic-devel 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-20ubuntu0.18.04.5 to applied/ubuntu/bion...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:02 UTC

Import patches-applied version 0.105-20ubuntu0.18.04.5 to applied/ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: 95ec9821dddf734604b7cd729cec49ddc60d9cef
Unapplied parent: d8e05ad2907d71a78e495d2e48952c47226bd322

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/bionic-security 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-20ubuntu0.18.04.5 to applied/ubuntu/bion...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:02 UTC

Import patches-applied version 0.105-20ubuntu0.18.04.5 to applied/ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: 95ec9821dddf734604b7cd729cec49ddc60d9cef
Unapplied parent: d8e05ad2907d71a78e495d2e48952c47226bd322

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/bionic-updates 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-20ubuntu0.18.04.5 to applied/ubuntu/bion...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:02 UTC

Import patches-applied version 0.105-20ubuntu0.18.04.5 to applied/ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: 95ec9821dddf734604b7cd729cec49ddc60d9cef
Unapplied parent: d8e05ad2907d71a78e495d2e48952c47226bd322

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/cosmic-devel 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-21ubuntu0.4 to applied/ubuntu/cosmic-sec...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:51:01 UTC

Import patches-applied version 0.105-21ubuntu0.4 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: c7a0d751c8f3659890ebae1fb22785f0acd985b3
Unapplied parent: 487018c8ff78f633dcac6960813772397c0afe70

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/cosmic-security 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-21ubuntu0.4 to applied/ubuntu/cosmic-sec...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:51:01 UTC

Import patches-applied version 0.105-21ubuntu0.4 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: c7a0d751c8f3659890ebae1fb22785f0acd985b3
Unapplied parent: 487018c8ff78f633dcac6960813772397c0afe70

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/cosmic-updates 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-21ubuntu0.4 to applied/ubuntu/cosmic-sec...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:51:01 UTC

Import patches-applied version 0.105-21ubuntu0.4 to applied/ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: c7a0d751c8f3659890ebae1fb22785f0acd985b3
Unapplied parent: 487018c8ff78f633dcac6960813772397c0afe70

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/xenial-devel 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-14.1ubuntu0.5 to ubuntu/xenial-security

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:28 UTC

Import patches-unapplied version 0.105-14.1ubuntu0.5 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 5f2921c5443095b0bc8b3a9a41717243d6a233be

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/trusty-updates 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-4ubuntu3.14.04.6 to ubuntu/trusty-secu...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:59 UTC

Import patches-unapplied version 0.105-4ubuntu3.14.04.6 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: a3cf6a144e0d062dd4ff61732e7400c6af22f425

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/trusty-security 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-4ubuntu3.14.04.6 to ubuntu/trusty-secu...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:59 UTC

Import patches-unapplied version 0.105-4ubuntu3.14.04.6 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: a3cf6a144e0d062dd4ff61732e7400c6af22f425

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/trusty-devel 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-4ubuntu3.14.04.6 to ubuntu/trusty-secu...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:59 UTC

Import patches-unapplied version 0.105-4ubuntu3.14.04.6 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: a3cf6a144e0d062dd4ff61732e7400c6af22f425

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/cosmic-updates 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-21ubuntu0.4 to ubuntu/cosmic-security

Author: Marc Deslauriers
Author Date: 2019-03-27 13:51:01 UTC

Import patches-unapplied version 0.105-21ubuntu0.4 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: f767f93042e3c3df82af7449d64e41365febbd38

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/cosmic-security 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-21ubuntu0.4 to ubuntu/cosmic-security

Author: Marc Deslauriers
Author Date: 2019-03-27 13:51:01 UTC

Import patches-unapplied version 0.105-21ubuntu0.4 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: f767f93042e3c3df82af7449d64e41365febbd38

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/cosmic-devel 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-21ubuntu0.4 to ubuntu/cosmic-security

Author: Marc Deslauriers
Author Date: 2019-03-27 13:51:01 UTC

Import patches-unapplied version 0.105-21ubuntu0.4 to ubuntu/cosmic-security

Imported using git-ubuntu import.

Changelog parent: f767f93042e3c3df82af7449d64e41365febbd38

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/bionic-updates 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-20ubuntu0.18.04.5 to ubuntu/bionic-sec...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:02 UTC

Import patches-unapplied version 0.105-20ubuntu0.18.04.5 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: ad033d856cac22f8e6297313768bc9b5b6ecb3a3

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/bionic-security 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-20ubuntu0.18.04.5 to ubuntu/bionic-sec...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:02 UTC

Import patches-unapplied version 0.105-20ubuntu0.18.04.5 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: ad033d856cac22f8e6297313768bc9b5b6ecb3a3

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

ubuntu/bionic-devel 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-unapplied version 0.105-20ubuntu0.18.04.5 to ubuntu/bionic-sec...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:02 UTC

Import patches-unapplied version 0.105-20ubuntu0.18.04.5 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: ad033d856cac22f8e6297313768bc9b5b6ecb3a3

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/trusty-devel 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-4ubuntu3.14.04.6 to applied/ubuntu/trust...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:59 UTC

Import patches-applied version 0.105-4ubuntu3.14.04.6 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 86bb4cdd44055b7dba49b8f8e94cd0f9a8246ae9
Unapplied parent: f4a5fd6055bf120c3486f35b5cfd2b7ca771760d

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/trusty-security 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-4ubuntu3.14.04.6 to applied/ubuntu/trust...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:59 UTC

Import patches-applied version 0.105-4ubuntu3.14.04.6 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 86bb4cdd44055b7dba49b8f8e94cd0f9a8246ae9
Unapplied parent: f4a5fd6055bf120c3486f35b5cfd2b7ca771760d

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/trusty-updates 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-4ubuntu3.14.04.6 to applied/ubuntu/trust...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:59 UTC

Import patches-applied version 0.105-4ubuntu3.14.04.6 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 86bb4cdd44055b7dba49b8f8e94cd0f9a8246ae9
Unapplied parent: f4a5fd6055bf120c3486f35b5cfd2b7ca771760d

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/xenial-updates 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-14.1ubuntu0.5 to applied/ubuntu/xenial-s...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:28 UTC

Import patches-applied version 0.105-14.1ubuntu0.5 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 2a18978fcfea1c8dff83f21ae4ac6c99c4de0037
Unapplied parent: db08047ab38a136e5486a723e506184b7d59053d

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

applied/ubuntu/xenial-devel 2019-04-03 11:43:17 UTC 2019-04-03
Import patches-applied version 0.105-14.1ubuntu0.5 to applied/ubuntu/xenial-s...

Author: Marc Deslauriers
Author Date: 2019-03-27 13:57:28 UTC

Import patches-applied version 0.105-14.1ubuntu0.5 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 2a18978fcfea1c8dff83f21ae4ac6c99c4de0037
Unapplied parent: db08047ab38a136e5486a723e506184b7d59053d

New changelog entries:
  * SECURITY UPDATE: start time protection mechanism bypass
    - debian/patches/CVE-2019-6133.patch: Compare PolkitUnixProcess uids
      for temporary authorizations in src/polkit/polkitsubject.c,
      src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c.
    - CVE-2019-6133

debian/stretch 2019-02-16 17:15:53 UTC 2019-02-16
Import patches-unapplied version 0.105-18+deb9u1 to debian/stretch

Author: Moritz M├╝hlenhoff
Author Date: 2018-12-06 17:38:04 UTC

Import patches-unapplied version 0.105-18+deb9u1 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: 7317b4120714eb351f52ac5604ce7ce189b8caea

New changelog entries:
  * CVE-2018-19788 (Closes: #915332)

applied/debian/stretch 2019-02-16 17:15:53 UTC 2019-02-16
Import patches-applied version 0.105-18+deb9u1 to applied/debian/stretch

Author: Moritz M├╝hlenhoff
Author Date: 2018-12-06 17:38:04 UTC

Import patches-applied version 0.105-18+deb9u1 to applied/debian/stretch

Imported using git-ubuntu import.

Changelog parent: 66b0b19e8e803dfc618e17246dfd336c0e82ef84
Unapplied parent: 14bd510d3bd305f110b6c73a82b38f9c73a21e08

New changelog entries:
  * CVE-2018-19788 (Closes: #915332)

ubuntu/disco-devel 2019-01-15 22:38:17 UTC 2019-01-15
Import patches-unapplied version 0.105-25 to debian/sid

Author: Jeremy Bicha
Author Date: 2019-01-15 16:11:58 UTC

Import patches-unapplied version 0.105-25 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 298bd6212cc5b94c77eb2f7b34357f0e98fb983e

New changelog entries:
  * Team upload
  * Add tests-add-tests-for-high-uids.patch
    - Patch from upstream modified by Ubuntu to test high UID fix
  * Compare PolkitUnixProcess uids for temporary authorizations.
    - Fix temporary auth hijacking via PID reuse and non-atomic fork
      (CVE-2019-6133) (Closes: #918985)

debian/buster 2019-01-15 22:38:17 UTC 2019-01-15
Import patches-unapplied version 0.105-25 to debian/sid

Author: Jeremy Bicha
Author Date: 2019-01-15 16:11:58 UTC

Import patches-unapplied version 0.105-25 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 298bd6212cc5b94c77eb2f7b34357f0e98fb983e

New changelog entries:
  * Team upload
  * Add tests-add-tests-for-high-uids.patch
    - Patch from upstream modified by Ubuntu to test high UID fix
  * Compare PolkitUnixProcess uids for temporary authorizations.
    - Fix temporary auth hijacking via PID reuse and non-atomic fork
      (CVE-2019-6133) (Closes: #918985)

applied/debian/buster 2019-01-15 22:38:17 UTC 2019-01-15
Import patches-applied version 0.105-25 to applied/debian/sid

Author: Jeremy Bicha
Author Date: 2019-01-15 16:11:58 UTC

Import patches-applied version 0.105-25 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 952cdb25865844c457ce9185791c4c15705d910f
Unapplied parent: 94eea80e76668ff408430ec917a4f1276f786800

New changelog entries:
  * Team upload
  * Add tests-add-tests-for-high-uids.patch
    - Patch from upstream modified by Ubuntu to test high UID fix
  * Compare PolkitUnixProcess uids for temporary authorizations.
    - Fix temporary auth hijacking via PID reuse and non-atomic fork
      (CVE-2019-6133) (Closes: #918985)

applied/ubuntu/disco-proposed 2019-01-15 22:38:17 UTC 2019-01-15
Import patches-applied version 0.105-25 to applied/debian/sid

Author: Jeremy Bicha
Author Date: 2019-01-15 16:11:58 UTC

Import patches-applied version 0.105-25 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 952cdb25865844c457ce9185791c4c15705d910f
Unapplied parent: 94eea80e76668ff408430ec917a4f1276f786800

New changelog entries:
  * Team upload
  * Add tests-add-tests-for-high-uids.patch
    - Patch from upstream modified by Ubuntu to test high UID fix
  * Compare PolkitUnixProcess uids for temporary authorizations.
    - Fix temporary auth hijacking via PID reuse and non-atomic fork
      (CVE-2019-6133) (Closes: #918985)

applied/ubuntu/disco-devel 2019-01-15 22:38:17 UTC 2019-01-15
Import patches-applied version 0.105-25 to applied/debian/sid

Author: Jeremy Bicha
Author Date: 2019-01-15 16:11:58 UTC

Import patches-applied version 0.105-25 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 952cdb25865844c457ce9185791c4c15705d910f
Unapplied parent: 94eea80e76668ff408430ec917a4f1276f786800

New changelog entries:
  * Team upload
  * Add tests-add-tests-for-high-uids.patch
    - Patch from upstream modified by Ubuntu to test high UID fix
  * Compare PolkitUnixProcess uids for temporary authorizations.
    - Fix temporary auth hijacking via PID reuse and non-atomic fork
      (CVE-2019-6133) (Closes: #918985)

applied/ubuntu/disco 2019-01-15 22:38:17 UTC 2019-01-15
Import patches-applied version 0.105-25 to applied/debian/sid

Author: Jeremy Bicha
Author Date: 2019-01-15 16:11:58 UTC

Import patches-applied version 0.105-25 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 952cdb25865844c457ce9185791c4c15705d910f
Unapplied parent: 94eea80e76668ff408430ec917a4f1276f786800

New changelog entries:
  * Team upload
  * Add tests-add-tests-for-high-uids.patch
    - Patch from upstream modified by Ubuntu to test high UID fix
  * Compare PolkitUnixProcess uids for temporary authorizations.
    - Fix temporary auth hijacking via PID reuse and non-atomic fork
      (CVE-2019-6133) (Closes: #918985)

ubuntu/disco-proposed 2019-01-15 22:38:17 UTC 2019-01-15
Import patches-unapplied version 0.105-25 to debian/sid

Author: Jeremy Bicha
Author Date: 2019-01-15 16:11:58 UTC

Import patches-unapplied version 0.105-25 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 298bd6212cc5b94c77eb2f7b34357f0e98fb983e

New changelog entries:
  * Team upload
  * Add tests-add-tests-for-high-uids.patch
    - Patch from upstream modified by Ubuntu to test high UID fix
  * Compare PolkitUnixProcess uids for temporary authorizations.
    - Fix temporary auth hijacking via PID reuse and non-atomic fork
      (CVE-2019-6133) (Closes: #918985)

ubuntu/disco 2019-01-15 22:38:17 UTC 2019-01-15
Import patches-unapplied version 0.105-25 to debian/sid

Author: Jeremy Bicha
Author Date: 2019-01-15 16:11:58 UTC

Import patches-unapplied version 0.105-25 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 298bd6212cc5b94c77eb2f7b34357f0e98fb983e

New changelog entries:
  * Team upload
  * Add tests-add-tests-for-high-uids.patch
    - Patch from upstream modified by Ubuntu to test high UID fix
  * Compare PolkitUnixProcess uids for temporary authorizations.
    - Fix temporary auth hijacking via PID reuse and non-atomic fork
      (CVE-2019-6133) (Closes: #918985)

ubuntu/artful-devel 2018-07-16 15:38:24 UTC 2018-07-16
Import patches-unapplied version 0.105-18ubuntu0.1 to ubuntu/artful-security

Author: Marc Deslauriers
Author Date: 2018-07-13 11:43:05 UTC

Import patches-unapplied version 0.105-18ubuntu0.1 to ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 7317b4120714eb351f52ac5604ce7ce189b8caea

New changelog entries:
  * SECURITY UPDATE: DoS and information disclosure
    - debian/patches/CVE-2018-1116.patch: properly check UID in
      src/polkit/polkitprivate.h, src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c,
      src/polkitbackend/polkitbackendsessionmonitor-systemd.c,
      src/polkitbackend/polkitbackendsessionmonitor.c,
      src/polkitbackend/polkitbackendsessionmonitor.h.
    - debian/libpolkit-gobject-1-0.symbols: updated for new private symbol.
    - CVE-2018-1116

ubuntu/artful-security 2018-07-16 15:38:24 UTC 2018-07-16
Import patches-unapplied version 0.105-18ubuntu0.1 to ubuntu/artful-security

Author: Marc Deslauriers
Author Date: 2018-07-13 11:43:05 UTC

Import patches-unapplied version 0.105-18ubuntu0.1 to ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 7317b4120714eb351f52ac5604ce7ce189b8caea

New changelog entries:
  * SECURITY UPDATE: DoS and information disclosure
    - debian/patches/CVE-2018-1116.patch: properly check UID in
      src/polkit/polkitprivate.h, src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c,
      src/polkitbackend/polkitbackendsessionmonitor-systemd.c,
      src/polkitbackend/polkitbackendsessionmonitor.c,
      src/polkitbackend/polkitbackendsessionmonitor.h.
    - debian/libpolkit-gobject-1-0.symbols: updated for new private symbol.
    - CVE-2018-1116

ubuntu/artful-updates 2018-07-16 15:38:24 UTC 2018-07-16
Import patches-unapplied version 0.105-18ubuntu0.1 to ubuntu/artful-security

Author: Marc Deslauriers
Author Date: 2018-07-13 11:43:05 UTC

Import patches-unapplied version 0.105-18ubuntu0.1 to ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 7317b4120714eb351f52ac5604ce7ce189b8caea

New changelog entries:
  * SECURITY UPDATE: DoS and information disclosure
    - debian/patches/CVE-2018-1116.patch: properly check UID in
      src/polkit/polkitprivate.h, src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c,
      src/polkitbackend/polkitbackendsessionmonitor-systemd.c,
      src/polkitbackend/polkitbackendsessionmonitor.c,
      src/polkitbackend/polkitbackendsessionmonitor.h.
    - debian/libpolkit-gobject-1-0.symbols: updated for new private symbol.
    - CVE-2018-1116

applied/ubuntu/artful-updates 2018-07-16 15:38:24 UTC 2018-07-16
Import patches-applied version 0.105-18ubuntu0.1 to applied/ubuntu/artful-sec...

Author: Marc Deslauriers
Author Date: 2018-07-13 11:43:05 UTC

Import patches-applied version 0.105-18ubuntu0.1 to applied/ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 66b0b19e8e803dfc618e17246dfd336c0e82ef84
Unapplied parent: 653bf07abc3f4db0570109901b6818149b09372d

New changelog entries:
  * SECURITY UPDATE: DoS and information disclosure
    - debian/patches/CVE-2018-1116.patch: properly check UID in
      src/polkit/polkitprivate.h, src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c,
      src/polkitbackend/polkitbackendsessionmonitor-systemd.c,
      src/polkitbackend/polkitbackendsessionmonitor.c,
      src/polkitbackend/polkitbackendsessionmonitor.h.
    - debian/libpolkit-gobject-1-0.symbols: updated for new private symbol.
    - CVE-2018-1116

applied/ubuntu/artful-security 2018-07-16 15:38:24 UTC 2018-07-16
Import patches-applied version 0.105-18ubuntu0.1 to applied/ubuntu/artful-sec...

Author: Marc Deslauriers
Author Date: 2018-07-13 11:43:05 UTC

Import patches-applied version 0.105-18ubuntu0.1 to applied/ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 66b0b19e8e803dfc618e17246dfd336c0e82ef84
Unapplied parent: 653bf07abc3f4db0570109901b6818149b09372d

New changelog entries:
  * SECURITY UPDATE: DoS and information disclosure
    - debian/patches/CVE-2018-1116.patch: properly check UID in
      src/polkit/polkitprivate.h, src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c,
      src/polkitbackend/polkitbackendsessionmonitor-systemd.c,
      src/polkitbackend/polkitbackendsessionmonitor.c,
      src/polkitbackend/polkitbackendsessionmonitor.h.
    - debian/libpolkit-gobject-1-0.symbols: updated for new private symbol.
    - CVE-2018-1116

applied/ubuntu/artful-devel 2018-07-16 15:38:24 UTC 2018-07-16
Import patches-applied version 0.105-18ubuntu0.1 to applied/ubuntu/artful-sec...

Author: Marc Deslauriers
Author Date: 2018-07-13 11:43:05 UTC

Import patches-applied version 0.105-18ubuntu0.1 to applied/ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: 66b0b19e8e803dfc618e17246dfd336c0e82ef84
Unapplied parent: 653bf07abc3f4db0570109901b6818149b09372d

New changelog entries:
  * SECURITY UPDATE: DoS and information disclosure
    - debian/patches/CVE-2018-1116.patch: properly check UID in
      src/polkit/polkitprivate.h, src/polkit/polkitunixprocess.c,
      src/polkitbackend/polkitbackendinteractiveauthority.c,
      src/polkitbackend/polkitbackendsessionmonitor-systemd.c,
      src/polkitbackend/polkitbackendsessionmonitor.c,
      src/polkitbackend/polkitbackendsessionmonitor.h.
    - debian/libpolkit-gobject-1-0.symbols: updated for new private symbol.
    - CVE-2018-1116

ubuntu/cosmic-proposed 2018-07-11 16:39:25 UTC 2018-07-11
Import patches-unapplied version 0.105-21 to debian/sid

Author: Simon McVittie
Author Date: 2018-07-11 08:29:32 UTC

Import patches-unapplied version 0.105-21 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6044c41292d35d1925b6851d0ea3c039c4cfe179

New changelog entries:
  * Remove --no-parallel now that parallel builds (hopefully) work.
    Thanks to Adrian Bunk for spotting this.
  * Refresh patches via gbp pq
  * Use one patch per upstream commit for easier metadata round-trips
  * Sync up src/polkitagent/polkitagenthelper-pam.c with 0.114
    - d/p/0.111/Fix-a-memory-leak.patch:
      Fix a memory leak when PAM authentication fails
    - d/p/0.113/Remove-a-redundant-assignment.patch:
      Fix a potential compiler warning
    - d/p/master/Fix-multi-line-pam-text-info.patch:
      Split into d/p/0.106/agenthelper-pam-Fix-newline-trimming-code.patch,
      d/p/0.114/Fix-multi-line-pam-text-info.patch,
      d/p/0.114/Refactor-send_to_helper-usage.patch
  * d/p/03_polkitunixsession_sessionid_from_display.patch:
    Replace with functionally identical
    d/p/0.114/Support-polkit-session-agent-running-outside-user-session.patch
    as applied upstream
  * d/watch: Use https
  * d/watch: Download upstream PGP signatures
  * debian/upstream/signing-key.asc: Add public keys for Ray Strode,
    Miloslav Trmac, David Zeuthen
  * d/gbp.conf: Merge upstream tags into the upstream branch
  * Add myself to Uploaders
  * d/gbp.conf: Set patch-numbers to false to match current practice
  * d/p/0.115/Fix-CVE-2018-1116-Trusting-client-supplied-UID.patch:
    Backport the security-significant part of 0.115 (CVE-2018-1116)
  * d/libpolkit-gobject-1-0.symbols: Update for new semi-private ABI
  * d/rules: Skip build-time tests if DEB_BUILD_OPTIONS=nocheck
  * Standards-Version: 4.1.5 (no changes required)
  * Set Rules-Requires-Root to no

ubuntu/cosmic 2018-07-11 16:39:25 UTC 2018-07-11
Import patches-unapplied version 0.105-21 to debian/sid

Author: Simon McVittie
Author Date: 2018-07-11 08:29:32 UTC

Import patches-unapplied version 0.105-21 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6044c41292d35d1925b6851d0ea3c039c4cfe179

New changelog entries:
  * Remove --no-parallel now that parallel builds (hopefully) work.
    Thanks to Adrian Bunk for spotting this.
  * Refresh patches via gbp pq
  * Use one patch per upstream commit for easier metadata round-trips
  * Sync up src/polkitagent/polkitagenthelper-pam.c with 0.114
    - d/p/0.111/Fix-a-memory-leak.patch:
      Fix a memory leak when PAM authentication fails
    - d/p/0.113/Remove-a-redundant-assignment.patch:
      Fix a potential compiler warning
    - d/p/master/Fix-multi-line-pam-text-info.patch:
      Split into d/p/0.106/agenthelper-pam-Fix-newline-trimming-code.patch,
      d/p/0.114/Fix-multi-line-pam-text-info.patch,
      d/p/0.114/Refactor-send_to_helper-usage.patch
  * d/p/03_polkitunixsession_sessionid_from_display.patch:
    Replace with functionally identical
    d/p/0.114/Support-polkit-session-agent-running-outside-user-session.patch
    as applied upstream
  * d/watch: Use https
  * d/watch: Download upstream PGP signatures
  * debian/upstream/signing-key.asc: Add public keys for Ray Strode,
    Miloslav Trmac, David Zeuthen
  * d/gbp.conf: Merge upstream tags into the upstream branch
  * Add myself to Uploaders
  * d/gbp.conf: Set patch-numbers to false to match current practice
  * d/p/0.115/Fix-CVE-2018-1116-Trusting-client-supplied-UID.patch:
    Backport the security-significant part of 0.115 (CVE-2018-1116)
  * d/libpolkit-gobject-1-0.symbols: Update for new semi-private ABI
  * d/rules: Skip build-time tests if DEB_BUILD_OPTIONS=nocheck
  * Standards-Version: 4.1.5 (no changes required)
  * Set Rules-Requires-Root to no

applied/ubuntu/cosmic-proposed 2018-07-11 16:39:25 UTC 2018-07-11
Import patches-applied version 0.105-21 to applied/debian/sid

Author: Simon McVittie
Author Date: 2018-07-11 08:29:32 UTC

Import patches-applied version 0.105-21 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e752dba6f603dd4aac16386b17268727496d80dd
Unapplied parent: 2955fbe87c9f5c00ebbd0d7d38105235b9ef7278

New changelog entries:
  * Remove --no-parallel now that parallel builds (hopefully) work.
    Thanks to Adrian Bunk for spotting this.
  * Refresh patches via gbp pq
  * Use one patch per upstream commit for easier metadata round-trips
  * Sync up src/polkitagent/polkitagenthelper-pam.c with 0.114
    - d/p/0.111/Fix-a-memory-leak.patch:
      Fix a memory leak when PAM authentication fails
    - d/p/0.113/Remove-a-redundant-assignment.patch:
      Fix a potential compiler warning
    - d/p/master/Fix-multi-line-pam-text-info.patch:
      Split into d/p/0.106/agenthelper-pam-Fix-newline-trimming-code.patch,
      d/p/0.114/Fix-multi-line-pam-text-info.patch,
      d/p/0.114/Refactor-send_to_helper-usage.patch
  * d/p/03_polkitunixsession_sessionid_from_display.patch:
    Replace with functionally identical
    d/p/0.114/Support-polkit-session-agent-running-outside-user-session.patch
    as applied upstream
  * d/watch: Use https
  * d/watch: Download upstream PGP signatures
  * debian/upstream/signing-key.asc: Add public keys for Ray Strode,
    Miloslav Trmac, David Zeuthen
  * d/gbp.conf: Merge upstream tags into the upstream branch
  * Add myself to Uploaders
  * d/gbp.conf: Set patch-numbers to false to match current practice
  * d/p/0.115/Fix-CVE-2018-1116-Trusting-client-supplied-UID.patch:
    Backport the security-significant part of 0.115 (CVE-2018-1116)
  * d/libpolkit-gobject-1-0.symbols: Update for new semi-private ABI
  * d/rules: Skip build-time tests if DEB_BUILD_OPTIONS=nocheck
  * Standards-Version: 4.1.5 (no changes required)
  * Set Rules-Requires-Root to no

applied/ubuntu/cosmic 2018-07-11 16:39:25 UTC 2018-07-11
Import patches-applied version 0.105-21 to applied/debian/sid

Author: Simon McVittie
Author Date: 2018-07-11 08:29:32 UTC

Import patches-applied version 0.105-21 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e752dba6f603dd4aac16386b17268727496d80dd
Unapplied parent: 2955fbe87c9f5c00ebbd0d7d38105235b9ef7278

New changelog entries:
  * Remove --no-parallel now that parallel builds (hopefully) work.
    Thanks to Adrian Bunk for spotting this.
  * Refresh patches via gbp pq
  * Use one patch per upstream commit for easier metadata round-trips
  * Sync up src/polkitagent/polkitagenthelper-pam.c with 0.114
    - d/p/0.111/Fix-a-memory-leak.patch:
      Fix a memory leak when PAM authentication fails
    - d/p/0.113/Remove-a-redundant-assignment.patch:
      Fix a potential compiler warning
    - d/p/master/Fix-multi-line-pam-text-info.patch:
      Split into d/p/0.106/agenthelper-pam-Fix-newline-trimming-code.patch,
      d/p/0.114/Fix-multi-line-pam-text-info.patch,
      d/p/0.114/Refactor-send_to_helper-usage.patch
  * d/p/03_polkitunixsession_sessionid_from_display.patch:
    Replace with functionally identical
    d/p/0.114/Support-polkit-session-agent-running-outside-user-session.patch
    as applied upstream
  * d/watch: Use https
  * d/watch: Download upstream PGP signatures
  * debian/upstream/signing-key.asc: Add public keys for Ray Strode,
    Miloslav Trmac, David Zeuthen
  * d/gbp.conf: Merge upstream tags into the upstream branch
  * Add myself to Uploaders
  * d/gbp.conf: Set patch-numbers to false to match current practice
  * d/p/0.115/Fix-CVE-2018-1116-Trusting-client-supplied-UID.patch:
    Backport the security-significant part of 0.115 (CVE-2018-1116)
  * d/libpolkit-gobject-1-0.symbols: Update for new semi-private ABI
  * d/rules: Skip build-time tests if DEB_BUILD_OPTIONS=nocheck
  * Standards-Version: 4.1.5 (no changes required)
  * Set Rules-Requires-Root to no

applied/ubuntu/bionic-proposed 2018-03-27 22:37:14 UTC 2018-03-27
Import patches-applied version 0.105-20 to applied/debian/sid

Author: Simon McVittie
Author Date: 2018-03-27 12:50:28 UTC

Import patches-applied version 0.105-20 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: dae5b1503e3569229b37b24478e755e18b9dba4a
Unapplied parent: b7039796c97b9895676be6e36e2480710bee42fe

New changelog entries:
  * Team upload
  * d/p/0.108/build-Fix-.gir-generation-for-parallel-make.patch:
    Add patch from upstream to fix parallel builds (Closes: #894205)

ubuntu/bionic 2018-03-27 22:37:14 UTC 2018-03-27
Import patches-unapplied version 0.105-20 to debian/sid

Author: Simon McVittie
Author Date: 2018-03-27 12:50:28 UTC

Import patches-unapplied version 0.105-20 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 794a12d71d05d87ab8159e5884d6bda3c1a7f3d0

New changelog entries:
  * Team upload
  * d/p/0.108/build-Fix-.gir-generation-for-parallel-make.patch:
    Add patch from upstream to fix parallel builds (Closes: #894205)

applied/ubuntu/bionic 2018-03-27 22:37:14 UTC 2018-03-27
Import patches-applied version 0.105-20 to applied/debian/sid

Author: Simon McVittie
Author Date: 2018-03-27 12:50:28 UTC

Import patches-applied version 0.105-20 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: dae5b1503e3569229b37b24478e755e18b9dba4a
Unapplied parent: b7039796c97b9895676be6e36e2480710bee42fe

New changelog entries:
  * Team upload
  * d/p/0.108/build-Fix-.gir-generation-for-parallel-make.patch:
    Add patch from upstream to fix parallel builds (Closes: #894205)

ubuntu/bionic-proposed 2018-03-27 22:37:14 UTC 2018-03-27
Import patches-unapplied version 0.105-20 to debian/sid

Author: Simon McVittie
Author Date: 2018-03-27 12:50:28 UTC

Import patches-unapplied version 0.105-20 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 794a12d71d05d87ab8159e5884d6bda3c1a7f3d0

New changelog entries:
  * Team upload
  * d/p/0.108/build-Fix-.gir-generation-for-parallel-make.patch:
    Add patch from upstream to fix parallel builds (Closes: #894205)

importer/ubuntu/pristine-tar 2018-03-06 14:50:20 UTC 2018-03-06
pristine-tar data for policykit-1_0.105.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-06 14:50:20 UTC

pristine-tar data for policykit-1_0.105.orig.tar.gz

importer/debian/pristine-tar 2018-03-06 14:39:53 UTC 2018-03-06
pristine-tar data for policykit-1_0.113.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-03-06 14:39:53 UTC

pristine-tar data for policykit-1_0.113.orig.tar.gz

ubuntu/artful 2017-05-24 22:16:39 UTC 2017-05-24
Import patches-unapplied version 0.105-18 to debian/sid

Author: Iain Lane
Author Date: 2017-05-24 10:21:35 UTC

Import patches-unapplied version 0.105-18 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2a107ea3ff801bf2367bf4e85a302e4a03d5ccd1

New changelog entries:
  * Team upload.
  * master/Add-gettext-support-for-.policy-files.patch: Backport from master:
    Add .loc and .its files so that gettext can be used to translate policy
    files. Some upstreams, particularly those that are switching to meson,
    expect these files to be present so that their PK policy files can be
    translated. (Closes: #863207)

applied/ubuntu/artful-proposed 2017-05-24 22:16:39 UTC 2017-05-24
Import patches-applied version 0.105-18 to applied/debian/sid

Author: Iain Lane
Author Date: 2017-05-24 10:21:35 UTC

Import patches-applied version 0.105-18 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 468eb5420f0f6bc036dd5e620324ead91c158166
Unapplied parent: 09a64250e329eed5d64a54126dfbd622962edb0e

New changelog entries:
  * Team upload.
  * master/Add-gettext-support-for-.policy-files.patch: Backport from master:
    Add .loc and .its files so that gettext can be used to translate policy
    files. Some upstreams, particularly those that are switching to meson,
    expect these files to be present so that their PK policy files can be
    translated. (Closes: #863207)

ubuntu/artful-proposed 2017-05-24 22:16:39 UTC 2017-05-24
Import patches-unapplied version 0.105-18 to debian/sid

Author: Iain Lane
Author Date: 2017-05-24 10:21:35 UTC

Import patches-unapplied version 0.105-18 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 2a107ea3ff801bf2367bf4e85a302e4a03d5ccd1

New changelog entries:
  * Team upload.
  * master/Add-gettext-support-for-.policy-files.patch: Backport from master:
    Add .loc and .its files so that gettext can be used to translate policy
    files. Some upstreams, particularly those that are switching to meson,
    expect these files to be present so that their PK policy files can be
    translated. (Closes: #863207)

applied/ubuntu/artful 2017-05-24 22:16:39 UTC 2017-05-24
Import patches-applied version 0.105-18 to applied/debian/sid

Author: Iain Lane
Author Date: 2017-05-24 10:21:35 UTC

Import patches-applied version 0.105-18 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 468eb5420f0f6bc036dd5e620324ead91c158166
Unapplied parent: 09a64250e329eed5d64a54126dfbd622962edb0e

New changelog entries:
  * Team upload.
  * master/Add-gettext-support-for-.policy-files.patch: Backport from master:
    Add .loc and .its files so that gettext can be used to translate policy
    files. Some upstreams, particularly those that are switching to meson,
    expect these files to be present so that their PK policy files can be
    translated. (Closes: #863207)

ubuntu/zesty-proposed 2016-10-21 22:22:59 UTC 2016-10-21
Import patches-unapplied version 0.105-17 to debian/sid

Author: Michael Biebl
Author Date: 2016-10-21 13:44:57 UTC

Import patches-unapplied version 0.105-17 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b48086ed0878857c23c9addb44d57b56a7179e12

New changelog entries:
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  * Rename the systemd service unit to polkit.service. It is now based on what
    was added upstream in 0.106.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

applied/ubuntu/zesty 2016-10-21 22:22:59 UTC 2016-10-21
Import patches-applied version 0.105-17 to applied/debian/sid

Author: Michael Biebl
Author Date: 2016-10-21 13:44:57 UTC

Import patches-applied version 0.105-17 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 8c2658ee68622eb32f752eef3e96f08d607a0e52
Unapplied parent: 1c7be57c296dc2b0b07875fa9e68144c99ea051f

New changelog entries:
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  * Rename the systemd service unit to polkit.service. It is now based on what
    was added upstream in 0.106.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

applied/ubuntu/zesty-devel 2016-10-21 22:22:59 UTC 2016-10-21
Import patches-applied version 0.105-17 to applied/debian/sid

Author: Michael Biebl
Author Date: 2016-10-21 13:44:57 UTC

Import patches-applied version 0.105-17 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 8c2658ee68622eb32f752eef3e96f08d607a0e52
Unapplied parent: 1c7be57c296dc2b0b07875fa9e68144c99ea051f

New changelog entries:
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  * Rename the systemd service unit to polkit.service. It is now based on what
    was added upstream in 0.106.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

applied/ubuntu/zesty-proposed 2016-10-21 22:22:59 UTC 2016-10-21
Import patches-applied version 0.105-17 to applied/debian/sid

Author: Michael Biebl
Author Date: 2016-10-21 13:44:57 UTC

Import patches-applied version 0.105-17 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 8c2658ee68622eb32f752eef3e96f08d607a0e52
Unapplied parent: 1c7be57c296dc2b0b07875fa9e68144c99ea051f

New changelog entries:
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  * Rename the systemd service unit to polkit.service. It is now based on what
    was added upstream in 0.106.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

ubuntu/zesty 2016-10-21 22:22:59 UTC 2016-10-21
Import patches-unapplied version 0.105-17 to debian/sid

Author: Michael Biebl
Author Date: 2016-10-21 13:44:57 UTC

Import patches-unapplied version 0.105-17 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b48086ed0878857c23c9addb44d57b56a7179e12

New changelog entries:
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  * Rename the systemd service unit to polkit.service. It is now based on what
    was added upstream in 0.106.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

ubuntu/zesty-devel 2016-10-21 22:22:59 UTC 2016-10-21
Import patches-unapplied version 0.105-17 to debian/sid

Author: Michael Biebl
Author Date: 2016-10-21 13:44:57 UTC

Import patches-unapplied version 0.105-17 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b48086ed0878857c23c9addb44d57b56a7179e12

New changelog entries:
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  * Rename the systemd service unit to polkit.service. It is now based on what
    was added upstream in 0.106.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

applied/ubuntu/yakkety 2016-10-07 02:04:31 UTC 2016-10-07
Import patches-applied version 0.105-16git1 to applied/ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-10-06 20:35:24 UTC

Import patches-applied version 0.105-16git1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 8c2658ee68622eb32f752eef3e96f08d607a0e52
Unapplied parent: 2f258286651fdf55a95ce4fd4cc21f07855453f2

New changelog entries:
  Upload current Debian packaging git.
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

applied/ubuntu/yakkety-devel 2016-10-07 02:04:31 UTC 2016-10-07
Import patches-applied version 0.105-16git1 to applied/ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-10-06 20:35:24 UTC

Import patches-applied version 0.105-16git1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 8c2658ee68622eb32f752eef3e96f08d607a0e52
Unapplied parent: 2f258286651fdf55a95ce4fd4cc21f07855453f2

New changelog entries:
  Upload current Debian packaging git.
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

ubuntu/yakkety-proposed 2016-10-07 02:04:31 UTC 2016-10-07
Import patches-unapplied version 0.105-16git1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-10-06 20:35:24 UTC

Import patches-unapplied version 0.105-16git1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: b48086ed0878857c23c9addb44d57b56a7179e12

New changelog entries:
  Upload current Debian packaging git.
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

ubuntu/yakkety 2016-10-07 02:04:31 UTC 2016-10-07
Import patches-unapplied version 0.105-16git1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-10-06 20:35:24 UTC

Import patches-unapplied version 0.105-16git1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: b48086ed0878857c23c9addb44d57b56a7179e12

New changelog entries:
  Upload current Debian packaging git.
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

ubuntu/yakkety-devel 2016-10-07 02:04:31 UTC 2016-10-07
Import patches-unapplied version 0.105-16git1 to ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-10-06 20:35:24 UTC

Import patches-unapplied version 0.105-16git1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: b48086ed0878857c23c9addb44d57b56a7179e12

New changelog entries:
  Upload current Debian packaging git.
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

applied/ubuntu/yakkety-proposed 2016-10-07 02:04:31 UTC 2016-10-07
Import patches-applied version 0.105-16git1 to applied/ubuntu/yakkety-proposed

Author: Martin Pitt
Author Date: 2016-10-06 20:35:24 UTC

Import patches-applied version 0.105-16git1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 8c2658ee68622eb32f752eef3e96f08d607a0e52
Unapplied parent: 2f258286651fdf55a95ce4fd4cc21f07855453f2

New changelog entries:
  Upload current Debian packaging git.
  [ Michael Biebl ]
  * Use https:// for the upstream homepage.
  * Update Vcs-Browser to use cgit.
  [ Simon McVittie ]
  * Build-depend on intltool instead of relying on gtk-doc-tools'
    dependency (Closes: #837846)
  [ Martin Pitt ]
  * Use PAM's common-session-noninteractive modules for pkexec instead of
    common-session. The latter also runs pam_systemd (the only difference
    normally) which is a no-op under the classic session-centric
    D-BUS/graphical login model (as it won't start a new one if it is already
    running within a logind session), but very expensive when using
    dbus-user-session and being called from a service that runs outside the
    PAM session. This causes long delays in e. g. gnome-settings-daemon's
    backlight helpers. (LP: #1626651)

applied/debian/jessie 2016-09-17 17:30:13 UTC 2016-09-17
Import patches-applied version 0.105-15~deb8u2 to applied/debian/jessie

Author: Michael Biebl
Author Date: 2016-09-06 15:53:11 UTC

Import patches-applied version 0.105-15~deb8u2 to applied/debian/jessie

Imported using git-ubuntu import.

Changelog parent: 05a8ae33e60f3b4b5ba9b407cca9b65656f2f2b4
Unapplied parent: 1eb9f04dc6023791ceadb42d302f08f70c9a3518

New changelog entries:
  * Disable 0.113/sessionmonitor-systemd-prepare-for-D-Bus-user-bus-mo.patch
    and 0.113/sessionmonitor-systemd-Use-sd_uid_get_state-to-check.patch.
    Those two patches add support for `systemd --user` sessions and the D-Bus
    user model. For that they rely on sd_uid_get_state() which seems to be
    broken in Jessie when logind is running under sysvinit. Since those
    features are not yet needed in Jessie, do not apply those patches.
    (Closes: #825956)
  * Upload to stable.

debian/jessie 2016-09-17 17:30:13 UTC 2016-09-17
Import patches-unapplied version 0.105-15~deb8u2 to debian/jessie

Author: Michael Biebl
Author Date: 2016-09-06 15:53:11 UTC

Import patches-unapplied version 0.105-15~deb8u2 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: 2d12bd831a6ab0aa7c065660d73c60a048195b07

New changelog entries:
  * Disable 0.113/sessionmonitor-systemd-prepare-for-D-Bus-user-bus-mo.patch
    and 0.113/sessionmonitor-systemd-Use-sd_uid_get_state-to-check.patch.
    Those two patches add support for `systemd --user` sessions and the D-Bus
    user model. For that they rely on sd_uid_get_state() which seems to be
    broken in Jessie when logind is running under sysvinit. Since those
    features are not yet needed in Jessie, do not apply those patches.
    (Closes: #825956)
  * Upload to stable.

ubuntu/xenial 2016-01-17 22:20:30 UTC 2016-01-17
Import patches-unapplied version 0.105-14.1 to debian/sid

Author: Adam Borowski
Author Date: 2016-01-14 05:28:38 UTC

Import patches-unapplied version 0.105-14.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8addb40294ddc5e3e26c30287a4e239649ee8d1d

New changelog entries:
  * Non-maintainer upload.
  * Fix FTBFS on non-linux/non-systemd. (Closes: #798769)

ubuntu/xenial-proposed 2016-01-17 22:20:30 UTC 2016-01-17
Import patches-unapplied version 0.105-14.1 to debian/sid

Author: Adam Borowski
Author Date: 2016-01-14 05:28:38 UTC

Import patches-unapplied version 0.105-14.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8addb40294ddc5e3e26c30287a4e239649ee8d1d

New changelog entries:
  * Non-maintainer upload.
  * Fix FTBFS on non-linux/non-systemd. (Closes: #798769)

applied/ubuntu/xenial-proposed 2016-01-17 22:20:30 UTC 2016-01-17
Import patches-applied version 0.105-14.1 to applied/debian/sid

Author: Adam Borowski
Author Date: 2016-01-14 05:28:38 UTC

Import patches-applied version 0.105-14.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: b88f4eacde94962272c0d40181a223d3ca3adaba
Unapplied parent: 988c581cbe51d231af7befc5de025317fa7db576

New changelog entries:
  * Non-maintainer upload.
  * Fix FTBFS on non-linux/non-systemd. (Closes: #798769)

applied/ubuntu/xenial 2016-01-17 22:20:30 UTC 2016-01-17
Import patches-applied version 0.105-14.1 to applied/debian/sid

Author: Adam Borowski
Author Date: 2016-01-14 05:28:38 UTC

Import patches-applied version 0.105-14.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: b88f4eacde94962272c0d40181a223d3ca3adaba
Unapplied parent: 988c581cbe51d231af7befc5de025317fa7db576

New changelog entries:
  * Non-maintainer upload.
  * Fix FTBFS on non-linux/non-systemd. (Closes: #798769)

ubuntu/vivid-proposed 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-unapplied version 0.105-8ubuntu5 to ubuntu/vivid-proposed

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:30:03 UTC

Import patches-unapplied version 0.105-8ubuntu5 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 94cfd399eb97bdef04582cb128ce2a25a05e7f9e

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

ubuntu/trusty-proposed 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-unapplied version 0.105-4ubuntu3.14.04.1 to ubuntu/trusty-prop...

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:36:30 UTC

Import patches-unapplied version 0.105-4ubuntu3.14.04.1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 108e61dd2e848c39bfcff0e48e2dc7c21d5e8753

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

ubuntu/vivid-devel 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-unapplied version 0.105-8ubuntu5 to ubuntu/vivid-proposed

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:30:03 UTC

Import patches-unapplied version 0.105-8ubuntu5 to ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 94cfd399eb97bdef04582cb128ce2a25a05e7f9e

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

applied/ubuntu/wily-proposed 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-applied version 0.105-11ubuntu3 to applied/ubuntu/wily-proposed

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:24:53 UTC

Import patches-applied version 0.105-11ubuntu3 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 44cca59a1686da76e5754830140b2ef21255a5ee
Unapplied parent: 9c1b1fdab79906d73325b20218da1c41cf6ad046

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

applied/ubuntu/wily-updates 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-applied version 0.105-11ubuntu3 to applied/ubuntu/wily-proposed

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:24:53 UTC

Import patches-applied version 0.105-11ubuntu3 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 44cca59a1686da76e5754830140b2ef21255a5ee
Unapplied parent: 9c1b1fdab79906d73325b20218da1c41cf6ad046

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

applied/ubuntu/wily-devel 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-applied version 0.105-11ubuntu3 to applied/ubuntu/wily-proposed

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:24:53 UTC

Import patches-applied version 0.105-11ubuntu3 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 44cca59a1686da76e5754830140b2ef21255a5ee
Unapplied parent: 9c1b1fdab79906d73325b20218da1c41cf6ad046

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

applied/ubuntu/vivid-updates 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-applied version 0.105-8ubuntu5 to applied/ubuntu/vivid-proposed

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:30:03 UTC

Import patches-applied version 0.105-8ubuntu5 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 53c1a6f95fe7dd7894982fa86e6543c8a0949cfe
Unapplied parent: 6ffc9a077825894ce58908d7ac1ff62bceef5c48

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

applied/ubuntu/vivid-proposed 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-applied version 0.105-8ubuntu5 to applied/ubuntu/vivid-proposed

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:30:03 UTC

Import patches-applied version 0.105-8ubuntu5 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 53c1a6f95fe7dd7894982fa86e6543c8a0949cfe
Unapplied parent: 6ffc9a077825894ce58908d7ac1ff62bceef5c48

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

applied/ubuntu/vivid-devel 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-applied version 0.105-8ubuntu5 to applied/ubuntu/vivid-proposed

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:30:03 UTC

Import patches-applied version 0.105-8ubuntu5 to applied/ubuntu/vivid-proposed

Imported using git-ubuntu import.

Changelog parent: 53c1a6f95fe7dd7894982fa86e6543c8a0949cfe
Unapplied parent: 6ffc9a077825894ce58908d7ac1ff62bceef5c48

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

applied/ubuntu/trusty-proposed 2015-11-24 21:34:52 UTC 2015-11-24
Import patches-applied version 0.105-4ubuntu3.14.04.1 to applied/ubuntu/trust...

Author: Dariusz Gadomski
Author Date: 2015-11-20 14:36:30 UTC

Import patches-applied version 0.105-4ubuntu3.14.04.1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: fe02773e2a19bd374876e52b090a71dcf8ed42c2
Unapplied parent: 2875f135a28c4a64e873099f3cba7cb538ba4acf

New changelog entries:
  * Fix handling of multi-line helper output. (LP: #1510824)

1100 of 188 results

Other repositories

Name Last Modified
lp:ubuntu/+source/policykit-1 2019-10-18
11 of 1 result
You can't create new repositories for policykit-1 in Ubuntu.