Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/php7.0
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2019-03-26 17:39:31 UTC 2019-03-26
DSC file for 7.0.33-0ubuntu0.16.04.3

Author: Ubuntu Git Importer
Author Date: 2019-03-26 17:39:31 UTC

DSC file for 7.0.33-0ubuntu0.16.04.3

ubuntu/xenial-updates 2019-03-26 17:13:19 UTC 2019-03-26
Import patches-unapplied version 7.0.33-0ubuntu0.16.04.3 to ubuntu/xenial-sec...

Author: Leonidas S. Barbosa
Author Date: 2019-03-21 12:49:35 UTC

Import patches-unapplied version 7.0.33-0ubuntu0.16.04.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 729412abf0e1afec049303a968c116b4dd811827

New changelog entries:
  * SECURITY UPDATE: Unauthorized users access
    - debian/patches/CVE-2019-9637.patch: fix in
      main/streams/plain_wrapper.c.
    - CVE-2019-9637
  * SECURITY UPDATE: Invalid read in exif_process_IFD_MAKERNOTE
    - debian/patches/CVE-2019-9638-and-CVE-2019-9639-*.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77563.jpg,
      ext/exif/tests/bug77563.phpt.
    - CVE-2019-9638
    - CVE-2019-9639
  * SECURITY UPDATE: Invalid read
    - debian/patches/CVE-2019-9640.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77540.jpg,
      ext/exif/tests/bug77540.phpt.
    - CVE-2019-9640
  * SECURITY UPDATE: Unitialized read
    - debian/patches/CVE-2019-9641.patch: fix in ext/exif/exif.c.
    - CVE-2019-9641
  * SECURITY UPDATE: Buffer overflow
    - debian/patches/CVE-2019-9675.patch: fix in
      ext/phar/tar.c, added tests in ext/phar/tests/bug71488.phpt,
      ext/phar/tests/bug77586,phpt, ext/phar/tests/bug77586/files/*.

applied/ubuntu/xenial-security 2019-03-26 17:13:19 UTC 2019-03-26
Import patches-applied version 7.0.33-0ubuntu0.16.04.3 to applied/ubuntu/xeni...

Author: Leonidas S. Barbosa
Author Date: 2019-03-21 12:49:35 UTC

Import patches-applied version 7.0.33-0ubuntu0.16.04.3 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 20175df1314ebe69cdc1db2e848781e4bf8d2041
Unapplied parent: 634dcc19cb0a9286dd3210502219c1efa3d17801

New changelog entries:
  * SECURITY UPDATE: Unauthorized users access
    - debian/patches/CVE-2019-9637.patch: fix in
      main/streams/plain_wrapper.c.
    - CVE-2019-9637
  * SECURITY UPDATE: Invalid read in exif_process_IFD_MAKERNOTE
    - debian/patches/CVE-2019-9638-and-CVE-2019-9639-*.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77563.jpg,
      ext/exif/tests/bug77563.phpt.
    - CVE-2019-9638
    - CVE-2019-9639
  * SECURITY UPDATE: Invalid read
    - debian/patches/CVE-2019-9640.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77540.jpg,
      ext/exif/tests/bug77540.phpt.
    - CVE-2019-9640
  * SECURITY UPDATE: Unitialized read
    - debian/patches/CVE-2019-9641.patch: fix in ext/exif/exif.c.
    - CVE-2019-9641
  * SECURITY UPDATE: Buffer overflow
    - debian/patches/CVE-2019-9675.patch: fix in
      ext/phar/tar.c, added tests in ext/phar/tests/bug71488.phpt,
      ext/phar/tests/bug77586,phpt, ext/phar/tests/bug77586/files/*.

ubuntu/xenial-security 2019-03-26 17:13:19 UTC 2019-03-26
Import patches-unapplied version 7.0.33-0ubuntu0.16.04.3 to ubuntu/xenial-sec...

Author: Leonidas S. Barbosa
Author Date: 2019-03-21 12:49:35 UTC

Import patches-unapplied version 7.0.33-0ubuntu0.16.04.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 729412abf0e1afec049303a968c116b4dd811827

New changelog entries:
  * SECURITY UPDATE: Unauthorized users access
    - debian/patches/CVE-2019-9637.patch: fix in
      main/streams/plain_wrapper.c.
    - CVE-2019-9637
  * SECURITY UPDATE: Invalid read in exif_process_IFD_MAKERNOTE
    - debian/patches/CVE-2019-9638-and-CVE-2019-9639-*.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77563.jpg,
      ext/exif/tests/bug77563.phpt.
    - CVE-2019-9638
    - CVE-2019-9639
  * SECURITY UPDATE: Invalid read
    - debian/patches/CVE-2019-9640.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77540.jpg,
      ext/exif/tests/bug77540.phpt.
    - CVE-2019-9640
  * SECURITY UPDATE: Unitialized read
    - debian/patches/CVE-2019-9641.patch: fix in ext/exif/exif.c.
    - CVE-2019-9641
  * SECURITY UPDATE: Buffer overflow
    - debian/patches/CVE-2019-9675.patch: fix in
      ext/phar/tar.c, added tests in ext/phar/tests/bug71488.phpt,
      ext/phar/tests/bug77586,phpt, ext/phar/tests/bug77586/files/*.

ubuntu/xenial-devel 2019-03-26 17:13:19 UTC 2019-03-26
Import patches-unapplied version 7.0.33-0ubuntu0.16.04.3 to ubuntu/xenial-sec...

Author: Leonidas S. Barbosa
Author Date: 2019-03-21 12:49:35 UTC

Import patches-unapplied version 7.0.33-0ubuntu0.16.04.3 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 729412abf0e1afec049303a968c116b4dd811827

New changelog entries:
  * SECURITY UPDATE: Unauthorized users access
    - debian/patches/CVE-2019-9637.patch: fix in
      main/streams/plain_wrapper.c.
    - CVE-2019-9637
  * SECURITY UPDATE: Invalid read in exif_process_IFD_MAKERNOTE
    - debian/patches/CVE-2019-9638-and-CVE-2019-9639-*.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77563.jpg,
      ext/exif/tests/bug77563.phpt.
    - CVE-2019-9638
    - CVE-2019-9639
  * SECURITY UPDATE: Invalid read
    - debian/patches/CVE-2019-9640.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77540.jpg,
      ext/exif/tests/bug77540.phpt.
    - CVE-2019-9640
  * SECURITY UPDATE: Unitialized read
    - debian/patches/CVE-2019-9641.patch: fix in ext/exif/exif.c.
    - CVE-2019-9641
  * SECURITY UPDATE: Buffer overflow
    - debian/patches/CVE-2019-9675.patch: fix in
      ext/phar/tar.c, added tests in ext/phar/tests/bug71488.phpt,
      ext/phar/tests/bug77586,phpt, ext/phar/tests/bug77586/files/*.

applied/ubuntu/xenial-devel 2019-03-26 17:13:19 UTC 2019-03-26
Import patches-applied version 7.0.33-0ubuntu0.16.04.3 to applied/ubuntu/xeni...

Author: Leonidas S. Barbosa
Author Date: 2019-03-21 12:49:35 UTC

Import patches-applied version 7.0.33-0ubuntu0.16.04.3 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 20175df1314ebe69cdc1db2e848781e4bf8d2041
Unapplied parent: 634dcc19cb0a9286dd3210502219c1efa3d17801

New changelog entries:
  * SECURITY UPDATE: Unauthorized users access
    - debian/patches/CVE-2019-9637.patch: fix in
      main/streams/plain_wrapper.c.
    - CVE-2019-9637
  * SECURITY UPDATE: Invalid read in exif_process_IFD_MAKERNOTE
    - debian/patches/CVE-2019-9638-and-CVE-2019-9639-*.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77563.jpg,
      ext/exif/tests/bug77563.phpt.
    - CVE-2019-9638
    - CVE-2019-9639
  * SECURITY UPDATE: Invalid read
    - debian/patches/CVE-2019-9640.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77540.jpg,
      ext/exif/tests/bug77540.phpt.
    - CVE-2019-9640
  * SECURITY UPDATE: Unitialized read
    - debian/patches/CVE-2019-9641.patch: fix in ext/exif/exif.c.
    - CVE-2019-9641
  * SECURITY UPDATE: Buffer overflow
    - debian/patches/CVE-2019-9675.patch: fix in
      ext/phar/tar.c, added tests in ext/phar/tests/bug71488.phpt,
      ext/phar/tests/bug77586,phpt, ext/phar/tests/bug77586/files/*.

applied/ubuntu/xenial-updates 2019-03-26 17:13:19 UTC 2019-03-26
Import patches-applied version 7.0.33-0ubuntu0.16.04.3 to applied/ubuntu/xeni...

Author: Leonidas S. Barbosa
Author Date: 2019-03-21 12:49:35 UTC

Import patches-applied version 7.0.33-0ubuntu0.16.04.3 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 20175df1314ebe69cdc1db2e848781e4bf8d2041
Unapplied parent: 634dcc19cb0a9286dd3210502219c1efa3d17801

New changelog entries:
  * SECURITY UPDATE: Unauthorized users access
    - debian/patches/CVE-2019-9637.patch: fix in
      main/streams/plain_wrapper.c.
    - CVE-2019-9637
  * SECURITY UPDATE: Invalid read in exif_process_IFD_MAKERNOTE
    - debian/patches/CVE-2019-9638-and-CVE-2019-9639-*.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77563.jpg,
      ext/exif/tests/bug77563.phpt.
    - CVE-2019-9638
    - CVE-2019-9639
  * SECURITY UPDATE: Invalid read
    - debian/patches/CVE-2019-9640.patch: fix in
      ext/exif/exif.c, added tests in ext/exif/tests/bug77540.jpg,
      ext/exif/tests/bug77540.phpt.
    - CVE-2019-9640
  * SECURITY UPDATE: Unitialized read
    - debian/patches/CVE-2019-9641.patch: fix in ext/exif/exif.c.
    - CVE-2019-9641
  * SECURITY UPDATE: Buffer overflow
    - debian/patches/CVE-2019-9675.patch: fix in
      ext/phar/tar.c, added tests in ext/phar/tests/bug71488.phpt,
      ext/phar/tests/bug77586,phpt, ext/phar/tests/bug77586/files/*.

importer/debian/dsc 2019-02-16 17:36:22 UTC 2019-02-16
DSC file for 7.0.33-0+deb9u1

Author: Ubuntu Git Importer
Author Date: 2019-02-16 17:36:22 UTC

DSC file for 7.0.33-0+deb9u1

debian/stretch 2019-02-16 17:15:45 UTC 2019-02-16
Import patches-unapplied version 7.0.33-0+deb9u1 to debian/stretch

Author: Ondřej Surý
Author Date: 2018-12-07 11:36:49 UTC

Import patches-unapplied version 7.0.33-0+deb9u1 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: eb1d1e629b3ac4db22b6fcb4f0a36d1e68f68de2

New changelog entries:
  * New upstream version 7.0.33
  * Fixed security bugs:
   + [CVE-2018-19518]: imap_open() function command injection
   + [CVE-2018-14851]: heap-buffer-overflow (READ of size 48) while
                       reading exif data
   + [CVE-2018-14883]: Int Overflow lead to Heap OverFlow in
                       exif_thumbnail_extract of exif.c
   + [CVE-2018-17082]: XSS due to the header Transfer-Encoding: chunked

applied/debian/stretch 2019-02-16 17:15:45 UTC 2019-02-16
Import patches-applied version 7.0.33-0+deb9u1 to applied/debian/stretch

Author: Ondřej Surý
Author Date: 2018-12-07 11:36:49 UTC

Import patches-applied version 7.0.33-0+deb9u1 to applied/debian/stretch

Imported using git-ubuntu import.

Changelog parent: 6c7a0b88f7e67efe67f4cc32cc6601bdc077d3c1
Unapplied parent: 9ba758e9d4292a5796c47d5cc4f6bf0e62be3f6d

New changelog entries:
  * New upstream version 7.0.33
  * Fixed security bugs:
   + [CVE-2018-19518]: imap_open() function command injection
   + [CVE-2018-14851]: heap-buffer-overflow (READ of size 48) while
                       reading exif data
   + [CVE-2018-14883]: Int Overflow lead to Heap OverFlow in
                       exif_thumbnail_extract of exif.c
   + [CVE-2018-17082]: XSS due to the header Transfer-Encoding: chunked

applied/debian/sid 2018-10-03 10:49:07 UTC 2018-10-03
Import patches-applied version 7.0.32-1 to applied/debian/sid

Author: Ondřej Surý
Author Date: 2018-10-01 11:42:15 UTC

Import patches-applied version 7.0.32-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 71d476f69c36b53a944047a6e5fb4bfda25a7e86
Unapplied parent: da6d576b7eca6a65a64a6dccb07d99a391b2dcf8

New changelog entries:
  * New upstream version 7.0.32
  * Rebase patches for PHP 7.0.32

debian/sid 2018-10-03 10:49:07 UTC 2018-10-03
Import patches-unapplied version 7.0.32-1 to debian/sid

Author: Ondřej Surý
Author Date: 2018-10-01 11:42:15 UTC

Import patches-unapplied version 7.0.32-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 08522462689c28223c38d3cc61ba8e698dd17998

New changelog entries:
  * New upstream version 7.0.32
  * Rebase patches for PHP 7.0.32

debian/buster 2018-08-04 04:34:41 UTC 2018-08-04
Import patches-unapplied version 7.0.31-1 to debian/sid

Author: Lior Kaplan
Author Date: 2018-08-03 23:49:02 UTC

Import patches-unapplied version 7.0.31-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d256eee5b694e15a36a3a4f887afc4ebafb5e80a

New changelog entries:
  [ Ondřej Surý ]
  * New upstream version 7.0.31
  * Fix the Vcs-Browser link

applied/debian/buster 2018-08-04 04:34:41 UTC 2018-08-04
Import patches-applied version 7.0.31-1 to applied/debian/sid

Author: Lior Kaplan
Author Date: 2018-08-03 23:49:02 UTC

Import patches-applied version 7.0.31-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: a3bfc7fe31f1e8102d4c614229e13e9913798c9c
Unapplied parent: bc592155e40078d1e4a79291163ce329c93736ed

New changelog entries:
  [ Ondřej Surý ]
  * New upstream version 7.0.31
  * Fix the Vcs-Browser link

importer/debian/pristine-tar 2018-04-07 11:09:59 UTC 2018-04-07
pristine-tar data for php7.0_7.0.29.orig.tar.xz

Author: Ubuntu Git Importer
Author Date: 2018-04-07 11:09:59 UTC

pristine-tar data for php7.0_7.0.29.orig.tar.xz

importer/ubuntu/pristine-tar 2018-03-19 12:38:31 UTC 2018-03-19
pristine-tar data for php7.0_7.0.28.orig.tar.xz

Author: Ubuntu Git Importer
Author Date: 2018-03-19 12:38:31 UTC

pristine-tar data for php7.0_7.0.28.orig.tar.xz

applied/ubuntu/xenial-proposed 2017-11-30 19:54:39 UTC 2017-11-30
Import patches-applied version 7.0.25-0ubuntu0.16.04.1 to applied/ubuntu/xeni...

Author: Nish Aravamudan
Author Date: 2017-11-01 17:18:38 UTC

Import patches-applied version 7.0.25-0ubuntu0.16.04.1 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: ffd8fd32a2f4491a5ac148f3f8a3675371eede9a
Unapplied parent: 63959a06d3134602f2fef1bec0af2b1be3f9dcb6

New changelog entries:
  * New upstream release (7.0.25)
    - LP: #1724896
    - LP: #1721607

ubuntu/xenial-proposed 2017-11-30 19:54:39 UTC 2017-11-30
Import patches-unapplied version 7.0.25-0ubuntu0.16.04.1 to ubuntu/xenial-pro...

Author: Nish Aravamudan
Author Date: 2017-11-01 17:18:38 UTC

Import patches-unapplied version 7.0.25-0ubuntu0.16.04.1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: ab218b909e9246802a257459765b3715cf1286cf
Upload parent: c0c24e386ecfa4fa3124a9b10c2912bfe1bf6e89

New changelog entries:
  * New upstream release (7.0.25)
    - LP: #1724896
    - LP: #1721607

applied/ubuntu/zesty-devel 2017-11-09 21:05:02 UTC 2017-11-09
Import patches-applied version 7.0.25-0ubuntu0.17.04.1 to applied/ubuntu/zest...

Author: Nish Aravamudan
Author Date: 2017-11-01 17:05:44 UTC

Import patches-applied version 7.0.25-0ubuntu0.17.04.1 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 22939554090dc83a4800cd1ca12083d64105ec94
Unapplied parent: ccf4e69f498542a57a338a160551b0d198f985ae

New changelog entries:
  * New upstream release (7.0.25)
    - LP: #1724896
    - LP: #1721607

applied/ubuntu/zesty-proposed 2017-11-09 21:05:02 UTC 2017-11-09
Import patches-applied version 7.0.25-0ubuntu0.17.04.1 to applied/ubuntu/zest...

Author: Nish Aravamudan
Author Date: 2017-11-01 17:05:44 UTC

Import patches-applied version 7.0.25-0ubuntu0.17.04.1 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 22939554090dc83a4800cd1ca12083d64105ec94
Unapplied parent: ccf4e69f498542a57a338a160551b0d198f985ae

New changelog entries:
  * New upstream release (7.0.25)
    - LP: #1724896
    - LP: #1721607

ubuntu/zesty-devel 2017-11-09 21:05:02 UTC 2017-11-09
Import patches-unapplied version 7.0.25-0ubuntu0.17.04.1 to ubuntu/zesty-prop...

Author: Nish Aravamudan
Author Date: 2017-11-01 17:05:44 UTC

Import patches-unapplied version 7.0.25-0ubuntu0.17.04.1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: e6bf3e4967bfeec7c2effeaa01a57ee40784d3b2
Upload parent: e705f83aceff372cccec5b00f337bbd84dfcd11c

New changelog entries:
  * New upstream release (7.0.25)
    - LP: #1724896
    - LP: #1721607

ubuntu/zesty-proposed 2017-11-09 21:05:02 UTC 2017-11-09
Import patches-unapplied version 7.0.25-0ubuntu0.17.04.1 to ubuntu/zesty-prop...

Author: Nish Aravamudan
Author Date: 2017-11-01 17:05:44 UTC

Import patches-unapplied version 7.0.25-0ubuntu0.17.04.1 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: e6bf3e4967bfeec7c2effeaa01a57ee40784d3b2
Upload parent: e705f83aceff372cccec5b00f337bbd84dfcd11c

New changelog entries:
  * New upstream release (7.0.25)
    - LP: #1724896
    - LP: #1721607

applied/ubuntu/zesty-updates 2017-08-10 15:14:05 UTC 2017-08-10
Import patches-applied version 7.0.22-0ubuntu0.17.04.1 to applied/ubuntu/zest...

Author: Nish Aravamudan
Author Date: 2017-08-08 22:03:30 UTC

Import patches-applied version 7.0.22-0ubuntu0.17.04.1 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 69f8d4630dae438013bf928916e561535d5c4790
Unapplied parent: 7f7f96152f88beaf818010444ad79a88aaa97a96

New changelog entries:
  * New upstream release (7.0.22)
    - LP: #1709489
  * Drop:
    - d/p/0048-Merge-OpenSSL-1.1.0-support-from-PHP-7.1-branch.patch
      [ Fixed upstream in 7.0.19 ]

ubuntu/zesty-security 2017-08-10 15:14:05 UTC 2017-08-10
Import patches-unapplied version 7.0.22-0ubuntu0.17.04.1 to ubuntu/zesty-secu...

Author: Nish Aravamudan
Author Date: 2017-08-08 22:03:30 UTC

Import patches-unapplied version 7.0.22-0ubuntu0.17.04.1 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: ede6cbc5ed2db43336818bf9f8d05219a25e0e8b

New changelog entries:
  * New upstream release (7.0.22)
    - LP: #1709489
  * Drop:
    - d/p/0048-Merge-OpenSSL-1.1.0-support-from-PHP-7.1-branch.patch
      [ Fixed upstream in 7.0.19 ]

ubuntu/zesty-updates 2017-08-10 15:14:05 UTC 2017-08-10
Import patches-unapplied version 7.0.22-0ubuntu0.17.04.1 to ubuntu/zesty-secu...

Author: Nish Aravamudan
Author Date: 2017-08-08 22:03:30 UTC

Import patches-unapplied version 7.0.22-0ubuntu0.17.04.1 to ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: ede6cbc5ed2db43336818bf9f8d05219a25e0e8b

New changelog entries:
  * New upstream release (7.0.22)
    - LP: #1709489
  * Drop:
    - d/p/0048-Merge-OpenSSL-1.1.0-support-from-PHP-7.1-branch.patch
      [ Fixed upstream in 7.0.19 ]

applied/ubuntu/zesty-security 2017-08-10 15:14:05 UTC 2017-08-10
Import patches-applied version 7.0.22-0ubuntu0.17.04.1 to applied/ubuntu/zest...

Author: Nish Aravamudan
Author Date: 2017-08-08 22:03:30 UTC

Import patches-applied version 7.0.22-0ubuntu0.17.04.1 to applied/ubuntu/zesty-security

Imported using git-ubuntu import.

Changelog parent: 69f8d4630dae438013bf928916e561535d5c4790
Unapplied parent: 7f7f96152f88beaf818010444ad79a88aaa97a96

New changelog entries:
  * New upstream release (7.0.22)
    - LP: #1709489
  * Drop:
    - d/p/0048-Merge-OpenSSL-1.1.0-support-from-PHP-7.1-branch.patch
      [ Fixed upstream in 7.0.19 ]

applied/ubuntu/yakkety-updates 2017-05-04 21:03:19 UTC 2017-05-04
Import patches-applied version 7.0.18-0ubuntu0.16.10.1 to applied/ubuntu/yakk...

Author: Nish Aravamudan
Author Date: 2017-04-26 23:55:19 UTC

Import patches-applied version 7.0.18-0ubuntu0.16.10.1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: a58467f82de19e0c2869cc994a133b23be57076b
Unapplied parent: 891544d7546e3b8072522c1107f1906c013574cc

New changelog entries:
  * New upstream release 7.0.18
    - LP: #1686237
    - LP: #1674892
    - Refresh patches for new upstream release
  * Drop:
    - debian/patches/0048-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - SECURITY REGRESSION: large mysql requests broken (LP #1668017)
      + debian/patches/fix_74021.patch: fix fetch_array with more than
        MEDIUMBLOB in ext/mysqlnd/mysqlnd_wireprotocol.c, added tests to
        ext/mysqli/tests/bug73800.phpt, ext/mysqli/tests/bug74021.phpt.
      [ Fixed upstream in 7.0.17 ]

ubuntu/yakkety-proposed 2017-05-04 21:03:19 UTC 2017-05-04
Import patches-unapplied version 7.0.18-0ubuntu0.16.10.1 to ubuntu/yakkety-pr...

Author: Nish Aravamudan
Author Date: 2017-04-26 23:55:19 UTC

Import patches-unapplied version 7.0.18-0ubuntu0.16.10.1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 3ab6b5023aeedb9d073661ce40adead197782075

New changelog entries:
  * New upstream release 7.0.18
    - LP: #1686237
    - LP: #1674892
    - Refresh patches for new upstream release
  * Drop:
    - debian/patches/0048-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - SECURITY REGRESSION: large mysql requests broken (LP #1668017)
      + debian/patches/fix_74021.patch: fix fetch_array with more than
        MEDIUMBLOB in ext/mysqlnd/mysqlnd_wireprotocol.c, added tests to
        ext/mysqli/tests/bug73800.phpt, ext/mysqli/tests/bug74021.phpt.
      [ Fixed upstream in 7.0.17 ]

ubuntu/yakkety-updates 2017-05-04 21:03:19 UTC 2017-05-04
Import patches-unapplied version 7.0.18-0ubuntu0.16.10.1 to ubuntu/yakkety-pr...

Author: Nish Aravamudan
Author Date: 2017-04-26 23:55:19 UTC

Import patches-unapplied version 7.0.18-0ubuntu0.16.10.1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 3ab6b5023aeedb9d073661ce40adead197782075

New changelog entries:
  * New upstream release 7.0.18
    - LP: #1686237
    - LP: #1674892
    - Refresh patches for new upstream release
  * Drop:
    - debian/patches/0048-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - SECURITY REGRESSION: large mysql requests broken (LP #1668017)
      + debian/patches/fix_74021.patch: fix fetch_array with more than
        MEDIUMBLOB in ext/mysqlnd/mysqlnd_wireprotocol.c, added tests to
        ext/mysqli/tests/bug73800.phpt, ext/mysqli/tests/bug74021.phpt.
      [ Fixed upstream in 7.0.17 ]

applied/ubuntu/yakkety-devel 2017-05-04 21:03:19 UTC 2017-05-04
Import patches-applied version 7.0.18-0ubuntu0.16.10.1 to applied/ubuntu/yakk...

Author: Nish Aravamudan
Author Date: 2017-04-26 23:55:19 UTC

Import patches-applied version 7.0.18-0ubuntu0.16.10.1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: a58467f82de19e0c2869cc994a133b23be57076b
Unapplied parent: 891544d7546e3b8072522c1107f1906c013574cc

New changelog entries:
  * New upstream release 7.0.18
    - LP: #1686237
    - LP: #1674892
    - Refresh patches for new upstream release
  * Drop:
    - debian/patches/0048-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - SECURITY REGRESSION: large mysql requests broken (LP #1668017)
      + debian/patches/fix_74021.patch: fix fetch_array with more than
        MEDIUMBLOB in ext/mysqlnd/mysqlnd_wireprotocol.c, added tests to
        ext/mysqli/tests/bug73800.phpt, ext/mysqli/tests/bug74021.phpt.
      [ Fixed upstream in 7.0.17 ]

applied/ubuntu/yakkety-proposed 2017-05-04 21:03:19 UTC 2017-05-04
Import patches-applied version 7.0.18-0ubuntu0.16.10.1 to applied/ubuntu/yakk...

Author: Nish Aravamudan
Author Date: 2017-04-26 23:55:19 UTC

Import patches-applied version 7.0.18-0ubuntu0.16.10.1 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: a58467f82de19e0c2869cc994a133b23be57076b
Unapplied parent: 891544d7546e3b8072522c1107f1906c013574cc

New changelog entries:
  * New upstream release 7.0.18
    - LP: #1686237
    - LP: #1674892
    - Refresh patches for new upstream release
  * Drop:
    - debian/patches/0048-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - SECURITY REGRESSION: large mysql requests broken (LP #1668017)
      + debian/patches/fix_74021.patch: fix fetch_array with more than
        MEDIUMBLOB in ext/mysqlnd/mysqlnd_wireprotocol.c, added tests to
        ext/mysqli/tests/bug73800.phpt, ext/mysqli/tests/bug74021.phpt.
      [ Fixed upstream in 7.0.17 ]

ubuntu/yakkety-devel 2017-05-04 21:03:19 UTC 2017-05-04
Import patches-unapplied version 7.0.18-0ubuntu0.16.10.1 to ubuntu/yakkety-pr...

Author: Nish Aravamudan
Author Date: 2017-04-26 23:55:19 UTC

Import patches-unapplied version 7.0.18-0ubuntu0.16.10.1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 3ab6b5023aeedb9d073661ce40adead197782075

New changelog entries:
  * New upstream release 7.0.18
    - LP: #1686237
    - LP: #1674892
    - Refresh patches for new upstream release
  * Drop:
    - debian/patches/0048-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - SECURITY REGRESSION: large mysql requests broken (LP #1668017)
      + debian/patches/fix_74021.patch: fix fetch_array with more than
        MEDIUMBLOB in ext/mysqlnd/mysqlnd_wireprotocol.c, added tests to
        ext/mysqli/tests/bug73800.phpt, ext/mysqli/tests/bug74021.phpt.
      [ Fixed upstream in 7.0.17 ]

applied/ubuntu/artful-proposed 2017-04-26 17:08:21 UTC 2017-04-26
Import patches-applied version 7.0.18-2ubuntu1 to applied/ubuntu/artful-proposed

Author: Nish Aravamudan
Author Date: 2017-04-26 16:34:48 UTC

Import patches-applied version 7.0.18-2ubuntu1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 9bb4e96f4dbb39ea274eaefabb29970e4be69bfc
Unapplied parent: 36da71d41d40f93a6297717e86855a8a21b50f7f

New changelog entries:
  * Merge with Debian unstable (LP: #1686235). Remaining changes:
    - Drop dh-php from Recommends to Suggests so it can be demoted to
      universe (LP #1590623).
      + dh-php has gained a dependency on xml2 which is in universe.
  * Drop:
    - debian/patches/0050-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - debian/patches/fix_74021.patch: Fix fetch_array with more than
      MEDIUMBLOB. Thanks to andrewnester <andrew.nester.dev@gmail.com>.
      Closes LP #1668017.
      [ Fixed upstream in 7.0.17 ]
    - Cherry-pick: 'Fix generating recommends for php extensions (Closes:
      #855467)' from 7.0.16-3 (LP #1663376).
      [ Fixed in Debian 7.0.16-3 ]

applied/ubuntu/artful-devel 2017-04-26 17:08:21 UTC 2017-04-26
Import patches-applied version 7.0.18-2ubuntu1 to applied/ubuntu/artful-proposed

Author: Nish Aravamudan
Author Date: 2017-04-26 16:34:48 UTC

Import patches-applied version 7.0.18-2ubuntu1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 9bb4e96f4dbb39ea274eaefabb29970e4be69bfc
Unapplied parent: 36da71d41d40f93a6297717e86855a8a21b50f7f

New changelog entries:
  * Merge with Debian unstable (LP: #1686235). Remaining changes:
    - Drop dh-php from Recommends to Suggests so it can be demoted to
      universe (LP #1590623).
      + dh-php has gained a dependency on xml2 which is in universe.
  * Drop:
    - debian/patches/0050-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - debian/patches/fix_74021.patch: Fix fetch_array with more than
      MEDIUMBLOB. Thanks to andrewnester <andrew.nester.dev@gmail.com>.
      Closes LP #1668017.
      [ Fixed upstream in 7.0.17 ]
    - Cherry-pick: 'Fix generating recommends for php extensions (Closes:
      #855467)' from 7.0.16-3 (LP #1663376).
      [ Fixed in Debian 7.0.16-3 ]

applied/ubuntu/artful 2017-04-26 17:08:21 UTC 2017-04-26
Import patches-applied version 7.0.18-2ubuntu1 to applied/ubuntu/artful-proposed

Author: Nish Aravamudan
Author Date: 2017-04-26 16:34:48 UTC

Import patches-applied version 7.0.18-2ubuntu1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 9bb4e96f4dbb39ea274eaefabb29970e4be69bfc
Unapplied parent: 36da71d41d40f93a6297717e86855a8a21b50f7f

New changelog entries:
  * Merge with Debian unstable (LP: #1686235). Remaining changes:
    - Drop dh-php from Recommends to Suggests so it can be demoted to
      universe (LP #1590623).
      + dh-php has gained a dependency on xml2 which is in universe.
  * Drop:
    - debian/patches/0050-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - debian/patches/fix_74021.patch: Fix fetch_array with more than
      MEDIUMBLOB. Thanks to andrewnester <andrew.nester.dev@gmail.com>.
      Closes LP #1668017.
      [ Fixed upstream in 7.0.17 ]
    - Cherry-pick: 'Fix generating recommends for php extensions (Closes:
      #855467)' from 7.0.16-3 (LP #1663376).
      [ Fixed in Debian 7.0.16-3 ]

applied/ubuntu/devel 2017-04-26 17:08:21 UTC 2017-04-26
Import patches-applied version 7.0.18-2ubuntu1 to applied/ubuntu/artful-proposed

Author: Nish Aravamudan
Author Date: 2017-04-26 16:34:48 UTC

Import patches-applied version 7.0.18-2ubuntu1 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 9bb4e96f4dbb39ea274eaefabb29970e4be69bfc
Unapplied parent: 36da71d41d40f93a6297717e86855a8a21b50f7f

New changelog entries:
  * Merge with Debian unstable (LP: #1686235). Remaining changes:
    - Drop dh-php from Recommends to Suggests so it can be demoted to
      universe (LP #1590623).
      + dh-php has gained a dependency on xml2 which is in universe.
  * Drop:
    - debian/patches/0050-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - debian/patches/fix_74021.patch: Fix fetch_array with more than
      MEDIUMBLOB. Thanks to andrewnester <andrew.nester.dev@gmail.com>.
      Closes LP #1668017.
      [ Fixed upstream in 7.0.17 ]
    - Cherry-pick: 'Fix generating recommends for php extensions (Closes:
      #855467)' from 7.0.16-3 (LP #1663376).
      [ Fixed in Debian 7.0.16-3 ]

ubuntu/artful 2017-04-26 17:08:21 UTC 2017-04-26
Import patches-unapplied version 7.0.18-2ubuntu1 to ubuntu/artful-proposed

Author: Nish Aravamudan
Author Date: 2017-04-26 16:34:48 UTC

Import patches-unapplied version 7.0.18-2ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 1c4100b7fa69b623ade576aab753b13496022573
Upload parent: e677e48fc2d2136da83c1a63d405eb6b549cc8d3

New changelog entries:
  * Merge with Debian unstable (LP: #1686235). Remaining changes:
    - Drop dh-php from Recommends to Suggests so it can be demoted to
      universe (LP #1590623).
      + dh-php has gained a dependency on xml2 which is in universe.
  * Drop:
    - debian/patches/0050-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - debian/patches/fix_74021.patch: Fix fetch_array with more than
      MEDIUMBLOB. Thanks to andrewnester <andrew.nester.dev@gmail.com>.
      Closes LP #1668017.
      [ Fixed upstream in 7.0.17 ]
    - Cherry-pick: 'Fix generating recommends for php extensions (Closes:
      #855467)' from 7.0.16-3 (LP #1663376).
      [ Fixed in Debian 7.0.16-3 ]

ubuntu/artful-devel 2017-04-26 17:08:21 UTC 2017-04-26
Import patches-unapplied version 7.0.18-2ubuntu1 to ubuntu/artful-proposed

Author: Nish Aravamudan
Author Date: 2017-04-26 16:34:48 UTC

Import patches-unapplied version 7.0.18-2ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 1c4100b7fa69b623ade576aab753b13496022573
Upload parent: e677e48fc2d2136da83c1a63d405eb6b549cc8d3

New changelog entries:
  * Merge with Debian unstable (LP: #1686235). Remaining changes:
    - Drop dh-php from Recommends to Suggests so it can be demoted to
      universe (LP #1590623).
      + dh-php has gained a dependency on xml2 which is in universe.
  * Drop:
    - debian/patches/0050-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - debian/patches/fix_74021.patch: Fix fetch_array with more than
      MEDIUMBLOB. Thanks to andrewnester <andrew.nester.dev@gmail.com>.
      Closes LP #1668017.
      [ Fixed upstream in 7.0.17 ]
    - Cherry-pick: 'Fix generating recommends for php extensions (Closes:
      #855467)' from 7.0.16-3 (LP #1663376).
      [ Fixed in Debian 7.0.16-3 ]

ubuntu/artful-proposed 2017-04-26 17:08:21 UTC 2017-04-26
Import patches-unapplied version 7.0.18-2ubuntu1 to ubuntu/artful-proposed

Author: Nish Aravamudan
Author Date: 2017-04-26 16:34:48 UTC

Import patches-unapplied version 7.0.18-2ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 1c4100b7fa69b623ade576aab753b13496022573
Upload parent: e677e48fc2d2136da83c1a63d405eb6b549cc8d3

New changelog entries:
  * Merge with Debian unstable (LP: #1686235). Remaining changes:
    - Drop dh-php from Recommends to Suggests so it can be demoted to
      universe (LP #1590623).
      + dh-php has gained a dependency on xml2 which is in universe.
  * Drop:
    - debian/patches/0050-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - debian/patches/fix_74021.patch: Fix fetch_array with more than
      MEDIUMBLOB. Thanks to andrewnester <andrew.nester.dev@gmail.com>.
      Closes LP #1668017.
      [ Fixed upstream in 7.0.17 ]
    - Cherry-pick: 'Fix generating recommends for php extensions (Closes:
      #855467)' from 7.0.16-3 (LP #1663376).
      [ Fixed in Debian 7.0.16-3 ]

ubuntu/devel 2017-04-26 17:08:21 UTC 2017-04-26
Import patches-unapplied version 7.0.18-2ubuntu1 to ubuntu/artful-proposed

Author: Nish Aravamudan
Author Date: 2017-04-26 16:34:48 UTC

Import patches-unapplied version 7.0.18-2ubuntu1 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 1c4100b7fa69b623ade576aab753b13496022573
Upload parent: e677e48fc2d2136da83c1a63d405eb6b549cc8d3

New changelog entries:
  * Merge with Debian unstable (LP: #1686235). Remaining changes:
    - Drop dh-php from Recommends to Suggests so it can be demoted to
      universe (LP #1590623).
      + dh-php has gained a dependency on xml2 which is in universe.
  * Drop:
    - debian/patches/0050-Fix-pdo_pgsql.patch: Fixed #73959 - lastInsertId
      fails to throw an exception in pdsql. Thanks to andrewnester
      <andrew.nester.dev@gmail.com>. Closes LP #1658289.
      [ Fixed upstream in 7.0.16 ]
    - debian/patches/fix_74021.patch: Fix fetch_array with more than
      MEDIUMBLOB. Thanks to andrewnester <andrew.nester.dev@gmail.com>.
      Closes LP #1668017.
      [ Fixed upstream in 7.0.17 ]
    - Cherry-pick: 'Fix generating recommends for php extensions (Closes:
      #855467)' from 7.0.16-3 (LP #1663376).
      [ Fixed in Debian 7.0.16-3 ]

ubuntu/zesty 2017-03-10 23:59:49 UTC 2017-03-10
Import patches-unapplied version 7.0.15-1ubuntu4 to ubuntu/zesty-proposed

Author: Nish Aravamudan
Author Date: 2017-02-28 21:33:59 UTC

Import patches-unapplied version 7.0.15-1ubuntu4 to ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: ccbff1785bd7f7551404f5627b2af0cec166d6ba
Upload parent: d3d41f3035cd6ed646ccaef3e93c3f59edc2bf78

New changelog entries:
  * Cherry-pick: 'Fix generating recommends for php extensions (Closes:
    #855467)' from 7.0.16-3 (LP: #1663376).

applied/ubuntu/zesty 2017-03-10 23:59:49 UTC 2017-03-10
Import patches-applied version 7.0.15-1ubuntu4 to applied/ubuntu/zesty-proposed

Author: Nish Aravamudan
Author Date: 2017-02-28 21:33:59 UTC

Import patches-applied version 7.0.15-1ubuntu4 to applied/ubuntu/zesty-proposed

Imported using git-ubuntu import.

Changelog parent: 3a14f9a1e942a379fbf48649bb89232e5bd03699
Unapplied parent: d98560eb01d26733d9d6db38987e10e11d34cb61

New changelog entries:
  * Cherry-pick: 'Fix generating recommends for php extensions (Closes:
    #855467)' from 7.0.16-3 (LP: #1663376).

applied/ubuntu/yakkety-security 2017-03-02 14:43:25 UTC 2017-03-02
Import patches-applied version 7.0.15-0ubuntu0.16.10.4 to applied/ubuntu/yakk...

Author: Marc Deslauriers
Author Date: 2017-03-01 15:50:27 UTC

Import patches-applied version 7.0.15-0ubuntu0.16.10.4 to applied/ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 8228785cf7987011bdb88c4b6a98d2668ca1eed6
Unapplied parent: 91ca5ad337601e2854dcc75ba72bf0a6c3e1f747

New changelog entries:
  * SECURITY REGRESSION: large mysql requests broken (LP: #1668017)
    - debian/patches/fix_74021.patch: fix fetch_array with more than
      MEDIUMBLOB in ext/mysqlnd/mysqlnd_wireprotocol.c, added tests to
      ext/mysqli/tests/bug73800.phpt, ext/mysqli/tests/bug74021.phpt.

ubuntu/yakkety-security 2017-03-02 14:43:25 UTC 2017-03-02
Import patches-unapplied version 7.0.15-0ubuntu0.16.10.4 to ubuntu/yakkety-se...

Author: Marc Deslauriers
Author Date: 2017-03-01 15:50:27 UTC

Import patches-unapplied version 7.0.15-0ubuntu0.16.10.4 to ubuntu/yakkety-security

Imported using git-ubuntu import.

Changelog parent: 5e50dd97fba3bfe8657bf3f4b6b0b10fea495772

New changelog entries:
  * SECURITY REGRESSION: large mysql requests broken (LP: #1668017)
    - debian/patches/fix_74021.patch: fix fetch_array with more than
      MEDIUMBLOB in ext/mysqlnd/mysqlnd_wireprotocol.c, added tests to
      ext/mysqli/tests/bug73800.phpt, ext/mysqli/tests/bug74021.phpt.

applied/ubuntu/yakkety 2016-10-04 18:19:10 UTC 2016-10-04
Import patches-applied version 7.0.8-3ubuntu3 to applied/ubuntu/yakkety-proposed

Author: Marc Deslauriers
Author Date: 2016-10-03 19:48:48 UTC

Import patches-applied version 7.0.8-3ubuntu3 to applied/ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: b61fb0e204c49abfc296426035fab5aaa72a1154
Unapplied parent: 8b41bae3b43ff13da218c2f2fcc4cf1ccd74c209

New changelog entries:
  * SECURITY UPDATE: denial of service or code execution via crafted
    serialized data
    - debian/patches/CVE-2016-7124.patch: fix unserializing logic in
      ext/session/session.c, ext/standard/var_unserializer.c*,
      ext/wddx/wddx.c, added tests to
      ext/standard/tests/serialize/bug72663.phpt,
      ext/standard/tests/serialize/bug72663_2.phpt,
      ext/standard/tests/serialize/bug72663_3.phpt.
    - CVE-2016-7124
  * SECURITY UPDATE: arbitrary-type session data injection
    - debian/patches/CVE-2016-7125.patch: consume data even if not storing
      in ext/session/session.c, added test to
      ext/session/tests/bug72681.phpt.
    - CVE-2016-7125
  * SECURITY UPDATE: denial of service and possible code execution in
    imagegammacorrect function
    - debian/patches/CVE-2016-7127.patch: check gamma values in
      ext/gd/gd.c, added test to ext/gd/tests/bug72730.phpt.
    - CVE-2016-7127
  * SECURITY UPDATE: information disclosure via exif_process_IFD_in_TIFF
    - debian/patches/CVE-2016-7128.patch: properly handle thumbnails in
      ext/exif/exif.c.
    - CVE-2016-7128
  * SECURITY UPDATE: denial of service and possible code execution via
    invalid ISO 8601 time value
    - debian/patches/CVE-2016-7129.patch: properly handle strings in
      ext/wddx/wddx.c, added test to ext/wddx/tests/bug72749.phpt.
    - CVE-2016-7129
  * SECURITY UPDATE: denial of service and possible code execution via
    invalid base64 binary value
    - debian/patches/CVE-2016-7130.patch: properly handle string in
      ext/wddx/wddx.c, added test to ext/wddx/tests/bug72750.phpt.
    - CVE-2016-7130
  * SECURITY UPDATE: denial of service and possible code execution via
    malformed wddxPacket XML document
    - debian/patches/CVE-2016-7131.patch: added checks to ext/wddx/wddx.c,
      added tests to ext/wddx/tests/bug72790.phpt,
      ext/wddx/tests/bug72799.phpt.
    - CVE-2016-7131
    - CVE-2016-7132
  * SECURITY UPDATE: denial of service and possible code execution via
    long pathname
    - debian/patches/CVE-2016-7133.patch: fix memory allocator in
      Zend/zend_alloc.c.
    - CVE-2016-7133
  * SECURITY UPDATE: denial of service and possible code execution via
    long string and curl_escape call
    - debian/patches/CVE-2016-7134.patch: check both curl_escape and
      curl_unescape in ext/curl/interface.c.
    - CVE-2016-7134
  * SECURITY UPDATE: denial of service and possible code execution via
    crafted field metadata in MySQL driver
    - debian/patches/CVE-2016-7412.patch: validate field length in
      ext/mysqlnd/mysqlnd_wireprotocol.c.
    - CVE-2016-7412
  * SECURITY UPDATE: denial of service and possible code execution via
    malformed wddxPacket XML document
    - debian/patches/CVE-2016-7413.patch: fixed use-after-free in
      ext/wddx/wddx.c, added test to ext/wddx/tests/bug72860.phpt.
    - CVE-2016-7413
  * SECURITY UPDATE: denial of service and possible code execution via
    crafted PHAR archive
    - debian/patches/CVE-2016-7414.patch: validate signatures in
      ext/phar/util.c, ext/phar/zip.c.
    - CVE-2016-7414
  * SECURITY UPDATE: denial of service and possible code execution via
    MessageFormatter::formatMessage call with a long first argument
    - debian/patches/CVE-2016-7416.patch: added locale length check to
      ext/intl/msgformat/msgformat_format.c.
    - CVE-2016-7416
  * SECURITY UPDATE: denial of service or code execution via crafted
    serialized data
    - debian/patches/CVE-2016-7417.patch: added type check to
      ext/spl/spl_array.c, added test to ext/spl/tests/bug73029.phpt, fix
      test in ext/spl/tests/bug70068.phpt.
    - CVE-2016-7417
  * SECURITY UPDATE: denial of service and possible code execution via
    malformed wddxPacket XML document
    - debian/patches/CVE-2016-7418.patch: fix out-of-bounds read in
      ext/wddx/wddx.c, added test to ext/wddx/tests/bug73065.phpt.
    - CVE-2016-7418

ubuntu/yakkety 2016-10-04 18:19:10 UTC 2016-10-04
Import patches-unapplied version 7.0.8-3ubuntu3 to ubuntu/yakkety-proposed

Author: Marc Deslauriers
Author Date: 2016-10-03 19:48:48 UTC

Import patches-unapplied version 7.0.8-3ubuntu3 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 57804547649fc4eb262d0e392893891f84f986a5

New changelog entries:
  * SECURITY UPDATE: denial of service or code execution via crafted
    serialized data
    - debian/patches/CVE-2016-7124.patch: fix unserializing logic in
      ext/session/session.c, ext/standard/var_unserializer.c*,
      ext/wddx/wddx.c, added tests to
      ext/standard/tests/serialize/bug72663.phpt,
      ext/standard/tests/serialize/bug72663_2.phpt,
      ext/standard/tests/serialize/bug72663_3.phpt.
    - CVE-2016-7124
  * SECURITY UPDATE: arbitrary-type session data injection
    - debian/patches/CVE-2016-7125.patch: consume data even if not storing
      in ext/session/session.c, added test to
      ext/session/tests/bug72681.phpt.
    - CVE-2016-7125
  * SECURITY UPDATE: denial of service and possible code execution in
    imagegammacorrect function
    - debian/patches/CVE-2016-7127.patch: check gamma values in
      ext/gd/gd.c, added test to ext/gd/tests/bug72730.phpt.
    - CVE-2016-7127
  * SECURITY UPDATE: information disclosure via exif_process_IFD_in_TIFF
    - debian/patches/CVE-2016-7128.patch: properly handle thumbnails in
      ext/exif/exif.c.
    - CVE-2016-7128
  * SECURITY UPDATE: denial of service and possible code execution via
    invalid ISO 8601 time value
    - debian/patches/CVE-2016-7129.patch: properly handle strings in
      ext/wddx/wddx.c, added test to ext/wddx/tests/bug72749.phpt.
    - CVE-2016-7129
  * SECURITY UPDATE: denial of service and possible code execution via
    invalid base64 binary value
    - debian/patches/CVE-2016-7130.patch: properly handle string in
      ext/wddx/wddx.c, added test to ext/wddx/tests/bug72750.phpt.
    - CVE-2016-7130
  * SECURITY UPDATE: denial of service and possible code execution via
    malformed wddxPacket XML document
    - debian/patches/CVE-2016-7131.patch: added checks to ext/wddx/wddx.c,
      added tests to ext/wddx/tests/bug72790.phpt,
      ext/wddx/tests/bug72799.phpt.
    - CVE-2016-7131
    - CVE-2016-7132
  * SECURITY UPDATE: denial of service and possible code execution via
    long pathname
    - debian/patches/CVE-2016-7133.patch: fix memory allocator in
      Zend/zend_alloc.c.
    - CVE-2016-7133
  * SECURITY UPDATE: denial of service and possible code execution via
    long string and curl_escape call
    - debian/patches/CVE-2016-7134.patch: check both curl_escape and
      curl_unescape in ext/curl/interface.c.
    - CVE-2016-7134
  * SECURITY UPDATE: denial of service and possible code execution via
    crafted field metadata in MySQL driver
    - debian/patches/CVE-2016-7412.patch: validate field length in
      ext/mysqlnd/mysqlnd_wireprotocol.c.
    - CVE-2016-7412
  * SECURITY UPDATE: denial of service and possible code execution via
    malformed wddxPacket XML document
    - debian/patches/CVE-2016-7413.patch: fixed use-after-free in
      ext/wddx/wddx.c, added test to ext/wddx/tests/bug72860.phpt.
    - CVE-2016-7413
  * SECURITY UPDATE: denial of service and possible code execution via
    crafted PHAR archive
    - debian/patches/CVE-2016-7414.patch: validate signatures in
      ext/phar/util.c, ext/phar/zip.c.
    - CVE-2016-7414
  * SECURITY UPDATE: denial of service and possible code execution via
    MessageFormatter::formatMessage call with a long first argument
    - debian/patches/CVE-2016-7416.patch: added locale length check to
      ext/intl/msgformat/msgformat_format.c.
    - CVE-2016-7416
  * SECURITY UPDATE: denial of service or code execution via crafted
    serialized data
    - debian/patches/CVE-2016-7417.patch: added type check to
      ext/spl/spl_array.c, added test to ext/spl/tests/bug73029.phpt, fix
      test in ext/spl/tests/bug70068.phpt.
    - CVE-2016-7417
  * SECURITY UPDATE: denial of service and possible code execution via
    malformed wddxPacket XML document
    - debian/patches/CVE-2016-7418.patch: fix out-of-bounds read in
      ext/wddx/wddx.c, added test to ext/wddx/tests/bug73065.phpt.
    - CVE-2016-7418

applied/ubuntu/xenial 2016-04-14 07:54:42 UTC 2016-04-14
Import patches-applied version 7.0.4-7ubuntu2 to applied/ubuntu/xenial-proposed

Author: Nish Aravamudan
Author Date: 2016-04-13 19:45:21 UTC

Import patches-applied version 7.0.4-7ubuntu2 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: fb9342ae4c432f2bc8ca0e9056d8ec3227f040b4
Unapplied parent: d96120e8468d5eb3b6a3edc66ccb734473fa53ad

New changelog entries:
  * debian/patches/0052-backport-186844be.patch: Fix bug #71695: Global
    variables are resreved before execution. Closes LP: #1569509.

ubuntu/xenial 2016-04-14 07:54:42 UTC 2016-04-14
Import patches-unapplied version 7.0.4-7ubuntu2 to ubuntu/xenial-proposed

Author: Nish Aravamudan
Author Date: 2016-04-13 19:45:21 UTC

Import patches-unapplied version 7.0.4-7ubuntu2 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: d6fd52b1875a4337610b01e4c8f310165ffe3f37

New changelog entries:
  * debian/patches/0052-backport-186844be.patch: Fix bug #71695: Global
    variables are resreved before execution. Closes LP: #1569509.

applied/debian/experimental 2015-12-03 22:13:53 UTC 2015-12-03
Import patches-applied version 7.0.0~rc8-3 to applied/debian/experimental

Author: Ondřej Surý
Author Date: 2015-11-30 08:27:58 UTC

Import patches-applied version 7.0.0~rc8-3 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 8d385687b117b89af26f8fabd9046c23bcd20a44
Unapplied parent: c95b0f9aa6621d9cd3e8f0fc01515f0484b80569

New changelog entries:
  * Move JSON ext to separate mk file and a separate package again
  * Re-enable Zend OpCache again and into a separate package

debian/experimental 2015-12-03 22:13:53 UTC 2015-12-03
Import patches-unapplied version 7.0.0~rc8-3 to debian/experimental

Author: Ondřej Surý
Author Date: 2015-11-30 08:27:58 UTC

Import patches-unapplied version 7.0.0~rc8-3 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 950c93b89a4fa33d4d7234a36f4663489dd0a05b

New changelog entries:
  * Move JSON ext to separate mk file and a separate package again
  * Re-enable Zend OpCache again and into a separate package

150 of 50 results

Other repositories

Name Last Modified
lp:ubuntu/+source/php7.0 2019-03-26
lp:~kstenerud/ubuntu/+source/php7.0 2019-03-11
lp:~nacc/ubuntu/+source/php7.0 2018-01-23
13 of 3 results
You can't create new repositories for php7.0 in Ubuntu.