View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/pam
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
applied/ubuntu/utopic-proposed 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-applied version 1.1.8-3ubuntu4 to applied/ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 19:32:23 UTC

Import patches-applied version 1.1.8-3ubuntu4 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: d80f6cbbedfee4916f801d2cc99f4f073e16772d
Unapplied parent: 2691a5032c7de1d2b1cf8ffc1b94cdc6eefcdb1b

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

applied/ubuntu/utopic 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-applied version 1.1.8-3ubuntu4 to applied/ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 19:32:23 UTC

Import patches-applied version 1.1.8-3ubuntu4 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: d80f6cbbedfee4916f801d2cc99f4f073e16772d
Unapplied parent: 2691a5032c7de1d2b1cf8ffc1b94cdc6eefcdb1b

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

applied/ubuntu/utopic-devel 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-applied version 1.1.8-3ubuntu4 to applied/ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 19:32:23 UTC

Import patches-applied version 1.1.8-3ubuntu4 to applied/ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: d80f6cbbedfee4916f801d2cc99f4f073e16772d
Unapplied parent: 2691a5032c7de1d2b1cf8ffc1b94cdc6eefcdb1b

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

ubuntu/utopic-proposed 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-unapplied version 1.1.8-3ubuntu4 to ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 19:32:23 UTC

Import patches-unapplied version 1.1.8-3ubuntu4 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 58599868f19a03ac623883aafb547c7322048554

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

ubuntu/utopic 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-unapplied version 1.1.8-3ubuntu4 to ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 19:32:23 UTC

Import patches-unapplied version 1.1.8-3ubuntu4 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 58599868f19a03ac623883aafb547c7322048554

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

ubuntu/utopic-devel 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-unapplied version 1.1.8-3ubuntu4 to ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 19:32:23 UTC

Import patches-unapplied version 1.1.8-3ubuntu4 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 58599868f19a03ac623883aafb547c7322048554

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

applied/ubuntu/trusty 2014-01-31 22:33:29 UTC 2014-01-31
Import patches-applied version 1.1.8-1ubuntu2 to applied/ubuntu/trusty-proposed

Author: Stéphane Graber
Author Date: 2014-01-31 22:11:02 UTC

Import patches-applied version 1.1.8-1ubuntu2 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 18cf64d34ae8759fea31414546d38c24e5803d33
Unapplied parent: a980decec1ac379f9032d3a794d6e069fbd36eb6

New changelog entries:
  * debian/patches-applied/pam-loginuid-in-containers: pam_loginuid:
    Update patch with follow-up changes to loginuid.c

applied/ubuntu/trusty-proposed 2014-01-31 22:33:29 UTC 2014-01-31
Import patches-applied version 1.1.8-1ubuntu2 to applied/ubuntu/trusty-proposed

Author: Stéphane Graber
Author Date: 2014-01-31 22:11:02 UTC

Import patches-applied version 1.1.8-1ubuntu2 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 18cf64d34ae8759fea31414546d38c24e5803d33
Unapplied parent: a980decec1ac379f9032d3a794d6e069fbd36eb6

New changelog entries:
  * debian/patches-applied/pam-loginuid-in-containers: pam_loginuid:
    Update patch with follow-up changes to loginuid.c

ubuntu/trusty 2014-01-31 22:33:29 UTC 2014-01-31
Import patches-unapplied version 1.1.8-1ubuntu2 to ubuntu/trusty-proposed

Author: Stéphane Graber
Author Date: 2014-01-31 22:11:02 UTC

Import patches-unapplied version 1.1.8-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 53f25be7061632c68f90a95608a85ca5c98140a8

New changelog entries:
  * debian/patches-applied/pam-loginuid-in-containers: pam_loginuid:
    Update patch with follow-up changes to loginuid.c

ubuntu/trusty-proposed 2014-01-31 22:33:29 UTC 2014-01-31
Import patches-unapplied version 1.1.8-1ubuntu2 to ubuntu/trusty-proposed

Author: Stéphane Graber
Author Date: 2014-01-31 22:11:02 UTC

Import patches-unapplied version 1.1.8-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 53f25be7061632c68f90a95608a85ca5c98140a8

New changelog entries:
  * debian/patches-applied/pam-loginuid-in-containers: pam_loginuid:
    Update patch with follow-up changes to loginuid.c

applied/ubuntu/saucy-devel 2013-05-18 05:33:36 UTC 2013-05-18
Import patches-applied version 1.1.3-8ubuntu3 to applied/ubuntu/saucy-proposed

Author: Steve Langasek
Author Date: 2013-05-18 05:07:43 UTC

Import patches-applied version 1.1.3-8ubuntu3 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 39424db3de4972108022b095ce341ed918018fd4
Unapplied parent: 89269961974917073467897ed52e50da10b65a5a

New changelog entries:
  * Adjust debian/patches-applied/update-motd to write to /run/motd.dynamic,
    as sysvinit/ssh/login in Debian have been changed to use this file and
    no longer links /etc/motd to /var/run/motd.

ubuntu/saucy 2013-05-18 05:33:36 UTC 2013-05-18
Import patches-unapplied version 1.1.3-8ubuntu3 to ubuntu/saucy-proposed

Author: Steve Langasek
Author Date: 2013-05-18 05:07:43 UTC

Import patches-unapplied version 1.1.3-8ubuntu3 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 834493101b1e63df6ed5659cb8592198580bbe41

New changelog entries:
  * Adjust debian/patches-applied/update-motd to write to /run/motd.dynamic,
    as sysvinit/ssh/login in Debian have been changed to use this file and
    no longer links /etc/motd to /var/run/motd.

applied/ubuntu/saucy-proposed 2013-05-18 05:33:36 UTC 2013-05-18
Import patches-applied version 1.1.3-8ubuntu3 to applied/ubuntu/saucy-proposed

Author: Steve Langasek
Author Date: 2013-05-18 05:07:43 UTC

Import patches-applied version 1.1.3-8ubuntu3 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 39424db3de4972108022b095ce341ed918018fd4
Unapplied parent: 89269961974917073467897ed52e50da10b65a5a

New changelog entries:
  * Adjust debian/patches-applied/update-motd to write to /run/motd.dynamic,
    as sysvinit/ssh/login in Debian have been changed to use this file and
    no longer links /etc/motd to /var/run/motd.

applied/ubuntu/saucy 2013-05-18 05:33:36 UTC 2013-05-18
Import patches-applied version 1.1.3-8ubuntu3 to applied/ubuntu/saucy-proposed

Author: Steve Langasek
Author Date: 2013-05-18 05:07:43 UTC

Import patches-applied version 1.1.3-8ubuntu3 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 39424db3de4972108022b095ce341ed918018fd4
Unapplied parent: 89269961974917073467897ed52e50da10b65a5a

New changelog entries:
  * Adjust debian/patches-applied/update-motd to write to /run/motd.dynamic,
    as sysvinit/ssh/login in Debian have been changed to use this file and
    no longer links /etc/motd to /var/run/motd.

ubuntu/saucy-devel 2013-05-18 05:33:36 UTC 2013-05-18
Import patches-unapplied version 1.1.3-8ubuntu3 to ubuntu/saucy-proposed

Author: Steve Langasek
Author Date: 2013-05-18 05:07:43 UTC

Import patches-unapplied version 1.1.3-8ubuntu3 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 834493101b1e63df6ed5659cb8592198580bbe41

New changelog entries:
  * Adjust debian/patches-applied/update-motd to write to /run/motd.dynamic,
    as sysvinit/ssh/login in Debian have been changed to use this file and
    no longer links /etc/motd to /var/run/motd.

ubuntu/saucy-proposed 2013-05-18 05:33:36 UTC 2013-05-18
Import patches-unapplied version 1.1.3-8ubuntu3 to ubuntu/saucy-proposed

Author: Steve Langasek
Author Date: 2013-05-18 05:07:43 UTC

Import patches-unapplied version 1.1.3-8ubuntu3 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 834493101b1e63df6ed5659cb8592198580bbe41

New changelog entries:
  * Adjust debian/patches-applied/update-motd to write to /run/motd.dynamic,
    as sysvinit/ssh/login in Debian have been changed to use this file and
    no longer links /etc/motd to /var/run/motd.

ubuntu/lucid-proposed 2013-03-26 21:33:26 UTC 2013-03-26
Import patches-unapplied version 1.1.1-2ubuntu5.6 to ubuntu/lucid-proposed

Author: Steve Langasek
Author Date: 2013-03-26 20:05:44 UTC

Import patches-unapplied version 1.1.1-2ubuntu5.6 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 74113e880732acba300d372f0f38d3c88a00790e

New changelog entries:
  * Include the pam_tally2 helper in /sbin so that the pam_tally2 module can
    be used. LP: #586462.

applied/ubuntu/lucid-updates 2013-03-26 21:33:26 UTC 2013-03-26
Import patches-applied version 1.1.1-2ubuntu5.6 to applied/ubuntu/lucid-proposed

Author: Steve Langasek
Author Date: 2013-03-26 20:05:44 UTC

Import patches-applied version 1.1.1-2ubuntu5.6 to applied/ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 81ebaea5aad7fdc24171d3b3b63ac31066ee1c24
Unapplied parent: 73d112aee5ab563d638706ce7c551e89d21523f9

New changelog entries:
  * Include the pam_tally2 helper in /sbin so that the pam_tally2 module can
    be used. LP: #586462.

applied/ubuntu/lucid-proposed 2013-03-26 21:33:26 UTC 2013-03-26
Import patches-applied version 1.1.1-2ubuntu5.6 to applied/ubuntu/lucid-proposed

Author: Steve Langasek
Author Date: 2013-03-26 20:05:44 UTC

Import patches-applied version 1.1.1-2ubuntu5.6 to applied/ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 81ebaea5aad7fdc24171d3b3b63ac31066ee1c24
Unapplied parent: 73d112aee5ab563d638706ce7c551e89d21523f9

New changelog entries:
  * Include the pam_tally2 helper in /sbin so that the pam_tally2 module can
    be used. LP: #586462.

applied/ubuntu/lucid-devel 2013-03-26 21:33:26 UTC 2013-03-26
Import patches-applied version 1.1.1-2ubuntu5.6 to applied/ubuntu/lucid-proposed

Author: Steve Langasek
Author Date: 2013-03-26 20:05:44 UTC

Import patches-applied version 1.1.1-2ubuntu5.6 to applied/ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 81ebaea5aad7fdc24171d3b3b63ac31066ee1c24
Unapplied parent: 73d112aee5ab563d638706ce7c551e89d21523f9

New changelog entries:
  * Include the pam_tally2 helper in /sbin so that the pam_tally2 module can
    be used. LP: #586462.

ubuntu/lucid-devel 2013-03-26 21:33:26 UTC 2013-03-26
Import patches-unapplied version 1.1.1-2ubuntu5.6 to ubuntu/lucid-proposed

Author: Steve Langasek
Author Date: 2013-03-26 20:05:44 UTC

Import patches-unapplied version 1.1.1-2ubuntu5.6 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 74113e880732acba300d372f0f38d3c88a00790e

New changelog entries:
  * Include the pam_tally2 helper in /sbin so that the pam_tally2 module can
    be used. LP: #586462.

ubuntu/lucid-updates 2013-03-26 21:33:26 UTC 2013-03-26
Import patches-unapplied version 1.1.1-2ubuntu5.6 to ubuntu/lucid-proposed

Author: Steve Langasek
Author Date: 2013-03-26 20:05:44 UTC

Import patches-unapplied version 1.1.1-2ubuntu5.6 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: 74113e880732acba300d372f0f38d3c88a00790e

New changelog entries:
  * Include the pam_tally2 helper in /sbin so that the pam_tally2 module can
    be used. LP: #586462.

ubuntu/raring-devel 2013-03-12 04:03:19 UTC 2013-03-12
Import patches-unapplied version 1.1.3-8ubuntu2 to ubuntu/raring-proposed

Author: Wookey
Author Date: 2013-02-15 12:45:27 UTC

Import patches-unapplied version 1.1.3-8ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 8fbdcd3f207e76ad97f6cf0aa142c4313b666105

New changelog entries:
  * Disable libaudit for stage1 bootstrap (LP: #1126404)

applied/ubuntu/raring 2013-03-12 04:03:19 UTC 2013-03-12
Import patches-applied version 1.1.3-8ubuntu2 to applied/ubuntu/raring-proposed

Author: Wookey
Author Date: 2013-02-15 12:45:27 UTC

Import patches-applied version 1.1.3-8ubuntu2 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: fae8a59e28ae97f0567c93b4c8f56200ed59b93c
Unapplied parent: 834493101b1e63df6ed5659cb8592198580bbe41

New changelog entries:
  * Disable libaudit for stage1 bootstrap (LP: #1126404)

applied/ubuntu/raring-devel 2013-03-12 04:03:19 UTC 2013-03-12
Import patches-applied version 1.1.3-8ubuntu2 to applied/ubuntu/raring-proposed

Author: Wookey
Author Date: 2013-02-15 12:45:27 UTC

Import patches-applied version 1.1.3-8ubuntu2 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: fae8a59e28ae97f0567c93b4c8f56200ed59b93c
Unapplied parent: 834493101b1e63df6ed5659cb8592198580bbe41

New changelog entries:
  * Disable libaudit for stage1 bootstrap (LP: #1126404)

applied/ubuntu/raring-proposed 2013-03-12 04:03:19 UTC 2013-03-12
Import patches-applied version 1.1.3-8ubuntu2 to applied/ubuntu/raring-proposed

Author: Wookey
Author Date: 2013-02-15 12:45:27 UTC

Import patches-applied version 1.1.3-8ubuntu2 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: fae8a59e28ae97f0567c93b4c8f56200ed59b93c
Unapplied parent: 834493101b1e63df6ed5659cb8592198580bbe41

New changelog entries:
  * Disable libaudit for stage1 bootstrap (LP: #1126404)

ubuntu/raring 2013-03-12 04:03:19 UTC 2013-03-12
Import patches-unapplied version 1.1.3-8ubuntu2 to ubuntu/raring-proposed

Author: Wookey
Author Date: 2013-02-15 12:45:27 UTC

Import patches-unapplied version 1.1.3-8ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 8fbdcd3f207e76ad97f6cf0aa142c4313b666105

New changelog entries:
  * Disable libaudit for stage1 bootstrap (LP: #1126404)

ubuntu/raring-proposed 2013-03-12 04:03:19 UTC 2013-03-12
Import patches-unapplied version 1.1.3-8ubuntu2 to ubuntu/raring-proposed

Author: Wookey
Author Date: 2013-02-15 12:45:27 UTC

Import patches-unapplied version 1.1.3-8ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 8fbdcd3f207e76ad97f6cf0aa142c4313b666105

New changelog entries:
  * Disable libaudit for stage1 bootstrap (LP: #1126404)

applied/ubuntu/quantal-devel 2012-07-03 07:06:07 UTC 2012-07-03
Import patches-applied version 1.1.3-7ubuntu3 to applied/ubuntu/quantal

Author: Steve Langasek
Author Date: 2012-07-03 06:55:25 UTC

Import patches-applied version 1.1.3-7ubuntu3 to applied/ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: e0ad34394ce16f1cad527673ecd86941123a9bb5
Unapplied parent: 45bb14fe271db4b59ac153d9788b41c4e025cf41

New changelog entries:
  [ Nathan Williams ]
  * Add /usr/local/games to PATH. LP: #110287.

applied/ubuntu/quantal 2012-07-03 07:06:07 UTC 2012-07-03
Import patches-applied version 1.1.3-7ubuntu3 to applied/ubuntu/quantal

Author: Steve Langasek
Author Date: 2012-07-03 06:55:25 UTC

Import patches-applied version 1.1.3-7ubuntu3 to applied/ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: e0ad34394ce16f1cad527673ecd86941123a9bb5
Unapplied parent: 45bb14fe271db4b59ac153d9788b41c4e025cf41

New changelog entries:
  [ Nathan Williams ]
  * Add /usr/local/games to PATH. LP: #110287.

ubuntu/quantal 2012-07-03 07:06:07 UTC 2012-07-03
Import patches-unapplied version 1.1.3-7ubuntu3 to ubuntu/quantal

Author: Steve Langasek
Author Date: 2012-07-03 06:55:25 UTC

Import patches-unapplied version 1.1.3-7ubuntu3 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 0a190c3ada7cb6530be4af6d60faf2948261b54f

New changelog entries:
  [ Nathan Williams ]
  * Add /usr/local/games to PATH. LP: #110287.

ubuntu/quantal-devel 2012-07-03 07:06:07 UTC 2012-07-03
Import patches-unapplied version 1.1.3-7ubuntu3 to ubuntu/quantal

Author: Steve Langasek
Author Date: 2012-07-03 06:55:25 UTC

Import patches-unapplied version 1.1.3-7ubuntu3 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 0a190c3ada7cb6530be4af6d60faf2948261b54f

New changelog entries:
  [ Nathan Williams ]
  * Add /usr/local/games to PATH. LP: #110287.

applied/debian/wheezy 2012-05-05 03:22:44 UTC 2012-05-05
Import patches-applied version 1.1.3-7.1 to applied/debian/sid

Author: Michael Gilbert
Author Date: 2012-04-29 06:23:26 UTC

Import patches-applied version 1.1.3-7.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: a1fdfa0b755859f78c917ea3c8d37980831a6272
Unapplied parent: fe98a1d14641b9634c61c2ceb2ff7bcb04432986

New changelog entries:
  * Non-maintainer upload.
  * Fix cve-2011-4708: user-configurable .pam_environment allows
    administrator-level changes without root access (closes: #611136).

debian/wheezy 2012-05-05 03:22:44 UTC 2012-05-05
Import patches-unapplied version 1.1.3-7.1 to debian/sid

Author: Michael Gilbert
Author Date: 2012-04-29 06:23:26 UTC

Import patches-unapplied version 1.1.3-7.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 0260ad338b33a4b9d95e026676b96ecc0cc9b6d4

New changelog entries:
  * Non-maintainer upload.
  * Fix cve-2011-4708: user-configurable .pam_environment allows
    administrator-level changes without root access (closes: #611136).

applied/ubuntu/precise 2012-02-09 02:36:50 UTC 2012-02-09
Import patches-applied version 1.1.3-7ubuntu2 to applied/ubuntu/precise

Author: Steve Langasek
Author Date: 2012-02-09 01:15:39 UTC

Import patches-applied version 1.1.3-7ubuntu2 to applied/ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 6d02d5110fca64fba94cbed892a9bfbdf8d4d990
Unapplied parent: 0a190c3ada7cb6530be4af6d60faf2948261b54f

New changelog entries:
  * No-change rebuild with gzip 1.4-1ubuntu2 to get multiarch-clean
    compression of manpages. LP: #871083.

ubuntu/precise 2012-02-09 02:36:50 UTC 2012-02-09
Import patches-unapplied version 1.1.3-7ubuntu2 to ubuntu/precise

Author: Steve Langasek
Author Date: 2012-02-09 01:15:39 UTC

Import patches-unapplied version 1.1.3-7ubuntu2 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 99278f5ab189b9b6acdf857592536185901965f0

New changelog entries:
  * No-change rebuild with gzip 1.4-1ubuntu2 to get multiarch-clean
    compression of manpages. LP: #871083.

debian/squeeze 2012-01-28 15:28:30 UTC 2012-01-28
Import patches-unapplied version 1.1.1-6.1+squeeze1 to debian/squeeze

Author: Moritz Muehlenhoff
Author Date: 2011-10-17 18:28:52 UTC

Import patches-unapplied version 1.1.1-6.1+squeeze1 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: edf7962a728bed4e572057b9e203cc6647455c8b

New changelog entries:
  * Non-maintainer upload by the Security Team
  * Fix CVE-2011-3148 and CVE-2011-3149

applied/debian/squeeze 2012-01-28 15:28:30 UTC 2012-01-28
Import patches-applied version 1.1.1-6.1+squeeze1 to applied/debian/squeeze

Author: Moritz Muehlenhoff
Author Date: 2011-10-17 18:28:52 UTC

Import patches-applied version 1.1.1-6.1+squeeze1 to applied/debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 302d368202c04fb859ee0e3a93c19ef4854182b3
Unapplied parent: 49acbcb2c36e534722da88576951ca6f8dbf700e

New changelog entries:
  * Non-maintainer upload by the Security Team
  * Fix CVE-2011-3148 and CVE-2011-3149

applied/ubuntu/natty-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.2-2ubuntu8.4 to applied/ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:03:44 UTC

Import patches-applied version 1.1.2-2ubuntu8.4 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 36190df2dd22c31fd263a7c935317641c3ed1c9a
Unapplied parent: b03d6813c728bcbb01b2e2cf4c0e469626d14701

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/natty-devel 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.2-2ubuntu8.4 to applied/ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:03:44 UTC

Import patches-applied version 1.1.2-2ubuntu8.4 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 36190df2dd22c31fd263a7c935317641c3ed1c9a
Unapplied parent: b03d6813c728bcbb01b2e2cf4c0e469626d14701

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/maverick-updates 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.1-4ubuntu2.4 to applied/ubuntu/maverick-se...

Author: Marc Deslauriers
Author Date: 2011-10-18 14:05:50 UTC

Import patches-applied version 1.1.1-4ubuntu2.4 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: b5a2a4b4c8ba5cb3772bf1ecee9b0bb5abef893c
Unapplied parent: 868e3048586225de2e742847ca1112a46e816646

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/maverick-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.1-4ubuntu2.4 to applied/ubuntu/maverick-se...

Author: Marc Deslauriers
Author Date: 2011-10-18 14:05:50 UTC

Import patches-applied version 1.1.1-4ubuntu2.4 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: b5a2a4b4c8ba5cb3772bf1ecee9b0bb5abef893c
Unapplied parent: 868e3048586225de2e742847ca1112a46e816646

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/oneiric-updates 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.3-2ubuntu2.1 to applied/ubuntu/oneiric-sec...

Author: Marc Deslauriers
Author Date: 2011-10-18 13:33:47 UTC

Import patches-applied version 1.1.3-2ubuntu2.1 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: a0ac70791f64766886ddfc9a6c32939f69ea2c98
Unapplied parent: 362cbc231b22dc2ba739a210161a4071993c094a

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/maverick-devel 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.1-4ubuntu2.4 to ubuntu/maverick-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:05:50 UTC

Import patches-unapplied version 1.1.1-4ubuntu2.4 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: a35470b08fee2285901d6d5e7ad90edc88e43a49

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/maverick-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.1-4ubuntu2.4 to ubuntu/maverick-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:05:50 UTC

Import patches-unapplied version 1.1.1-4ubuntu2.4 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: a35470b08fee2285901d6d5e7ad90edc88e43a49

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/maverick-updates 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.1-4ubuntu2.4 to ubuntu/maverick-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:05:50 UTC

Import patches-unapplied version 1.1.1-4ubuntu2.4 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: a35470b08fee2285901d6d5e7ad90edc88e43a49

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/oneiric-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.3-2ubuntu2.1 to applied/ubuntu/oneiric-sec...

Author: Marc Deslauriers
Author Date: 2011-10-18 13:33:47 UTC

Import patches-applied version 1.1.3-2ubuntu2.1 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: a0ac70791f64766886ddfc9a6c32939f69ea2c98
Unapplied parent: 362cbc231b22dc2ba739a210161a4071993c094a

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/hardy-devel 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 0.99.7.1-5ubuntu6.5 to applied/ubuntu/hardy-se...

Author: Marc Deslauriers
Author Date: 2011-10-18 14:31:55 UTC

Import patches-applied version 0.99.7.1-5ubuntu6.5 to applied/ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 5dafc4682c4d71a5b15f3a39fa5fb1ff3502db7c
Unapplied parent: 7150b1410e07b05e2a2ac2579fb3b3904322c133

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in
      Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3149

applied/ubuntu/oneiric-devel 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.3-2ubuntu2.1 to applied/ubuntu/oneiric-sec...

Author: Marc Deslauriers
Author Date: 2011-10-18 13:33:47 UTC

Import patches-applied version 1.1.3-2ubuntu2.1 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: a0ac70791f64766886ddfc9a6c32939f69ea2c98
Unapplied parent: 362cbc231b22dc2ba739a210161a4071993c094a

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/natty-updates 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.2-2ubuntu8.4 to applied/ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:03:44 UTC

Import patches-applied version 1.1.2-2ubuntu8.4 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 36190df2dd22c31fd263a7c935317641c3ed1c9a
Unapplied parent: b03d6813c728bcbb01b2e2cf4c0e469626d14701

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/hardy-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 0.99.7.1-5ubuntu6.5 to applied/ubuntu/hardy-se...

Author: Marc Deslauriers
Author Date: 2011-10-18 14:31:55 UTC

Import patches-applied version 0.99.7.1-5ubuntu6.5 to applied/ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 5dafc4682c4d71a5b15f3a39fa5fb1ff3502db7c
Unapplied parent: 7150b1410e07b05e2a2ac2579fb3b3904322c133

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in
      Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3149

applied/ubuntu/hardy-updates 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 0.99.7.1-5ubuntu6.5 to applied/ubuntu/hardy-se...

Author: Marc Deslauriers
Author Date: 2011-10-18 14:31:55 UTC

Import patches-applied version 0.99.7.1-5ubuntu6.5 to applied/ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 5dafc4682c4d71a5b15f3a39fa5fb1ff3502db7c
Unapplied parent: 7150b1410e07b05e2a2ac2579fb3b3904322c133

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in
      Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3149

applied/ubuntu/maverick-devel 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.1-4ubuntu2.4 to applied/ubuntu/maverick-se...

Author: Marc Deslauriers
Author Date: 2011-10-18 14:05:50 UTC

Import patches-applied version 1.1.1-4ubuntu2.4 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: b5a2a4b4c8ba5cb3772bf1ecee9b0bb5abef893c
Unapplied parent: 868e3048586225de2e742847ca1112a46e816646

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

applied/ubuntu/lucid-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-applied version 1.1.1-2ubuntu5.4 to applied/ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:26:13 UTC

Import patches-applied version 1.1.1-2ubuntu5.4 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 9f1d82eb9c99152484c4b8013120d5a00af265f8
Unapplied parent: 74113e880732acba300d372f0f38d3c88a00790e

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/oneiric-updates 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.3-2ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2011-10-18 13:33:47 UTC

Import patches-unapplied version 1.1.3-2ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 598ee99b17dd1fe6f5f32ffebd614fb9fff09e4c

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/oneiric-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.3-2ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2011-10-18 13:33:47 UTC

Import patches-unapplied version 1.1.3-2ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 598ee99b17dd1fe6f5f32ffebd614fb9fff09e4c

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/hardy-devel 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 0.99.7.1-5ubuntu6.5 to ubuntu/hardy-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:31:55 UTC

Import patches-unapplied version 0.99.7.1-5ubuntu6.5 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: ccbb672d9c06e2ff4b1e105a34c1dc4deb28860d

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in
      Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3149

ubuntu/oneiric-devel 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.3-2ubuntu2.1 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2011-10-18 13:33:47 UTC

Import patches-unapplied version 1.1.3-2ubuntu2.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 598ee99b17dd1fe6f5f32ffebd614fb9fff09e4c

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/hardy-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 0.99.7.1-5ubuntu6.5 to ubuntu/hardy-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:31:55 UTC

Import patches-unapplied version 0.99.7.1-5ubuntu6.5 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: ccbb672d9c06e2ff4b1e105a34c1dc4deb28860d

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in
      Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3149

ubuntu/hardy-updates 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 0.99.7.1-5ubuntu6.5 to ubuntu/hardy-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:31:55 UTC

Import patches-unapplied version 0.99.7.1-5ubuntu6.5 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: ccbb672d9c06e2ff4b1e105a34c1dc4deb28860d

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in
      Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in Linux-PAM/modules/pam_env/pam_env.c.
    - CVE-2011-3149

ubuntu/natty-updates 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.2-2ubuntu8.4 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:03:44 UTC

Import patches-unapplied version 1.1.2-2ubuntu8.4 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 9edb99aadb01e92fe61f32fd705b1ebe4d7ef9e5

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/natty-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.2-2ubuntu8.4 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:03:44 UTC

Import patches-unapplied version 1.1.2-2ubuntu8.4 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 9edb99aadb01e92fe61f32fd705b1ebe4d7ef9e5

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/natty-devel 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.2-2ubuntu8.4 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:03:44 UTC

Import patches-unapplied version 1.1.2-2ubuntu8.4 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 9edb99aadb01e92fe61f32fd705b1ebe4d7ef9e5

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/lucid-security 2011-10-24 19:05:30 UTC 2011-10-24
Import patches-unapplied version 1.1.1-2ubuntu5.4 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2011-10-18 14:26:13 UTC

Import patches-unapplied version 1.1.1-2ubuntu5.4 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: 0126f8d2803c31b35b91bd6e9ad75f52e17b3fa6

New changelog entries:
  * SECURITY UPDATE: possible code execution via incorrect environment file
    parsing (LP: #874469)
    - debian/patches-applied/CVE-2011-3148.patch: correctly count leading
      whitespace when parsing environment file in modules/pam_env/pam_env.c.
    - CVE-2011-3148
  * SECURITY UPDATE: denial of service via overflowed environment variable
    expansion (LP: #874565)
    - debian/patches-applied/CVE-2011-3149.patch: when overflowing, exit
      with PAM_BUF_ERR in modules/pam_env/pam_env.c.
    - CVE-2011-3149
  * SECURITY UPDATE: code execution via incorrect environment cleaning
    - debian/patches-applied/update-motd: updated to use clean environment
      and absolute paths in modules/pam_motd/pam_motd.c.
    - CVE-2011-XXXX

ubuntu/oneiric-proposed 2011-10-10 07:03:38 UTC 2011-10-10
Import patches-unapplied version 1.1.3-2ubuntu2 to ubuntu/oneiric-proposed

Author: Steve Langasek
Author Date: 2011-10-09 22:41:41 UTC

Import patches-unapplied version 1.1.3-2ubuntu2 to ubuntu/oneiric-proposed

Imported using git-ubuntu import.

Changelog parent: 598ee99b17dd1fe6f5f32ffebd614fb9fff09e4c

New changelog entries:
  * No-change rebuild to regenerate compressed manpages, which for some
    unknown reason were compressed differently on some architectures than
    on others, breaking multiarch co-installability. LP: #871083.

applied/ubuntu/oneiric-proposed 2011-10-10 07:03:38 UTC 2011-10-10
Import patches-applied version 1.1.3-2ubuntu2 to applied/ubuntu/oneiric-proposed

Author: Steve Langasek
Author Date: 2011-10-09 22:41:41 UTC

Import patches-applied version 1.1.3-2ubuntu2 to applied/ubuntu/oneiric-proposed

Imported using git-ubuntu import.

Changelog parent: a0ac70791f64766886ddfc9a6c32939f69ea2c98
Unapplied parent: 81dbb532a9c8db416cda02167a813aa250a12897

New changelog entries:
  * No-change rebuild to regenerate compressed manpages, which for some
    unknown reason were compressed differently on some architectures than
    on others, breaking multiarch co-installability. LP: #871083.

ubuntu/oneiric 2011-08-19 02:03:47 UTC 2011-08-19
Import patches-unapplied version 1.1.3-2ubuntu1 to ubuntu/oneiric

Author: Kees Cook
Author Date: 2011-08-18 21:41:18 UTC

Import patches-unapplied version 1.1.3-2ubuntu1 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: c3e0f77ae0c5c72d77b1bd4cf2939400d0c33469

New changelog entries:
  * Merge with Debian to get bug fix for unknown kernel rlimits. Remaining
    changes:
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's
      not present there or in /etc/security/pam_env.conf. (should send to
      Debian).
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running.
    - Change Vcs-Bzr to point at the Ubuntu branch.
    - debian/patches-applied/series: Ubuntu patches are as below ...
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits.
    - debian/patches-applied/pam_motd-legal-notice: display the contents of
      /etc/legal once, then set a flag in the user's homedir to prevent
      showing it again.
    - debian/update-motd.5, debian/libpam-modules.manpages: add a manpage
      for update-motd, with some best practices and notes of explanation.
    - debian/patches/update-motd-manpage-ref: add a reference in pam_motd(8)
      to update-motd(5)
    - debian/libpam0g.postinst: drop kdm from the list of services to
      restart.
    - debian/libpam0g.postinst: check if gdm is actually running before
      trying to reload it.
    - debian/local/common-session{,-noninteractive}: Enable pam_umask by
      default, now that the umask setting is gone from /etc/profile.
    - debian/local/pam-auth-update: Add the new md5sums for pam_umask addition.
    - add debian/patches-applied/pam_umask_usergroups_from_login.defs.patch:
      Deprecate pam_unix' explicit "usergroups" option and instead read it
      from /etc/login.def's "USERGROUP_ENAB" option if umask is only defined
      there. This restores compatibility with the pre-PAM behaviour of login.
      (Closes: #583958)
  * Dropped changes:
    - debian/patches-applied/027_pam_limits_better_init_allow_explicit_root:
      no need to bump the hard limit for number of file descriptors any more
      since we read kernel limits directly now.

applied/ubuntu/oneiric 2011-08-19 02:03:47 UTC 2011-08-19
Import patches-applied version 1.1.3-2ubuntu1 to applied/ubuntu/oneiric

Author: Kees Cook
Author Date: 2011-08-18 21:41:18 UTC

Import patches-applied version 1.1.3-2ubuntu1 to applied/ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: cb371525952a5eb3ea3cd44fc435b8d4365f4e3d
Unapplied parent: 598ee99b17dd1fe6f5f32ffebd614fb9fff09e4c

New changelog entries:
  * Merge with Debian to get bug fix for unknown kernel rlimits. Remaining
    changes:
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's
      not present there or in /etc/security/pam_env.conf. (should send to
      Debian).
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running.
    - Change Vcs-Bzr to point at the Ubuntu branch.
    - debian/patches-applied/series: Ubuntu patches are as below ...
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits.
    - debian/patches-applied/pam_motd-legal-notice: display the contents of
      /etc/legal once, then set a flag in the user's homedir to prevent
      showing it again.
    - debian/update-motd.5, debian/libpam-modules.manpages: add a manpage
      for update-motd, with some best practices and notes of explanation.
    - debian/patches/update-motd-manpage-ref: add a reference in pam_motd(8)
      to update-motd(5)
    - debian/libpam0g.postinst: drop kdm from the list of services to
      restart.
    - debian/libpam0g.postinst: check if gdm is actually running before
      trying to reload it.
    - debian/local/common-session{,-noninteractive}: Enable pam_umask by
      default, now that the umask setting is gone from /etc/profile.
    - debian/local/pam-auth-update: Add the new md5sums for pam_umask addition.
    - add debian/patches-applied/pam_umask_usergroups_from_login.defs.patch:
      Deprecate pam_unix' explicit "usergroups" option and instead read it
      from /etc/login.def's "USERGROUP_ENAB" option if umask is only defined
      there. This restores compatibility with the pre-PAM behaviour of login.
      (Closes: #583958)
  * Dropped changes:
    - debian/patches-applied/027_pam_limits_better_init_allow_explicit_root:
      no need to bump the hard limit for number of file descriptors any more
      since we read kernel limits directly now.

ubuntu/maverick-proposed 2011-05-04 00:05:25 UTC 2011-05-04
Import patches-unapplied version 1.1.1-4ubuntu2.1 to ubuntu/maverick-proposed

Author: Dustin Kirkland 
Author Date: 2011-05-03 12:58:52 UTC

Import patches-unapplied version 1.1.1-4ubuntu2.1 to ubuntu/maverick-proposed

Imported using git-ubuntu import.

Changelog parent: fd1ac0932fe2dc15a682a31e544933cb31b14b60

New changelog entries:
  * debian/patches-applied/update-motd: santize the environment before
    calling run-parts, LP: #610125

applied/ubuntu/natty-proposed 2011-05-04 00:05:25 UTC 2011-05-04
Import patches-applied version 1.1.2-2ubuntu8.1 to applied/ubuntu/natty-proposed

Author: Dustin Kirkland 
Author Date: 2011-04-27 18:02:15 UTC

Import patches-applied version 1.1.2-2ubuntu8.1 to applied/ubuntu/natty-proposed

Imported using git-ubuntu import.

Changelog parent: 0d1ab95afaceef39b5229196a76ec6c2d3d5be5d
Unapplied parent: c5a41b2ce5b1593f61ff5e6981750fbaac5234d6

New changelog entries:
  * debian/patches-applied/update-motd: santize the environment before
    calling run-parts, LP: #610125

applied/ubuntu/maverick-proposed 2011-05-04 00:05:25 UTC 2011-05-04
Import patches-applied version 1.1.1-4ubuntu2.1 to applied/ubuntu/maverick-pr...

Author: Dustin Kirkland 
Author Date: 2011-05-03 12:58:52 UTC

Import patches-applied version 1.1.1-4ubuntu2.1 to applied/ubuntu/maverick-proposed

Imported using git-ubuntu import.

Changelog parent: ed3ddb1980ab5932c9aca2b36e3cd5146ad0c186
Unapplied parent: 7ec4b45d7a143f4e5b20c90e3ac98663dc4bb67f

New changelog entries:
  * debian/patches-applied/update-motd: santize the environment before
    calling run-parts, LP: #610125

ubuntu/natty-proposed 2011-05-04 00:05:25 UTC 2011-05-04
Import patches-unapplied version 1.1.2-2ubuntu8.1 to ubuntu/natty-proposed

Author: Dustin Kirkland 
Author Date: 2011-04-27 18:02:15 UTC

Import patches-unapplied version 1.1.2-2ubuntu8.1 to ubuntu/natty-proposed

Imported using git-ubuntu import.

Changelog parent: 7e4eaaf2fb17ec7f8fab51d4826bc45a69c048b3

New changelog entries:
  * debian/patches-applied/update-motd: santize the environment before
    calling run-parts, LP: #610125

ubuntu/natty 2011-04-14 17:04:58 UTC 2011-04-14
Import patches-unapplied version 1.1.2-2ubuntu8 to ubuntu/natty

Author: Stéphane Graber
Author Date: 2011-04-12 01:57:36 UTC

Import patches-unapplied version 1.1.2-2ubuntu8 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 7747935e4ca493e901636543b2b2fb56ec805d43

New changelog entries:
  * Check if gdm is actually running before trying to reload it. (LP: #745532)

applied/ubuntu/natty 2011-04-14 17:04:58 UTC 2011-04-14
Import patches-applied version 1.1.2-2ubuntu8 to applied/ubuntu/natty

Author: Stéphane Graber
Author Date: 2011-04-12 01:57:36 UTC

Import patches-applied version 1.1.2-2ubuntu8 to applied/ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: aef2449277350f4c23fa7d5e334a999ce63a570b
Unapplied parent: 7e4eaaf2fb17ec7f8fab51d4826bc45a69c048b3

New changelog entries:
  * Check if gdm is actually running before trying to reload it. (LP: #745532)

applied/ubuntu/maverick 2010-08-17 06:06:22 UTC 2010-08-17
Import patches-applied version 1.1.1-4ubuntu1 to applied/ubuntu/maverick

Author: Steve Langasek
Author Date: 2010-08-17 02:12:35 UTC

Import patches-applied version 1.1.1-4ubuntu1 to applied/ubuntu/maverick

Imported using git-ubuntu import.

Changelog parent: 70a2434a1b19b4071683123217ecb107262141bb
Unapplied parent: ea1d393fbbfb6d5398acbe9fefe0ac547e7ac0c6

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's
      not present there or in /etc/security/pam_env.conf. (should send to
      Debian).
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running.
    - debian/patches-applied/series: Ubuntu patches are as below ...
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits.
    - Change Vcs-Bzr to point at the Ubuntu branch.
    - Make libpam-modules depend on base-files (>= 5.0.0ubuntu6), to ensure
      run-parts does the right thing in /etc/update-motd.d.
    - debian/patches-applied/pam_motd-legal-notice: display the contents of
      /etc/legal once, then set a flag in the user's homedir to prevent
      showing it again.
    - debian/update-motd.5, debian/libpam-modules.manpages: add a manpage
      for update-motd, with some best practices and notes of explanation.
    - debian/patches/update-motd-manpage-ref: add a reference in pam_motd(8)
      to update-motd(5)

ubuntu/maverick 2010-08-17 06:06:22 UTC 2010-08-17
Import patches-unapplied version 1.1.1-4ubuntu1 to ubuntu/maverick

Author: Steve Langasek
Author Date: 2010-08-17 02:12:35 UTC

Import patches-unapplied version 1.1.1-4ubuntu1 to ubuntu/maverick

Imported using git-ubuntu import.

Changelog parent: f5a85e76c0fc77a41343ddf24f13eb8917bb2a56

New changelog entries:
  * Merge from Debian unstable, remaining changes:
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's
      not present there or in /etc/security/pam_env.conf. (should send to
      Debian).
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running.
    - debian/patches-applied/series: Ubuntu patches are as below ...
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits.
    - Change Vcs-Bzr to point at the Ubuntu branch.
    - Make libpam-modules depend on base-files (>= 5.0.0ubuntu6), to ensure
      run-parts does the right thing in /etc/update-motd.d.
    - debian/patches-applied/pam_motd-legal-notice: display the contents of
      /etc/legal once, then set a flag in the user's homedir to prevent
      showing it again.
    - debian/update-motd.5, debian/libpam-modules.manpages: add a manpage
      for update-motd, with some best practices and notes of explanation.
    - debian/patches/update-motd-manpage-ref: add a reference in pam_motd(8)
      to update-motd(5)

applied/ubuntu/karmic-updates 2010-07-07 22:06:03 UTC 2010-07-07
Import patches-applied version 1.1.0-2ubuntu1.1 to applied/ubuntu/karmic-secu...

Author: Kees Cook
Author Date: 2010-07-07 17:55:09 UTC

Import patches-applied version 1.1.0-2ubuntu1.1 to applied/ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 023978c3d7e80ddd068aa453ccf6356d935255fa
Unapplied parent: 76614b3f9b9c70f5aad4b2ca689900928f1b1eae

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via symlink following.
    - debian/patches-applied/pam_motd-legal-notice: drop privs for work.
    - CVE-2010-0832

ubuntu/karmic-devel 2010-07-07 22:06:03 UTC 2010-07-07
Import patches-unapplied version 1.1.0-2ubuntu1.1 to ubuntu/karmic-security

Author: Kees Cook
Author Date: 2010-07-07 17:55:09 UTC

Import patches-unapplied version 1.1.0-2ubuntu1.1 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: eecc79d7e4e472782801cd04bb0af556d2b1dd1a

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via symlink following.
    - debian/patches-applied/pam_motd-legal-notice: drop privs for work.
    - CVE-2010-0832

ubuntu/karmic-updates 2010-07-07 22:06:03 UTC 2010-07-07
Import patches-unapplied version 1.1.0-2ubuntu1.1 to ubuntu/karmic-security

Author: Kees Cook
Author Date: 2010-07-07 17:55:09 UTC

Import patches-unapplied version 1.1.0-2ubuntu1.1 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: eecc79d7e4e472782801cd04bb0af556d2b1dd1a

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via symlink following.
    - debian/patches-applied/pam_motd-legal-notice: drop privs for work.
    - CVE-2010-0832

ubuntu/karmic-security 2010-07-07 22:06:03 UTC 2010-07-07
Import patches-unapplied version 1.1.0-2ubuntu1.1 to ubuntu/karmic-security

Author: Kees Cook
Author Date: 2010-07-07 17:55:09 UTC

Import patches-unapplied version 1.1.0-2ubuntu1.1 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: eecc79d7e4e472782801cd04bb0af556d2b1dd1a

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via symlink following.
    - debian/patches-applied/pam_motd-legal-notice: drop privs for work.
    - CVE-2010-0832

applied/ubuntu/karmic-security 2010-07-07 22:06:03 UTC 2010-07-07
Import patches-applied version 1.1.0-2ubuntu1.1 to applied/ubuntu/karmic-secu...

Author: Kees Cook
Author Date: 2010-07-07 17:55:09 UTC

Import patches-applied version 1.1.0-2ubuntu1.1 to applied/ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 023978c3d7e80ddd068aa453ccf6356d935255fa
Unapplied parent: 76614b3f9b9c70f5aad4b2ca689900928f1b1eae

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via symlink following.
    - debian/patches-applied/pam_motd-legal-notice: drop privs for work.
    - CVE-2010-0832

applied/ubuntu/karmic-devel 2010-07-07 22:06:03 UTC 2010-07-07
Import patches-applied version 1.1.0-2ubuntu1.1 to applied/ubuntu/karmic-secu...

Author: Kees Cook
Author Date: 2010-07-07 17:55:09 UTC

Import patches-applied version 1.1.0-2ubuntu1.1 to applied/ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 023978c3d7e80ddd068aa453ccf6356d935255fa
Unapplied parent: 76614b3f9b9c70f5aad4b2ca689900928f1b1eae

New changelog entries:
  * SECURITY UPDATE: root privilege escalation via symlink following.
    - debian/patches-applied/pam_motd-legal-notice: drop privs for work.
    - CVE-2010-0832

applied/ubuntu/lucid 2010-04-13 22:05:00 UTC 2010-04-13
Import patches-applied version 1.1.1-2ubuntu2 to applied/ubuntu/lucid

Author: Dustin Kirkland 
Author Date: 2010-04-13 21:58:12 UTC

Import patches-applied version 1.1.1-2ubuntu2 to applied/ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 139d46346103bdc21821da2b64518827ed82a45a
Unapplied parent: a06ee1911f4425739b9598f2ae132c290eaba1ae

New changelog entries:
  * debian/update-motd.5, debian/libpam-modules.manpages: add a manpage
    for update-motd, with some best practices and notes of explanation,
    LP: #562566
  * debian/patches/update-motd-manpage-ref: add a reference in pam_mod(8)
    to update-motd(5), LP: #552175

ubuntu/lucid 2010-04-13 22:05:00 UTC 2010-04-13
Import patches-unapplied version 1.1.1-2ubuntu2 to ubuntu/lucid

Author: Dustin Kirkland 
Author Date: 2010-04-13 21:58:12 UTC

Import patches-unapplied version 1.1.1-2ubuntu2 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 9dfe43c2c93cb29fe6f4dfc9bf2e7147598c6525

New changelog entries:
  * debian/update-motd.5, debian/libpam-modules.manpages: add a manpage
    for update-motd, with some best practices and notes of explanation,
    LP: #562566
  * debian/patches/update-motd-manpage-ref: add a reference in pam_mod(8)
    to update-motd(5), LP: #552175

applied/ubuntu/intrepid-updates 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-applied version 1.0.1-4ubuntu5.6 to applied/ubuntu/intrepid-se...

Author: Steve Langasek
Author Date: 2009-08-07 08:24:13 UTC

Import patches-applied version 1.0.1-4ubuntu5.6 to applied/ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 02f53914fe909640377d6b47e8661bc3cf7c2f6f
Unapplied parent: 201a10bece7c4b26c9c393769f6e73c5ceb2bdb1

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

ubuntu/intrepid-devel 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-unapplied version 1.0.1-4ubuntu5.6 to ubuntu/intrepid-security

Author: Steve Langasek
Author Date: 2009-08-07 08:24:13 UTC

Import patches-unapplied version 1.0.1-4ubuntu5.6 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 6691db90e11e6bf3eef7eb9957836117b995327a

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

ubuntu/intrepid-security 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-unapplied version 1.0.1-4ubuntu5.6 to ubuntu/intrepid-security

Author: Steve Langasek
Author Date: 2009-08-07 08:24:13 UTC

Import patches-unapplied version 1.0.1-4ubuntu5.6 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 6691db90e11e6bf3eef7eb9957836117b995327a

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

ubuntu/intrepid-updates 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-unapplied version 1.0.1-4ubuntu5.6 to ubuntu/intrepid-security

Author: Steve Langasek
Author Date: 2009-08-07 08:24:13 UTC

Import patches-unapplied version 1.0.1-4ubuntu5.6 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 6691db90e11e6bf3eef7eb9957836117b995327a

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

ubuntu/jaunty-devel 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-unapplied version 1.0.1-9ubuntu1.1 to ubuntu/jaunty-security

Author: Steve Langasek
Author Date: 2009-08-07 08:32:50 UTC

Import patches-unapplied version 1.0.1-9ubuntu1.1 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: 3eec304276b5baa9eafed1dafff8068754bd3902

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

ubuntu/jaunty-security 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-unapplied version 1.0.1-9ubuntu1.1 to ubuntu/jaunty-security

Author: Steve Langasek
Author Date: 2009-08-07 08:32:50 UTC

Import patches-unapplied version 1.0.1-9ubuntu1.1 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: 3eec304276b5baa9eafed1dafff8068754bd3902

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

ubuntu/jaunty-updates 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-unapplied version 1.0.1-9ubuntu1.1 to ubuntu/jaunty-security

Author: Steve Langasek
Author Date: 2009-08-07 08:32:50 UTC

Import patches-unapplied version 1.0.1-9ubuntu1.1 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: 3eec304276b5baa9eafed1dafff8068754bd3902

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

applied/ubuntu/jaunty-updates 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-applied version 1.0.1-9ubuntu1.1 to applied/ubuntu/jaunty-secu...

Author: Steve Langasek
Author Date: 2009-08-07 08:32:50 UTC

Import patches-applied version 1.0.1-9ubuntu1.1 to applied/ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: da2ed8268c488f6b5968a3dcc93ce4efe7480e8a
Unapplied parent: f4e6d63dc37d18d2ba006505e86ff8f6571c5b7b

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

applied/ubuntu/jaunty-security 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-applied version 1.0.1-9ubuntu1.1 to applied/ubuntu/jaunty-secu...

Author: Steve Langasek
Author Date: 2009-08-07 08:32:50 UTC

Import patches-applied version 1.0.1-9ubuntu1.1 to applied/ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: da2ed8268c488f6b5968a3dcc93ce4efe7480e8a
Unapplied parent: f4e6d63dc37d18d2ba006505e86ff8f6571c5b7b

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

applied/ubuntu/jaunty-devel 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-applied version 1.0.1-9ubuntu1.1 to applied/ubuntu/jaunty-secu...

Author: Steve Langasek
Author Date: 2009-08-07 08:32:50 UTC

Import patches-applied version 1.0.1-9ubuntu1.1 to applied/ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: da2ed8268c488f6b5968a3dcc93ce4efe7480e8a
Unapplied parent: f4e6d63dc37d18d2ba006505e86ff8f6571c5b7b

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

applied/ubuntu/intrepid-security 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-applied version 1.0.1-4ubuntu5.6 to applied/ubuntu/intrepid-se...

Author: Steve Langasek
Author Date: 2009-08-07 08:24:13 UTC

Import patches-applied version 1.0.1-4ubuntu5.6 to applied/ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 02f53914fe909640377d6b47e8661bc3cf7c2f6f
Unapplied parent: 201a10bece7c4b26c9c393769f6e73c5ceb2bdb1

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

applied/ubuntu/intrepid-devel 2009-09-08 22:04:50 UTC 2009-09-08
Import patches-applied version 1.0.1-4ubuntu5.6 to applied/ubuntu/intrepid-se...

Author: Steve Langasek
Author Date: 2009-08-07 08:24:13 UTC

Import patches-applied version 1.0.1-4ubuntu5.6 to applied/ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 02f53914fe909640377d6b47e8661bc3cf7c2f6f
Unapplied parent: 201a10bece7c4b26c9c393769f6e73c5ceb2bdb1

New changelog entries:
  * When no profiles are chosen in pam-auth-update, throw an error message
    and prompt again instead of letting the user end up with an insecure
    system. This introduces a new debconf template. LP: #410171.

ubuntu/karmic 2009-09-04 09:04:46 UTC 2009-09-04
Import patches-unapplied version 1.1.0-2ubuntu1 to ubuntu/karmic

Author: Steve Langasek
Author Date: 2009-09-04 08:11:48 UTC

Import patches-unapplied version 1.1.0-2ubuntu1 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 66c9534831f73d9a738049950b4829857c690426

New changelog entries:
  * Merge from Debian, remaining changes:
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's not
      present there or in /etc/security/pam_env.conf. (should send to Debian).
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running.
    - debian/patches-applied/series: Ubuntu patches are as below ...
    - debian/patches-applied/ubuntu-no-error-if-missingok: add a new, magic
      module option 'missingok' which will suppress logging of errors by
      libpam if the module is not found.
    - debian/patches-applied/ubuntu-regression_fix_securetty: prompt for
      password on bad username.
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits.
    - Change Vcs-Bzr to point at the Ubuntu branch.
    - Make libpam-modules depend on base-files (>= 5.0.0ubuntu6), to ensure
      run-parts does the right thing in /etc/update-motd.d.
    - debian/patches-applied/pam_motd-legal-notice: display the contents of
      /etc/legal once, then set a flag in the user's homedir to prevent showing
      it again.
    - debian/local/common-{auth,account,password}.md5sums: include the
      Ubuntu-specific intrepid,jaunty md5sums for use during the
      common-session-noninteractive upgrade.
  * Changes merged in Debian:
    - debian/local/common-password, debian/pam-configs/unix: switch from
      "md5" to "sha512" as password crypt default.
  [ Steve Langasek ]
  * debian/patches/pam_unix_dont_trust_chkpwd_caller.patch: fix this patch
    to call setregid() instead of always returning an error on username
    mismatch in unix_chkpwd, needed in the SELinux case and in some corner
    cases with the broken_shadow option. Thanks to Michael Spang for the
    analysis. Closes: #543589.
  * fix the PAM mini-policy to not tell app maintainers that they don't need
    to depend on libpam-modules if they reference modules from there.
  * make libpam-runtime depend on libpam-modules (>= 1.0.1-6) - nothing else
    guarantees that we have pam_unix available for use by pam-auth-update.
  * Use /bin/sh instead of /bin/bash for libpam0g.postinst, since we've
    confirmed there are no longer any bashisms there. Closes: #519973.
  * Clean up the libpam0g postinst a bit; invoke-rc.d has been a guaranteed
    interface for two stable release cycles now
  * debian/patches/namespace_with_awk_not_gawk: fix the sample
    namespace.init script's dependency on non-POSIX features of gawk, since
    we don't use gawk by default. Closes; #518908.
  * Updated debconf translations:
    - German, thanks to Sven Joachim <svenjoac@gmx.de> (closes: #544464)
  [ Kees Cook ]
  * debian/local/common-password, debian/pam-configs/unix: switch from "md5"
    to "sha512" as password crypt default.

applied/ubuntu/karmic 2009-09-04 09:04:46 UTC 2009-09-04
Import patches-applied version 1.1.0-2ubuntu1 to applied/ubuntu/karmic

Author: Steve Langasek
Author Date: 2009-09-04 08:11:48 UTC

Import patches-applied version 1.1.0-2ubuntu1 to applied/ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 24fe0e94cf6bf4a27f435962687b0fe39c867567
Unapplied parent: eecc79d7e4e472782801cd04bb0af556d2b1dd1a

New changelog entries:
  * Merge from Debian, remaining changes:
    - debian/libpam-modules.postinst: Add PATH to /etc/environment if it's not
      present there or in /etc/security/pam_env.conf. (should send to Debian).
    - debian/libpam0g.postinst: only ask questions during update-manager when
      there are non-default services running.
    - debian/patches-applied/series: Ubuntu patches are as below ...
    - debian/patches-applied/ubuntu-no-error-if-missingok: add a new, magic
      module option 'missingok' which will suppress logging of errors by
      libpam if the module is not found.
    - debian/patches-applied/ubuntu-regression_fix_securetty: prompt for
      password on bad username.
    - debian/patches-applied/ubuntu-rlimit_nice_correction: Explicitly
      initialise RLIMIT_NICE rather than relying on the kernel limits.
    - Change Vcs-Bzr to point at the Ubuntu branch.
    - Make libpam-modules depend on base-files (>= 5.0.0ubuntu6), to ensure
      run-parts does the right thing in /etc/update-motd.d.
    - debian/patches-applied/pam_motd-legal-notice: display the contents of
      /etc/legal once, then set a flag in the user's homedir to prevent showing
      it again.
    - debian/local/common-{auth,account,password}.md5sums: include the
      Ubuntu-specific intrepid,jaunty md5sums for use during the
      common-session-noninteractive upgrade.
  * Changes merged in Debian:
    - debian/local/common-password, debian/pam-configs/unix: switch from
      "md5" to "sha512" as password crypt default.
  [ Steve Langasek ]
  * debian/patches/pam_unix_dont_trust_chkpwd_caller.patch: fix this patch
    to call setregid() instead of always returning an error on username
    mismatch in unix_chkpwd, needed in the SELinux case and in some corner
    cases with the broken_shadow option. Thanks to Michael Spang for the
    analysis. Closes: #543589.
  * fix the PAM mini-policy to not tell app maintainers that they don't need
    to depend on libpam-modules if they reference modules from there.
  * make libpam-runtime depend on libpam-modules (>= 1.0.1-6) - nothing else
    guarantees that we have pam_unix available for use by pam-auth-update.
  * Use /bin/sh instead of /bin/bash for libpam0g.postinst, since we've
    confirmed there are no longer any bashisms there. Closes: #519973.
  * Clean up the libpam0g postinst a bit; invoke-rc.d has been a guaranteed
    interface for two stable release cycles now
  * debian/patches/namespace_with_awk_not_gawk: fix the sample
    namespace.init script's dependency on non-POSIX features of gawk, since
    we don't use gawk by default. Closes; #518908.
  * Updated debconf translations:
    - German, thanks to Sven Joachim <svenjoac@gmx.de> (closes: #544464)
  [ Kees Cook ]
  * debian/local/common-password, debian/pam-configs/unix: switch from "md5"
    to "sha512" as password crypt default.

applied/debian/lenny 2009-04-21 13:10:47 UTC 2009-04-21
Import patches-applied version 1.0.1-5+lenny1 to applied/debian/lenny

Author: Jan Christoph Nordholz
Author Date: 2009-03-17 17:51:07 UTC

Import patches-applied version 1.0.1-5+lenny1 to applied/debian/lenny

Imported using git-ubuntu import.

Changelog parent: 1aa2bbca58a77994c0c442768dbe4ca5e2364d87
Unapplied parent: b503b99c353f9599d7d2266cf9072be67a418364

New changelog entries:
  * Security NMU, high urgency.
  * Fix signedness error in _pam_StrTok(), CVE-2009-0887.
    Closes: #520115.

debian/lenny 2009-04-21 13:10:47 UTC 2009-04-21
Import patches-unapplied version 1.0.1-5+lenny1 to debian/lenny

Author: Jan Christoph Nordholz
Author Date: 2009-03-17 17:51:07 UTC

Import patches-unapplied version 1.0.1-5+lenny1 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: 4d8319f4a06b9608574319a2b758d07259f9cbf4

New changelog entries:
  * Security NMU, high urgency.
  * Fix signedness error in _pam_StrTok(), CVE-2009-0887.
    Closes: #520115.

101200 of 238 results

Other repositories

Name Last Modified
lp:ubuntu/+source/pam 2020-02-11
lp:~ubuntu-core-dev/ubuntu/+source/pam/+git/pam 2019-02-14
lp:~tjaalton/ubuntu/+source/pam 2018-04-06
lp:~vorlon/ubuntu/+source/pam 2018-03-17
14 of 4 results
You can't create new repositories for pam in Ubuntu.