View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/maas
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
ubuntu/utopic 2014-10-22 17:08:32 UTC 2014-10-22
Import patches-unapplied version 1.7.0~beta8+bzr3272-0ubuntu1 to ubuntu/utopi...

Author: Andres Rodriguez
Author Date: 2014-10-22 16:55:08 UTC

Import patches-unapplied version 1.7.0~beta8+bzr3272-0ubuntu1 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 5b4a66aec59f7ac17e2a3784c17a04be9da9a3bc

New changelog entries:
  * New Upstream Release, Beta 8 bzr 3272.
    - Maintain backward compatibility with status codes to not break
      client MAAS API users. (LP: #1383609)
    - Allow users to disable DHCP NIC scanning during commissioning otherwise
      this can lead machines not being able to commission (LP: #1383384)
    - Ensure that MAAS can correctly download, and install HWE Kernels, and
      not crash in the process. (LP: #1357532, LP: #1382281)
    - Add a lock to ensure we don't give the same 2 systems to two different
      users when acquiring a machine. (LP: #1382575)
  [ Michael McCracken ]
  * debian/maas-dns.postrm: ensure named.conf is cleaned of maas
    includes (LP: #1346538)

applied/ubuntu/trusty 2014-04-15 18:08:36 UTC 2014-04-15
Import patches-applied version 1.5+bzr2252-0ubuntu1 to applied/ubuntu/trusty-...

Author: Andres Rodriguez
Author Date: 2014-04-09 23:02:00 UTC

Import patches-applied version 1.5+bzr2252-0ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 6940bf93d61120316d2488f347c804d62ec4ef54
Unapplied parent: 2cdb015b024d3f784d225d6a688021606a8b1370

New changelog entries:
  * New upstream release
    - Add support to install Third Party Drivers. In order for this to be
      used the user will have to go to the Settings page to enable the
      installation of these drivers. (LP: #1305839)
    - Use release images instead of daily. (LP: #1306701)
    - Quote interface name in dhcpd.template, otherwise DHCP server fails
      to start. (LP: #1306335)
    - Fix IntegrityError, when multiple processes are trying to register
      the same component. (LP: #1307415)
    - Add missing armhf commissioning template (LP: #1307780)
  * debian/maas-region-controller-min.install: Install drivers.yaml.
  * debian/maas-region-controller.postinst: No longer show the
    installation note by default. (LP: #1284652)

ubuntu/trusty 2014-04-15 18:08:36 UTC 2014-04-15
Import patches-unapplied version 1.5+bzr2252-0ubuntu1 to ubuntu/trusty-proposed

Author: Andres Rodriguez
Author Date: 2014-04-09 23:02:00 UTC

Import patches-unapplied version 1.5+bzr2252-0ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 5320cc15f7aa65f0bbd6a57280725f47774b6daa

New changelog entries:
  * New upstream release
    - Add support to install Third Party Drivers. In order for this to be
      used the user will have to go to the Settings page to enable the
      installation of these drivers. (LP: #1305839)
    - Use release images instead of daily. (LP: #1306701)
    - Quote interface name in dhcpd.template, otherwise DHCP server fails
      to start. (LP: #1306335)
    - Fix IntegrityError, when multiple processes are trying to register
      the same component. (LP: #1307415)
    - Add missing armhf commissioning template (LP: #1307780)
  * debian/maas-region-controller-min.install: Install drivers.yaml.
  * debian/maas-region-controller.postinst: No longer show the
    installation note by default. (LP: #1284652)

ubuntu/saucy-devel 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2.3 to ubuntu/saucy-...

Author: Seth Arnold
Author Date: 2014-02-11 20:16:40 UTC

Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2.3 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: b06e19ca57045ff156e58c4cb01988938d7307a8

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller-min.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

ubuntu/quantal-devel 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1.2 to ubuntu/quanta...

Author: Seth Arnold
Author Date: 2014-02-11 20:07:50 UTC

Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1.2 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: a2cb2696871db96f98186ef55a3af88ed0553ddd

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

ubuntu/saucy-security 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2.3 to ubuntu/saucy-...

Author: Seth Arnold
Author Date: 2014-02-11 20:16:40 UTC

Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2.3 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: b06e19ca57045ff156e58c4cb01988938d7307a8

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller-min.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

ubuntu/saucy-updates 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2.3 to ubuntu/saucy-...

Author: Seth Arnold
Author Date: 2014-02-11 20:16:40 UTC

Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2.3 to ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: b06e19ca57045ff156e58c4cb01988938d7307a8

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller-min.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

applied/ubuntu/quantal-security 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1.2 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2014-02-11 20:07:50 UTC

Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1.2 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: ad0dc626bba7cbe97bc10dd85aad0d5524805df6
Unapplied parent: e88fcb488b2430a42078674df3254788478a82c3

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

applied/ubuntu/saucy-updates 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2.3 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2014-02-11 20:16:40 UTC

Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2.3 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 8ce610f8e5b51d6dace80d9395652e04f0d143ba
Unapplied parent: ce4b3cbd801f7f2e866da110726a57a34055baeb

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller-min.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

applied/ubuntu/quantal-devel 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1.2 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2014-02-11 20:07:50 UTC

Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1.2 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: ad0dc626bba7cbe97bc10dd85aad0d5524805df6
Unapplied parent: e88fcb488b2430a42078674df3254788478a82c3

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

applied/ubuntu/saucy-devel 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2.3 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2014-02-11 20:16:40 UTC

Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2.3 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 8ce610f8e5b51d6dace80d9395652e04f0d143ba
Unapplied parent: ce4b3cbd801f7f2e866da110726a57a34055baeb

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller-min.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

applied/ubuntu/saucy-security 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2.3 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2014-02-11 20:16:40 UTC

Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2.3 to applied/ubuntu/saucy-security

Imported using git-ubuntu import.

Changelog parent: 8ce610f8e5b51d6dace80d9395652e04f0d143ba
Unapplied parent: ce4b3cbd801f7f2e866da110726a57a34055baeb

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller-min.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

applied/ubuntu/quantal-updates 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1.2 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2014-02-11 20:07:50 UTC

Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1.2 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: ad0dc626bba7cbe97bc10dd85aad0d5524805df6
Unapplied parent: e88fcb488b2430a42078674df3254788478a82c3

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

ubuntu/quantal-updates 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1.2 to ubuntu/quanta...

Author: Seth Arnold
Author Date: 2014-02-11 20:07:50 UTC

Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1.2 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: a2cb2696871db96f98186ef55a3af88ed0553ddd

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

ubuntu/quantal-security 2014-02-13 19:18:36 UTC 2014-02-13
Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1.2 to ubuntu/quanta...

Author: Seth Arnold
Author Date: 2014-02-11 20:07:50 UTC

Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1.2 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: a2cb2696871db96f98186ef55a3af88ed0553ddd

New changelog entries:
  * SECURITY UPDATE: incorrect Content-type header allowed cross-site
    scripting vulnerability if an unknown API was used. (LP: #1251336)
    - debian/patches/CVE-2013-1070.patch: Use Content-type text/plain to force
      browsers to not render error messages as HTML.
    - CVE-2013-1070
  * SECURITY UPDATE: /etc/maas/txlongpoll.yaml contained a publicly readable
    password. (LP: #1254034)
    - debian/maas-region-controller.postinst: chown and chmod
      /etc/maas/txlongpoll.yaml with correct permissions
    - CVE-2013-1069

ubuntu/raring-devel 2013-11-07 02:23:16 UTC 2013-11-07
Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2.3 to ubuntu/raring...

Author: Seth Arnold
Author Date: 2013-11-02 00:19:42 UTC

Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2.3 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 86d157580bb195f61698a0819c88cd8467e41fe6

New changelog entries:
  * SECURITY UPDATE: failure to authenticate downloaded content (LP: #1039513)
    - debian/patches/CVE-2013-1058.patch: Authenticate downloaded files with
      GnuPG and MD5SUM files. Thanks to Julian Edwards.
    - CVE-2013-1058
  * SECURITY UPDATE: configuration options may be loaded from current working
    directory (LP: #1158425)
    - debian/patches/CVE-2013-1057-1-3.patch: Do not load configuration
      options from the current working directory. Thanks to Julian Edwards.
    - CVE-2013-1057

ubuntu/raring-security 2013-11-07 02:23:16 UTC 2013-11-07
Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2.3 to ubuntu/raring...

Author: Seth Arnold
Author Date: 2013-11-02 00:19:42 UTC

Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2.3 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 86d157580bb195f61698a0819c88cd8467e41fe6

New changelog entries:
  * SECURITY UPDATE: failure to authenticate downloaded content (LP: #1039513)
    - debian/patches/CVE-2013-1058.patch: Authenticate downloaded files with
      GnuPG and MD5SUM files. Thanks to Julian Edwards.
    - CVE-2013-1058
  * SECURITY UPDATE: configuration options may be loaded from current working
    directory (LP: #1158425)
    - debian/patches/CVE-2013-1057-1-3.patch: Do not load configuration
      options from the current working directory. Thanks to Julian Edwards.
    - CVE-2013-1057

ubuntu/raring-updates 2013-11-07 02:23:16 UTC 2013-11-07
Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2.3 to ubuntu/raring...

Author: Seth Arnold
Author Date: 2013-11-02 00:19:42 UTC

Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2.3 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 86d157580bb195f61698a0819c88cd8467e41fe6

New changelog entries:
  * SECURITY UPDATE: failure to authenticate downloaded content (LP: #1039513)
    - debian/patches/CVE-2013-1058.patch: Authenticate downloaded files with
      GnuPG and MD5SUM files. Thanks to Julian Edwards.
    - CVE-2013-1058
  * SECURITY UPDATE: configuration options may be loaded from current working
    directory (LP: #1158425)
    - debian/patches/CVE-2013-1057-1-3.patch: Do not load configuration
      options from the current working directory. Thanks to Julian Edwards.
    - CVE-2013-1057

applied/ubuntu/raring-devel 2013-11-07 02:23:16 UTC 2013-11-07
Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2.3 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2013-11-02 00:19:42 UTC

Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2.3 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 4ad9297e41d76e29579b59636ff68914fec67dcd
Unapplied parent: 59143af7840f2fefee5fc45221ae93a97bf623eb

New changelog entries:
  * SECURITY UPDATE: failure to authenticate downloaded content (LP: #1039513)
    - debian/patches/CVE-2013-1058.patch: Authenticate downloaded files with
      GnuPG and MD5SUM files. Thanks to Julian Edwards.
    - CVE-2013-1058
  * SECURITY UPDATE: configuration options may be loaded from current working
    directory (LP: #1158425)
    - debian/patches/CVE-2013-1057-1-3.patch: Do not load configuration
      options from the current working directory. Thanks to Julian Edwards.
    - CVE-2013-1057

applied/ubuntu/raring-security 2013-11-07 02:23:16 UTC 2013-11-07
Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2.3 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2013-11-02 00:19:42 UTC

Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2.3 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 4ad9297e41d76e29579b59636ff68914fec67dcd
Unapplied parent: 59143af7840f2fefee5fc45221ae93a97bf623eb

New changelog entries:
  * SECURITY UPDATE: failure to authenticate downloaded content (LP: #1039513)
    - debian/patches/CVE-2013-1058.patch: Authenticate downloaded files with
      GnuPG and MD5SUM files. Thanks to Julian Edwards.
    - CVE-2013-1058
  * SECURITY UPDATE: configuration options may be loaded from current working
    directory (LP: #1158425)
    - debian/patches/CVE-2013-1057-1-3.patch: Do not load configuration
      options from the current working directory. Thanks to Julian Edwards.
    - CVE-2013-1057

applied/ubuntu/raring-updates 2013-11-07 02:23:16 UTC 2013-11-07
Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2.3 to applied/ubuntu/...

Author: Seth Arnold
Author Date: 2013-11-02 00:19:42 UTC

Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2.3 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 4ad9297e41d76e29579b59636ff68914fec67dcd
Unapplied parent: 59143af7840f2fefee5fc45221ae93a97bf623eb

New changelog entries:
  * SECURITY UPDATE: failure to authenticate downloaded content (LP: #1039513)
    - debian/patches/CVE-2013-1058.patch: Authenticate downloaded files with
      GnuPG and MD5SUM files. Thanks to Julian Edwards.
    - CVE-2013-1058
  * SECURITY UPDATE: configuration options may be loaded from current working
    directory (LP: #1158425)
    - debian/patches/CVE-2013-1057-1-3.patch: Do not load configuration
      options from the current working directory. Thanks to Julian Edwards.
    - CVE-2013-1057

applied/ubuntu/saucy-proposed 2013-10-24 21:28:24 UTC 2013-10-24
Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2.2 to applied/ubuntu/...

Author: Andres Rodriguez
Author Date: 2013-10-24 20:35:00 UTC

Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2.2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 2d3f073308a84c319884d863e044a1bba8661f18
Unapplied parent: 309b2248acc81309504bc959614fd3dd719b53a9

New changelog entries:
  * debian/patches:
    - 99_fix_dhcp_template_lp1240972.patch: Do not prevent the MAAS DHCP
      template from adding ignore-client-uids on precise, which causes
      issues with DNS for MAAS in the Cloud Archive. (LP: #1240972)
    - 99_arm_generic_kernel_lp1166994.patch: Re-enable armhf generic as it
      is supported starting from raring. (LP: #1166994)
  * debian/patches/99_fix_juju_multienv_lp1239488: Allows juju to distinguish
    between different environments, actually fixing the MAAS side of multiple
    juju environment support. (LP: #1239488)

ubuntu/saucy-proposed 2013-10-24 21:28:24 UTC 2013-10-24
Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2.2 to ubuntu/saucy-...

Author: Andres Rodriguez
Author Date: 2013-10-24 20:35:00 UTC

Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2.2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 72157e8dbe6a50a7f624ed00b5ad769f1197d45c

New changelog entries:
  * debian/patches:
    - 99_fix_dhcp_template_lp1240972.patch: Do not prevent the MAAS DHCP
      template from adding ignore-client-uids on precise, which causes
      issues with DNS for MAAS in the Cloud Archive. (LP: #1240972)
    - 99_arm_generic_kernel_lp1166994.patch: Re-enable armhf generic as it
      is supported starting from raring. (LP: #1166994)
  * debian/patches/99_fix_juju_multienv_lp1239488: Allows juju to distinguish
    between different environments, actually fixing the MAAS side of multiple
    juju environment support. (LP: #1239488)

ubuntu/saucy 2013-10-16 08:58:19 UTC 2013-10-16
Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2 to ubuntu/saucy-pr...

Author: Andres Rodriguez
Author Date: 2013-10-14 17:10:21 UTC

Import patches-unapplied version 1.4+bzr1693+dfsg-0ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 27c2c37312ade7b232ad9f766615b5d75dd4df17

New changelog entries:
  * debian/patches:
    - 99_fix_wsgi_app_group_lp1237463.patch: Import wsgi into the %{GLOBAL}
      application group, to avoid bson encoding issues. (LP: #1237463)
    - 99_ephemeral_backward_compat_lp1238376.patch: Maintain import_ephemerals
      config compatibility to allow maas-import-ephemerals to inherit the
      config used for maas-import-pxe-files, otherwise it will always download
      all releases even when set to a particular one. (LP: #1238376)
    - 99_split_config_arch_rel_lp1238681.patch: arches/releases are a list
      of characters that need to be split. (LP: #1238681)
    - 99_handle_ephemeral_archs_correctly.patch: Allow maas-import-ephemerals
      to use arches correctly coming from the legacy config (LP: #1240215)

applied/ubuntu/saucy 2013-10-16 08:58:19 UTC 2013-10-16
Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2 to applied/ubuntu/sa...

Author: Andres Rodriguez
Author Date: 2013-10-14 17:10:21 UTC

Import patches-applied version 1.4+bzr1693+dfsg-0ubuntu2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: ad09214abe8244133500466a56f201a5a77d37f9
Unapplied parent: 202348f10f6181f928e7bcbc159ba7fdb0833419

New changelog entries:
  * debian/patches:
    - 99_fix_wsgi_app_group_lp1237463.patch: Import wsgi into the %{GLOBAL}
      application group, to avoid bson encoding issues. (LP: #1237463)
    - 99_ephemeral_backward_compat_lp1238376.patch: Maintain import_ephemerals
      config compatibility to allow maas-import-ephemerals to inherit the
      config used for maas-import-pxe-files, otherwise it will always download
      all releases even when set to a particular one. (LP: #1238376)
    - 99_split_config_arch_rel_lp1238681.patch: arches/releases are a list
      of characters that need to be split. (LP: #1238681)
    - 99_handle_ephemeral_archs_correctly.patch: Allow maas-import-ephemerals
      to use arches correctly coming from the legacy config (LP: #1240215)

applied/ubuntu/precise-proposed 2013-09-19 20:33:24 UTC 2013-09-19
Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1~12.04.3 to applied/u...

Author: Andres Rodriguez
Author Date: 2013-09-06 02:53:10 UTC

Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1~12.04.3 to applied/ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 1a0b98cd84f0d1247fea7ab93181908ed4a981d8
Unapplied parent: 168bedb2945719eb5b92b539775060b0773a882e

New changelog entries:
  * MAAS Stable Release Update:
    - debian/patches/04-dhcp-lease-conflict.patch: Sets expiry lease time
      to 30 seconds (LP: #1069570)

ubuntu/precise-proposed 2013-09-19 20:33:24 UTC 2013-09-19
Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1~12.04.3 to ubuntu/...

Author: Andres Rodriguez
Author Date: 2013-09-06 02:53:10 UTC

Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1~12.04.3 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 7821c73107f827af75064a94b37a541f5a9ae98a

New changelog entries:
  * MAAS Stable Release Update:
    - debian/patches/04-dhcp-lease-conflict.patch: Sets expiry lease time
      to 30 seconds (LP: #1069570)

applied/ubuntu/raring-proposed 2013-08-22 18:48:13 UTC 2013-08-22
Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2.2 to applied/ubuntu/...

Author: Andres Rodriguez
Author Date: 2013-08-21 14:57:37 UTC

Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2.2 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 38506a929fc65d895e271645de15e6adc2a7eba4
Unapplied parent: 5d0b5fb1dde1180ca55fdbf9940098cea463cd84

New changelog entries:
  * debian/patches:
    - 99_filestorage_empty_files_lp1204507.patch: Fix to allow the storage
      of empty files when using Juju Go, otherwise machines will fail to
      bootstrap. (LP: #1204507)
    - 99_default_timezone_utc_lp1211447.patch: Default to UTC for the
      deployed nodes. (LP: #1211447)

ubuntu/raring-proposed 2013-08-22 18:48:13 UTC 2013-08-22
Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2.2 to ubuntu/raring...

Author: Andres Rodriguez
Author Date: 2013-08-21 14:57:37 UTC

Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2.2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: d6b131a01a8dcc491f6a094ba5b222b8539084e3

New changelog entries:
  * debian/patches:
    - 99_filestorage_empty_files_lp1204507.patch: Fix to allow the storage
      of empty files when using Juju Go, otherwise machines will fail to
      bootstrap. (LP: #1204507)
    - 99_default_timezone_utc_lp1211447.patch: Default to UTC for the
      deployed nodes. (LP: #1211447)

applied/ubuntu/raring 2013-04-19 18:03:18 UTC 2013-04-19
Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2 to applied/ubuntu/ra...

Author: Andres Rodriguez
Author Date: 2013-04-19 16:41:18 UTC

Import patches-applied version 1.3+bzr1461+dfsg-0ubuntu2 to applied/ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: f7af6c78c3968be0d83ce23fd3c5cf37adabf290
Unapplied parent: 9134c713e231b345af7920a4801e19fcd905db05

New changelog entries:
  * debian/patches/99-fix-maas-fpi.patch: Update to correctly reflect
    correct install path.

ubuntu/raring 2013-04-19 18:03:18 UTC 2013-04-19
Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2 to ubuntu/raring-p...

Author: Andres Rodriguez
Author Date: 2013-04-19 16:41:18 UTC

Import patches-unapplied version 1.3+bzr1461+dfsg-0ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: c7f953b409e832215eece064bcdf2d8ad025bcb8

New changelog entries:
  * debian/patches/99-fix-maas-fpi.patch: Update to correctly reflect
    correct install path.

ubuntu/quantal-proposed 2013-04-09 18:33:15 UTC 2013-04-09
Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1 to ubuntu/quantal-...

Author: Andres Rodriguez
Author Date: 2013-03-07 19:22:35 UTC

Import patches-unapplied version 1.2+bzr1373+dfsg-0ubuntu1 to ubuntu/quantal-proposed

Imported using git-ubuntu import.

Changelog parent: 6cf4cdea02de25a38f31eaf44c07ef584bf60647

New changelog entries:
  * MAAS Stable Release Update (LP: #1109283):
    This SRU brings a new upstream release of MAAS that removes
    the usage of a cobbler code copy, 'maas-provision' as well as
    several bug fixes. Exception has been granted by the Technical
    Board to proceed. More information can be found in:
    https://lists.ubuntu.com/archives/ubuntu-devel-announce/2013-February/001012.html
  [ Andres Rodriguez ]
  * debian/control:
    - Change Conflicts/Replaces for Breaks/Replaces.
    - Conflicts on tftpd-hpa and dnsmasq.
    - Do not pre-depends, but Depends on ${misc:Depends} for 'maas'.
  [ Steve Langasek ]
  * postinst scripts are never called with 'reconfigure' as the script
    argument. Remove references to this (mythical) invocation.
  * always call 'set -e' from maintainer scripts instead of passing 'sh -e'
    as the interpreter, so that scripts will behave correctly when run via
    'sh -x'.
  * invoke-rc.d is never allowed to not exist - simplify scripts (and make
    them better policy-compliant) by invoking unconditionally. (The only
    possible exception is in the postrm, where it's *theoretically* possible
    for invoke-rc.d to be missing if the user has completely stripped
    down their system; that's a fairly unreasonable corner case, but we
    might as well be correct if it ever happens.)
  * db_get+db_set is a no-op; don't call db_set to push back a value we just
    got from db_get.
  * Omit superfluous calls to 'exit 0' at the end of each script.
  * Remove maas-cluster-controller prerm script, which called debconf for no
    reason.
  * Don't invoke debconf in the postrm script either, debhelper already does
    this for us.
  * Other miscellaneous maintainer script fixes
  * debian/maas-common.postinst: call adduser and addgroup unconditionally;
    the tools are already designed to DTRT, we don't need to check for the
    user/group existence before calling them nor should we worry about
    calling them only once on first install.
  * debian/maas-common.postrm: delete the maas group, not just the user,
    as the comment in the code implies we should do.

applied/ubuntu/quantal-proposed 2013-04-09 18:33:15 UTC 2013-04-09
Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1 to applied/ubuntu/qu...

Author: Andres Rodriguez
Author Date: 2013-03-07 19:22:35 UTC

Import patches-applied version 1.2+bzr1373+dfsg-0ubuntu1 to applied/ubuntu/quantal-proposed

Imported using git-ubuntu import.

Changelog parent: 799dd534e0266fa359de52d5d49585eb5a1c44d5
Unapplied parent: 7cf76371084d94f8934af4bba392fa99d6072cf4

New changelog entries:
  * MAAS Stable Release Update (LP: #1109283):
    This SRU brings a new upstream release of MAAS that removes
    the usage of a cobbler code copy, 'maas-provision' as well as
    several bug fixes. Exception has been granted by the Technical
    Board to proceed. More information can be found in:
    https://lists.ubuntu.com/archives/ubuntu-devel-announce/2013-February/001012.html
  [ Andres Rodriguez ]
  * debian/control:
    - Change Conflicts/Replaces for Breaks/Replaces.
    - Conflicts on tftpd-hpa and dnsmasq.
    - Do not pre-depends, but Depends on ${misc:Depends} for 'maas'.
  [ Steve Langasek ]
  * postinst scripts are never called with 'reconfigure' as the script
    argument. Remove references to this (mythical) invocation.
  * always call 'set -e' from maintainer scripts instead of passing 'sh -e'
    as the interpreter, so that scripts will behave correctly when run via
    'sh -x'.
  * invoke-rc.d is never allowed to not exist - simplify scripts (and make
    them better policy-compliant) by invoking unconditionally. (The only
    possible exception is in the postrm, where it's *theoretically* possible
    for invoke-rc.d to be missing if the user has completely stripped
    down their system; that's a fairly unreasonable corner case, but we
    might as well be correct if it ever happens.)
  * db_get+db_set is a no-op; don't call db_set to push back a value we just
    got from db_get.
  * Omit superfluous calls to 'exit 0' at the end of each script.
  * Remove maas-cluster-controller prerm script, which called debconf for no
    reason.
  * Don't invoke debconf in the postrm script either, debhelper already does
    this for us.
  * Other miscellaneous maintainer script fixes
  * debian/maas-common.postinst: call adduser and addgroup unconditionally;
    the tools are already designed to DTRT, we don't need to check for the
    user/group existence before calling them nor should we worry about
    calling them only once on first install.
  * debian/maas-common.postrm: delete the maas group, not just the user,
    as the comment in the code implies we should do.

applied/ubuntu/quantal 2012-10-15 20:03:15 UTC 2012-10-15
Import patches-applied version 0.1+bzr1264+dfsg-0ubuntu2 to applied/ubuntu/qu...

Author: Andres Rodriguez
Author Date: 2012-10-11 21:38:08 UTC

Import patches-applied version 0.1+bzr1264+dfsg-0ubuntu2 to applied/ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 4b9aa68d3e8d581b04697de2857cacc79cd58195
Unapplied parent: 6339161c6e70f9de88bf62391e2e8fb007d40170

New changelog entries:
  * Fix MAAS not working after CD/preseed install (LP: #1065763)
    - debian/extras/maas-region-celeryd: Add wrapper to run celery from
      the upstart job.
    - debian/extras/maas-region-controller.maas-region-celery.upstart: Create
      rabbitmq user if it does not exists.
  * debian/control: Remove unneeded deps on python-txtftp for some binary pkgs.
  * debian/maas-region-controller.postinst: Minor fix referencing variable.

ubuntu/quantal 2012-10-15 20:03:15 UTC 2012-10-15
Import patches-unapplied version 0.1+bzr1264+dfsg-0ubuntu2 to ubuntu/quantal

Author: Andres Rodriguez
Author Date: 2012-10-11 21:38:08 UTC

Import patches-unapplied version 0.1+bzr1264+dfsg-0ubuntu2 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: 9812345413b49f470e1a39984a08043fc643918a

New changelog entries:
  * Fix MAAS not working after CD/preseed install (LP: #1065763)
    - debian/extras/maas-region-celeryd: Add wrapper to run celery from
      the upstart job.
    - debian/extras/maas-region-controller.maas-region-celery.upstart: Create
      rabbitmq user if it does not exists.
  * debian/control: Remove unneeded deps on python-txtftp for some binary pkgs.
  * debian/maas-region-controller.postinst: Minor fix referencing variable.

ubuntu/precise 2012-04-23 10:04:05 UTC 2012-04-23
Import patches-unapplied version 0.1+bzr482+dfsg-0ubuntu1 to ubuntu/precise-p...

Author: Andres Rodriguez
Author Date: 2012-04-18 06:44:46 UTC

Import patches-unapplied version 0.1+bzr482+dfsg-0ubuntu1 to ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: 24f93b797c3e669990b2dcd9deb79654f51df91e

New changelog entries:
  * New upstream release (Fixes LP: #981103)
  * debian/maas.postinst:
    - Make sure rabbitmq and postgresql are started on upgrade (LP: #981282)
    - Handle upgrades from any lower than 0.1+bzr462+dfsg-0ubuntu1 to
      correctly re-generate passwords, and not have db sync/migrate issues
      as config has changed upstream.
    - Correctly set Passwords for PSERV, otherwise it won't set new passwords.
  * Allow MAAS_DEFAULT_URL reconfiguration. (LP: #980970)
    - debian/maas.config: Add reconfigure validation to correctly allow it,
      and ask a question.
    - debian/maas.postinst: Reconfigure DEFAULT_MAAS_URL as well as cobbler
      server and next_server for PXE/Provisioning.
    - debian/maas.templates: Add debconf question and update info.
  * Do not lose MAAS_DEFAULT_URL settings on upgrade (LP: #984309)
  * debian/maas.postinst:
    - Set cobbler password in between quotes (LP: #984427)
    - Do not change permissions to maas.log (LP: #980915)
  * no longer use maas-cloudimg2ephemeral, but rather use premade images
    at http://maas.ubuntu.com

applied/ubuntu/precise 2012-04-23 10:04:05 UTC 2012-04-23
Import patches-applied version 0.1+bzr482+dfsg-0ubuntu1 to applied/ubuntu/pre...

Author: Andres Rodriguez
Author Date: 2012-04-18 06:44:46 UTC

Import patches-applied version 0.1+bzr482+dfsg-0ubuntu1 to applied/ubuntu/precise-proposed

Imported using git-ubuntu import.

Changelog parent: cca19e70aed58c2a56d3ee481a688316ae51ebf6
Unapplied parent: c6378d863c54ced65bc78bb63c7b81c2af824c59

New changelog entries:
  * New upstream release (Fixes LP: #981103)
  * debian/maas.postinst:
    - Make sure rabbitmq and postgresql are started on upgrade (LP: #981282)
    - Handle upgrades from any lower than 0.1+bzr462+dfsg-0ubuntu1 to
      correctly re-generate passwords, and not have db sync/migrate issues
      as config has changed upstream.
    - Correctly set Passwords for PSERV, otherwise it won't set new passwords.
  * Allow MAAS_DEFAULT_URL reconfiguration. (LP: #980970)
    - debian/maas.config: Add reconfigure validation to correctly allow it,
      and ask a question.
    - debian/maas.postinst: Reconfigure DEFAULT_MAAS_URL as well as cobbler
      server and next_server for PXE/Provisioning.
    - debian/maas.templates: Add debconf question and update info.
  * Do not lose MAAS_DEFAULT_URL settings on upgrade (LP: #984309)
  * debian/maas.postinst:
    - Set cobbler password in between quotes (LP: #984427)
    - Do not change permissions to maas.log (LP: #980915)
  * no longer use maas-cloudimg2ephemeral, but rather use premade images
    at http://maas.ubuntu.com

101137 of 137 results

Other repositories

Name Last Modified
lp:ubuntu/+source/maas 2019-06-28
11 of 1 result
You can't create new repositories for maas in Ubuntu.