You can't create new repositories for linux-meta-raspi2 in Ubuntu.