View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/libpng
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2018-07-11 14:31:36 UTC 2018-07-11
DSC file for 1.2.54-1ubuntu1.1

Author: Ubuntu Git Importer
Author Date: 2018-07-11 14:31:36 UTC

DSC file for 1.2.54-1ubuntu1.1

ubuntu/xenial-updates 2018-07-11 14:23:13 UTC 2018-07-11
Import patches-unapplied version 1.2.54-1ubuntu1.1 to ubuntu/xenial-security

Author: Leonidas S. Barbosa
Author Date: 2018-07-10 19:59:38 UTC

Import patches-unapplied version 1.2.54-1ubuntu1.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 1b33a09b4febd64b89ab774b46249d21681e0407

New changelog entries:
  * SECURITY UPDATE: Null pointer dereference
    - debian/patches/CVE-2016-10087.patch: fix in png.c.
    - CVE-2016-10087

ubuntu/trusty-devel 2018-07-11 14:23:13 UTC 2018-07-11
Import patches-unapplied version 1.2.50-1ubuntu2.14.04.3 to ubuntu/trusty-sec...

Author: Leonidas S. Barbosa
Author Date: 2018-07-10 19:58:16 UTC

Import patches-unapplied version 1.2.50-1ubuntu2.14.04.3 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 24063f4bd82d03f885303f0654e028c94eb1b13a

New changelog entries:
  * SECURITY UPDATE: Null pointer dereference
    - debian/patches/CVE-2016-10087.patch: fix in png.c.
    - CVE-2016-10087

ubuntu/trusty-security 2018-07-11 14:23:13 UTC 2018-07-11
Import patches-unapplied version 1.2.50-1ubuntu2.14.04.3 to ubuntu/trusty-sec...

Author: Leonidas S. Barbosa
Author Date: 2018-07-10 19:58:16 UTC

Import patches-unapplied version 1.2.50-1ubuntu2.14.04.3 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 24063f4bd82d03f885303f0654e028c94eb1b13a

New changelog entries:
  * SECURITY UPDATE: Null pointer dereference
    - debian/patches/CVE-2016-10087.patch: fix in png.c.
    - CVE-2016-10087

ubuntu/trusty-updates 2018-07-11 14:23:13 UTC 2018-07-11
Import patches-unapplied version 1.2.50-1ubuntu2.14.04.3 to ubuntu/trusty-sec...

Author: Leonidas S. Barbosa
Author Date: 2018-07-10 19:58:16 UTC

Import patches-unapplied version 1.2.50-1ubuntu2.14.04.3 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 24063f4bd82d03f885303f0654e028c94eb1b13a

New changelog entries:
  * SECURITY UPDATE: Null pointer dereference
    - debian/patches/CVE-2016-10087.patch: fix in png.c.
    - CVE-2016-10087

ubuntu/xenial-security 2018-07-11 14:23:13 UTC 2018-07-11
Import patches-unapplied version 1.2.54-1ubuntu1.1 to ubuntu/xenial-security

Author: Leonidas S. Barbosa
Author Date: 2018-07-10 19:59:38 UTC

Import patches-unapplied version 1.2.54-1ubuntu1.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 1b33a09b4febd64b89ab774b46249d21681e0407

New changelog entries:
  * SECURITY UPDATE: Null pointer dereference
    - debian/patches/CVE-2016-10087.patch: fix in png.c.
    - CVE-2016-10087

ubuntu/xenial-devel 2018-07-11 14:23:13 UTC 2018-07-11
Import patches-unapplied version 1.2.54-1ubuntu1.1 to ubuntu/xenial-security

Author: Leonidas S. Barbosa
Author Date: 2018-07-10 19:59:38 UTC

Import patches-unapplied version 1.2.54-1ubuntu1.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: 1b33a09b4febd64b89ab774b46249d21681e0407

New changelog entries:
  * SECURITY UPDATE: Null pointer dereference
    - debian/patches/CVE-2016-10087.patch: fix in png.c.
    - CVE-2016-10087

importer/ubuntu/pristine-tar 2018-03-07 21:32:52 UTC 2018-03-07
pristine-tar data for libpng_1.2.54.orig.tar.xz

Author: Ubuntu Git Importer
Author Date: 2018-03-07 21:32:52 UTC

pristine-tar data for libpng_1.2.54.orig.tar.xz

importer/debian/dsc 2018-03-07 21:10:24 UTC 2018-03-07
DSC file for 1.2.50-2+deb8u3

Author: Ubuntu Git Importer
Author Date: 2018-03-07 21:10:24 UTC

DSC file for 1.2.50-2+deb8u3

importer/debian/pristine-tar 2018-03-07 21:08:29 UTC 2018-03-07
pristine-tar data for libpng_1.2.54.orig.tar.xz

Author: Ubuntu Git Importer
Author Date: 2018-03-07 21:08:29 UTC

pristine-tar data for libpng_1.2.54.orig.tar.xz

applied/debian/jessie 2017-01-14 17:28:58 UTC 2017-01-14
Import patches-applied version 1.2.50-2+deb8u3 to applied/debian/jessie

Author: Gianfranco Costamagna
Author Date: 2017-01-02 17:21:33 UTC

Import patches-applied version 1.2.50-2+deb8u3 to applied/debian/jessie

Imported using git-ubuntu import.

Changelog parent: 0338dbda32314be6b3ef20c4f9de25987bbb8125
Unapplied parent: 9f9a20970f81dad778399ef8ea636ebe8663503c

New changelog entries:
  * debian/patches/CVE-2016-10087.patch:
    - cherry-pick upstream fix for CVE-2016-10087

debian/jessie 2017-01-14 17:28:58 UTC 2017-01-14
Import patches-unapplied version 1.2.50-2+deb8u3 to debian/jessie

Author: Gianfranco Costamagna
Author Date: 2017-01-02 17:21:33 UTC

Import patches-unapplied version 1.2.50-2+deb8u3 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: e4202ef7a0d7ba3a577c421727cb04b419bd6977

New changelog entries:
  * debian/patches/CVE-2016-10087.patch:
    - cherry-pick upstream fix for CVE-2016-10087

ubuntu/yakkety 2016-04-23 01:48:53 UTC 2016-04-23
Import patches-unapplied version 1.2.54-6ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-04-23 01:37:22 UTC

Import patches-unapplied version 1.2.54-6ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 1b789fede656edfec97e28a309bf30ac7fe3f112

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/devel 2016-04-23 01:48:53 UTC 2016-04-23
Import patches-unapplied version 1.2.54-6ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-04-23 01:37:22 UTC

Import patches-unapplied version 1.2.54-6ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 1b789fede656edfec97e28a309bf30ac7fe3f112

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/yakkety-devel 2016-04-23 01:48:53 UTC 2016-04-23
Import patches-unapplied version 1.2.54-6ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-04-23 01:37:22 UTC

Import patches-unapplied version 1.2.54-6ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 1b789fede656edfec97e28a309bf30ac7fe3f112

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/yakkety-proposed 2016-04-23 01:48:53 UTC 2016-04-23
Import patches-unapplied version 1.2.54-6ubuntu1 to ubuntu/yakkety-proposed

Author: Matthias Klose
Author Date: 2016-04-23 01:37:22 UTC

Import patches-unapplied version 1.2.54-6ubuntu1 to ubuntu/yakkety-proposed

Imported using git-ubuntu import.

Changelog parent: 1b789fede656edfec97e28a309bf30ac7fe3f112

New changelog entries:
  * Merge with Debian; remaining changes:
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

applied/debian/wheezy 2016-04-02 23:34:49 UTC 2016-04-02
Import patches-applied version 1.2.49-1+deb7u2 to applied/debian/wheezy

Author: Salvatore Bonaccorso
Author Date: 2016-01-07 19:07:15 UTC

Import patches-applied version 1.2.49-1+deb7u2 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 90fddb06d48af00d55909f23708a49f5b7584f98
Unapplied parent: 0e8a1a453dc69dd49e077cfb2b217ee6422f39bf

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Add patches to address CVE-2015-8472.
    CVE-2015-8472: Incomplete fix for callers on png_set_PLTE. (Closes: #807112)
  * Add CVE-2015-8540.patch patch.
    CVE-2015-8540: underflow read in png_check_keyword(). (Closes: #807694)
  * Non-maintainer upload by the Security Team.
  * Add CVE-2015-7981.patch patch.
    CVE-2015-7981: Out-of-bounds read in png_convert_to_rfc1123.
    (Closes: #803078)
  * Add Prevent-writing-over-length-PLTE-chunk-Cosm.patch patch.
    CVE-2015-8126: Multiple buffer overflows in the png_set_PLTE and
    png_get_PLTE functions. (Closes: #805113)
  * Add Fixed-new-bug-with-CRC-error-after-reading-.patch patch.
    Fixed new bug with CRC error after reading an over-length palette.

debian/wheezy 2016-04-02 23:34:49 UTC 2016-04-02
Import patches-unapplied version 1.2.49-1+deb7u2 to debian/wheezy

Author: Salvatore Bonaccorso
Author Date: 2016-01-07 19:07:15 UTC

Import patches-unapplied version 1.2.49-1+deb7u2 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: b8eb6466aade15da015aa927f925058cf0a3dc48

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Add patches to address CVE-2015-8472.
    CVE-2015-8472: Incomplete fix for callers on png_set_PLTE. (Closes: #807112)
  * Add CVE-2015-8540.patch patch.
    CVE-2015-8540: underflow read in png_check_keyword(). (Closes: #807694)
  * Non-maintainer upload by the Security Team.
  * Add CVE-2015-7981.patch patch.
    CVE-2015-7981: Out-of-bounds read in png_convert_to_rfc1123.
    (Closes: #803078)
  * Add Prevent-writing-over-length-PLTE-chunk-Cosm.patch patch.
    CVE-2015-8126: Multiple buffer overflows in the png_set_PLTE and
    png_get_PLTE functions. (Closes: #805113)
  * Add Fixed-new-bug-with-CRC-error-after-reading-.patch patch.
    Fixed new bug with CRC error after reading an over-length palette.

ubuntu/xenial-proposed 2016-01-06 19:09:16 UTC 2016-01-06
Import patches-unapplied version 1.2.54-1ubuntu1 to ubuntu/xenial-proposed

Author: Marc Deslauriers
Author Date: 2016-01-06 17:39:08 UTC

Import patches-unapplied version 1.2.54-1ubuntu1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 9cebfe504b56e813ccc8e18407ba4674f9a27167

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/xenial 2016-01-06 19:09:16 UTC 2016-01-06
Import patches-unapplied version 1.2.54-1ubuntu1 to ubuntu/xenial-proposed

Author: Marc Deslauriers
Author Date: 2016-01-06 17:39:08 UTC

Import patches-unapplied version 1.2.54-1ubuntu1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 9cebfe504b56e813ccc8e18407ba4674f9a27167

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/vivid-devel 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.51-0ubuntu3.15.04.2 to ubuntu/vivid-secu...

Author: Marc Deslauriers
Author Date: 2015-12-18 14:53:37 UTC

Import patches-unapplied version 1.2.51-0ubuntu3.15.04.2 to ubuntu/vivid-security

Imported using git-ubuntu import.

Changelog parent: 85668ebdd58adcd1850963b81f3b6d5ddebbaa5f

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/wily-updates 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.51-0ubuntu3.15.10.2 to ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2015-12-18 14:49:01 UTC

Import patches-unapplied version 1.2.51-0ubuntu3.15.10.2 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: 90ae7fb2a927e2ae77a2e87eafbc6c6f7eec0838

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/wily-security 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.51-0ubuntu3.15.10.2 to ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2015-12-18 14:49:01 UTC

Import patches-unapplied version 1.2.51-0ubuntu3.15.10.2 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: 90ae7fb2a927e2ae77a2e87eafbc6c6f7eec0838

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/wily-devel 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.51-0ubuntu3.15.10.2 to ubuntu/wily-security

Author: Marc Deslauriers
Author Date: 2015-12-18 14:49:01 UTC

Import patches-unapplied version 1.2.51-0ubuntu3.15.10.2 to ubuntu/wily-security

Imported using git-ubuntu import.

Changelog parent: 90ae7fb2a927e2ae77a2e87eafbc6c6f7eec0838

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/vivid-updates 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.51-0ubuntu3.15.04.2 to ubuntu/vivid-secu...

Author: Marc Deslauriers
Author Date: 2015-12-18 14:53:37 UTC

Import patches-unapplied version 1.2.51-0ubuntu3.15.04.2 to ubuntu/vivid-security

Imported using git-ubuntu import.

Changelog parent: 85668ebdd58adcd1850963b81f3b6d5ddebbaa5f

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/vivid-security 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.51-0ubuntu3.15.04.2 to ubuntu/vivid-secu...

Author: Marc Deslauriers
Author Date: 2015-12-18 14:53:37 UTC

Import patches-unapplied version 1.2.51-0ubuntu3.15.04.2 to ubuntu/vivid-security

Imported using git-ubuntu import.

Changelog parent: 85668ebdd58adcd1850963b81f3b6d5ddebbaa5f

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/precise-updates 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.46-3ubuntu4.2 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2015-12-18 14:54:56 UTC

Import patches-unapplied version 1.2.46-3ubuntu4.2 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 7768c6b5c5bee5fe588183b2a3fa59f9dde1ef64

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/precise-security 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.46-3ubuntu4.2 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2015-12-18 14:54:56 UTC

Import patches-unapplied version 1.2.46-3ubuntu4.2 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 7768c6b5c5bee5fe588183b2a3fa59f9dde1ef64

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

ubuntu/precise-devel 2016-01-06 17:41:16 UTC 2016-01-06
Import patches-unapplied version 1.2.46-3ubuntu4.2 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2015-12-18 14:54:56 UTC

Import patches-unapplied version 1.2.46-3ubuntu4.2 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 7768c6b5c5bee5fe588183b2a3fa59f9dde1ef64

New changelog entries:
  * SECURITY UPDATE: overflows in png_handle_zTXt(), png_handle_sPLT(),
    png_handle_pCAL(), and png_set_PLTE()
    - debian/patches/CVE-2015-8472.patch: check lengths in pngrutil.c,
      properly use info_ptr in pngset.c.
    - CVE-2015-8472
  * SECURITY UPDATE: out-of-range read in png_check_keyword()
    - debian/patches/CVE-2015-8540.patch: check key_len in pngwutil.c.
    - CVE-2015-8540

applied/debian/sid 2015-11-18 22:17:10 UTC 2015-11-18
Import patches-applied version 1.2.54-1 to applied/debian/sid

Author: Nobuhiro Iwamatsu
Author Date: 2015-11-18 02:00:42 UTC

Import patches-applied version 1.2.54-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e85dc486cdd64c3b05bafab1e9ce2a0730d1ade3
Unapplied parent: 760ca84291072c5d63ddd415f936f7cdd3a2e68c

New changelog entries:
  * New upstream release. (Closes: #803078, #805113)
  * Remove patches/02-required-space.patch.
    Already applied in upstream.
  * Bumped standards version to 3.9.6.

debian/sid 2015-11-18 22:17:10 UTC 2015-11-18
Import patches-unapplied version 1.2.54-1 to debian/sid

Author: Nobuhiro Iwamatsu
Author Date: 2015-11-18 02:00:42 UTC

Import patches-unapplied version 1.2.54-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cabcf3b02eb2bcb82f5e275b53085768bb6d0a52

New changelog entries:
  * New upstream release. (Closes: #803078, #805113)
  * Remove patches/02-required-space.patch.
    Already applied in upstream.
  * Bumped standards version to 3.9.6.

debian/stretch 2015-11-18 22:17:10 UTC 2015-11-18
Import patches-unapplied version 1.2.54-1 to debian/sid

Author: Nobuhiro Iwamatsu
Author Date: 2015-11-18 02:00:42 UTC

Import patches-unapplied version 1.2.54-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cabcf3b02eb2bcb82f5e275b53085768bb6d0a52

New changelog entries:
  * New upstream release. (Closes: #803078, #805113)
  * Remove patches/02-required-space.patch.
    Already applied in upstream.
  * Bumped standards version to 3.9.6.

applied/debian/stretch 2015-11-18 22:17:10 UTC 2015-11-18
Import patches-applied version 1.2.54-1 to applied/debian/sid

Author: Nobuhiro Iwamatsu
Author Date: 2015-11-18 02:00:42 UTC

Import patches-applied version 1.2.54-1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e85dc486cdd64c3b05bafab1e9ce2a0730d1ade3
Unapplied parent: 760ca84291072c5d63ddd415f936f7cdd3a2e68c

New changelog entries:
  * New upstream release. (Closes: #803078, #805113)
  * Remove patches/02-required-space.patch.
    Already applied in upstream.
  * Bumped standards version to 3.9.6.

ubuntu/utopic-devel 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 18:29:36 UTC

Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 493e73f9d15261973d1b742057c699bcb8071e95

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

ubuntu/vivid 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 18:29:36 UTC

Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 493e73f9d15261973d1b742057c699bcb8071e95

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

ubuntu/utopic-proposed 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 18:29:36 UTC

Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 493e73f9d15261973d1b742057c699bcb8071e95

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

ubuntu/wily 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 18:29:36 UTC

Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 493e73f9d15261973d1b742057c699bcb8071e95

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

ubuntu/utopic 2014-10-21 20:28:41 UTC 2014-10-21
Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Author: Brian Murray
Author Date: 2014-10-21 18:29:36 UTC

Import patches-unapplied version 1.2.51-0ubuntu3 to ubuntu/utopic-proposed

Imported using git-ubuntu import.

Changelog parent: 493e73f9d15261973d1b742057c699bcb8071e95

New changelog entries:
  * No-change rebuild to get debug symbols on all architectures.

ubuntu/trusty 2014-03-31 22:53:24 UTC 2014-03-31
Import patches-unapplied version 1.2.50-1ubuntu2 to ubuntu/trusty-proposed

Author: Brian Murray
Author Date: 2014-03-31 21:20:51 UTC

Import patches-unapplied version 1.2.50-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 0d4a50f0eec09c2e3ea93dde7e5c0bc3f50ddbe0

New changelog entries:
  * Add debian/patches/02-required-space.patch, thanks to Dan Kegel for the
    patch. (LP: #1298779)

ubuntu/trusty-proposed 2014-03-31 22:53:24 UTC 2014-03-31
Import patches-unapplied version 1.2.50-1ubuntu2 to ubuntu/trusty-proposed

Author: Brian Murray
Author Date: 2014-03-31 21:20:51 UTC

Import patches-unapplied version 1.2.50-1ubuntu2 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 0d4a50f0eec09c2e3ea93dde7e5c0bc3f50ddbe0

New changelog entries:
  * Add debian/patches/02-required-space.patch, thanks to Dan Kegel for the
    patch. (LP: #1298779)

ubuntu/saucy-devel 2013-08-23 03:13:18 UTC 2013-08-23
Import patches-unapplied version 1.2.49-4ubuntu1 to ubuntu/saucy-proposed

Author: Jackson Doak
Author Date: 2013-08-22 06:05:43 UTC

Import patches-unapplied version 1.2.49-4ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 033f618ff373351b20a04fc133e52dcc79be70d7

New changelog entries:
   * Merge from Debian unstable. Remaining changes:
    - Revert to gzip compression for libpng12-0's data tarball. Packages in
      the base system may not use bzip2.
    - Add debian/tests: Simple compile/link/run autopkgtest

ubuntu/saucy-proposed 2013-08-23 03:13:18 UTC 2013-08-23
Import patches-unapplied version 1.2.49-4ubuntu1 to ubuntu/saucy-proposed

Author: Jackson Doak
Author Date: 2013-08-22 06:05:43 UTC

Import patches-unapplied version 1.2.49-4ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 033f618ff373351b20a04fc133e52dcc79be70d7

New changelog entries:
   * Merge from Debian unstable. Remaining changes:
    - Revert to gzip compression for libpng12-0's data tarball. Packages in
      the base system may not use bzip2.
    - Add debian/tests: Simple compile/link/run autopkgtest

ubuntu/saucy 2013-08-23 03:13:18 UTC 2013-08-23
Import patches-unapplied version 1.2.49-4ubuntu1 to ubuntu/saucy-proposed

Author: Jackson Doak
Author Date: 2013-08-22 06:05:43 UTC

Import patches-unapplied version 1.2.49-4ubuntu1 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 033f618ff373351b20a04fc133e52dcc79be70d7

New changelog entries:
   * Merge from Debian unstable. Remaining changes:
    - Revert to gzip compression for libpng12-0's data tarball. Packages in
      the base system may not use bzip2.
    - Add debian/tests: Simple compile/link/run autopkgtest

ubuntu/raring-proposed 2012-11-12 13:33:24 UTC 2012-11-12
Import patches-unapplied version 1.2.49-1ubuntu2 to ubuntu/raring-proposed

Author: Rafał Cieślak
Author Date: 2012-10-31 15:43:53 UTC

Import patches-unapplied version 1.2.49-1ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 70d6d015bf966d289dd3899d78592afde483bd2a

New changelog entries:
  * Add debian/tests: Simple compile/link/run autopkgtest. (LP: #1073538)

ubuntu/raring-devel 2012-11-12 13:33:24 UTC 2012-11-12
Import patches-unapplied version 1.2.49-1ubuntu2 to ubuntu/raring-proposed

Author: Rafał Cieślak
Author Date: 2012-10-31 15:43:53 UTC

Import patches-unapplied version 1.2.49-1ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 70d6d015bf966d289dd3899d78592afde483bd2a

New changelog entries:
  * Add debian/tests: Simple compile/link/run autopkgtest. (LP: #1073538)

ubuntu/raring 2012-11-12 13:33:24 UTC 2012-11-12
Import patches-unapplied version 1.2.49-1ubuntu2 to ubuntu/raring-proposed

Author: Rafał Cieślak
Author Date: 2012-10-31 15:43:53 UTC

Import patches-unapplied version 1.2.49-1ubuntu2 to ubuntu/raring-proposed

Imported using git-ubuntu import.

Changelog parent: 70d6d015bf966d289dd3899d78592afde483bd2a

New changelog entries:
  * Add debian/tests: Simple compile/link/run autopkgtest. (LP: #1073538)

applied/debian/experimental 2012-07-05 10:26:23 UTC 2012-07-05
Import patches-applied version 1.5.11-1 to applied/debian/experimental

Author: Nobuhiro Iwamatsu
Author Date: 2012-07-05 04:18:14 UTC

Import patches-applied version 1.5.11-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 1f0ad98e57c4d25e71db796b9a8748812a93ed33
Unapplied parent: cef6ed4f526662c3e911cb41883b060b5bebdf50

New changelog entries:
  * New upstream release.

debian/experimental 2012-07-05 10:26:23 UTC 2012-07-05
Import patches-unapplied version 1.5.11-1 to debian/experimental

Author: Nobuhiro Iwamatsu
Author Date: 2012-07-05 04:18:14 UTC

Import patches-unapplied version 1.5.11-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 4eebb4bb3b210f0e9434a2b42d6031b7be961266

New changelog entries:
  * New upstream release.

ubuntu/quantal 2012-05-24 14:34:51 UTC 2012-05-24
Import patches-unapplied version 1.2.49-1ubuntu1 to ubuntu/quantal

Author: Marc Deslauriers
Author Date: 2012-05-24 14:13:23 UTC

Import patches-unapplied version 1.2.49-1ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: b8eb6466aade15da015aa927f925058cf0a3dc48

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Revert to gzip compression for libpng12-0's data tarball. Packages in
      the base system may not use bzip2.

ubuntu/quantal-devel 2012-05-24 14:34:51 UTC 2012-05-24
Import patches-unapplied version 1.2.49-1ubuntu1 to ubuntu/quantal

Author: Marc Deslauriers
Author Date: 2012-05-24 14:13:23 UTC

Import patches-unapplied version 1.2.49-1ubuntu1 to ubuntu/quantal

Imported using git-ubuntu import.

Changelog parent: b8eb6466aade15da015aa927f925058cf0a3dc48

New changelog entries:
  * Merge from Debian unstable. Remaining changes:
    - Revert to gzip compression for libpng12-0's data tarball. Packages in
      the base system may not use bzip2.

applied/debian/squeeze 2012-05-12 15:16:24 UTC 2012-05-12
Import patches-applied version 1.2.44-1+squeeze4 to applied/debian/squeeze

Author: Moritz Muehlenhoff
Author Date: 2012-04-04 18:08:48 UTC

Import patches-applied version 1.2.44-1+squeeze4 to applied/debian/squeeze

Imported using git-ubuntu import.

Changelog parent: c20bb0b07061003fe966c7d77cd5bca909671a78
Unapplied parent: 03f0cf1db3344446f0787476493e85071bc57d49

New changelog entries:
  * CVE-2011-3048
  * CVE-2011-3045
  * Fix integer overflow (chromium #112822)

debian/squeeze 2012-05-12 15:16:24 UTC 2012-05-12
Import patches-unapplied version 1.2.44-1+squeeze4 to debian/squeeze

Author: Moritz Muehlenhoff
Author Date: 2012-04-04 18:08:48 UTC

Import patches-unapplied version 1.2.44-1+squeeze4 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 8c37d18984b8e7fd31d2e282f452b30147f7a1ed

New changelog entries:
  * CVE-2011-3048
  * CVE-2011-3045
  * Fix integer overflow (chromium #112822)

ubuntu/lucid-devel 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.42-1ubuntu2.5 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:43:48 UTC

Import patches-unapplied version 1.2.42-1ubuntu2.5 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d8fbd612e54c876ad1cf98e53f700532f8f53ba4

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/natty-updates 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.44-1ubuntu3.4 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:40:00 UTC

Import patches-unapplied version 1.2.44-1ubuntu3.4 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 33d0fc6e94a41f605bce629711e708f74a6f9f7a

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/natty-security 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.44-1ubuntu3.4 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:40:00 UTC

Import patches-unapplied version 1.2.44-1ubuntu3.4 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 33d0fc6e94a41f605bce629711e708f74a6f9f7a

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/hardy-devel 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.15~beta5-3ubuntu0.7 to ubuntu/hardy-secu...

Author: Marc Deslauriers
Author Date: 2012-04-05 12:47:42 UTC

Import patches-unapplied version 1.2.15~beta5-3ubuntu0.7 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: be089c73b3bdb38ea8c4fbe55cafe8b62a43cb65

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - pngset.c: correctly restore to previous condition.
    - Patch from Debian's 1.2.44-1+squeeze4 update
    - CVE-2011-3048

ubuntu/hardy-security 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.15~beta5-3ubuntu0.7 to ubuntu/hardy-secu...

Author: Marc Deslauriers
Author Date: 2012-04-05 12:47:42 UTC

Import patches-unapplied version 1.2.15~beta5-3ubuntu0.7 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: be089c73b3bdb38ea8c4fbe55cafe8b62a43cb65

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - pngset.c: correctly restore to previous condition.
    - Patch from Debian's 1.2.44-1+squeeze4 update
    - CVE-2011-3048

ubuntu/hardy-updates 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.15~beta5-3ubuntu0.7 to ubuntu/hardy-secu...

Author: Marc Deslauriers
Author Date: 2012-04-05 12:47:42 UTC

Import patches-unapplied version 1.2.15~beta5-3ubuntu0.7 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: be089c73b3bdb38ea8c4fbe55cafe8b62a43cb65

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - pngset.c: correctly restore to previous condition.
    - Patch from Debian's 1.2.44-1+squeeze4 update
    - CVE-2011-3048

ubuntu/lucid-updates 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.42-1ubuntu2.5 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:43:48 UTC

Import patches-unapplied version 1.2.42-1ubuntu2.5 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d8fbd612e54c876ad1cf98e53f700532f8f53ba4

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/oneiric-updates 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.46-3ubuntu1.3 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:27:19 UTC

Import patches-unapplied version 1.2.46-3ubuntu1.3 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 1122828eb9384e40f903f642fb7591849482d54d

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/natty-devel 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.44-1ubuntu3.4 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:40:00 UTC

Import patches-unapplied version 1.2.44-1ubuntu3.4 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 33d0fc6e94a41f605bce629711e708f74a6f9f7a

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/maverick-updates 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.44-1ubuntu0.4 to ubuntu/maverick-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:41:07 UTC

Import patches-unapplied version 1.2.44-1ubuntu0.4 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 85406ef03c5afa7b961d062b05fe68406f533fb9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/lucid-security 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.42-1ubuntu2.5 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:43:48 UTC

Import patches-unapplied version 1.2.42-1ubuntu2.5 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d8fbd612e54c876ad1cf98e53f700532f8f53ba4

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/oneiric-devel 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.46-3ubuntu1.3 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:27:19 UTC

Import patches-unapplied version 1.2.46-3ubuntu1.3 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 1122828eb9384e40f903f642fb7591849482d54d

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/maverick-security 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.44-1ubuntu0.4 to ubuntu/maverick-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:41:07 UTC

Import patches-unapplied version 1.2.44-1ubuntu0.4 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 85406ef03c5afa7b961d062b05fe68406f533fb9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/oneiric-security 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.46-3ubuntu1.3 to ubuntu/oneiric-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:27:19 UTC

Import patches-unapplied version 1.2.46-3ubuntu1.3 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 1122828eb9384e40f903f642fb7591849482d54d

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/maverick-devel 2012-04-05 18:04:44 UTC 2012-04-05
Import patches-unapplied version 1.2.44-1ubuntu0.4 to ubuntu/maverick-security

Author: Marc Deslauriers
Author Date: 2012-04-05 12:41:07 UTC

Import patches-unapplied version 1.2.44-1ubuntu0.4 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 85406ef03c5afa7b961d062b05fe68406f533fb9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

ubuntu/precise 2012-04-05 15:03:36 UTC 2012-04-05
Import patches-unapplied version 1.2.46-3ubuntu4 to ubuntu/precise

Author: Marc Deslauriers
Author Date: 2012-04-05 12:21:56 UTC

Import patches-unapplied version 1.2.46-3ubuntu4 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 153317313e1e257e3b8578434c61e69f94acbe29

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    memory corruption issue.
    - debian/patches/CVE-2011-3048.patch: correctly restore to previous
      condition in pngset.c.
    - CVE-2011-3048

applied/debian/lenny 2012-03-10 15:13:16 UTC 2012-03-10
Import patches-applied version 1.2.27-2+lenny5 to applied/debian/lenny

Author: Nobuhiro Iwamatsu
Author Date: 2011-07-15 20:13:23 UTC

Import patches-applied version 1.2.27-2+lenny5 to applied/debian/lenny

Imported using git-ubuntu import.

Changelog parent: d6e70861781d4c599f7f720c3cfe948a424eb044
Unapplied parent: 0c1d0f43570141e339ddc94cd39fd37521f4c6c0

New changelog entries:
  * Apply upstream patch to 1-byte uninitialized memory reference in
    png_format_buffer(). (Closes: #632786, CVE-2011-2501)
  * Apply upstream patch to buffer overwrite in png_rgb_to_gray.
    (Closes: #633871, CVE-2011-2690)
  * Apply upstream patch to crash in png_default_error due to use of
    NULL Pointer. (Closes: #633871, CVE-2011-2691)
  * Apply upstream patch to memory corruption when handling empty sCAL chunks.
    (Closes: #633871, CVE-2011-2692)

debian/lenny 2012-03-10 15:13:16 UTC 2012-03-10
Import patches-unapplied version 1.2.27-2+lenny5 to debian/lenny

Author: Nobuhiro Iwamatsu
Author Date: 2011-07-15 20:13:23 UTC

Import patches-unapplied version 1.2.27-2+lenny5 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: b0a979026d979c6c7fa5b38e928ec62d819cd923

New changelog entries:
  * Apply upstream patch to 1-byte uninitialized memory reference in
    png_format_buffer(). (Closes: #632786, CVE-2011-2501)
  * Apply upstream patch to buffer overwrite in png_rgb_to_gray.
    (Closes: #633871, CVE-2011-2690)
  * Apply upstream patch to crash in png_default_error due to use of
    NULL Pointer. (Closes: #633871, CVE-2011-2691)
  * Apply upstream patch to memory corruption when handling empty sCAL chunks.
    (Closes: #633871, CVE-2011-2692)

ubuntu/oneiric 2011-08-10 21:04:01 UTC 2011-08-10
Import patches-unapplied version 1.2.46-3ubuntu1 to ubuntu/oneiric

Author: Colin Watson
Author Date: 2011-08-10 20:25:16 UTC

Import patches-unapplied version 1.2.46-3ubuntu1 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: ead34920af78bc7c351cca734caeff18fc658ca0

New changelog entries:
  * Revert to gzip compression for libpng12-0's data tarball. Packages in
    the base system may not use bzip2.

ubuntu/natty 2011-03-20 03:04:45 UTC 2011-03-20
Import patches-unapplied version 1.2.44-1ubuntu3 to ubuntu/natty

Author: Steve Langasek
Author Date: 2011-03-20 00:51:38 UTC

Import patches-unapplied version 1.2.44-1ubuntu3 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: aedb06a3100ae550bfbea7424cf8804376193eb9

New changelog entries:
  * Build for multiarch. Requires converting libpng3 from Arch: all to
    Arch: any.
  * Drop debian/libpng12-0-udeb.dirs, which just adds a pointless empty
    directory to the udeb.

ubuntu/jaunty-security 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.27-2ubuntu2.2 to ubuntu/jaunty-security

Author: Marc Deslauriers
Author Date: 2010-07-05 17:00:03 UTC

Import patches-unapplied version 1.2.27-2ubuntu2.2 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: e7281f66829ae568b8133e97f0c060fee3fc160d

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - debian/patches/05-CVE-2010-1205.patch: check for unexpected data
      after the last row in pngpread.c.
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - debian/patches/06-CVE-2010-2249.patch: properly free memory in
      pngrutil.c.
    - CVE-2010-2249

ubuntu/dapper-devel 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.8rel-5ubuntu0.6 to ubuntu/dapper-security

Author: Marc Deslauriers
Author Date: 2010-07-05 17:19:22 UTC

Import patches-unapplied version 1.2.8rel-5ubuntu0.6 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: bc188a2b2a63ee16d48874df4557339374ea3dc4

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - pngpread.c: check for unexpected data after the last row.
    - patch backported from 1.2.44
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - pngrutil.c: properly free memory
    - patch backported from 1.2.44
    - CVE-2010-2249

ubuntu/dapper-security 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.8rel-5ubuntu0.6 to ubuntu/dapper-security

Author: Marc Deslauriers
Author Date: 2010-07-05 17:19:22 UTC

Import patches-unapplied version 1.2.8rel-5ubuntu0.6 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: bc188a2b2a63ee16d48874df4557339374ea3dc4

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - pngpread.c: check for unexpected data after the last row.
    - patch backported from 1.2.44
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - pngrutil.c: properly free memory
    - patch backported from 1.2.44
    - CVE-2010-2249

ubuntu/dapper-updates 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.8rel-5ubuntu0.6 to ubuntu/dapper-security

Author: Marc Deslauriers
Author Date: 2010-07-05 17:19:22 UTC

Import patches-unapplied version 1.2.8rel-5ubuntu0.6 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: bc188a2b2a63ee16d48874df4557339374ea3dc4

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - pngpread.c: check for unexpected data after the last row.
    - patch backported from 1.2.44
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - pngrutil.c: properly free memory
    - patch backported from 1.2.44
    - CVE-2010-2249

ubuntu/jaunty-devel 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.27-2ubuntu2.2 to ubuntu/jaunty-security

Author: Marc Deslauriers
Author Date: 2010-07-05 17:00:03 UTC

Import patches-unapplied version 1.2.27-2ubuntu2.2 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: e7281f66829ae568b8133e97f0c060fee3fc160d

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - debian/patches/05-CVE-2010-1205.patch: check for unexpected data
      after the last row in pngpread.c.
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - debian/patches/06-CVE-2010-2249.patch: properly free memory in
      pngrutil.c.
    - CVE-2010-2249

ubuntu/jaunty-updates 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.27-2ubuntu2.2 to ubuntu/jaunty-security

Author: Marc Deslauriers
Author Date: 2010-07-05 17:00:03 UTC

Import patches-unapplied version 1.2.27-2ubuntu2.2 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: e7281f66829ae568b8133e97f0c060fee3fc160d

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - debian/patches/05-CVE-2010-1205.patch: check for unexpected data
      after the last row in pngpread.c.
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - debian/patches/06-CVE-2010-2249.patch: properly free memory in
      pngrutil.c.
    - CVE-2010-2249

ubuntu/karmic-devel 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.37-1ubuntu0.2 to ubuntu/karmic-security

Author: Marc Deslauriers
Author Date: 2010-07-05 15:44:13 UTC

Import patches-unapplied version 1.2.37-1ubuntu0.2 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 7a09e769210e7ede0b62e770e29d4a08310ffd4c

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - debian/patches/03-CVE-2010-1205.patch: check for unexpected data
      after the last row in pngpread.c.
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - debian/patches/04-CVE-2010-2249.patch: properly free memory in
      pngrutil.c.
    - CVE-2010-2249

ubuntu/karmic-security 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.37-1ubuntu0.2 to ubuntu/karmic-security

Author: Marc Deslauriers
Author Date: 2010-07-05 15:44:13 UTC

Import patches-unapplied version 1.2.37-1ubuntu0.2 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 7a09e769210e7ede0b62e770e29d4a08310ffd4c

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - debian/patches/03-CVE-2010-1205.patch: check for unexpected data
      after the last row in pngpread.c.
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - debian/patches/04-CVE-2010-2249.patch: properly free memory in
      pngrutil.c.
    - CVE-2010-2249

ubuntu/karmic-updates 2010-07-08 13:06:00 UTC 2010-07-08
Import patches-unapplied version 1.2.37-1ubuntu0.2 to ubuntu/karmic-security

Author: Marc Deslauriers
Author Date: 2010-07-05 15:44:13 UTC

Import patches-unapplied version 1.2.37-1ubuntu0.2 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 7a09e769210e7ede0b62e770e29d4a08310ffd4c

New changelog entries:
  * SECURITY UPDATE: arbitrary code execution from additional data row via
    malformed PNG image
    - debian/patches/03-CVE-2010-1205.patch: check for unexpected data
      after the last row in pngpread.c.
    - CVE-2010-1205
  * SECURITY UPDATE: denial of service via memory leak from malformed sCAL
    chunks
    - debian/patches/04-CVE-2010-2249.patch: properly free memory in
      pngrutil.c.
    - CVE-2010-2249

ubuntu/maverick 2010-06-26 20:25:27 UTC 2010-06-26
Import patches-unapplied version 1.2.44-1 to debian/sid

Author: Anibal Monsalve Salazar
Author Date: 2010-06-26 03:32:43 UTC

Import patches-unapplied version 1.2.44-1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: e5da50933709227f350fa299f418709582196ed6

New changelog entries:
  * New upstream release
    Stop memory leak when reading a malformed sCAL chunk

ubuntu/lucid 2010-03-19 19:05:10 UTC 2010-03-19
Import patches-unapplied version 1.2.42-1ubuntu2 to ubuntu/lucid

Author: Marc Deslauriers
Author Date: 2010-03-11 19:22:24 UTC

Import patches-unapplied version 1.2.42-1ubuntu2 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 294dc2ab71bf22b9bfec382c094a171e904d36a4

New changelog entries:
  * SECURITY UPDATE: denial of service via decompression bomb (LP: #533140)
    - debian/patches/02-CVE-2010-0205.patch: use new two-pass decompression
      method in pngrutil.c.
    - CVE-2010-0205

ubuntu/intrepid-devel 2010-03-16 17:08:13 UTC 2010-03-16
Import patches-unapplied version 1.2.27-1ubuntu0.2 to ubuntu/intrepid-security

Author: Marc Deslauriers
Author Date: 2010-03-15 15:04:48 UTC

Import patches-unapplied version 1.2.27-1ubuntu0.2 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 60ebc8e48ff9c3fe587e230632c81aae2819a056

New changelog entries:
  * SECURITY UPDATE: denial of service via decompression bomb (LP: #533140)
    - debian/patches/03-CVE-2010-0205.patch: use new two-pass decompression
      method in pngrutil.c.
    - CVE-2010-0205
  * SECURITY UPDATE: information disclosure via 1-bit interlaced images
    - debian/patches/04-CVE-2009-2042.patch: initialize memory in
      pngrutil.c.
    - CVE-2009-2042

ubuntu/intrepid-updates 2010-03-16 17:08:13 UTC 2010-03-16
Import patches-unapplied version 1.2.27-1ubuntu0.2 to ubuntu/intrepid-security

Author: Marc Deslauriers
Author Date: 2010-03-15 15:04:48 UTC

Import patches-unapplied version 1.2.27-1ubuntu0.2 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 60ebc8e48ff9c3fe587e230632c81aae2819a056

New changelog entries:
  * SECURITY UPDATE: denial of service via decompression bomb (LP: #533140)
    - debian/patches/03-CVE-2010-0205.patch: use new two-pass decompression
      method in pngrutil.c.
    - CVE-2010-0205
  * SECURITY UPDATE: information disclosure via 1-bit interlaced images
    - debian/patches/04-CVE-2009-2042.patch: initialize memory in
      pngrutil.c.
    - CVE-2009-2042

ubuntu/intrepid-security 2010-03-16 17:08:13 UTC 2010-03-16
Import patches-unapplied version 1.2.27-1ubuntu0.2 to ubuntu/intrepid-security

Author: Marc Deslauriers
Author Date: 2010-03-15 15:04:48 UTC

Import patches-unapplied version 1.2.27-1ubuntu0.2 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 60ebc8e48ff9c3fe587e230632c81aae2819a056

New changelog entries:
  * SECURITY UPDATE: denial of service via decompression bomb (LP: #533140)
    - debian/patches/03-CVE-2010-0205.patch: use new two-pass decompression
      method in pngrutil.c.
    - CVE-2010-0205
  * SECURITY UPDATE: information disclosure via 1-bit interlaced images
    - debian/patches/04-CVE-2009-2042.patch: initialize memory in
      pngrutil.c.
    - CVE-2009-2042

ubuntu/karmic 2009-07-15 14:19:14 UTC 2009-07-15
Import patches-unapplied version 1.2.37-1 to debian/squeeze

Author: Anibal Monsalve Salazar
Author Date: 2009-06-04 13:03:58 UTC

Import patches-unapplied version 1.2.37-1 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 0588409fa1a8b6c0b139800dfc4e1796894ca812

New changelog entries:
  * New upstream release

ubuntu/jaunty 2009-03-06 02:10:25 UTC 2009-03-06
Import patches-unapplied version 1.2.27-2ubuntu2 to ubuntu/jaunty

Author: Jamie Strandboge
Author Date: 2009-03-05 20:15:45 UTC

Import patches-unapplied version 1.2.27-2ubuntu2 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: f30ca85a0aca71f1c7d805ae691f9f3bd093ad8d

New changelog entries:
  * SECURITY UPDATE: denial of service and possible execution of arbitrary
    code via crafted image (LP: #338027)
    - debian/patches/02-CVE-2009-0040.diff: initialize pointers in pngread.c,
      pngrtans.c, pngset.c and example.c
    - CVE-2009-0040
  * SECURITY UPDATE: denial of service via incorrect memory assignment
    (LP: #324258)
    - debian/patches/02-CVE-2008-5907.diff: update pngwutil.c to properly set
      new_key to NULL string
    - CVE-2008-5907

ubuntu/gutsy-security 2009-03-06 02:04:43 UTC 2009-03-06
Import patches-unapplied version 1.2.15~beta5-2ubuntu0.2 to ubuntu/gutsy-secu...

Author: Jamie Strandboge
Author Date: 2009-03-05 13:55:49 UTC

Import patches-unapplied version 1.2.15~beta5-2ubuntu0.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: e69dc03957b6aaacca152a4b56f2e02ff2a1aade

New changelog entries:
  * SECURITY UPDATE: denial of service and possible execution of arbitrary
    code via crafted image (LP: #338027)
    - initialize pointers in pngread.c, pngrtans.c, pngset.c and example.c
    - CVE-2009-0040
  * SECURITY UPDATE: denial of service and possible execution of arbitrary
    code via crafted image (LP: #217128)
    - initialize "unknown" chunks in pngpread.c, pngrutil.c and pngset.c
    - CVE-2008-1382
  * SECURITY UPDATE: denial of service via off-by-one error
    - shorten tIME_string to 29 bytes in pngtest.c
    - CVE-2008-3964
  * SECURITY UPDATE: denial of service via incorrect memory assignment
    (LP: #324258)
    - update pngwutil.c to properly set new_key to NULL string
    - CVE-2008-5907

ubuntu/gutsy-updates 2009-03-06 02:04:43 UTC 2009-03-06
Import patches-unapplied version 1.2.15~beta5-2ubuntu0.2 to ubuntu/gutsy-secu...

Author: Jamie Strandboge
Author Date: 2009-03-05 13:55:49 UTC

Import patches-unapplied version 1.2.15~beta5-2ubuntu0.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: e69dc03957b6aaacca152a4b56f2e02ff2a1aade

New changelog entries:
  * SECURITY UPDATE: denial of service and possible execution of arbitrary
    code via crafted image (LP: #338027)
    - initialize pointers in pngread.c, pngrtans.c, pngset.c and example.c
    - CVE-2009-0040
  * SECURITY UPDATE: denial of service and possible execution of arbitrary
    code via crafted image (LP: #217128)
    - initialize "unknown" chunks in pngpread.c, pngrutil.c and pngset.c
    - CVE-2008-1382
  * SECURITY UPDATE: denial of service via off-by-one error
    - shorten tIME_string to 29 bytes in pngtest.c
    - CVE-2008-3964
  * SECURITY UPDATE: denial of service via incorrect memory assignment
    (LP: #324258)
    - update pngwutil.c to properly set new_key to NULL string
    - CVE-2008-5907

ubuntu/gutsy-devel 2009-03-06 02:04:43 UTC 2009-03-06
Import patches-unapplied version 1.2.15~beta5-2ubuntu0.2 to ubuntu/gutsy-secu...

Author: Jamie Strandboge
Author Date: 2009-03-05 13:55:49 UTC

Import patches-unapplied version 1.2.15~beta5-2ubuntu0.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: e69dc03957b6aaacca152a4b56f2e02ff2a1aade

New changelog entries:
  * SECURITY UPDATE: denial of service and possible execution of arbitrary
    code via crafted image (LP: #338027)
    - initialize pointers in pngread.c, pngrtans.c, pngset.c and example.c
    - CVE-2009-0040
  * SECURITY UPDATE: denial of service and possible execution of arbitrary
    code via crafted image (LP: #217128)
    - initialize "unknown" chunks in pngpread.c, pngrutil.c and pngset.c
    - CVE-2008-1382
  * SECURITY UPDATE: denial of service via off-by-one error
    - shorten tIME_string to 29 bytes in pngtest.c
    - CVE-2008-3964
  * SECURITY UPDATE: denial of service via incorrect memory assignment
    (LP: #324258)
    - update pngwutil.c to properly set new_key to NULL string
    - CVE-2008-5907

ubuntu/intrepid 2008-05-03 02:07:03 UTC 2008-05-03
Import patches-unapplied version 1.2.27-1 to ubuntu/intrepid

Author: Anibal Monsalve Salazar
Author Date: 2008-04-29 07:22:16 UTC

Import patches-unapplied version 1.2.27-1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: cc3aa6c066bdb6bc485de36bc67c4f96507ba2a5

New changelog entries:
  * New upstream release
  * Patches merged upstream:
    debian/patches/02-476669-CVE-2008-1382.diff
    debian/patches/03-404514-png.5.diff
  * Run ./autogen.sh
  * New upstream release. Closes: #431202
  * Use quilt
    Add 01-legacy.diff
  * Fix CVE-2008-1382 denial of service and possibly code execution
    Add 02-476669-CVE-2008-1382.diff
    Closes: #476669
  * Fix URL in png.5. Closes: #404514
    Add 03-404514-png.5.diff
  * Move examples to libpng12-dev. Closes: #401467
  * Fix "libpng (<= 1.2.20) contains grey-licensed code". Closes: #469126
  * Fix the following lintian issues:
    W: libpng source: debian-rules-ignores-make-clean-error line 37
    W: libpng source: substvar-source-version-is-deprecated libpng12-dev
    W: libpng source: out-of-date-standards-version 3.7.2 (current is 3.7.3)
    W: libpng12-0-udeb udeb: description-contains-homepage
    W: libpng3: description-contains-homepage
    W: libpng12-dev: description-contains-homepage
    W: libpng12-0: package-contains-empty-directory usr/bin/
    W: libpng12-0: package-contains-empty-directory usr/sbin/
    W: libpng12-0: description-contains-homepage
    W: libpng12-0: doc-base-unknown-section libpng12:22 Apps/Programming

ubuntu/edgy-security 2007-10-25 19:03:49 UTC 2007-10-25
Import patches-unapplied version 1.2.8rel-5.1ubuntu0.3 to ubuntu/edgy-security

Author: Jamie Strandboge
Author Date: 2007-10-24 19:27:44 UTC

Import patches-unapplied version 1.2.8rel-5.1ubuntu0.3 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: 0d8d5f83df2a3b368a65cbd20d364959e702581b

New changelog entries:
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngpread.c and pngrutil.c to properly do bounds checking on read
    operations
  * References
    CVE-2007-5269

ubuntu/feisty-updates 2007-10-25 19:03:49 UTC 2007-10-25
Import patches-unapplied version 1.2.15~beta5-1ubuntu1.1 to ubuntu/feisty-sec...

Author: Jamie Strandboge
Author Date: 2007-10-15 13:27:22 UTC

Import patches-unapplied version 1.2.15~beta5-1ubuntu1.1 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: 74324aa86b65563d32650521001de0971008b953

New changelog entries:
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngpread.c and pngrutil.c to properly do bounds checking on read
    operations
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngset.c to properly check palette size in png_set_hIST
  * References
    CVE-2007-5269
    CVE-2007-5268

ubuntu/feisty-security 2007-10-25 19:03:49 UTC 2007-10-25
Import patches-unapplied version 1.2.15~beta5-1ubuntu1.1 to ubuntu/feisty-sec...

Author: Jamie Strandboge
Author Date: 2007-10-15 13:27:22 UTC

Import patches-unapplied version 1.2.15~beta5-1ubuntu1.1 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: 74324aa86b65563d32650521001de0971008b953

New changelog entries:
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngpread.c and pngrutil.c to properly do bounds checking on read
    operations
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngset.c to properly check palette size in png_set_hIST
  * References
    CVE-2007-5269
    CVE-2007-5268

ubuntu/feisty-devel 2007-10-25 19:03:49 UTC 2007-10-25
Import patches-unapplied version 1.2.15~beta5-1ubuntu1.1 to ubuntu/feisty-sec...

Author: Jamie Strandboge
Author Date: 2007-10-15 13:27:22 UTC

Import patches-unapplied version 1.2.15~beta5-1ubuntu1.1 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: 74324aa86b65563d32650521001de0971008b953

New changelog entries:
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngpread.c and pngrutil.c to properly do bounds checking on read
    operations
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngset.c to properly check palette size in png_set_hIST
  * References
    CVE-2007-5269
    CVE-2007-5268

ubuntu/edgy-updates 2007-10-25 19:03:49 UTC 2007-10-25
Import patches-unapplied version 1.2.8rel-5.1ubuntu0.3 to ubuntu/edgy-security

Author: Jamie Strandboge
Author Date: 2007-10-24 19:27:44 UTC

Import patches-unapplied version 1.2.8rel-5.1ubuntu0.3 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: 0d8d5f83df2a3b368a65cbd20d364959e702581b

New changelog entries:
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngpread.c and pngrutil.c to properly do bounds checking on read
    operations
  * References
    CVE-2007-5269

ubuntu/edgy-devel 2007-10-25 19:03:49 UTC 2007-10-25
Import patches-unapplied version 1.2.8rel-5.1ubuntu0.3 to ubuntu/edgy-security

Author: Jamie Strandboge
Author Date: 2007-10-24 19:27:44 UTC

Import patches-unapplied version 1.2.8rel-5.1ubuntu0.3 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: 0d8d5f83df2a3b368a65cbd20d364959e702581b

New changelog entries:
  * SECURITY UPDATE: denial of service via a crafted PNG image
  * fix for pngpread.c and pngrutil.c to properly do bounds checking on read
    operations
  * References
    CVE-2007-5269

ubuntu/hardy 2007-10-23 22:04:14 UTC 2007-10-23
Import patches-unapplied version 1.2.15~beta5-3 to ubuntu/hardy

Author: Anibal Monsalve Salazar
Author Date: 2007-10-13 23:55:00 UTC

Import patches-unapplied version 1.2.15~beta5-3 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 7c8dbbca96f88f340ffd768a27daaa613b3a078a

New changelog entries:
  * ACKed NMU.
  * Fixed out-of-bounds read operations triggered by crafted
    png image files (CVE-2007-5269) (Closes: #446308).
  * Non-maintainer upload by testing security team.
  * Fixed out-of-bounds read operations triggered by crafted
    png image files (CVE-2007-5269) (Closes: #446308).

ubuntu/gutsy 2007-10-05 03:03:39 UTC 2007-10-05
Import patches-unapplied version 1.2.15~beta5-2build1 to ubuntu/gutsy

Author: LaMont Jones
Author Date: 2007-10-05 02:23:02 UTC

Import patches-unapplied version 1.2.15~beta5-2build1 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 7c8dbbca96f88f340ffd768a27daaa613b3a078a

New changelog entries:
  * Trigger rebuild for hppa

1100 of 121 results

Other repositories

Name Last Modified
lp:ubuntu/+source/libpng 2018-07-11
11 of 1 result
You can't create new repositories for libpng in Ubuntu.