You can't create new repositories for ironic in Ubuntu.