View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/icu
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
ubuntu/wily-devel 2015-09-11 16:48:41 UTC 2015-09-11
Import patches-unapplied version 55.1-4ubuntu1 to ubuntu/wily-proposed

Author: Marc Deslauriers
Author Date: 2015-09-11 12:24:31 UTC

Import patches-unapplied version 55.1-4ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: ccb19b977bb33fcdd8f8e574bac8a83252f5dd40

New changelog entries:
  * SECURITY UPDATE: denial of service via mishandling of converter names
    with initial x- substrings
    - debian/patches/CVE-2015-1270.patch: fix patch so it actually applies.
    - CVE-2015-1270
  * SECURITY UPDATE: information disclosure via overflows
    - debian/patches/CVE-2015-2632.patch: properly calculate index in
      source/layout/Features.cpp, check for overflows in
      source/layout/LETableReference.h.
    - CVE-2015-2632

ubuntu/wily-proposed 2015-09-11 16:48:41 UTC 2015-09-11
Import patches-unapplied version 55.1-4ubuntu1 to ubuntu/wily-proposed

Author: Marc Deslauriers
Author Date: 2015-09-11 12:24:31 UTC

Import patches-unapplied version 55.1-4ubuntu1 to ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: ccb19b977bb33fcdd8f8e574bac8a83252f5dd40

New changelog entries:
  * SECURITY UPDATE: denial of service via mishandling of converter names
    with initial x- substrings
    - debian/patches/CVE-2015-1270.patch: fix patch so it actually applies.
    - CVE-2015-1270
  * SECURITY UPDATE: information disclosure via overflows
    - debian/patches/CVE-2015-2632.patch: properly calculate index in
      source/layout/Features.cpp, check for overflows in
      source/layout/LETableReference.h.
    - CVE-2015-2632

applied/ubuntu/wily-devel 2015-09-11 16:48:41 UTC 2015-09-11
Import patches-applied version 55.1-4ubuntu1 to applied/ubuntu/wily-proposed

Author: Marc Deslauriers
Author Date: 2015-09-11 12:24:31 UTC

Import patches-applied version 55.1-4ubuntu1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 0c2d6d07ea6d09ab461b79d9064f20439e30bd35
Unapplied parent: c7348067dc740b6ab3957a0f6582049fb8fca0d6

New changelog entries:
  * SECURITY UPDATE: denial of service via mishandling of converter names
    with initial x- substrings
    - debian/patches/CVE-2015-1270.patch: fix patch so it actually applies.
    - CVE-2015-1270
  * SECURITY UPDATE: information disclosure via overflows
    - debian/patches/CVE-2015-2632.patch: properly calculate index in
      source/layout/Features.cpp, check for overflows in
      source/layout/LETableReference.h.
    - CVE-2015-2632

applied/ubuntu/wily-proposed 2015-09-11 16:48:41 UTC 2015-09-11
Import patches-applied version 55.1-4ubuntu1 to applied/ubuntu/wily-proposed

Author: Marc Deslauriers
Author Date: 2015-09-11 12:24:31 UTC

Import patches-applied version 55.1-4ubuntu1 to applied/ubuntu/wily-proposed

Imported using git-ubuntu import.

Changelog parent: 0c2d6d07ea6d09ab461b79d9064f20439e30bd35
Unapplied parent: c7348067dc740b6ab3957a0f6582049fb8fca0d6

New changelog entries:
  * SECURITY UPDATE: denial of service via mishandling of converter names
    with initial x- substrings
    - debian/patches/CVE-2015-1270.patch: fix patch so it actually applies.
    - CVE-2015-1270
  * SECURITY UPDATE: information disclosure via overflows
    - debian/patches/CVE-2015-2632.patch: properly calculate index in
      source/layout/Features.cpp, check for overflows in
      source/layout/LETableReference.h.
    - CVE-2015-2632

applied/debian/wheezy 2015-09-05 17:02:12 UTC 2015-09-05
Import patches-applied version 4.8.1.1-12+deb7u3 to applied/debian/wheezy

Author: Laszlo Boszormenyi
Author Date: 2015-07-25 15:16:27 UTC

Import patches-applied version 4.8.1.1-12+deb7u3 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 1f1dfadf57f162f2f42ade724fabafec636718b7
Unapplied parent: 5e95f56a7ff0b9c14c5551a1592c07ee59a67dc1

New changelog entries:
  * Fix security bugs:
    - CVE-2015-4760 , missing boundary checks in layout engine,
    - CVE-2014-6585 , finish null pointer checks.
  * Add myself as uploader.
  * Non-maintainer upload by the Security Team.
    - Thanks to Marc Deslauriers for many of the backports.
  * Backport of icu's new layout engine.
    - Fixes CVE-2013-1569, CVE-2013-2383, CVE-2013-2384, and CVE-2013-2419.
  * CVE-2014-6585: out-of-bounds read.
  * CVE-2014-6591: more out-of-bounds reads.
  * CVE-2014-7923: memory corruption in regular expression comparison.
  * CVE-2014-7926: memory corruption in regular expression comparison.
  * CVE-2014-7940: uninitialized memory in i18n/icol.cpp.
  * CVE-2014-9654: more regular expression handling issues.

debian/wheezy 2015-09-05 17:02:12 UTC 2015-09-05
Import patches-unapplied version 4.8.1.1-12+deb7u3 to debian/wheezy

Author: Laszlo Boszormenyi
Author Date: 2015-07-25 15:16:27 UTC

Import patches-unapplied version 4.8.1.1-12+deb7u3 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 2bb8d6194c65860a23d60da38c3b4397db000419

New changelog entries:
  * Fix security bugs:
    - CVE-2015-4760 , missing boundary checks in layout engine,
    - CVE-2014-6585 , finish null pointer checks.
  * Add myself as uploader.
  * Non-maintainer upload by the Security Team.
    - Thanks to Marc Deslauriers for many of the backports.
  * Backport of icu's new layout engine.
    - Fixes CVE-2013-1569, CVE-2013-2383, CVE-2013-2384, and CVE-2013-2419.
  * CVE-2014-6585: out-of-bounds read.
  * CVE-2014-6591: more out-of-bounds reads.
  * CVE-2014-7923: memory corruption in regular expression comparison.
  * CVE-2014-7926: memory corruption in regular expression comparison.
  * CVE-2014-7940: uninitialized memory in i18n/icol.cpp.
  * CVE-2014-9654: more regular expression handling issues.

applied/ubuntu/utopic-devel 2015-05-11 14:53:17 UTC 2015-05-11
Import patches-applied version 52.1-6ubuntu0.3 to applied/ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-05-08 12:49:12 UTC

Import patches-applied version 52.1-6ubuntu0.3 to applied/ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: 225954c0847f6daed1bb2948c5cb3a3e3ed8dd98
Unapplied parent: a84a0ff729e1da23c23a0eb6f08996d142ef43f1

New changelog entries:
  * SECURITY UPDATE: heap overflow via incorrect isolateCount
    - debian/patches/CVE-2015-8146.patch: check for valid isolateCount in
      source/common/ubidi.c.
    - CVE-2015-8146
  * SECURITY UPDATE: integer overflow via incorrect state size
    - debian/patches/CVE-2015-8147.patch: change state to int32_t in
      source/common/ubidiimp.h.
    - CVE-2015-8147

applied/ubuntu/utopic-updates 2015-05-11 14:53:17 UTC 2015-05-11
Import patches-applied version 52.1-6ubuntu0.3 to applied/ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-05-08 12:49:12 UTC

Import patches-applied version 52.1-6ubuntu0.3 to applied/ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: 225954c0847f6daed1bb2948c5cb3a3e3ed8dd98
Unapplied parent: a84a0ff729e1da23c23a0eb6f08996d142ef43f1

New changelog entries:
  * SECURITY UPDATE: heap overflow via incorrect isolateCount
    - debian/patches/CVE-2015-8146.patch: check for valid isolateCount in
      source/common/ubidi.c.
    - CVE-2015-8146
  * SECURITY UPDATE: integer overflow via incorrect state size
    - debian/patches/CVE-2015-8147.patch: change state to int32_t in
      source/common/ubidiimp.h.
    - CVE-2015-8147

applied/ubuntu/utopic-security 2015-05-11 14:53:17 UTC 2015-05-11
Import patches-applied version 52.1-6ubuntu0.3 to applied/ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-05-08 12:49:12 UTC

Import patches-applied version 52.1-6ubuntu0.3 to applied/ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: 225954c0847f6daed1bb2948c5cb3a3e3ed8dd98
Unapplied parent: a84a0ff729e1da23c23a0eb6f08996d142ef43f1

New changelog entries:
  * SECURITY UPDATE: heap overflow via incorrect isolateCount
    - debian/patches/CVE-2015-8146.patch: check for valid isolateCount in
      source/common/ubidi.c.
    - CVE-2015-8146
  * SECURITY UPDATE: integer overflow via incorrect state size
    - debian/patches/CVE-2015-8147.patch: change state to int32_t in
      source/common/ubidiimp.h.
    - CVE-2015-8147

ubuntu/utopic-devel 2015-05-11 14:53:17 UTC 2015-05-11
Import patches-unapplied version 52.1-6ubuntu0.3 to ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-05-08 12:49:12 UTC

Import patches-unapplied version 52.1-6ubuntu0.3 to ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: deab7f45b0b1ae7f6f7a7c36810106ffc6625397

New changelog entries:
  * SECURITY UPDATE: heap overflow via incorrect isolateCount
    - debian/patches/CVE-2015-8146.patch: check for valid isolateCount in
      source/common/ubidi.c.
    - CVE-2015-8146
  * SECURITY UPDATE: integer overflow via incorrect state size
    - debian/patches/CVE-2015-8147.patch: change state to int32_t in
      source/common/ubidiimp.h.
    - CVE-2015-8147

ubuntu/utopic-updates 2015-05-11 14:53:17 UTC 2015-05-11
Import patches-unapplied version 52.1-6ubuntu0.3 to ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-05-08 12:49:12 UTC

Import patches-unapplied version 52.1-6ubuntu0.3 to ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: deab7f45b0b1ae7f6f7a7c36810106ffc6625397

New changelog entries:
  * SECURITY UPDATE: heap overflow via incorrect isolateCount
    - debian/patches/CVE-2015-8146.patch: check for valid isolateCount in
      source/common/ubidi.c.
    - CVE-2015-8146
  * SECURITY UPDATE: integer overflow via incorrect state size
    - debian/patches/CVE-2015-8147.patch: change state to int32_t in
      source/common/ubidiimp.h.
    - CVE-2015-8147

ubuntu/utopic-security 2015-05-11 14:53:17 UTC 2015-05-11
Import patches-unapplied version 52.1-6ubuntu0.3 to ubuntu/utopic-security

Author: Marc Deslauriers
Author Date: 2015-05-08 12:49:12 UTC

Import patches-unapplied version 52.1-6ubuntu0.3 to ubuntu/utopic-security

Imported using git-ubuntu import.

Changelog parent: deab7f45b0b1ae7f6f7a7c36810106ffc6625397

New changelog entries:
  * SECURITY UPDATE: heap overflow via incorrect isolateCount
    - debian/patches/CVE-2015-8146.patch: check for valid isolateCount in
      source/common/ubidi.c.
    - CVE-2015-8146
  * SECURITY UPDATE: integer overflow via incorrect state size
    - debian/patches/CVE-2015-8147.patch: change state to int32_t in
      source/common/ubidiimp.h.
    - CVE-2015-8147

ubuntu/vivid 2015-03-17 22:13:35 UTC 2015-03-17
Import patches-unapplied version 52.1-8 to debian/sid

Author: Laszlo Boszormenyi
Author Date: 2015-03-17 11:14:15 UTC

Import patches-unapplied version 52.1-8 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a1a112bd8e89dbf82fd7438caf2d0bfb6f1c978d

New changelog entries:
  * New maintainer (closes: #777694).
  * Update Standars-Version to 3.9.6 .
  [ Michael Gilbert <mgilbert@debian.org> ]
  * Apply a more complete fix for CVE-2014-7940 (closes: #780503).
    - Thanks to Marc Deslauriers.

applied/ubuntu/vivid 2015-03-17 22:13:35 UTC 2015-03-17
Import patches-applied version 52.1-8 to applied/debian/sid

Author: Laszlo Boszormenyi
Author Date: 2015-03-17 11:14:15 UTC

Import patches-applied version 52.1-8 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 22d73f699df9881fbfd222d0eee25c759af3f617
Unapplied parent: bd753f4ccd7d6f76d8ef8635229abd977fccb70c

New changelog entries:
  * New maintainer (closes: #777694).
  * Update Standars-Version to 3.9.6 .
  [ Michael Gilbert <mgilbert@debian.org> ]
  * Apply a more complete fix for CVE-2014-7940 (closes: #780503).
    - Thanks to Marc Deslauriers.

ubuntu/vivid-proposed 2015-03-17 22:13:35 UTC 2015-03-17
Import patches-unapplied version 52.1-8 to debian/sid

Author: Laszlo Boszormenyi
Author Date: 2015-03-17 11:14:15 UTC

Import patches-unapplied version 52.1-8 to debian/sid

Imported using git-ubuntu import.

Changelog parent: a1a112bd8e89dbf82fd7438caf2d0bfb6f1c978d

New changelog entries:
  * New maintainer (closes: #777694).
  * Update Standars-Version to 3.9.6 .
  [ Michael Gilbert <mgilbert@debian.org> ]
  * Apply a more complete fix for CVE-2014-7940 (closes: #780503).
    - Thanks to Marc Deslauriers.

applied/ubuntu/vivid-proposed 2015-03-17 22:13:35 UTC 2015-03-17
Import patches-applied version 52.1-8 to applied/debian/sid

Author: Laszlo Boszormenyi
Author Date: 2015-03-17 11:14:15 UTC

Import patches-applied version 52.1-8 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 22d73f699df9881fbfd222d0eee25c759af3f617
Unapplied parent: bd753f4ccd7d6f76d8ef8635229abd977fccb70c

New changelog entries:
  * New maintainer (closes: #777694).
  * Update Standars-Version to 3.9.6 .
  [ Michael Gilbert <mgilbert@debian.org> ]
  * Apply a more complete fix for CVE-2014-7940 (closes: #780503).
    - Thanks to Marc Deslauriers.

ubuntu/utopic 2014-09-29 22:17:55 UTC 2014-09-29
Import patches-unapplied version 52.1-6 to debian/sid

Author: Jay Berkenbilt
Author Date: 2014-09-29 13:59:09 UTC

Import patches-unapplied version 52.1-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 994e4c66bc3f46f0d115d2489cf9802d8897239c

New changelog entries:
  * Ensure that only flags intended to be set by users make it into
    icu-config. Previously hardening flags were sneaking in there.
    (Closes: #759792)

applied/ubuntu/utopic-proposed 2014-09-29 22:17:55 UTC 2014-09-29
Import patches-applied version 52.1-6 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2014-09-29 13:59:09 UTC

Import patches-applied version 52.1-6 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e98e01a6cd1c9536c75f83c1fca3e2b708c413bf
Unapplied parent: e6f1a03bbcce4db6c7a4d49280c8b4cd94a3b5f7

New changelog entries:
  * Ensure that only flags intended to be set by users make it into
    icu-config. Previously hardening flags were sneaking in there.
    (Closes: #759792)

ubuntu/utopic-proposed 2014-09-29 22:17:55 UTC 2014-09-29
Import patches-unapplied version 52.1-6 to debian/sid

Author: Jay Berkenbilt
Author Date: 2014-09-29 13:59:09 UTC

Import patches-unapplied version 52.1-6 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 994e4c66bc3f46f0d115d2489cf9802d8897239c

New changelog entries:
  * Ensure that only flags intended to be set by users make it into
    icu-config. Previously hardening flags were sneaking in there.
    (Closes: #759792)

applied/ubuntu/utopic 2014-09-29 22:17:55 UTC 2014-09-29
Import patches-applied version 52.1-6 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2014-09-29 13:59:09 UTC

Import patches-applied version 52.1-6 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e98e01a6cd1c9536c75f83c1fca3e2b708c413bf
Unapplied parent: e6f1a03bbcce4db6c7a4d49280c8b4cd94a3b5f7

New changelog entries:
  * Ensure that only flags intended to be set by users make it into
    icu-config. Previously hardening flags were sneaking in there.
    (Closes: #759792)

applied/debian/squeeze 2014-02-15 16:46:02 UTC 2014-02-15
Import patches-applied version 4.4.1-8+squeeze2 to applied/debian/squeeze

Author: Michael Gilbert
Author Date: 2013-10-27 04:40:46 UTC

Import patches-applied version 4.4.1-8+squeeze2 to applied/debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 9aac1abbdd8f117eb5dc59ac34eb5c49b88142b2
Unapplied parent: 5ff6b03aa1089ca88baa0aa70feaf7288a371b21

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Fix cve-2013-0900: race condition in locid.cpp.
  * Fix cve-2013-2924: use-after-free issue in csrucode.cpp.

debian/squeeze 2014-02-15 16:46:02 UTC 2014-02-15
Import patches-unapplied version 4.4.1-8+squeeze2 to debian/squeeze

Author: Michael Gilbert
Author Date: 2013-10-27 04:40:46 UTC

Import patches-unapplied version 4.4.1-8+squeeze2 to debian/squeeze

Imported using git-ubuntu import.

Changelog parent: 3525be67f08c06057a916a67081450d05fc3f025

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Fix cve-2013-0900: race condition in locid.cpp.
  * Fix cve-2013-2924: use-after-free issue in csrucode.cpp.

ubuntu/trusty-proposed 2013-12-24 22:12:39 UTC 2013-12-24
Import patches-unapplied version 52.1-3 to debian/sid

Author: Jay Berkenbilt
Author Date: 2013-12-24 16:45:03 UTC

Import patches-unapplied version 52.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dab23cc1c299b562541aeafe317f6341647c2a18

New changelog entries:
  * Add package dependency information to assist with upgrades in Ubuntu.
    This eliminates the need for a delta on the Ubuntu version of the
    package.

applied/ubuntu/trusty 2013-12-24 22:12:39 UTC 2013-12-24
Import patches-applied version 52.1-3 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2013-12-24 16:45:03 UTC

Import patches-applied version 52.1-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 09ccf01a23f5f1ac59e3460e021767155de57c33
Unapplied parent: 966537e51f2027d8ec950737049458b9415a73cf

New changelog entries:
  * Add package dependency information to assist with upgrades in Ubuntu.
    This eliminates the need for a delta on the Ubuntu version of the
    package.

applied/ubuntu/trusty-proposed 2013-12-24 22:12:39 UTC 2013-12-24
Import patches-applied version 52.1-3 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2013-12-24 16:45:03 UTC

Import patches-applied version 52.1-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 09ccf01a23f5f1ac59e3460e021767155de57c33
Unapplied parent: 966537e51f2027d8ec950737049458b9415a73cf

New changelog entries:
  * Add package dependency information to assist with upgrades in Ubuntu.
    This eliminates the need for a delta on the Ubuntu version of the
    package.

ubuntu/trusty 2013-12-24 22:12:39 UTC 2013-12-24
Import patches-unapplied version 52.1-3 to debian/sid

Author: Jay Berkenbilt
Author Date: 2013-12-24 16:45:03 UTC

Import patches-unapplied version 52.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dab23cc1c299b562541aeafe317f6341647c2a18

New changelog entries:
  * Add package dependency information to assist with upgrades in Ubuntu.
    This eliminates the need for a delta on the Ubuntu version of the
    package.

applied/ubuntu/raring-updates 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-applied version 4.8.1.1-12ubuntu0.1 to applied/ubuntu/raring-s...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:31:53 UTC

Import patches-applied version 4.8.1.1-12ubuntu0.1 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 9ccc1f049366a99afae9b7f4fc76ca39d43b5f93
Unapplied parent: 6f4c83abfd2c89ca098b3e72be705b7b01684a09

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/raring-security 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-applied version 4.8.1.1-12ubuntu0.1 to applied/ubuntu/raring-s...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:31:53 UTC

Import patches-applied version 4.8.1.1-12ubuntu0.1 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 9ccc1f049366a99afae9b7f4fc76ca39d43b5f93
Unapplied parent: 6f4c83abfd2c89ca098b3e72be705b7b01684a09

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/raring-devel 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-unapplied version 4.8.1.1-12ubuntu0.1 to ubuntu/raring-security

Author: Marc Deslauriers
Author Date: 2013-10-10 14:31:53 UTC

Import patches-unapplied version 4.8.1.1-12ubuntu0.1 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 845ba2f4e7e37fe3b09fa9c9f2c7ef4abf1e6610

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/raring-security 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-unapplied version 4.8.1.1-12ubuntu0.1 to ubuntu/raring-security

Author: Marc Deslauriers
Author Date: 2013-10-10 14:31:53 UTC

Import patches-unapplied version 4.8.1.1-12ubuntu0.1 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 845ba2f4e7e37fe3b09fa9c9f2c7ef4abf1e6610

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/quantal-updates 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-applied version 4.8.1.1-8ubuntu0.1 to applied/ubuntu/quantal-s...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:33:37 UTC

Import patches-applied version 4.8.1.1-8ubuntu0.1 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 65afb63e6a6489e2509b71a8bc55d14d7adbf115
Unapplied parent: d9a60dcdf3579c8e24b80576141bfb0a2fab8e47

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    race condition.
    - debian/patches/CVE-2013-0900.patch: fix thread safety issue in
      source/common/locid.cpp, source/common/unicode/locid.h.
    - CVE-2013-0900
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/quantal-security 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-applied version 4.8.1.1-8ubuntu0.1 to applied/ubuntu/quantal-s...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:33:37 UTC

Import patches-applied version 4.8.1.1-8ubuntu0.1 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 65afb63e6a6489e2509b71a8bc55d14d7adbf115
Unapplied parent: d9a60dcdf3579c8e24b80576141bfb0a2fab8e47

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    race condition.
    - debian/patches/CVE-2013-0900.patch: fix thread safety issue in
      source/common/locid.cpp, source/common/unicode/locid.h.
    - CVE-2013-0900
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/raring-updates 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-unapplied version 4.8.1.1-12ubuntu0.1 to ubuntu/raring-security

Author: Marc Deslauriers
Author Date: 2013-10-10 14:31:53 UTC

Import patches-unapplied version 4.8.1.1-12ubuntu0.1 to ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 845ba2f4e7e37fe3b09fa9c9f2c7ef4abf1e6610

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/quantal-devel 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-applied version 4.8.1.1-8ubuntu0.1 to applied/ubuntu/quantal-s...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:33:37 UTC

Import patches-applied version 4.8.1.1-8ubuntu0.1 to applied/ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 65afb63e6a6489e2509b71a8bc55d14d7adbf115
Unapplied parent: d9a60dcdf3579c8e24b80576141bfb0a2fab8e47

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    race condition.
    - debian/patches/CVE-2013-0900.patch: fix thread safety issue in
      source/common/locid.cpp, source/common/unicode/locid.h.
    - CVE-2013-0900
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/quantal-updates 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-unapplied version 4.8.1.1-8ubuntu0.1 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-10-10 14:33:37 UTC

Import patches-unapplied version 4.8.1.1-8ubuntu0.1 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 8f6ccba86f360016331a8458bd080cabf6e61bed

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    race condition.
    - debian/patches/CVE-2013-0900.patch: fix thread safety issue in
      source/common/locid.cpp, source/common/unicode/locid.h.
    - CVE-2013-0900
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/raring-devel 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-applied version 4.8.1.1-12ubuntu0.1 to applied/ubuntu/raring-s...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:31:53 UTC

Import patches-applied version 4.8.1.1-12ubuntu0.1 to applied/ubuntu/raring-security

Imported using git-ubuntu import.

Changelog parent: 9ccc1f049366a99afae9b7f4fc76ca39d43b5f93
Unapplied parent: 6f4c83abfd2c89ca098b3e72be705b7b01684a09

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/quantal-security 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-unapplied version 4.8.1.1-8ubuntu0.1 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-10-10 14:33:37 UTC

Import patches-unapplied version 4.8.1.1-8ubuntu0.1 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 8f6ccba86f360016331a8458bd080cabf6e61bed

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    race condition.
    - debian/patches/CVE-2013-0900.patch: fix thread safety issue in
      source/common/locid.cpp, source/common/unicode/locid.h.
    - CVE-2013-0900
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/quantal-devel 2013-10-15 16:58:21 UTC 2013-10-15
Import patches-unapplied version 4.8.1.1-8ubuntu0.1 to ubuntu/quantal-security

Author: Marc Deslauriers
Author Date: 2013-10-10 14:33:37 UTC

Import patches-unapplied version 4.8.1.1-8ubuntu0.1 to ubuntu/quantal-security

Imported using git-ubuntu import.

Changelog parent: 8f6ccba86f360016331a8458bd080cabf6e61bed

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    race condition.
    - debian/patches/CVE-2013-0900.patch: fix thread safety issue in
      source/common/locid.cpp, source/common/unicode/locid.h.
    - CVE-2013-0900
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/saucy 2013-10-10 19:48:26 UTC 2013-10-10
Import patches-applied version 4.8.1.1-12ubuntu2 to applied/ubuntu/saucy-prop...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:28:18 UTC

Import patches-applied version 4.8.1.1-12ubuntu2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 38f55718faf206b8ab23a48a1ffcdc68ecb9f0b0
Unapplied parent: 9f92424c6ebc57cee7cceb395e684d17107e43b1

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/saucy-devel 2013-10-10 19:48:26 UTC 2013-10-10
Import patches-applied version 4.8.1.1-12ubuntu2 to applied/ubuntu/saucy-prop...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:28:18 UTC

Import patches-applied version 4.8.1.1-12ubuntu2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 38f55718faf206b8ab23a48a1ffcdc68ecb9f0b0
Unapplied parent: 9f92424c6ebc57cee7cceb395e684d17107e43b1

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/saucy 2013-10-10 19:48:26 UTC 2013-10-10
Import patches-unapplied version 4.8.1.1-12ubuntu2 to ubuntu/saucy-proposed

Author: Marc Deslauriers
Author Date: 2013-10-10 14:28:18 UTC

Import patches-unapplied version 4.8.1.1-12ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 02278947246bf7914db3e7d1b4e60d6ea4b1c564

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/saucy-proposed 2013-10-10 19:48:26 UTC 2013-10-10
Import patches-applied version 4.8.1.1-12ubuntu2 to applied/ubuntu/saucy-prop...

Author: Marc Deslauriers
Author Date: 2013-10-10 14:28:18 UTC

Import patches-applied version 4.8.1.1-12ubuntu2 to applied/ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 38f55718faf206b8ab23a48a1ffcdc68ecb9f0b0
Unapplied parent: 9f92424c6ebc57cee7cceb395e684d17107e43b1

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/saucy-proposed 2013-10-10 19:48:26 UTC 2013-10-10
Import patches-unapplied version 4.8.1.1-12ubuntu2 to ubuntu/saucy-proposed

Author: Marc Deslauriers
Author Date: 2013-10-10 14:28:18 UTC

Import patches-unapplied version 4.8.1.1-12ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 02278947246bf7914db3e7d1b4e60d6ea4b1c564

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

ubuntu/saucy-devel 2013-10-10 19:48:26 UTC 2013-10-10
Import patches-unapplied version 4.8.1.1-12ubuntu2 to ubuntu/saucy-proposed

Author: Marc Deslauriers
Author Date: 2013-10-10 14:28:18 UTC

Import patches-unapplied version 4.8.1.1-12ubuntu2 to ubuntu/saucy-proposed

Imported using git-ubuntu import.

Changelog parent: 02278947246bf7914db3e7d1b4e60d6ea4b1c564

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    use after free.
    - debian/patches/CVE-2013-2924.patch: check lengths in
      source/i18n/csrucode.cpp.
    - CVE-2013-2924

applied/ubuntu/raring 2013-03-21 22:18:37 UTC 2013-03-21
Import patches-applied version 4.8.1.1-12 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2013-03-21 15:29:08 UTC

Import patches-applied version 4.8.1.1-12 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 30abc0517e98ee7ed3ef953b2ad29a5c55b76f8a
Unapplied parent: d7c1c9cdc232ac0cc94d92cda3560e4bd573ed96

New changelog entries:
  * Add patch to address CVE-2013-0900, a threading race condition.
    (Closes: #702346)

ubuntu/raring-proposed 2013-03-21 22:18:37 UTC 2013-03-21
Import patches-unapplied version 4.8.1.1-12 to debian/sid

Author: Jay Berkenbilt
Author Date: 2013-03-21 15:29:08 UTC

Import patches-unapplied version 4.8.1.1-12 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dfddb4507ea47f96187926814fd0314378868054

New changelog entries:
  * Add patch to address CVE-2013-0900, a threading race condition.
    (Closes: #702346)

applied/ubuntu/raring-proposed 2013-03-21 22:18:37 UTC 2013-03-21
Import patches-applied version 4.8.1.1-12 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2013-03-21 15:29:08 UTC

Import patches-applied version 4.8.1.1-12 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 30abc0517e98ee7ed3ef953b2ad29a5c55b76f8a
Unapplied parent: d7c1c9cdc232ac0cc94d92cda3560e4bd573ed96

New changelog entries:
  * Add patch to address CVE-2013-0900, a threading race condition.
    (Closes: #702346)

ubuntu/raring 2013-03-21 22:18:37 UTC 2013-03-21
Import patches-unapplied version 4.8.1.1-12 to debian/sid

Author: Jay Berkenbilt
Author Date: 2013-03-21 15:29:08 UTC

Import patches-unapplied version 4.8.1.1-12 to debian/sid

Imported using git-ubuntu import.

Changelog parent: dfddb4507ea47f96187926814fd0314378868054

New changelog entries:
  * Add patch to address CVE-2013-0900, a threading race condition.
    (Closes: #702346)

applied/ubuntu/quantal 2012-06-05 22:20:50 UTC 2012-06-05
Import patches-applied version 4.8.1.1-8 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2012-06-05 18:27:27 UTC

Import patches-applied version 4.8.1.1-8 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: ec140ec7b0c0ac78f0dee86a530fed0632485ffb
Unapplied parent: cf567e4e9de70fc57568af51eebea07a5c21145b

New changelog entries:
  * Switch hardening back to hardening-wrapper again since otherwise some
    things sneak into icu-config's output.

ubuntu/quantal 2012-06-05 22:20:50 UTC 2012-06-05
Import patches-unapplied version 4.8.1.1-8 to debian/sid

Author: Jay Berkenbilt
Author Date: 2012-06-05 18:27:27 UTC

Import patches-unapplied version 4.8.1.1-8 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1c94533c070c223f4cb75712fc5fca5f395bc69f

New changelog entries:
  * Switch hardening back to hardening-wrapper again since otherwise some
    things sneak into icu-config's output.

debian/lenny 2012-03-10 15:12:31 UTC 2012-03-10
Import patches-unapplied version 3.8.1-3+lenny3 to debian/lenny

Author: Jay Berkenbilt
Author Date: 2012-01-22 00:56:44 UTC

Import patches-unapplied version 3.8.1-3+lenny3 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: f87415274a91197bcd43703dac0e8a7a72c0d0cb

New changelog entries:
  * Apply patch CVE-2011-4599 to address a buffer overflow.

applied/debian/lenny 2012-03-10 15:12:31 UTC 2012-03-10
Import patches-applied version 3.8.1-3+lenny3 to applied/debian/lenny

Author: Jay Berkenbilt
Author Date: 2012-01-22 00:56:44 UTC

Import patches-applied version 3.8.1-3+lenny3 to applied/debian/lenny

Imported using git-ubuntu import.

Changelog parent: d40ac7acd30c0b4b891a16f1e776eac1065ab1ae
Unapplied parent: 64baa77a593c58a029341cf2e1d84a89c5e6f515

New changelog entries:
  * Apply patch CVE-2011-4599 to address a buffer overflow.

ubuntu/oneiric-devel 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.4.2-2ubuntu0.11.10.1 to ubuntu/oneiric-sec...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:21:17 UTC

Import patches-unapplied version 4.4.2-2ubuntu0.11.10.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: ddd3ea85ae6842568e25fed49a348e511c3ead37

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/oneiric-security 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.4.2-2ubuntu0.11.10.1 to ubuntu/oneiric-sec...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:21:17 UTC

Import patches-unapplied version 4.4.2-2ubuntu0.11.10.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: ddd3ea85ae6842568e25fed49a348e511c3ead37

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/oneiric-updates 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.4.2-2ubuntu0.11.10.1 to ubuntu/oneiric-sec...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:21:17 UTC

Import patches-unapplied version 4.4.2-2ubuntu0.11.10.1 to ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: ddd3ea85ae6842568e25fed49a348e511c3ead37

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/oneiric-updates 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.4.2-2ubuntu0.11.10.1 to applied/ubuntu/oneir...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:21:17 UTC

Import patches-applied version 4.4.2-2ubuntu0.11.10.1 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 0798df62fb87d61a3ff1fee8bd68a873059d71f8
Unapplied parent: cf0d298665540002157f661f5123ce1320942d08

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/oneiric-security 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.4.2-2ubuntu0.11.10.1 to applied/ubuntu/oneir...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:21:17 UTC

Import patches-applied version 4.4.2-2ubuntu0.11.10.1 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 0798df62fb87d61a3ff1fee8bd68a873059d71f8
Unapplied parent: cf0d298665540002157f661f5123ce1320942d08

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/oneiric-devel 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.4.2-2ubuntu0.11.10.1 to applied/ubuntu/oneir...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:21:17 UTC

Import patches-applied version 4.4.2-2ubuntu0.11.10.1 to applied/ubuntu/oneiric-security

Imported using git-ubuntu import.

Changelog parent: 0798df62fb87d61a3ff1fee8bd68a873059d71f8
Unapplied parent: cf0d298665540002157f661f5123ce1320942d08

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/natty-updates 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.4.2-2ubuntu0.11.04.1 to applied/ubuntu/natty...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:39:39 UTC

Import patches-applied version 4.4.2-2ubuntu0.11.04.1 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 0798df62fb87d61a3ff1fee8bd68a873059d71f8
Unapplied parent: 647b30ae0ed83b823a5dfdf375560e94a26bb11c

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/natty-security 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.4.2-2ubuntu0.11.04.1 to applied/ubuntu/natty...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:39:39 UTC

Import patches-applied version 4.4.2-2ubuntu0.11.04.1 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 0798df62fb87d61a3ff1fee8bd68a873059d71f8
Unapplied parent: 647b30ae0ed83b823a5dfdf375560e94a26bb11c

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/natty-devel 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.4.2-2ubuntu0.11.04.1 to applied/ubuntu/natty...

Author: Marc Deslauriers
Author Date: 2012-01-25 19:39:39 UTC

Import patches-applied version 4.4.2-2ubuntu0.11.04.1 to applied/ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: 0798df62fb87d61a3ff1fee8bd68a873059d71f8
Unapplied parent: 647b30ae0ed83b823a5dfdf375560e94a26bb11c

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/maverick-updates 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.2.1-3ubuntu0.10.10.1 to applied/ubuntu/maver...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:11:21 UTC

Import patches-applied version 4.2.1-3ubuntu0.10.10.1 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: b43ce50e09a904787598a4f9bb4f2587d47c18a7
Unapplied parent: fd480de663c12267479b916e107288cab1878cc9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/maverick-security 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.2.1-3ubuntu0.10.10.1 to applied/ubuntu/maver...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:11:21 UTC

Import patches-applied version 4.2.1-3ubuntu0.10.10.1 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: b43ce50e09a904787598a4f9bb4f2587d47c18a7
Unapplied parent: fd480de663c12267479b916e107288cab1878cc9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/maverick-devel 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.2.1-3ubuntu0.10.10.1 to applied/ubuntu/maver...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:11:21 UTC

Import patches-applied version 4.2.1-3ubuntu0.10.10.1 to applied/ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: b43ce50e09a904787598a4f9bb4f2587d47c18a7
Unapplied parent: fd480de663c12267479b916e107288cab1878cc9

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/lucid-updates 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.2.1-3ubuntu0.10.04.1 to applied/ubuntu/lucid...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:13:36 UTC

Import patches-applied version 4.2.1-3ubuntu0.10.04.1 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: b43ce50e09a904787598a4f9bb4f2587d47c18a7
Unapplied parent: c810b4376ca9ae4a4564ee01f8320b07c7cf2dbd

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/lucid-security 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.2.1-3ubuntu0.10.04.1 to applied/ubuntu/lucid...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:13:36 UTC

Import patches-applied version 4.2.1-3ubuntu0.10.04.1 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: b43ce50e09a904787598a4f9bb4f2587d47c18a7
Unapplied parent: c810b4376ca9ae4a4564ee01f8320b07c7cf2dbd

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

applied/ubuntu/lucid-devel 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-applied version 4.2.1-3ubuntu0.10.04.1 to applied/ubuntu/lucid...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:13:36 UTC

Import patches-applied version 4.2.1-3ubuntu0.10.04.1 to applied/ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: b43ce50e09a904787598a4f9bb4f2587d47c18a7
Unapplied parent: c810b4376ca9ae4a4564ee01f8320b07c7cf2dbd

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/lucid-devel 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.2.1-3ubuntu0.10.04.1 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2012-01-25 20:13:36 UTC

Import patches-unapplied version 4.2.1-3ubuntu0.10.04.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d1181d976b06e6bc7f69d58ec0b469fe83256cef

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/lucid-security 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.2.1-3ubuntu0.10.04.1 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2012-01-25 20:13:36 UTC

Import patches-unapplied version 4.2.1-3ubuntu0.10.04.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d1181d976b06e6bc7f69d58ec0b469fe83256cef

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/lucid-updates 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.2.1-3ubuntu0.10.04.1 to ubuntu/lucid-security

Author: Marc Deslauriers
Author Date: 2012-01-25 20:13:36 UTC

Import patches-unapplied version 4.2.1-3ubuntu0.10.04.1 to ubuntu/lucid-security

Imported using git-ubuntu import.

Changelog parent: d1181d976b06e6bc7f69d58ec0b469fe83256cef

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/maverick-devel 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.2.1-3ubuntu0.10.10.1 to ubuntu/maverick-se...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:11:21 UTC

Import patches-unapplied version 4.2.1-3ubuntu0.10.10.1 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: d1181d976b06e6bc7f69d58ec0b469fe83256cef

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/maverick-security 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.2.1-3ubuntu0.10.10.1 to ubuntu/maverick-se...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:11:21 UTC

Import patches-unapplied version 4.2.1-3ubuntu0.10.10.1 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: d1181d976b06e6bc7f69d58ec0b469fe83256cef

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/maverick-updates 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.2.1-3ubuntu0.10.10.1 to ubuntu/maverick-se...

Author: Marc Deslauriers
Author Date: 2012-01-25 20:11:21 UTC

Import patches-unapplied version 4.2.1-3ubuntu0.10.10.1 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: d1181d976b06e6bc7f69d58ec0b469fe83256cef

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/natty-devel 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.4.2-2ubuntu0.11.04.1 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2012-01-25 19:39:39 UTC

Import patches-unapplied version 4.4.2-2ubuntu0.11.04.1 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: ddd3ea85ae6842568e25fed49a348e511c3ead37

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/natty-security 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.4.2-2ubuntu0.11.04.1 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2012-01-25 19:39:39 UTC

Import patches-unapplied version 4.4.2-2ubuntu0.11.04.1 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: ddd3ea85ae6842568e25fed49a348e511c3ead37

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/natty-updates 2012-01-26 14:35:13 UTC 2012-01-26
Import patches-unapplied version 4.4.2-2ubuntu0.11.04.1 to ubuntu/natty-security

Author: Marc Deslauriers
Author Date: 2012-01-25 19:39:39 UTC

Import patches-unapplied version 4.4.2-2ubuntu0.11.04.1 to ubuntu/natty-security

Imported using git-ubuntu import.

Changelog parent: ddd3ea85ae6842568e25fed49a348e511c3ead37

New changelog entries:
  * SECURITY UPDATE: denial of service and possible code execution via
    out of bounds access
    - debian/patches/CVE-2011-4599.patch: add bounds checks in
      source/common/uloc.c.
    - CVE-2011-4599

ubuntu/precise 2012-01-23 21:25:21 UTC 2012-01-23
Import patches-unapplied version 4.8.1.1-3 to debian/sid

Author: Jay Berkenbilt
Author Date: 2012-01-22 00:44:44 UTC

Import patches-unapplied version 4.8.1.1-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: bd0cc5e48c8d708da375b378d3eab56df0ea314f

New changelog entries:
  * Add patch to address CVE-2011-4599, a potential buffer overflow.
    (Closes: #654883)

applied/ubuntu/precise 2012-01-23 21:25:21 UTC 2012-01-23
Import patches-applied version 4.8.1.1-3 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2012-01-22 00:44:44 UTC

Import patches-applied version 4.8.1.1-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 2340d7f954d15ca31e3a1d88ab131b5f63ba8530
Unapplied parent: 2d91f304355864d97befc2b15731df61950e411a

New changelog entries:
  * Add patch to address CVE-2011-4599, a potential buffer overflow.
    (Closes: #654883)

ubuntu/natty 2010-11-26 03:19:47 UTC 2010-11-26
Import patches-unapplied version 4.4.2-2 to debian/sid

Author: Jay Berkenbilt
Author Date: 2010-11-25 17:51:18 UTC

Import patches-unapplied version 4.4.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6dcf3d0dc52f52437363e16bbac5244e6f3413e5

New changelog entries:
  * Apply patch to fix Malayam rendering. (Closes: #591615)

applied/ubuntu/oneiric 2010-11-26 03:19:47 UTC 2010-11-26
Import patches-applied version 4.4.2-2 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2010-11-25 17:51:18 UTC

Import patches-applied version 4.4.2-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7168d3bb7b8fa1923b1bc46bef443b051a7ebe6c
Unapplied parent: bfa614578a9a1179624c68ac0b9dddeaffa01551

New changelog entries:
  * Apply patch to fix Malayam rendering. (Closes: #591615)

applied/ubuntu/natty 2010-11-26 03:19:47 UTC 2010-11-26
Import patches-applied version 4.4.2-2 to applied/debian/sid

Author: Jay Berkenbilt
Author Date: 2010-11-25 17:51:18 UTC

Import patches-applied version 4.4.2-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7168d3bb7b8fa1923b1bc46bef443b051a7ebe6c
Unapplied parent: bfa614578a9a1179624c68ac0b9dddeaffa01551

New changelog entries:
  * Apply patch to fix Malayam rendering. (Closes: #591615)

ubuntu/oneiric 2010-11-26 03:19:47 UTC 2010-11-26
Import patches-unapplied version 4.4.2-2 to debian/sid

Author: Jay Berkenbilt
Author Date: 2010-11-25 17:51:18 UTC

Import patches-unapplied version 4.4.2-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 6dcf3d0dc52f52437363e16bbac5244e6f3413e5

New changelog entries:
  * Apply patch to fix Malayam rendering. (Closes: #591615)

applied/ubuntu/karmic-devel 2009-10-22 20:09:26 UTC 2009-10-22
Import patches-applied version 4.0.1-2ubuntu2 to applied/ubuntu/karmic

Author: Loïc Minier
Author Date: 2009-10-21 12:45:37 UTC

Import patches-applied version 4.0.1-2ubuntu2 to applied/ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 7f7954b2c0da56b1a0e86c6c72cadef77e4b8b7b
Unapplied parent: 640cda89b13b22494dcfdd9ee2f85f6abac7b27c

New changelog entries:
  * No change rebuild to fix misbuilt binaries on armel.

applied/ubuntu/karmic 2009-10-22 20:09:26 UTC 2009-10-22
Import patches-applied version 4.0.1-2ubuntu2 to applied/ubuntu/karmic

Author: Loïc Minier
Author Date: 2009-10-21 12:45:37 UTC

Import patches-applied version 4.0.1-2ubuntu2 to applied/ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 7f7954b2c0da56b1a0e86c6c72cadef77e4b8b7b
Unapplied parent: 640cda89b13b22494dcfdd9ee2f85f6abac7b27c

New changelog entries:
  * No change rebuild to fix misbuilt binaries on armel.

ubuntu/karmic 2009-10-22 20:09:26 UTC 2009-10-22
Import patches-unapplied version 4.0.1-2ubuntu2 to ubuntu/karmic

Author: Loïc Minier
Author Date: 2009-10-21 12:45:37 UTC

Import patches-unapplied version 4.0.1-2ubuntu2 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 368a07060f288c2c594aabfbfc62153864cb4113

New changelog entries:
  * No change rebuild to fix misbuilt binaries on armel.

ubuntu/karmic-devel 2009-10-22 20:09:26 UTC 2009-10-22
Import patches-unapplied version 4.0.1-2ubuntu2 to ubuntu/karmic

Author: Loïc Minier
Author Date: 2009-10-21 12:45:37 UTC

Import patches-unapplied version 4.0.1-2ubuntu2 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: 368a07060f288c2c594aabfbfc62153864cb4113

New changelog entries:
  * No change rebuild to fix misbuilt binaries on armel.

applied/ubuntu/jaunty-security 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8.1-3ubuntu1.1 to applied/ubuntu/jaunty-secu...

Author: Jamie Strandboge
Author Date: 2009-10-07 15:29:13 UTC

Import patches-applied version 3.8.1-3ubuntu1.1 to applied/ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: 25313884bf8f6dd257fefb516a23fff61a68eaf5
Unapplied parent: a65653daff26e3cfa942d76a1c2513226f42c440

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

applied/ubuntu/jaunty-devel 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8.1-3ubuntu1.1 to applied/ubuntu/jaunty-secu...

Author: Jamie Strandboge
Author Date: 2009-10-07 15:29:13 UTC

Import patches-applied version 3.8.1-3ubuntu1.1 to applied/ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: 25313884bf8f6dd257fefb516a23fff61a68eaf5
Unapplied parent: a65653daff26e3cfa942d76a1c2513226f42c440

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

applied/ubuntu/intrepid-updates 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8.1-2ubuntu0.2 to applied/ubuntu/intrepid-se...

Author: Jamie Strandboge
Author Date: 2009-10-07 15:52:20 UTC

Import patches-applied version 3.8.1-2ubuntu0.2 to applied/ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: fa517570858773155d5a9002df91e01c7ebf262c
Unapplied parent: f232bde5b5665682d9eb48fab106d67c0d3eed54

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

applied/ubuntu/intrepid-security 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8.1-2ubuntu0.2 to applied/ubuntu/intrepid-se...

Author: Jamie Strandboge
Author Date: 2009-10-07 15:52:20 UTC

Import patches-applied version 3.8.1-2ubuntu0.2 to applied/ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: fa517570858773155d5a9002df91e01c7ebf262c
Unapplied parent: f232bde5b5665682d9eb48fab106d67c0d3eed54

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

applied/ubuntu/intrepid-devel 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8.1-2ubuntu0.2 to applied/ubuntu/intrepid-se...

Author: Jamie Strandboge
Author Date: 2009-10-07 15:52:20 UTC

Import patches-applied version 3.8.1-2ubuntu0.2 to applied/ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: fa517570858773155d5a9002df91e01c7ebf262c
Unapplied parent: f232bde5b5665682d9eb48fab106d67c0d3eed54

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

applied/ubuntu/hardy-updates 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8-6ubuntu0.2 to applied/ubuntu/hardy-security

Author: Jamie Strandboge
Author Date: 2009-10-07 16:33:48 UTC

Import patches-applied version 3.8-6ubuntu0.2 to applied/ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 34465cfe9d3277f41719f77e022c0752523c3b7a
Unapplied parent: 71f707965c5a40d48550218395db4eeecf8cce27

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

applied/ubuntu/hardy-security 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8-6ubuntu0.2 to applied/ubuntu/hardy-security

Author: Jamie Strandboge
Author Date: 2009-10-07 16:33:48 UTC

Import patches-applied version 3.8-6ubuntu0.2 to applied/ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 34465cfe9d3277f41719f77e022c0752523c3b7a
Unapplied parent: 71f707965c5a40d48550218395db4eeecf8cce27

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

ubuntu/hardy-devel 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-unapplied version 3.8-6ubuntu0.2 to ubuntu/hardy-security

Author: Jamie Strandboge
Author Date: 2009-10-07 16:33:48 UTC

Import patches-unapplied version 3.8-6ubuntu0.2 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 9aed81b5e3fb19cc3464ca0805cbec4d229cd746

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

applied/ubuntu/hardy-devel 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8-6ubuntu0.2 to applied/ubuntu/hardy-security

Author: Jamie Strandboge
Author Date: 2009-10-07 16:33:48 UTC

Import patches-applied version 3.8-6ubuntu0.2 to applied/ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 34465cfe9d3277f41719f77e022c0752523c3b7a
Unapplied parent: 71f707965c5a40d48550218395db4eeecf8cce27

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

ubuntu/hardy-security 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-unapplied version 3.8-6ubuntu0.2 to ubuntu/hardy-security

Author: Jamie Strandboge
Author Date: 2009-10-07 16:33:48 UTC

Import patches-unapplied version 3.8-6ubuntu0.2 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 9aed81b5e3fb19cc3464ca0805cbec4d229cd746

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

ubuntu/hardy-updates 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-unapplied version 3.8-6ubuntu0.2 to ubuntu/hardy-security

Author: Jamie Strandboge
Author Date: 2009-10-07 16:33:48 UTC

Import patches-unapplied version 3.8-6ubuntu0.2 to ubuntu/hardy-security

Imported using git-ubuntu import.

Changelog parent: 9aed81b5e3fb19cc3464ca0805cbec4d229cd746

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

applied/ubuntu/jaunty-updates 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-applied version 3.8.1-3ubuntu1.1 to applied/ubuntu/jaunty-secu...

Author: Jamie Strandboge
Author Date: 2009-10-07 15:29:13 UTC

Import patches-applied version 3.8.1-3ubuntu1.1 to applied/ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: 25313884bf8f6dd257fefb516a23fff61a68eaf5
Unapplied parent: a65653daff26e3cfa942d76a1c2513226f42c440

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

ubuntu/intrepid-devel 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-unapplied version 3.8.1-2ubuntu0.2 to ubuntu/intrepid-security

Author: Jamie Strandboge
Author Date: 2009-10-07 15:52:20 UTC

Import patches-unapplied version 3.8.1-2ubuntu0.2 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 4386b20362e35418ce157791b86473c8a1e96532

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

ubuntu/intrepid-security 2009-10-08 18:05:28 UTC 2009-10-08
Import patches-unapplied version 3.8.1-2ubuntu0.2 to ubuntu/intrepid-security

Author: Jamie Strandboge
Author Date: 2009-10-07 15:52:20 UTC

Import patches-unapplied version 3.8.1-2ubuntu0.2 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: 4386b20362e35418ce157791b86473c8a1e96532

New changelog entries:
  * SECURITY UPDATE: fix improper handling of invalid byte sequences
    during Unicode conversion
    - debian/07-CVE-2009-0153.patch: backported patch thanks to RedHat via
      Debian
    - 03-redhat.icu5797.patch, 04-redhat.icu6001.patch, and
      05-redhat.icu6002.patch required for applying 07-CVE-2009-0153.patch
      with 06-CVE-2008-1036.patch needing adjustments. Patch from Debian.
    - CVE-2009-0153

101200 of 258 results

Other repositories

Name Last Modified
lp:ubuntu/+source/icu 2019-08-07
11 of 1 result
You can't create new repositories for icu in Ubuntu.