View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/gpsd
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2019-10-26 00:07:48 UTC 2019-10-26
DSC file for 3.19-2

Author: Ubuntu Git Importer
Author Date: 2019-10-26 00:07:48 UTC

DSC file for 3.19-2

importer/debian/dsc 2019-10-14 04:36:40 UTC 2019-10-14
DSC file for 3.19-2

Author: Ubuntu Git Importer
Author Date: 2019-10-14 04:36:40 UTC

DSC file for 3.19-2

ubuntu/focal-devel 2019-10-14 04:30:57 UTC 2019-10-14
Import patches-unapplied version 3.19-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-10-13 19:56:20 UTC

Import patches-unapplied version 3.19-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9a0fd35970cf658a13f284c97050eeda2adcc5d6

New changelog entries:
  * [06ae5582] Add debian/.gitlab-ci.yml
  * [b200620e] Update Vcs-Git Urls
  * [1991f99e] git is not available on buildds.
  * [809c6c4a] Remove weird env flag overrides
  * [85c4fbb7] snapshot changelog
  * [24e0be41] try again
  * [ede12b7b] Merge branch 'master' of salsa.debian.org:debian-gps-team/pkg-gpsd
  * [29fe8717] Remove options only used by the init script.
  * [0232f523] Scons ignores hardening-flags and others, try this.
  * [d163bdcd] Revert "Scons ignores hardening-flags and others, try this."
    This reverts commit 0232f52302f65f545118f653f787daf2429d0c0a.
  * [27d27ef5] A better try to fix scons env handling
  * [fc43714a] More fixes for the env-handling.
  * [9b34a869] Fix the broken fix
  * [6fd99707] Also merge CFLAGS/CXXFLAGS/...
  * [200cf80c] Also try to fix python cflags handling
  * [0dd50707] Use python3 for default scons things.
    After building the first version with python 3, the pickle version of
    the cached scons data will be too old.
  * [bbf652ee] Remove python2 support.
    Building both python versions got impossible since recent python3
    versions use a new picke version and scons stores its state in a pickle
    file...
  * [8eee1d20] Also remove dependencies on python-gps
  * [e3b30066] Updating debian/control from debian/control.in
  * [0332c8e5] Remove duplicate build-deps
  * [62b43a57] Updating changelog
  * [a8bbbce5] Use python3 for gpsd-clients
  * [288e9075] gpsd-clients breaks/replaces python-gps
  * [2f21db33] use aptly
  * [fd092a4d] Use python3-gi instead of python3-gtk
  * [0be9eebd] changes need to go into control.in
  * [a620b1d5] Depend on python3
  * [cbf832dd] Updating debian/control from debian/control.in

applied/debian/sid 2019-10-14 04:30:57 UTC 2019-10-14
Import patches-applied version 3.19-2 to applied/debian/sid

Author: Bernd Zeimetz
Author Date: 2019-10-13 19:56:20 UTC

Import patches-applied version 3.19-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7a6181d6848de4b6a31542eae7dfdf6c22c42532
Unapplied parent: 94c0863a668be3a35a36376aa15983de5f655395

New changelog entries:
  * [06ae5582] Add debian/.gitlab-ci.yml
  * [b200620e] Update Vcs-Git Urls
  * [1991f99e] git is not available on buildds.
  * [809c6c4a] Remove weird env flag overrides
  * [85c4fbb7] snapshot changelog
  * [24e0be41] try again
  * [ede12b7b] Merge branch 'master' of salsa.debian.org:debian-gps-team/pkg-gpsd
  * [29fe8717] Remove options only used by the init script.
  * [0232f523] Scons ignores hardening-flags and others, try this.
  * [d163bdcd] Revert "Scons ignores hardening-flags and others, try this."
    This reverts commit 0232f52302f65f545118f653f787daf2429d0c0a.
  * [27d27ef5] A better try to fix scons env handling
  * [fc43714a] More fixes for the env-handling.
  * [9b34a869] Fix the broken fix
  * [6fd99707] Also merge CFLAGS/CXXFLAGS/...
  * [200cf80c] Also try to fix python cflags handling
  * [0dd50707] Use python3 for default scons things.
    After building the first version with python 3, the pickle version of
    the cached scons data will be too old.
  * [bbf652ee] Remove python2 support.
    Building both python versions got impossible since recent python3
    versions use a new picke version and scons stores its state in a pickle
    file...
  * [8eee1d20] Also remove dependencies on python-gps
  * [e3b30066] Updating debian/control from debian/control.in
  * [0332c8e5] Remove duplicate build-deps
  * [62b43a57] Updating changelog
  * [a8bbbce5] Use python3 for gpsd-clients
  * [288e9075] gpsd-clients breaks/replaces python-gps
  * [2f21db33] use aptly
  * [fd092a4d] Use python3-gi instead of python3-gtk
  * [0be9eebd] changes need to go into control.in
  * [a620b1d5] Depend on python3
  * [cbf832dd] Updating debian/control from debian/control.in

ubuntu/devel 2019-10-14 04:30:57 UTC 2019-10-14
Import patches-unapplied version 3.19-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-10-13 19:56:20 UTC

Import patches-unapplied version 3.19-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9a0fd35970cf658a13f284c97050eeda2adcc5d6

New changelog entries:
  * [06ae5582] Add debian/.gitlab-ci.yml
  * [b200620e] Update Vcs-Git Urls
  * [1991f99e] git is not available on buildds.
  * [809c6c4a] Remove weird env flag overrides
  * [85c4fbb7] snapshot changelog
  * [24e0be41] try again
  * [ede12b7b] Merge branch 'master' of salsa.debian.org:debian-gps-team/pkg-gpsd
  * [29fe8717] Remove options only used by the init script.
  * [0232f523] Scons ignores hardening-flags and others, try this.
  * [d163bdcd] Revert "Scons ignores hardening-flags and others, try this."
    This reverts commit 0232f52302f65f545118f653f787daf2429d0c0a.
  * [27d27ef5] A better try to fix scons env handling
  * [fc43714a] More fixes for the env-handling.
  * [9b34a869] Fix the broken fix
  * [6fd99707] Also merge CFLAGS/CXXFLAGS/...
  * [200cf80c] Also try to fix python cflags handling
  * [0dd50707] Use python3 for default scons things.
    After building the first version with python 3, the pickle version of
    the cached scons data will be too old.
  * [bbf652ee] Remove python2 support.
    Building both python versions got impossible since recent python3
    versions use a new picke version and scons stores its state in a pickle
    file...
  * [8eee1d20] Also remove dependencies on python-gps
  * [e3b30066] Updating debian/control from debian/control.in
  * [0332c8e5] Remove duplicate build-deps
  * [62b43a57] Updating changelog
  * [a8bbbce5] Use python3 for gpsd-clients
  * [288e9075] gpsd-clients breaks/replaces python-gps
  * [2f21db33] use aptly
  * [fd092a4d] Use python3-gi instead of python3-gtk
  * [0be9eebd] changes need to go into control.in
  * [a620b1d5] Depend on python3
  * [cbf832dd] Updating debian/control from debian/control.in

debian/sid 2019-10-14 04:30:57 UTC 2019-10-14
Import patches-unapplied version 3.19-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-10-13 19:56:20 UTC

Import patches-unapplied version 3.19-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9a0fd35970cf658a13f284c97050eeda2adcc5d6

New changelog entries:
  * [06ae5582] Add debian/.gitlab-ci.yml
  * [b200620e] Update Vcs-Git Urls
  * [1991f99e] git is not available on buildds.
  * [809c6c4a] Remove weird env flag overrides
  * [85c4fbb7] snapshot changelog
  * [24e0be41] try again
  * [ede12b7b] Merge branch 'master' of salsa.debian.org:debian-gps-team/pkg-gpsd
  * [29fe8717] Remove options only used by the init script.
  * [0232f523] Scons ignores hardening-flags and others, try this.
  * [d163bdcd] Revert "Scons ignores hardening-flags and others, try this."
    This reverts commit 0232f52302f65f545118f653f787daf2429d0c0a.
  * [27d27ef5] A better try to fix scons env handling
  * [fc43714a] More fixes for the env-handling.
  * [9b34a869] Fix the broken fix
  * [6fd99707] Also merge CFLAGS/CXXFLAGS/...
  * [200cf80c] Also try to fix python cflags handling
  * [0dd50707] Use python3 for default scons things.
    After building the first version with python 3, the pickle version of
    the cached scons data will be too old.
  * [bbf652ee] Remove python2 support.
    Building both python versions got impossible since recent python3
    versions use a new picke version and scons stores its state in a pickle
    file...
  * [8eee1d20] Also remove dependencies on python-gps
  * [e3b30066] Updating debian/control from debian/control.in
  * [0332c8e5] Remove duplicate build-deps
  * [62b43a57] Updating changelog
  * [a8bbbce5] Use python3 for gpsd-clients
  * [288e9075] gpsd-clients breaks/replaces python-gps
  * [2f21db33] use aptly
  * [fd092a4d] Use python3-gi instead of python3-gtk
  * [0be9eebd] changes need to go into control.in
  * [a620b1d5] Depend on python3
  * [cbf832dd] Updating debian/control from debian/control.in

ubuntu/focal-proposed 2019-10-14 04:30:57 UTC 2019-10-14
Import patches-unapplied version 3.19-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-10-13 19:56:20 UTC

Import patches-unapplied version 3.19-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9a0fd35970cf658a13f284c97050eeda2adcc5d6

New changelog entries:
  * [06ae5582] Add debian/.gitlab-ci.yml
  * [b200620e] Update Vcs-Git Urls
  * [1991f99e] git is not available on buildds.
  * [809c6c4a] Remove weird env flag overrides
  * [85c4fbb7] snapshot changelog
  * [24e0be41] try again
  * [ede12b7b] Merge branch 'master' of salsa.debian.org:debian-gps-team/pkg-gpsd
  * [29fe8717] Remove options only used by the init script.
  * [0232f523] Scons ignores hardening-flags and others, try this.
  * [d163bdcd] Revert "Scons ignores hardening-flags and others, try this."
    This reverts commit 0232f52302f65f545118f653f787daf2429d0c0a.
  * [27d27ef5] A better try to fix scons env handling
  * [fc43714a] More fixes for the env-handling.
  * [9b34a869] Fix the broken fix
  * [6fd99707] Also merge CFLAGS/CXXFLAGS/...
  * [200cf80c] Also try to fix python cflags handling
  * [0dd50707] Use python3 for default scons things.
    After building the first version with python 3, the pickle version of
    the cached scons data will be too old.
  * [bbf652ee] Remove python2 support.
    Building both python versions got impossible since recent python3
    versions use a new picke version and scons stores its state in a pickle
    file...
  * [8eee1d20] Also remove dependencies on python-gps
  * [e3b30066] Updating debian/control from debian/control.in
  * [0332c8e5] Remove duplicate build-deps
  * [62b43a57] Updating changelog
  * [a8bbbce5] Use python3 for gpsd-clients
  * [288e9075] gpsd-clients breaks/replaces python-gps
  * [2f21db33] use aptly
  * [fd092a4d] Use python3-gi instead of python3-gtk
  * [0be9eebd] changes need to go into control.in
  * [a620b1d5] Depend on python3
  * [cbf832dd] Updating debian/control from debian/control.in

debian/experimental 2019-07-23 16:27:25 UTC 2019-07-23
Import patches-unapplied version 3.19-1 to debian/experimental

Author: Bernd Zeimetz
Author Date: 2019-07-11 08:01:16 UTC

Import patches-unapplied version 3.19-1 to debian/experimental

Imported using git-ubuntu import.

Changelog parent: 8647b24919fe6f908f4169b95b88456ee53031bf

New changelog entries:
  [ Christian Ehrhardt ]
  * [d61040a0] d/usr.sbin.gpsd: Relicense to BSD to match the Project.
    As the Author of the profile I'm relicensing the apparmor profile
    to the BSD License to match the (majority) of the rest of the
    GPSD project licenses.
    Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * [5de17f0c] Allow gpsd.service to be enabled by the admin at boot time.
    Be sure to keep it disabled. The admin needs to explicitely start
    it if needed. (Closes: #928681)
  [ Bernd Zeimetz ]
  * [7a45f357] Update upstream source from tag 'upstream/3.19'
    Update to upstream version '3.19'
    with Debian dir b3aea49f5d39c5eb18ffcb61a2b6cebae7f7322f
  * [63e0cd09] snapshot changelog
  * [5e3a1568] test script location changed
  * [9035f8d9] add test_misc.py
  * [6d9ccaf3] Add gpsrinex
  * [764bfeaa] Updating symbol files

applied/debian/experimental 2019-07-23 16:27:25 UTC 2019-07-23
Import patches-applied version 3.19-1 to applied/debian/experimental

Author: Bernd Zeimetz
Author Date: 2019-07-11 08:01:16 UTC

Import patches-applied version 3.19-1 to applied/debian/experimental

Imported using git-ubuntu import.

Changelog parent: 5873d8d1c028bb83e6744a97d3646b9e4d0940d6
Unapplied parent: b6b19613bb0cfb0652eab2843f85a370fa214995

New changelog entries:
  [ Christian Ehrhardt ]
  * [d61040a0] d/usr.sbin.gpsd: Relicense to BSD to match the Project.
    As the Author of the profile I'm relicensing the apparmor profile
    to the BSD License to match the (majority) of the rest of the
    GPSD project licenses.
    Signed-off-by: Christian Ehrhardt <christian.ehrhardt@canonical.com>
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * [5de17f0c] Allow gpsd.service to be enabled by the admin at boot time.
    Be sure to keep it disabled. The admin needs to explicitely start
    it if needed. (Closes: #928681)
  [ Bernd Zeimetz ]
  * [7a45f357] Update upstream source from tag 'upstream/3.19'
    Update to upstream version '3.19'
    with Debian dir b3aea49f5d39c5eb18ffcb61a2b6cebae7f7322f
  * [63e0cd09] snapshot changelog
  * [5e3a1568] test script location changed
  * [9035f8d9] add test_misc.py
  * [6d9ccaf3] Add gpsrinex
  * [764bfeaa] Updating symbol files

applied/debian/buster 2019-05-25 16:31:37 UTC 2019-05-25
Import patches-applied version 3.17-7 to applied/debian/sid

Author: Bernd Zeimetz
Author Date: 2019-05-25 09:55:30 UTC

Import patches-applied version 3.17-7 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 3c96059e39f7128d208c0da5e1de3beba2fa8a11
Unapplied parent: a81ef07ca9610a6662e5658f37b25d1c725a988f

New changelog entries:
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * [ffb32ff8] Allow gpsd.service to be enabled by the admin at boot time.
    Be sure to keep it disabled. The admin needs to explicitely start
    it if needed.
    Closes: #928681

ubuntu/eoan 2019-05-25 16:31:37 UTC 2019-05-25
Import patches-unapplied version 3.17-7 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-05-25 09:55:30 UTC

Import patches-unapplied version 3.17-7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 78378a52fb8163e036351069d9591bc20c630ad7

New changelog entries:
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * [ffb32ff8] Allow gpsd.service to be enabled by the admin at boot time.
    Be sure to keep it disabled. The admin needs to explicitely start
    it if needed.
    Closes: #928681

ubuntu/eoan-devel 2019-05-25 16:31:37 UTC 2019-05-25
Import patches-unapplied version 3.17-7 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-05-25 09:55:30 UTC

Import patches-unapplied version 3.17-7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 78378a52fb8163e036351069d9591bc20c630ad7

New changelog entries:
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * [ffb32ff8] Allow gpsd.service to be enabled by the admin at boot time.
    Be sure to keep it disabled. The admin needs to explicitely start
    it if needed.
    Closes: #928681

ubuntu/eoan-proposed 2019-05-25 16:31:37 UTC 2019-05-25
Import patches-unapplied version 3.17-7 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-05-25 09:55:30 UTC

Import patches-unapplied version 3.17-7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 78378a52fb8163e036351069d9591bc20c630ad7

New changelog entries:
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * [ffb32ff8] Allow gpsd.service to be enabled by the admin at boot time.
    Be sure to keep it disabled. The admin needs to explicitely start
    it if needed.
    Closes: #928681

ubuntu/focal 2019-05-25 16:31:37 UTC 2019-05-25
Import patches-unapplied version 3.17-7 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-05-25 09:55:30 UTC

Import patches-unapplied version 3.17-7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 78378a52fb8163e036351069d9591bc20c630ad7

New changelog entries:
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * [ffb32ff8] Allow gpsd.service to be enabled by the admin at boot time.
    Be sure to keep it disabled. The admin needs to explicitely start
    it if needed.
    Closes: #928681

debian/buster 2019-05-25 16:31:37 UTC 2019-05-25
Import patches-unapplied version 3.17-7 to debian/sid

Author: Bernd Zeimetz
Author Date: 2019-05-25 09:55:30 UTC

Import patches-unapplied version 3.17-7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 78378a52fb8163e036351069d9591bc20c630ad7

New changelog entries:
  [ Lisandro Damián Nicanor Pérez Meyer ]
  * [ffb32ff8] Allow gpsd.service to be enabled by the admin at boot time.
    Be sure to keep it disabled. The admin needs to explicitely start
    it if needed.
    Closes: #928681

ubuntu/cosmic-devel 2018-05-03 15:44:42 UTC 2018-05-03
Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-05-03 14:15:38 UTC

Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 7468d22b4ef09a7fa3d446c19f4e6f816126507e

New changelog entries:
  * No-change rebuild for ncurses soname changes.

ubuntu/disco 2018-05-03 15:44:42 UTC 2018-05-03
Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-05-03 14:15:38 UTC

Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 7468d22b4ef09a7fa3d446c19f4e6f816126507e

New changelog entries:
  * No-change rebuild for ncurses soname changes.

ubuntu/disco-devel 2018-05-03 15:44:42 UTC 2018-05-03
Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-05-03 14:15:38 UTC

Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 7468d22b4ef09a7fa3d446c19f4e6f816126507e

New changelog entries:
  * No-change rebuild for ncurses soname changes.

ubuntu/cosmic 2018-05-03 15:44:42 UTC 2018-05-03
Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-05-03 14:15:38 UTC

Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 7468d22b4ef09a7fa3d446c19f4e6f816126507e

New changelog entries:
  * No-change rebuild for ncurses soname changes.

ubuntu/cosmic-proposed 2018-05-03 15:44:42 UTC 2018-05-03
Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Author: Matthias Klose
Author Date: 2018-05-03 14:15:38 UTC

Import patches-unapplied version 3.17-5build1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: 7468d22b4ef09a7fa3d446c19f4e6f816126507e

New changelog entries:
  * No-change rebuild for ncurses soname changes.

importer/ubuntu/pristine-tar 2018-04-03 00:23:45 UTC 2018-04-03
pristine-tar data for gpsd_3.17.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-04-03 00:23:45 UTC

pristine-tar data for gpsd_3.17.orig.tar.gz

importer/debian/pristine-tar 2018-04-02 23:52:43 UTC 2018-04-02
pristine-tar data for gpsd_3.17.orig.tar.gz

Author: Ubuntu Git Importer
Author Date: 2018-04-02 23:52:43 UTC

pristine-tar data for gpsd_3.17.orig.tar.gz

ubuntu/bionic 2017-12-28 04:30:15 UTC 2017-12-28
Import patches-unapplied version 3.17-5 to debian/sid

Author: Bernd Zeimetz
Author Date: 2017-12-27 23:57:01 UTC

Import patches-unapplied version 3.17-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c4607cbc049d0d47a766ec06af17fbc79476fc2b

New changelog entries:
  * [fd1e83f9] Add pkg-config as Build-Dependency.
    Went missing somehow :(
  * [6d0e69e3] Build with default compiler standard
  * [8994d7cb] Actually change control.in, not control.
    Needs an extra check to make sure I don't forget again :)
  * [a744cad9] Updating debian/control from debian/control.in

ubuntu/bionic-proposed 2017-12-28 04:30:15 UTC 2017-12-28
Import patches-unapplied version 3.17-5 to debian/sid

Author: Bernd Zeimetz
Author Date: 2017-12-27 23:57:01 UTC

Import patches-unapplied version 3.17-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c4607cbc049d0d47a766ec06af17fbc79476fc2b

New changelog entries:
  * [fd1e83f9] Add pkg-config as Build-Dependency.
    Went missing somehow :(
  * [6d0e69e3] Build with default compiler standard
  * [8994d7cb] Actually change control.in, not control.
    Needs an extra check to make sure I don't forget again :)
  * [a744cad9] Updating debian/control from debian/control.in

ubuntu/bionic-devel 2017-12-28 04:30:15 UTC 2017-12-28
Import patches-unapplied version 3.17-5 to debian/sid

Author: Bernd Zeimetz
Author Date: 2017-12-27 23:57:01 UTC

Import patches-unapplied version 3.17-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c4607cbc049d0d47a766ec06af17fbc79476fc2b

New changelog entries:
  * [fd1e83f9] Add pkg-config as Build-Dependency.
    Went missing somehow :(
  * [6d0e69e3] Build with default compiler standard
  * [8994d7cb] Actually change control.in, not control.
    Needs an extra check to make sure I don't forget again :)
  * [a744cad9] Updating debian/control from debian/control.in

applied/debian/stretch 2016-11-05 04:12:16 UTC 2016-11-05
Import patches-applied version 3.16-4 to applied/debian/sid

Author: Bernd Zeimetz
Author Date: 2016-11-04 22:35:14 UTC

Import patches-applied version 3.16-4 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: b65529624da59761c5ce590962a84cbb0955f2f2
Unapplied parent: 0eb0dba531a1f5af6ae46dc8230ce6642739a910

New changelog entries:
  * [2405f456] Fix debug symbol handling.
    Debug symbols went missing when upstream switched the strip
    option name.
    Thanks to Andre Naujoks (Closes: #842792)
  * [74c3cd07] Updating debian/control from debian/control.in
  * [b66410da] hadle debian/control creation a bit better
  * [06a9623f] Use gz compression for now.
  * [44376877] Remove obsolete build dependency on hardening-includes.

debian/stretch 2016-11-05 04:12:16 UTC 2016-11-05
Import patches-unapplied version 3.16-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-11-04 22:35:14 UTC

Import patches-unapplied version 3.16-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: efe7bc040bfa80cb3b8141de61b842135747b07e

New changelog entries:
  * [2405f456] Fix debug symbol handling.
    Debug symbols went missing when upstream switched the strip
    option name.
    Thanks to Andre Naujoks (Closes: #842792)
  * [74c3cd07] Updating debian/control from debian/control.in
  * [b66410da] hadle debian/control creation a bit better
  * [06a9623f] Use gz compression for now.
  * [44376877] Remove obsolete build dependency on hardening-includes.

ubuntu/zesty-devel 2016-11-05 04:12:16 UTC 2016-11-05
Import patches-unapplied version 3.16-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-11-04 22:35:14 UTC

Import patches-unapplied version 3.16-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: efe7bc040bfa80cb3b8141de61b842135747b07e

New changelog entries:
  * [2405f456] Fix debug symbol handling.
    Debug symbols went missing when upstream switched the strip
    option name.
    Thanks to Andre Naujoks (Closes: #842792)
  * [74c3cd07] Updating debian/control from debian/control.in
  * [b66410da] hadle debian/control creation a bit better
  * [06a9623f] Use gz compression for now.
  * [44376877] Remove obsolete build dependency on hardening-includes.

ubuntu/zesty-proposed 2016-11-05 04:12:16 UTC 2016-11-05
Import patches-unapplied version 3.16-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-11-04 22:35:14 UTC

Import patches-unapplied version 3.16-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: efe7bc040bfa80cb3b8141de61b842135747b07e

New changelog entries:
  * [2405f456] Fix debug symbol handling.
    Debug symbols went missing when upstream switched the strip
    option name.
    Thanks to Andre Naujoks (Closes: #842792)
  * [74c3cd07] Updating debian/control from debian/control.in
  * [b66410da] hadle debian/control creation a bit better
  * [06a9623f] Use gz compression for now.
  * [44376877] Remove obsolete build dependency on hardening-includes.

ubuntu/artful 2016-11-05 04:12:16 UTC 2016-11-05
Import patches-unapplied version 3.16-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-11-04 22:35:14 UTC

Import patches-unapplied version 3.16-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: efe7bc040bfa80cb3b8141de61b842135747b07e

New changelog entries:
  * [2405f456] Fix debug symbol handling.
    Debug symbols went missing when upstream switched the strip
    option name.
    Thanks to Andre Naujoks (Closes: #842792)
  * [74c3cd07] Updating debian/control from debian/control.in
  * [b66410da] hadle debian/control creation a bit better
  * [06a9623f] Use gz compression for now.
  * [44376877] Remove obsolete build dependency on hardening-includes.

ubuntu/artful-devel 2016-11-05 04:12:16 UTC 2016-11-05
Import patches-unapplied version 3.16-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-11-04 22:35:14 UTC

Import patches-unapplied version 3.16-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: efe7bc040bfa80cb3b8141de61b842135747b07e

New changelog entries:
  * [2405f456] Fix debug symbol handling.
    Debug symbols went missing when upstream switched the strip
    option name.
    Thanks to Andre Naujoks (Closes: #842792)
  * [74c3cd07] Updating debian/control from debian/control.in
  * [b66410da] hadle debian/control creation a bit better
  * [06a9623f] Use gz compression for now.
  * [44376877] Remove obsolete build dependency on hardening-includes.

ubuntu/zesty 2016-11-05 04:12:16 UTC 2016-11-05
Import patches-unapplied version 3.16-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-11-04 22:35:14 UTC

Import patches-unapplied version 3.16-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: efe7bc040bfa80cb3b8141de61b842135747b07e

New changelog entries:
  * [2405f456] Fix debug symbol handling.
    Debug symbols went missing when upstream switched the strip
    option name.
    Thanks to Andre Naujoks (Closes: #842792)
  * [74c3cd07] Updating debian/control from debian/control.in
  * [b66410da] hadle debian/control creation a bit better
  * [06a9623f] Use gz compression for now.
  * [44376877] Remove obsolete build dependency on hardening-includes.

ubuntu/yakkety 2016-09-24 22:15:17 UTC 2016-09-24
Import patches-unapplied version 3.16-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-09-24 12:34:07 UTC

Import patches-unapplied version 3.16-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d63ad1e2b4ffb62f181e448458f56f1272d7adf9

New changelog entries:
  * [aa43cc65] Various patches were applied upstream.
    Take them from there, removing our version.
  * [1444f940] Build with -std=gnu++98. (Closes: #830993)
  * [505d032a] Remove netbase/systemd-sysv dependency.
    Not needed anymore. (Closes: #768100)
  * [b53473f0] Migrate to github.
  * [cb624dcb] Add travis.yml build stuff.
  * [1c3c3463] Updating gbp.conf to ignore travis.yml for debuild.
  * [d870a5c6] Don't rebuild for the static library.

ubuntu/yakkety-devel 2016-09-24 22:15:17 UTC 2016-09-24
Import patches-unapplied version 3.16-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-09-24 12:34:07 UTC

Import patches-unapplied version 3.16-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d63ad1e2b4ffb62f181e448458f56f1272d7adf9

New changelog entries:
  * [aa43cc65] Various patches were applied upstream.
    Take them from there, removing our version.
  * [1444f940] Build with -std=gnu++98. (Closes: #830993)
  * [505d032a] Remove netbase/systemd-sysv dependency.
    Not needed anymore. (Closes: #768100)
  * [b53473f0] Migrate to github.
  * [cb624dcb] Add travis.yml build stuff.
  * [1c3c3463] Updating gbp.conf to ignore travis.yml for debuild.
  * [d870a5c6] Don't rebuild for the static library.

ubuntu/yakkety-proposed 2016-09-24 22:15:17 UTC 2016-09-24
Import patches-unapplied version 3.16-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2016-09-24 12:34:07 UTC

Import patches-unapplied version 3.16-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d63ad1e2b4ffb62f181e448458f56f1272d7adf9

New changelog entries:
  * [aa43cc65] Various patches were applied upstream.
    Take them from there, removing our version.
  * [1444f940] Build with -std=gnu++98. (Closes: #830993)
  * [505d032a] Remove netbase/systemd-sysv dependency.
    Not needed anymore. (Closes: #768100)
  * [b53473f0] Migrate to github.
  * [cb624dcb] Add travis.yml build stuff.
  * [1c3c3463] Updating gbp.conf to ignore travis.yml for debuild.
  * [d870a5c6] Don't rebuild for the static library.

ubuntu/xenial 2016-02-06 21:15:17 UTC 2016-02-06
Import patches-unapplied version 3.15-2build1 to ubuntu/xenial-proposed

Author: Matthias Klose
Author Date: 2016-02-06 20:52:52 UTC

Import patches-unapplied version 3.15-2build1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 464ca16c6b2115f22972facee87838af42602ac5

New changelog entries:
  * No-change rebuild for ncurses6 transition.

ubuntu/xenial-devel 2016-02-06 21:15:17 UTC 2016-02-06
Import patches-unapplied version 3.15-2build1 to ubuntu/xenial-proposed

Author: Matthias Klose
Author Date: 2016-02-06 20:52:52 UTC

Import patches-unapplied version 3.15-2build1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 464ca16c6b2115f22972facee87838af42602ac5

New changelog entries:
  * No-change rebuild for ncurses6 transition.

ubuntu/xenial-proposed 2016-02-06 21:15:17 UTC 2016-02-06
Import patches-unapplied version 3.15-2build1 to ubuntu/xenial-proposed

Author: Matthias Klose
Author Date: 2016-02-06 20:52:52 UTC

Import patches-unapplied version 3.15-2build1 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: 464ca16c6b2115f22972facee87838af42602ac5

New changelog entries:
  * No-change rebuild for ncurses6 transition.

ubuntu/vivid 2015-01-25 16:14:00 UTC 2015-01-25
Import patches-unapplied version 3.11-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2015-01-25 11:15:44 UTC

Import patches-unapplied version 3.11-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c1893cf48117173d0df938f9666effcc8eea18e

New changelog entries:
  [ Andreas Beckmann ]
  * [dd6bbdf1] avoid prompting due to modified lenny conffiles

applied/debian/jessie 2015-01-25 16:14:00 UTC 2015-01-25
Import patches-applied version 3.11-3 to applied/debian/sid

Author: Bernd Zeimetz
Author Date: 2015-01-25 11:15:44 UTC

Import patches-applied version 3.11-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 41b611d2edc3c95d9209ea1440c575f7b21dee07
Unapplied parent: 5185e59c1289d2b49bc01370615837dbf6ec9e12

New changelog entries:
  [ Andreas Beckmann ]
  * [dd6bbdf1] avoid prompting due to modified lenny conffiles

debian/jessie 2015-01-25 16:14:00 UTC 2015-01-25
Import patches-unapplied version 3.11-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2015-01-25 11:15:44 UTC

Import patches-unapplied version 3.11-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c1893cf48117173d0df938f9666effcc8eea18e

New changelog entries:
  [ Andreas Beckmann ]
  * [dd6bbdf1] avoid prompting due to modified lenny conffiles

ubuntu/vivid-devel 2015-01-25 16:14:00 UTC 2015-01-25
Import patches-unapplied version 3.11-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2015-01-25 11:15:44 UTC

Import patches-unapplied version 3.11-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c1893cf48117173d0df938f9666effcc8eea18e

New changelog entries:
  [ Andreas Beckmann ]
  * [dd6bbdf1] avoid prompting due to modified lenny conffiles

ubuntu/vivid-proposed 2015-01-25 16:14:00 UTC 2015-01-25
Import patches-unapplied version 3.11-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2015-01-25 11:15:44 UTC

Import patches-unapplied version 3.11-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c1893cf48117173d0df938f9666effcc8eea18e

New changelog entries:
  [ Andreas Beckmann ]
  * [dd6bbdf1] avoid prompting due to modified lenny conffiles

ubuntu/wily 2015-01-25 16:14:00 UTC 2015-01-25
Import patches-unapplied version 3.11-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2015-01-25 11:15:44 UTC

Import patches-unapplied version 3.11-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c1893cf48117173d0df938f9666effcc8eea18e

New changelog entries:
  [ Andreas Beckmann ]
  * [dd6bbdf1] avoid prompting due to modified lenny conffiles

ubuntu/wily-devel 2015-01-25 16:14:00 UTC 2015-01-25
Import patches-unapplied version 3.11-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2015-01-25 11:15:44 UTC

Import patches-unapplied version 3.11-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4c1893cf48117173d0df938f9666effcc8eea18e

New changelog entries:
  [ Andreas Beckmann ]
  * [dd6bbdf1] avoid prompting due to modified lenny conffiles

ubuntu/utopic-proposed 2014-08-04 22:15:10 UTC 2014-08-04
Import patches-unapplied version 3.10+dev3~d6b65b48-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2014-08-04 15:19:32 UTC

Import patches-unapplied version 3.10+dev3~d6b65b48-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c9078ff220730c04cd05a8f421718e95fe27d481

New changelog entries:
  * [7b5a9811] Set GPSD_SOCKET to the default location.
    Thanks to Jeremy Laine (Closes: #756488)

ubuntu/utopic 2014-08-04 22:15:10 UTC 2014-08-04
Import patches-unapplied version 3.10+dev3~d6b65b48-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2014-08-04 15:19:32 UTC

Import patches-unapplied version 3.10+dev3~d6b65b48-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c9078ff220730c04cd05a8f421718e95fe27d481

New changelog entries:
  * [7b5a9811] Set GPSD_SOCKET to the default location.
    Thanks to Jeremy Laine (Closes: #756488)

ubuntu/utopic-devel 2014-08-04 22:15:10 UTC 2014-08-04
Import patches-unapplied version 3.10+dev3~d6b65b48-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2014-08-04 15:19:32 UTC

Import patches-unapplied version 3.10+dev3~d6b65b48-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c9078ff220730c04cd05a8f421718e95fe27d481

New changelog entries:
  * [7b5a9811] Set GPSD_SOCKET to the default location.
    Thanks to Jeremy Laine (Closes: #756488)

ubuntu/trusty 2013-08-08 04:13:26 UTC 2013-08-08
Import patches-unapplied version 3.9-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2013-08-06 20:26:32 UTC

Import patches-unapplied version 3.9-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4a7afea1b8f6509c525a116fd9369208fa374f6c

New changelog entries:
  * [75fe68f6] Add patch to work around the PATH_MAX issue on hurd.
    The patch was not applie dupstream and went missing on the last upload.

ubuntu/trusty-proposed 2013-08-08 04:13:26 UTC 2013-08-08
Import patches-unapplied version 3.9-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2013-08-06 20:26:32 UTC

Import patches-unapplied version 3.9-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4a7afea1b8f6509c525a116fd9369208fa374f6c

New changelog entries:
  * [75fe68f6] Add patch to work around the PATH_MAX issue on hurd.
    The patch was not applie dupstream and went missing on the last upload.

ubuntu/trusty-devel 2013-08-08 04:13:26 UTC 2013-08-08
Import patches-unapplied version 3.9-3 to debian/sid

Author: Bernd Zeimetz
Author Date: 2013-08-06 20:26:32 UTC

Import patches-unapplied version 3.9-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4a7afea1b8f6509c525a116fd9369208fa374f6c

New changelog entries:
  * [75fe68f6] Add patch to work around the PATH_MAX issue on hurd.
    The patch was not applie dupstream and went missing on the last upload.

ubuntu/saucy-proposed 2013-08-05 22:13:26 UTC 2013-08-05
Import patches-unapplied version 3.9-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2013-08-05 14:23:10 UTC

Import patches-unapplied version 3.9-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4022506d8bda627849b3e51137c7e728570dbee1

New changelog entries:
  [ Bernd Zeimetz ]
  * [649f6e3b] Fix symbols file for m68k and others without unsigned long.
    (Closes: #718741)
  [ Michael Stapelberg ]
  * [d41eaabd] switch to dh-systemd for proper systemd maintscripts
    (Closes: #714199)

ubuntu/saucy-devel 2013-08-05 22:13:26 UTC 2013-08-05
Import patches-unapplied version 3.9-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2013-08-05 14:23:10 UTC

Import patches-unapplied version 3.9-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4022506d8bda627849b3e51137c7e728570dbee1

New changelog entries:
  [ Bernd Zeimetz ]
  * [649f6e3b] Fix symbols file for m68k and others without unsigned long.
    (Closes: #718741)
  [ Michael Stapelberg ]
  * [d41eaabd] switch to dh-systemd for proper systemd maintscripts
    (Closes: #714199)

ubuntu/saucy 2013-08-05 22:13:26 UTC 2013-08-05
Import patches-unapplied version 3.9-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2013-08-05 14:23:10 UTC

Import patches-unapplied version 3.9-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 4022506d8bda627849b3e51137c7e728570dbee1

New changelog entries:
  [ Bernd Zeimetz ]
  * [649f6e3b] Fix symbols file for m68k and others without unsigned long.
    (Closes: #718741)
  [ Michael Stapelberg ]
  * [d41eaabd] switch to dh-systemd for proper systemd maintscripts
    (Closes: #714199)

debian/wheezy 2013-06-15 16:38:28 UTC 2013-06-15
Import patches-unapplied version 3.6-4+deb7u1 to debian/wheezy

Author: Bernd Zeimetz
Author Date: 2013-05-03 18:57:35 UTC

Import patches-unapplied version 3.6-4+deb7u1 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 536255779ed2db74e71d923c0c84043f3c0f1d19

New changelog entries:
  * [818fb0a6] Fixing two security bugs in gpsd
    - one triggered by malformed NMEA packets, making gpsd crash
    - the other one is a possible DOS in the AIS parser,
      CVE-2013-2038
    Thanks to Salvatore Bonaccorso (Closes: #706665)

applied/debian/wheezy 2013-06-15 16:38:28 UTC 2013-06-15
Import patches-applied version 3.6-4+deb7u1 to applied/debian/wheezy

Author: Bernd Zeimetz
Author Date: 2013-05-03 18:57:35 UTC

Import patches-applied version 3.6-4+deb7u1 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 60ff0ea1f4b959823f143b7fa2a83f2eeb81f4ce
Unapplied parent: c642521ca689da7a43a2e477c6b084f578eded8c

New changelog entries:
  * [818fb0a6] Fixing two security bugs in gpsd
    - one triggered by malformed NMEA packets, making gpsd crash
    - the other one is a possible DOS in the AIS parser,
      CVE-2013-2038
    Thanks to Salvatore Bonaccorso (Closes: #706665)

ubuntu/precise-updates 2013-05-08 18:33:18 UTC 2013-05-08
Import patches-unapplied version 3.4-2ubuntu0.1 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2013-05-03 21:14:00 UTC

Import patches-unapplied version 3.4-2ubuntu0.1 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 9f721613b73a0c879f78d0bfcfa65324598963d5

New changelog entries:
  * SECURITY UPDATE: denial of service via gps-supplied data
    - debian/patches/CVE-2013-2038.patch: properly handle recovery in
      packet.c, check payload size in driver_aivdm.c.
    - CVE-2013-2038

ubuntu/precise-devel 2013-05-08 18:33:18 UTC 2013-05-08
Import patches-unapplied version 3.4-2ubuntu0.1 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2013-05-03 21:14:00 UTC

Import patches-unapplied version 3.4-2ubuntu0.1 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 9f721613b73a0c879f78d0bfcfa65324598963d5

New changelog entries:
  * SECURITY UPDATE: denial of service via gps-supplied data
    - debian/patches/CVE-2013-2038.patch: properly handle recovery in
      packet.c, check payload size in driver_aivdm.c.
    - CVE-2013-2038

ubuntu/precise-security 2013-05-08 18:33:18 UTC 2013-05-08
Import patches-unapplied version 3.4-2ubuntu0.1 to ubuntu/precise-security

Author: Marc Deslauriers
Author Date: 2013-05-03 21:14:00 UTC

Import patches-unapplied version 3.4-2ubuntu0.1 to ubuntu/precise-security

Imported using git-ubuntu import.

Changelog parent: 9f721613b73a0c879f78d0bfcfa65324598963d5

New changelog entries:
  * SECURITY UPDATE: denial of service via gps-supplied data
    - debian/patches/CVE-2013-2038.patch: properly handle recovery in
      packet.c, check payload size in driver_aivdm.c.
    - CVE-2013-2038

ubuntu/raring 2012-07-04 04:19:58 UTC 2012-07-04
Import patches-unapplied version 3.6-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2012-07-03 19:46:21 UTC

Import patches-unapplied version 3.6-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fe14a1757314ee731225b20fd23f92db9bc3c683

New changelog entries:
  * [8607cd96] Add some bugfixes from upstream.
    - Avoid adding devices with path names longer than
      GPS_PATH_MAX
    - Accept Freescale i.MX processor UARTs as serial port
    - Fix the notification of ntpd about leap seconds.
  * [528213ef] Update regression tests according to the leap second change.
    Whenever the default leap second changes in timebase.h the
    GPS tests will break (times one second off) and the testloads will
    have to be rebuilt. The problem is in the SiRF tests; that driver
    relies on the default until it gets the current offset from subframe
    data.
    timebase.h is being created from the leapseconds.cache file at build
    time. As leapseconds happen rarely, there is no support to read them
    from a config file included yet.

ubuntu/raring-devel 2012-07-04 04:19:58 UTC 2012-07-04
Import patches-unapplied version 3.6-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2012-07-03 19:46:21 UTC

Import patches-unapplied version 3.6-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fe14a1757314ee731225b20fd23f92db9bc3c683

New changelog entries:
  * [8607cd96] Add some bugfixes from upstream.
    - Avoid adding devices with path names longer than
      GPS_PATH_MAX
    - Accept Freescale i.MX processor UARTs as serial port
    - Fix the notification of ntpd about leap seconds.
  * [528213ef] Update regression tests according to the leap second change.
    Whenever the default leap second changes in timebase.h the
    GPS tests will break (times one second off) and the testloads will
    have to be rebuilt. The problem is in the SiRF tests; that driver
    relies on the default until it gets the current offset from subframe
    data.
    timebase.h is being created from the leapseconds.cache file at build
    time. As leapseconds happen rarely, there is no support to read them
    from a config file included yet.

ubuntu/quantal 2012-07-04 04:19:58 UTC 2012-07-04
Import patches-unapplied version 3.6-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2012-07-03 19:46:21 UTC

Import patches-unapplied version 3.6-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fe14a1757314ee731225b20fd23f92db9bc3c683

New changelog entries:
  * [8607cd96] Add some bugfixes from upstream.
    - Avoid adding devices with path names longer than
      GPS_PATH_MAX
    - Accept Freescale i.MX processor UARTs as serial port
    - Fix the notification of ntpd about leap seconds.
  * [528213ef] Update regression tests according to the leap second change.
    Whenever the default leap second changes in timebase.h the
    GPS tests will break (times one second off) and the testloads will
    have to be rebuilt. The problem is in the SiRF tests; that driver
    relies on the default until it gets the current offset from subframe
    data.
    timebase.h is being created from the leapseconds.cache file at build
    time. As leapseconds happen rarely, there is no support to read them
    from a config file included yet.

ubuntu/quantal-devel 2012-07-04 04:19:58 UTC 2012-07-04
Import patches-unapplied version 3.6-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2012-07-03 19:46:21 UTC

Import patches-unapplied version 3.6-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: fe14a1757314ee731225b20fd23f92db9bc3c683

New changelog entries:
  * [8607cd96] Add some bugfixes from upstream.
    - Avoid adding devices with path names longer than
      GPS_PATH_MAX
    - Accept Freescale i.MX processor UARTs as serial port
    - Fix the notification of ntpd about leap seconds.
  * [528213ef] Update regression tests according to the leap second change.
    Whenever the default leap second changes in timebase.h the
    GPS tests will break (times one second off) and the testloads will
    have to be rebuilt. The problem is in the SiRF tests; that driver
    relies on the default until it gets the current offset from subframe
    data.
    timebase.h is being created from the leapseconds.cache file at build
    time. As leapseconds happen rarely, there is no support to read them
    from a config file included yet.

ubuntu/precise 2012-01-20 03:23:03 UTC 2012-01-20
Import patches-unapplied version 3.4-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2012-01-19 22:38:51 UTC

Import patches-unapplied version 3.4-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b0b82442f0a99b6d0f409cf4e27669e9ef7268f4

New changelog entries:
  * [26984e29] Limit gps_shm_* symbols to amd64.
    Due to missing hardware memory barrier support they are only
    available on amd64 for now.

ubuntu/oneiric 2011-06-29 18:08:09 UTC 2011-06-29
Import patches-unapplied version 2.95-13.1 to debian/sid

Author: Luk Claes
Author Date: 2011-06-29 18:08:09 UTC

Import patches-unapplied version 2.95-13.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 68e7f2b344d90e487b1b89c807ce8a2b3ef70b65

New changelog entries:
  * Non-maintainer upload.
  * Don't ship .la files (Closes: #621300).
  * Add Danish debconf translation (Closes: #623089).
  * Update Dutch debconf translation (Closes: #627923).

ubuntu/oneiric-devel 2011-06-29 18:08:09 UTC 2011-06-29
Import patches-unapplied version 2.95-13.1 to debian/sid

Author: Luk Claes
Author Date: 2011-06-29 18:08:09 UTC

Import patches-unapplied version 2.95-13.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 68e7f2b344d90e487b1b89c807ce8a2b3ef70b65

New changelog entries:
  * Non-maintainer upload.
  * Don't ship .la files (Closes: #621300).
  * Add Danish debconf translation (Closes: #623089).
  * Update Dutch debconf translation (Closes: #627923).

ubuntu/natty 2010-12-03 22:04:53 UTC 2010-12-03
Import patches-unapplied version 2.95-8ubuntu1 to ubuntu/natty

Author: Matthias Klose
Author Date: 2010-12-03 20:25:58 UTC

Import patches-unapplied version 2.95-8ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 90f3b782f28324441c7cfe6b60c44ab816c45a3b

New changelog entries:
  * Fix build failure with ld --no-add-needed.
  * Don't list symbols from libqt in the symbols file.

ubuntu/natty-devel 2010-12-03 22:04:53 UTC 2010-12-03
Import patches-unapplied version 2.95-8ubuntu1 to ubuntu/natty

Author: Matthias Klose
Author Date: 2010-12-03 20:25:58 UTC

Import patches-unapplied version 2.95-8ubuntu1 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 90f3b782f28324441c7cfe6b60c44ab816c45a3b

New changelog entries:
  * Fix build failure with ld --no-add-needed.
  * Don't list symbols from libqt in the symbols file.

debian/squeeze 2010-11-17 09:19:36 UTC 2010-11-17
Import patches-unapplied version 2.95-8 to debian/sid

Author: Bernd Zeimetz
Author Date: 2010-11-16 19:26:10 UTC

Import patches-unapplied version 2.95-8 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 9903d1a089e02b80e21466060a7dd10982e262eb

New changelog entries:
  * [b6aae9a2] Stripping unnecessary options/comments from
    debian/gbp.conf
  * [405de6db] Add patch to fix a SEGV when receiving short aivdm
    message type 26. (Closes: #603439) - thanks to Nirgal Vourgère

applied/debian/squeeze 2010-11-17 09:19:36 UTC 2010-11-17
Import patches-applied version 2.95-8 to applied/debian/sid

Author: Bernd Zeimetz
Author Date: 2010-11-16 19:26:10 UTC

Import patches-applied version 2.95-8 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 29bdf8122375c8192a333daaa241e04287d6a1d8
Unapplied parent: 90f3b782f28324441c7cfe6b60c44ab816c45a3b

New changelog entries:
  * [b6aae9a2] Stripping unnecessary options/comments from
    debian/gbp.conf
  * [405de6db] Add patch to fix a SEGV when receiving short aivdm
    message type 26. (Closes: #603439) - thanks to Nirgal Vourgère

ubuntu/maverick 2010-05-19 21:25:41 UTC 2010-05-19
Import patches-unapplied version 2.94-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2010-05-09 23:02:23 UTC

Import patches-unapplied version 2.94-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 19aa29b8a4be05d96ee201adb8afff8d3f455a60

New changelog entries:
  * [fbf3a00f] Build Python scripts with 'python' first.
  * [997bbb72] Add libusv-dev as build dependency.
  * [325a0fe8] Although not necessary any more, start gpsd before ntp.
  * [79029259] python-gps needs to conflict with python-json.
  * [e42b75ed] Backport Python related changes/fixes from git master.

ubuntu/maverick-devel 2010-05-19 21:25:41 UTC 2010-05-19
Import patches-unapplied version 2.94-2 to debian/sid

Author: Bernd Zeimetz
Author Date: 2010-05-09 23:02:23 UTC

Import patches-unapplied version 2.94-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 19aa29b8a4be05d96ee201adb8afff8d3f455a60

New changelog entries:
  * [fbf3a00f] Build Python scripts with 'python' first.
  * [997bbb72] Add libusv-dev as build dependency.
  * [325a0fe8] Although not necessary any more, start gpsd before ntp.
  * [79029259] python-gps needs to conflict with python-json.
  * [e42b75ed] Backport Python related changes/fixes from git master.

ubuntu/lucid 2010-04-06 20:16:53 UTC 2010-04-06
Import patches-unapplied version 2.92-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2010-04-06 11:14:41 UTC

Import patches-unapplied version 2.92-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b903b87dfaa58688e1855469dd8ed6319b038bed

New changelog entries:
  * [8fcedc1e] gpsd: Move python to Recommends python is only needed
    when udev is used, udev is in Recommends only, so it does not make
    much sense to have Python in Depends.
  * [d0b914c1] Fix gpsd socket location parsing in gpsd.config. (Closes:
    #576316) - thanks to Sascha Silbe
  * [7325341a] Include gpsctl manpage in gpsd-clients.
  * Keeping the medium urgency as the package was kept out of the
    archive due to the breakage of ries/ftp-master.debian.org.

ubuntu/lucid-devel 2010-04-06 20:16:53 UTC 2010-04-06
Import patches-unapplied version 2.92-4 to debian/sid

Author: Bernd Zeimetz
Author Date: 2010-04-06 11:14:41 UTC

Import patches-unapplied version 2.92-4 to debian/sid

Imported using git-ubuntu import.

Changelog parent: b903b87dfaa58688e1855469dd8ed6319b038bed

New changelog entries:
  * [8fcedc1e] gpsd: Move python to Recommends python is only needed
    when udev is used, udev is in Recommends only, so it does not make
    much sense to have Python in Depends.
  * [d0b914c1] Fix gpsd socket location parsing in gpsd.config. (Closes:
    #576316) - thanks to Sascha Silbe
  * [7325341a] Include gpsctl manpage in gpsd-clients.
  * Keeping the medium urgency as the package was kept out of the
    archive due to the breakage of ries/ftp-master.debian.org.

ubuntu/karmic-devel 2009-07-31 01:15:07 UTC 2009-07-31
Import patches-unapplied version 2.39-5 to debian/sid

Author: Bernd Zeimetz
Author Date: 2009-07-30 11:31:32 UTC

Import patches-unapplied version 2.39-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cd4c1b1ee3981e6f116010c1f037f1fb9642add6

New changelog entries:
  [ Thomas Mueller ]
  * [c884a6d0] Updating debconf translation: de.po (Closes: #538900)
  [ Bernd Zeimetz ]
  * [26d4a13e] gpsd.init: Move bluetooth to Should-Start - thanks to
    Carsten Einig
  * [7113becd] Add missing macro UNUSED to gpsd.h. (LP: #396256) -
    thanks to Dennis Nienhüser

ubuntu/karmic 2009-07-31 01:15:07 UTC 2009-07-31
Import patches-unapplied version 2.39-5 to debian/sid

Author: Bernd Zeimetz
Author Date: 2009-07-30 11:31:32 UTC

Import patches-unapplied version 2.39-5 to debian/sid

Imported using git-ubuntu import.

Changelog parent: cd4c1b1ee3981e6f116010c1f037f1fb9642add6

New changelog entries:
  [ Thomas Mueller ]
  * [c884a6d0] Updating debconf translation: de.po (Closes: #538900)
  [ Bernd Zeimetz ]
  * [26d4a13e] gpsd.init: Move bluetooth to Should-Start - thanks to
    Carsten Einig
  * [7113becd] Add missing macro UNUSED to gpsd.h. (LP: #396256) -
    thanks to Dennis Nienhüser

ubuntu/jaunty-devel 2009-03-22 17:04:20 UTC 2009-03-22
Import patches-unapplied version 2.38-1ubuntu3 to ubuntu/jaunty

Author: Matthias Klose
Author Date: 2009-03-22 15:46:55 UTC

Import patches-unapplied version 2.38-1ubuntu3 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: eb42bb4cecdbe0dbe303fa31ad8054f39bfad80c

New changelog entries:
  * No-change rebuild to fix lpia shared library dependencies.

ubuntu/jaunty 2009-03-22 17:04:20 UTC 2009-03-22
Import patches-unapplied version 2.38-1ubuntu3 to ubuntu/jaunty

Author: Matthias Klose
Author Date: 2009-03-22 15:46:55 UTC

Import patches-unapplied version 2.38-1ubuntu3 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: eb42bb4cecdbe0dbe303fa31ad8054f39bfad80c

New changelog entries:
  * No-change rebuild to fix lpia shared library dependencies.

applied/debian/lenny 2009-01-05 14:10:39 UTC 2009-01-05
Import patches-applied version 2.37-7 to applied/debian/sid

Author: Bernd Zeimetz
Author Date: 2009-01-04 22:49:56 UTC

Import patches-applied version 2.37-7 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 659098b0b2f2188b7f6dd4f371046ffda47e68d1
Unapplied parent: f2d44af5092ce4134338442527a2c9a9e47bb82e

New changelog entries:
  * debian/control: Adding Vcs-Git/Vcs-Browser fields.
  * debian/patches: Adding use-python2.4.dpatch to use Python 2.4 as
    default for gpsprof and gpsfake.
    Due to a yet not fully debugged bug the pty module of recent
    Python 2.5 versions does not work as expected anymore, hence
    use Python 2.4 for now.

debian/lenny 2009-01-05 14:10:39 UTC 2009-01-05
Import patches-unapplied version 2.37-7 to debian/sid

Author: Bernd Zeimetz
Author Date: 2009-01-04 22:49:56 UTC

Import patches-unapplied version 2.37-7 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 1bc87d26b51dc0f2184bd3c45e29280455a27475

New changelog entries:
  * debian/control: Adding Vcs-Git/Vcs-Browser fields.
  * debian/patches: Adding use-python2.4.dpatch to use Python 2.4 as
    default for gpsprof and gpsfake.
    Due to a yet not fully debugged bug the pty module of recent
    Python 2.5 versions does not work as expected anymore, hence
    use Python 2.4 for now.

ubuntu/intrepid 2008-06-01 14:04:43 UTC 2008-06-01
Import patches-unapplied version 2.37-4 to ubuntu/intrepid

Author: Bernd Zeimetz
Author Date: 2008-05-31 16:07:16 UTC

Import patches-unapplied version 2.37-4 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: c52485ad86f6d9581d8284437f27b42c7e853c3f

New changelog entries:
  * debian/po translation updates:
    - ja.po, thanks to Kenshi Muto (Closes: #483505).

ubuntu/intrepid-devel 2008-06-01 14:04:43 UTC 2008-06-01
Import patches-unapplied version 2.37-4 to ubuntu/intrepid

Author: Bernd Zeimetz
Author Date: 2008-05-31 16:07:16 UTC

Import patches-unapplied version 2.37-4 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: c52485ad86f6d9581d8284437f27b42c7e853c3f

New changelog entries:
  * debian/po translation updates:
    - ja.po, thanks to Kenshi Muto (Closes: #483505).

ubuntu/hardy-devel 2008-02-09 20:03:39 UTC 2008-02-09
Import patches-unapplied version 2.36-2 to ubuntu/hardy

Author: Bernd Zeimetz
Author Date: 2008-01-13 10:49:55 UTC

Import patches-unapplied version 2.36-2 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 359eefe28c6b4aa71b21fbf6312bc73662ac848e

New changelog entries:
  * debian/patches:
    - Adding garmin-usb-fix.dpatch (r4656 from svn) to fix the broken Garmin
      USB driver. Thanks to P.C. Chan for the help to find the breakage.
      (Closes: #457684)
  * New upstream release.
  * debian/control:
    - Updating/adding versioned build-deps on debhelper and dpkg-dev to ensure
      that debian/package.symbols files are supported.
  * debian/rules:
    - Removing the call of dpkg-gensymbols as this is handled by dh_makeshlibs
      now.
  * debian/libgps17.symbols:
    - Removing the Debian revision from the minimal version number.
    - Adding the symbol garmintxt_parse@Base which was introduced in 2.36.
  * debian/patches:
    - Removing gpsfake-logfile-howto.dpatch and gpsfake-gpsd-path.dpatch -
      integrated upstream.
  * debian/patches:
    - Updating gpsfake-gpsd-path.dpatch to let gpsfake exit gracefully if
      gpsd is not found. Based on a patch by Andreas Putzo.
  * debian/control:
    - Adding gpsd to Recommends for python-gps, thanks to Andreas Putzo
      (Closes: #456929).
  * debian/patches:
    - Adding gpsfake-gpsd-path.dpatch to hardcode the path to gpsd into
      gpsfake.py as /usr/sbin is not in the normal user's path. Thanks again
      to Andreas Putzo (Closes: #456928).
  * New upstream version, including several bugfixes for bugs reported by
    Steinar H. Gunderson (Closes: #410133, #410138, #410132).
  * The license of Tachometer.c was fixed by upstream, so we're able to build
    and ship xgpsspeed again.
  * debian/patches:
    - Dropping the following patches as they are not needed anymore:
      Tachometer.c-removal.dpatch, python-setup.dpatch,
      no-xgpsspeed-manpage.dpatch, gps.h-fix.dpatch, libgpsmm.h-fix.dpatch
    - Adding gpsd_dbus.h-buildfix.dpatch to fix a build failure.
  * debian/libgps17.symbols, debian/rules:
    - Adding symbosl file and running dpkg-gensymbols.
  * debian/control:
    - Bumping Standards-Version to 3.7.3.

ubuntu/hardy 2008-02-09 20:03:39 UTC 2008-02-09
Import patches-unapplied version 2.36-2 to ubuntu/hardy

Author: Bernd Zeimetz
Author Date: 2008-01-13 10:49:55 UTC

Import patches-unapplied version 2.36-2 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 359eefe28c6b4aa71b21fbf6312bc73662ac848e

New changelog entries:
  * debian/patches:
    - Adding garmin-usb-fix.dpatch (r4656 from svn) to fix the broken Garmin
      USB driver. Thanks to P.C. Chan for the help to find the breakage.
      (Closes: #457684)
  * New upstream release.
  * debian/control:
    - Updating/adding versioned build-deps on debhelper and dpkg-dev to ensure
      that debian/package.symbols files are supported.
  * debian/rules:
    - Removing the call of dpkg-gensymbols as this is handled by dh_makeshlibs
      now.
  * debian/libgps17.symbols:
    - Removing the Debian revision from the minimal version number.
    - Adding the symbol garmintxt_parse@Base which was introduced in 2.36.
  * debian/patches:
    - Removing gpsfake-logfile-howto.dpatch and gpsfake-gpsd-path.dpatch -
      integrated upstream.
  * debian/patches:
    - Updating gpsfake-gpsd-path.dpatch to let gpsfake exit gracefully if
      gpsd is not found. Based on a patch by Andreas Putzo.
  * debian/control:
    - Adding gpsd to Recommends for python-gps, thanks to Andreas Putzo
      (Closes: #456929).
  * debian/patches:
    - Adding gpsfake-gpsd-path.dpatch to hardcode the path to gpsd into
      gpsfake.py as /usr/sbin is not in the normal user's path. Thanks again
      to Andreas Putzo (Closes: #456928).
  * New upstream version, including several bugfixes for bugs reported by
    Steinar H. Gunderson (Closes: #410133, #410138, #410132).
  * The license of Tachometer.c was fixed by upstream, so we're able to build
    and ship xgpsspeed again.
  * debian/patches:
    - Dropping the following patches as they are not needed anymore:
      Tachometer.c-removal.dpatch, python-setup.dpatch,
      no-xgpsspeed-manpage.dpatch, gps.h-fix.dpatch, libgpsmm.h-fix.dpatch
    - Adding gpsd_dbus.h-buildfix.dpatch to fix a build failure.
  * debian/libgps17.symbols, debian/rules:
    - Adding symbosl file and running dpkg-gensymbols.
  * debian/control:
    - Bumping Standards-Version to 3.7.3.

ubuntu/gutsy-backports 2007-11-29 15:04:43 UTC 2007-11-29
Import patches-unapplied version 2.34.dfsg-4~gutsy1 to ubuntu/gutsy-backports

Author: Jonathan Riddell
Author Date: 2007-11-29 14:35:50 UTC

Import patches-unapplied version 2.34.dfsg-4~gutsy1 to ubuntu/gutsy-backports

Imported using git-ubuntu import.

Changelog parent: d36f7beacc0a2ea92e9c8c868dd179c6359c6cdd

New changelog entries:
  * Automated backport upload; no source changes.

ubuntu/gutsy 2007-04-27 10:04:07 UTC 2007-04-27
Import patches-unapplied version 2.33-5 to ubuntu/gutsy

Author: Tilman Koschnick
Author Date: 2007-02-25 20:18:11 UTC

Import patches-unapplied version 2.33-5 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: f7cea59db6f49f4946fcaba27a481fe140d50bc0

New changelog entries:
  * debian/control:
    - add build-dependency on autotools-dev
  [ Christian Perrier ]
  * debconf templates:
    - all PO files converted to UTF-8
    - add German translation, thanks to Alwin Meschede (closes: #400511)
    - add Catalan translation, thanks to Jorda Polo (closes: #410213)
    - add Galician translation, thanks to Jacobo Tarrio (closes: #412241)
    - add Portuguese translation, thanks to Miguel Figueiredo (closes: #412257)

ubuntu/gutsy-devel 2007-04-27 10:04:07 UTC 2007-04-27
Import patches-unapplied version 2.33-5 to ubuntu/gutsy

Author: Tilman Koschnick
Author Date: 2007-02-25 20:18:11 UTC

Import patches-unapplied version 2.33-5 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: f7cea59db6f49f4946fcaba27a481fe140d50bc0

New changelog entries:
  * debian/control:
    - add build-dependency on autotools-dev
  [ Christian Perrier ]
  * debconf templates:
    - all PO files converted to UTF-8
    - add German translation, thanks to Alwin Meschede (closes: #400511)
    - add Catalan translation, thanks to Jorda Polo (closes: #410213)
    - add Galician translation, thanks to Jacobo Tarrio (closes: #412241)
    - add Portuguese translation, thanks to Miguel Figueiredo (closes: #412257)

ubuntu/feisty-devel 2006-11-08 09:03:37 UTC 2006-11-08
Import patches-unapplied version 2.33-4 to ubuntu/feisty

Author: Tilman Koschnick
Author Date: 2006-10-07 19:41:37 UTC

Import patches-unapplied version 2.33-4 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: c91a8d7f45ef24f5d1f2f9ecb962cb8a54359771

New changelog entries:
  * debian/patches/:
    - add 23_hotplug_racecond.dpatch (closes: #321421)
  * /etc/init.d/gpsd:
    - order run levels in LSB headers
  * Upload sponsored by Petter Reinholdtsen
  * Acknowledging previous NMU, thanks to Kai Hendry (closes: #377773)
  * remove rpath from binaries (required on amd64, ?)
  * /etc/init.d/gpsd:
    - require /etc/default/gpsd
    - add Short-Description to LSB section
    - use LSB logging functions
    - remove 'S' from Default-Stop LSB header
  * use python-support to install python modules
  * debian/control:
    - improve package description
    - drop alternative build dependency on libxaw6-dev
    - add build dependency on docbook-xsl (>= 1.71.0.dfsg.1-1), allowing to:
  * debian/patches/:
    - preserve <screen> environments in 22_manpage_linebreak.dpatch
  * Upload sponsored by Petter Reinholdtsen

ubuntu/feisty 2006-11-08 09:03:37 UTC 2006-11-08
Import patches-unapplied version 2.33-4 to ubuntu/feisty

Author: Tilman Koschnick
Author Date: 2006-10-07 19:41:37 UTC

Import patches-unapplied version 2.33-4 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: c91a8d7f45ef24f5d1f2f9ecb962cb8a54359771

New changelog entries:
  * debian/patches/:
    - add 23_hotplug_racecond.dpatch (closes: #321421)
  * /etc/init.d/gpsd:
    - order run levels in LSB headers
  * Upload sponsored by Petter Reinholdtsen
  * Acknowledging previous NMU, thanks to Kai Hendry (closes: #377773)
  * remove rpath from binaries (required on amd64, ?)
  * /etc/init.d/gpsd:
    - require /etc/default/gpsd
    - add Short-Description to LSB section
    - use LSB logging functions
    - remove 'S' from Default-Stop LSB header
  * use python-support to install python modules
  * debian/control:
    - improve package description
    - drop alternative build dependency on libxaw6-dev
    - add build dependency on docbook-xsl (>= 1.71.0.dfsg.1-1), allowing to:
  * debian/patches/:
    - preserve <screen> environments in 22_manpage_linebreak.dpatch
  * Upload sponsored by Petter Reinholdtsen

ubuntu/edgy 2006-08-30 21:03:36 UTC 2006-08-30
Import patches-unapplied version 2.33-2.1build1 to ubuntu/edgy

Author: Sebastian Dröge
Author Date: 2006-08-30 20:00:48 UTC

Import patches-unapplied version 2.33-2.1build1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: c91a8d7f45ef24f5d1f2f9ecb962cb8a54359771

New changelog entries:
  * Rebuild against dbus 0.90

ubuntu/edgy-devel 2006-08-30 21:03:36 UTC 2006-08-30
Import patches-unapplied version 2.33-2.1build1 to ubuntu/edgy

Author: Sebastian Dröge
Author Date: 2006-08-30 20:00:48 UTC

Import patches-unapplied version 2.33-2.1build1 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: c91a8d7f45ef24f5d1f2f9ecb962cb8a54359771

New changelog entries:
  * Rebuild against dbus 0.90

applied/ubuntu/devel 2005-12-21 16:38:16 UTC 2005-12-21
Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Author: Michael Vogt
Author Date: 2005-12-20 21:51:42 UTC

Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 240ad257635616ef24ab2e6dd12024a832def6d8
Unapplied parent: 4cdab0a85afb3bb5df6cc1ab3530ba2436e3236e

New changelog entries:
  * rebuild against latest dbus
  * debian/rules:
    - Force LDFLAGS="$(LDFLAGS) -lm" upon build. (closes: #340852)
  * Resynchronize with Debian.
  * debian/control: drop Standards-Version update
  * debian/patches:
    - Update 13_dbus_new_api.dpatch to get new gpxlogger building.
  * New upstream release
  * debian/copyright: update author list
  * debian/patches/:
    - add 13_include_xm_fix.dpatch
  * debconf templates:
    - add Swedish translation, thanks to Daniel Nylander (closes: #333676)
  * New upstream release
    - new programs: cgps, gpsflash, gpspipe, gpxlogger, rtcmdecode
  * move sirfmon to gpsd-clients package
  * debian/patches/:
    - rm 12_send_dbus_fix.dpatch (included upstream)
  * update lintian-overrides
  * Resynchronise with Debian.
  * debian/control: update Standards-Version
  * recompile against libstdc++6

applied/ubuntu/dapper-devel 2005-12-21 16:38:16 UTC 2005-12-21
Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Author: Michael Vogt
Author Date: 2005-12-20 21:51:42 UTC

Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 240ad257635616ef24ab2e6dd12024a832def6d8
Unapplied parent: 4cdab0a85afb3bb5df6cc1ab3530ba2436e3236e

New changelog entries:
  * rebuild against latest dbus
  * debian/rules:
    - Force LDFLAGS="$(LDFLAGS) -lm" upon build. (closes: #340852)
  * Resynchronize with Debian.
  * debian/control: drop Standards-Version update
  * debian/patches:
    - Update 13_dbus_new_api.dpatch to get new gpxlogger building.
  * New upstream release
  * debian/copyright: update author list
  * debian/patches/:
    - add 13_include_xm_fix.dpatch
  * debconf templates:
    - add Swedish translation, thanks to Daniel Nylander (closes: #333676)
  * New upstream release
    - new programs: cgps, gpsflash, gpspipe, gpxlogger, rtcmdecode
  * move sirfmon to gpsd-clients package
  * debian/patches/:
    - rm 12_send_dbus_fix.dpatch (included upstream)
  * update lintian-overrides
  * Resynchronise with Debian.
  * debian/control: update Standards-Version
  * recompile against libstdc++6

applied/ubuntu/dapper 2005-12-21 16:38:16 UTC 2005-12-21
Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Author: Michael Vogt
Author Date: 2005-12-20 21:51:42 UTC

Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 240ad257635616ef24ab2e6dd12024a832def6d8
Unapplied parent: 4cdab0a85afb3bb5df6cc1ab3530ba2436e3236e

New changelog entries:
  * rebuild against latest dbus
  * debian/rules:
    - Force LDFLAGS="$(LDFLAGS) -lm" upon build. (closes: #340852)
  * Resynchronize with Debian.
  * debian/control: drop Standards-Version update
  * debian/patches:
    - Update 13_dbus_new_api.dpatch to get new gpxlogger building.
  * New upstream release
  * debian/copyright: update author list
  * debian/patches/:
    - add 13_include_xm_fix.dpatch
  * debconf templates:
    - add Swedish translation, thanks to Daniel Nylander (closes: #333676)
  * New upstream release
    - new programs: cgps, gpsflash, gpspipe, gpxlogger, rtcmdecode
  * move sirfmon to gpsd-clients package
  * debian/patches/:
    - rm 12_send_dbus_fix.dpatch (included upstream)
  * update lintian-overrides
  * Resynchronise with Debian.
  * debian/control: update Standards-Version
  * recompile against libstdc++6

ubuntu/dapper-devel 2005-12-21 16:38:16 UTC 2005-12-21
Import patches-unapplied version 2.30-1ubuntu3 to ubuntu/dapper

Author: Michael Vogt
Author Date: 2005-12-20 21:51:42 UTC

Import patches-unapplied version 2.30-1ubuntu3 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 4905c00790f48987d4ce8b44e2ee65757ec2bb74

New changelog entries:
  * rebuild against latest dbus
  * debian/rules:
    - Force LDFLAGS="$(LDFLAGS) -lm" upon build. (closes: #340852)
  * Resynchronize with Debian.
  * debian/control: drop Standards-Version update
  * debian/patches:
    - Update 13_dbus_new_api.dpatch to get new gpxlogger building.
  * New upstream release
  * debian/copyright: update author list
  * debian/patches/:
    - add 13_include_xm_fix.dpatch
  * debconf templates:
    - add Swedish translation, thanks to Daniel Nylander (closes: #333676)
  * New upstream release
    - new programs: cgps, gpsflash, gpspipe, gpxlogger, rtcmdecode
  * move sirfmon to gpsd-clients package
  * debian/patches/:
    - rm 12_send_dbus_fix.dpatch (included upstream)
  * update lintian-overrides
  * Resynchronise with Debian.
  * debian/control: update Standards-Version
  * recompile against libstdc++6

ubuntu/dapper 2005-12-21 16:38:16 UTC 2005-12-21
Import patches-unapplied version 2.30-1ubuntu3 to ubuntu/dapper

Author: Michael Vogt
Author Date: 2005-12-20 21:51:42 UTC

Import patches-unapplied version 2.30-1ubuntu3 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 4905c00790f48987d4ce8b44e2ee65757ec2bb74

New changelog entries:
  * rebuild against latest dbus
  * debian/rules:
    - Force LDFLAGS="$(LDFLAGS) -lm" upon build. (closes: #340852)
  * Resynchronize with Debian.
  * debian/control: drop Standards-Version update
  * debian/patches:
    - Update 13_dbus_new_api.dpatch to get new gpxlogger building.
  * New upstream release
  * debian/copyright: update author list
  * debian/patches/:
    - add 13_include_xm_fix.dpatch
  * debconf templates:
    - add Swedish translation, thanks to Daniel Nylander (closes: #333676)
  * New upstream release
    - new programs: cgps, gpsflash, gpspipe, gpxlogger, rtcmdecode
  * move sirfmon to gpsd-clients package
  * debian/patches/:
    - rm 12_send_dbus_fix.dpatch (included upstream)
  * update lintian-overrides
  * Resynchronise with Debian.
  * debian/control: update Standards-Version
  * recompile against libstdc++6

applied/ubuntu/edgy-devel 2005-12-21 16:38:16 UTC 2005-12-21
Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Author: Michael Vogt
Author Date: 2005-12-20 21:51:42 UTC

Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 240ad257635616ef24ab2e6dd12024a832def6d8
Unapplied parent: 4cdab0a85afb3bb5df6cc1ab3530ba2436e3236e

New changelog entries:
  * rebuild against latest dbus
  * debian/rules:
    - Force LDFLAGS="$(LDFLAGS) -lm" upon build. (closes: #340852)
  * Resynchronize with Debian.
  * debian/control: drop Standards-Version update
  * debian/patches:
    - Update 13_dbus_new_api.dpatch to get new gpxlogger building.
  * New upstream release
  * debian/copyright: update author list
  * debian/patches/:
    - add 13_include_xm_fix.dpatch
  * debconf templates:
    - add Swedish translation, thanks to Daniel Nylander (closes: #333676)
  * New upstream release
    - new programs: cgps, gpsflash, gpspipe, gpxlogger, rtcmdecode
  * move sirfmon to gpsd-clients package
  * debian/patches/:
    - rm 12_send_dbus_fix.dpatch (included upstream)
  * update lintian-overrides
  * Resynchronise with Debian.
  * debian/control: update Standards-Version
  * recompile against libstdc++6

applied/ubuntu/edgy 2005-12-21 16:38:16 UTC 2005-12-21
Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Author: Michael Vogt
Author Date: 2005-12-20 21:51:42 UTC

Import patches-applied version 2.30-1ubuntu3 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 240ad257635616ef24ab2e6dd12024a832def6d8
Unapplied parent: 4cdab0a85afb3bb5df6cc1ab3530ba2436e3236e

New changelog entries:
  * rebuild against latest dbus
  * debian/rules:
    - Force LDFLAGS="$(LDFLAGS) -lm" upon build. (closes: #340852)
  * Resynchronize with Debian.
  * debian/control: drop Standards-Version update
  * debian/patches:
    - Update 13_dbus_new_api.dpatch to get new gpxlogger building.
  * New upstream release
  * debian/copyright: update author list
  * debian/patches/:
    - add 13_include_xm_fix.dpatch
  * debconf templates:
    - add Swedish translation, thanks to Daniel Nylander (closes: #333676)
  * New upstream release
    - new programs: cgps, gpsflash, gpspipe, gpxlogger, rtcmdecode
  * move sirfmon to gpsd-clients package
  * debian/patches/:
    - rm 12_send_dbus_fix.dpatch (included upstream)
  * update lintian-overrides
  * Resynchronise with Debian.
  * debian/control: update Standards-Version
  * recompile against libstdc++6

applied/ubuntu/breezy-devel 2005-12-21 05:03:32 UTC 2005-12-21
Import patches-applied version 2.28-1ubuntu1 to applied/ubuntu/breezy

Author: Sebastian Dröge
Author Date: 2005-07-27 16:33:41 UTC

Import patches-applied version 2.28-1ubuntu1 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: a72282b4f06bf72395df42155e2cd922eb8e5804
Unapplied parent: 4905c00790f48987d4ce8b44e2ee65757ec2bb74

New changelog entries:
  * Resynchronise with Debian.
  * 13_dbus_new_api.dpatch
    -move gpsd to the new DBUS API
  * New upstream release
  * debian/patches/:
    - rm 10_dbus_fix.dpatch (included upstream)
    - rm 11_hotplug_fix.dpatch (obsolete)
    - add 12_send_dbus_fix.dpatch
  * update lintian-overrides
  * New upstream release
    - bugfix: gps.h refers to missing gpsutils.h (closes: #314998)
  * compile with dbus support
  * debian/patches/:
    - rm 09_gpsdrive_fix.dpatch (obsolete)
    - add 10_dbus_fix.dpatch
    - add 11_hotplug_fix.dpatch
  * update lintian-overrides
  * debconf templates:
    - update French translation, thanks to Jean-Luc Coulon (closes: #315364)
  * bump Standards-Version to 3.6.2 (no changes required)
  * New upstream release (closes: #301469)
    - license change from GPL to BSD
    - gpsd now starts as root and drops privileges afterwards; this is
      required for the interface to ntpd, see README.Debian for details
    - no default device /dev/gps anymore (closes: #303174)
    - bugfix: libgps leaks socket fd when setsockopt or connect fails
      (closes: #299427)
    - hotplug support added
    - new sirfmon program
    - gpsprobe removed
  * add dependency on netbase (closes: #299286)
  * prefere build dependency on lesstif2 over lesstif
  * debian/patches/:
    - rm 03_documentation.dpatch
    - rm 07_unit_options.dpatch (not accepted upstream, superseded by
      less intrusive 08_default_units.dpatch)
    - add 08_default_units.dpatch
    - add 09_gpsdrive_fix.dpatch
  * update lintian-overrides
  * revise README.Debian
  * debconf templates:
    - add Czech translation, thanks to Miroslav Kure (closes: #310466)
    - add Vietnamese translation, thanks to Clytie Siddall (closes: #311879)
  * New upstream release
    - new gpsfake, gpsprof programs
  * add CAN number to previous changelog version
  * debian/patches/:
    - rm 05_gps_py_typo.dpatch (included upstream)
    - rm 06_X11_ad_files.dpatch (included upstream)
    - rm 08_maxchannels.dpatch (obsolete)
    - rm 09_syslog_formatstring.dpatch (obsolete)
  * update lintian-overrides
  * setting urgency=high because of RC bugfix
  * bugfix: remote security problem with format strings
    - CAN-2004-1388
    - add debian/patches/09_syslog_formatstring.dpatch
    - thanks to Ulf Harnhammar, KF, Petter Reinholdtsen
      (closes: #292347, #292370)
  * fix lintian warnings
    - change description of gpsd-clients
    - add /usr/share/lintian/overrides/gpsd
      (ignoring non-dev-pkg-with-shlib-symlink,
      description-synopsis-starts-with-a-capital-letter)
  * import bugfixes from upstream's SVN
    - avoid potential buffer overrun and memory leak
    - add debian/patches/08_maxchannels.dpatch
  * X11 app-defaults files:
    - include xgps*.ad
    - add debian/patches/06_X11_ad_files.dpatch
  * fix speedunits, altunits options:
    - add debian/patches/07_unit_options.dpatch
    - rm debian/patches/01_speedunits.dpatch (superseded by 07_unit_options)
  * New upstream release
  * added -P <pidfile> option
    - use option in /etc/init.d/gpsd
    - closes: #287737
  * debian/patches/:
    - upstream renames gps to xgps; rm 02_gps_to_xgps.dpatch (obsolete)
    - add 01_speedunits.dpatch: use metric system by default
      (closes: #289944)
    - add 05_gps_py_typo.dpatch: fix syntax error in gps.py

ubuntu/breezy-devel 2005-12-21 05:03:32 UTC 2005-12-21
Import patches-unapplied version 2.28-1ubuntu1 to ubuntu/breezy

Author: Sebastian Dröge
Author Date: 2005-07-27 16:33:41 UTC

Import patches-unapplied version 2.28-1ubuntu1 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: b7cf2d6d746a22fb8d21b2c412ef684dc56de73d

New changelog entries:
  * Resynchronise with Debian.
  * 13_dbus_new_api.dpatch
    -move gpsd to the new DBUS API
  * New upstream release
  * debian/patches/:
    - rm 10_dbus_fix.dpatch (included upstream)
    - rm 11_hotplug_fix.dpatch (obsolete)
    - add 12_send_dbus_fix.dpatch
  * update lintian-overrides
  * New upstream release
    - bugfix: gps.h refers to missing gpsutils.h (closes: #314998)
  * compile with dbus support
  * debian/patches/:
    - rm 09_gpsdrive_fix.dpatch (obsolete)
    - add 10_dbus_fix.dpatch
    - add 11_hotplug_fix.dpatch
  * update lintian-overrides
  * debconf templates:
    - update French translation, thanks to Jean-Luc Coulon (closes: #315364)
  * bump Standards-Version to 3.6.2 (no changes required)
  * New upstream release (closes: #301469)
    - license change from GPL to BSD
    - gpsd now starts as root and drops privileges afterwards; this is
      required for the interface to ntpd, see README.Debian for details
    - no default device /dev/gps anymore (closes: #303174)
    - bugfix: libgps leaks socket fd when setsockopt or connect fails
      (closes: #299427)
    - hotplug support added
    - new sirfmon program
    - gpsprobe removed
  * add dependency on netbase (closes: #299286)
  * prefere build dependency on lesstif2 over lesstif
  * debian/patches/:
    - rm 03_documentation.dpatch
    - rm 07_unit_options.dpatch (not accepted upstream, superseded by
      less intrusive 08_default_units.dpatch)
    - add 08_default_units.dpatch
    - add 09_gpsdrive_fix.dpatch
  * update lintian-overrides
  * revise README.Debian
  * debconf templates:
    - add Czech translation, thanks to Miroslav Kure (closes: #310466)
    - add Vietnamese translation, thanks to Clytie Siddall (closes: #311879)
  * New upstream release
    - new gpsfake, gpsprof programs
  * add CAN number to previous changelog version
  * debian/patches/:
    - rm 05_gps_py_typo.dpatch (included upstream)
    - rm 06_X11_ad_files.dpatch (included upstream)
    - rm 08_maxchannels.dpatch (obsolete)
    - rm 09_syslog_formatstring.dpatch (obsolete)
  * update lintian-overrides
  * setting urgency=high because of RC bugfix
  * bugfix: remote security problem with format strings
    - CAN-2004-1388
    - add debian/patches/09_syslog_formatstring.dpatch
    - thanks to Ulf Harnhammar, KF, Petter Reinholdtsen
      (closes: #292347, #292370)
  * fix lintian warnings
    - change description of gpsd-clients
    - add /usr/share/lintian/overrides/gpsd
      (ignoring non-dev-pkg-with-shlib-symlink,
      description-synopsis-starts-with-a-capital-letter)
  * import bugfixes from upstream's SVN
    - avoid potential buffer overrun and memory leak
    - add debian/patches/08_maxchannels.dpatch
  * X11 app-defaults files:
    - include xgps*.ad
    - add debian/patches/06_X11_ad_files.dpatch
  * fix speedunits, altunits options:
    - add debian/patches/07_unit_options.dpatch
    - rm debian/patches/01_speedunits.dpatch (superseded by 07_unit_options)
  * New upstream release
  * added -P <pidfile> option
    - use option in /etc/init.d/gpsd
    - closes: #287737
  * debian/patches/:
    - upstream renames gps to xgps; rm 02_gps_to_xgps.dpatch (obsolete)
    - add 01_speedunits.dpatch: use metric system by default
      (closes: #289944)
    - add 05_gps_py_typo.dpatch: fix syntax error in gps.py

1100 of 106 results

Other repositories

Name Last Modified
lp:ubuntu/+source/gpsd 2019-10-26
11 of 1 result
You can't create new repositories for gpsd in Ubuntu.