View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/dbus
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
ubuntu/quantal 2012-10-03 21:03:45 UTC 2012-10-03
Import patches-unapplied version 1.6.4-1ubuntu4 to ubuntu/quantal-proposed

Author: Marc Deslauriers
Author Date: 2012-10-03 18:41:36 UTC

Import patches-unapplied version 1.6.4-1ubuntu4 to ubuntu/quantal-proposed

Imported using git-ubuntu import.

Changelog parent: 56bfdcbbbc646dfa70d26fe3ca4a5431aff6a105

New changelog entries:
  * debian/patches/CVE-2012-3524-regression-fix.patch: updated to fix test
    suite.

ubuntu/quantal-proposed 2012-10-03 21:03:45 UTC 2012-10-03
Import patches-unapplied version 1.6.4-1ubuntu4 to ubuntu/quantal-proposed

Author: Marc Deslauriers
Author Date: 2012-10-03 18:41:36 UTC

Import patches-unapplied version 1.6.4-1ubuntu4 to ubuntu/quantal-proposed

Imported using git-ubuntu import.

Changelog parent: 56bfdcbbbc646dfa70d26fe3ca4a5431aff6a105

New changelog entries:
  * debian/patches/CVE-2012-3524-regression-fix.patch: updated to fix test
    suite.

ubuntu/precise 2012-02-22 09:03:38 UTC 2012-02-22
Import patches-unapplied version 1.4.18-1ubuntu1 to ubuntu/precise

Author: Martin Pitt
Author Date: 2012-02-22 08:26:02 UTC

Import patches-unapplied version 1.4.18-1ubuntu1 to ubuntu/precise

Imported using git-ubuntu import.

Changelog parent: 91b8abf99c4c0c018a89f24c97b00ae7f9d4e8b7

New changelog entries:
  * Merge with Debian unstable to pick up the new bug fix release. Remaining
    Ubuntu changes:
    - Install binaries into / rather than /usr:
      + debian/rules: Set --exec-prefix=/
      + debian/dbus.install, debian/dbus-x11.install: Install from /bin
    - Use upstart to start:
      + Add debian/dbus.upstart.
      + debian/control: Add upstart dependency.
      + debian/dbus.postinst: Use upstart call instead of invoking the init.d
        script for checking if we are already running.
      + debian/control: versioned dependency on netbase that emits the new
        deconfiguring-networking event used in upstart script.
    - 20_system_conf_limit.patch: Increase max_match_rules_per_connection for
      the system bus to 5000 (LP #454093)
    - 81-session.conf-timeout.patch: Raise the service startup timeout from 25
      to 60 seconds. It may be too short on the live CD with slow machines.
    - Add 0001-activation-allow-for-more-variation-than-just-system.patch,
      0002-bus-change-systemd-activation-to-activation-systemd.patch,
      0003-upstart-add-upstart-as-a-possible-activation-type.patch,
      0004-upstart-add-UpstartJob-to-service-desktop-files.patch,
      0005-activation-implement-upstart-activation.patch: Patches from Scott
      James Remnant to implement Upstart service activation. Not upstream.

applied/debian/lenny 2011-10-01 21:11:02 UTC 2011-10-01
Import patches-applied version 1.2.1-5+lenny2 to applied/debian/lenny

Author: Nico Golde
Author Date: 2011-01-15 14:54:45 UTC

Import patches-applied version 1.2.1-5+lenny2 to applied/debian/lenny

Imported using git-ubuntu import.

Changelog parent: 7e97946a8333199dd817bb5ec4455a5cd0339a68
Unapplied parent: 31e5e8cc61a04dc47b1a200e02183572392cfa08

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Backport upstream patch to fix a possible call stack overflow and thus
    denial of service, when processing messages with excessive nested variants.
    This fix restricts the nesting level to 64 (52-CVE-2010-4352.patch).

debian/lenny 2011-10-01 21:11:02 UTC 2011-10-01
Import patches-unapplied version 1.2.1-5+lenny2 to debian/lenny

Author: Nico Golde
Author Date: 2011-01-15 14:54:45 UTC

Import patches-unapplied version 1.2.1-5+lenny2 to debian/lenny

Imported using git-ubuntu import.

Changelog parent: 1dad94b08176a350a09c78015aae70b2998764fa

New changelog entries:
  * Non-maintainer upload by the Security Team.
  * Backport upstream patch to fix a possible call stack overflow and thus
    denial of service, when processing messages with excessive nested variants.
    This fix restricts the nesting level to 64 (52-CVE-2010-4352.patch).

ubuntu/oneiric 2011-09-02 10:03:50 UTC 2011-09-02
Import patches-unapplied version 1.4.14-1ubuntu1 to ubuntu/oneiric

Author: Martin Pitt
Author Date: 2011-09-02 06:42:50 UTC

Import patches-unapplied version 1.4.14-1ubuntu1 to ubuntu/oneiric

Imported using git-ubuntu import.

Changelog parent: f9f04a66b8ebd872d543e405fed078564ef4935d

New changelog entries:
  * Merge with Debian unstable. Remaining changes:
    - Install binaries into / rather than /usr:
      + debian/rules: Set --exec-prefix=/
      + debian/dbus.install, debian/dbus-x11.install: Install from /bin
    - Use upstart to start:
      + Add debian/dbus.upstart.
      + debian/control: Add upstart dependency.
      + debian/dbus.postinst: Use upstart call instead of invoking the init.d
        script for checking if we are already running.
      + debian/control: versioned dependency on netbase that emits the new
        deconfiguring-networking event used in upstart script.
    - 20_system_conf_limit.patch: Increase max_match_rules_per_connection for
      the system bus to 5000 (LP #454093)
    - 81-session.conf-timeout.patch: Raise the service startup timeout from 25
      to 60 seconds. It may be too short on the live CD with slow machines.
    - Add 0001-activation-allow-for-more-variation-than-just-system.patch,
      0002-bus-change-systemd-activation-to-activation-systemd.patch,
      0003-upstart-add-upstart-as-a-possible-activation-type.patch,
      0004-upstart-add-UpstartJob-to-service-desktop-files.patch,
      0005-activation-implement-upstart-activation.patch: Patches from Scott
      James Remnant to implement Upstart service activation. Not upstream.

ubuntu/maverick-security 2011-07-26 22:05:11 UTC 2011-07-26
Import patches-unapplied version 1.4.0-0ubuntu1.3 to ubuntu/maverick-security

Author: Jamie Strandboge
Author Date: 2011-07-22 14:01:52 UTC

Import patches-unapplied version 1.4.0-0ubuntu1.3 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 621aaf9aa257ef2a2497ca3340d761ff884d7aca

New changelog entries:
  * SECURITY UPDATE: denial of service via messages with non-native byte order
    - debian/patches/99-CVE-2011-2200.patch: update dbus-marshal-header.c
      to verify header->data byte order and header->byte_order match in
      _dbus_header_byteswap()
    - CVE-2011-2200

ubuntu/maverick-updates 2011-07-26 22:05:11 UTC 2011-07-26
Import patches-unapplied version 1.4.0-0ubuntu1.3 to ubuntu/maverick-security

Author: Jamie Strandboge
Author Date: 2011-07-22 14:01:52 UTC

Import patches-unapplied version 1.4.0-0ubuntu1.3 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 621aaf9aa257ef2a2497ca3340d761ff884d7aca

New changelog entries:
  * SECURITY UPDATE: denial of service via messages with non-native byte order
    - debian/patches/99-CVE-2011-2200.patch: update dbus-marshal-header.c
      to verify header->data byte order and header->byte_order match in
      _dbus_header_byteswap()
    - CVE-2011-2200

ubuntu/maverick-devel 2011-07-26 22:05:11 UTC 2011-07-26
Import patches-unapplied version 1.4.0-0ubuntu1.3 to ubuntu/maverick-security

Author: Jamie Strandboge
Author Date: 2011-07-22 14:01:52 UTC

Import patches-unapplied version 1.4.0-0ubuntu1.3 to ubuntu/maverick-security

Imported using git-ubuntu import.

Changelog parent: 621aaf9aa257ef2a2497ca3340d761ff884d7aca

New changelog entries:
  * SECURITY UPDATE: denial of service via messages with non-native byte order
    - debian/patches/99-CVE-2011-2200.patch: update dbus-marshal-header.c
      to verify header->data byte order and header->byte_order match in
      _dbus_header_byteswap()
    - CVE-2011-2200

ubuntu/natty 2011-03-20 23:05:01 UTC 2011-03-20
Import patches-unapplied version 1.4.6-1ubuntu6 to ubuntu/natty

Author: Steve Langasek
Author Date: 2011-03-20 22:07:49 UTC

Import patches-unapplied version 1.4.6-1ubuntu6 to ubuntu/natty

Imported using git-ubuntu import.

Changelog parent: 89296e9872260958e0eff488d2a93fd746b0b119

New changelog entries:
  * debian/rules: fix up the sed of the .pc file, we need the path to be
    relative to the multiarch dir. Thanks to Lionel Le Folgoc for pointing
    this out.

ubuntu/maverick-proposed 2011-03-04 18:05:06 UTC 2011-03-04
Import patches-unapplied version 1.4.0-0ubuntu1.2 to ubuntu/maverick-proposed

Author: Alkis Georgopoulos
Author Date: 2011-02-14 09:49:57 UTC

Import patches-unapplied version 1.4.0-0ubuntu1.2 to ubuntu/maverick-proposed

Imported using git-ubuntu import.

Changelog parent: f4d282b686db158876081f65c8329142bcfe6e19

New changelog entries:
  * Prevent dbus.postinst from failing in chroots (LP: #552404).

ubuntu/lucid-proposed 2011-03-04 18:05:06 UTC 2011-03-04
Import patches-unapplied version 1.2.16-2ubuntu4.2 to ubuntu/lucid-proposed

Author: Alkis Georgopoulos
Author Date: 2011-01-21 10:55:56 UTC

Import patches-unapplied version 1.2.16-2ubuntu4.2 to ubuntu/lucid-proposed

Imported using git-ubuntu import.

Changelog parent: adc4c84ba6eac2448be5bbabaf4650a189cebbc3

New changelog entries:
  * Prevent dbus.postinst from failing in chroots (LP: #552404)

ubuntu/karmic-updates 2011-01-18 17:05:13 UTC 2011-01-18
Import patches-unapplied version 1.2.16-0ubuntu9.1 to ubuntu/karmic-security

Author: Jamie Strandboge
Author Date: 2011-01-04 20:37:19 UTC

Import patches-unapplied version 1.2.16-0ubuntu9.1 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 94006d948fb784364b48da7c98ec7d63d1ccfcec

New changelog entries:
  * SECURITY UPDATE: fix DoS with too deeply nested messages
    - debian/patches/99-CVE-2010-4352.patch: Limit nesting to 64 for dynamic
      message variants. Backported from upstream.
    - CVE-2010-4352
    - LP: #688992
  * debian/control: Build-Depends on libexpat1-dev instead of libexpat-dev

ubuntu/karmic-security 2011-01-18 17:05:13 UTC 2011-01-18
Import patches-unapplied version 1.2.16-0ubuntu9.1 to ubuntu/karmic-security

Author: Jamie Strandboge
Author Date: 2011-01-04 20:37:19 UTC

Import patches-unapplied version 1.2.16-0ubuntu9.1 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 94006d948fb784364b48da7c98ec7d63d1ccfcec

New changelog entries:
  * SECURITY UPDATE: fix DoS with too deeply nested messages
    - debian/patches/99-CVE-2010-4352.patch: Limit nesting to 64 for dynamic
      message variants. Backported from upstream.
    - CVE-2010-4352
    - LP: #688992
  * debian/control: Build-Depends on libexpat1-dev instead of libexpat-dev

ubuntu/karmic-devel 2011-01-18 17:05:13 UTC 2011-01-18
Import patches-unapplied version 1.2.16-0ubuntu9.1 to ubuntu/karmic-security

Author: Jamie Strandboge
Author Date: 2011-01-04 20:37:19 UTC

Import patches-unapplied version 1.2.16-0ubuntu9.1 to ubuntu/karmic-security

Imported using git-ubuntu import.

Changelog parent: 94006d948fb784364b48da7c98ec7d63d1ccfcec

New changelog entries:
  * SECURITY UPDATE: fix DoS with too deeply nested messages
    - debian/patches/99-CVE-2010-4352.patch: Limit nesting to 64 for dynamic
      message variants. Backported from upstream.
    - CVE-2010-4352
    - LP: #688992
  * debian/control: Build-Depends on libexpat1-dev instead of libexpat-dev

ubuntu/maverick 2010-09-27 22:06:00 UTC 2010-09-27
Import patches-unapplied version 1.4.0-0ubuntu1 to ubuntu/maverick

Author: Jonathan Riddell
Author Date: 2010-09-27 12:06:32 UTC

Import patches-unapplied version 1.4.0-0ubuntu1 to ubuntu/maverick

Imported using git-ubuntu import.

Changelog parent: 7e336121ec8ca10289b23bde366e41710c815c84

New changelog entries:
  * New upstream release
   - Fixes https://bugs.freedesktop.org/show_bug.cgi?id=17754 Race condition in protected_change_timeout
   - Requested by various upstream KDE developers http://lists.kde.org/?t=128514970000004&r=1&w=2

ubuntu/lucid 2010-03-30 15:05:10 UTC 2010-03-30
Import patches-unapplied version 1.2.16-2ubuntu4 to ubuntu/lucid

Author: Martin Pitt
Author Date: 2010-03-30 14:28:07 UTC

Import patches-unapplied version 1.2.16-2ubuntu4 to ubuntu/lucid

Imported using git-ubuntu import.

Changelog parent: 1fbe35404441b3b30a798e2eeaa73a886ff7a2a5

New changelog entries:
  * Add debian/dbus.links: provide a symlink for dbus-daemon-launch-helper's
    old location in /usr, to provide a more stable upgrade from Hardy. This
    can be dropped in Lucid+1. (LP: #551672)

ubuntu/karmic 2009-10-24 05:04:37 UTC 2009-10-24
Import patches-unapplied version 1.2.16-0ubuntu9 to ubuntu/karmic

Author: Michael Vogt
Author Date: 2009-10-23 18:10:26 UTC

Import patches-unapplied version 1.2.16-0ubuntu9 to ubuntu/karmic

Imported using git-ubuntu import.

Changelog parent: fbd7eed65d3e9fd8fb78166897033b140841435f

New changelog entries:
  * 20_system_conf_limit.patch:
    - increase max_match_rules_per_connection for the system
      bus to 5000 (LP: #454093)

ubuntu/jaunty-devel 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 1.2.12-0ubuntu2.1 to ubuntu/jaunty-security

Author: Marc Deslauriers
Author Date: 2009-07-06 14:44:11 UTC

Import patches-unapplied version 1.2.12-0ubuntu2.1 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: c640117f56aa3af949fe30b403437db56f69b6bc

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/82-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/intrepid-devel 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 1.2.4-0ubuntu1.1 to ubuntu/intrepid-security

Author: Marc Deslauriers
Author Date: 2009-07-06 14:49:54 UTC

Import patches-unapplied version 1.2.4-0ubuntu1.1 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: b9421c8edc78a3a2303cccfff5d5ef7ac46d6e38

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/82-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/intrepid-security 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 1.2.4-0ubuntu1.1 to ubuntu/intrepid-security

Author: Marc Deslauriers
Author Date: 2009-07-06 14:49:54 UTC

Import patches-unapplied version 1.2.4-0ubuntu1.1 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: b9421c8edc78a3a2303cccfff5d5ef7ac46d6e38

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/82-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/intrepid-updates 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 1.2.4-0ubuntu1.1 to ubuntu/intrepid-security

Author: Marc Deslauriers
Author Date: 2009-07-06 14:49:54 UTC

Import patches-unapplied version 1.2.4-0ubuntu1.1 to ubuntu/intrepid-security

Imported using git-ubuntu import.

Changelog parent: b9421c8edc78a3a2303cccfff5d5ef7ac46d6e38

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/82-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/jaunty-security 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 1.2.12-0ubuntu2.1 to ubuntu/jaunty-security

Author: Marc Deslauriers
Author Date: 2009-07-06 14:44:11 UTC

Import patches-unapplied version 1.2.12-0ubuntu2.1 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: c640117f56aa3af949fe30b403437db56f69b6bc

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/82-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/jaunty-updates 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 1.2.12-0ubuntu2.1 to ubuntu/jaunty-security

Author: Marc Deslauriers
Author Date: 2009-07-06 14:44:11 UTC

Import patches-unapplied version 1.2.12-0ubuntu2.1 to ubuntu/jaunty-security

Imported using git-ubuntu import.

Changelog parent: c640117f56aa3af949fe30b403437db56f69b6bc

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/82-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/dapper-updates 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 0.60-6ubuntu8.4 to ubuntu/dapper-security

Author: Marc Deslauriers
Author Date: 2009-07-06 15:20:45 UTC

Import patches-unapplied version 0.60-6ubuntu8.4 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: a6945c80b604df6be452270523fe3ae44c48dbbf

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/84-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/dapper-security 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 0.60-6ubuntu8.4 to ubuntu/dapper-security

Author: Marc Deslauriers
Author Date: 2009-07-06 15:20:45 UTC

Import patches-unapplied version 0.60-6ubuntu8.4 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: a6945c80b604df6be452270523fe3ae44c48dbbf

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/84-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/dapper-devel 2009-07-13 19:04:51 UTC 2009-07-13
Import patches-unapplied version 0.60-6ubuntu8.4 to ubuntu/dapper-security

Author: Marc Deslauriers
Author Date: 2009-07-06 15:20:45 UTC

Import patches-unapplied version 0.60-6ubuntu8.4 to ubuntu/dapper-security

Imported using git-ubuntu import.

Changelog parent: a6945c80b604df6be452270523fe3ae44c48dbbf

New changelog entries:
  * SECURITY UPDATE: Signature spoofing via incorrect logic
    - debian/patches/84-security-CVE-2009-1189.patch: fix logic in
      dbus/dbus-marshal-validate.c and fix test in
      dbus/dbus-marshal-validate-util.c.
    - CVE-2009-1189

ubuntu/jaunty 2009-01-27 15:04:27 UTC 2009-01-27
Import patches-unapplied version 1.2.12-0ubuntu2 to ubuntu/jaunty

Author: Colin Watson
Author Date: 2009-01-27 14:25:59 UTC

Import patches-unapplied version 1.2.12-0ubuntu2 to ubuntu/jaunty

Imported using git-ubuntu import.

Changelog parent: 1b195f0aeacb3bb7b6ba6367e4600fd0f14d5dcc

New changelog entries:
  * Create $MESSAGEHOME (/var/run/dbus) if it's missing, rather than just
    MESSAGEHOME which clearly wasn't what was intended.

ubuntu/hardy-proposed 2008-10-14 19:04:22 UTC 2008-10-14
Import patches-unapplied version 1.1.20-1ubuntu3.2 to ubuntu/hardy-proposed

Author: Martin Pitt
Author Date: 2008-10-14 18:18:24 UTC

Import patches-unapplied version 1.1.20-1ubuntu3.2 to ubuntu/hardy-proposed

Imported using git-ubuntu import.

Changelog parent: 2672db27f472b2c77218421c3266840374be4e6d

New changelog entries:
  * Add debian/patches/04_helper_fd_leak.patch: Close file descriptors before
    exec()ing helpers, to avoid locking hardware like video cards by eternally
    open file fds. (LP: #230877)

ubuntu/feisty-devel 2008-10-14 17:04:29 UTC 2008-10-14
Import patches-unapplied version 1.0.2-1ubuntu4.2 to ubuntu/feisty-security

Author: Kees Cook
Author Date: 2008-10-14 02:48:09 UTC

Import patches-unapplied version 1.0.2-1ubuntu4.2 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: c0cd6e7b883b72b88f86c64c988f98f3c09a3dfb

New changelog entries:
  * SECURITY UPDATE: policy bypass with NULL interfaces.
    - Add 82-NULL-policy-bypass.patch: upstream fixes.
    - CVE-2008-0595
  * SECURITY UPDATE: application crash via corrupt signatures.
    - Add 83-signature-validation.patch: upstream fixes.
    - CVE-2008-3834

ubuntu/gutsy-updates 2008-10-14 17:04:29 UTC 2008-10-14
Import patches-unapplied version 1.1.1-3ubuntu4.2 to ubuntu/gutsy-security

Author: Kees Cook
Author Date: 2008-10-14 02:10:35 UTC

Import patches-unapplied version 1.1.1-3ubuntu4.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: aebd9c92995e9c7c6b98b421a93bd768d5b9e27d

New changelog entries:
  * SECURITY UPDATE: policy bypass with NULL interfaces.
    - Add 82-NULL-policy-bypass.patch: upstream fixes.
    - CVE-2008-0595
  * SECURITY UPDATE: application crash via corrupt signatures.
    - Add 83-signature-validation.patch: upstream fixes.
    - CVE-2008-3834

ubuntu/gutsy-security 2008-10-14 17:04:29 UTC 2008-10-14
Import patches-unapplied version 1.1.1-3ubuntu4.2 to ubuntu/gutsy-security

Author: Kees Cook
Author Date: 2008-10-14 02:10:35 UTC

Import patches-unapplied version 1.1.1-3ubuntu4.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: aebd9c92995e9c7c6b98b421a93bd768d5b9e27d

New changelog entries:
  * SECURITY UPDATE: policy bypass with NULL interfaces.
    - Add 82-NULL-policy-bypass.patch: upstream fixes.
    - CVE-2008-0595
  * SECURITY UPDATE: application crash via corrupt signatures.
    - Add 83-signature-validation.patch: upstream fixes.
    - CVE-2008-3834

ubuntu/gutsy-devel 2008-10-14 17:04:29 UTC 2008-10-14
Import patches-unapplied version 1.1.1-3ubuntu4.2 to ubuntu/gutsy-security

Author: Kees Cook
Author Date: 2008-10-14 02:10:35 UTC

Import patches-unapplied version 1.1.1-3ubuntu4.2 to ubuntu/gutsy-security

Imported using git-ubuntu import.

Changelog parent: aebd9c92995e9c7c6b98b421a93bd768d5b9e27d

New changelog entries:
  * SECURITY UPDATE: policy bypass with NULL interfaces.
    - Add 82-NULL-policy-bypass.patch: upstream fixes.
    - CVE-2008-0595
  * SECURITY UPDATE: application crash via corrupt signatures.
    - Add 83-signature-validation.patch: upstream fixes.
    - CVE-2008-3834

ubuntu/feisty-updates 2008-10-14 17:04:29 UTC 2008-10-14
Import patches-unapplied version 1.0.2-1ubuntu4.2 to ubuntu/feisty-security

Author: Kees Cook
Author Date: 2008-10-14 02:48:09 UTC

Import patches-unapplied version 1.0.2-1ubuntu4.2 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: c0cd6e7b883b72b88f86c64c988f98f3c09a3dfb

New changelog entries:
  * SECURITY UPDATE: policy bypass with NULL interfaces.
    - Add 82-NULL-policy-bypass.patch: upstream fixes.
    - CVE-2008-0595
  * SECURITY UPDATE: application crash via corrupt signatures.
    - Add 83-signature-validation.patch: upstream fixes.
    - CVE-2008-3834

ubuntu/feisty-security 2008-10-14 17:04:29 UTC 2008-10-14
Import patches-unapplied version 1.0.2-1ubuntu4.2 to ubuntu/feisty-security

Author: Kees Cook
Author Date: 2008-10-14 02:48:09 UTC

Import patches-unapplied version 1.0.2-1ubuntu4.2 to ubuntu/feisty-security

Imported using git-ubuntu import.

Changelog parent: c0cd6e7b883b72b88f86c64c988f98f3c09a3dfb

New changelog entries:
  * SECURITY UPDATE: policy bypass with NULL interfaces.
    - Add 82-NULL-policy-bypass.patch: upstream fixes.
    - CVE-2008-0595
  * SECURITY UPDATE: application crash via corrupt signatures.
    - Add 83-signature-validation.patch: upstream fixes.
    - CVE-2008-3834

ubuntu/intrepid 2008-10-07 14:04:38 UTC 2008-10-07
Import patches-unapplied version 1.2.4-0ubuntu1 to ubuntu/intrepid

Author: Martin Pitt
Author Date: 2008-10-07 13:26:32 UTC

Import patches-unapplied version 1.2.4-0ubuntu1 to ubuntu/intrepid

Imported using git-ubuntu import.

Changelog parent: 680d55c2aab4d975f70e05ce905def55dbfd0b65

New changelog entries:
  * New upstream bug fix release: (LP: #279425)
    - Fix crash on dbus_signature_validate("a{(ii)i}", NULL), which would
      unexpectedly abort the calling program. [CVE-2008-3834]
    - Close file descriptors before exec()ing helpers, to avoid locking
      hardware like video cards by eternally open file fds. (LP: #230877)
    - A small number of compilation and portability fixes.

ubuntu/hardy 2008-02-29 09:03:44 UTC 2008-02-29
Import patches-unapplied version 1.1.20-1ubuntu1 to ubuntu/hardy

Author: Martin Pitt
Author Date: 2008-02-28 14:08:15 UTC

Import patches-unapplied version 1.1.20-1ubuntu1 to ubuntu/hardy

Imported using git-ubuntu import.

Changelog parent: 9ebac7777b0dcdbe970c0c71ceb78b63d5ad94b9

New changelog entries:
  * New upstream release: Tons of bug fixes, a security fix (CVE-2008-0595),
    and two small new features:
    - inotify support (to replace previous dnotify implementation); can be
      disabled with configure switch if it causes trouble
    - Add matching support for program binaries in dbus policy rules.
  * Merge with Debian unstable; remaining changes:
    - debian/patches/81-session.conf-timeout.patch: Raise the service startup
      timeout from 25 to 60 seconds. It may be too short on the live CD with
      slow machines.
    - Add consolekit (>= 0.2.3-3ubuntu2) dependency, which provides
      pam_console compatible stamps in /var/run/console. This keeps
      "at_console" policies working until we get rid of them completely.
      (See policykit-integration spec)
    - debian/dbus.{postinst,prerm}: Do not restart dbus on upgrades, since it
      breaks too many applications. Instead, trigger a "reboot required"
      notification. Since this cancels the postinst early, add an explicit
      update-rc.d call to the symlink migration.
    - debian/rules: Do not install /etc/X11/Xsession.d/75dbus_dbus-launch, we
      do not need it for Gnome, KDE, and XFCE, and it causes trouble.
      (LP #62163)
    - debian/dbus.preinst: Remove obsolete conffile
      /etc/X11/Xsession.d/75dbus_dbus-launch on upgrades. This needs to be
      kept until after Hardy's release.
  * Debian's forceful way of RC symlink migration should finally fix all the
    previous upgrade issues with wrong priorities. (LP: #25931)
  [ Loic Minier ]
  * Forcefully remove old init script symlinks on upgrades to this version to
    properly reinstall the init script when using insserv or file-rc; thanks
    Petter Reinholdtsen; closes: #466503.
  [ Michael Biebl ]
  * New upstream release.
  [ Loic Minier ]
  * Merge patch from Ubuntu to build a devhelp file; thanks Martin Pitt;
    closes: #454142.
    - Build-dep on xsltproc.
    - New patch, dbus-1.0.1-generate-xml-docs, enables generation of XML docs
      which serve as source for the devhelp generation.
    - Add a XSLT file from the Fedora package, debian/doxygen_to_devhelp.xsl.
    - Generate the devhelp file from the XML files thanks to the XSL file via
      xsltproc in build/dbus-1-doc::.
    - Install the devhelp index in dbus-1-doc and move the HTML documentation
      around; add a symlink from the gtk-doc dir.
  * Misc smallish whitespace cleanups.
  * Start dbus at runlevel priority 12 and stop at priority 88. This
    eliminates the race condition of starting the X session before hal is
    running. Migrate rc?.d symlinks from 20 to 12/88 on upgrades. This need
    to be kept until after lenny is released.
  * Set LSB Default-Stop section to 1 and only install a shutdown script for
    runlevel 1 to only stop dbus when going down to single user mode; dbus can
    simply be killed like everything else on shutdown or reboot by sendsigs;
    drop rc0 and rc6.d symlinks on upgrades.
  * Bump up dbus-x11 conflicts/replaces to << 1.1.2 to match the transition
    version in Ubuntu and reduce the delta.
  * Cleanup trailing whitespace.
  * Drop superfluous exit 0 at the end of dbus' init script which is set -e.
  * Add ${shlibs:Depends} to libdbus-1-dev.
  * Simplify dbus.postinst.
  * Rename patch dbus-1.0.1-generate-xml-docs to
    10_dbus-1.0.1-generate-xml-docs to reflect current patch stack order.
  * Set shlibs via DEB_DH_MAKESHLIBS_ARGS_ALL instead of libdbus-1-3.shlibs
    and extract libdbus-1-3 package name from control to avoid hardcoding the
    SONAME and package name.
  [ Michael Biebl ]
  * New upstream release.
  * Deprecate the ENABLED option and remove it from /etc/default/dbus. Print a
    warning message in the init script if this option is still used.
  * debian/patches/03_uuid_nul.patch
    - Removed, merged upstream.
  * debian/patches/04_dbus_launch.patch
    - Removed, merged upstream.
  * debian/control
    - Bump Standards-Version to 3.7.3. No further changes required.
  * debian/dbus.init
    - Fix LSB init header. Use $remote_fs instead of $local_fs as the
      daemon requires /usr to be mounted.
      Remove S from Should-Stop. (Closes: #459473)
    - Use mountpoint to check if /proc is mounted. (Closes: #458392)
    - Decrease retry-time to 5 secs on stop. (Closes: #462182)

ubuntu/gutsy 2007-10-05 12:03:47 UTC 2007-10-05
Import patches-unapplied version 1.1.1-3ubuntu4 to ubuntu/gutsy

Author: Sebastien Bacher
Author Date: 2007-10-04 13:56:28 UTC

Import patches-unapplied version 1.1.1-3ubuntu4 to ubuntu/gutsy

Imported using git-ubuntu import.

Changelog parent: 630a988f9a7b3c2d36158e570dafda746e551231

New changelog entries:
  * debian/control:
    - Build-Depends on xsltproc
  * debian/dbus-1-doc.install:
    - install the devhelp index
  * debian/dbus-1-doc.links:
    - create a devhelp documentation symlink
  * debian/doxygen_to_devhelp.xsl:
    - file from fedora used to generate a devhelp documentation index
  * debian/patches/dbus-1.0.1-generate-xml-docs.patch:
    - patch from fedora, build the xml documentation
  * debian/rules:
    - build and clean the devhelp index

ubuntu/feisty-proposed 2007-07-26 10:03:41 UTC 2007-07-26
Import patches-unapplied version 1.0.2-1ubuntu4 to ubuntu/feisty-proposed

Author: Martin Pitt
Author Date: 2007-07-26 09:08:35 UTC

Import patches-unapplied version 1.0.2-1ubuntu4 to ubuntu/feisty-proposed

Imported using git-ubuntu import.

Changelog parent: a3a9237f8ed99d2abf00be6c2d1882124b064044

New changelog entries:
  * Add debian/patches/02_dbus-launch_close_pipe.patch:
    - _dbus_get_autolaunch_address(): When calling dbus-launch fails,
       close the reading end of the pipe.
    - This caused a serious fd leak in programs like cups when they repeatedly
      try to send dbus messages, dbus is not running, and dbus-launch is not
      available or otherwise fails to execute.
    - LP: #112803

ubuntu/feisty 2007-03-08 13:03:51 UTC 2007-03-08
Import patches-unapplied version 1.0.2-1ubuntu3 to ubuntu/feisty

Author: Martin Pitt
Author Date: 2007-03-08 12:53:22 UTC

Import patches-unapplied version 1.0.2-1ubuntu3 to ubuntu/feisty

Imported using git-ubuntu import.

Changelog parent: 36ffd37fae2252da44996a80c847821cb54d466b

New changelog entries:
  * debian/rules: Start dbus at runlevel priority 12, so that it comes before
    gdm. This eliminates the race condition of starting the X session before
    hal is running. (LP: #25931 and two handfuls of dups)
  * debian/dbus.postinst: Migrate rc?.d symlinks from 20 to 12 on upgrades to
    this version.
  * debian/control: Set Ubuntu maintainer.
  * debian/rules: Clean up doc/*.html (they are generated from XML sources).

ubuntu/breezy-security 2007-01-04 21:03:18 UTC 2007-01-04
Import patches-unapplied version 0.36.2-0ubuntu7.1 to ubuntu/breezy-security

Author: Kees Cook
Author Date: 2006-12-13 21:33:05 UTC

Import patches-unapplied version 0.36.2-0ubuntu7.1 to ubuntu/breezy-security

Imported using git-ubuntu import.

Changelog parent: f29b4009d8c85e0e7428a3182918a5b317d78bae

New changelog entries:
  * SECURITY UPDATE: denial of service, dbus can be made to ignore
    registered matches for other local users.
  * Add debian/patches/match_removal.patch: fix from upstream CVS.
  * References
    http://webcvs.freedesktop.org/dbus/dbus/bus/signals.c?r1=1.14&r2=1.14.2.1&view=patch&pathrev=DBUS_1_0
    CVE-2006-6107

ubuntu/edgy-updates 2007-01-04 21:03:18 UTC 2007-01-04
Import patches-unapplied version 0.93-0ubuntu3.1 to ubuntu/edgy-security

Author: Kees Cook
Author Date: 2006-12-14 02:15:00 UTC

Import patches-unapplied version 0.93-0ubuntu3.1 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: a3ca36081c0c6fd0b75ee8848b4f99d6a061c7d3

New changelog entries:
  * SECURITY UPDATE: denial of service, dbus can be made to ignore
    registered matches for other local users.
  * Add debian/patches/match_removal.patch: fix from upstream CVS.
  * References
    http://webcvs.freedesktop.org/dbus/dbus/bus/signals.c?r1=1.14&r2=1.14.2.1&view=patch&pathrev=DBUS_1_0
    CVE-2006-6107

ubuntu/breezy-devel 2007-01-04 21:03:18 UTC 2007-01-04
Import patches-unapplied version 0.36.2-0ubuntu7.1 to ubuntu/breezy-security

Author: Kees Cook
Author Date: 2006-12-13 21:33:05 UTC

Import patches-unapplied version 0.36.2-0ubuntu7.1 to ubuntu/breezy-security

Imported using git-ubuntu import.

Changelog parent: f29b4009d8c85e0e7428a3182918a5b317d78bae

New changelog entries:
  * SECURITY UPDATE: denial of service, dbus can be made to ignore
    registered matches for other local users.
  * Add debian/patches/match_removal.patch: fix from upstream CVS.
  * References
    http://webcvs.freedesktop.org/dbus/dbus/bus/signals.c?r1=1.14&r2=1.14.2.1&view=patch&pathrev=DBUS_1_0
    CVE-2006-6107

ubuntu/edgy-security 2007-01-04 21:03:18 UTC 2007-01-04
Import patches-unapplied version 0.93-0ubuntu3.1 to ubuntu/edgy-security

Author: Kees Cook
Author Date: 2006-12-14 02:15:00 UTC

Import patches-unapplied version 0.93-0ubuntu3.1 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: a3ca36081c0c6fd0b75ee8848b4f99d6a061c7d3

New changelog entries:
  * SECURITY UPDATE: denial of service, dbus can be made to ignore
    registered matches for other local users.
  * Add debian/patches/match_removal.patch: fix from upstream CVS.
  * References
    http://webcvs.freedesktop.org/dbus/dbus/bus/signals.c?r1=1.14&r2=1.14.2.1&view=patch&pathrev=DBUS_1_0
    CVE-2006-6107

ubuntu/edgy-devel 2007-01-04 21:03:18 UTC 2007-01-04
Import patches-unapplied version 0.93-0ubuntu3.1 to ubuntu/edgy-security

Author: Kees Cook
Author Date: 2006-12-14 02:15:00 UTC

Import patches-unapplied version 0.93-0ubuntu3.1 to ubuntu/edgy-security

Imported using git-ubuntu import.

Changelog parent: a3ca36081c0c6fd0b75ee8848b4f99d6a061c7d3

New changelog entries:
  * SECURITY UPDATE: denial of service, dbus can be made to ignore
    registered matches for other local users.
  * Add debian/patches/match_removal.patch: fix from upstream CVS.
  * References
    http://webcvs.freedesktop.org/dbus/dbus/bus/signals.c?r1=1.14&r2=1.14.2.1&view=patch&pathrev=DBUS_1_0
    CVE-2006-6107

ubuntu/edgy 2006-10-20 11:03:48 UTC 2006-10-20
Import patches-unapplied version 0.93-0ubuntu3 to ubuntu/edgy

Author: Sebastian Dröge
Author Date: 2006-10-18 18:21:40 UTC

Import patches-unapplied version 0.93-0ubuntu3 to ubuntu/edgy

Imported using git-ubuntu import.

Changelog parent: 9e44bc5e2d9cd17644bc65837482c8d347b4f427

New changelog entries:
  * debian/session.conf,
    debian/patches/dbus-raise-service-start-timeout.patch:
    + Raise the service activation timeout in the correct file now to 60
      seconds...

applied/ubuntu/hoary-updates 2006-10-06 18:52:57 UTC 2006-10-06
Import patches-applied version 0.23.4-0ubuntu4 to applied/ubuntu/hoary-updates

Author: Matthias Klose
Author Date: 2005-07-27 09:48:27 UTC

Import patches-applied version 0.23.4-0ubuntu4 to applied/ubuntu/hoary-updates

Imported using git-ubuntu import.

Changelog parent: 2f08f4f9b9081266d46d72f4e226c26fa5f59d0b
Unapplied parent: c0952f936edeeb3de895549512d1edea1ab05d69

New changelog entries:
  * debian/patches/dbus-gilstate: Fix segfaults in python bindings.
    Patch by Anthony Baxter. Ubuntu #7292.

ubuntu/hoary-devel 2006-10-06 18:52:57 UTC 2006-10-06
Import patches-unapplied version 0.23.4-0ubuntu4 to ubuntu/hoary-updates

Author: Matthias Klose
Author Date: 2005-07-27 09:48:27 UTC

Import patches-unapplied version 0.23.4-0ubuntu4 to ubuntu/hoary-updates

Imported using git-ubuntu import.

Changelog parent: b60050aaa7f166a6ce952b44100af1f9d38d76a2

New changelog entries:
  * debian/patches/dbus-gilstate: Fix segfaults in python bindings.
    Patch by Anthony Baxter. Ubuntu #7292.

ubuntu/hoary-updates 2006-10-06 18:52:57 UTC 2006-10-06
Import patches-unapplied version 0.23.4-0ubuntu4 to ubuntu/hoary-updates

Author: Matthias Klose
Author Date: 2005-07-27 09:48:27 UTC

Import patches-unapplied version 0.23.4-0ubuntu4 to ubuntu/hoary-updates

Imported using git-ubuntu import.

Changelog parent: b60050aaa7f166a6ce952b44100af1f9d38d76a2

New changelog entries:
  * debian/patches/dbus-gilstate: Fix segfaults in python bindings.
    Patch by Anthony Baxter. Ubuntu #7292.

applied/ubuntu/hoary-devel 2006-10-06 18:52:57 UTC 2006-10-06
Import patches-applied version 0.23.4-0ubuntu4 to applied/ubuntu/hoary-updates

Author: Matthias Klose
Author Date: 2005-07-27 09:48:27 UTC

Import patches-applied version 0.23.4-0ubuntu4 to applied/ubuntu/hoary-updates

Imported using git-ubuntu import.

Changelog parent: 2f08f4f9b9081266d46d72f4e226c26fa5f59d0b
Unapplied parent: c0952f936edeeb3de895549512d1edea1ab05d69

New changelog entries:
  * debian/patches/dbus-gilstate: Fix segfaults in python bindings.
    Patch by Anthony Baxter. Ubuntu #7292.

applied/ubuntu/dapper-devel 2006-05-15 19:06:59 UTC 2006-05-15
Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Author: Sebastian Dröge
Author Date: 2006-05-15 18:02:55 UTC

Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 9ba5ed9ec009724b2207b17dbba41d7301360639
Unapplied parent: 3210fda90b2c942cd2cfa60ded98ad8526c81420

New changelog entries:
  * Add a small hack to debian/rules to get us the content for the
    monodoc-dbus-1-manual package. (Ubuntu: #44449)

applied/ubuntu/dapper 2006-05-15 19:06:59 UTC 2006-05-15
Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Author: Sebastian Dröge
Author Date: 2006-05-15 18:02:55 UTC

Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 9ba5ed9ec009724b2207b17dbba41d7301360639
Unapplied parent: 3210fda90b2c942cd2cfa60ded98ad8526c81420

New changelog entries:
  * Add a small hack to debian/rules to get us the content for the
    monodoc-dbus-1-manual package. (Ubuntu: #44449)

applied/ubuntu/devel 2006-05-15 19:06:59 UTC 2006-05-15
Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Author: Sebastian Dröge
Author Date: 2006-05-15 18:02:55 UTC

Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 9ba5ed9ec009724b2207b17dbba41d7301360639
Unapplied parent: 3210fda90b2c942cd2cfa60ded98ad8526c81420

New changelog entries:
  * Add a small hack to debian/rules to get us the content for the
    monodoc-dbus-1-manual package. (Ubuntu: #44449)

applied/ubuntu/edgy-devel 2006-05-15 19:06:59 UTC 2006-05-15
Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Author: Sebastian Dröge
Author Date: 2006-05-15 18:02:55 UTC

Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 9ba5ed9ec009724b2207b17dbba41d7301360639
Unapplied parent: 3210fda90b2c942cd2cfa60ded98ad8526c81420

New changelog entries:
  * Add a small hack to debian/rules to get us the content for the
    monodoc-dbus-1-manual package. (Ubuntu: #44449)

ubuntu/dapper 2006-05-15 19:06:59 UTC 2006-05-15
Import patches-unapplied version 0.60-6ubuntu8 to ubuntu/dapper

Author: Sebastian Dröge
Author Date: 2006-05-15 18:02:55 UTC

Import patches-unapplied version 0.60-6ubuntu8 to ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: e023df06e3259a84f465bbf684b1f9e30d57588d

New changelog entries:
  * Add a small hack to debian/rules to get us the content for the
    monodoc-dbus-1-manual package. (Ubuntu: #44449)

applied/ubuntu/edgy 2006-05-15 19:06:59 UTC 2006-05-15
Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Author: Sebastian Dröge
Author Date: 2006-05-15 18:02:55 UTC

Import patches-applied version 0.60-6ubuntu8 to applied/ubuntu/dapper

Imported using git-ubuntu import.

Changelog parent: 9ba5ed9ec009724b2207b17dbba41d7301360639
Unapplied parent: 3210fda90b2c942cd2cfa60ded98ad8526c81420

New changelog entries:
  * Add a small hack to debian/rules to get us the content for the
    monodoc-dbus-1-manual package. (Ubuntu: #44449)

ubuntu/breezy 2005-12-21 04:49:27 UTC 2005-12-21
Import patches-unapplied version 0.36.2-0ubuntu7 to ubuntu/breezy

Author: Martin Pitt
Author Date: 2005-09-30 18:14:53 UTC

Import patches-unapplied version 0.36.2-0ubuntu7 to ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: b60050aaa7f166a6ce952b44100af1f9d38d76a2

New changelog entries:
  * Use update-notifier's brand new notify-reboot-required script instead of
    creating a dbus specific update notification.
  * debian/control: Change the package conflict to a Replaces: to not confuse
    apt and dpkg more than necessary.
  * Move dbus-launch from dbus-1-utils to dbus. This allows KDE to use
    dbus-launch without pulling in all Gnome dependencies through -utils.
  * debian/control: Add appropriate conflict.
  * debian/dbus.postinst: Add an update notification that recommends to reboot
    the machine soon.
  * debian/dbus.init: Remove the notification on dbus startup.
  * Use '...' rather than ':' in init script, for consistency with other
    messages
  * debian/dbus.postrm: Add back dropped DEBHELPER token to make rc2.d
    symlink generation and daemon start work again.
  * debian/rules: Tell dh_installinit to use priority 12 instead of default
    20, in accordance to Daniel's migration on upgrades.
  * Update to new upstream version.
    + Remove dbus-sessionbus-checkuid.patch and
      dbus-python-invalid-values.patch, since they got merged in this
      release.
    + Fix library crashes on errors (closes: Ubuntu#14178).
  * Restore S20 -> S12 init script migration, and remove dbus-1 symlinks from
    /etc/rc.d (closes: Ubuntu#14314).
  * Re-add dbus-sessionbus-checkuid.patch, as it is still needed for 0.3x, and
    only got applied to the 0.2x branch upstream. Thanks Sjoerd Simons for
    the catch.
  * Add dependency on dbus from dbus-utils (closes: Ubuntu#10838).
  * Fix descriptions to refer to dbus rather than dbus-1.
  * Rebuild again to drop the libglitz dependencies.
  * Rebuild with the new cairo version
  * debian/dbus.postinst, debian/dbus.prerm: Do not restart dbus on upgrades,
    since this breaks too many applications. (Ubuntu #13312)
  * debian/*.install:
    - don't list .la files.
  * debian/dbus-utils.install:
    - list some other binaries to install here.
  * debian/*.install:
    - install the .la files for the non python packages.
  * New upstream version.
  * Remove *.la files from installation.
    + Gross hack to remove dbus_bindings.{a,la} from python2.4-dbus.
  * Remove XSIism in dbus.preinst (which is the most frightening hack).
  * Add dbus-make-libtool-safe.patch, which replaces an explicit libtool call
    with $(LIBTOOL) in glib/Makefile.*.
  * Add dbus-python-invalid-values.patch, which fixes sending of Byte values
    in the Python bindings (fd.o#4023).
  * Fix ftbfs's from headers disappearing.
  * add architecture limits to mono-mcs as well.
  * Don't build Mono support for architectures that can't do it.
  * But add Mono support back to amd64.
  * SECURITY UPDATE: Fix authentication bypass.
  * Add debian/patches/dbus-sessionbus-checkuid.patch:
    - bus/session.conf.in: Do not allow any user to connect to any session bus
      by default.
    - bus/policy.c: "allowed" now defaults to true if the connecting user id
      matches the session bus user id.
    - This stops other users from listening and sending to other user's
      session dbus instances.
    - References:
      CAN-2005-0201
      https://bugs.freedesktop.org/show_bug.cgi?id=2436
  * Make debian/rules-fu reference libdbus-1-cil, not libdbus-1 so
    dh_makeclilibs actually gets called
  * debian/patches/dbus-gilstate: Fix segfaults in python bindings.
    Patch by Anthony Baxter. Ubuntu #7292.
  * Debian adopted our 0.33 package and most changes, new Ubuntu package based
    on pristine Debian version.
  * LSB'ified debian/dbus.init.
  * debian/dbus.postinst: Corrected init script name.
  * debian/control:
    - Add lsb-base dependency.
    - Adapted build dependencies.
    - CXX transition: Rename libdbus-qt-1-1 to libdbus-qt-1-1c2.
    - Fixed libdbus-1-cil name and dependencies.
  * Added debian/dbus.preinst to do the /etc/init.d/dbus-1 -> /etc/init.d/dbus
    transition.
  * debian/dbus.init: Fixed event.d directory.
  * New upstream release
  * Build libdbus-cil on amd64 too (Closes: #314247)
  * Python bindings need python2.4, so build them against python2.4.
  * New upstream release (Closes: #299049)
  * Redone the package names to be much more sane.
    - Based on ubuntu's dbus 0.33 package by Daniel Stone.
    - dbus deamon goes into the dbus package instead of dbus-1
    - glib bindings in libdbus-glib-1-1 instead of dbus-glib-1
    - qt bindings in libdbus-qt-1-1 instead of dbus-qt-1
    - Library component from dbus-1 goed into libdbus-1-1
  * debian/patches/dbus-fixverbose.patch
    - Removed. Fixed upstream
  * debian/patches/dbus-getpwname.patch
    - Removed. Fixed upstream
  * debian/patches/fix-policy-group.patch
    - Removed. Not relevant anymore
  * Actually install all the mono related gumpf.
  * Re-enable dbus, rename libdbus-cil to libdbus-1-cil.
  * Replace kdelibs-dev with kdelibs4-dev in the build dependencies.
  * CXX transition: Rename libdbus-qt-1-1 to libdbus-qt-1-1c2.
  * New upstream version (now with 97% more API breakage!).
    + Resolves segfault exposed by NetworkManager (closes: Ubuntu#8395).
  * Remove fix-policy-group.patch as the relevant section of code (matching by
    gid) appears to have disappeared entirely?
  * dbus-daemon-1 is now dbus-daemon.
  * The client API has changed massively. Rename dbus-glib-1* to
    libdbus-glib-1-1* and dbus-qt-1* to libdbus-qt-1-1* to reflect major
    soversion bump from 0 to 1. Rename dbus-1-dev to libdbus-1-dev. Move the
    library component of dbus-1 to libdbus-1-1; rename the rest of dbus-1 to
    dbus.
  * Merge dbus-mono packaging in; it is no longer a separate source package.
    Don't build it right now though, since mono is still in universe.

applied/ubuntu/breezy-devel 2005-12-21 04:49:27 UTC 2005-12-21
Import patches-applied version 0.36.2-0ubuntu7 to applied/ubuntu/breezy

Author: Martin Pitt
Author Date: 2005-09-30 18:14:53 UTC

Import patches-applied version 0.36.2-0ubuntu7 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 2f08f4f9b9081266d46d72f4e226c26fa5f59d0b
Unapplied parent: f29b4009d8c85e0e7428a3182918a5b317d78bae

New changelog entries:
  * Use update-notifier's brand new notify-reboot-required script instead of
    creating a dbus specific update notification.
  * debian/control: Change the package conflict to a Replaces: to not confuse
    apt and dpkg more than necessary.
  * Move dbus-launch from dbus-1-utils to dbus. This allows KDE to use
    dbus-launch without pulling in all Gnome dependencies through -utils.
  * debian/control: Add appropriate conflict.
  * debian/dbus.postinst: Add an update notification that recommends to reboot
    the machine soon.
  * debian/dbus.init: Remove the notification on dbus startup.
  * Use '...' rather than ':' in init script, for consistency with other
    messages
  * debian/dbus.postrm: Add back dropped DEBHELPER token to make rc2.d
    symlink generation and daemon start work again.
  * debian/rules: Tell dh_installinit to use priority 12 instead of default
    20, in accordance to Daniel's migration on upgrades.
  * Update to new upstream version.
    + Remove dbus-sessionbus-checkuid.patch and
      dbus-python-invalid-values.patch, since they got merged in this
      release.
    + Fix library crashes on errors (closes: Ubuntu#14178).
  * Restore S20 -> S12 init script migration, and remove dbus-1 symlinks from
    /etc/rc.d (closes: Ubuntu#14314).
  * Re-add dbus-sessionbus-checkuid.patch, as it is still needed for 0.3x, and
    only got applied to the 0.2x branch upstream. Thanks Sjoerd Simons for
    the catch.
  * Add dependency on dbus from dbus-utils (closes: Ubuntu#10838).
  * Fix descriptions to refer to dbus rather than dbus-1.
  * Rebuild again to drop the libglitz dependencies.
  * Rebuild with the new cairo version
  * debian/dbus.postinst, debian/dbus.prerm: Do not restart dbus on upgrades,
    since this breaks too many applications. (Ubuntu #13312)
  * debian/*.install:
    - don't list .la files.
  * debian/dbus-utils.install:
    - list some other binaries to install here.
  * debian/*.install:
    - install the .la files for the non python packages.
  * New upstream version.
  * Remove *.la files from installation.
    + Gross hack to remove dbus_bindings.{a,la} from python2.4-dbus.
  * Remove XSIism in dbus.preinst (which is the most frightening hack).
  * Add dbus-make-libtool-safe.patch, which replaces an explicit libtool call
    with $(LIBTOOL) in glib/Makefile.*.
  * Add dbus-python-invalid-values.patch, which fixes sending of Byte values
    in the Python bindings (fd.o#4023).
  * Fix ftbfs's from headers disappearing.
  * add architecture limits to mono-mcs as well.
  * Don't build Mono support for architectures that can't do it.
  * But add Mono support back to amd64.
  * SECURITY UPDATE: Fix authentication bypass.
  * Add debian/patches/dbus-sessionbus-checkuid.patch:
    - bus/session.conf.in: Do not allow any user to connect to any session bus
      by default.
    - bus/policy.c: "allowed" now defaults to true if the connecting user id
      matches the session bus user id.
    - This stops other users from listening and sending to other user's
      session dbus instances.
    - References:
      CAN-2005-0201
      https://bugs.freedesktop.org/show_bug.cgi?id=2436
  * Make debian/rules-fu reference libdbus-1-cil, not libdbus-1 so
    dh_makeclilibs actually gets called
  * debian/patches/dbus-gilstate: Fix segfaults in python bindings.
    Patch by Anthony Baxter. Ubuntu #7292.
  * Debian adopted our 0.33 package and most changes, new Ubuntu package based
    on pristine Debian version.
  * LSB'ified debian/dbus.init.
  * debian/dbus.postinst: Corrected init script name.
  * debian/control:
    - Add lsb-base dependency.
    - Adapted build dependencies.
    - CXX transition: Rename libdbus-qt-1-1 to libdbus-qt-1-1c2.
    - Fixed libdbus-1-cil name and dependencies.
  * Added debian/dbus.preinst to do the /etc/init.d/dbus-1 -> /etc/init.d/dbus
    transition.
  * debian/dbus.init: Fixed event.d directory.
  * New upstream release
  * Build libdbus-cil on amd64 too (Closes: #314247)
  * Python bindings need python2.4, so build them against python2.4.
  * New upstream release (Closes: #299049)
  * Redone the package names to be much more sane.
    - Based on ubuntu's dbus 0.33 package by Daniel Stone.
    - dbus deamon goes into the dbus package instead of dbus-1
    - glib bindings in libdbus-glib-1-1 instead of dbus-glib-1
    - qt bindings in libdbus-qt-1-1 instead of dbus-qt-1
    - Library component from dbus-1 goed into libdbus-1-1
  * debian/patches/dbus-fixverbose.patch
    - Removed. Fixed upstream
  * debian/patches/dbus-getpwname.patch
    - Removed. Fixed upstream
  * debian/patches/fix-policy-group.patch
    - Removed. Not relevant anymore
  * Actually install all the mono related gumpf.
  * Re-enable dbus, rename libdbus-cil to libdbus-1-cil.
  * Replace kdelibs-dev with kdelibs4-dev in the build dependencies.
  * CXX transition: Rename libdbus-qt-1-1 to libdbus-qt-1-1c2.
  * New upstream version (now with 97% more API breakage!).
    + Resolves segfault exposed by NetworkManager (closes: Ubuntu#8395).
  * Remove fix-policy-group.patch as the relevant section of code (matching by
    gid) appears to have disappeared entirely?
  * dbus-daemon-1 is now dbus-daemon.
  * The client API has changed massively. Rename dbus-glib-1* to
    libdbus-glib-1-1* and dbus-qt-1* to libdbus-qt-1-1* to reflect major
    soversion bump from 0 to 1. Rename dbus-1-dev to libdbus-1-dev. Move the
    library component of dbus-1 to libdbus-1-1; rename the rest of dbus-1 to
    dbus.
  * Merge dbus-mono packaging in; it is no longer a separate source package.
    Don't build it right now though, since mono is still in universe.

applied/ubuntu/breezy 2005-12-21 04:49:27 UTC 2005-12-21
Import patches-applied version 0.36.2-0ubuntu7 to applied/ubuntu/breezy

Author: Martin Pitt
Author Date: 2005-09-30 18:14:53 UTC

Import patches-applied version 0.36.2-0ubuntu7 to applied/ubuntu/breezy

Imported using git-ubuntu import.

Changelog parent: 2f08f4f9b9081266d46d72f4e226c26fa5f59d0b
Unapplied parent: f29b4009d8c85e0e7428a3182918a5b317d78bae

New changelog entries:
  * Use update-notifier's brand new notify-reboot-required script instead of
    creating a dbus specific update notification.
  * debian/control: Change the package conflict to a Replaces: to not confuse
    apt and dpkg more than necessary.
  * Move dbus-launch from dbus-1-utils to dbus. This allows KDE to use
    dbus-launch without pulling in all Gnome dependencies through -utils.
  * debian/control: Add appropriate conflict.
  * debian/dbus.postinst: Add an update notification that recommends to reboot
    the machine soon.
  * debian/dbus.init: Remove the notification on dbus startup.
  * Use '...' rather than ':' in init script, for consistency with other
    messages
  * debian/dbus.postrm: Add back dropped DEBHELPER token to make rc2.d
    symlink generation and daemon start work again.
  * debian/rules: Tell dh_installinit to use priority 12 instead of default
    20, in accordance to Daniel's migration on upgrades.
  * Update to new upstream version.
    + Remove dbus-sessionbus-checkuid.patch and
      dbus-python-invalid-values.patch, since they got merged in this
      release.
    + Fix library crashes on errors (closes: Ubuntu#14178).
  * Restore S20 -> S12 init script migration, and remove dbus-1 symlinks from
    /etc/rc.d (closes: Ubuntu#14314).
  * Re-add dbus-sessionbus-checkuid.patch, as it is still needed for 0.3x, and
    only got applied to the 0.2x branch upstream. Thanks Sjoerd Simons for
    the catch.
  * Add dependency on dbus from dbus-utils (closes: Ubuntu#10838).
  * Fix descriptions to refer to dbus rather than dbus-1.
  * Rebuild again to drop the libglitz dependencies.
  * Rebuild with the new cairo version
  * debian/dbus.postinst, debian/dbus.prerm: Do not restart dbus on upgrades,
    since this breaks too many applications. (Ubuntu #13312)
  * debian/*.install:
    - don't list .la files.
  * debian/dbus-utils.install:
    - list some other binaries to install here.
  * debian/*.install:
    - install the .la files for the non python packages.
  * New upstream version.
  * Remove *.la files from installation.
    + Gross hack to remove dbus_bindings.{a,la} from python2.4-dbus.
  * Remove XSIism in dbus.preinst (which is the most frightening hack).
  * Add dbus-make-libtool-safe.patch, which replaces an explicit libtool call
    with $(LIBTOOL) in glib/Makefile.*.
  * Add dbus-python-invalid-values.patch, which fixes sending of Byte values
    in the Python bindings (fd.o#4023).
  * Fix ftbfs's from headers disappearing.
  * add architecture limits to mono-mcs as well.
  * Don't build Mono support for architectures that can't do it.
  * But add Mono support back to amd64.
  * SECURITY UPDATE: Fix authentication bypass.
  * Add debian/patches/dbus-sessionbus-checkuid.patch:
    - bus/session.conf.in: Do not allow any user to connect to any session bus
      by default.
    - bus/policy.c: "allowed" now defaults to true if the connecting user id
      matches the session bus user id.
    - This stops other users from listening and sending to other user's
      session dbus instances.
    - References:
      CAN-2005-0201
      https://bugs.freedesktop.org/show_bug.cgi?id=2436
  * Make debian/rules-fu reference libdbus-1-cil, not libdbus-1 so
    dh_makeclilibs actually gets called
  * debian/patches/dbus-gilstate: Fix segfaults in python bindings.
    Patch by Anthony Baxter. Ubuntu #7292.
  * Debian adopted our 0.33 package and most changes, new Ubuntu package based
    on pristine Debian version.
  * LSB'ified debian/dbus.init.
  * debian/dbus.postinst: Corrected init script name.
  * debian/control:
    - Add lsb-base dependency.
    - Adapted build dependencies.
    - CXX transition: Rename libdbus-qt-1-1 to libdbus-qt-1-1c2.
    - Fixed libdbus-1-cil name and dependencies.
  * Added debian/dbus.preinst to do the /etc/init.d/dbus-1 -> /etc/init.d/dbus
    transition.
  * debian/dbus.init: Fixed event.d directory.
  * New upstream release
  * Build libdbus-cil on amd64 too (Closes: #314247)
  * Python bindings need python2.4, so build them against python2.4.
  * New upstream release (Closes: #299049)
  * Redone the package names to be much more sane.
    - Based on ubuntu's dbus 0.33 package by Daniel Stone.
    - dbus deamon goes into the dbus package instead of dbus-1
    - glib bindings in libdbus-glib-1-1 instead of dbus-glib-1
    - qt bindings in libdbus-qt-1-1 instead of dbus-qt-1
    - Library component from dbus-1 goed into libdbus-1-1
  * debian/patches/dbus-fixverbose.patch
    - Removed. Fixed upstream
  * debian/patches/dbus-getpwname.patch
    - Removed. Fixed upstream
  * debian/patches/fix-policy-group.patch
    - Removed. Not relevant anymore
  * Actually install all the mono related gumpf.
  * Re-enable dbus, rename libdbus-cil to libdbus-1-cil.
  * Replace kdelibs-dev with kdelibs4-dev in the build dependencies.
  * CXX transition: Rename libdbus-qt-1-1 to libdbus-qt-1-1c2.
  * New upstream version (now with 97% more API breakage!).
    + Resolves segfault exposed by NetworkManager (closes: Ubuntu#8395).
  * Remove fix-policy-group.patch as the relevant section of code (matching by
    gid) appears to have disappeared entirely?
  * dbus-daemon-1 is now dbus-daemon.
  * The client API has changed massively. Rename dbus-glib-1* to
    libdbus-glib-1-1* and dbus-qt-1* to libdbus-qt-1-1* to reflect major
    soversion bump from 0 to 1. Rename dbus-1-dev to libdbus-1-dev. Move the
    library component of dbus-1 to libdbus-1-1; rename the rest of dbus-1 to
    dbus.
  * Merge dbus-mono packaging in; it is no longer a separate source package.
    Don't build it right now though, since mono is still in universe.

ubuntu/hoary 2005-12-20 20:45:14 UTC 2005-12-20
Import patches-unapplied version 0.23.4-0ubuntu3 to ubuntu/hoary

Author: Daniel Stone
Author Date: 2005-04-04 02:47:21 UTC

Import patches-unapplied version 0.23.4-0ubuntu3 to ubuntu/hoary

Imported using git-ubuntu import.

applied/ubuntu/hoary 2005-12-20 20:45:14 UTC 2005-12-20
Import patches-applied version 0.23.4-0ubuntu3 to applied/ubuntu/hoary

Author: Daniel Stone
Author Date: 2005-04-04 02:47:21 UTC

Import patches-applied version 0.23.4-0ubuntu3 to applied/ubuntu/hoary

Imported using git-ubuntu import.

Unapplied parent: b60050aaa7f166a6ce952b44100af1f9d38d76a2

applied/ubuntu/warty-security 2005-12-20 20:08:22 UTC 2005-12-20
Import patches-applied version 0.22-1ubuntu2.1 to applied/ubuntu/warty-security

Author: Martin Pitt
Author Date: 2005-06-27 07:17:30 UTC

Import patches-applied version 0.22-1ubuntu2.1 to applied/ubuntu/warty-security

Imported using git-ubuntu import.

Changelog parent: d453cc90075ae4f11609e70f07f30da241cda025
Unapplied parent: 6478342e9c03a1c0a50ab9059fc2810d499cc586

New changelog entries:
  * SECURITY UPDATE: Fix authentication bypass.
  * Add debian/patches/dbus-sessionbus-checkuid.patch:
    - bus/session.conf.in: Do not allow any user to connect to any session bus
      by default.
    - bus/policy.c: "allowed" now defaults to true if the connecting user id
      matches the session bus user id.
    - This stops other users from listening and sending to other user's
      session dbus instances.
    - References:
      CAN-2005-0201
      https://bugs.freedesktop.org/show_bug.cgi?id=2436

ubuntu/warty-security 2005-12-20 20:08:22 UTC 2005-12-20
Import patches-unapplied version 0.22-1ubuntu2.1 to ubuntu/warty-security

Author: Martin Pitt
Author Date: 2005-06-27 07:17:30 UTC

Import patches-unapplied version 0.22-1ubuntu2.1 to ubuntu/warty-security

Imported using git-ubuntu import.

Changelog parent: 77a0f9d40ad8c910b49062dccd92ca5bbcf4a867

New changelog entries:
  * SECURITY UPDATE: Fix authentication bypass.
  * Add debian/patches/dbus-sessionbus-checkuid.patch:
    - bus/session.conf.in: Do not allow any user to connect to any session bus
      by default.
    - bus/policy.c: "allowed" now defaults to true if the connecting user id
      matches the session bus user id.
    - This stops other users from listening and sending to other user's
      session dbus instances.
    - References:
      CAN-2005-0201
      https://bugs.freedesktop.org/show_bug.cgi?id=2436

applied/ubuntu/warty-devel 2005-12-20 20:08:22 UTC 2005-12-20
Import patches-applied version 0.22-1ubuntu2.1 to applied/ubuntu/warty-security

Author: Martin Pitt
Author Date: 2005-06-27 07:17:30 UTC

Import patches-applied version 0.22-1ubuntu2.1 to applied/ubuntu/warty-security

Imported using git-ubuntu import.

Changelog parent: d453cc90075ae4f11609e70f07f30da241cda025
Unapplied parent: 6478342e9c03a1c0a50ab9059fc2810d499cc586

New changelog entries:
  * SECURITY UPDATE: Fix authentication bypass.
  * Add debian/patches/dbus-sessionbus-checkuid.patch:
    - bus/session.conf.in: Do not allow any user to connect to any session bus
      by default.
    - bus/policy.c: "allowed" now defaults to true if the connecting user id
      matches the session bus user id.
    - This stops other users from listening and sending to other user's
      session dbus instances.
    - References:
      CAN-2005-0201
      https://bugs.freedesktop.org/show_bug.cgi?id=2436

ubuntu/warty-devel 2005-12-20 20:08:22 UTC 2005-12-20
Import patches-unapplied version 0.22-1ubuntu2.1 to ubuntu/warty-security

Author: Martin Pitt
Author Date: 2005-06-27 07:17:30 UTC

Import patches-unapplied version 0.22-1ubuntu2.1 to ubuntu/warty-security

Imported using git-ubuntu import.

Changelog parent: 77a0f9d40ad8c910b49062dccd92ca5bbcf4a867

New changelog entries:
  * SECURITY UPDATE: Fix authentication bypass.
  * Add debian/patches/dbus-sessionbus-checkuid.patch:
    - bus/session.conf.in: Do not allow any user to connect to any session bus
      by default.
    - bus/policy.c: "allowed" now defaults to true if the connecting user id
      matches the session bus user id.
    - This stops other users from listening and sending to other user's
      session dbus instances.
    - References:
      CAN-2005-0201
      https://bugs.freedesktop.org/show_bug.cgi?id=2436

ubuntu/warty 2005-12-20 14:27:19 UTC 2005-12-20
Import patches-unapplied version 0.22-1ubuntu2 to ubuntu/warty

Author: Daniel Stone
Author Date: 2004-10-10 10:52:10 UTC

Import patches-unapplied version 0.22-1ubuntu2 to ubuntu/warty

Imported using git-ubuntu import.

applied/ubuntu/warty 2005-12-20 14:27:19 UTC 2005-12-20
Import patches-applied version 0.22-1ubuntu2 to applied/ubuntu/warty

Author: Daniel Stone
Author Date: 2004-10-10 10:52:10 UTC

Import patches-applied version 0.22-1ubuntu2 to applied/ubuntu/warty

Imported using git-ubuntu import.

Unapplied parent: 77a0f9d40ad8c910b49062dccd92ca5bbcf4a867

101167 of 167 results

Other repositories

Name Last Modified
lp:ubuntu/+source/dbus 2019-12-12
lp:~ddstreet/ubuntu/+source/dbus 2019-10-07
lp:~racb/ubuntu/+source/dbus 2016-12-14
13 of 3 results
You can't create new repositories for dbus in Ubuntu.