View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/ubuntu/+source/amd64-microcode
Members of Ubuntu Server Dev import team can upload to this repository. Log in for directions.

Branches

Name Last Modified Last Commit
importer/ubuntu/dsc 2018-08-13 10:06:54 UTC 2018-08-13
DSC file for 3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1

Author: Ubuntu Git Importer
Author Date: 2018-08-13 10:06:54 UTC

DSC file for 3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1

ubuntu/trusty-updates 2018-08-13 09:58:18 UTC 2018-08-13
Import patches-unapplied version 3.20180524.1~ubuntu0.14.04.2+really20130710....

Author: Julian Andres Klode
Author Date: 2018-08-07 12:09:42 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 66ef27b13812832961c36a02e6e23d990e1d6c01

New changelog entries:
  * Install (all) microcode on non-amd systems too if MODULES=most in initramfs-tools
    config (LP: #1778738)

ubuntu/trusty-proposed 2018-08-13 09:58:18 UTC 2018-08-13
Import patches-unapplied version 3.20180524.1~ubuntu0.14.04.2+really20130710....

Author: Julian Andres Klode
Author Date: 2018-08-07 12:09:42 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 66ef27b13812832961c36a02e6e23d990e1d6c01

New changelog entries:
  * Install (all) microcode on non-amd systems too if MODULES=most in initramfs-tools
    config (LP: #1778738)

applied/ubuntu/trusty-devel 2018-08-13 09:58:18 UTC 2018-08-13
Import patches-applied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1u...

Author: Julian Andres Klode
Author Date: 2018-08-07 12:09:42 UTC

Import patches-applied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 4c96ec553e4d12b1e39a4407d35dcae17c9c0a4b
Unapplied parent: b3f4da8c9164ef60c390474f24274ba9e37b65d8

New changelog entries:
  * Install (all) microcode on non-amd systems too if MODULES=most in initramfs-tools
    config (LP: #1778738)

applied/ubuntu/trusty-proposed 2018-08-13 09:58:18 UTC 2018-08-13
Import patches-applied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1u...

Author: Julian Andres Klode
Author Date: 2018-08-07 12:09:42 UTC

Import patches-applied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 4c96ec553e4d12b1e39a4407d35dcae17c9c0a4b
Unapplied parent: b3f4da8c9164ef60c390474f24274ba9e37b65d8

New changelog entries:
  * Install (all) microcode on non-amd systems too if MODULES=most in initramfs-tools
    config (LP: #1778738)

ubuntu/trusty-devel 2018-08-13 09:58:18 UTC 2018-08-13
Import patches-unapplied version 3.20180524.1~ubuntu0.14.04.2+really20130710....

Author: Julian Andres Klode
Author Date: 2018-08-07 12:09:42 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1 to ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 66ef27b13812832961c36a02e6e23d990e1d6c01

New changelog entries:
  * Install (all) microcode on non-amd systems too if MODULES=most in initramfs-tools
    config (LP: #1778738)

applied/ubuntu/trusty-updates 2018-08-13 09:58:18 UTC 2018-08-13
Import patches-applied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1u...

Author: Julian Andres Klode
Author Date: 2018-08-07 12:09:42 UTC

Import patches-applied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1 to applied/ubuntu/trusty-proposed

Imported using git-ubuntu import.

Changelog parent: 4c96ec553e4d12b1e39a4407d35dcae17c9c0a4b
Unapplied parent: b3f4da8c9164ef60c390474f24274ba9e37b65d8

New changelog entries:
  * Install (all) microcode on non-amd systems too if MODULES=most in initramfs-tools
    config (LP: #1778738)

ubuntu/trusty-security 2018-07-05 19:58:12 UTC 2018-07-05
Import patches-unapplied version 3.20180524.1~ubuntu0.14.04.2+really20130710....

Author: Steve Beattie
Author Date: 2018-07-03 21:11:11 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1 to ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: cfa94c4ea64cf85e8548e6260b156fcb45a71b33

New changelog entries:
  * REGRESSION UPDATE: revert to 2.20131007.1+really20130710.1 due to
    3.20180524.1~ubuntu0.14.04.1 causing boot looping for some AMD
    processors (LP: #1779092)

applied/ubuntu/trusty-security 2018-07-05 19:58:12 UTC 2018-07-05
Import patches-applied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1 ...

Author: Steve Beattie
Author Date: 2018-07-03 21:11:11 UTC

Import patches-applied version 3.20180524.1~ubuntu0.14.04.2+really20130710.1 to applied/ubuntu/trusty-security

Imported using git-ubuntu import.

Changelog parent: 718707d0a7d56fac58806a49198fff1651706f31
Unapplied parent: 66ef27b13812832961c36a02e6e23d990e1d6c01

New changelog entries:
  * REGRESSION UPDATE: revert to 2.20131007.1+really20130710.1 due to
    3.20180524.1~ubuntu0.14.04.1 causing boot looping for some AMD
    processors (LP: #1779092)

ubuntu/xenial-devel 2018-07-02 16:18:14 UTC 2018-07-02
Import patches-unapplied version 3.20180524.1~ubuntu0.16.04.2 to ubuntu/xenia...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.16.04.2 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: f09b5ce13c4c0032242c5c1b48d008adafd1227e

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/xenial-updates 2018-07-02 16:18:14 UTC 2018-07-02
Import patches-applied version 3.20180524.1~ubuntu0.16.04.2 to applied/ubuntu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1~ubuntu0.16.04.2 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: f71da548810a3cf7129ee71717e23712238d58e9
Unapplied parent: c6d884db94bf4a021aba766ccb34de9f481b529c

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/xenial-updates 2018-07-02 16:18:14 UTC 2018-07-02
Import patches-unapplied version 3.20180524.1~ubuntu0.16.04.2 to ubuntu/xenia...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.16.04.2 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: f09b5ce13c4c0032242c5c1b48d008adafd1227e

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/xenial-proposed 2018-07-02 16:18:14 UTC 2018-07-02
Import patches-unapplied version 3.20180524.1~ubuntu0.16.04.2 to ubuntu/xenia...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.16.04.2 to ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: f09b5ce13c4c0032242c5c1b48d008adafd1227e

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/xenial-devel 2018-07-02 16:18:14 UTC 2018-07-02
Import patches-applied version 3.20180524.1~ubuntu0.16.04.2 to applied/ubuntu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1~ubuntu0.16.04.2 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: f71da548810a3cf7129ee71717e23712238d58e9
Unapplied parent: c6d884db94bf4a021aba766ccb34de9f481b529c

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/xenial-proposed 2018-07-02 16:18:14 UTC 2018-07-02
Import patches-applied version 3.20180524.1~ubuntu0.16.04.2 to applied/ubuntu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1~ubuntu0.16.04.2 to applied/ubuntu/xenial-proposed

Imported using git-ubuntu import.

Changelog parent: f71da548810a3cf7129ee71717e23712238d58e9
Unapplied parent: c6d884db94bf4a021aba766ccb34de9f481b529c

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/artful-devel 2018-07-02 16:13:14 UTC 2018-07-02
Import patches-unapplied version 3.20180524.1~ubuntu0.17.10.2 to ubuntu/artfu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.17.10.2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 391eb58436fa5f6fbddfeb17f62c2c6045e70333

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/artful-proposed 2018-07-02 16:13:14 UTC 2018-07-02
Import patches-unapplied version 3.20180524.1~ubuntu0.17.10.2 to ubuntu/artfu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.17.10.2 to ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: 391eb58436fa5f6fbddfeb17f62c2c6045e70333

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/artful-proposed 2018-07-02 16:13:14 UTC 2018-07-02
Import patches-applied version 3.20180524.1~ubuntu0.17.10.2 to applied/ubuntu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1~ubuntu0.17.10.2 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: f6cb80998bc7d86ef64200e79d68983f60a2fe58
Unapplied parent: a5af3cdde93b64afb33c86e4f1d0d11f26a4faaf

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/artful-devel 2018-07-02 16:13:14 UTC 2018-07-02
Import patches-applied version 3.20180524.1~ubuntu0.17.10.2 to applied/ubuntu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1~ubuntu0.17.10.2 to applied/ubuntu/artful-proposed

Imported using git-ubuntu import.

Changelog parent: f6cb80998bc7d86ef64200e79d68983f60a2fe58
Unapplied parent: a5af3cdde93b64afb33c86e4f1d0d11f26a4faaf

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/bionic-devel 2018-07-02 16:08:11 UTC 2018-07-02
Import patches-applied version 3.20180524.1~ubuntu0.18.04.2 to applied/ubuntu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1~ubuntu0.18.04.2 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 824d56c6d5fcd731a9ffe34100a5fc420ba9a11b
Unapplied parent: b58c33ec6d25749f90a949419be6b6ae530f9bcc

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/bionic-proposed 2018-07-02 16:08:11 UTC 2018-07-02
Import patches-applied version 3.20180524.1~ubuntu0.18.04.2 to applied/ubuntu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1~ubuntu0.18.04.2 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 824d56c6d5fcd731a9ffe34100a5fc420ba9a11b
Unapplied parent: b58c33ec6d25749f90a949419be6b6ae530f9bcc

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/bionic-updates 2018-07-02 16:08:11 UTC 2018-07-02
Import patches-applied version 3.20180524.1~ubuntu0.18.04.2 to applied/ubuntu...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1~ubuntu0.18.04.2 to applied/ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: 824d56c6d5fcd731a9ffe34100a5fc420ba9a11b
Unapplied parent: b58c33ec6d25749f90a949419be6b6ae530f9bcc

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/bionic-updates 2018-07-02 16:08:11 UTC 2018-07-02
Import patches-unapplied version 3.20180524.1~ubuntu0.18.04.2 to ubuntu/bioni...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.18.04.2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: e61668b6b3bcb98a58dfb1c037af40ca3ed66376

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/bionic-devel 2018-07-02 16:08:11 UTC 2018-07-02
Import patches-unapplied version 3.20180524.1~ubuntu0.18.04.2 to ubuntu/bioni...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.18.04.2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: e61668b6b3bcb98a58dfb1c037af40ca3ed66376

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/bionic-proposed 2018-07-02 16:08:11 UTC 2018-07-02
Import patches-unapplied version 3.20180524.1~ubuntu0.18.04.2 to ubuntu/bioni...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.18.04.2 to ubuntu/bionic-proposed

Imported using git-ubuntu import.

Changelog parent: e61668b6b3bcb98a58dfb1c037af40ca3ed66376

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/cosmic 2018-06-26 14:38:12 UTC 2018-06-26
Import patches-applied version 3.20180524.1ubuntu1 to applied/ubuntu/cosmic-p...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1ubuntu1 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: fa529a15eb5cd85385e8bde885bbdf4d0cab504b
Unapplied parent: 3fd0a8b984e616fcd85780037bb78f7adb990202

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/cosmic-devel 2018-06-26 14:38:12 UTC 2018-06-26
Import patches-applied version 3.20180524.1ubuntu1 to applied/ubuntu/cosmic-p...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1ubuntu1 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: fa529a15eb5cd85385e8bde885bbdf4d0cab504b
Unapplied parent: 3fd0a8b984e616fcd85780037bb78f7adb990202

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/cosmic-proposed 2018-06-26 14:38:12 UTC 2018-06-26
Import patches-applied version 3.20180524.1ubuntu1 to applied/ubuntu/cosmic-p...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1ubuntu1 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: fa529a15eb5cd85385e8bde885bbdf4d0cab504b
Unapplied parent: 3fd0a8b984e616fcd85780037bb78f7adb990202

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/devel 2018-06-26 14:38:12 UTC 2018-06-26
Import patches-applied version 3.20180524.1ubuntu1 to applied/ubuntu/cosmic-p...

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-applied version 3.20180524.1ubuntu1 to applied/ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: fa529a15eb5cd85385e8bde885bbdf4d0cab504b
Unapplied parent: 3fd0a8b984e616fcd85780037bb78f7adb990202

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/devel 2018-06-26 14:38:12 UTC 2018-06-26
Import patches-unapplied version 3.20180524.1ubuntu1 to ubuntu/cosmic-proposed

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1ubuntu1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/cosmic-proposed 2018-06-26 14:38:12 UTC 2018-06-26
Import patches-unapplied version 3.20180524.1ubuntu1 to ubuntu/cosmic-proposed

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1ubuntu1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/cosmic-devel 2018-06-26 14:38:12 UTC 2018-06-26
Import patches-unapplied version 3.20180524.1ubuntu1 to ubuntu/cosmic-proposed

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1ubuntu1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

ubuntu/cosmic 2018-06-26 14:38:12 UTC 2018-06-26
Import patches-unapplied version 3.20180524.1ubuntu1 to ubuntu/cosmic-proposed

Author: Julian Andres Klode
Author Date: 2018-06-26 14:32:22 UTC

Import patches-unapplied version 3.20180524.1ubuntu1 to ubuntu/cosmic-proposed

Imported using git-ubuntu import.

Changelog parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

applied/ubuntu/artful-updates 2018-06-20 21:18:11 UTC 2018-06-20
Import patches-applied version 3.20180524.1~ubuntu0.17.10.1 to applied/ubuntu...

Author: Steve Beattie
Author Date: 2018-05-29 22:16:39 UTC

Import patches-applied version 3.20180524.1~ubuntu0.17.10.1 to applied/ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: fa529a15eb5cd85385e8bde885bbdf4d0cab504b
Unapplied parent: 391eb58436fa5f6fbddfeb17f62c2c6045e70333

New changelog entries:
  * SECURITY UPDATE: Add Spectre Variant 2 protection for family 17h AMD
    processors (CVE-2017-5715)
    - Backport to artful.

ubuntu/artful-updates 2018-06-20 21:18:11 UTC 2018-06-20
Import patches-unapplied version 3.20180524.1~ubuntu0.17.10.1 to ubuntu/artfu...

Author: Steve Beattie
Author Date: 2018-05-29 22:16:39 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.17.10.1 to ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * SECURITY UPDATE: Add Spectre Variant 2 protection for family 17h AMD
    processors (CVE-2017-5715)
    - Backport to artful.

ubuntu/artful-security 2018-06-20 21:18:11 UTC 2018-06-20
Import patches-unapplied version 3.20180524.1~ubuntu0.17.10.1 to ubuntu/artfu...

Author: Steve Beattie
Author Date: 2018-05-29 22:16:39 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.17.10.1 to ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * SECURITY UPDATE: Add Spectre Variant 2 protection for family 17h AMD
    processors (CVE-2017-5715)
    - Backport to artful.

applied/ubuntu/artful-security 2018-06-20 21:18:11 UTC 2018-06-20
Import patches-applied version 3.20180524.1~ubuntu0.17.10.1 to applied/ubuntu...

Author: Steve Beattie
Author Date: 2018-05-29 22:16:39 UTC

Import patches-applied version 3.20180524.1~ubuntu0.17.10.1 to applied/ubuntu/artful-security

Imported using git-ubuntu import.

Changelog parent: fa529a15eb5cd85385e8bde885bbdf4d0cab504b
Unapplied parent: 391eb58436fa5f6fbddfeb17f62c2c6045e70333

New changelog entries:
  * SECURITY UPDATE: Add Spectre Variant 2 protection for family 17h AMD
    processors (CVE-2017-5715)
    - Backport to artful.

ubuntu/bionic-security 2018-06-20 21:18:11 UTC 2018-06-20
Import patches-unapplied version 3.20180524.1~ubuntu0.18.04.1 to ubuntu/bioni...

Author: Steve Beattie
Author Date: 2018-05-29 22:16:39 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.18.04.1 to ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * SECURITY UPDATE: Add Spectre Variant 2 protection for family 17h AMD
    processors (CVE-2017-5715)
    - Backport to bionic.

ubuntu/xenial-security 2018-06-20 21:18:11 UTC 2018-06-20
Import patches-unapplied version 3.20180524.1~ubuntu0.16.04.1 to ubuntu/xenia...

Author: Steve Beattie
Author Date: 2018-05-29 22:16:39 UTC

Import patches-unapplied version 3.20180524.1~ubuntu0.16.04.1 to ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * SECURITY UPDATE: Add Spectre Variant 2 protection for family 17h AMD
    processors (CVE-2017-5715)
    - Backport to xenial.

applied/ubuntu/xenial-security 2018-06-20 21:18:11 UTC 2018-06-20
Import patches-applied version 3.20180524.1~ubuntu0.16.04.1 to applied/ubuntu...

Author: Steve Beattie
Author Date: 2018-05-29 22:16:39 UTC

Import patches-applied version 3.20180524.1~ubuntu0.16.04.1 to applied/ubuntu/xenial-security

Imported using git-ubuntu import.

Changelog parent: fa529a15eb5cd85385e8bde885bbdf4d0cab504b
Unapplied parent: f09b5ce13c4c0032242c5c1b48d008adafd1227e

New changelog entries:
  * SECURITY UPDATE: Add Spectre Variant 2 protection for family 17h AMD
    processors (CVE-2017-5715)
    - Backport to xenial.

applied/ubuntu/bionic-security 2018-06-20 21:18:11 UTC 2018-06-20
Import patches-applied version 3.20180524.1~ubuntu0.18.04.1 to applied/ubuntu...

Author: Steve Beattie
Author Date: 2018-05-29 22:16:39 UTC

Import patches-applied version 3.20180524.1~ubuntu0.18.04.1 to applied/ubuntu/bionic-security

Imported using git-ubuntu import.

Changelog parent: fa529a15eb5cd85385e8bde885bbdf4d0cab504b
Unapplied parent: e61668b6b3bcb98a58dfb1c037af40ca3ed66376

New changelog entries:
  * SECURITY UPDATE: Add Spectre Variant 2 protection for family 17h AMD
    processors (CVE-2017-5715)
    - Backport to bionic.

importer/debian/dsc 2018-05-25 22:42:03 UTC 2018-05-25
DSC file for 3.20180524.1

Author: Ubuntu Git Importer
Author Date: 2018-05-25 22:42:03 UTC

DSC file for 3.20180524.1

applied/debian/buster 2018-05-25 22:26:58 UTC 2018-05-25
Import patches-applied version 3.20180524.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2018-05-25 18:38:22 UTC

Import patches-applied version 3.20180524.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 4856f71a24332e78d0d1779b25d277a78b950dd2
Unapplied parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * New microcode update packages from AMD upstream:
    + Re-added Microcodes:
      sig 0x00610f01, patch id 0x06001119, 2012-07-13
  * This update avoids regressing sig 0x610f01 processors on systems with
    outdated firmware by adding back exactly the same microcode patch that was
    present before [for these processors]. It does not implement Spectre-v2
    mitigation for these processors.
  * README: update for new release

applied/debian/sid 2018-05-25 22:26:58 UTC 2018-05-25
Import patches-applied version 3.20180524.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2018-05-25 18:38:22 UTC

Import patches-applied version 3.20180524.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 4856f71a24332e78d0d1779b25d277a78b950dd2
Unapplied parent: a02782d21489bf04ff0d5c145741537f62e4525e

New changelog entries:
  * New microcode update packages from AMD upstream:
    + Re-added Microcodes:
      sig 0x00610f01, patch id 0x06001119, 2012-07-13
  * This update avoids regressing sig 0x610f01 processors on systems with
    outdated firmware by adding back exactly the same microcode patch that was
    present before [for these processors]. It does not implement Spectre-v2
    mitigation for these processors.
  * README: update for new release

debian/buster 2018-05-25 22:26:58 UTC 2018-05-25
Import patches-unapplied version 3.20180524.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2018-05-25 18:38:22 UTC

Import patches-unapplied version 3.20180524.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 811c3b7ac4130238a8a5189a69c709ed804ff09a

New changelog entries:
  * New microcode update packages from AMD upstream:
    + Re-added Microcodes:
      sig 0x00610f01, patch id 0x06001119, 2012-07-13
  * This update avoids regressing sig 0x610f01 processors on systems with
    outdated firmware by adding back exactly the same microcode patch that was
    present before [for these processors]. It does not implement Spectre-v2
    mitigation for these processors.
  * README: update for new release

debian/sid 2018-05-25 22:26:58 UTC 2018-05-25
Import patches-unapplied version 3.20180524.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2018-05-25 18:38:22 UTC

Import patches-unapplied version 3.20180524.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 811c3b7ac4130238a8a5189a69c709ed804ff09a

New changelog entries:
  * New microcode update packages from AMD upstream:
    + Re-added Microcodes:
      sig 0x00610f01, patch id 0x06001119, 2012-07-13
  * This update avoids regressing sig 0x610f01 processors on systems with
    outdated firmware by adding back exactly the same microcode patch that was
    present before [for these processors]. It does not implement Spectre-v2
    mitigation for these processors.
  * README: update for new release

importer/ubuntu/pristine-tar 2018-04-03 12:35:39 UTC 2018-04-03
pristine-tar data for amd64-microcode_1.20120910.orig.tar.bz2

Author: Ubuntu Git Importer
Author Date: 2018-04-03 12:35:39 UTC

pristine-tar data for amd64-microcode_1.20120910.orig.tar.bz2

importer/debian/pristine-tar 2018-04-03 12:33:12 UTC 2018-04-03
pristine-tar data for amd64-microcode_2.20120910.orig.tar.bz2

Author: Ubuntu Git Importer
Author Date: 2018-04-03 12:33:12 UTC

pristine-tar data for amd64-microcode_2.20120910.orig.tar.bz2

ubuntu/bionic 2018-01-10 16:29:27 UTC 2018-01-10
Import patches-unapplied version 3.20171205.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2018-01-08 14:19:57 UTC

Import patches-unapplied version 3.20171205.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d862959038f1d0f02834f6408fd11384cf10b776

New changelog entries:
  * New microcode updates (closes: #886382):
    sig 0x00800f12, patch id 0x08001213, 2017-12-05
    Thanks to SuSE for distributing these ahead of AMD's official release!
  * Add IBPB support for family 17h AMD processors (CVE-2017-5715)
  * README: describe source for faml17h microcode update
  * Upload to unstable to match IBPB microcode support on Intel in Debian
    unstable.
  * WARNING: requires at least kernel 4.15, 4.14.13, 4.9.76, 4.4.111 (or a
    backport of commit f4e9b7af0cd58dd039a0fb2cd67d57cea4889abf
    "x86/microcode/AMD: Add support for fam17h microcode loading") otherwise
    it will not be applied to the processor.

applied/ubuntu/bionic 2018-01-10 16:29:27 UTC 2018-01-10
Import patches-applied version 3.20171205.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2018-01-08 14:19:57 UTC

Import patches-applied version 3.20171205.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 8da2c7a7a1049b583f0f3f0b12c4590cdd2f7564
Unapplied parent: ee499606f350bb4f9fb72cf0b108aca073a30ce7

New changelog entries:
  * New microcode updates (closes: #886382):
    sig 0x00800f12, patch id 0x08001213, 2017-12-05
    Thanks to SuSE for distributing these ahead of AMD's official release!
  * Add IBPB support for family 17h AMD processors (CVE-2017-5715)
  * README: describe source for faml17h microcode update
  * Upload to unstable to match IBPB microcode support on Intel in Debian
    unstable.
  * WARNING: requires at least kernel 4.15, 4.14.13, 4.9.76, 4.4.111 (or a
    backport of commit f4e9b7af0cd58dd039a0fb2cd67d57cea4889abf
    "x86/microcode/AMD: Add support for fam17h microcode loading") otherwise
    it will not be applied to the processor.

applied/ubuntu/zesty-security 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-applied version 3.20160316.3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-applied version 3.20160316.3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7c8733c5672350043795c9b3bfc6fb73a8272f05
Unapplied parent: d862959038f1d0f02834f6408fd11384cf10b776

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

applied/ubuntu/zesty-updates 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-applied version 3.20160316.3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-applied version 3.20160316.3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7c8733c5672350043795c9b3bfc6fb73a8272f05
Unapplied parent: d862959038f1d0f02834f6408fd11384cf10b776

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

ubuntu/zesty-security 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-unapplied version 3.20160316.3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-unapplied version 3.20160316.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c69ac1920123f24db2194c3be0c57535e45a687e

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

ubuntu/zesty-proposed 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-unapplied version 3.20160316.3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-unapplied version 3.20160316.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c69ac1920123f24db2194c3be0c57535e45a687e

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

ubuntu/zesty-updates 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-unapplied version 3.20160316.3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-unapplied version 3.20160316.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c69ac1920123f24db2194c3be0c57535e45a687e

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

debian/stretch 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-unapplied version 3.20160316.3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-unapplied version 3.20160316.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c69ac1920123f24db2194c3be0c57535e45a687e

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

ubuntu/zesty-devel 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-unapplied version 3.20160316.3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-unapplied version 3.20160316.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c69ac1920123f24db2194c3be0c57535e45a687e

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

ubuntu/zesty 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-unapplied version 3.20160316.3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-unapplied version 3.20160316.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c69ac1920123f24db2194c3be0c57535e45a687e

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

applied/ubuntu/zesty-devel 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-applied version 3.20160316.3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-applied version 3.20160316.3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7c8733c5672350043795c9b3bfc6fb73a8272f05
Unapplied parent: d862959038f1d0f02834f6408fd11384cf10b776

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

applied/debian/stretch 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-applied version 3.20160316.3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-applied version 3.20160316.3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7c8733c5672350043795c9b3bfc6fb73a8272f05
Unapplied parent: d862959038f1d0f02834f6408fd11384cf10b776

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

applied/ubuntu/zesty 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-applied version 3.20160316.3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-applied version 3.20160316.3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7c8733c5672350043795c9b3bfc6fb73a8272f05
Unapplied parent: d862959038f1d0f02834f6408fd11384cf10b776

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

ubuntu/artful 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-unapplied version 3.20160316.3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-unapplied version 3.20160316.3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: c69ac1920123f24db2194c3be0c57535e45a687e

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

applied/ubuntu/artful 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-applied version 3.20160316.3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-applied version 3.20160316.3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7c8733c5672350043795c9b3bfc6fb73a8272f05
Unapplied parent: d862959038f1d0f02834f6408fd11384cf10b776

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

applied/ubuntu/zesty-proposed 2016-12-01 04:11:18 UTC 2016-12-01
Import patches-applied version 3.20160316.3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-11-30 01:54:53 UTC

Import patches-applied version 3.20160316.3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 7c8733c5672350043795c9b3bfc6fb73a8272f05
Unapplied parent: d862959038f1d0f02834f6408fd11384cf10b776

New changelog entries:
  * initramfs: Make the early initramfs reproducible (closes: #845194)
  * rules: switch to simplified dh-based build (debhelper v9)

applied/ubuntu/yakkety-proposed 2016-04-23 22:11:10 UTC 2016-04-23
Import patches-applied version 3.20160316.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-04-10 19:31:23 UTC

Import patches-applied version 3.20160316.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 255540676f4cc0437b38227ca5599709a837f03b
Unapplied parent: 5fa2b511a0bbe520ca43a937373b2240bf299874

New changelog entries:
  * Bump major version number to 3: early-initramfs support
  * Support is now restricted to Linux kernel 3.14 and later. For older
    kernels, please use the version 2 (older) branch of the package.
  * Implement early-initramfs mode, and remove normal mode
    * debian/control: add versioned recommends for initramfs-tools and
      dracut. Note that dracut 044 is required for Linux 4.4 and later,
      otherwise dracut 040 would be enough
    * debian/default: add early mode, remove normal mode from comments
    * initramfs hook: use cpio to generate an early-initramfs with
      microcode for all processors, blacklist kernels older than 3.14,
      and remove normal mode support.
    * initramfs.init-premount: remove, not needed for early-initramfs
    * debian/rules: don't install init-premount initramfs script.
  * initramfs.hook: detect a missing microcode.ko and don't attempt to
    force_load() it. In verbose mode, log when the microcode driver is
    modular. For Linux 4.4 and later, skip the module loading logic
    (closes: #809444)
  * README.Debian: update for early initramfs support, and add information
    on how to disable early updates using the dis_ucode_ldr kernel boot
    parameter
  * Support for x32 was enabled in debian/control for the 2.20160316.1
    upload, but the changelog did not record this by mistake. The missing
    entry was retroactively added to debian/changelog by this upload

ubuntu/yakkety 2016-04-23 22:11:10 UTC 2016-04-23
Import patches-unapplied version 3.20160316.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-04-10 19:31:23 UTC

Import patches-unapplied version 3.20160316.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d278c9b54239c2e40df4168dad58e95c704aa67a

New changelog entries:
  * Bump major version number to 3: early-initramfs support
  * Support is now restricted to Linux kernel 3.14 and later. For older
    kernels, please use the version 2 (older) branch of the package.
  * Implement early-initramfs mode, and remove normal mode
    * debian/control: add versioned recommends for initramfs-tools and
      dracut. Note that dracut 044 is required for Linux 4.4 and later,
      otherwise dracut 040 would be enough
    * debian/default: add early mode, remove normal mode from comments
    * initramfs hook: use cpio to generate an early-initramfs with
      microcode for all processors, blacklist kernels older than 3.14,
      and remove normal mode support.
    * initramfs.init-premount: remove, not needed for early-initramfs
    * debian/rules: don't install init-premount initramfs script.
  * initramfs.hook: detect a missing microcode.ko and don't attempt to
    force_load() it. In verbose mode, log when the microcode driver is
    modular. For Linux 4.4 and later, skip the module loading logic
    (closes: #809444)
  * README.Debian: update for early initramfs support, and add information
    on how to disable early updates using the dis_ucode_ldr kernel boot
    parameter
  * Support for x32 was enabled in debian/control for the 2.20160316.1
    upload, but the changelog did not record this by mistake. The missing
    entry was retroactively added to debian/changelog by this upload

ubuntu/yakkety-devel 2016-04-23 22:11:10 UTC 2016-04-23
Import patches-unapplied version 3.20160316.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-04-10 19:31:23 UTC

Import patches-unapplied version 3.20160316.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d278c9b54239c2e40df4168dad58e95c704aa67a

New changelog entries:
  * Bump major version number to 3: early-initramfs support
  * Support is now restricted to Linux kernel 3.14 and later. For older
    kernels, please use the version 2 (older) branch of the package.
  * Implement early-initramfs mode, and remove normal mode
    * debian/control: add versioned recommends for initramfs-tools and
      dracut. Note that dracut 044 is required for Linux 4.4 and later,
      otherwise dracut 040 would be enough
    * debian/default: add early mode, remove normal mode from comments
    * initramfs hook: use cpio to generate an early-initramfs with
      microcode for all processors, blacklist kernels older than 3.14,
      and remove normal mode support.
    * initramfs.init-premount: remove, not needed for early-initramfs
    * debian/rules: don't install init-premount initramfs script.
  * initramfs.hook: detect a missing microcode.ko and don't attempt to
    force_load() it. In verbose mode, log when the microcode driver is
    modular. For Linux 4.4 and later, skip the module loading logic
    (closes: #809444)
  * README.Debian: update for early initramfs support, and add information
    on how to disable early updates using the dis_ucode_ldr kernel boot
    parameter
  * Support for x32 was enabled in debian/control for the 2.20160316.1
    upload, but the changelog did not record this by mistake. The missing
    entry was retroactively added to debian/changelog by this upload

ubuntu/yakkety-proposed 2016-04-23 22:11:10 UTC 2016-04-23
Import patches-unapplied version 3.20160316.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-04-10 19:31:23 UTC

Import patches-unapplied version 3.20160316.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d278c9b54239c2e40df4168dad58e95c704aa67a

New changelog entries:
  * Bump major version number to 3: early-initramfs support
  * Support is now restricted to Linux kernel 3.14 and later. For older
    kernels, please use the version 2 (older) branch of the package.
  * Implement early-initramfs mode, and remove normal mode
    * debian/control: add versioned recommends for initramfs-tools and
      dracut. Note that dracut 044 is required for Linux 4.4 and later,
      otherwise dracut 040 would be enough
    * debian/default: add early mode, remove normal mode from comments
    * initramfs hook: use cpio to generate an early-initramfs with
      microcode for all processors, blacklist kernels older than 3.14,
      and remove normal mode support.
    * initramfs.init-premount: remove, not needed for early-initramfs
    * debian/rules: don't install init-premount initramfs script.
  * initramfs.hook: detect a missing microcode.ko and don't attempt to
    force_load() it. In verbose mode, log when the microcode driver is
    modular. For Linux 4.4 and later, skip the module loading logic
    (closes: #809444)
  * README.Debian: update for early initramfs support, and add information
    on how to disable early updates using the dis_ucode_ldr kernel boot
    parameter
  * Support for x32 was enabled in debian/control for the 2.20160316.1
    upload, but the changelog did not record this by mistake. The missing
    entry was retroactively added to debian/changelog by this upload

applied/ubuntu/yakkety 2016-04-23 22:11:10 UTC 2016-04-23
Import patches-applied version 3.20160316.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-04-10 19:31:23 UTC

Import patches-applied version 3.20160316.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 255540676f4cc0437b38227ca5599709a837f03b
Unapplied parent: 5fa2b511a0bbe520ca43a937373b2240bf299874

New changelog entries:
  * Bump major version number to 3: early-initramfs support
  * Support is now restricted to Linux kernel 3.14 and later. For older
    kernels, please use the version 2 (older) branch of the package.
  * Implement early-initramfs mode, and remove normal mode
    * debian/control: add versioned recommends for initramfs-tools and
      dracut. Note that dracut 044 is required for Linux 4.4 and later,
      otherwise dracut 040 would be enough
    * debian/default: add early mode, remove normal mode from comments
    * initramfs hook: use cpio to generate an early-initramfs with
      microcode for all processors, blacklist kernels older than 3.14,
      and remove normal mode support.
    * initramfs.init-premount: remove, not needed for early-initramfs
    * debian/rules: don't install init-premount initramfs script.
  * initramfs.hook: detect a missing microcode.ko and don't attempt to
    force_load() it. In verbose mode, log when the microcode driver is
    modular. For Linux 4.4 and later, skip the module loading logic
    (closes: #809444)
  * README.Debian: update for early initramfs support, and add information
    on how to disable early updates using the dis_ucode_ldr kernel boot
    parameter
  * Support for x32 was enabled in debian/control for the 2.20160316.1
    upload, but the changelog did not record this by mistake. The missing
    entry was retroactively added to debian/changelog by this upload

applied/ubuntu/yakkety-devel 2016-04-23 22:11:10 UTC 2016-04-23
Import patches-applied version 3.20160316.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2016-04-10 19:31:23 UTC

Import patches-applied version 3.20160316.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 255540676f4cc0437b38227ca5599709a837f03b
Unapplied parent: 5fa2b511a0bbe520ca43a937373b2240bf299874

New changelog entries:
  * Bump major version number to 3: early-initramfs support
  * Support is now restricted to Linux kernel 3.14 and later. For older
    kernels, please use the version 2 (older) branch of the package.
  * Implement early-initramfs mode, and remove normal mode
    * debian/control: add versioned recommends for initramfs-tools and
      dracut. Note that dracut 044 is required for Linux 4.4 and later,
      otherwise dracut 040 would be enough
    * debian/default: add early mode, remove normal mode from comments
    * initramfs hook: use cpio to generate an early-initramfs with
      microcode for all processors, blacklist kernels older than 3.14,
      and remove normal mode support.
    * initramfs.init-premount: remove, not needed for early-initramfs
    * debian/rules: don't install init-premount initramfs script.
  * initramfs.hook: detect a missing microcode.ko and don't attempt to
    force_load() it. In verbose mode, log when the microcode driver is
    modular. For Linux 4.4 and later, skip the module loading logic
    (closes: #809444)
  * README.Debian: update for early initramfs support, and add information
    on how to disable early updates using the dis_ucode_ldr kernel boot
    parameter
  * Support for x32 was enabled in debian/control for the 2.20160316.1
    upload, but the changelog did not record this by mistake. The missing
    entry was retroactively added to debian/changelog by this upload

applied/debian/wheezy 2016-04-02 23:20:55 UTC 2016-04-02
Import patches-applied version 1.20160316.1 to applied/debian/wheezy

Author: Henrique de Moraes Holschuh
Author Date: 2016-03-19 22:10:20 UTC

Import patches-applied version 1.20160316.1 to applied/debian/wheezy

Imported using git-ubuntu import.

Changelog parent: 8a6fcca4ce8070eea04421e7ed3d96c533d23510
Unapplied parent: 85d4866131083c279cd1e6fd600f1af2dd289e99

New changelog entries:
  * Upstream release 20160316 built from linux-firmware:
    + Updated Microcodes:
      sig 0x00600f20, patch id 0x0600084f, 2016-01-25
    + This microcode updates fixes a critical erratum on NMI handling
      introduced by microcode patch id 0x6000832 from the 20141028 update.
      The erratum is also present on microcode patch id 0x6000836.
    + THIS IS A CRITICAL STABILITY AND SECURITY UPDATE FOR THE EARLIER
      AMD PILEDRIVER PROCESSORS, including:
      + AMD Opteron 3300, 4300, 6300
      + AMD FX "Vishera" (43xx, 63xx, 83xx, 93xx, 95xx)
      + AMD processors with family 21, model 2, stepping 0
  * Robert Święcki, while fuzzing the kernel using the syzkaller tool,
    uncovered very strange behavior on an AMD FX-8320, later reproduced on
    other AMD Piledriver model 2, stepping 0 processors including the Opteron
    6300. Robert discovered, using his proof-of-concept exploit code, that
    the incorrect behavior allows an unpriviledged attacker on an unpriviledged
    VM to corrupt the return stack of the host kernel's NMI handler. At best,
    this results in unpredictable host behavior. At worst, it allows for an
    unpriviledged user on unpriviledged VM to carry a sucessful host-kernel
    ring 0 code injection attack.
  * The erratum is timing-dependant, easily triggered by workloads that
    cause a high number of NMIs, such as running the "perf" tool.

debian/wheezy 2016-04-02 23:20:55 UTC 2016-04-02
Import patches-unapplied version 1.20160316.1 to debian/wheezy

Author: Henrique de Moraes Holschuh
Author Date: 2016-03-19 22:10:20 UTC

Import patches-unapplied version 1.20160316.1 to debian/wheezy

Imported using git-ubuntu import.

Changelog parent: b59ee273ed3bcda6f1fa15a65f3a4dbc779ba725

New changelog entries:
  * Upstream release 20160316 built from linux-firmware:
    + Updated Microcodes:
      sig 0x00600f20, patch id 0x0600084f, 2016-01-25
    + This microcode updates fixes a critical erratum on NMI handling
      introduced by microcode patch id 0x6000832 from the 20141028 update.
      The erratum is also present on microcode patch id 0x6000836.
    + THIS IS A CRITICAL STABILITY AND SECURITY UPDATE FOR THE EARLIER
      AMD PILEDRIVER PROCESSORS, including:
      + AMD Opteron 3300, 4300, 6300
      + AMD FX "Vishera" (43xx, 63xx, 83xx, 93xx, 95xx)
      + AMD processors with family 21, model 2, stepping 0
  * Robert Święcki, while fuzzing the kernel using the syzkaller tool,
    uncovered very strange behavior on an AMD FX-8320, later reproduced on
    other AMD Piledriver model 2, stepping 0 processors including the Opteron
    6300. Robert discovered, using his proof-of-concept exploit code, that
    the incorrect behavior allows an unpriviledged attacker on an unpriviledged
    VM to corrupt the return stack of the host kernel's NMI handler. At best,
    this results in unpredictable host behavior. At worst, it allows for an
    unpriviledged user on unpriviledged VM to carry a sucessful host-kernel
    ring 0 code injection attack.
  * The erratum is timing-dependant, easily triggered by workloads that
    cause a high number of NMIs, such as running the "perf" tool.

applied/debian/jessie 2016-04-02 22:47:17 UTC 2016-04-02
Import patches-applied version 2.20160316.1~deb8u1 to applied/debian/jessie

Author: Henrique de Moraes Holschuh
Author Date: 2016-03-19 17:21:54 UTC

Import patches-applied version 2.20160316.1~deb8u1 to applied/debian/jessie

Imported using git-ubuntu import.

Changelog parent: 255540676f4cc0437b38227ca5599709a837f03b
Unapplied parent: 0398e0984e41f6e2bc103e93061b52d681d404d2

New changelog entries:
  * This is exactly the same release as 2.20160316.1

debian/jessie 2016-04-02 22:47:17 UTC 2016-04-02
Import patches-unapplied version 2.20160316.1~deb8u1 to debian/jessie

Author: Henrique de Moraes Holschuh
Author Date: 2016-03-19 17:21:54 UTC

Import patches-unapplied version 2.20160316.1~deb8u1 to debian/jessie

Imported using git-ubuntu import.

Changelog parent: d278c9b54239c2e40df4168dad58e95c704aa67a

New changelog entries:
  * This is exactly the same release as 2.20160316.1

ubuntu/xenial 2016-03-22 04:21:16 UTC 2016-03-22
Import patches-unapplied version 2.20160316.1 to debian/stretch

Author: Henrique de Moraes Holschuh
Author Date: 2016-03-19 17:02:44 UTC

Import patches-unapplied version 2.20160316.1 to debian/stretch

Imported using git-ubuntu import.

Changelog parent: 40fd6f805ff2fea4c941edb4754dffb8d51a02e7

New changelog entries:
  * Upstream release 20160316 built from linux-firmware:
    + Updated Microcodes:
      sig 0x00600f20, patch id 0x0600084f, 2016-01-25
    + This microcode updates fixes a critical erratum on NMI handling
      introduced by microcode patch id 0x6000832 from the 20141028 update.
      The erratum is also present on microcode patch id 0x6000836.
    + THIS IS A CRITICAL STABILITY AND SECURITY UPDATE FOR THE EARLIER
      AMD PILEDRIVER PROCESSORS, including:
      + AMD Opteron 3300, 4300, 6300
      + AMD FX "Vishera" (43xx, 63xx, 83xx, 93xx, 95xx)
      + AMD processors with family 21, model 2, stepping 0
  * Robert Święcki, while fuzzing the kernel using the syzkaller tool,
    uncovered very strange behavior on an AMD FX-8320, later reproduced on
    other AMD Piledriver model 2, stepping 0 processors including the Opteron
    6300. Robert discovered, using his proof-of-concept exploit code, that
    the incorrect behavior allows an unpriviledged attacker on an unpriviledged
    VM to corrupt the return stack of the host kernel's NMI handler. At best,
    this results in unpredictable host behavior. At worst, it allows for an
    unpriviledged user on unpriviledged VM to carry a sucessful host-kernel
    ring 0 code injection attack.
  * The erratum is timing-dependant, easily triggered by workloads that cause
    a high number of NMIs, such as running the "perf" tool.

applied/ubuntu/xenial 2016-03-22 04:21:16 UTC 2016-03-22
Import patches-applied version 2.20160316.1 to applied/debian/stretch

Author: Henrique de Moraes Holschuh
Author Date: 2016-03-19 17:02:44 UTC

Import patches-applied version 2.20160316.1 to applied/debian/stretch

Imported using git-ubuntu import.

Changelog parent: 095ebb40148966f643d8ad532d0e56b20d7725eb
Unapplied parent: d278c9b54239c2e40df4168dad58e95c704aa67a

New changelog entries:
  * Upstream release 20160316 built from linux-firmware:
    + Updated Microcodes:
      sig 0x00600f20, patch id 0x0600084f, 2016-01-25
    + This microcode updates fixes a critical erratum on NMI handling
      introduced by microcode patch id 0x6000832 from the 20141028 update.
      The erratum is also present on microcode patch id 0x6000836.
    + THIS IS A CRITICAL STABILITY AND SECURITY UPDATE FOR THE EARLIER
      AMD PILEDRIVER PROCESSORS, including:
      + AMD Opteron 3300, 4300, 6300
      + AMD FX "Vishera" (43xx, 63xx, 83xx, 93xx, 95xx)
      + AMD processors with family 21, model 2, stepping 0
  * Robert Święcki, while fuzzing the kernel using the syzkaller tool,
    uncovered very strange behavior on an AMD FX-8320, later reproduced on
    other AMD Piledriver model 2, stepping 0 processors including the Opteron
    6300. Robert discovered, using his proof-of-concept exploit code, that
    the incorrect behavior allows an unpriviledged attacker on an unpriviledged
    VM to corrupt the return stack of the host kernel's NMI handler. At best,
    this results in unpredictable host behavior. At worst, it allows for an
    unpriviledged user on unpriviledged VM to carry a sucessful host-kernel
    ring 0 code injection attack.
  * The erratum is timing-dependant, easily triggered by workloads that cause
    a high number of NMIs, such as running the "perf" tool.

ubuntu/wily 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-unapplied version 2.20141028.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-unapplied version 2.20141028.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 075e370861fd5e8595fa2991bb26a6eab2c36709

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

applied/ubuntu/vivid-devel 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-applied version 2.20141028.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-applied version 2.20141028.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 76de997d016188d14e0d29f3ead9ae5da1e3c400
Unapplied parent: 40fd6f805ff2fea4c941edb4754dffb8d51a02e7

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

ubuntu/vivid-proposed 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-unapplied version 2.20141028.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-unapplied version 2.20141028.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 075e370861fd5e8595fa2991bb26a6eab2c36709

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

ubuntu/vivid 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-unapplied version 2.20141028.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-unapplied version 2.20141028.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 075e370861fd5e8595fa2991bb26a6eab2c36709

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

ubuntu/vivid-devel 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-unapplied version 2.20141028.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-unapplied version 2.20141028.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 075e370861fd5e8595fa2991bb26a6eab2c36709

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

applied/ubuntu/vivid-proposed 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-applied version 2.20141028.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-applied version 2.20141028.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 76de997d016188d14e0d29f3ead9ae5da1e3c400
Unapplied parent: 40fd6f805ff2fea4c941edb4754dffb8d51a02e7

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

applied/ubuntu/vivid 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-applied version 2.20141028.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-applied version 2.20141028.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 76de997d016188d14e0d29f3ead9ae5da1e3c400
Unapplied parent: 40fd6f805ff2fea4c941edb4754dffb8d51a02e7

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

applied/ubuntu/wily-devel 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-applied version 2.20141028.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-applied version 2.20141028.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 76de997d016188d14e0d29f3ead9ae5da1e3c400
Unapplied parent: 40fd6f805ff2fea4c941edb4754dffb8d51a02e7

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

applied/ubuntu/wily 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-applied version 2.20141028.1 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-applied version 2.20141028.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: 76de997d016188d14e0d29f3ead9ae5da1e3c400
Unapplied parent: 40fd6f805ff2fea4c941edb4754dffb8d51a02e7

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

ubuntu/wily-devel 2014-12-19 04:10:55 UTC 2014-12-19
Import patches-unapplied version 2.20141028.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2014-12-18 15:36:27 UTC

Import patches-unapplied version 2.20141028.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 075e370861fd5e8595fa2991bb26a6eab2c36709

New changelog entries:
  * Upstream release 20141028 built from linux-firmware:
    + Updated microcode patches for family 0x15 processors
    + Added microcode patches for family 0x16 processors
  * AMD did not update the relevant microcode documentation (errata fixed,
    microcode patch levels, etc), so there is no documentation for the
    family 0x16 microcode patches, and the documentation for family 0x15 is
    stale.
  * postinst: do not update microcode on upgrades:
    Remove code that triggers a microcode update on package upgrade. The
    resulting postinst script is now identical to the one in Debian jessie's
    intel-microcode, and thus known-good.
    NOTE: this code was already disabled for the majority of the users due
    to Debian bug #723975 (closes: #723975, #723081)
  * kpreinst: remove, we don't update microcode on postinst anymore
  * blacklist automated loading of the microcode module:
    This is in line with the desired behavior of only updating microcode
    *automatically* during system boot, when it is safer to do so. The
    local admin can still load the microcode module and update the microcode
    manually at any time, of course. This is in sync with the intel-microcode
    packages in Debian jessie, which will also blacklist the microcode module.
    Note that the initramfs will force-load the microcode module in a safe
    condition, the blacklist avoids module autoloading outside the initramfs
  * control: bump standards version (no changes required)
  * copyright: update upstream URL and upstream copyright date
    (closes: #753593)
  * docs: future-proof by using a glob pattern for per-family README files
  * initramfs hook: support forced installation of amd64-microcode:
    Add a config file (/etc/default/amd64-microcode) to select the mode of
    operation: do nothing, force install to initramfs, install only when
    running on an amd64 processor (closes: #726854)
  * initramfs hook: fix (likely unexploitable) issues found by shellcheck
  * Add a NEWS.Debian file to warn users we will no longer update the
    microcode on package upgrade (note that we were not doing it on any
    Debian kernels anyway). Also document the existence of the new
    /etc/default/amd64-microcode file

applied/ubuntu/trusty 2013-09-08 10:10:51 UTC 2013-09-08
Import patches-applied version 2.20131007.1+really20130710.1 to applied/debia...

Author: Henrique de Moraes Holschuh
Author Date: 2013-09-08 01:22:00 UTC

Import patches-applied version 2.20131007.1+really20130710.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: cf3432fd9a2bb2cc01237f828be2d6ca4c9a349e
Unapplied parent: 075e370861fd5e8595fa2991bb26a6eab2c36709

New changelog entries:
  * Fix M-D-Y issue that leaked to the package version number
  * The real upstream release date is 2013-07-10

ubuntu/trusty 2013-09-08 10:10:51 UTC 2013-09-08
Import patches-unapplied version 2.20131007.1+really20130710.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-09-08 01:22:00 UTC

Import patches-unapplied version 2.20131007.1+really20130710.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8024d8ce3ea1860337cfaa48b4e93b23c2420b7b

New changelog entries:
  * Fix M-D-Y issue that leaked to the package version number
  * The real upstream release date is 2013-07-10

ubuntu/utopic 2013-09-08 10:10:51 UTC 2013-09-08
Import patches-unapplied version 2.20131007.1+really20130710.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-09-08 01:22:00 UTC

Import patches-unapplied version 2.20131007.1+really20130710.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8024d8ce3ea1860337cfaa48b4e93b23c2420b7b

New changelog entries:
  * Fix M-D-Y issue that leaked to the package version number
  * The real upstream release date is 2013-07-10

ubuntu/utopic-devel 2013-09-08 10:10:51 UTC 2013-09-08
Import patches-unapplied version 2.20131007.1+really20130710.1 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-09-08 01:22:00 UTC

Import patches-unapplied version 2.20131007.1+really20130710.1 to debian/sid

Imported using git-ubuntu import.

Changelog parent: 8024d8ce3ea1860337cfaa48b4e93b23c2420b7b

New changelog entries:
  * Fix M-D-Y issue that leaked to the package version number
  * The real upstream release date is 2013-07-10

applied/ubuntu/utopic-devel 2013-09-08 10:10:51 UTC 2013-09-08
Import patches-applied version 2.20131007.1+really20130710.1 to applied/debia...

Author: Henrique de Moraes Holschuh
Author Date: 2013-09-08 01:22:00 UTC

Import patches-applied version 2.20131007.1+really20130710.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: cf3432fd9a2bb2cc01237f828be2d6ca4c9a349e
Unapplied parent: 075e370861fd5e8595fa2991bb26a6eab2c36709

New changelog entries:
  * Fix M-D-Y issue that leaked to the package version number
  * The real upstream release date is 2013-07-10

applied/ubuntu/utopic 2013-09-08 10:10:51 UTC 2013-09-08
Import patches-applied version 2.20131007.1+really20130710.1 to applied/debia...

Author: Henrique de Moraes Holschuh
Author Date: 2013-09-08 01:22:00 UTC

Import patches-applied version 2.20131007.1+really20130710.1 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: cf3432fd9a2bb2cc01237f828be2d6ca4c9a349e
Unapplied parent: 075e370861fd5e8595fa2991bb26a6eab2c36709

New changelog entries:
  * Fix M-D-Y issue that leaked to the package version number
  * The real upstream release date is 2013-07-10

applied/ubuntu/saucy-devel 2013-07-20 22:10:51 UTC 2013-07-20
Import patches-applied version 1.20120910-3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-07-20 15:45:04 UTC

Import patches-applied version 1.20120910-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c978c0341d62c977a807ac074c192f4475a3d3d2
Unapplied parent: 8f3ee6c479c4c857bf4a61c4cc4cea74197191db

New changelog entries:
  * control: remove homepage and update standards-version
  * initramfs: update copyright information
  * initramfs, postinst: don't do anything on non-AMD systems (Closes: #715518)
  * initramfs, postinst: blacklist several kernel versions (Closes: #717185)
  * control: add breaks: intel-microcode (<< 1.20130222.6~)
  * load microcode module on package install/upgrade

applied/ubuntu/saucy-proposed 2013-07-20 22:10:51 UTC 2013-07-20
Import patches-applied version 1.20120910-3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-07-20 15:45:04 UTC

Import patches-applied version 1.20120910-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c978c0341d62c977a807ac074c192f4475a3d3d2
Unapplied parent: 8f3ee6c479c4c857bf4a61c4cc4cea74197191db

New changelog entries:
  * control: remove homepage and update standards-version
  * initramfs: update copyright information
  * initramfs, postinst: don't do anything on non-AMD systems (Closes: #715518)
  * initramfs, postinst: blacklist several kernel versions (Closes: #717185)
  * control: add breaks: intel-microcode (<< 1.20130222.6~)
  * load microcode module on package install/upgrade

ubuntu/saucy 2013-07-20 22:10:51 UTC 2013-07-20
Import patches-unapplied version 1.20120910-3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-07-20 15:45:04 UTC

Import patches-unapplied version 1.20120910-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: da73420ae9074cca6f5236408f7048ffc78c9740

New changelog entries:
  * control: remove homepage and update standards-version
  * initramfs: update copyright information
  * initramfs, postinst: don't do anything on non-AMD systems (Closes: #715518)
  * initramfs, postinst: blacklist several kernel versions (Closes: #717185)
  * control: add breaks: intel-microcode (<< 1.20130222.6~)
  * load microcode module on package install/upgrade

ubuntu/saucy-proposed 2013-07-20 22:10:51 UTC 2013-07-20
Import patches-unapplied version 1.20120910-3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-07-20 15:45:04 UTC

Import patches-unapplied version 1.20120910-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: da73420ae9074cca6f5236408f7048ffc78c9740

New changelog entries:
  * control: remove homepage and update standards-version
  * initramfs: update copyright information
  * initramfs, postinst: don't do anything on non-AMD systems (Closes: #715518)
  * initramfs, postinst: blacklist several kernel versions (Closes: #717185)
  * control: add breaks: intel-microcode (<< 1.20130222.6~)
  * load microcode module on package install/upgrade

ubuntu/saucy-devel 2013-07-20 22:10:51 UTC 2013-07-20
Import patches-unapplied version 1.20120910-3 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-07-20 15:45:04 UTC

Import patches-unapplied version 1.20120910-3 to debian/sid

Imported using git-ubuntu import.

Changelog parent: da73420ae9074cca6f5236408f7048ffc78c9740

New changelog entries:
  * control: remove homepage and update standards-version
  * initramfs: update copyright information
  * initramfs, postinst: don't do anything on non-AMD systems (Closes: #715518)
  * initramfs, postinst: blacklist several kernel versions (Closes: #717185)
  * control: add breaks: intel-microcode (<< 1.20130222.6~)
  * load microcode module on package install/upgrade

applied/ubuntu/saucy 2013-07-20 22:10:51 UTC 2013-07-20
Import patches-applied version 1.20120910-3 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2013-07-20 15:45:04 UTC

Import patches-applied version 1.20120910-3 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: c978c0341d62c977a807ac074c192f4475a3d3d2
Unapplied parent: 8f3ee6c479c4c857bf4a61c4cc4cea74197191db

New changelog entries:
  * control: remove homepage and update standards-version
  * initramfs: update copyright information
  * initramfs, postinst: don't do anything on non-AMD systems (Closes: #715518)
  * initramfs, postinst: blacklist several kernel versions (Closes: #717185)
  * control: add breaks: intel-microcode (<< 1.20130222.6~)
  * load microcode module on package install/upgrade

ubuntu/raring 2012-10-09 16:17:20 UTC 2012-10-09
Import patches-unapplied version 1.20120910-2 to debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2012-10-09 11:18:01 UTC

Import patches-unapplied version 1.20120910-2 to debian/sid

Imported using git-ubuntu import.

Changelog parent: d7d8c06a61ac60753ce98ef3b0bfb63b5a368d31

New changelog entries:
  * initramfs: work around initramfs-tools bug #688794.
    Use "_" in place of "+-." for the initramfs script name. This works
    around a PANIC during boot when the initramfs was created in a system
    with noexec $TMPDIR.

applied/ubuntu/raring-devel 2012-10-09 16:17:20 UTC 2012-10-09
Import patches-applied version 1.20120910-2 to applied/debian/sid

Author: Henrique de Moraes Holschuh
Author Date: 2012-10-09 11:18:01 UTC

Import patches-applied version 1.20120910-2 to applied/debian/sid

Imported using git-ubuntu import.

Changelog parent: e449a2166d413d6a26391b1369a6339444b59df0
Unapplied parent: da73420ae9074cca6f5236408f7048ffc78c9740

New changelog entries:
  * initramfs: work around initramfs-tools bug #688794.
    Use "_" in place of "+-." for the initramfs script name. This works
    around a PANIC during boot when the initramfs was created in a system
    with noexec $TMPDIR.

1100 of 108 results

Other repositories

Name Last Modified
lp:ubuntu/+source/amd64-microcode 2018-08-20
11 of 1 result
You can't create new repositories for amd64-microcode in Ubuntu.