View Bazaar branches
Get this repository:
git clone https://git.launchpad.net/doxygen-sid

Branches

Name Last Modified Last Commit
master 2021-03-21 23:04:29 UTC 2021-03-21
release to unstable

Author: Paolo Greppi
Author Date: 2021-03-21 23:04:29 UTC

release to unstable

pristine-tar 2021-01-08 18:01:57 UTC 2021-01-08
pristine-tar data for doxygen_1.9.1.orig.tar.gz

Author: Paolo Greppi
Author Date: 2021-01-08 18:01:57 UTC

pristine-tar data for doxygen_1.9.1.orig.tar.gz

upstream 2021-01-08 18:01:44 UTC 2021-01-08
New upstream version 1.9.1

Author: Paolo Greppi
Author Date: 2021-01-08 18:01:44 UTC

New upstream version 1.9.1

debian/sid 2019-12-10 18:10:05 UTC 2019-12-10
Import Debian changes 1.8.13-13

Author: Steve Langasek
Author Date: 2019-12-09 05:31:05 UTC

Import Debian changes 1.8.13-13

doxygen (1.8.13-13) unstable; urgency=medium

  * QA upload.
  * Make autopkgtests cross-test-friendly.

debian/bookworm 2019-10-31 12:13:12 UTC 2019-10-31
Import Debian changes 1.8.13-12

Author: Steve Langasek
Author Date: 2019-10-20 06:34:45 UTC

Import Debian changes 1.8.13-12

doxygen (1.8.13-12) unstable; urgency=medium

  * QA upload.
  * Build using LLVM 9.0.

debian/buster 2018-03-14 19:28:20 UTC 2018-03-14
Import Debian changes 1.8.13-10

Author: Matthias Klose
Author Date: 2018-03-12 08:22:14 UTC

Import Debian changes 1.8.13-10

doxygen (1.8.13-10) unstable; urgency=medium

  * Orphan the package. See: #888580.
  * Build using LLVM 6.0.
  * Drop build dependency on ruby-compass. Closes: #875505.
  * Stop building the doxygen-dbg package.

debian/stretch 2018-03-14 19:27:11 UTC 2018-03-14
Import Debian changes 1.8.13-4

Author: Matthias Klose
Author Date: 2017-01-04 09:44:49 UTC

Import Debian changes 1.8.13-4

doxygen (1.8.13-4) unstable; urgency=medium

  * Fix segfault generating XML. Issue #776791. Closes: #849991.

doxygen (1.8.13-3) unstable; urgency=medium

  * Build-depend on zlib1g-dev.

doxygen (1.8.13-2) unstable; urgency=medium

  * Build using clang on armel, mips64el, sparc64.

doxygen (1.8.13-1) experimental; urgency=medium

  * doxygen 1.8.13 release.
  * Use json-c instead of the osmium source for the autopkg test.
  * Configure with build_search again. Closes: #822204.

doxygen (1.8.12-1) unstable; urgency=medium

  * doxygen 1.8.12 release.
  * Stop using llvm/clang on armel and kfreebsd-*.

doxygen (1.8.11-3) unstable; urgency=medium

  * Applied upstream commit 9a2c7bbfb0c53b4532db7280e6804c7ce76d70a3:
    Use UTC timezone when displaying QDateTimes parsed from SOURCE_DATE_EPOCH
    Closes: #792201

doxygen (1.8.11-2) unstable; urgency=medium

  * Fix python version number extraction for python release candidate builds.

doxygen (1.8.11-1) unstable; urgency=medium

  * Upload to unstable.

doxygen (1.8.11-1~exp2) experimental; urgency=medium

  * Revert an upstream change which lets to file names with whitespace,
    exceeding 256 characters.
    See https://bugzilla.gnome.org/show_bug.cgi?id=759241.
  * Fix build with unreleased python versions.

doxygen (1.8.11-1~exp1) experimental; urgency=medium

  * doxygen 1.8.11 release.
  * Build using cmake, Qt5.
  * Fix some lintian warnings.

doxygen (1.8.9.1-6) unstable; urgency=medium

  * Only depend on unversioned libclang. (Closes: #803646)
  * Add build profile annotations to Build-Depends. (Closes: #738263)
  * Build doc/language.doc from source. (Closes: #794758)
  * Clean more generated files. Fix twice-FTBFS. (Closes: #794745)

doxygen (1.8.9.1-5) unstable; urgency=medium

  * Don't configure --with-sqlite3, still experimental according to upstream.
    Closes: #758975.

doxygen (1.8.9.1-4) unstable; urgency=high

  * Rebuild for GCC 5 / xapian-core.

doxygen (1.8.9.1-3) unstable; urgency=medium

  * Upload to unstable.
  * Disable HTML timestamps in Doxygen's own documentation.
    (no-timestamps.diff).
  * Default to not generating HTML timestamps: Upstream commit
    3f2e8a3067712b025623e4420e6eb161febfd42b default-no-timestamps.diff.
    (Closes: #780617)

doxygen (1.8.9.1-2) experimental; urgency=medium

  * Removed \backmatter in case of COMPACT_LATEX. Issue #742427.

doxygen (1.8.9.1-1) experimental; urgency=medium

  * doxygen 1.8.9.1 release.

debian/jessie 2018-03-14 19:26:24 UTC 2018-03-14
Import Debian changes 1.8.8-5

Author: Helmut Grohne
Author Date: 2014-11-02 14:07:52 UTC

Import Debian changes 1.8.8-5

doxygen (1.8.8-5) unstable; urgency=medium

  * Cherry pick c83db38ea83499be19d9ff242bfa22ae534ee80c. (Closes: #762272)
  * Fix FTBFS: Update syntax of Build-Profiles header. (Closes: #767658)

doxygen (1.8.8-4) unstable; urgency=medium

  * Cherry pick 6d4044ad43ae1424a256eb1c26992301e7c64f4a. (Closes: #760700)
  * Declare compliance with policy 3.9.6: No changes needed.

doxygen (1.8.8-3) unstable; urgency=medium

  * Fix sqlite3 configuration.

doxygen (1.8.8-2) unstable; urgency=medium

  * Build-depend on libxapian-dev.

doxygen (1.8.8-1) unstable; urgency=medium

  * doxygen 1.8.8 release.
  * Build-depend on python3.
  * Build using libclang where available.
  * Really enable sqlite support.

doxygen (1.8.7-3) unstable; urgency=medium

  * doxygen-latex: Depend on cm-super-minimal.

doxygen (1.8.7-2) unstable; urgency=medium

  * Reorder latex packages to avoid bogus syntax check. Thanks to Mattias
    Ellert for tracking down the issue and providing a patch. (Closes:
    #750536).
  * Indent debian/doxygen.NEWS for valid formatting.
  * Bump copyright years.

doxygen (1.8.7-1) unstable; urgency=medium

  * doxygen 1.8.7 release.
    + Standard build regenerates *_js.h now. Update README.jquery.
    + Add doxygen.NEWS for GENERATE_HTML default change.
    + Refresh patches. dot-config.diff completely rewritten against
      config.xml.
  * Uglify javascript during build. Therefore B-D: yui-compressor.
  * Also remove winbuild to avoid accidentally using it.
  * Add half a stage1 build-profile to drop libqt4-dev. Not annotating the
    dependency because #744246. Thanks to Daniel Schepler and Wookey.
    (Addresses: #738263)

doxygen (1.8.6-2) unstable; urgency=medium

  * Fix autopkgtest.
    + Missing dependency on dpkg-dev for apt-get source.
    + apt-get source prints to stderr.

doxygen (1.8.6-1) unstable; urgency=low

  * doxygen 1.8.6 release.

doxygen (1.8.5-1) unstable; urgency=low

  * doxygen 1.8.5 release.
    + Refresh patches. dot-config.diff had a failed hunk.
    + README got renamed to README.md.
  * Add debug package doxygen-dbg.
  * Demote recommends doxygen-latex from doxygen to suggests. (Closes:
    #720493)
  * LDFLAGS are called QMAKE_LFLAGS_RELEASE (not ...LDFLAGS...),
    this should fix the build log checks and hardening.
  * Install upstream changelog. (Closes: #569504)
  * Shrink doxygen-doc binary package using hardlinks (rdfind).
    + Add lintian-override for package-contains-hardlink
  * Rewrite debian/copyright in DEP5 syntax.
  * Bump standards version to 3.9.5: No changes needed.
  * Explain that jquery embedding is going to stay in README.jquery.
    (Closes: #630982)
  * Add an autopkgtest building the documentation of osmium.
    It managed to crash Doxygen earlier, see #657917.

doxygen (1.8.4-1) unstable; urgency=low

  * doxygen 1.8.4 release
    + Upstream now ships jquery sources. (Closes: #625956)
    + Add libsqlite3-dev to Build-Depends.
    + Refresh patches. All hunks succeeded.
    + Upstream changelog included in source package for #569504.
  * Acknowledge upload version 1.8.1.2-2.
    + Added myself as uploader.
  * Enable doxygen-gui on hurd. (Closes: #700631)
  * Clean before build, to ensure that no prebuilt files are used.
  * Use packaged tmake.
    + Add tmake Build-Depends, patch configure to use packaged tmake.
    + Add a tmake wrapper that forces our CFLAGS into tmake. This fixes
      the tmake part of #596636.
  * Add a qmake wrapper that forces our... you know the story. (Closes:
    #596636)
  * Bump standards version to 3.9.4: No changes needed.
  * Add an initial dh_doxygen helper that cleans generated documentation for
    inclusion in binary packages. This is a small aspect of #630982.
  * Added Homepage to control.
  * Removed duplicate dependency latex-xcolor from doxygen-latex.

doxygen (1.8.3.1-1) experimental; urgency=low

  * doxygen 1.8.3.1 release.

doxygen (1.8.2-1) experimental; urgency=low

  * doxygen 1.8.2 release.

debian/wheezy 2018-03-14 19:22:31 UTC 2018-03-14
Import Debian changes 1.8.1.2-2

Author: Helmut Grohne
Author Date: 2013-02-28 09:09:45 UTC

Import Debian changes 1.8.1.2-2

doxygen (1.8.1.2-2) unstable; urgency=low

  [ Mònica Ramírez Arceda ]
  * Non-maintainer upload.
  * Include jquery-1.7.1.js source in debian/jquery and update its license.
    This file has the source code for src/jquery_p[123].js.
    Closes: #625956.
  * Include jquery.scrollTo-1.4.2.js in debian/jquery and add its license.
    This file has the source code for src/jquery_fx.js.
  * Include jquery-ui*.js and jquery.ba-hashchange.js in debian/jquery and
    add their licenses. These files have the source code for src/jquery_ui.js.

  [ Helmut Grohne ]
  * Added myself as uploader.

doxygen (1.8.1.2-1) unstable; urgency=low

  * doxygen 1.8.1.2 (bug fix) release.
    - Changes:
      + doxygen now strips the leading indentation shared by the lines in a
        @code..@endcode block.
      + id 678218: Changed title of the SVG graphs from 'G' to the root node
        of the graph.
    - New features:
      + Added button in the navigation tree to allow enabling/disabling
        syncing the navigation tree with the content.
      + Extended the number of HTML entities with Greek letters and other
        symbols (thanks to Charles Karney for the patch).
      + id 663645: Added support for C++11 strongly typed enums
        (enum class E { ... }).
    - Bug fixes:
      + id 590518: Added missing class member initialization to a class
        in doxmlparser and made the library compile again.
      + id 667678: Added support for Obj-C property attribute "unsafe_retained".
      + id 674842,676984: Unmatched quote in a comment prevented alias
        expansion.
      + id 676019: Fixed another case where local include path did not appear
        correctly in the class documentation.
      + id 676966: Fortran: Some keyword were not colored in the source view.
      + id 676981: Fortran: Argument type was wrong type of in case of
        out of place !> comment.
      + id 677935: Included patch to fix problem compiling for x86 release
        on Windows.
      + id 677992: Section without title could result in an invalid
        Qt Help index.
      + id 678022: Anonymous enum could result in an invalid Qt Help index.
      + id 678102: Superfluous trailing comma in javascript prevented
        navigation tree to load in IE7.
      + id 678177: a + at the start of a line inside a <pre> block, triggered
        the start of a list. Also -- and --- where not kept untouched inside
        a <pre> block.
      + id 678180: ndash (--) appearing in a brief description could lead to
        invalid SVG images.
      + id 678288: -- and --- inside a Markdown code block were not handled
        properly.
      + id 679331,675766: In body documentation with a different indentation
        then the main documentation was not rendered correctly (MARKDOWN=YES).
      + id 679436: Using an escaped pipe symbol in a Markdown table did not
        get unescaped in the output.
      + id 679533: Code fragments did not appear properly in the doxygen manual.
      + id 679615: Added missing delete call in a piece of debugging code.
      + id 679626: Fixed some navigation issues in the manual
      + Not all inherited members appeared in the "Additional inherited members"
        list.
      + Link to call after "Inherited members" was not correct when
        CREATE_SUBDIRS was enabled.
      + New VHDL diagram was not generated if the path contained spaces.
      + Fixed a couple of problems handling Objective-C categories.
  * Fix segfault building the leechcraft docs (Thibaut Paumard).
    Closes: #676423.
  * Make doxygen Multi-Arch: foreign. Closes: #658984.

doxygen (1.8.1.1-1) unstable; urgency=low

  * doxygen 1.8.1.1 (bug fix) release.

doxygen (1.8.1-1) unstable; urgency=low

  * doxygen 1.8.1 release.
  * Build-depend on latex-xcolor.
  * doxygen-latex: Depend on latex-xcolor.

doxygen (1.7.6.1-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * Add depends on ghostscript and texlive-fonts-recommended to doxygen-latex.
    Closes: #654587, #637661.

doxygen (1.7.6.1-2) unstable; urgency=low

  * Don't apply doxygen_direct_dot_run.diff. Closes: #618125.

doxygen (1.7.6.1-1) unstable; urgency=low

  * New upstream version.

doxygen (1.7.6-1) unstable; urgency=low

  * New upstream version.

doxygen (1.7.5.1-1) unstable; urgency=low

  * New upstream version.

doxygen (1.7.4-4) unstable; urgency=low

  * doxygen-latex: Depend on texlive-font-utils. Closes: #636315.

doxygen (1.7.4-3) unstable; urgency=low

  * doxygen: Drop the dependency on doxygen-latex. Closes: #616351, #619902.

doxygen (1.7.4-2) unstable; urgency=low

  * Re-enable the doxygen_direct_dot_run.diff patch, still issues on
    armel. Closes: #627494.
  * Only include jquery.js in generated output when needed (Chris Butler).
    Closes: #622147.
  * Include jquery.js source in debian/; add jquery.js license.
    Closes: #625956.

doxygen (1.7.4-1) unstable; urgency=low

  * New upstream version.

doxygen (1.7.3-6) unstable; urgency=low

  * Update doxygen_direct_dot_run.diff (Mattias Ellert). Closes: #618433.
  * Disable the doxygen_direct_dot_run.diff patch, race conditions should
    be fixed in 1.7.x releases.

doxygen (1.7.3-5) unstable; urgency=low

  * Let doxygen depend on doxygen-latex for some time, until packages
    explicitly build-depend on doxygen-latex.

doxygen (1.7.3-4) experimental; urgency=low

  * Build a dependency package adding dependencies for all LaTeX packages
    required to build documents using the default stylesheet.

doxygen (1.7.3-3) experimental; urgency=low

  * Recommend latex-xcolor and texlive-latex-base, unconditionally
    used for documentation generated in LaTeX.
  * Build with -g. Closes: #605586.
  * COMPACT_LATEX is fixed in 1.7.3. Closes: #606276.

doxygen (1.7.3-2) experimental; urgency=low

  * Fix build failure with qmake-qt3. Closes: #602814.

doxygen (1.7.3-1) experimental; urgency=low

  * New upstream version.

doxygen (1.7.2-1) experimental; urgency=low

  * New upstream version.

doxygen (1.7.1-2) unstable; urgency=low

  * Don't use threads for the `dot' runs (Petr Salinger).
    Closes: #591648, #593317.

doxygen (1.7.1-1) unstable; urgency=low

  * New upstream version. Closes: #588702.

doxygen (1.6.3-1) unstable; urgency=low

  * New upstream version.

doxygen (1.6.2+20100208-0.1) unstable; urgency=low

  * Non-maintainer upload.
  * Update to a svn snapshot to fix release critical bugs.
    Closes: #564243, #564338, #564703.

doxygen (1.6.2-1) unstable; urgency=low

  * New upstream version.
  * Build-depend-indep on texlive-font-utils. Closes: #562335.
  * Build again doxywizrd. Closes: #556263.

doxygen (1.6.1-1) unstable; urgency=low

  * New upstream version.

doxygen (1.6.0-1) unstable; urgency=low

  * New upstream version.
  * Upstream did remove the support for png images, remove the corresponding
    debian system-libpng patch.
  * Don't build doxywizard-gui, currently fails to build.

doxygen (1.5.9-1) unstable; urgency=low

  * New upstream version.
  * Let doxygen recommend texlive-extra-utils for epstopdf. Closes: #488833.
  * Don't apply the gd-renderer patch. Closes: #477364.
  * Accept additional values known by `dot -T' for DOT_IMAGE_FORMAT.
  * Set the default for DOT_MULTI_TARGET to true.

doxygen (1.5.8-1.1) unstable; urgency=low

  * Non-maintainer upload to fix Segmentation Fault.
  * Applied patch from Gentoo to fix a Segmentation Fault as
    debian/patches/path-prefix.dpatch. Thanks to Martin von Gagern for
    the patch and Leandro Lucarella for the pointer. Closes: #518031

doxygen (1.5.8-1) unstable; urgency=low

  * New upstream version.
  * Build-depend on libqt4-dev.

doxygen (1.5.7.1-0ubuntu2) jaunty; urgency=low

  * Build-depend on texlive-latex-recommended.

doxygen (1.5.7.1-0ubuntu1) jaunty; urgency=low

  * New upstream version.
  * Adjust build dependencies.

doxygen (1.5.6-2) unstable; urgency=low

  * Reenable the gd-renderer patch.

doxygen (1.5.6-1) unstable; urgency=low

  * New upstream version.

doxygen (1.5.5-2) unstable; urgency=low

  * Merge from Ubuntu:
    - Fix crash with empty column cells. LP: #129040.

doxygen (1.5.5-1) unstable; urgency=low

  * New upstream version.
    - Allow documentation of template parameters. Closes: #227864.

doxygen (1.5.4-1) unstable; urgency=low

  * New upstream version.
  * Update conflict with older graphviz package (closes: #450938).

doxygen (1.5.3-20071020-1) unstable; urgency=low

  * New upstream version from CVS.
  * Avoid large images by using the gd renderer (Cyril Brulebois). Closes: #444147.

doxygen (1.5.3-1) unstable; urgency=low

  * New upstream version. Fixes:
    - Doxygen gets confused by template typedefs that contain parenthesis.
      Closes: #267406.

doxygen (1.5.2-20070723-1) unstable; urgency=low

  * New upstream version from CVS.
    - Fix segfault for unknown or obsoleted tags in the config file.
      Closes: #428972.
    - debian/patches/latexgen.dpatch: Remove, applied upstream.
    - debian/patches/install-docs.dpatch: Remove, obsolete.
  * Adjust build dependencies for the Hurd. Closes: #434432.

doxygen (1.5.2-4) unstable; urgency=low

  * Build-depend on texlive-fonts-recommended. Closes: #425886.

doxygen (1.5.2-3) unstable; urgency=low

  * Build-depend on texlive-generic-recommended as well.

doxygen (1.5.2-2) unstable; urgency=low

  * Build-depend on texlive-latex-recommended, instead of texlive-latex-base.
    Closes: #425087.

doxygen (1.5.2-1) unstable; urgency=low

  * New upstream version. Closes: #418025.
  * Add build dependency on texlive-extra-utils. Closes: #420331.

doxygen (1.5.1-1) unstable; urgency=low

  * New upstream version.

doxygen (1.4.7-1) unstable; urgency=low

  * New upstream version.

doxygen (1.4.6-2.3) unstable; urgency=high

  * Non-maintainer upload. (Yes, the third in a row. I hope to get it right
    this time.)
  * Do the buffer overflow fixes in a file in debian/patches/ instead of
    directly in the Debian diff.

doxygen (1.4.6-2.2) unstable; urgency=low

  * Non-maintainer upload.
  * Use $(shell pwd) instead of $(PWD) in debian/rules, which fixes FTBFS on
    builds that use (newer versions of) sudo.

doxygen (1.4.6-2.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix buffer overflows in QCString::sprintf() and SCString::sprintf().
    (Closes: #357722)

doxygen (1.4.6-2) unstable; urgency=low

  * Fix build error with g++-4.1 (closes: #358208).
  * Adjust package description (closes: #347194).

doxygen (1.4.6-1) unstable; urgency=low

  * New upstream version.
  * Fix generation of (La)TeX files (closes: #344468).

doxygen (1.4.5-1.1) unstable; urgency=low

  * Remove unused code (QChar::row, QChar::col) that does not build with
    gcc 4.0 (closes: #338099).

doxygen (1.4.5-1) unstable; urgency=low

  * New upstream version.

doxygen (1.4.4-1) unstable; urgency=low

  * New upstream version.
    - Fix malformed XML output (closes: #315205).
  * Fix build dependency for the hurd (closes: #312823).
  * Tighten build dependency on libqt3-mt-dev.

doxygen (1.4.4-0ubuntu1) breezy; urgency=low

  * New upstream version.

doxygen (1.4.3-20050530-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Do not Build-Depend on libqt3-mt-dev on the Hurd (closes #312823).

doxygen (1.4.3-20050530-1) unstable; urgency=low

  * New upstream version.

doxygen (1.4.2-4) unstable; urgency=medium

  * src/translator_ca.h: Revert accidental conversion to unicode.
    Patch by Maximiliano Pin (closes: #309913).

doxygen (1.4.2-3) unstable; urgency=high

  * Warn, if empty prototype is found, instead of segfaulting.
    Closes: #307447.
  * src/docparser.cpp: Fix another segfault (backport from CVS).

doxygen (1.4.2-2) unstable; urgency=medium

  * Do not build doxygen-gui on the Hurd (closes: #301954).
  * Enhance doxygen manpage (closes: #285132).

doxygen (1.4.2-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix a null dereference segfault in the lexer when comments contain a
    syntax error. Closes: #304659

doxygen (1.4.2-1) unstable; urgency=low

  * New upstream version.

doxygen (1.4.1-1) unstable; urgency=low

  * New upstream version.
  * Add menu entry for doxywizard (closes: #289726).

doxygen (1.4.0-1) unstable; urgency=low

  * New upstream version.

doxygen (1.3.9.1-1) unstable; urgency=medium

  * New upstream version.
    - Fixed problem matching array parameters that include template parameters
      as the array size (closes: #275299).
    - Fixed parsing problem in the preprocessor when an expression contained
      the division operator (closes: #274698).

doxygen (1.3.9-1) unstable; urgency=medium

  * New upstream release.

doxygen (1.3.8-20040928-1) unstable; urgency=low

  * New upstream version (CVS tarball).
    - Fix segfault while building gconfmm2.0 docs (closes: #274318).

doxygen (1.3.8-20040913-1) unstable; urgency=low

  * New upstream version (CVS tarball).
  * Bugs fixed upstream in this or earlier releases:
    - Fix FTBFS on GNU/k*BSD (closes: #263542).
    - Problems with macrocreated functions (closes: #187625).
    - Use \renewcommand{\footrulewidth}{...} instead of
      \setlength{\footrulewidth}{...}. Closes: #194211.
    - Do not capitalize identifiers at the start of a sentence.
      Closes: #238275.
    - Interpretation of c++ 'using' keyword (closes: #244213).
    - Mishandling of c++ 'friend' declarations (closes: #244221).
    - Fix warning related to * vs. [] (closes: #147357).
  * Add conflict with older graphviz package (closes: #266309).
  * Don't use libpng provided by package (closes: #269231).
  * Add doxywizard(1) manpage (closes: #234022).

doxygen (1.3.8-1) unstable; urgency=low

  * New maintainer.

doxygen (1.3.8-0.1) unstable; urgency=low

  * NMU.
  * New upstream version.

doxygen (1.3.7-0.2) unstable; urgency=low

  * NMU.
  * Apply Goswin's patch, build depend on python (closes: #241690).

doxygen (1.3.7-0.1.0.1.pure64) unstable; urgency=low

  * Temporarily copy src and VERSION into build tree for translate.py

doxygen (1.3.7-0.1) unstable; urgency=low

  * NMU
  * New upstream version.

doxygen (1.3.6.20040222-0.1) unstable; urgency=medium

  * NMU
  * New upstream version (CVS tarball). Closes: #234348.
  * Fixing termination problems in 1.3.5 and 1.3.6 (closes: #232598).

doxygen (1.3.5-0.1) unstable; urgency=low

  * NMU
  * New upstream version.

doxygen (1.3.4-0.1) unstable; urgency=low

  * NMU
  * New upstream release. (Closes: #203198)
  * Verified that this version no longer segfaults on the yehia docs.
    (Closes: #198984)
  * [debian/doxytag.1] Added a NAME section so it can be parsed for whatis.
    (Closes: #210620)

doxygen (1.3.2-1.1) unstable; urgency=low

  * NMU
  * [debian/control] Dropped build dependency on obsolete
    libqt3-plugins-headers and versioned the libqt3-mt-dev build dependency so
    as to be sure it pulls in a libqt3-headers which replaces
    libqt3-plugins-headers. Fixes FTBFS. (Closes: #213858)

doxygen (1.3.2-1) unstable; urgency=low

  * New upstream release

doxygen (1.3.1-1) unstable; urgency=low

  * New upstream release (Closes: Bug#188852, Bug#196050)
  * debian/control: doxygen-doc relationship should be "suggests"
    (Closes: Bug#196437)
  * debian/control: Build-Dep on flex-old

doxygen (1.3-rc3-1) unstable; urgency=low

  * New upstream release
  * built with g++-3.2
  * debian/control: build depend on libqt3-mt-dev (Closes: Bug#180599)

doxygen (1.3-rc2-1) unstable; urgency=low

  * New upstream release (Closes: Bug#173643)
  * debian/control: build depend on xlibs-dev (Closes: Bug#170119)
  * debian/control: build depend on libqt3-dev
  * debian/doxygen.1 debian/doxytag.1: improved manpages (Closes: Bug#170716)

doxygen (1.3-rc1-1) unstable; urgency=low

  * New upstream release (Closes: Bug#169676)
    - contains fix for unconditional ouptut of tags even
      when in conditional blocks (Closes: Bug#167515)
    - contains fix for RTF image path bug (Closes: Bug#167722)

doxygen (1.2.18-2) unstable; urgency=low

  * fixed signed/unsigned compiler warning (Closes: Bug#161990)

doxygen (1.2.18-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.16-3) unstable; urgency=low

  * doxygen-doc provides doxygen-docs (Closes: Bug#149804)

doxygen (1.2.16-2) unstable; urgency=low

  * doxygen-doc conflicts/replaces doxygen-docs (Closes: Bug#149154)

doxygen (1.2.16-1) unstable; urgency=low

  * New upstream release
  * debian/control: renamed binary package doxygen-docs to doxygen-doc
    to better conform with standard practice (Closes: #147629)

doxygen (1.2.15-2) unstable; urgency=low

  * debian/watch: added uscan version 2 compliant watch file

doxygen (1.2.15-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.14-3) unstable; urgency=low

  * debian/control: added Conflicts against earlier version (Closes: #135670)

doxygen (1.2.14-2) unstable; urgency=low

  * Fixed Section for doxygen-docs: from devel to docs

doxygen (1.2.14-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.13.1-1) unstable; urgency=low

  * New upstream release
  * new package (doxygen-gui) for libqt-dependent binaries (Closes: Bug#130369)
  * new package (doxygen-docs) for documentation (Closes: Bug#131229)

doxygen (1.2.12-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.11.1-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.9.1-1) unstable; urgency=low

  * New upstream release (Closes: #101374)

doxygen (1.2.8.1-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.8-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.7-1) unstable; urgency=low

  * New upstream release (Closes: #96924)

doxygen (1.2.6-3) unstable; urgency=low

  * added doc-base registration; thanks to Steve M. Robbins (Closes: #92605)

doxygen (1.2.6-2) unstable; urgency=low

  * enable xml support
  * fixed a typo that put docs into /usr/share/doc/doxygeen (Closes: #90374)

doxygen (1.2.6-1) unstable; urgency=low

  * New upstream release
  * Build-depends on libqt-dev rather than libqt2.2-dev (Closes: #88576)
  * QTDIR is set to /usr/share/qt from /usr/lib/qt2 (Closes: #88578,#90070)
  * above two changes fix "fails to build from source" (Closes: #88204)

doxygen (1.2.5-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.4-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.3-1) unstable; urgency=low

  * New upstream release

doxygen (1.2.2-2) unstable; urgency=low

  * Changed maintainer field to Luca Filipozzi <lfilipoz@debian.org>

doxygen (1.2.2-1) unstable; urgency=low

  * New upstream release... bug fixes and some additional features
    (see http://www.stack.nl/~dimitri/doxygen/changelog.html for info)

doxygen (1.2.1-1) unstable; urgency=low

  * New upstream release
  * Compiled against libqt2.2 (closes: #71813)
  * debian/control: removed the libqt2 dependency since it is added
    automatically by ${shlibs:Depends}
  * debian/control: added Build-Depends and upgraded Standards-Version
  * debian/control: added Suggests for graphviz for the graph functions
    (note: graphviz is non-free, so it is listed as a suggestion only)
  * debian/rules: added --with-doxywizard and --with-configgen so that
    the doxy wizard and the config generator are included in the package
  * debian/rules: added --dot dot to specify the name of the "dot" tool
    so that it will be found if installed at runtime rather than needing
    it to be installed at build time (the configure script attempts to
    find "dot" but the build does not actually need it)
  * Note that the upstream package no longer contains the LaTeX source
    for the docs. Instead, PDF and PS versions of the docs are provided.

  + many thanks to Torsten Landschoff for his help... all the above changes
    were suggested by him

doxygen (1.0.0-2) unstable; urgency=low

  * Compiled against libqt2.

doxygen (1.0.0-1) unstable; urgency=low

  * Initial Release.

19 of 9 results

Other repositories

Name Last Modified
lp:doxygen-sid 2021-03-22
11 of 1 result
You can't create new repositories for doxygen-sid.